Retro: ASUS mimic CX200 JTAG hacking 

Back in my university years I have had some issues with an Asus MIMIC CX200 camera. One of them got broken after a firmware upgrade so I have decided to fix it with JTAG. I have successfully got to UrJTAG to read the IDCODE of the S3C4510B, but I was unable to detect the flash. Now I know that I have had to tweak the bus driver and reveng the board a bit.

Here are some pics (shot with my Nokia 6230 in VGA res) about the trick:


Thin albanian wires were soldered directly to the pins.


Live together cry together series 100 Ohm level shifter JTAG adapter to LPT port.


I have designed an addon board to expose the CPU's intresting interfaces (2 serial, USB, JTAG)



It is fun to look back to those pictures from now. After 5 years we got to a state when it is easier and cheaper to buy a Rpi to solve the same problem rather than fixing that board...
[ hozzászólás ] ( 3 megtekintés ) [ 0 trackbackek ] permalink kapcsolódó link ( 3.1 / 64 )
VPNC connection fails after upgrading to Ubuntu 13.10 (saucy) 

My corporate VPN connection got broken after I have updated my desktop to Kubuntu 13.10.

First I have started the Networkmanager's vpnc service in debug mode:

sudo /usr/lib/NetworkManager/nm-vpnc-service --debug


When connecting to the VPN the following message had been shown at the end of the log:


S5.5 do xauth reply
[2014-01-12 09:54:00]
/usr/sbin/vpnc: server requested domain, but none set (use "Domain ..." in config or --domain


The KDE networkmanager applet do not provide input for the domain, so it had to be workarounded:

Edit the /etc/NetworkManager/system-connections/[VPN connection name]

And insert the following line under the [vpn] section:

Domain=your_domain

[ hozzászólás ] ( 1 megtekintés ) [ 0 trackbackek ] permalink ( 3.1 / 98 )
Geovision GV-800(S) under Linux 

One of my friends asked me to get working a Geovision GV-800(S) DVR card with zoneminder.
According to the google results several people succeed with this subject. For e.g.:
http://siripong-computer-tips.blogspot. ... linux.html

I have installed a n Ubuntu 12.04 server, and the necessary packages. This distribution shuiips with a relatively new kernel (3.5.0) which means that the necessary bttv modules were included fine. The device had shown up fine: I had 4 v4l2 devices with 4 channels per each (Composite0-4). I have added these channels as sources to the Zoneminder but I have not been able to get image from them. After several trials I have installed XFCE and XAWTV. I have not been able to get image with that tool too, and at the channel changes I got I/O errors and the software claimed about invalid framebuffer address on startup.

As final trying I have installed a Windows XP to the box, and installed the Geovision software. The device had shown up in the device manager fine, but there were a yellow exclamation points next to the devices with Device cannot started message. I have seen that card working in different computer.

As a last trial we have decided to try to upgrade the BIOS, and that solved the problem.
[ hozzászólás ] ( 3 megtekintés ) [ 0 trackbackek ] permalink ( 3 / 103 )
The macaddress in the /etc/udev/rules.d/70-persistent-net.rules is case sensitive 

Really!
It must have the letters in lowercase.
[ hozzászólás ] [ 0 trackbackek ] permalink ( 3.1 / 135 )
Android Studio - Waiting for device @ Ubuntu 

I have started to develop to Android on Ubuntu.
At my first attempt when I have tried run my app on the device, the device shown up as ?????????? in the Android Studio Choose Device dialog.

The problem root cause is the access rights around the device descriptors.

The ADB daemon is started with the user's permissions, so I had created an udev rule to get access to the device:

mm@lapos:/opt/android-studio/bin$ cat /etc/udev/rules.d/51-android.rules
# Concorde tablet (18d1:0003)
ATTR{idVendor}=="18d1",ATTR{idProduct}=="0003" MODE="0666"

[ hozzászólás ] [ 0 trackbackek ] permalink ( 3.1 / 117 )

| 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | Következő> >>

 
számláló