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1-1. gyakorlat: Frekvencia-átvitel vizsgálata (Frequency 
Response) VI 

 
Tárgy: VI-k megnyitása és futtatása. 

 

1. Labview indítása:  

A LabVIEW elindításához kattintson a Start»Programs»National 

Instruments»LabVIEW 7.1»LabVIEW iconra, vagy az Asztalon 

található LabVIEW iconra. Erre megjelenik a LabVIEW „dialog box”. 

 
2. Kattintson Help gomb jobb oldalán található kis háromszögre .  A help 

listázza az elérhető LabVIEW segítség témaköröket. 

 

3. Kattintson Find Examples gombra. Megkapjuk az elérhető LabVIEW 

példa témaköröket könyvtárakba rendezve. 
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4. Kattintson az „Industry Applications ,majd a Instrument Input and 

Output” menüpontra és utána „Frequency Response”-ra. Megjelenik a 

„Frequency Response VI” előlapja (front panel). 

Megjegyzés: A VI megnyitható az Open VI gombra való kattintással, vagy a VI 

megkeresésével a  
labview 7.1\examples\apps\freqresp.llb\Frequency 

Response.vi útvonalon. 

 

Előlap (Front Panel) 
 

5.  A VI elindításához kattintson a baloldalon látható Run gombra az 

eszköztárban. 

Ez a VI mérőjelet küld az éppen tesztelt egységnek (Unit Under Test 

(UUT)) és méri az egység erre adott válaszát. A frekvencia függvényében 

kapott válasz látható az alábbi illusztráción. 

 

 
 

 

6. A balra látható „Operating tool", az eszközkezelő, és az Amplitude feliratú 

gomb segítségével változtassa meg az amplitúdót. Kattintson a jelzésre 

forgatógombon és vonszolja a kívánt pozícióba, mintha egy létező 

forgatógomb lenne. A digitális kijelzésen található nyilak segítségével az 

értékek digitálisan változtathatók. A digitális kijelzőre helyezve a kurzort a 

számértékek közvetlenül is változtathatók.  
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Ha egy számot írunk be a digitális kijelzőre, a balra látható Enter gomb 

jelenik meg az eszköz sávon. A beirt szám, csak akkor továbbítódik a VI-

hez, ha rákattintunk erre a gombra, vagy a billentyűzet ENTER gombjára.  

 

 

7. Indítsa újra aVI-t a Run gombbal. Változtassa a többi szabályozó elemet és 

figyelje meg azok hatását  

 

Blokk Diagram 
 

8. Válassza ki Window»Show Diagram menüpontot, vagy nyomja meg a 

<Ctrl-E> gombokat a „Frequency Response” VI blokk diagramjának 

megtekintéséhez. 

 

 

 
 

 

 

 

Ez a blokkdiagram további blokkdiagram elemeket, subVI-ket, 

függvényeket, struktúrát tartalmaz. 

9. Az „Operating tool”-al kattintson kettőt az alábbi DMM ikonra.  

 

 
 

Ez az ikon egy subVI, amely a Fluke 8840A digitális multimétert 

szimulálja. A kettős kattintás után a subVI előlapja jelenik meg.  
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Az előlapot úgy tervezték, hogy hasonlítson egy valódi multiméter 

felületére. 

 

Ez az, amiért egy LabVIEW programot „virtual instrument”-nek, virtuális 

mérőeszköznek  neveznek. A LabVIEW alkalmazások moduláris 

felépítésűek, ezért ha  változtatás  szükséges, azt csak a program egy 

részében kell elvégezni. A moduláris részeket más alkalmazásokban is fel 

lehet használni.  

Például a fenti subVI szimulálja egy Fluke multiméter működését, de 

átalakítható egy berendezés vezérlésére is.  

10. Válassza a File»Close menüpontot a Demo Fluke 8840AVI előlapjának 

bezárására. 

11. Ne zárja be a Frequency Response VI-t, mivel szükséges lesz a következő 

gyakorlathoz.  
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1-1-2. gyakorlat: Jelgenerálás egy LabVIEW VI segitségével 

(Acquiring a Signal) VI 
 
Tárgy: Ismerkedés a LabVIEW programotási környezetével. Jelgenerálás és 
megjelenítés.  

A következő feladat során egy jelgenerátor és megjelenítő VI- kell elkészíteni, 

felhasználva a LabVIEW-ben rendelkezésre álló mintákat (templates). Ezen minta file 

-ok segítségével egyszerűbb a LabVIEW megismerése. 

12. Labview indítása:  

A LabVIEW elindításához kattintson a Start»Programs»National 

Instruments»LabVIEW 7.1»LabVIEW ikonra, vagy az Asztalon 

található LabVIEW ikonra. Erre megjelenik a LabVIEW „dialog box”. 

13. A megjelent LabVIEW dialog box-ban, amely következő ábrán is látható, 

kattintson a New gombra. Erre megjelenik az új VI-k létrehozására 

alkalmas párbeszéd 

ablak.

 

14. Válassza a VI from Template» Tutorial (Getting Started)» Generate 

and Display mintát. A mintafájl által létrehozott VI jelet generál és 

megjeleníti azt. A megjelenített mintaprogram előlapja és kapcsolása a 

Block diagram preview és Front panel preview ablakaiban. A következő 

ábra mutatja a New párbeszéd ablakot és a létrehozott minta a VI-t. 

15. Kattintson az OK gombra a mintaprogram megnyitásához. Kettős 

kattintással a Create new lista egyik menüpontjára azonnal megnyitja a 

kiválasztott mintafájt. 
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16. Vizsgálja meg az előlapot (Front Panel). A felhasználói felület (vagy 

előlap) szürke háttérrel jelenik meg és beállító elemeket, valamint 

kijelzőket tartalmaz. Az előlap címsávja tartalmazza az ablak nevét 

(Generate and Display VI). 

Megjegyzés: Ha az előlap nem látható, megjeleníthető a Window» Show Front Panel 

menüpontok választásával. 

17. Nézze meg a VI blokkdiagramját. A blokkdiagram fehér háttérrel jelenik 

meg és VI-ket, programstruktúrákat tartalmaz, amelyek kapcsolódnak az 

előlap objektumaihoz. A blokkdiagram címsávja szintén tartalmazza az 

ablak, (program) nevét (Generate and Display VI). 

Megjegyzés: Ha az előlap nem látható, megjeleníthető a Window» Show Block Diagram 

menüpontok választásával. 

18. Indítsa el a VI-t az előlap eszközsávján lévő Run gomb segítségével (lásd a 

baloldalon). Az előlap megjelenítésre szolgáló grafikonján egy szinusz jel 

jelenik meg. 

19. Állítsa meg a VI-t az előlap eszközsávján lévő Stop gomb segítségével 

(lásd a baloldalon).  

 
További beállító elemek adása az előlaphoz. 
 

A beállító elemek az előlapon valódi, fizikai készülékek beállító elemeit szimulálják, 

adatokat adnak a VI blokkdiagramjának. Sok eszköz rendelkezik forgatógombokkal, 

amellyel változtatni lehet a bemenő adatok értékeit. A következő lépések 

végrehajtásával egy forgatógombot adunk az előlaphoz. 
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 Tipp:   A  feladatok végrehajtása közben a hibás lépéseket törölni lehet az  Edit»Undo  

menüpont választásával, vagy <Ctrl-Z> billentyűgomb kombináció leütésével.  

 
1. Ha a Controls paletta nem látható, akkor a Window» Show Controls 

Palette menüpontok választásával megjeleníthető 

2. Mozgassa a kurzort a Controls paletta felett, hogy kiválassza a Numeric 

Controls palettát. Amikor mozgatja a kurzort a Numeric Controls paletta 

felett, a szubpaletta neve megjelenik a paletta felső részen.  

3. Kattintson a Numeric Controls ikonra a Numeric Controls paletta 

megnyitásához. 

4. Válassza a knob control-t a Numeric Controls palettáról és helyezze az 

előlapra, balra a grafikontól. A gyakorlat során a jel amplitúdójának 

változtatására használjuk ezt a beállító gombot. 

5. Válassza a File»Save As menüpontot és mentse el a Signal.vi néven a saját 

VI könyvtárában. 

 

A jel típusának megváltoztatása  
 

A blokkdiagram tartalmaz egy Simulate Signal felirattal jelzett kék ikont. Ez az ikon 

reprezentálja a "Simulate Signal Express VI"-t. Ez a VI alapértelmezésként egy 

szinusz jelet szimulál. A következő lépésekkel a jelet fűrészfog jellé változtatjuk. 

 

1. Jelenítse meg a blokkdiagramot a  Window»Show Block Diagram 

menüpont választásával, vagy a blokkdiagramra kattintással. A balra 

látható "Simulate Signal Express VI" egy olyan blokkdiagram komponens, 

amit be lehet állítani különböző szokásos mérési feladatok megoldására.  A 

VI a beállításnak megfelelő jelet állítja elő. 

2. Kattintson a jobb egérgombbal a "Simulate Signal Express VI"-re és 

válassza a Properies-t a felbukkanó menüből, hogy megjelenítse a 

Configure Simulate Signal párbeszéd ablakot. (Vagy duplakattintás az 

ikonra.) 

3. Válassza a "Sawtooth" fűrészfog alakú jelet a Signal type legördülő 

menüből. A megfelelő jel azonnal láthatóvá válik a jobb oldalon látható 

Result Preview ablakban. A Configure Simulate Signal párbeszéd ablak a 

következő ábrán látható. 

4. Kattintson az OK gombra, hogy a módosítás érvényes legyen. 
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5. A Blokkdiagram való visszatérés után mozgassa a kurzort le- fel a 

"Simulate Signal Express VI" ikon alsó élén. 

6. Amikor egy kettős nyíl jelenik meg, kattintson az ikonra és húzza lefelé az 

ikon alsó határoló élét, amíg az Amplitude bemenet meg jelenik. Jegyezze 

meg az eljárást, hogyan kell további be ill. ki-meneteket megjeleníteni. 

Mivel az Amplitude bemenet megjelent a blokkdiagramon, lehetőség lesz 

a fűrészfogjel amplitúdójának beálltására. Az előző ábrán a Configure 

Simulate Signal párbeszéd ablakban is állítható volt az Amplitude értéke. 

Amikor  a beállítás lehetősége megjelenik a bemenetek között, akkor az 

adott mennyiség mindkét helyen állítható. 

 

A blokkdiagramon megjelenő objektumok összekapcsolása 
(huzalozása).  
 

Ahhoz, hogy az előlapon megjelenő beállító elemmel lehessen változtatni a jel 

amplitúdóját, a két objektumot össze kell kapcsolni. A következő lépések 

végrehajtásával összekötheti a forgatógombot a Simulate Signal Express VI 

Amplitude bemenetével. 

 

1. Mozgassa a kurzort a blokkdiagrammon látható Knob elem csatlakozója 

felett, amig a pozitionáló eszköz meg nem jelenik. Amikor kurzor nyíl 

alakú lesz, akkor válik az objektum mozgatására alkalmassá.  
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A balra látható "Positioning tool" alkalmas még az objektum 

kiválasztására, pozicionálására és méretezésére. 

2. Kattintson a Knob beállító csatlakozóelemére, és utána helyezze a 

Simulate Signal Express VI-től balra. Figyeljen arra, hogy a Knob 

csatlakozóelem ciklus belsejében maradjon. 

A csatlakozók (terminálok) az előlapon látható beállító elemek és 

megjelenítők képei a blokkdiagrammon. Ezek az adatcsere be és kimeneti 

pontjai az előlap és a blokkdiagram közötti adatcserében. 

3. Kattintson a blokkdiagram fehér területére, hogy a Knob csatlakozójának a 

kiválasztását megszüntesse. 

4. Mozgassa a kurzort  a Knob cstlakozója felett, ahogy bal oldalt látható. 

Figyelje meg, hogy a kurzor a huzalozási eszköz képét veszi fel. Ezt az 

eszközt használhatjuk a különböző objektumok összekötésére.  

 

Megjegyzés: A kurzor nem változik a huzalozó eszközzé amíg az objektumot ki nem 

választja (kattintással).  

 

5. Amikor  a kurzor huzalozó eszközképére változik, kattintson a nyilra és 

utána kattintson a Simulate Signal Express VI Amplitude bemenetére, 

ahogy balra látható, hogy a két objektumot összekapcsoljuk. 

Figyelje meg, hogy egy összekötő vezeték jelenik meg a két objektum 

között. Az adatok a vezeték mentén áramlanak a csatlakozótól az Express 

VI-hez. 

6. Válassza a File» Save menüpontot és mentse el a VI-t a saját könyvtárába.  
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1-2. gyakorlat: A LabVIEW Help és Manuals 
 

Tárgy: A LabVIEW help eszközeinek használata az előlap és blokk- 
diagram objektumok tulajdonságainak megismerésére.  

 
Tartalomfüggő Help Ablakok 
 

1. A Frequency Response VI még nyitva van az 1-1 gyakorlatból. Ha nincs nyitva, 

nyissa meg az 1-1 gyakorlatnál leírtak szerint. 

2. Válassza ki a Window»Show Diagram menüpontot, hogy a blokkdiagram legyen 

látható. 

3. Válassza ki a Help»Show Context Help menüpontot vagy nyomja meg a <Ctrl-H> 

gombokat a billentyűzeten, hogy megjelenjen a Context Help (tartalomfüggő 

segítség) ablak. 

4. A Context Help információt ad a különböző objektumokról, amikor a kurzor az 

objektum fölé kerül. 

a. Mozgassa a bal oldalt látható „Positioning tool” eszközt a „Logarithm Base 

10” függvény fölé, amely a „Bode Plot” címke alatt található. A függvény 

angol nyelvű leírása megjelenik a „Context Help” ablakban. 

b. Kattintson a bal oldalt látható „More Help” gombra a Context Help ablakban, 

hogy megnyissa a megfelelő részletes segítséget a LabVIEW Help-ben. A 

Click here for more help-re kattintva a Context Help ablak alján szintén 

megnyitja a megfelelő magyarázatot a LabVIEW Help-ben. 

5. A LabVIEW Help tartalmazza a paletták, menük, eszközök, VI-k, és függvények 

részletes leírását. Próbálja ki a help-et más függvényekre is. 

a. Vigye a bal oldalt mutatott „Wiring tool”-t, Logarithm Base 10 függvény egyik 

csatlakozási pontja fölé. A megfelelő terminal villog a Context Help ablakban, 

amikor az eszköz felette mozog.  

b. Vigye a bal oldalt mutatott „Wiring tool”-t egy vezeték fölé. A Context Help 

ablak megmutatja a vezeték adattípusát. 

 

 

Hogyan oldjuk meg… leírások LabVIEW Help-ben 

A VI és a függvények adatai mellett LabVIEW Help általános leírást és probléma- 

megoldásokat is tartalmaz. Válassza ki Help»VI, Function, and How-To Help menüpontot 

LabVIEW Help elindítására. 

A LabVIEW Help Contents (Tartalom), Index(Tárgymutató), és Search(Keresés)  füleire 

kattintva további ismereteket szerezhet a LabVIEW-ról. 

Nyomtatott és PDF formátumú dokumentumok, teljes 

szövegkeresés 

A LabVIEW széleskörű leírásokat tartalmaz mind új, mind gyakorlott LabVIEW felhasználók 

számára. Az összes LabVIEW kézikönyv és alkalmazási leírás („Application Notes”) PDF 

 

 

 

lvhelp.chm::/LabVIEW_Help.html
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formátumban is elérhető. A PDF file-ok megjelenítéséhez az Adobe Acrobat Reader 4.0 vagy 

annak későbbi változata szükséges. A NI Product Manuals Library címen a dokumentumok 

újabb változatai is elérhetők. 

A LabVIEW Bookshelf bő forrása az összes nyomtatott és PDF dokumentumnak. Keresni 

lehet az összes a LabVIEW kézikönyv és alkalmazási leírás PDF változatában. 

1. A LabVIEW-ban nyissa meg LabVIEW Bookshelf –et a Help»Search the LabVIEW 

Bookshelf menüpontban.  

2. Az Acrobat Reader-ben kattintson a Search-re, hogy megnyissa a keresés 

párbeszédablakát.  

3. Álltsa be a keresés helyének az All PDF documentum in kapcsolót a C:\Program 

Files\National Instruments könyvtárra (használja a Browse for Location menü pontot a 

legördülő menüből és keresse meg a fenti könyvtárat)  

4. Írja be a „temperature”-t mint keresendő szöveget és kattintson a  Search-re.  

5. Megjelenik az adott kifejezést tartalmazó dokumentumok listája. A + jelre kattintással 

a keresés eredménye jeleníthető meg az adott dokumentumban.  

6. Kattintson az egyik listaelemre, és megfelelő dokumentum megnyílik a találat helyén. 

7. Egy speciálisabb keresés végrehajtására kattintson a New Search gombra, hogy új 

keresést indítson. Írja be hogy „single-buffered analog output” és kattintson a Search-

re.  

8. Kattintással megnyithatja a listázott dokumentumok egyikét.  

9. Amikor befejezte, zárja be az Acrobat Reader-t.  

NI fejlesztő övezet (NI Developer Zone) 

Az NI Developer Zone a zone.ni.com címen alapvető forrása mérő és automatizált rendszerek 

felépítésére. A NI Developer Zone-ben találhatók programok, gyakorló feladatok, technikai 

prezentációk az NI termékekről, eszközvezérlőkről, valamint egyéb hasznos segítségek.  

Hasonlítsák össze a keresés eredményét a „single-buffered analog output”-ra a NI Developer 

Zone-ban és az installált dokumentációban. Például olyan információt akarunk megtalálni, 

hogy hogyan kell folytonos hullámalakot generálni külső triggereléssel. 

1. A LabVIEW Help menüpontjában nyissa meg a Web Resources menüpontot. A 

bejelenkező Weblapon válassza a Community-LabVIEW Zone belépési pontot a 

baloldali menüből. Ezután lépjen a Code Sharing lapra. 

2. A keresés ablakba írja be „analog output” és kattintson a GO-ra. Nagyszámú találat 

jelenik meg.  

3. Lépjen vissza a keresés inditó lapjára és válassza ki a Serach opciókból a LabVIEW 

code-t és a Multifuction DAQ eszközt és ismételje meg a keresést. Adja hozzá  az „E-

Series” –t a keresési szöveghez, hogy csak olyan témák érdekesek, amelyek egy 

National Instruments E-Series adatgyűjtő kártyát használ. Jelentősen csökken a 

találatok száma.  

javascript:WWW(WWW_Manuals)
javascript:WWW(WWW_Zone)
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4. A keresés egyik eredménye a Continuously Generate Waveform Analog Output 

Using an External Analog Trigger (E-Series). Kattintson a linkre a dokumentum 

megjelenítésére. A dokumentum általános információkat és utasításokat tartalmaz a 

példa használatára, a használt adatgyűjtő kártya legfontosabb paramétereire és egy 

linket a ZIP formátumú példához. Kattintson a linkre a ZIP formátumú példa 

letöltésére.  

5. Nyissa meg a ZIP file-t. A file tartalmazza a szükséges VIk-et, egy „readme” file-t, a 

VI-k igényeivel.  

6. Amikor befejezte zárja be a Web keresőt, és a ZIP file-t.  

 

További érdekes oldalak, amelyeket érdemes megnézni: 

Academic:  a felső menüsorból. Itt az oktatás támogatására részletes információk érhetők el 

az NI termékekről, különbözö a méréstechnikával kapcsolatos oktatási anyagok, programok 

érhetők el. 

LabVIEW Discussion Forum:  Érdemes megnézni az állás ajánlatokat is. 

Student Corner  

Resources 
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2-1. gyakorlat: Celsiust Fahrenheitre konvertáló VI 
 
Cél: Egy új VI létrehozása 

 

 
A következő lépéseket végrehajtva egy olyan VI-t hozunk létre, amely a 

hőmérséklet Celsiusban megadott értékét Fahrenheitre konvertálja. A 

huzalozási utasításokon a baloldalt láthatóhoz hasonló egér ikon azt jelzi, hogy 

hova kell kattintani az egér mutatóval. A szám a nyílban a kattintások számát 

mutatja. 

 

Előlap (front panel) 
 

 
 

1. Válassza a File» menüből a New pontot egy új előlap létrehozására. Ha már az összes 

VI zárva volt, akkor kattintson a LabVIEW nyitópaneljának New VI gombjára.  

2. (Tetszés szerint) Válassza Window»Tile Left and Right menüpontot, hogy a blokk- 

diagram és az előlap egymás mellett elhelyezve jelenjen meg.  

3. Hozzon létre egy digitális beállító elemet (digital control). Ezt fogja használni a 

Celsius fok megadására.  

a. Válassza ki a digitális beállító elemet a Controls»Numeric palettán. Ha a 

Controls paletta nem látható, a jobb egérgombbal kattintson az előlap egy 

szabad területére, hogy megjelenjen.  

b. Mozgassa a beállító elemet az előlapon és kattintson arra a helyre, ahova 

helyezni akarja.  

c. Írja be a Celsius-fok szöveget a címke belsejébe, utána kattintson a 

címkén kívülre, vagy az Enter gombra az eszközsávban. Ha nem ír be azonnal 

a címke helyére új szöveget, akkor a LabVIEW az előre definiált szöveget 

használja. A címke később is bármikor átírható a baloldalt mutatott címke-

feliratozó eszköz segítségével.  

4. Hozzon létre számkijelzőt. Ez a kijelző fogja megjeleníteni a hőmérséklete Fahrenheit-

fokban.  

a. Válassza ki a digitális kijelzőt Controls»Numeric palettán.  

b. Vigye a kijelzőt az előlapon a kiválasztott helyre és helyezze oda egy 

kattintással.  

c. Írja be Fahrenheit-fok szöveget a címke belsejébe, utána kattintson a 

címkén kívülre, vagy az Enter gombra az eszközsávban. 

A LabVIEW létrehozza a megfelelő beállító és kijelző terminálokat a blokkdiagramon. 

A terminál mindig mutatja az adattípusát a beállítónak és kijelzőnek Például egy a 

baloldalon mutatott DBL terminál, egy dupla-pontosságú, lebegőpontos számkijelzőt 

vagy beállító-elemet jelez. 

Megjegyzés A beállító-elemet egy szélesebb határoló téglalap jelzi.  
1 
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Blokkdiagram 
 
 

 
 
 
 

 

 

5. Jelenítse meg a blokkdiagramot a Window»ShowDiagram menüpontra való 

kattintással. 

6. Válassza ki a szorzás (Multiply) és összeadás (Add) függvényeket 

Functions»Numeric palettáról és helyezze őket a blokkdiagramra. Ha a Functions 

paletta nem látható, kattintson a jobb egérgombbal a blokkdiagram területére, hogy a 

Functions palettát megjelenítse.  

7. Válassza ki szám konstanst a Functions»Numeric palettáról, és helyezzen két 

példányát a blokkdiagramra. Amikor a konstans a blokkdiagramra kerül, a konstans 

érték megváltoztatható, a kívánt érték azonnal beírható . 

8. Írjon 1.8-t az egyik és 32.0-t a másik konstans helyére. Ha már elhelyezte a 

konstans, mielőtt új értéket adott volna, a címkéző eszköz (Labeling tool) segítségével 

bármikor megváltoztathatja. 

9. Használja a baloldalt mutatott „Wiring tool”-t az ikonok összekötésére, ahogy a fenti 

blokkdiagramon látszik.  

 Két terminál összekötése a „Wiring tool”-lal a következő módon történik. 

Kattintson az egyik csatlakozási pontra (terminálra), mozgassa az egeret a másik 

terminálhoz és kattintson a másik terminálra, ahogy a következő képen látszik. A 

huzalozást bármely terminálnál kezdheti.  

  

 
 

 

 

 

 

 

 

 A vezetéket meg lehet törni, egy tetszőleges ponton a blokkdiagramra kattintva és 

utána merőleges irányba mozgatva a kurzort. A vezeték irányát a „Spacebar” 

lenyomásával lehet megváltoztatni. 

A csatlakozási pontok (terminálok) a következő módon tehetők láthatóvá: Kattintson a jobb 

egérgombbal a szorzó és összeadó függvényre és válassza ki 
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 Visible Items»Terminals a menüből. A huzalozás befejezése után újra a jobb 

egérgombbal kiválasztva a Visible Items»Terminals menüpontot, a megjelenítést 

és az azt jelző pipát el lehet távolítani. 

 Amikor a huzalozóval a csatlakozó fölé kerül, a csatlakozó elkezd villogni, 

jelezve, hogy a kattintás összeköti a vezetéket a csatlakozóval, és kijelzi a 

csatlakozási pont nevét.  

 Már megkezdett, de szükségtelen vezetéket az ESC gomb, a jobb egérgombbal 

való kattintás vagy a kezdő csatlakozóra való kattintás törli. 

10. Jelenítse meg az előlapot, az előlapra kattintva, vagy kiválasztva  a Window»Show 

Panel menüpontot. 

11. Mentse el a VI-t, mivel a későbbiekben még használni fogjuk. 

a. Válassza ki a File»Save menüpontot. 

b. Navigáljon a d:\exercises\LV Basics I\sajatnev könyvtárhoz; ha 

még nincs, hozza létre. 

Megjegyzés: Mentsen minden VI-t ugyanebbe a saját könyvtárba.  

c. Írja be a VI neveként:  Convert C to F.vi a párbeszédablakba. 

d. Kattintson a Save gombra. 

12. Írjon be egy számot a digitális beállítóba és futtassa a programot (VI-t).  

a. Használja a baloldalon mutatott „Operating tool”-t, vagy a „Labeling tool”-t, 

és kétszer kattintva a digitális beállítóra  írjon be új számokat.  

b. Kattintson a Run gombra a VI futtatásához. 

c. Próbáljon ki különböző számokat és futtassa a VI-t. 

13. Válassza a File»Close Convert C to F VI bezárására. 
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2-2. gyakorlat: VI szerkesztése (Editing Exercise VI) 
 
Tárgy: Egy VI szerkesztése 
 

Módosítsa az előlapot az alábbinak megfelelően, és huzalozza össze a blokkdiagramot, hogy a 

VI működőképes legyen 

Megjegyzés: Hiba esetén használja az Edit»Undo utasítás a hibás lépés korrigálására. 

 
Előlap (Front Panel) 

 
 

1. Válassza a File»Open és navigáljon a  d:\exercises\LV Basics I mappába és 

nyissa meg a Editing Exercise-hu VI-t. 

 

(Windows, Sun, and HP-UX): Ha az összes VI zárva volt, kattintson az Open VI 

gombra a LabVIEW dialóg ablakban. 

 

2. Digitális beállító elem áthelyezése 

a. A baloldalon mutatott pozicionáló eszközzel kattintson a digitális beállító 

elemre és helyezze át egy másik helyre. A hozzá tartozó címke együtt mozog 

az elemmel. 

b. Kattintson egy üres területre, hogy a kiválasztást megszüntesse.  

c. Kattintson a címkére és helyezze át egy másik helyre. A beállítóelem nem 

követi. A címke bárhova helyezhető a beállítóelemhez képest. A címke mindig 

követi a hozzá tartozó beállítóelemet, ha azt mozgatják.  

3. A három kapcsoló áthelyezése csoportként  

a. A „Positioning tool” –lal kattintson a három kapcsoló közelében és rajzoljon 

egy kijelölő négyszöget a kapcsolók köré. 
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b. Kattintson az egyik kapcsolóra és húzza át egy másik helyre. Az összes 

kapcsoló együtt mozog. 

4. A három LED kijelzőt rendezze egy sorba és egymástól egyenlő távolságra. 

a. Kattintson a „Positioning tool”-lal egy szabad területre a három LED 

közelében és rajzoljon egy kijelölő négyszöget a három LED köré. 

b. Válassza ki az Align Objects legördülő menüt és abból a Vertical Centers, a 

baloldalon mutatott menüpontot  a LED-ek vízszintes egyenesre való 

igazítására.  

c. Válassza a „Distribute Objects” legördülő menüből a bal oldat látható 

„Horizontal Centers”-t, a LED-ek elrendezésére. 

5. Egy kör alakú LED átszínezése és átméretezése 

a. Vigye a „Positioning tool”-t a LED fölé. Az átméretező kör jelenik meg LED 

fölött. 

b. Kattintson és húzza a kurzort, hogy felnagyítsa a LED-t. Tartsa lenyomva a 

<Shift> gombot,  ha a LED-et arányosan akarja változtatni. 

6. Változtassa meg a LED színét! 

a. Alapértelmezésben a LED kikapcsolt (OFF) állapotban sötétzöld (FALSE). A 

baloldalon mutatott „Operating tool”-al kattintson a LED-re, hogy átkapcsolja 

a bekapcsolt állapotnak (ON) megfelelő színre, a világod zöldre (TRUE). 

b. Használja a baloldalon mutatott színező eszközt a „Coloring tool”-t és 

jobboldali egérkattintással a LED-en megjelenítse a szín választékot. 

c. Válassza a piros színt az bekapcsolt állapot új színének. 

7. A digitális kijelző címkéjének megjelenítése és szerkesztése  

a. Használja a baloldalt mutatott címkézőt, „Labeling tool”-t, majd egy jobboldali 

egérgomb kattintással a digitális kijelzőre válassza a Visible Items»Label 

pontot a  felbukkanó menüből. Egy kis szövegdoboz jelenik meg a 

szövegkurzorral a beírandó szöveg fogadására. 

b. Írja be a Digitális Kijelző szöveget a dobozba. 

c. Kattintson bárhova a címkén kívülre, vagy kattintson az Enter gombra az 

eszközsávon a szövegbevitel befejezésére. 

8. Szövegbeviteli pont törlése 

a. A „Positioning tool”-lal válassza ki a szövegbeviteli pontot. 

b. Nyomja le a <Delete> gombot, vagy válassza az Edit»Clear parancsot a 

szöveg törlésére. 

9. Szabad címke megduplázása. 

a. Tartsa lenyomva a <Ctrl> gombot és a „Positioning tool”-lal kattintson a 

címkére.  

b. Húzza a másolatot az új helyre. 

10. Változtassa meg a szöveg jellemzőit és rejtse el a dobozt a szabad címke körül.  

a. A „Positioning tool”-lal válassza ki a címkét. 

b. A Text Settings legördülő menüből változtassa meg a szöveg jellemzőit.  

c. A Coloring tool-lal kattintson a jobb egérgombbal a címkére, majd válassza ki  

a színt a  színválasztóból. A doboz elrejtését a szinbeállitó jobb felső sarkában 

lévő T betüre kattintással lehet elérni (Transparent). 

11. Változtassa meg az y –tengely szövegének és színének jellemzőit.  

a. A „Labeling tool”-al jelölje ki a 10.0 –et az y tengelyen.  

b. A Text Settings legördülő menüből változtassa meg a szöveg jellemzőit és 

színét. 

12. Kettős kattintással a 0.0 -ra, majd -10.0 –et beírva megváltozik az y tengely 

skálája. 
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Blokkdiagram 
 

13. A „Window»Show Diagram” menüpont választása megjeleníti a blokkdiagramot. 

Huzalozza be úgy a blokkdiagramot, ahogy az alább látható. 

 

 

 
 

 

 A szorzás (Multiply) függvény az 5.0 számállandót és a digitális beállító értékét 

szorozza össze. 

 Az „Uniform White Noise VI” egyenletes fehérzaj generátor VI egyenletes 

eloszlású pszeudovéletlenszámokat hoz létre a [–a:a] intervallumban, ahol a az 

amplitúdó abszolút értéke, jelen esetben 10.00 ami a VI bemenő értéke. 

 A „Not” függvény invertálja azt a logikai értéket, amelyet az A kapcsoló ad és 

továbbítja az új értéket a LED-hez. 

14. A jobb egérgombbal kattintson a „Multiply” függvény bal alsó csatlakozójára és 

válassza a Create»Constant pontot az előugró menüből a kívánt számállandó 

létrehozására.  

15. Írja be az 5 értéket a szövegdobozba, és kattintson az Enter gombra az eszközsávban. 

 

16. Használja a „Wiring tool”-t és az alábbi eljárást a blokkdiagram behuzalozására. 

 Válassza a Help»Show Context Help menüpontot, hogy megjelenítse a Context 

Help ablakot. Használja Context Help ablakot, hogy meghatározza, mely 

csatlakozási pontok szükségesek. A szükséges csatlakozók félkövér betűkkel 

vannak jelezve, a javasoltakat egyszerű szöveg jelzi, míg az opcionálisak szürkék. 

 A csatlakozási pontok azonosítására a csomópontokon kattintson az ikonra és 

válassza a Visible Items»Terminal –t a felbukkanó menüből, hogy a  csatlakozó 

lapok láthatóvá váljanak. Amikor a huzalozás kész, válassza újra a Visible 

Items»Terminal  pontot a menüből, hogy a kiválasztás megszűnjön. 

 Elágazás létrehozásához kattintson a vezetékre, ahol az elágazást akarja, illetve 

jobb egérgombbal való kattintásnál válassza a Create Wire Branch opciót. 

 Egy megkezdett huzalozást az <Esc> gomb lenyomásával, vagy jobb egérgombbal 

való kattintással, vagy a kiinduló csatlakozó terminálra való újabb kattintással 

lehet megszüntetni.  
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17. Válassza a File»Save As menüpontot a VI elmentésére. 

18. Jelenítse meg az előlapot rákattintással, vagy a Window»Show Panel menüponttal.  

19. Használja „Operating tool”-t az előlap beállítóelemeinek megváltoztatására. 

20. Kattintson a Run gombra az eszközsávon a VI elindításához. 

21. Válassza a File»Close pontot a VI bezárására. 
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2-3. gyakorlat: Debug Exercise (Main) VI 
 
Cél: A hibakeresés gyakorlása 
 

Töltse be a Debug Exercise (Main) VI  hibás VI-t, korrigálja a hibákat, használja a 

lépésenkénti végrehajtást, lépkedjen végig a VI-n. 

 

1. Válassza File»Open pontot és keresse meg a 

d:\hallgato\exercises\LV Basics I könyvtárat, abban pedig a 

Debug Exercise (Main) VI-t.  
(Windows, Sun, és HP-UX) Ha az összes korábban megnyitott VI-t már 

bezárta, kattintson az Open VI gombra a LabVIEW dialóg ablakban.  
A következő előlap jelenik meg. 

 

 
 

A baloldalt látható megtört Run gomb azt jelzi, hogy a VI hibás, nem 

futtaható. 

2. Válassza a Window»Show Diagram parancsot a diagramablak 

megjelenítésére. 

 

 
 

A véletlenszám (0-1) generátor függvény pszeudovéletlenszámokat állít elő 

a 0-1 intervallumban. 

A szorzás függvény jele. 

Az a számkonstans, amivel megszorozzuk a véletlenszámot.  

A nyomkövetési gyakorlat VI (Debug Exercise (Sub) VI) hozzáad 100.0-at, 

és kiszámítja a kapott érték négyzetgyökét. 

3. Keresse meg és javítsa ki a hibákat.  

 

 

 

 

 

 

 



22 

a. Kattintson a megtört Run gombra. A hibák listája (Error list) 

ablak jelenik meg és megadja az összes hiba leírását  

b. Rákattintva egy sorra, a hiba részletesebb leírása jelenik meg a hiba 

valószínű okáról. 

c. A Show Error gombra kattintva a hibás blokkdiagram elem vagy 

előlap objektum jelenik meg, megjelölve a hibához kapcsolódó 

objektumot. 

d. Használja fel a Details rész leírását a hiba javításához.  

4. Mentse a VI-t a  File»Save paranccsal. 

5. Jelenítse meg az előlapot rákattintással vagy a Window»Show Panel 

menüpont kiválasztásával. 

6. Kattintson a Run gombra néhányszor, hogy a VI-t többször futtassa. 

7. Válassza a Window»Show Diagram parancsot a blokkdiagram 

megjelenítésére. 

8. Jelenítse meg az adatáramlást a blokkdiagramon.  

a. Kattintson a baloldalt látható Highlight Execution gombra a 

végrehajtás nyomonkövetésének bekapcsolásához  . 

b. Kattintson a baloldalt látható Step Into gombra, a lépésenkénti 

végrehajtás megkezdésére. Az adatáramlás megjelenítése mutatja az 

adatmozgást a blokkdiagramban az egyik csomópontjától a másikig 

egy, a vezeték mentén mozgó „buborék” formájában. A villogó 

csomópont jelzi, hogy végrehajtásra kész a csomópont  

c. Kattintson a balra látható Step Over gombra, hogy egyenként 

végrehajtson minden lépést. Valahányszor a Step Over gombra 

kattint, az aktuális utasítás végrehajtódik, és a megáll az utána 

következő végrehajtásra kész utasításon.  

Az adatok megjelennek az előlapon is mialatt keresztüllépegetünk a 

VI-n. A VI véletlenszámokat generál és ezeket megszorozza 10.0-

zel. A szubVI hozzáad az eredményhez 100-at és négyzetgyököt 

von az eredményből. 

d. Amikor a blokkdiagram külső kerülete villog, kattintson a balra 

látható Step Out gombra, hogy befejezze a lépésenkénti 

végrehajtást Debug Exercise (Main) VI-ben. 

9.  Hajtsa végre lépésenként VI-t és benne található subVI-t. 

a. Kattintson a  Step Into gombra a lépésenkénti végrehajtásra. 

b. Amikor a Debug Exercise (Sub) VI villog kattintson Step Into 

gombra. A következő blokkdiagram jelenik meg.  

 
 

c. Jelenítse meg a „Debug Exercise (Main) VI” blokkdiagramot 

rákattintással. Amikor a balra látható zöld nyíl megjelenik a subVI 
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ikonon a Debug Exercise (Main) VI blokkdiagramban, jelzi, hogy a 

VI lépésenkénti végrehajtási módban van.  

d. Jelenítse meg a Debug Exercise (Sub) VI blokkdiagramját a subVI-

re való rákattintással. 

e. Kattintson a Step Out gombra kétszer a lépésenkénti végrehajtás 

befejezésére a subVI blokkdiagramjában. A Debug Exercise (Main) 

VI blokkdiagram még aktív. 

f. Kattintson Step Out gombra, hogy leállítsa a lépésenkénti 

végrehajtást. 

10. Használjon egy teszt pontot a vezetékeken áramló adat ellenőrzésére.  

a. Használja a baloldalon látható „Probe tool”-t rákattintva bármely 

objektumra.  

A következő ablak jelenik meg.  

 
 

A szám a Probe ablak címsávjában megegyezik a blokkdiagramon 

megjelenő számmal.  

b. Lépésenként hajtassa végre a VI-t ismét, és figyelje meg, hogyan 

változnak az adatok az adatok a Probe ablakban.  

11. Helyezzen el egy töréspontot a blokkdiagramon a végrehajtás megállítására 

egy adott pontban.  

a. Használja a baloldalon látható töréspont beállító eszközt 

(Breakpoint tool) a töréspont létrehozására, rákattintva a kívánt 

helyre. A szabad munkaterületre kattintva, az első utasítás 

végrehajtása elé kerül töréspont. 

b. Kattintson a Run gombra a VI futtatásához. A VI futása megáll a 

kijelölt töréspontnál. 

c. A VI továbbfuttatásához kattintson a baloldalt látható Continue 

gombra. 

d. A „Breakpoint tool”-lal történő újabb kattintással további helyek 

jelölhetők ki, illetve másodszor kattintva egy töréspontra, törlődik. 

12. Újra kattintva a Highlight Execution gombra a nyomkövetés 

megjelenítése megszűnik. 

13. A File»Close menüpont választásával bezárhatja a VI-t és a nyitott 

ablakokat. 
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Feladatok: 
2-4. Készítsen egy VI-t, ami összehasonlít két számot, és bekapcsol egy LED-

et, ha az első szám nagyobb, mint a második. 

Tipp: Használja a Greater Or Equal? függvényt, amely a 

Functions»Comparison palettán található. Mentse el a VI-t 

Compare.vi néven. 

2-5. Készítsen egy VI-t, amely véletlenszámokat generál 0.0 és 10.0 között, 

majd elosztja a generált számokat az előlapon beállított értékkel. Ha a 

beállított szám 0.0 a VI bekapcsol egy LED-et, ami a 0-val való osztásra 

figyelmeztet. Mentse el ezt a VI-t Divide.vi néven. 

2-6. Készítsen egy VI-t, ami meghatározza egy másodfokú egyenlet gyökeit, 

az előlapon megadott együtthatóértékek mellett. Kijelzi, ha az 

egyenletnek csak komplex megoldása van, és megjeleníti az előlapon a 

megoldásokat. Mentse el a megoldást masodfok.vi néven. 
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3-1. gyakorlat: Celsius-Fahrenheit konvertáló SubVI 
létrehozása a Convert C to F VI-ből 

 
Feladat: A subVI-re jellemző ikon és csatlakozóelem létrehozása egy VI-in, 
hogy az a továbbiakban SubVI-ként legyen használható.  
 
A következő lépések segítségével hozza létre a Celsius - Fahrenheit konvertáló programból a 

subVI változatot, kialakítva a subVI-t reprezentáló ikont és csatlakozót.  

 
A subVI hasonló a más programozási nyelvekben használt szubrutinhoz, függvényhez vagy 

eljáráshoz. Ezért használhatunk VI-t - szubrutinként - egy hívó VI diagram paneljában. A 

subVI előlap paneljának és diagram paneljának definíciója ugyanazt jelenti, mint bármely más 

VI esetében. Úgy tudjuk létrehozni, hogy definiálunk a számára egy ikont és csatlakoztatjuk 

az adatbemeneteket és -kimeneteket a csatlakozó megfelelő pontjaihoz. 
 
Előlap 

1. Használjuk az előzőekben létrehozott Convert C to F VI-t. A File»Open menüpont 

alatt navigálva keresse meg és nyissa meg a korábban elkészített Convert C to F VI-t. 

A következő előlap jelenik meg: 

 

 
 

 

2. Minden VI-hoz tartozik egy ikon, ami a front és diagram panel ablak jobb felső 

sarkában található. Alapértelmezésként egy LabVIEW alapikon szerepel. Az 

ikonszerkesztő eléréséhez a előlap panel ablakból jobb egérgombbal kattintással 

jelenítsük meg az ikonhoz tartozó menüt és válasszuk ki az "Edit" (Szerkesztés) 

menüpontot. Erre az Icon Editor dialóg ablak jelenik meg.  

3. Kettős kattintással a kiválasztó eszközre (lásd baloldalt) jelölje ki teljes 

alapértelmezett ikont. 

4. A <Delete> gomb lenyomásával törölje az alapértelmezett ikont 

5. Kettős kattintással a balra látható négyszögrajzoló ikonra újra megrajzolhatja az ikon 

keretét. 

6. Hozza létre a következő ikont. 

7.  

 

 



26 

 
 

a. Használja baloldalon látható „Text tool”-t és kattintson a szerkesztés területére.  

b. Írja be a C és F karaktereket. 

c. Kettős kattintással a betűkiválasztásra a betűtípust beállító ablak jelenik meg. 

Változtassa fontot a Small Fonts-ra. 

d. A nyilat a „Pencil tool” segítségével hozhatja létre. 
Megjegyzés: Vízszintes vagy függőleges egyenes vonal húzásához tartsa lenyomva a 

<Shift> gombot, amikor a rajzoló ceruzát használja.  

e. A „Select tool”-lal és a nyilakkal jelölje ki és mozgassa szövegeket és a nyilat 

a megfelelő pozícióba. 

f. Válassza ki a B&W ikont és válassza a 256 Colors-t a Copy from mezőből, 

hogy létrehozza a fekete-fehér ikont, amelyet a LabVIEW a nyomtatásra 

használ, ha nincs színes nyomtató. 

g. Amikor elkészült az ikon, kattintson az OK gombra az Icon Editor 

bezárására. A létrehozott ikon megjelenik az előlap és a blokkdiagram jobb 

felső sarkában.  

8. Most kijelöljük a subVI bemeneti és kimeneti kapcsolódási pontjait, valmint 

létrehozzuk a VI-hez tartozó programkapcsolatot. Jelenítsük meg először a subVI 

kapcsolódási pontjait. Ezt úgy érhetjük el, hogy az előlap panel ablakban a jobb 

egérkattintással subVI ikonjára megjelenő menüből kiválasztjuk a "Show Connector" 

(Mutasd a csatlakozót) menüpontot. Ekkor a subVI ikon képe helyett a kapcsolódási 

pontjai jelennek meg és az egérmutató huzalozó eszközzé változik.  

A konnektor kapcsolódási pontjain keresztül a bemeneti adatok az adatbemeneti 

elemekhez juthatnak, a kimeneti adatok pedig az adatkimeneti elemekből elérhetővé 

válnak. Ehhez hozzá kell rendelnünk előlap panel elemeit a konnektor kapcsolódási 

pontjaihoz.  

A LabVIEW az előlapon lévő beállító elemek, és kijelzők alapján választja ki a 

csatlakozó struktúráját. Ezen az előlapon két csatlakozóelem van: a Celsius és a 

Fahrenheit, így a LabVIEW a baloldalt látható csatlakozószerkezetet választja.  

9. Kapcsoljuk össze a csatlakozókat a digitális beállító elemhez és kijelzőhöz. 

a. Válassza Help»Show Context Help a  Context Help ablak megjelenítésére. 

Figyelje a csatalakozókat a Context Help ablakban a létrehozás alatt. 

b. Kattintson a baloldali csatlakozóra a csatlakozólapon. Az eszköz 

automatikusan a huzalozóvá válik és a terminál fekete lesz. 

c. Kattintson a Celsius beállító elemre. A baloldali csatlakozó narancs színűvé 

válik és apró kockás kijelölést kap.  

 

d. Kattintson egy szabad területre az előlapon. A kijelölés eltűnik, és a csatlakozó 

felveszi a beállító elem adattípusának színét, jelezve, hogy a kapcsolat létrejött. 

1.  
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e. Ismételje meg az előzőeket a jobb terminállal és a Fahrenheit kijelzővel. A 

jobboldali csatlakozó is narancsszínű lesz. 

f. Kattintson egy szabad területre az előlapon. A kijelölés eltűnik és a 

csatalakozó felveszi a megfelelő elem adatszínét, jelezve, hogy a kapcsolat 

létrejött. 

g. Vigye a kurzort a csatlakozó fölé. A Context Help ablak mutatja, hogy 

mindkét terminál lebegőpontos értékhez kapcsolódik.  

10. A File»Save utasítással mentse el a VI-t, későbbi használatra.  

11. Fejezze be a feladatot a File»Close menüpont választásával.  



28 

3-2 gyakorlat: Hőmérő készítése (Thermometer) VI 

 
Tárgy: VI létrehozása, majd átalakítása subVI-já. 
 

A következő feladat hőmérséklet mérő subVI létrehozása, egy szimulált hőmérsékletérzékelő 

segítségével, mely egy valódi kártya jeleit szimulálja. A hőmérsékletérzékelő a hőmérséklettel 

arányos feszültséget szolgáltat. A voltban mért feszültségértéket 100-zal kell szorozni, hogy 

°C-ban kapjuk a hőmérsékletet. A hőmérsékletnek Fahrenheit fokban is kijelezhetőnek kell 

lennie.  

Jelen esetben a számítógépbe helyezett kártya (DAQ) helyett egy, a mérést szimuláló subVI-t 

használunk. 

 

 
Előlap 

1. Válassza a File»New pontot egy új előlap létrehozásához. 

(Windows, Sun, és HP-UX:) Ha az összes VI zárva volt, a New VI gombbal nyithat 

meg egy új VI-t a LabVIEW párbeszédablakban. 

2. Hozzon létre egy hőmérőt, ahogy az a következő előlapon látható. 

 

 
 

a. Válassza a „thermometer”-t a Controls»Numeric palettán és helyezze az 

előlapra.  

b. Írja be a Hőmérő nevet a címkébe, majd kattintson a címkén kívülre, vagy az 

Enter gombra. 

c. A jobboldali egérgombbal kattintson a hőmérőre és válassza a Visible 

Items»Digital Display a menüből, hogy a digitális kijelző is látható legyen. 

3. Hozzon létre egy függőlegesen működtethető kapcsolót. 

a. Válassza a kapcsolót a Controls»Boolean palettáról. 

b. Írja be a Hőmérsékleti skála szöveget a címkébe, majd kattintson egy 

üres területre.  

c. A címkéző „Labeling tool” segítségével helyezzen egy független címkét 

(Celsius fok) a kapcsoló TRUE pozíciójához, ahogy az a fenti előlapon 

látható.  

d. Helyezzen el egy címkét Fahrenheit felirattal a kapcsoló FALSE 

pozíciójánál. 

4. Készítse el a VI leírását, amely majd megjelenik a Context Help ablakban, ha a 

kurzor a VI fölé kerül.  

 



29 

a. Válassza a File»VI Properties menüpontot. A VI Properties párbeszédablak 

jelenik meg. Válassza a Documentation pontot a Category legördülő 

menüből. 

b. Írja be a következő leírást a  VI-ről a Description mezőbe:  Ez a VI 
hőmérsékletet mér egy hőmérsékletérzékelő és DAQ kártya 

segítségével. 

c. Kattintson OK gombra. 

5. Készítse el a hőmérséklet kijelző és a kapcsoló leírását a Context Help ablak számára, 

valamint azt a rövid leírást, ami megjelenik az objektum felett mozgó kurzor estén. 

a. Kattintson a jobb egérgombbal a hőmérséklet kijelzőre és válassza 

Description and Tip a megjelenő menüből. 

b. Írja következő leírást a hőmérőről a Description mezőbe: Megjeleníti a 
mért hőmérsékletet. 

c. Írja a hőmérséklet szót a Tip mezőbe. 

d. Kattintson az OK gombra. 

e. Kattintson a jobb egérgombbal a függőleges kapcsolóra és válassza a 

Description and Tip pontot a megjelenő menüből. 

f. Írja a következő leírást a kapcsolóról a Description mezőbe: Kiválasztja a 
használt hőmérsékleti skálát (Fahrenheit vagy Celsius). 

g. Írja be: skála - C vagy F a Tip mezőbe. 

h. Kattintson az OK gombra. 

6. Válassza a Help»Show Context Help a Context Help ablak megjelenítésére. 

7. Vigye a kurzort az előlapi objektumok fölé, hogy lássa a leírásokat a Context Help 

ablakban.  

 
Blokkdiagram 
 

8. Válassza a Window»Show Diagram pontot a blokkdiagram megjelenítésére.  

9. Hozza létre a következő blokkdiagramot. 

 

 
 

a. Helyezze a (Demo) Read Voltage VI-t a blokkdiagramra. Ez a VI szimulálja a 

valódi mérést végző Read Voltage VI-t  

b. Helyezze a szorzás (Multiply) függvényt – mely a Functions»Numeric 

palettán található – a blokkdiagramra. Ez a függvény fogja 100.0 -zal 

megszorozni a ReadVoltage VI által kapott értéket, hogy a hőmérséklet 

Celsius fokban mért értékét kapjuk. 

c. Válassza a Functions»Select a VI pontot a palettáról és navigáljon abba a 

könyvtárba, ahova az előző feladat során készített Convert C to F VI-t 

elmentette.  

d. Helyezze el a blokkdiagramon a Select függvényt, ami a 

Functions»Comparison palettán található. Ez a függvény vagy a Fahrenheit 
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(FALSE) vagy a Celsius (TRUE) hőmérséklet értéket továbbítja a 

hőmérsékleti skála választásától függően. 

e. Kattintson a jobb egérgombbal a Read Voltage VI device csatlakozójára, 

válassza a Create»Constant pontot,  írjon be 1-et, majd  nyomja meg az 

<Enter> gombot a számkonstans létrehozására.  

f. Kattintson jobb egérgombbal a Multiply függvény y csatlakozójára, válassza a 

Create»Constant pontot, írja be: 100 és az <Enter> gombbal hozza létre ezt 

az állandót.  

g. Kattintson jobb egérgombbal a Read Voltage VI channel csatlakozójára, 

válassza a Create»Constant pontot, írja be a 0 értéket, utána az <Enter> 

gombbal hozza létre az állandót. 

h. A „Positioning tool” segítségével helyezze el az ikonokat a fenti 

blokkdiagramon látható formában, majd a Wiring tool segítségével kapcsolja 

őket össze.  

Tipp Azonosíthatja a csatlakozókat a elemeken való jobb egérkattintással és a Visible 

Items»Terminal pont kiválasztással a felbukkanó menüből.  

10. Jelenítse meg az előlapot rákattintással vagy a Window»Show Panel menüpont 

kiválasztásával. 

11. Kattintson a baloldalt látható Continuous Run gombra a VI folyamatos futtatására.  

12. Kattintson a Continuous Run gombra ismét a VI futásának megállítására. 

13. Hozza létre a következő ikont, hogy a „Temperature VI” subVI-ként legyen 

használható. 

 

 
 

a. Kettős kattintással a kiválasztó eszközre (lásd baloldalt)  jelölje ki a teljes 

alapértelmezett ikont. 

b. A <Delete> gomb lenyomásával törölje az alapértelmezett ikont. 

c. Kettős kattintással a balra látható négyszögrajzoló ikonra, rajzolja meg az ikon 

keretét. 

d. A ceruza (Pencil tool) segítségével rajzolja meg a hőmérőt jelző ikont.  

e. Az előtér (Foreground) és kitöltő (Fill tool) eszközök segítségével színezze be 

a hőmérőt pirosra. 
Megjegyzés: Vízszintes vagy függőleges egyenes vonal húzásához tartja lenyomva a 

<Shift> gombot, mialatt a rajzoló ceruzát használja.  

f. Kettős kattintással a feliratozó eszközre, változtassa a fontot  Small Fonts-ra. 

g. Válassza a B&W ikont és válassza a 256 Colors-t a Copy from mezőből, 

hogy létrehozza a fekete-fehér ikont, amelyet a LabVIEW  nyomtatásra 

használ, ha nincs színes nyomtató. 
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h. Amikor elkészült az ikon, kattintson az OK gombra az Icon Editor 

bezárására. A létrehozott ikon megjelenik az előlap és a blokkdiagram jobb 

felső sarkában. 

14. Kattintson a jobb egérgombbal a Show Connector menüpontra a felbukkanó menüből 

és csatlakoztassa a kapcsolót és a hőmérőt az ikon csatlakozóihoz. 

a. Kattintson a baloldali csatlakozóra a csatlakozólapon.  

b. Kattintson a Hőmérsékleti skála beállítóra; a baloldali csatlakozó zöldre vált 

(logikai változó). 

c. Kattintson a jobboldali csatlakozóra a csatlakozólapon. 

d. Kattintson a Hőmérséklet kijelzőre. A jobboldali csatlakozó narancsszínűre 

vált (duplapontosságú lebegőpontos változó). 

e. Kattintson az előlap egy szabad területére a befejezéshez. 

15. Mentse el a VI-t későbbi használatra. 

a. Válassza a File»Save As pontot 

b. Menjen a korábban eltárolt saját VI-ket tartalmazó könyvtárhoz  

c. Írja be:  Thermometer.vi a megjelenő párbeszédablakba. 

d. Kattintson a Save gombra. 

16. Válassza a File»Close menüpontot a VI bezárására. 
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További feladatok 
 

3-3 Készítsen egy VI-t, amely kiszámítja a meredekségét két X-Y koordinátapárral 

megadott egyenesnek, ahogy az alábbi előlapon és blokkdiagramon látható: 

 

 
 

 

Dokumentálja a VI-t alaposan, majd hozza létre az ikonját és a csatlakozólapját.  

Jelölje ki a meredekségszámítást, körülvéve a kijelöléssel a számítási részét a 

blokkdiagramnak, és válassza az Edit»Create SubVI parancsot a subVI létrehozására.  

Mentse el a VI-t, mint  Slope.vi. 

(SubVI-t úgy is készíthetünk egy blokkdiagram egy részéből, hogy a kiválasztó 

eszközzel kijelöljük a blokkdiagram adott területét és az Edit»Create SubVI 

paranccsal subVI-já alakítjuk. ) 
 

3-4. Készítsen subVI-t a korábban elkészített másodfokú egyenlet megoldó VI-ból. 

 

3-5. Az előzőekben elkészített meredekség meghatározó VI-t bővítse az egyenest leíró két 

paraméter meghatározására: y=ax+b 
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4-1. gyakorlat: Hőmérséklet monitor (Temperature 
Monitor) VI 

Tárgy: A While ciklus és waveform chart (Hullámforma diagram) használata az 
adatok gyűjtésére és megjelenítésére.  
 

E  példa keretében egy hőmérsékleti grafikont fog létrehozni, amely egy digitális hőmérőtől 

érkező adatokat ábrázolja. A program mindaddig működik, ameddig a felhasználó a 

"Főkapcsoló" elnevezésű kapcsolót logikai igaz értékről nem kapcsolja át hamisra. 

 

Előlap 
1. Hozzon létre egy új VI-t. 

2. Készítse el a következő panelt: 

 

 
 

a. Válasszon egy függőleges kapcsolót a Controls»Boolean palettáról és 

helyezze az előlapra. Ezt használja majd az adatgyűjtés megállítására.  

b. Írja be: Főkapcsoló a címkébe és kattintson a címkén kívülre, vagy az 

Enter gombra eszközsávon. 

c. Válassza a „waveform chart”-ot (hullámforma diagram) a 

Controls»Graph palettáról és helyezze az előlapra. A hullámforma 

diagram valós időben jeleníti meg az adatokat. 

d. Írja be: Hőmérséklet történet a címkén belülre, majd kattintson a 

címkén kívülre, vagy az Enter gombra az eszközsávon.  

e. A hullámforma diagram jelmagyarázat címkéje Plot 0. Használja a 

„Labeling tool”-t hármas kattintással a Plot 0 szövegre a jelmagyarázat 

címkében és írja be: Hőmérséklet , majd kattintson a címkén kívülre, 

vagy az Enter gombra az eszközsávon. 

f. A hőmérsékletérzékelő méri a szobahőmérsékletet. Használja a „Labeling 

tool”-t kettős kattintással a 10.0-re az y - tengelyen, írjon be 90 -et, 

majd kattintson a címkén kívülre vagy az Enter gombra az eszközsávon a 

diagram átskálázásához.  

g. Változtassa a –10.0-et az y  tengelyen 70-re. 

h. Jelölje az y tengelyt Hőmérséklet (Deg F), majd  az  x  tengelyt Idő 

(sec) felirattal. 

i.  

 



34 

 
 
Blokkdiagram 
 

3. Válassza a Window»Show Diagram a blokkdiagram megjelenítésére. 

4. Vegye körbe a két csatlakozóelemet egy „While Loop” ciklussal, ahogy az 

alábbi blokkdiagramon látszik.  

 
 

 

a. Válassza a „While Loop”-ot a Functions»Structures palettából. 

b. Kattintson és húzza a kiválasztó négyszöget a két terminál köré.  

c. Használja a pozicionáló eszközt a ciklus átméretezésére, ha szükséges.  

5. Válassza a Functions»Select a VI pontot és keresse meg a korábban elmentett 

Hőmérő VI-t. Kettős kattintás után helyezze a blokkdiagramra. Ez a VI minden 

végrehajtáskor egy hőmérséklet értéket ad. 

6. Huzalozza össze a blokkdiagram objektumokat, ahogy a fenti blokkdiagram 

mutatja. 

Megjegyzés: A hőmérséklet Celsius fokban történő mérésére kapcsoljon egy 

logikai (Boolean) konstanst a Functions»Boolean palettáról a Temp Scale 

bemenetére a Hőmérséklet VI-nak. Változtassa a skálát a hullámforma 

diagramon 20 és 32 re a 70 és 90 helyett. 

7. Mentse el a VI-t  Hőmérséklet Monitor.vi néven, mivel a későbbiekben 

még használni fogjuk 

8. Jelenítse meg az előlapot rákattintással vagy Window»Show Panel menüpont 

választásával. 

9. Használja az „Operating tool”-t, kattintson a függőleges kapcsolóra és kapcsolja át 

az ON állásba. 

10. Futtassa a VI-t 

11. A "While Loop" egy olyan LabVIEW struktúra, amely addig ismételi az általa 

bekeretezett blokkdiagram-részletet, ameddig a benne lévő feltétel igaz értékű. 

Például amíg a kapcsoló bekapcsolt állapotban van (TRUE), a Hőmérő VI 

végrehajt egy új mérést, és az adatot megjeleníti a hullámforma diagramon. 

12. Kattintson a kapcsolóra az adatgyűjtés megállításához. Amikor a feltétel hamis 

(FALSE), a ciklus végrehajtása megáll. 

13. Alakítsa át a hullámforma diagram X és Y skáláját.  
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a. Kattintson a jobb egérgombbal a diagramra és válassza az Y 

Scale»Formatting menüpontot a megjelenő menüből. A következő 

párbeszédablak jelenik meg: 
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b. Kattintson a Scale Style ikonra és válasszon különböző stílusokat az y 

tengelyre. 

Választhat különböző skálákat (Log, inveted), rácsot, skálafaktorokat, 

számformátumot és pontosságot.  
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c. Válassza a fenti párbeszédablakon látható beállításokat és kattintson az OK 

gombra. 

14. Kattintson a jobb egérgombbal a hullámforma diagramra és válassza a Data 

Operations»Clear Chart menüpontot a felbukkanó menüből a diagram 

törléséhez. Ha a VI fut, a felbukkanó menüből közvetlenül választhatja Clear 

Chart parancsot.  

 

A logikai kapcsolók mechanikai hatásának változtatása 
 
A mikor futtatni akarja a VI-t, először kapcsolja kapcsolót az ON állásba, majd kattintson a 

Run gombra. Módosíthatja a logikai kapcsolók mechanikai hatását az alábbi lehetőségek 

egyikének választásával. 

 

 Switch When Pressed—Lenyomáskor kapcsol. Amikor az Operating tool-lal a 

kapcsolóra kattint, a logikai értéke az ellenkezőre vált. A VI olvasásnak nincs hatása 

az állapotra. 

 Switch When Released—Felengedéskor kapcsol. Amikor az Operating tool-lal a 

kapcsolóra kattint, az egérgomb felengedésekor a logikai értéke az ellenkezőre vált. A 

VI olvasásnak nincs hatása az állapotra.. 

 Switch Until Released— Felengedéskor kapcsol. Amíg lenyomva tartja az 

egérgombot, a változó értéke az eredeti ellenkezője lesz. Az ajtócsengőhöz hasonlóan 

működik. A VI olvasásnak nincs hatása az állapotra.  

 Latch When Pressed— Tárolja a lenyomás utáni értéket. Ellenkezőjére változtatja 

a változó értékét amikor lenyomják, és tartja ezen értéket az első kiolvasásáig. Ekkor  

visszaállítja az eredeti értéket. Jól felhasználható While Loop-ok megállítására.  

 • Latch When Released— Tárolja a felengedés utáni értéket. Ellenkezőjére 

változtatja a változó értékét a felengedéskor, és tartja ezen értéket az első kiolvasásáig. 

Ekkor visszaállítja az eredeti értéket. Ez garantálja, hogy legalább egyszer az új érték 

szerepel 

 • Latch Until Released— Tárolja a lenyomás alatti értéket. Ellenkezőjére 

változtatja a változó értékét a lenyomva tartás idejére, vagy az első kiolvasásáig, 

(amelyik később következik be).  

 

15. Módosítsa a függőleges kapcsolót úgy, hogy minden indításkor automatikusan 

rajzolja a diagramot. (A kapcsolóval csak megállítani lehessen). 

a. Állítsa  meg VI-t, ha fut. 

b. Az Operating tool –lal állítsa át a kapcsolót a bekapcsolt (ON) pozícióba.  

c. A jobb egérgombbal történő kattintásra a  felbukkanó menüből válassza a 

Data Operations»Make Current Value Default menüpontot. Ez a 

bekapcsolt állapotot teszi az indulási értékké.  

d. A jobb egérgombbal történő kattintásra felbukkanó menüből válassza a 

Mechanical Action»LatchWhen Pressed menüpontot. 

16. Futtassa a VI-t. 

17. Használja a Operating tool -t az adatgyűjtés leállítására. A kapcsoló az OFF 

pozícióba vált, majd visszaáll az ON értékre, miután a ciklus feltételvizsgálója 

beolvasta az értéket.  
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Időzítés hozzáadása 
 

 

Amikor a VI fut, a While Loop végrehajtása a lehető legnagyobb sebességgel történik. A 

következő lépések végrehajtásával beállítható, hogy az adatgyűjtés bizonyos 

időintervallumonként történjen. 

 

 
 

a. Helyezze a Wait Until Next ms Multiple függvényt (a Functions»Time & 

Dialog palettán található) a blokkdiagramra. Ez a függvény hatására a ciklus 

fél másodpercenként hajtódik végre (500 ms). 

b. Kattintson a jobb egérgombbal a millisecond multiple bemenetére a Wait 

Until Next ms Multiple függvénynek, válassza a Create»Constant a 

felbukkanó menüből és írja be a 500 értéket, majd nyomja meg az <Enter> 

gombot. Az 500-as érték jelenti az 500 ms-os várakozást, azaz a ciklus fél 

másodpercenkénti végrehajtását. 

c. Az előlapon kattintson a jobb egérgombbal a diagramra és válassza az X 

Scale»Formatting  pontot a felbukkanó menüből. Változtassa a dX értékét 

0.5 –re, mivel  500 ms várakozás van az egyes iterációk között. 

18. Mentse el a VI-t, mert a későbbiekben használni fogjuk.  

19. Futtassa a VI-t. 

20. Változtassa meg a numerikus értéket és futtassa újra a VI-t.  

21. Zárja be a VI-t. 
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4-2. gyakorlat. Véletlenjel-generátor (Random Signal) VI  

 
Feladat : Változtatható időzítés hozzáadása a ciklushoz 
 
Készítsen egy a VI-t, ami véletlenszámokat generál és megjeleníti azokat egy hullámforma 

diagramon oszcilloszkóp stílusú kirajzolással.  

 

1. Helyezzen el egy forgatógombos szabályozót az előlapon és állítsa be hogy 0 és 2 

szekundum között legyen változtatható a késleltetés, ahogy az alábbi előlapon 

látható. 

 

 
 

2. Helyezzen el egy kapcsolót a VI megállítására. 

3. Konfigurálja úgy a kapcsolót, hogy ne kelljen mindig bekapcsolnia, amikor futtatni 

akarja a VI-t.  

4. Készítse el a fent látható front panelt az alábbi tippek alapján:  

 Kattintson a jobb egérgombbal a hullámforma diagramra és 

válassza a Visible Items»Plot Legend pontot a felbukkanó 

menüből, hogy elrejtse a feliratot.  

 Kattintson a jobb egérgombbal a Time címkére és válassza a 

Visible Scale Label -t a felbukkanó menüből, hogy elrejtse az x 

tengely feliratát.  

5. Készítse el a blokkdiagramot az alábbi tippek alapján: 

  Használja a Random Number (0-1) függvényt  (a 

Functions»Numeric palettán található) az adatok létrehozására. 

 Szorozza meg a beállító gomb értékét 1000-rel, hogy a 

másodpercet milliszekundummá konvertálja. Használja ezen 

értéket Functions»Time&Dialog palettán található Wait Until 

Next ms Multiple függvény bemenő adataként.  
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  Kattintson jobb egérgombbal a megjelenítőre és válassza az 

Advanced»Update Mode pontot a felbukkanó menüből és 

állítsa be a chart módot. 

6. Mentse el a VI-t, mint Random Signal.vi. 

7. Futtassa a VI-t. 

8. Változtassa meg a késleltetés értékét és futtassa újra a VI-t. 

9. Zárja be a VI-t. 
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4-3 gyakorlat. Automatikus egyezés keresése (Auto 
Match) VI 

 
Tárgy: Adat továbbítása a While Loop ciklusból egy „alagúton” keresztül 
 
A feladat olyan VI létrehozása, amely addig generál véletlenszámokat, amíg a generált szám 

meg nem egyezik egy előre beállított értékkel. A VI a végrehajtott ciklust számláló változó 

segítségével megjeleníti hány lépes kellett az egyezés eléréséhez.  

 
Előlap 
 

1. Nyisson meg egy új előlapot. 

2. Hozza létre a következő előlapot és módosítsa a beállító elemeket és kijelzőket az 

alább megadottak szerint.  

 

 
 

A Number to Match beállítóelem megadja az elérendő számot.  

A Current Number kijelző megjeleníti az éppen generált véletlenszámot.  

A # of iterations kijelző a futás végén megadja, hogy hány iterációs lépés 

történt az egyezés előtt.  

 

Az elfogadható számintervallum beállítása (Setting the Data Range) 
 

Használja a Data Range opciót annak megoldására, hogy a kiválasztott érték 

kompatibilis legyen a generált véletlenszámokkal. A hibajelzést, ha az adat nem 

megfelelő, tárgytalannak is tekintheti, vagy automatikusan helyettesítheti a helyes 

intervallumba eső értékkel. A következő lépésekkel az elfogadott adatok 0 és 10000 

közötti egész számok lesznek,  az előre beállított érték pedig 50. 

 

3. Kattintson a jobb egérgombbal a Number to Match beállítóra és válassza a  Data 

Range pontot a felbukkanó menüből. A Data Range párbeszédablak jelenik meg. 
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4. Törölje a bejelölést a Use Defaults jelölődobozban. 

5. Válassza a fenti dialóg ablakban található értékeket. 

6. Kattintson a OK gombra. 

 

A kijelzés pontosságának módosítása (Modifying Digits of 
Precision) 
 
Alapértelmezésként a LabVIEW a számokat fixpontosan, két tizedes pontossággal jeleníti 

meg, pl. 3.14. Használja a Format &Precision opciót a kijelzés pontosságának 

megváltoztatására, vagy a kijelzés formájának a változtatására (tudományos, mérnöki vagy 

óra/perc/másodperc módok). Állítsa a következő lépésekkel egész számok kijelzésre a 

megjelenítő elemeket.  

7. Kattintson a jobb egérgombbal a Current Number kijelzőre és válassza a Format 

& Precision pontot a megjelenő menüből. A Format&Precision dialóg ablak 

jelenik meg. 

 
8. Írjon 0-t a Digits of Precision szövegdobozba és kattintson az OK gombra. 

9. Ismételje meg a 7 és 8 lépéseket a # of iterations kijelzőre is. 
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Blokkdiagram 
 

 

10. Készítse el a következő blokkdiagramot. 

 

 
 

 

a. Helyezze el a Random Number (0-1) függvényt, ami a Functions»Numeric 

palettán található. Ez a függvényt véletlenszámokat hoz létre a 0 1 

intervallumban. 

b. Helyezze el a Multiply függvényt, ami a Functions»Numeric palettán 

található. Ez a függvény megszorozza a véletlenszámokat 10000-el. 

c. Hozzon létre egy, a szorzóelem y csatlakozójához kapcsolódó 10000 értékű 

állandót.  

d. Helyezze el a  Functions»Numeric palettán található Round To Nearest 

függvényt a blokkdiagramon. Ez a függvény kerekíteni fogja a véletlenszám- 

értékeket a legközelebbi egészre. 

e. Helyezze el a Functions»Comparison palettán található Not Equal? 

függvényt a blokkdiagramon. Ez a függvény összehasonlítja a véletlen- 

számokat a Number to Match -ban megadott értékkel és TRUE (igaz) 

értékkel tér vissza, ha a két szám egyenlő, különben FALSE (hamis) értékkel. 

f. Helyezzen egy While Loop ciklust a blokkdiagramra a Functions»Structures 

palettáról. A While Loop  határolóján megjelenő kék négyszöget alagútnak 

nevezzük. Az alagutak vezetnek adatokat a ciklusba és onnan kifelé. A 

kimenőadat a ciklusok befejezése utáni érték. Amikor az alagút adatot küld a 

ciklusnak, csak az adat megérkezése után kezdődik a ciklus végrehajtása. A 

While ciklus végrehajtódik, amíg az egyezés létre nem jön a véletlenszám és a 

beállított érték között. Minden végrehajtáskor a ciklusváltozó értéke eggyel nő. 

Az iteráció száma a ciklus befejezéskor kerül továbbításra. A számlálás 0-ról 

indul, ezért a végén még eggyel növelni kell az átadott az értéket, hogy 

megkapjuk az iterációk számát. 

g. Helyezze el az Increment függvényt, mely a  Functions»Numeric palettán 

található. Ez a függvény fogja eggyel növelni a While Loop számlálóját a 

ciklus befejezése után. 
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11. Mentse el a VI-t Auto Match.vi-ként. 

12. Jelenítse meg az előlapot és változtassa meg az értéket a Number to Match. 

beállító elemnél. 

13. Futtassa a VI-t. Változtassa meg a  Number to Match értékét és futtassa a VI-t 

ismét. A Current Number értéke minden iterációs lépésben megváltozik, míg a  # 

of iterations  csak az egyezés teljesülésekor, a ciklusból való kilépésnél jelenik 

meg. 

14. A kijelzők változásaink láthatóvá tételéhez kapcsolja be a nyomkövetést. 

15. Változtassa meg a Number to Match értékét egy olyan értékre ami kívül van az 

elfogadott értékeken.  

16. Futtassa a VI-t. A LabVIEW beállítja a legközelebbi egész értékre a számot, úgy 

hogy megfeleljen a specifikációnak.  

17. Zárja be a VI-t. 
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4-4 gyakorlat. Shift regiszterek használata (Shift Register 
Example VI) 

 

A shift regiszterek, amelyek a "While Loop" és a "For 

Loop" struktúrákban alkalmazhatók, értékeket adnak át egy 

iterációból a következõbe.  Shift regisztert úgy hozhatunk 

létre, hogy a ciklus struktúra bal vagy jobb oldali 

peremének felhívható menüjébõl kiválasztjuk a "Add Shift 

Register" (Adj hozzá egy shift regisztert) menüpontot. 

A shift regiszter definiálása után két darab kapcsolódási 

pontból áll, melyek egymással szemben, a ciklus struktúra 

peremének függõleges oldalán helyezkednek el. Az iteráció befejeztével a jobb oldali shift 

regiszter kapcsolódási pontja tárolja a kiszámított adatot. Az adat az iteráció végén kerül át a 

bal oldali shift regiszter kapcsolódási pontjába, és a következõ iterációban jelenik meg. A 

shift regiszter különbözõ adattípusokat tartalmazhat, így logikai, szöveges, tömb és más 

típusokat. A shift regiszter adattípusát a legelőször hozzá kapcsolt adattípusa határozza meg. 

 

Felkészíthetjük shift regisztert arra is, hogy megjegyezze a 

korábbi iterációkból származó értékeket. Ez különösen az 

adatok átlagolásánál hasznos. További kapcsolódási 

pontokat hozhatunk létre a korábbi iterációk értékeinek 

tárolásához. Ezt úgy érhetjük el, hogy a bal oldali shift 

regiszter kapcsolódási pontjának felhívható menüjébõl 

kiválasztjuk az "Add Element" (Adj hozzá további elemet) 

menüpontot. Például ha további két elemet adunk a bal 

oldali shift regiszter kapcsolódási pontjához, elérhetjük a három megelőző iteráció értékeit. 

 

Shift regiszterek kezdeti értékének beállítása 

 

A shift regiszter megadott kezdeti értékű 

beállításához kapcsoljunk kezdeti értéket a shift 

regiszter bal oldali kapcsolódási pontjához (a 

"While Loop"-on kívül). Ha a kezdeti értéket nem 

állítjuk be, a shift regiszter kezdeti értéke az az 

érték lesz, amely shift regiszter adattípusára 

jellemző. Például ha a shift regiszter logikai 

adattípusú, a kezdeti érték "False" (Hamis) lesz. Ha 

a shift register adattípusa numerikus, a kezdeti érték 0 (nulla) lesz. 

 

Megjegyzés: A LabVIEW  addig nem törli a shift regiszterben tárolt értéket, amíg a VI-t nem 

zárja be és nem távolítja el a memóriából. Vagyis, ha inicializálatlan shift regiszter-eket 

tartalmazó VI-t futtat, akkor a következő futtatás kezdeti értékei az előző futtatásból 

származnak. 
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4-5 gyakorlat. Átlaghőmérséklet megjelenítése 
(Temperature Running Average VI) 

 
Feladat: Shift regiszterek segítségével számolja ki az utolsó három 
hőmérsékletmérés átlagát 
 
Használja a korábban elkészített Hőmérséklet monitor VI-t kiindulásként, először mentse el a 

VI-t  új néven. 

 

 

Blokkdiagram 
 
Készítse el a következő blokkdiagramot. 

 

 
 

Tipp: Használja a 3 hőmérséklet adat összeadására a Functions»Numeric palettáról a 

Compound Arithmetic függvényt. A Positoning Tool segítségével növelje meg a bemenetek 

számát háromra. 
 

Egészítse ki a VI-t, hogy a hőmérséklet a pillanatnyi és átlagértéket is megjelenítse. A 

kiegészített VI a következő: 
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Az új elem a Bundle függvény, amely a  Functions»Cluster palettán található és két (vagy 

több) értékből egy rekordot képez, amit itt cluster-nak neveznek. A megjelenítő hullámforma 

diagram a bementén cluster esetén két görbét jelenít meg. 
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4-6 gyakorlat. Véletlenszámok átlagolása (Random Average 
VI) 

 
Feladat: Készítsen egy VI-t, amely két diagramot jelenít meg, az egyik a véletlenszámok 

sorozata, a másik az utolsó négy pont átlaga. A hullámforma diagramot használja 

pásztázó (sweep) módban. A While Loop helyett használja a For Loop-ot. 

 
A hullámforma diagramnak három működési módja van, amelyek közül választhatunk. A 

diagram felhívható menüjéből válasszuk ki a "Data Operations" (Adatműveletek) 

menüpontot, majd az "Update Mode" (Frissítési mód) menüelemet, ezután kiválaszthatjuk a 

"Strip Chart" (Szalagdiagram), a "Scope Chart" (Szkóp diagram) vagy a "Sweep Chart" 

(Pásztázó diagram) üzemmódok valamelyikét. 

 

A "Strip Chart" (Szalagdiagramnak) egy görgető típusú megjelenítője van, amely hasonlít egy 

papírszalagos diagramrajzolóhoz. A  "Scope Chart" (Szkóp diagram) és a "Sweep Chart" 

(Pásztázó diagram)-oknak pedig az oszcilloszkóp képernyőjéhez hasonló megjelenési 

formájuk van. Mivel a "Scope Chart" és a "Sweep Chart" diagramoknál kisebb memória 

területet kell mozgatni a rajzok frissítéséhez, ezek sokkal gyorsabb megjelenítők, mint a 

"Strip Chart" diagram típus. A "Scope Chart" (Szkóp diagram) -ban, amikor a rajzolás eléri a 

grafikus ábrázolás keretének jobb oldalát, a terület törlődik és a bal oldalról újra kezdődik a 

rajzolás. A "Sweep Chart" (Pásztázó diagram) hasonlóan működik, mint a "Scope Chart" 

(Szkóp diagram), de a megjelenítőt nem törli le, amikor a rajzolás a keret jobb oldalához ér. 

Ehelyett egy mozgó függőleges vonal (marker) jelzi, hogy hol vannak az újonnan rajzolt 

adatok a diagramban. 

 

A "For Loop" egy megadott számszor megismétli az általa 

bekeretezett blokk diagramot. A "For Loop"-ot a "Functions" 

(Függvények) paletta "Structures" (Struktúrák) alpalettájáról 

választhatjuk ki, majd bekeretezhetjük azt a blokkdiagram 

részletet, amelyet a "For Loop"-ban akarunk ciklikusan 

megismételni. A "For Loop" egy méreteiben 

megváltoztatható doboz. A "For Loop"-nak két kapcsolódási 

pontja van, ezek: 

 a ciklus végérték (  ) és az  

 iterációs kapcsolódási pont. (  )  

A ciklus végérték kapcsolódási pont megadja, hogy hányszor fusson le a ciklus. Az iterációs 

kapcsolódási pont pedig tartalmazza a lefutott ciklusok számát. 

 

A "For Loop" és a "While Loop" között az a különbség, hogy a "For Loop" esetében 

előzetesen meghatározzuk, hogy hányszor fusson le a ciklus. A "While Loop"-ban viszont a 

VI addig ismétli meg a bekeretezett blokk diagramot, amíg a feltétel kapcsolódási ponthoz 

tartozó logikai érték "True" (Igaz) értékű. A "For Loop"-nak megfelelő pszeudo-kód a 

következő: 

 

For i = 0 to N-1 

  {Blokk diagram a struktúrában} 
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További feladatok 
 
4-7 A While Loop felhasználásával készítsen egy VI-t, amely úgy működik, mint a For Loop 

és While Loop kombinációja, azaz akkor áll meg, amikor elér egy beállított számú 

iterációt, vagy az előlapon átkapcsolnak egy kapcsolót. Mentse el,  Combo While-

For Loop.vi néven. 

 

4-8 Készítsen egy VI-t, ami folyamatosan méri a hőmérsékletet másodpercenként és 

megjeleníti a mért adatokat egy szkóp diagramon. Ha a hőmérséklet meghalad egy 

felső, illetve egy alsó korlátot akkor kigyújt egy LED-et az előlapon. A diagramra 

rajzolja fel a hőmérsékletet és az alsó felső korlátját is. Az alsó és felső korlát legyen 

állítható az előlapról. Mentse a VI-t  Hőmérséklet-korláttal.vi néven. 

 

4-9 Módosítsa az előbbi VI-t, hogy megjelenítse ez elért maximális és minimális 

hőmérsékleteket.  

 

Megjegyzés: Használja a shift regisztereket és a Max & Min függvényeket, amelyek a 

Functions»Comparison palettán találhatók. Mentse el a VI-t  Hőmérséklet-

korláttal(max-min).vi néven. 
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5-1 gyakorlat: Tömbök használata (Array Exercise) VI 
 
Tárgy: Tömbök létrehozása; ismerkedés a tömbök függvényeivel.  
 

 A következő lépésekben létre fog hozni egy új VI-t, amely egy véletlenszámokból álló 

tömböt generál, majd átskálázza a tömb elemeit és végül kiválasztja a tömb egy részét. 

 

Előlap 
1. Hozzon létre egy új VI-t és készítse el a következő panelt. 

 

 
 

a. Helyezzen az előlapra egy tömböt a Controls»Array & Cluster palettáról.  

b. Írja be a tömb címkéjébe a „Random Array” nevet és kattintson a címkén 

kívülre, vagy az Enter gombra az eszközsávon. 

c. A Controls»Numeric palettáról helyezzen egy digitális kijelzőt a tömb 

keretébe.  

d. A „Positioning tool” eszközzel jobbra növelje meg a tömb méretét úgy, 

hogy 10 digitális kijelző jelenjen meg.  

e. A <Ctrl> billentyűt lenyomva tartva kattintson a tömbre, a bal egérgombot 

lenyomva tartva a tömböt húzza lefelé és az egérgombot felengedve 

(drag&drop) egy másolat tömb hozható létre. A „Random Array” két 

másolatát hozza így létre.  

f. A címkék átírásával nevezze át a másolatokat „Final Array” és 

„Subset Array”-re. 

g. A Controls»Numeric palettáról helyezzen az előlapra három digitális 

beállító elemet és nevezze át őket rendre a „Scaling Factor” „Start 

Subset” és „# of Elements” nevekre. 

h. Jobb egérgombbal kattintva „Start Subset” és „# of Elements” 

nevű elemekre a Representation menüpontban az I32 típus kiválasztásával 

állítsa egész szám típusúra a két elemet. 

i. Az előlap három digitális beállító elemének számértékét egyelőre ne 

változtassa meg. 
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Blokkdiagram 
 

2. Jelenítse meg (Window»Show Diagram), majd  állítsa össze a következő 

blokkdiagramot. 

  
 

 

a. A Functions»Numeric palettáról helyezzen diagramba egy „Random 

Number (0-1)” függvényt. Ez a függvény 0 és 1 közé eső véletlenszámot 

generál. 

b. A Functions»Structures palettáról helyezzen a diagramba egy „For 

Loop”-ot. Ez a ciklus egy 10 véletlenszámból álló tömböt szolgáltat a 

kimeneti csatornáján, amennyiben egy 10 értékű konstanst köt a ciklus 

végérték (  ) kapcsolódási pontra. 

c. A Functions»Array palettáról helyezzen a diagramba egy „Array Subset” 

függvényt. Ez a függvény a bemeneti tömbből a „Start Subset” által 

megadott elemtől kezdődően a „# of Elements” által megadott 

elemszámú résztömböt állít elő.  

d. Huzalozza össze a blokkdiagram objektumokat, ahogy a blokkdiagram ábra 

mutatja. 

 

3. Mentse el a VI-t  Array Exercise.vi  néven. 

 

4. Váltson át előlap nézetre, változtassa meg a beállító elemek értékeit és futtassa 

néhányszor a VI-t. A „For Loop” 10 cikluslépést hajt végre. Minden lépésben egy 

véletlenszámot állít elő a kimeneti csatornában, és a „Random Array” tömbben 

tárolja el őket. A VI a „Random Array” tömb minden elemét megszorozza a 

„Scaling Factor” értékével és a „Final Array”-be írja az eredményt. Ezután 

ebből előállít a „Start Subset” által megadott elemtől kezdődően a „# of 

Elements” által megadott elemszámú résztömböt.   

 

5. Zárja be a VI-t. 
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5-2. gyakorlat. Grafikus hullámforma tömb (Graph 
Waveform Array) VI  

 
Tárgy: Egy For ciklussal automatikusan indexelt tömb létrehozása és 
kirajzolása egy hullámforma grafikonon 
  
Készítsen egy a VI-t, amely készít egy tömböt, és azt egy hullámforma grafikonon ábrázolja. 

Módosítsa a VI-t úgy, hogy egyidejűleg több grafikont is megjelenítsen. 

 

Előlap 
 

1. Hozzon létre egy új VI-t és készítse el a következő panelt.  

 

 
 

a. Helyezzen az előlapra egy tömböt a Controls»Array & Cluster palettáról.  

b. Nevezze át  „Waveform Array” névre. 

c. A Controls»Numeric palettáról helyezzen egy digitális kijelzőt a tömb 

keretébe.  

d. A Controls»Graph palettáról helyezzen egy hullámforma grafikont a 

panelre. 
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Blokkdiagram 
 

2. Állítsa össze a következő blokkdiagramot  

 

 
 

 
Tipp: Az adatok grafikonba történő irányításánál használja a Context Help ablakot a helyes 

huzalozás és a „Build Array” illetve „Bundle” függvények helyes használatának 

meghatározására.  Általában a „waveform chart” hullámforma diagram egyedi skalár pontok, a 

„waveform graph” hullámforma grafikon az y tömb elemei, az „XY” grafikon pedig az x és y 

tömbelem párok értékekeinek megjelenítésére  használható. 

 Példaként, ha a Help»Examples»Fundamentals»Graphs and Charts»Waveform Graph 

VI példában a blokkdiagramon a kurzort a hullámforma grafikon terminál felé állítjuk a 

következő információ jelenik meg a Context Help ablakban. 

 

 
 

a. A Functions»Select a VI palettaművelettel keresse meg a 

d:\exercises\ LV Basics I\sajatnev mappában a  

Thermometer VI-t, amit a 3-2. gyakorlatban hozott létre, és dupla 

kattintással helyezze a blokkdiagramra. Ez a VI a For Loop minden 

ciklusában egy szimulált a hőmérsékletadatot állít elő. 

b. A Functions»Structures palettáról helyezzen a diagramba egy „For 

Loop”-ot. Minden For ciklus egy a hőmérsékletadatot állít elő és tárol. 

Állítson be egy 100 értékű konstanst a ciklus végérték kapcsolódási 

ponton. 

 

3. Mentse el a VI-t  Graph Waveform Array.vi néven.  

 

4. Váltson át előlap nézetre és futtassa a VI-t. A VI felrajzolja az automatikusan 

indexelt tömböt a hullámforma grafikonon.  
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5. Írja be a „Waveform Array” tömb bármely elemének indexét a tömb 

indexkijelzőjébe, hogy megjelenjen az adott indexű elem értéke. Ha a tömb 

méreténél nagyobb számot ír be, akkor a kijelző inaktívan elszürkül. 

 

6. A „Positioning tool” eszközzel méretezze át a tömbkijelzőt úgy, hogy több elem is 

látszódjon. A kijelző így a beírt indexértéktől kezdve növekvő indexsorrendben 

jeleníti meg az elemeket.  

 

7. Váltson vissza blokkdiagram nézetre. Ebben most az alapértelmezett kezdő x és x 

értéket használta. Abban az esetben, ha a hullámforma tömbnek speciális a kezdő x 

és a x értéke, úgy a „Bundle” függvénnyel ez is beállítható. 

 

8. Módosítsa a következő módon a blokkdiagramot: 

 

 
 

a. A Functions»Cluster palettáról helyezzen a diagramba egy „Bundle” 

függvényt. Ez a függvény a rajzolási elemeket egy csoportba gyűjtve állítja be: 

a kezdő x0 (=20) érték, a x (=0.5) érték és a hullámforma adatok  y tömbje. 

 

b. Jobb egérgombbal a „Bundle” függvény ikonra kattintva és a menüből 

kiválasztva az Add Input pontot létrehozható a harmadik bemeneti 

csatlakozás. 

 

c. A Functions»Numeric palettáról helyezzen a diagramba két konstanst a kezdő 

x és a  x számára. A „Labeling tool” eszközzel először címkézze Dx -nek a 

x-et, majd újra a „Labeling tool” eszközzel válassza ki a D betűt és a Text 

Settings legördülő menüben állítsa át Symbol fonttípusra a () 

megjelenítéséhez. 

 

9. Váltson át előlap nézetre. 

 

10. Mentse és futtassa a VI-t. A VI a grafikonra ugyanazt a 100 pontot rajzolja fel, de 

20 kezdőértékkel és 0.5 lépésközzel az x-tengelyen. Egy valós idejű tesztben ez a 

grafikon egy 20 másodpercnél kezdődő, 50 másodperc alatt mért adatsornak 

felelne meg. 

 

11. Jobb egérgombbal kattintson a hullámforma grafikonra és a menüből válassza a 

Visible Items»GraphPalette pontot, hogy megjelenítse a grafikon palettát. A 

Zoom gombra kattintva a grafikon adatait részletesen megjelenítheti. 
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12. Jobb egérgombbal a hullámforma grafikonra kattintva és a menüből kiválasztva a 

Visible Items»Scale Legend pontot megjelenítheti a skála feliratozást.  

 

13. Váltson blokkdiagram nézetre. 

 

14. Állítsa be x0-t 0-ra, x-et 1-re.  
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Grafikonok több görbével (Multiple-Plot Graphs) 
Hozzon létre egy több görbét tartalmazó hullámforma grafikont úgy, hogy egy kétdimenziós 

(2D) tömböt konstruál a szokásosan egygörbés grafikonon ábrázolt adatokból. 

 

1. Készítse el az alábbi blokkdiagramot. 

 

 
 

a. A Functions»Numeric»Trigonometric palettáról helyezzen a diagramba 

egy szinusz függvényt, amely egy szinuszhullám pontjait megadó tömb 

elemeit fogja előállítani. 

b. A Functions»Array palettáról helyezzen a diagramba egy „Build Array” 

függvényt, amely a két tömb közös grafikonon történő felrajzolásához 

szükséges tömböt alakítja ki. Jobb egérgombbal a függvény ikonra 

kattintva és a menüből kiválasztva az Add Input pontot létrehozható a 

második bemeneti csatlakozás. 

c. A Functions» Numeric»Additional Numeric Constants palettáról 

helyezzen a diagramba egy  konstanst. 

d. Helyezze el a többi művelethez tartozó függvényeket és konstansokat, és 

huzalozza össze őket a fent látható módon. 

 

2. Váltson előlap nézetre. 

 

3. Mentse és futtassa a VI-t. A két görbét ugyanarra a grafikonra rajzolja a VI. 

 

4. Váltson vissza blokkdiagram nézetre. 

 

5. Jobb egérgombbal a „Waveform Array” tömb vezetékére kattintva és a menüből 

kiválasztva a Custom Probe»Graph»Waveform Graph pontot egy a vezeték 

adatait megjelenítő tesztgrafikont (szondát) lehet kirajzoltatni. 

 

6. Váltson előlap nézetre és futtassa a VI-t. A tesztgrafikonon csak a adattömb rajza 

jelenik meg, mivel a szinuszjelforrás vezetékére nem helyeztünk szondát. 

 

7. Zárja be a tesztgrafikon ablakát. 

 

8. Nagyítsa ki a grafikon egy részét. 

 

a. Kattintson a Zoom gombra a grafikus palettán és következő legördülő 

menü jelenik meg 
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b. Válassza ki Zoom by X Rectangle nagyítást, ahogy az ábra mutatja. 

c. A grafikonra kattintva, lenyomott egérgombbal kijelölhető a nagyítani 

kívánt tartomány. Az egérgomb felengedésekor a grafikonon csak a 

kiválasztott rész lesz látható. 

d. Próbálja ki a hasonlóan válaszható a Zoom by Y Rectangle vagy a Zoom 

by Selected Area nagyításokat is. 

e. A bal alsó Undo Zoom gombra kattintva visszaállítható a nagyítás előtti 

állapot. De ez elvégezhető a tengelyfeliratok mellett levő x-axis single fit 

és y-axis single fit gombokkal is. 

 

9. Használhatja a „Panning tool” eszközt is, hogy a grafikonkeret tartományán belül 

elmozdítsa a görbéket. 

 

10. Használja a „Cursor Movement tool” eszközt, hogy a kurzort normál módba állítsa 

vissza. 

 

 

11. Mentse és zárja be a VI-t. 
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5-3. gyakorlat.  Hőmérséklet analízis (Temperature 
Analysis) VI  

 
Tárgy: Hőmérsékleti adatok grafikus ábrázolása és analízise. 
  
 Készítsen egy a VI-t, ami 0.25 másodperces lépésközzel 10 másodpercig hőmérsékletet mér. 

Az adatgyűjtés alatt a VI a mért értékeket valós időben jeleníti meg egy hullámforma 

diagramon. A mérés befejezése után a VI az adatokat grafikonon ábrázolja és kiszámítja a 

maximum, minimum és átlagértékeket, majd megjeleníti a grafikonhoz illesztett görbét. 

 

Előlap 
 

1. Hozzon létre egy új VI-t és készítse el a következő front panelt az alábbi tippek 

alapján. 

 

 
 

 Kattintson a jobb egérgombbal a hullámforma diagram jelmagyarázó 

feliratára és a felbukkanó menü Point Style pontjában állítsa be a 

hullámforma diagramon a (x) pontstílust. 

 Kattintson a jobb egérgombbal a hullámforma diagramra és válassza a 

Visible Items»Plot Legend a felbukkanó menüből, hogy elrejtse a 

feliratot. 

 Kattintson a jobb egérgombbal a hullámforma diagramra és válassza a 

menüből az X Scale»Formatting pontot és állítsa be dX értékét 0.25-re 

a kijelzés pontosságát (Digits of Precision) két tizedes értékűre. 

 A „Positioning tool” eszközzel méretezze kétszeresre a hullámforma 

grafikon jelmagyarázó feliratát. 

 A „Labeling tool” segítségével nevezze át a Plot 0-t Temp-re és a 

Plot 1-et Fitted-re. 
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 Állítsa be a hullámforma grafikonon a Temp görbénél a négyzet () 

pontstílust  

 Egyelőre még ne építse meg a Mean, Max és Min kijelzőket. 

 

Blokkdiagram 
 

2. Készítse el az alábbi blokkdiagramot. 

 
        

a. A Functions»Select a VI menüpont használatával nyissa meg és helyezze 

a blokkdiagramra a 3-2. gyakorlatban elmentett Thermometer.vi-t. Ez a 

VI a For Loop minden ciklusában egy szimulált a hőmérsékletadatot állít 

elő. 

b. A Functions»Time & Dialog palettáról helyezzen egy „Wait Until Next 

ms Multiple” függvényt a blokkdiagramra és állítson be 250-es bemeneti 

értéket, amellyel a függvény a For Loop ciklusait 250 ms-ként időzíti. 

c. A Functions»Array palettáról helyezzen egy „Array Max & Min” 

függvényt a blokkdiagramra, amely a hőmérséklet maximum és minimum 

értékét számítja ki. 

d. A Functions»Mathematics»Probability and Statistics palettáról helyezze 

a „Mean” VI-t a blokkdiagramra, amely a mért hőmérséklet átlagértékét 

számítja ki. 

e. Kattintson a jobb egérgombbal a „Array Max & Min” függvény kimeneti 

vonalaira és legördülő menü Create»Indicator pontját választva hozza 

létre a Max, Min és Mean kijelzőket. 

f. A Functions»Mathematics»Curve Fitting palettáról helyezzen a „General 

Polynomial Fit” VI-t a blokkdiagramra, amely a mért hőmérsékletértékekre 

illesztett polinom tömbbe foglalt értékeit számítja ki. 

g. A Functions»Cluster palettáról helyezzen egy „Bundle” függvényt a 

blokkdiagramra, majd a <Ctrl> billentyű lenyomásával készítsen belőle egy 

másolatot. Ezek a függvények a rajzolási paramétereket állítják be és 

foglalják egy csoportba: x0 (=0), x (=0.25) és a mért hőmérsékletadatok 

y tömbje. Az grafikon rajzolásánál a  x paraméter 0.25-ös értéke meg 

kell, hogy egyezzen a hőmérsékletmérés lépésközével. 

 

h. A Functions»Array palettáról helyezzen a diagramba egy „Build Array” 

függvényt, amely a mért hőmérséklet adattömb és az illesztett polinom 

adattömb egyesítésével a közös grafikonon történő felrajzolásához 

szükséges tömböt alakítja ki.  



60 

 

3. Mentse el a VI-t „Temperature Analysis.vi” néven. 

 

4. Váltson előlap nézetre és futtassa a VI-t. A grafikonon mind a mért hőmérséklet 

értékek, mind az illesztett polinom is megjelenik. 

 

5. Próbáljon ki különböző rendű polinomokat az illesztésnél. 

 

6. A rajzolási és kitöltési minták (plot styles, fill styles) módosításával változtassa meg a 

grafikon megjelenését. 

a. Kattintson jobb egérgombbal a Temp grafikon Temp görbéjéhez tartozó 

jelmagyarázó feliratra és a legördülő menü Common Plots»Scatter Plot 

pontját választva különálló pontonkénti megjelenítést állítson be. 

b. Kattintson jobb egérgombbal a Temp grafikon Fitted görbéjéhez tartozó 

jelmagyarázó feliratra és a legördülő menü Bar Plots pontját választva 

oszlopdiagram típusú megjelenítést állítson be. A grafikonnak így hasonlítania 

kell a következő ábrához. 

 
 

7. Mentse és zárja be a VI-t. 
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5-4. gyakorlat. Kör grafikon (Graph Circle) VI  

 
Tárgy: Adatok ábrázolása X-Y grafikonon. 
  
 Készítsen egy a VI-t, ami egy kört rajzol független x és y tömbadatokból. 

 

 

Előlap 
 

1. Hozzon létre egy új VI-t és készítse el a következő front panelt. 

 

 
 

a. A Controls»Graph palettáról helyezzen fel egy XY grafikont. 

 

b. Írja át a grfikon cimkéjét XY Circle Graph-ra. 

 

c. Írja át a Plot 0 jelmagyarázat feliratot Circle-re. 

 

d. Kattintson a jobb egérgombbal a hullámforma diagram jelmagyarázó feliratára 

és a legördülő menü Point Style pontjában állítsa be a hullámforma diagramon 

a () pontstílust. 

 

e. Állítsa be a tengelyen a határokat és címkéket a fenti ábrának megfelelően. 

 

Blokkdiagram 
 

2. Készítse el az alábbi blokkdiagramot. 
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a. A Functions»Numeric»Trigonometric palettáról helyezzen egy „Sine & 

Cosine” függvényt, amely szinusz és a koszinuszhullám értékeit szolgáltatja. 

 

b. A Functions»Cluster palettáról helyezzen egy „Bundle” függvényt a 

blokkdiagramra. Ez a függvény a szinusz és koszinusz értékek tömbjeit 

foglalja egy tömbbe, hogy az adatpárok egy kört rajzoljanak. 

 

c. A Functions» Numeric»Additional Numeric Constants palettáról helyezzen 

a diagramba egy 2 konstanst. 

   

3. Mentse el a VI-t „Circle.vi” néven. 

 

4. Váltson előlap nézetre és futtassa a VI-t. 

 

5. Zárja be a VI-t. 
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5-5. gyakorlat. Cluster-ek (Objektumcsoportok) VI  

 
Tárgy:  Cluster-ek létrehozása és azok felbontása illetve összeállítása Cluster 

függvényekkel 
  
 

Előlap 
 

1. Hozzon létre egy új VI-t és készítse el a következő front panelt. 

 

 
a. Helyezzen el egy Stop gombot, egy digitális kijelzőt és egy kerek LED-et a 

panelen. 

b. A Controls»Array & Cluster palettáról helyezzen el egy clustert. 

c. A clusterbe helyezze el a fenti négy objektumot. 

d. Az előbbi cluster duplikálásával hozzon létre egy másolat clustert, címkézze át 

Modified Cluster névre, majd jobb egérgombbal rákattintva numerikus 

beállító elemre a Change to Indicator menüponttal állítsa át kijelzőre. 

e. A d. pont lépéseivel hozza létre a Small Cluster nevű clustert és az ábrának 

megfelelő módon változtassa meg a kijelzőit. 

 

2. Ellenőrizze a clusterekben belső elemsorrendet a Cluster és a Modified Cluster 

elemsorrendje meg kell, hogy egyezzen. 

a. Kattintson jobb egérgombbal az ellenőrizendő cluster keretvonalára és a 

legőrdölő menüből a Reorder Controls in Cluster-t kiválasztva változtassa 

meg az elemek sorrendjét, ha szükséges. 

b. A felső megjelenítősorban látható sorszám a cluster elemeinek keretébe 

kattintva az egyes elemekhez rendelhető. A következő ábrán látható 

elemsorrendet állítsa be.  
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Blokkdiagram 
 

3. Készítse el az alábbi blokkdiagramot.  

 

 
 

a. A Functions»Cluster palettáról helyezzen egy „Unbundle” függvényt a 

blokkdiagramra, amely a clustert elemeire bontja. Méretezze át a függvény 

ikonját, vagy huzalozza a bemenetére a Cluster-t, hogy négy kimenet jelenjen 

meg.  

b. A Functions»Cluster palettáról helyezzen egy „Bundle” függvényt a 

blokkdiagramra, amely a Small Cluster-t összeállítja. 

c. A Functions»Cluster palettáról helyezzen egy „Unbundle by Name” 

függvényt a blokkdiagramra, amely a cluster elemeire bontja és adott számú 

elemet ad a kimeneten. Méretezze át a függvény ikonját, hogy két kimenet 

jelenjen meg. Ha nem a kívánt elem címkéje látszik, akkor kattintson a jobb 

egérgombbal a címkére és a legördülő menü Select Item pontjával válassza ki 

a kívánt elemet. 

d. A Functions»Numeric palettáról helyezzen egy „Increment” függvényt a 

blokkdiagramra, amely a Numeric értékét növeli meg eggyel. 

e. A Functions»Boolean palettáról helyezzen egy „Not” függvényt a 

blokkdiagramra, amely a Boolean értékét negálja.  

 

f. A Functions»Cluster palettáról helyezzen egy „Bundle by Name” függvényt a 

blokkdiagramra, amely Cluster kimeneti vonalában a Numeric és Boolean 

értékét lecséréli és létrehozza a Modified Cluster-t. Méretezze át a függvény 

ikonját, hogy két bemenet jelenjen meg. Ha nem a kívánt elem címkéje látszik, 
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akkor kattintson a jobb egérgombbal a címkére és a legördülő menü Select 

Item pontjával válassza ki a kívánt elemet. 

g. Kattintson a jobb egérgombbal a While Loop feltételének szimbólumára és a 

legördülő menüből válassza ki a Stop If True pontot. Így a VI futása akkor 

fog megállni, ha a feltételhez huzalozott Stop gombra kattint.  

 

4. Mentse el a VI-t „Cluster Exercise.vi” néven. 

 

5. Váltson előlap nézetre és futtassa a VI-t. 

 

6. Írjon be különböző értékeket a Cluster-be és futtassa újra a VI-t. 

 

7. Zárja be a VI-t. 
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5-6. gyakorlat. Cluster átskálázás (Cluster Scaling) VI  

 
Tárgy:  Cluster-ek egymásra való leképezése 
 
  
Készítsen egy a VI-t, ami elemenként különböző faktorokkal átskálázza a cluster-ben tárolt 

adatokat. A VI egy feltételezett mérőrendszerben a nyomást, az átfolyási sebességet és a 

hőmérsékletet mérő átalakítók feszültségértékeit skálázza úgy át, hogy végeredményül a mért 

eredeti mennyiségek értékeit kapjuk. 
 

 

Előlap 
 

1. Nyissa meg a d:\exercises\LV Basics I mappában a Cluster Scaling VI-t. A 

front panel már meg van építve. 

 

2. A front panelen a Raw Data cluster beállító elemein állítsa be az alábbi értékeket 

 

 

 
 

 
Blokkdiagram 
 

 

3. Készítse el az alábbi blokkdiagramot. A Functions»Cluster palettáról helyezzen egy 

„Cluster Constant” keretet a blokkdiagramra és ebbe helyezzen numerikus 

konstansokat.  Ellenőrizze, hogy mindenhol a megfelelő skálafaktor értéket 

alkalmazta-e a Raw Data cluster elemei számára. 
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4. Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába  „Cluster 

Scaling.vi” néven. 

 

5. Váltson előlap nézetre és futtassa a VI-t. 

 

6. Változtasson a beállítók értékein és futtassa újra a VI-t. 

 

7. Zárja be a VI-t. 
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További feladatok 
 
 
5-7 Készítsen egy VI-t, amely egy 100 véletlenszámból álló tömb elemeinek a sorrendjét 

megfordítja. Például a tömb 99. elemének az értéke a tömb korábbi 0. elemének értéke 

lesz (array[0] → array[99], array[1] →[98], …, stb.). 

Tipp:  A tömbsorrend megfordításához használja a Functions»Array palettáról a „Reverse 

1D Array” függvényt. 

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába „Reverse 

Random Array.vi” néven. 

 

5-8 Készítsen egy VI-t, amely a Temperature Array tömbbe gyűjti a 3-2. gyakorlatban 

létrehozott (d:\exercises\ LV Basics I\sajatnev mappába mentett) 

Thermometer subVI adatait. A tömb méretét az előlapon elhelyezett beállító 

elemmel állítsa be. Inicializáljon egy az előzővel megegyező méretű Initialized Array 

nevű tömböt az „Initialize Array” függvénnyel úgy, hogy minden elemének értéke 10 

legyen. Adja össze a két tömböt, az eredményül adódó Final Array tömb méretét 

határozza meg és olvassa ki a középső elemének az értékét (Mid Value). Jelenítse 

meg a Temperature Array, Initialized Array, Final Array és Mid Value 

objektumokat. 

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába „Find 

Mid Value.vi” néven. 

5-9 Készítsen egy VI-t, amely egy 3 sorból és 10 oszlopból álló, kétdimenziós, 

véletlenszámokból álló tömböt állít elő, majd minden egyes sort indexel és külön 

grafikonon jelenít meg. Az előlap így 3 grafikont fog tartalmazni.  

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába „Extract 

2D Array.vi” néven. 

5-10 Készítsen egy VI-t, amely egy dobókockával való dobást szimulál (1, 2, 3, 4, 5, 6 

lehetséges értékekkel) és minden egyes értékhez rögzíti, hogy az hányszor fordult elő. 

A bemeneti érték a dobások száma, a kimeneti értékek az egyes értékek előfordulási 

számai. Csak egy shift regisztert használjon a megoldásban. 

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába „Die 

Roller.vi” néven. 

 

5-11 Készítsen egy VI-t, amely generál egy véletlenszámokból álló egydimenziós tömböt, 

majd páronként összeszorozza az egymás utáni elemeit (0-s elemet az 1-essel, 2-es 
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elemet a 3-assal, …) és az eredményeket egy kimeneti tömbben tárolja. (Pl. az 1 23 

10 5 7 11 tömbhöz a 23 50 77 eredménytömb tartozna.) 

Tipp:  Használja a Functions»Array palettán található „Decimate 1D Array” függvényt. 

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába „Array 

Pair Multiplier.vi” néven. 
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6-1 gyakorlat: Négyzetgyök „Square Root” VI 
 
Tárgy: A „Case” feltételes struktúra használata.  
 

 Készítsen egy új VI-t, amely első lépésben leellenőrzi, hogy a bemeneti szám negatív-e. Ha 

nem negatív, akkor kiszámítja a szám négyzetgyökét, negatív esetben pedig hibaüzenetet ad 

vissza. 

 

Figyelmeztetés Ne futtassa folytonos módban ezt a VI-t! 

 

Előlap 
 

1. Hozzon létre egy új VI-t és készítse el a következő panelt. 

 

 
 
Blokkdiagram 
 

2. Állítsa össze a következő blokkdiagramot. 

 
 

a. A Functions»Structures palettáról helyezzen diagramba egy „Case” 

feltételes strukturát.  

b. A keret tetején lévő gombra kattintva állítsa be a „FALSE” hamis 

logikai esetet. 

c. A Functions»Comparison palettáról helyezzen a diagramba egy 

„Greater or Equal to 0?” függvényt. Ez a függvény a logikai igaz 

„TRUE” értéket ad vissza, ha a bementi szám nullától nagyobb vagy 

egyenlő.  

d. Helyezzen el egy numerikus konstanst a „Case” struktúrába és jobb 

egérgombbal a  konstansra kattintva és a menüből kiválasztva a 

Format & Precision pontban állítsa a tizedesjegyek (Digits of 

Precision) számát 1-re és válasszon lebegőpontos számábrázolást 

(Floating Point Notation), majd kattintson az OK gombra. 

e. A Functions»Time & Dialog palettáról helyezzen a diagramba egy 

„One Button Dialog” függvényt. Ez a függvény egy párbeszédablakot 

jelenít meg majd a következő hibaüzenettünkkel: Hiba...Negatív 

Szám. 
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f. Jobb egérgombbal a „One Button Dialog” függvény „Message” 

kivezetésre kattintva, a menüből a Create»Constant pontot kiválasztva 

írja be a  Hiba...Negatív Szám  üzenetet. 

g. A „Case” struktúra keretének tetején válassza most a logikai igaz 

„TRUE” esetet és a Functions»Numeric palettáról helyezzen el egy 

„Square Root” függvény, ahogy a következő ábra mutatja.  

 

 
 

3. Mentse el a VI-t  Square Root.vi  néven.  

 

4. Váltson át előlap nézetre és futtassa néhányszor a VI-t. Ha a bementi számérték 0 vagy 

pozitív, akkor a VI a logikai igaz „TRUE” esetet hajtja végre és a Numeric értékének 

a négyzetgyökét szolgáltatja. Ha a Numeric negatív, akkor a VI a logikai hamis 

„FALSE” esetet dolgozza fel és –99999.0-t ad eredményül és egy párbeszédablakban 

megjeleníti a megadott hibaüzenetet. 

 

5. Zárja be a VI-t. 
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6-2 gyakorlat: Hőmérsékletszabályozó (Temperature 
Control) VI 

 
Tárgy: A „Case” feltételes struktúra használata.  
 

 Készítsen egy új VI-t, amely egy LED kigyújtásával és hangjelzéssel jelzi, ha a hőmérséklet 

kilép egy adott tartományból. 

 

 

Előlap 
 

1. Nyissa meg a „Temperature Running Average VI”-t, amelyet a 4-5. gyakorlatban 

hozott létre. 

 

2. Módosítsa az előlapot a következő módon. 

 

 
 

3. Jobb egérgombbal kattintson a hullámforma diagramra és a legördülő menüből 

válassza a Visible Items»Digital Display pontot, hogy a számértékek 

megjelenjenek. 

 

4. Mentse el a VI-t  „Temperature Control.vi” néven. 

 



73 

Blokkdiagram 
 

5. A blokkdiagramot a következő ábrának megfelelően módosítsa. A „Case” 

feltételes struktúra hamis logikai értékhez tartozó „FALSE” ablaka üres. 

 

 
 

 

a. A Functions»Comparison palettáról helyezzen diagramba egy „Greater?” 

függvényt. Ez a függvény logikai igaz (TRUE) értéket ad majd, ha a 

hőmérséklet a High Limit változóban megadott értéknél nagyobb lesz. 

b. A Functions»Graphics&Sound»Sound palettáról helyezzen a „Case”  

struktúrába a „Beep VI”-t, amely így hangjelzést ad, ha a struktúra logikai 

igaz (TRUE) értéket kap a bemenetére.  

 

6. Mentse el a VI-t. 

 

7. Váltson előlap nézetre és adjon 80-as értéket a High Limit-változónak és futtassa a 

VI-t. Ha a Thermometer VI által adott hőmérsékletérték nagyobb, mint a High 

Limit értéke, akkor a Warning figyelmeztető LED kigyullad és a VI hangjelzést ad. 

Ha a hőmérsékletérték kisebb, mint a High Limit értéke, akkor Warning LED 

elalszik és a hangjelzés véget ér. 

 

8. Zárja be a VI-t. 
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6-3 gyakorlat: Futási idő (Time to Match) VI” 

 
Tárgy: A Sequence struktúra használata.  
 

 Hozzon létre egy új VI-t, amely meghatározza, hogy mennyi időbe telik, amíg a számítógép 

által ciklikusan generált véletlenszám megegyezik egy előre megadott értékkel.  

 

Előlap 
1. Nyissa meg az „Auto Match” VI-t, amelyet a 4-3. gyakorlatban készített. 

 

2. Módosítsa az előlapot a következő ábrának megfelelően. 

 

 
 

a. Változtassa a Number to Match, Current Number, és # of iterations 

változók típusát I32 egész típusúra.  

b. Változtassa a Time to Match típusát DBL típusúra és állítson be 3 tizedes 

jegy pontosságot.  

 

3. Mentse el a VI-t  „Time to Match.vi” néven. 

 

4. A blokkdiagramot a következő ábrának megfelelően módosítsa. 
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a. A Functions»Structures palettáról helyezzen egy „Sequence”  struktúrát a 

diagramba. 

b. Jobb egérgombbal kattintson a struktúra határvonalára és a legördülő 

menüből az Add Frame After pontot választva adjon hozzá egy keretet. 

c. A Functions»Time&Dialog palettáról helyezzen egy „Tick Count (ms)”  

függvényt a diagramba, amely az operációs rendszeróra állásának aktuális 

értékét olvassa be és adja meg milliszekundumokban. 

 

5. Mentse el a VI-t. 

 

6. Váltson előlap nézetre, adjon meg egy értéket a Number to Match változónak és 

futtassa a VI-t. A 0-s számú keretben a VI addig hajtja végre a While Loop-ot, 

amíg a Current Number értéke meg nem egyezik a Number to Match értékével. 

Az 1-es keretben pedig a „Tick Count (ms)” függvény beolvassa az operációs 

rendszeróra állásának aktuális értékét, majd ezt kivonva az indulási időből 

kiszámítja és másodpercekben megadja az eltelt időt. 

 

 Megjegyzés: Ha a Time to Match mindig 0.000, akkor a VI valószínűleg túl gyorsan fut. 

Ekkor vagy a végrehajtás nyomon követése (Highlight Execution) módban futtassa a VI-t, 

vagy növelje meg a 0-s számú keretben a szorzás függvény bemenetén a konstans értékét 

1000000-ra. 

 

7. Zárja be a VI-t. 
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6-4 gyakorlat: „Formula Node Exercise VI” 

 
Tárgy: A „Formula Node” használata.  
 

 Hozzon létre egy új VI-t, amely a „Formula Node” használatával komplex matematikai 

műveleteket hajt végre és ábrázolja az eredményeket.  

 

Előlap 
 

1. Hozzon létre egy új VI-t és készítse el a következő előlapot. 

 

 
 

2. Készítse el a következő blokkdiagramot. 

 

 
 

a. A Functions»Structures palettáról helyezzen diagramba egy „Formula 

Node” struktúrát.  

b. Jobb egérgombbal kattintson a struktúra bal határvonalára és a legördülő 

menüből az Add Input pontot választva hozzon létre egy x bemeneti 

vonalat. 

c. Az előző ponthoz hasonlóan -az Add Output menüpontot választva- a 

keret jobb oldalán hozzon létre egy y és egy a kimeneti vonalat. (Kimeneti 

vonalat a keretben szereplő a ideiglenes változónak is meg kell adni.) 
 
Megjegyzés: A be- és kimeneti vonalak elnevezésénél pontosan ugyanazokat a 

neveket kell használni, mint amelyeket a változók az egyenletekben viselnek. A kis- 

és nagybetűk is meg vannak különböztetve.  

 

d. A „Formula Node”-ba írja be a következő egyenleteket. (A ** jel 

hatványozást jelent. A LabVIEW Help-ben megtalálható az egyenletek 

szintaktikájának részletes leírása.) 
a = tanh(x) + cos(x); 



77 

y = a**3 + a; 

 

3. Mentse el a VI-t  „Formula Node Exercise.vi” néven. 

 

4. Váltson előlap nézetre és futtassa a VI-t. A VI grafikonra rajzolja az  

y=f(x)
3
+f(x)függvényt, ahol f(x)=tanh(x)+cos(x). Minden 

cikluslépésben a VI a ciklusszámláló értékét 15-tel elosztja, és ez kerül a Formula 

Node bemenetére, amely kiszámítja vele a függvényértéket. Az eredménytömb a 

hullámforma grafikonon jelenik meg. 

 

5. Zárja be a VI-t. 
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További feladatok 
 
6-5 Készítsen egy VI-t, amely a Formula Node segítségével kiszámítja az alábbi 

egyenletek által megadott függvények értékeit: 

y1=x
3
+x

2
+5;  

y2=mx+b; 

Mindkét egyenletet ugyanabban a Formula Node-ban számítsa ki, használja a 

pontosvesszőt (;) a beírásnál az egyenletek után. 

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába 

„Equations.vi” néven. 

6-6 Készítsen egy VI-t, amely ügy működik, mint egy zsebszámológép. Az előlapon 

használjon digitális beviteli eszközöket a két bemeneti szám megadására, és egy 

kijelzőt a művelet eredményének kijelzésére. Használjon egy „slide control” beviteli 

eszközt a művelet (összeadás, kivonás, szorzás, osztás) kiválasztására. 

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába 

„Calculator.vi” néven. 

6-7 Módosítsa a 6-1. gyakorlatban készített „Square Root” VI-t így, hogy az az 

számításokat és a feltételvizsgálatokat Formula Node-dal végezze.  

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába „Square 

Root 2.vi” néven. 

6-8 Készítsen egy két bemenettel (Threshold és Input Array) és egy kimenettel (Output 

Array) rendelkező VI-t, amelynél a kimeneti Output Array a bemeneti Input Array 

azon elemeit tartalmazza,  amelyek nagyobb értékűek mint a Threshold.  

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába „Array 

Over Threshold.vi” néven. 

Készítsen egy másik VI-t, amely 0 ás 1 közé eső véletlenszámokból álló tömböt 

generál, majd ebből az előbbi  „Array Over Threshold” VI-t felhasználva, a 

kimeneti tömbbe a 0.5-nél nagyobb elemeket helyezi. 

Mentse el a VI-t a d:\exercises\LV Basics I\sajatnev mappába „Using 

Array Over Threshold.vi” néven. 
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7-1 gyakorlat: String-műveletek (Build String) VI 

 
Tárgy: A Format Into String, Concatenate Strings és a String Length 
függvények használata  
 

 Hozzon létre egy új VI-t, amely egy numerikus változót szöveges változóvá (string-gé)  alakít 

át, összefűzi a string-et egy másikkal és az így kapott kimeneti string-nek meghatározza a 

hosszát. A VI emellett még megkeres egy mintát a string-ben, majd a string maradék részét 

újra numerikus változóvá konvertálja.  

 

Előlap 
 

1. Hozzon létre egy új VI-t és készítse el a következő panelt. 

 

 
 

a. Jobb egérgombbal kattintson a String 2 és a legördülő menüből válassza a 

‘\’ Codes Display pontot.  

b. Változtassa String Length és Offset Past Match típusát I32-re. 
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Blokkdiagram 
 

2. Készítse el a következő blokkdiagramot. 

 

 
 

a. A Functions»String palettáról helyezzen diagramba egy „Format Into 

String” függvényt. Ez a függvény egy numerikus változót string-gé  alakít át. 

  

b. Jobb egérgombbal kattintson a „Format Into String” függvényre és a 

legördülő menüből válassza az Edit Format String pontot. 

 

c. A párbeszédablakban jelölje be a Use specified precision négyzetét és 

írjon 4-et a szövegmezőbe.  

 

d. Kattinson az OK gombra. A LabVIEW létre hozza a %.4f format string-

et, amely a Numeric változó négy tizedesjegyű alakját string-gé alakítja. 

 

e. A „Labeling tool” segítségével írjon be egy-egy szóközt a %.4f konstans 

mindkét oldalára és nyomja le a <Shift-Enter> billentyűket, így a konverzió 

után a Numeric két szóközzel közbefogva fog szerepelni a Combined String-

ben. 

 

f. Ha a jobb egérgombbal a konstansra kattint és a legördülő menüből 

kiválasztja a ‘\’ Codes Display pontot, akkor a szóközök \s kódalakban 

jelennek meg. 

 

g. A Functions»String palettáról helyezzen diagramba egy „Concatenate 

Strings” függvényt. Ez a függvény a bemeneti string-eket egy kimeneti string-

be fűzi össze.  

 

h. A Functions»String palettáról helyezzen diagramba egy „String Length” 

függvényt. Ez a függvény a Combined String karaktereinek a számát adja 

eredményül.  

 

i. A Functions»String palettáról helyezzen diagramba egy „Match Pattern” 

függvényt. Ez a függvény megkeresi a megadott (kettőspont) karaktert a 

String 2-ben.   
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j. Jobb egérgombbal kattintson és a regular expression bemeneti 

csatlakozásra és a legördülő menüből válassza ki a Create» Constant pontot, 

irjon be egy kettőspontot (:) és nyomja le a <Shift-Enter> billentyűket. 

 

k. A Functions»String palettáról helyezzen diagramba egy „Scan from 

String” függvényt. Ez a függvény a megadott (kettőspont) karakter utáni részt 

numerikus változóvá alakítja át. 

 

 

3.  Váltson előlap nézetre és készítse el a következő ikont és a kapcsolódási pontokat, 

hogy a VI-t subVI-ként használhassa a későbbiekben. (Ha szükséges, az ikonok és 

a kapcsolódási pontok létrehozásához nézze át a 3. gyakolatban a SubVI 

létrehozása című fejezetet [Creating a SubVI].) 

 

 
 

4. Mentse el a VI-t  „Build String.vi” néven, mivel később még szükség lesz rá. 

 

5. Változtassa meg az előlapon a változók értékeit, majd futtassa újra a VI-t. A VI 

összefűzi a Header, Numeric, és Trailer változókat Combined String-gé és 

megjeleníti string hosszát. A VI emellett még megkeresi a kettőspontot a String 2-

ben, majd a kettőspont utáni részt Numeric Out numerikus változóvá konvertálja 

és megjeleníti a kettőspont utáni első karakter sorszámát (Offset Past Match.) 

 

6. Mentse el és zárja be a VI-t. 
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7-2 gyakorlat: Fájlba író VI  (File Writer VI) 

 
Tárgy: Adatok fájlba írása 
 

Készítsen VI-t, mely szöveget, számadatot és mértékegységet fűz össze egy fájlba. A 7-3 

gyakorlatban készítendő VI ezt a fájlt fogja majd beolvasni és tartalmát a képernyőn 

megjeleníteni.    

 

Előlap 
 

1. Hozzon létre egy új VI-t és készítse el a következő előlapot. 

 

 
 

a.   A Controls » String & Path palettáról helyezzen el egy elérési út (path) kijelzőt 

az előlapon. Ez jelzi a létrehozandó adatfájl helyét a merevlemezen.    

 

b.  Jobb egérgombbal kattintson a String to Write (kiírandó szöveg) területre és válassza 

ki a Visible Items » Scrollbar opciót a görgetősáv megjelenítéséhez. 

 

Blokkdiagram 
 

2.   Készítse el a következő blokkdiagramot: 
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j. Helyezze el a 7-1 gyakorlat során elkészített „Build String” VI-t a  

diagramon. Ez a VI három bemeneti stringet fűz össze egy összetett 

karakterlánccá. 

 

k.  A Functions » File I/O palettáról illessze be az Open/Create/Replace File 

VI-t a diagramba. Ez a VI egy párbeszédablakot jelenít meg fájlok 

létrehozásához vagy megnyitásához 

 

l. .Az Enter Filename konstans létrehozásához jobb egérgombbal 

kattintson a prompt bemeneti csatlakozásra és válassza a Create » 

Constant pontot a gyorsmenüből. 

 

m. Ugyanezt a pontot válassza ki a fenti módon a function bemeneti 

csatlakozásnál is, majd az „Operating tool” segítségével válassza a create 

or replace opciót. 

 

n. A Functions » File I/O palettáról a „Write File” függvényt helyezze el a 

diagramon. Ez a függvény írja majd fájlba az összefűzött karakterláncot. 

 

o. A Functions » File I/O palettáról a „Close File” függvényt helyezze el a 

diagramon. E függvény lezárja a fájlt. 

  

p. A Functions » Time & Dialog palettáról válassza ki a „Simple Error 

Handler VI”-t, és illessze be a diagramba. Ez az „Egyszerű hibakezelő VI” 

a fájlműveletek során esetlegesen fellépő hibákat figyeli, és egy 

párbeszédablakban jelzi.  

 

3. File Writer.vi  néven mentse el a fenti módon létrehozott VI-t. 

 

4. Változtassa meg az előlapon a bemenő adatokat, majd futtassa a VI-t.  

 Megjelenik az  Enter Filename  párbeszédablak.  

 

5. Írjon be egy fájlnevet (pl. demofile.txt) és kattintson a Save vagy OK 

gombra. A VI fájlba írja a String to Write, Numeric to Write és Unit to write 

elemek tartalmát. 
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7-3 gyakorlat: Fájlból olvasó VI  (File Reader VI) 

 
Tárgy: Adatok olvasása fájlból 
 

Készítsen VI-t, mely kiolvassa és egy szövegkijelzőben megjeleníti a 7-2 gyakorlatban 

létrehozott fájl tartalmát.    

 

Előlap 
 

1. Hozzon létre egy új VI-t és a Controls » String & Path palettán található path 

elem segítségével készítse el a következő előlapot: 

 

 
 

 

Blokkdiagram 
 

2.   Készítse el a következő blokkdiagramot: 

 

 
. 

 

a.  A Functions » File I/O palettáról illessze be az Open/Create/Replace File 

VI-t a diagramba. Ez a VI egy párbeszédablakot jelenít meg fájlok 

létrehozásához vagy megnyitásához 

 

b. .A Select Filename konstans létrehozásához jobb egérgombbal 

kattintson a prompt bemeneti csatlakozásra és válassza a Create » 

Constant pontot a gyorsmenüből. 
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c. Ugyanezt a menüpontot érje el a fenti módon a function bemeneti 

csatlakozásnál is, majd az „Operating tool” segítségével válassza ki az 

open funkciót. 

 

d. A Functions » File I/O palettáról a „Read File” függvényt helyezze el a 

diagramon. Ez a függvény a fájl kezdetétől számítva a count értékében 

meghatározott számú bájtot olvas be. 

 

e. A Functions » File I/O palettáról a „Close File” függvényt helyezze el a 

diagramon. E függvény lezárja a fájlt. 

  

f. A Functions » Time & Dialog palettáról válassza ki a „Simple Error 

Handler VI”-t, és illessze be a diagramba. Ez az „Egyszerű hibakezelő VI” 

a fájlműveletek során esetlegesen fellépő hibákat figyeli, és egy 

párbeszédablakban jelzi.  

 

3. File Reader.vi  néven mentse el az elkészült VI-t. 

 

4. Az „Operating tool” kiválasztása után kattintson az előlapon a Browse  

gombra. 

 

5. Keresse meg a 7-2 gyakorlatban létrehozott fájlt (pl. demofile.txt) és 

kattintson az Open vagy az OK gombra. 

 

6. Futtassa a VI-t. A String Read from File kijelző megjeleníti a fájl 

tartalmát. 

 

7. Módosítsa a VI-t úgy, hogy a számadat külön, digitális kijelzőben jelenjen 

meg. Mentse el a módosított VI-t is. 

 

Tipp:  Használja fel a Match Pattern függvényt az első számkarakter megkereséséhez. 
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7-4 gyakorlat: Hőmérséklet regisztráló VI (Temperature 
Logger VI) 

 
Tárgy: Adatok fájlba írása táblázatkezelő vagy szövegszerkesztő program 

számára olvasható formában 
 

Készítsen VI-t, mely az időt és a pillanatnyi hőmérsékletet fájlba menti.  

 

Előlap 
 

1. Nyissa meg a 6-2 gyakorlatban elkészített Temperature Control VI-t, és mentse ki még 

egy példányban Temperature Logger.vi néven. Az előlapot hagyja változatlan 

formában. 

 
 

Blokkdiagram 
 

2.   Módosítsa a blokkdiagramot a következőképpen: 
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a. A Functions » File I/O palettáról illessze be az Open/Create/Replace File 

VI-t a diagramba. Ez a VI egy párbeszédablakot jelenít meg fájlok 

létrehozásához vagy megnyitásához 

 

b.  Helyezze el a diagramon a Get Date/Time String függvényt, melyet a 

Functions » File I/O palettán talál meg. A függvény értéke string 

formátumban megadja a hőmérsékletmérés idejét. 

 

c. A Functions » Boolean palettáról helyezzen el egy TRUE értékű logikai 

konstanst a megfelelő helyen. Ez az érték állítja be az előbbi függvényt, 

hogy rögzítse a másodperceket is a stringben. 

 

d.  A Functions » File I/O palettáról illessze be a diagramba a Format Into 

File függvényt. Ez a hőméréskletmérés eredményét formázott stringgé 

konvertálja, és fájlba írja. 

 

e. A tab és end of line konstanst a Functions » String palettán találja. 

 

f. A Functions » Cluster palettáról illessze be az Unbundle by Name 

függvényt. Ez eltávolítja a status elemet a hibaklaszterről. 

 

g. A Functions » Boolean palettáról helyezze el a Not és And függvényeket. 

Ha a Power értéke TRUE és nem következett be hiba, a végrehajtás 

folytatódhat. 

 

h. A Functions » File I/O palettáról a „Close File” függvényt helyezze el a 

diagramon. E függvény lezárja a fájlt. 

  

i. A Functions » Time & Dialog palettáról válassza ki a „Simple Error 

Handler VI”-t, és illessze be a diagramba. Ez az „Egyszerű hibakezelő VI” 

a fájlműveletek során esetlegesen fellépő hibákat figyeli, és egy 

párbeszédablakban jelzi.  

 

3. Mentse el az elkészült VI-t, mert később még szükség lesz rá. 

 

4. Futtassa a VI-t. Megjelenik az Enter Filename párbeszédablak. 

 

5. Írja be a temp.txt fájlnevet, majd kattintson a Save vagy OK gombra. 

A VI létrehoz egy temp.txt nevű fájlt. Ezt követően minden fél másod-

percben elvégez egy mérést mindaddig, amíg a Power kapcsolóval meg nem 

állítjuk a futást, vagy valamilyen hiba be nem következik. Az adatokat 

folyamatosan regisztrálja a fájlban, a VI futásának megállítása után pedig 

lezárja a fájlt. 

 

6. Zárja be a VI-t 

 

7. Indítson el valamilyen szövegszerkesztő vagy táblázatkezelő programot 

(pl. a Notepad vagy a WordPad a Windowsban) 

8. Nyissa meg a temp.txt fájlt a programból. Az első oszlopban az 

időadatokat látjuk, a második oszlopban pedig a hőmérsékleteket. 
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7-5 gyakorlat: Táblázatkezelési VI (Spreadsheet Example 
VI) 

 
Tárgy: Kétdimenziós tömb mentése táblázatkezelő program számára olvasható 

szövegfájlformátumban 
 

A 7-4 gyakorlatban már végeztünk hasonló célú feladatot stringekkel, melyekben 

tabulátorok (tab konstansok) választották el az oszlopokat, az end of lines konstansok 

pedig a sorokat. Az alábbi lépések során egy olyan VI-t vizsgálunk, amely 

táblázatkezelővel beolvasható fájlformátumban menti el egy numerikus tömb 

tartalmát.  

 

Előlap 
 

1. Nyissa meg a Spreadsheet Example VI-t. Az előlap már készen van:  

 

 
 

2. Futtassa a VI-t. 

 Ez a VI egy kétdimenziós tömböt generál, 128 sorral és 3 oszloppal. Az első 

oszlop egy tiszta szinuszos jel adatait tartalmazza, a második oszlopban zaj, a 

harmadikban pedig koszinuszfüggvény szerinti jelalak van tárolva. A VI 

mindhárom oszlop adatait ábrázolja a grafikonon,valamint kijelzi az adatokat 

táblázatos formában is. Végül a VI megjelenít egy párbeszédablakot. 

 

3. Írja be a ablakba a wave.txt fájlnevet, és kattintson a Save vagy az OK 

gombra. A későbbiek folyamán meg fogjuk vizsgálni ezt a fájlt. 
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Blokkdiagram 
 

2.   Jelenítse meg, majd tanulmányozza a VI  blokkdiagramját . 

 

 
 

 A Functions » Analyze » Signal Processing » Signal Generation palettán 

található Sine Pattern VI kimenete 128 elemes numerikus tömb, mely egy 

szinuszfüggvény értékeit tartalmazza. A második Sine Pattern VI bemenetén 

található 90.0 értékű konstans adja meg a függvényértékek kezdőfázisát 

.  

 A Uniform White Noise VI, melyet szintén a fenti palettán találunk, egyenletes 

fehérzajnak megfelelő adatokkal tölti fel a 128 elemű tömböt.  

 

 A Functions » Array palettán elérhető Build Array VI  építi fel a következő 

kétdimenziós tömböt a szinusz, a zaj, és a koszinusz adatokat tartalmazó 

tömbökből. 

 

  
 

 A Functions » Array palettáról elérhető  Transpose 2D Array függvény a 

sorokat oszlopokká, az oszlopokat sorokká rendezi át: 
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 A  Functions » File I/O palettán található a Write To Spreadsheet File VI, 

amely a kétdimenziós tömböt a táblázatkezelő számára olvasható string 

típusra alakítja, majd kiírja egy fájlba. A string az ábrán látható formátumú (a 

nyíl a tabulátort jelzi, a ¶ jel pedig a sor vége karaktert). 

 

 
 

  A Functions » String » String/Number Conversion palettáról érhető el 

a Number To Fractional String függvény, mely egy numerikus adattömböt 

karakter (string) típusúvá konvertál, melyet azután táblázatos formában 

jelenít meg a VI az előlapon. 

 

5.    Zárja be a VI-t. 

 

Megjegyzés:  Ebben a példában három tömböt tároltunk egy fájlban. Ennél több tömb 

tárolásához növelje meg a Build Array függvény bemeneteinek számát. 

 

6. Nyissa meg a fájlt szövegszerkesztő és/vagy táblázatkezelő programból is. 

 

A  wave.txt fajl megnyitása után az első, a második és a harmadik 

oszlopban rendre megjelennek a szinuszos hullámforma, a fehérzaj és a 

koszinuszfüggvény szerinti hullámforma adatai. 
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7-6 gyakorlat: Hőmérsékletmérési alkalmazás VI 
(Temperature Application VI) 

 
Tárgy: Mindazon ismeretek alkalmazása , melyeket a kurzusban eddig 

megismertünk (struktúrák, shift regiszterek, hullámforma kijelzők, 
tömbök, grafikonok, filem-veletek stb.) 

 

Készítsen VI-t az ábrán látható front panellel, mely az alább leírtaknak megfelelően 

működik. Mentse el a kész VI-t Temperature Application.vi néven. 

 

 
 

1. Végezzen hőmérsékletmérést másodpercenként mindaddig, amíg a felhasználó 

megállítja a VI futását, vagy hiba következik be. 

 

2. Jelenítse meg a pillanatnyi hőmérsékletet, valamint az előző három mérés átlagát 

egy hullámforma kijelzőn. 

  

3. Ha a hőmérséklet meghalad egy határértéket, gyújtson ki egy LED-et. 

 

4.  Minden egyes mérés után regisztrálja a dátumot és az időt (másodperceket is), a 

hőmérsékletet, az előző három mérés átlagát, valamint egy egyszavas szöveges 

üzenetet arról, hogy a hőmérséklet normális-e, avagy meghalad egy határértéket. 

Az adatokat úgy rögzítse, hogy minden adat külön oszlopban legyen, 

táblázatformátumban, az alábbi példa szerint:  
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5. Az adatgyűjtés megállítása után XY grafikonon ábrázolja a tárolt 

hőmérsékletadatokat. Illesszen görbét a pontokra. Jelezze a minimum-, a 

maximum- és az átlaghőmérsékleteket. 

 

Tipp: A feladat megoldásánál induljon ki a 7-4 gyakorlatban megépített Temperature 

Logger VI-ból. Az 5. feladathoz használjon fel részleteket az 5-3 gyakorlat során 

felépített Temperature Analysis VI-ból. 
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8-1 Gyakorlat: Mérésadatgyűjtő eszközök használata 
 
Tárgy:  A  „Measurement & Automation Explorer” alkalmazása a rendelkezésre 
álló DAQ  konfiguráció vizsgálatára, a talált eszköz interaktív tesztelésére és 
három virtuális csatorna létrehozására.   
 

 Végezze el a következő lépéseket a Measurement & Automation Explorer (MAX) 

segítségével a számítógépében található Data Acquisition (DAQ), azaz mérésadatgyűjtő, -

feldolgozó eszközök konfigurációjának megvizsgálásához.  A Measurement & Automation 

Explorer tesztprogramjaival ellenőrizze a hardvereszköz működőképességét, és hozzon létre 

három virtuális csatornát, melyeket a külső csatlakozószerelvény fizikai vonalaihoz fog 

hozzárendelni.     

 

a.)   A DAQ eszközbeállítások vizsgálata 

 
1. A LabVIEW Tools » Measurement & Automation Explorer menüpont 

kiválasztásával indítsa el ezt az alkalmazást vagy kattintson az Asztalon is 

megtalálható ikonr. Ez az alkalmazás megkeresi a számítógépben található 

National Instruments hardvereszközöket, és megjeleníti a velük kapcsolatos 

információkat. 

 

2. A Configuration ablakban nyissa meg a Devices and Interfaces ágat, mely a 

számítógépbe installált NI eszközök listáját tartalmazza. Az alábbi példa szerint 

egy PCI-MIO-16XE-50 típusú többfunkciós mérésadatgyűjtő kártya van a 

számítógépben.  

 
  

A Measurement & Automation Explorer megjeleníti a számítógépen található 

valamennyi National Instruments hardver- és szoftvereszközt. Az azonosító szám 

(device number) zárójelben jelenik meg az illető eszköz neve után. Egy adatgyűjtő 

és feldolgozó VI-ban ezzel az azonosító számmal tudja kiválasztani azt az 

eszközt, amellyel DAQ műveleteket szeretne végezni. A LabVIEW 7.0 változattól 

kezdve két különböző eszközvezérlő van a mérőkártyákhoz: "Traditional NI-
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DAQ Devices", amely kompatibilis a korábbi LabVIEW változatokkal és az új 

fejlesztésekhez a "NI-DAQmx Devices" vezérlők. Egyidejüleg csak az egyik 

típusú vezérlő használható! A továbbiakban a leírás a Traditional NI-DAQ 

Devices- vezérlőkre vonatkozik!!  A továbbikban a leírás szerint kell eljárni és 

az EXPRESS VI-knél szereplő DAQ-Assistant nem hasznáható! Vezérlőcseréhez 

újra kell indítani a számítógépet. 

 

Megjegyzés: Az aktuális konfiguráció természetesen az ábrán szereplőtől különböző lehet. 

Az eszközinformációkat részben takaró help ablak a Measurement & 

Automation Explorer jobb felső részén található Show/Hide gombra kattintva  

elrejthető. 

  

 

3. Egy adott eszközről részletesebb tájékoztatást tulajdonságablakának 

megjelenítésével kaphat. Az egérmutatóval válassza ki az eszközt a listából, majd 

kattintson az eszközsávon a Properties gombra. A megjelenő párbeszédablakban 

konfigurálhatja a fenti példában szereplő mérésadatgyűjtő kártyát: 

 

A párbeszédablak több lapból áll, melyek közt a megfelelő fülre való kattintással 

választhat. A System lap az adott eszközhöz a Windows regisztrációs 

adatbázisában hozzárendelt erőforrásokat mutatja. A további lapokon (melyek 

eszközönként változók lehetnek) állíthatja be az adott részegységekhez tartozó 

paramétereket (pl. az analóg kimenetek és bemenetek jellemzőit, a kiegészítő és az 

adatfeldolgozással kapcsolatos paramétereket stb.) 

 

4. A System lapon a Test Resources gombra való kattintással tesztelheti az 

eszközhöz rendelt – a Windows Eszközkezelőjében is megjelenő – erőforrásokat. 

Mivel az eszköz már konfigurálva van, a tesztnek hiba nélkül le kell futnia. 

 

 

b.)   A DAQ eszköz részegységeinek tesztelése 
 

5.  A MAX ablakhoz való visszatéréshez kattintson kétszer egymás után az OK 

gombra. 
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6. A DAQ eszköz funkcióinak egyenkénti teszteléséhez kattintson az eszközsávon a 

Test Panel gombra, mely megjeleníti a tesztablakot. Ezen belül az Analog Input 

fülre való kattintással tesztelheti az analóg bemeneteket. 

 

 

7. Válassza ki az Analog Output lapot, melyen egyenfeszültséget vagy szinuszos 

váltakozófeszültséget állíthat be az eszköz valamelyik analóg kimenetén.  

 

8. A kimeneti üzemmódot (Output Mode) váltsa át szinuszjel-generátorra (Sine 

Generator) és kattintson a Start Sine Generator gombra az indításhoz. A 

LabVIEW folyamatosan szinuszjelet generál a 0. sorszámú analóg kimeneten. 

 

9. A mérőkártyához tartozó külső csatlakozószerelvényen kösse össze az Analog Out  

0. kimenetét az Analog In 1. bemenetéhez. Differenciális bemenet esetén az analóg 

kimenet földjét kösse a bemeneti vonal párjához. 

 

10. Az Analog Input lapon válassza ki az 1. számú bemenetet. A LabVIEW beolvassa 

és megjeleníti a 0. analóg kimenetről származó jelet.  

 

11. Váltson át a Counter I/O lapra a kártyán található számláló/időzítő áramkör 

teszteléséhez. 

 

12. A számláló üzemmódját (Counter Mode) váltsa át Simple Event Counting-ra, 

majd a Start gombbal indítsa a tesztet. A számlált érték (Counter Value) gyors 

ütemben nő. A Reset gombbal állíthatja meg a tesztet. 

 

13. A Digital I/O lapon tesztelheti a kártya digitális kimeneti/bemeneti vonalait. Ha 

egy-egy bemenetet vezetékdarabbal a földre köt, az ablakban ellenőrizheti ennek 

hatását az adott vonalhoz tartozó logikai szint kijelzőn. 

 

14. Néhány vonalat állítson be kimenetként, és tetszés szerint váltsa át a Logic Level 

kapcsolókat. A külső szerelvényhez csatlakoztatott LED-ek vagy feszültségmérő 

műszer segítségével ellenőrizheti a kapcsolókkal beállított logikai szintek 

megjelenését a kapcsokon.  

 

 

c.)   A DAQ eszköz csatornáinak konfigurálása 
 

 

1. Kattintson jobb egérgombbal a Data Neighborhood ikonon, a gyorsmenüből 

válassza a  Create New majd a Traditional NI-DAQ Virtual Channel opciót; 

végül kattintson a Finish gombra.  
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2. A megjelenő paneleken töltse ki a rovatokat az alábbi táblázat szerint. Az analóg 

bemenetek 0. csatornája a csatlakozószerelvényen hozzákötött jelforrásról (a 

példában hőmérséklet-szenzor) fog beolvasni és digitalizálni feszültségértékeket. 

Ezeket a rovatokat a tényleges hardverkörülményeknek megfelelően a példától 

eltérően konfigurálhatja. A Next vagy Tovább gombra való kattintással haladhat 

sorba a beállításokon. 
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3.  

 
 



98 
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Ellenőrizze és szükség szerint módosítsa a beállításokat. 

 

 

4.  Hozzon létre egy második virtuális csatornát a 15. pontban leírt módszerrel, és írja 

be a következő beállításokat: 

  



100 
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5. Végül hozzon létre egy harmadik csatornát is úgy, hogy jobb egérgombbal 

kattintson a chan1 -en és válassza a Duplicate menüpontot. A Copy Virtual 

Channel párbeszédablak jelenik meg. 

 

6. Hagyja változatlanul az alapértelmezett értekeket és kattintson az OK gombra. A 

MAX -ban megjelenik a harmadik virtuális csatorna chan2 néven, a chan1 -gyel 

azonos paraméterekkel. 

 

7. Ellenőrizze a beállításokat és javítsa ki a szöveget a chan2 Properties menüjében.  

 

 
8. A Measurement & Automation Explorerben most a következő ábrának megfelelő 

ablakot kell látnia (az eltérő hardverfeltételekből adódóan természetesen lehetnek 

különbségek).   
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23.   Zárja be a Measurement & Automation Explorert a File » Exit menüponttal. 
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8-2 Gyakorlat: Feszültségmérő (Voltmeter) VI 
 
 
Tárgy:  Analóg jel beolvasása  DAQ  eszközről   
 

Készítsen VI-t, mely a DAQ eszköz egyik bemenetéről feszültségértékeket olvas 

be, és megjeleníti az előlapon.  

 

 

Előlap 

 

1. Nyisson új VI-t és készítse el a következő előlapot: 

 

 

a. Helyezzen egy analóg feszültségkijelzőt (meter) a Controls » Numeric 

palettáról az előlapra. 

 

b. Állítsa be a műszer skáláját a mérendő feszültségtartománynak megfelelően. 

A feliratozó eszközzel (Labeling Tool) duplán kattintson az alapértelmezett 

10.0 végkitérésre, és írja be a kívánt értéket. Szükség szerint méretezze át a 

műszert nagyobbra. 

 

c. A függőleges kapcsolót elhelyezése után konfigurálja úgy, hogy az 

alapértelmezett értéke TRUE legyen, típusa pedig Latch When Pressed. 

 

d. Jobb egérgombbal kattintson a Channel kontrollra és válassza az Allow 

Undefined Names pontot, majd írjon be 0 -t. 
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Blokkdiagram 

 

 

 

2. Készítse el a következő blokkdiagramot: 

 

 

 

a. A Functions » Data Acquisition » Analog Input palettáról helyezze az 

AI Sample Channel VI-t a blokkdiagramra. Ez a VI beolvas egy analóg 

bemeneti csatornát, és kiadja a feszültségértéket. 

 

Megjegyzés: Ha nincs a számítógépben DAQ eszköz, vagy a bemenetei nincsenek 

feszültségforrásra csatlakoztatva, az AI Sample Channel VI helyett használja a Functions » 

User Libraries » Basics I Course palettáról elérhető (Demo) AI Sample Channel VI-t. Ez a 

VI szimulált feszültségértékeket ad át a kimenetén. 

 

 

b. A Functions » Time & Dialog palettáról helyezze a diagramra a Wait Until 

Next ms Multiple időzítőt. A fenti beállításban a beolvasási ciklus 100 

milliszekundumonként fog ismétlődni. 

 

3. Mentse el a VI-t Voltmeter.vi néven, hogy később más VI-k építésénél fel 

tudja majd használni. 

 

4. Hozza előtérbe az előlapot, és futtassa a VI-t. Az analóg műszer mutatója jelzi a 

beolvasott feszültségértékeket.  Hiba bekövetkezése esetén az Easy I/O VI 

megjelenít egy ablakot a hibakóddal és a hiba leírásával. 

 

5. Zárja be a VI-t. 
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8-5 Gyakorlat: Jelalakbeolvasó (Acquire Waveform) VI 
 
 
Tárgy:  Analóg hullámforma beolvasása és megjelenítése  
 

Készítsen VI-t, mely a Data Acquisition VI-k segítségével analóg jelalakot olvas 

be és megjeleníti azt egy előlapi grafikonon. Az analóg bemenet 

1. csatornájára csatlakoztasson szinuszos jelforrást.   

 

 

Előlap 

 

1. Nyisson új VI-t és készítse el a következő előlapot: 

 

 

 
 

 

A # of Samples a mintavételezendő pontok számát, a Samples/Sec a 

mintavételezés gyakoriságát adja meg. 

 

a. A Controls » I/O palettáról helyezzen egy hullámforma-kijelzőt  az előlapra. 

 

b. A kijelzőben állítsa az x tengelyen a pontosságot (digits of precision) 1-re. Az 

x tengely felirata előtt megjelenik az m prefixum, jelezve hogy 

milliszekundumokban jeleníti meg az értékeket. 
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Blokkdiagram 

 

2. Készítse el a következő blokkdiagramot: 

 

 
 

 

3. A Functions » Data Acquisition » Analog Input palettáról helyezze az 

AI Acquire Waveform VI-t a blokkdiagramra. Ez a VI 1000 pontot olvas be az 1. 

csatornáról 10000 mintavétel/másodperc sebességgel. 

 

Megjegyzés: Ha nincs a számítógépben DAQ eszköz, vagy nem áll rendelkezésre megfelelő 

jelforrás, az AI Acquire Waveform VI helyett használja a Functions » User Libraries » 

Basics I Course palettáról elérhető (Demo) AI Acquire Waveform VI-t. Ez a VI a valódival 

megegyező számú szimulált mintavételi pontot ad át a kimenetén, a fenti mintavételi 

gyakorisággal. 

 

4. Mentse el a VI-t Acquire Waveform.vi néven. 

 

5. Váltson át az előlapra,  írjon be bemenő értékeket, és futtassa a VI-t. A grafikonon 

megjelenik az analóg hullámforma. Futtassa a VI-t különböző mintavételi 

gyakoriságokkal és mintaszámokkal. 

 

6. Hagyja nyitva a VI-t, mert szüksége lesz rá a következő gyakorlatban. 
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8-6 Gyakorlat: Jelalakbeolvasó és fájlba író (Acquire 
Waveform to File) VI 

 
 
Tárgy:   Az analóg bemeneti csatornáról beolvasott hullámforma-adatok fájlba 

írása 
 

1. Ha nincs megnyitva, olvassa be az előző gyakorlatban elkészített Acquire 

Waveform  VI-t. 

 

2. Mentse el a VI-t  új néven:  Acquire Waveform to File.vi 

 

Blokkdiagram 
 

3. Módosítsa a blokkdiagramot a következőképpen: 

 

 

 

 

 

 

 

 

 

 

 

 

a. A Functions » Waveform » Waveform File I/O palettáról helyezze az 

Export Waveforms to Spreadsheet VI-t a blokkdiagramra. Ez a VI megnyit 

egy fájlt, a hullámforma-adatokat megformázva, fejléccel ellátva kiírja a 

fájlba, végül lezárja a fájlt. 

 

b. A Functions » Time & Dialog  palettáról helyezze a Simple Error Handler 

VI-t a blokkdiagramra. Ez a VI az esetleges hibák bekövetkeztét kezeli le, és 

azokra párbeszédablakban figyelmeztet. 

 

4. Mentse el a VI-t. 

 

5. Térjen vissza az előlaphoz és futtassa a VI-t. A jelek beolvasása és megjelenítése 

után a VI egy szövegbeviteli ablakban bekéri az elmentendő fájl nevét. 

 

6. Írja be a fájlnevet (pl. acquire.vi)  és kattintson az OK gombra. 

 

7. Nyissa meg az elmentett fájlt táblázatkezelő vagy szövegszerkesztő programban. 

A fejlécinformációkat a táblázat első sora tartalmazza.  Itt található a mérés 

indításának ideje és az időnövekmény értéke. A táblázat soraiban vannak a 

hullámforma-adatok. Az első oszlopban az időadatokat, a másodikban pedig 

pillanatnyi feszültségértékeket találjuk. 



108 

8-7 Gyakorlat: Adatszkennelési példa (Scan Example) VI 
 
 
Tárgy:   Az Easy I/O VI-k használata szkenneléses adatgyűjtésre 

 

Hajtsa végre a következő lépéseket egy olyan VI futtatásához, amely két különböző 

hullámformát olvas be és jelenít meg grafikonon. 

 

A külső szerelvényen csatlakoztasson szinuszjelforrást az analóg bemenet 1. 

csatornájához, négyszögjelet pedig a 2. csatornához. 

 

1. Nyissa meg az előre elkészített Scan Example VI-t. 

 

2. Vizsgálja meg a VI blokkdiagramját. 

 

Megjegyzés: Ha nincs a számítógépben DAQ eszköz, vagy nem áll rendelkezésre 

megfelelő jelforrás, az AI Acquire Waveforms VI helyett használja a Functions » User 

Libraries » Basics I Course palettáról elérhető (Demo) AI Acquire Waveforms VI-t. E 

VI segítségével szimulálhatja szinuszhullám, illetve négyszögjel  beolvasását az analóg 

bemenet 1., illetve 2. csatornájára.  

 

3. Futtassa a VI-t. A grafikonon megjelennek a hullámformák. 

 

4. Zárja be a VI-t. Ne mentsen el semmilyen változtatást. 
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8-8 Gyakorlat: Kétféle hullámforma szkennelő (Scan Two 
Waveforms) VI 

 
 
Tárgy: Többcsatornás adatgyűjtés a DAQ eszközről, és a hullámformák 

megjelenítése közös grafikonon. 
 

Hajtsa végre a következő lépéseket egy olyan VI futtatásához, amely két különböző 

hullámformát olvas be és jelenít meg közös grafikonon. 

 

1. A külső szerelvényen csatlakoztasson szinuszjelforrást az analóg bemenet 1. 

csatornájához, négyszögjelet pedig a 2. csatornához. 

 

2. Készítsen VI-t, mely mindkét csatornáról beszkenneli az adatokat, és közös 

hullámforma-grafikonon (waveform graph) ábrázolja azokat. 

 

Megjegyzés: Ha nincs a számítógépben DAQ eszköz, vagy nem áll rendelkezésre 

megfelelő jelforrás, az AI Acquire Waveforms VI helyett használja a Functions » User 

Libraries » Basics I Course palettáról elérhető (Demo) AI Acquire Waveforms VI-t. E 

VI segítségével szimulálhatja szinuszhullám, illetve négyszögjel  beolvasását az analóg 

bemenet 1., illetve 2. csatornájára.  

 

3. Mentse el a VI-t Scan Two Waveforms VI néven. A VI elkészítéséhez az 

alábbi előlap nyújthat segítséget: 
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9-1 Gyakorlat. A párhuzamos port használata a LabVIEW 
OutPort.VI és InPort.VI segítségével. 

 
Tárgy: Adatok küldése a printer portra.  

 

A normál használata a portnak, adatok küldése a nyomtató, vagy más a kimenetre csatlakozó 

eszköz számára. 8 bites adatokat, azaz byte-okat küld egy időben a kimenetre. A többi vonal 

ami elérhető DB-25 csatlakozón állapotvonalak, vezérlő vonalak és földvezetékek. Az állapot 

és vezérlővonalakat az aszinkron kommunikációra és visszajelzésre használják, amikor 

nyomtatóval kommunikálnak.  

A Microsoft Windows környezetben lehetőség van a párhuzamos port korlátozott használatára a Windows standard 

függvényeinek segítségével, hasonlóan a soros kommunikációval. Ez azt jelenti, hogy adatok kivitelére a párhuzamos porton 

keresztül lehetséges ugyanazon VISA VI-k használatával, mint a soros kommunikáció esetén. Azonban, a Windows API nem 

tartalmaz támogatást az adatbevitelre. Bár némely estben a hardver támogatja a bemenetet, a szoftver nem. Ez nem jeleni, 

azonban, hogy lehetetlen a párhuzamos portot bemenetnek használni a LabVIEW-ban, csak azt, hogy a nem lehetséges a 

VISA VI-kel.  

 

A párhuzamos port a legtöbb számítógépen egy un. DB-25 csatlakozót használ, ami az alábbi 

ábrán látható. A csatlakozó lábkiosztása az 1. Táblázatban található. .  

 
 

Megjegyzés:: A tüskék számozása 1-13 a felső sorban és  14 - 25 az alsó sorban jobbról balra haladva. 

  Bevezetés 
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1. Táblázat. A Printer port lábkiosztása.  
 

 

  

  A párhuzamos port konfigurációja. 

 

Módszer  

 

A párhuzamos port használata digitális kimenetre majdnem triviális ha a Windows API 

függvényeit használjuk. A fő trükk, hogy a 11(Busy) és 12 (Paper End, Empty PE) pontokat 

le kell földelni. Különben a hardver meghajtó az gondolja, hogy a printer foglalt, vagy hiba 

miatt nem tudja továbbítania az adatokat. Az interfész tárolja az utoljára beirt értéket, amíg új 

értéket nem kap, vagy kikapcsolják a számítógépet. A LabVIEW formálisan a soros 

kommunikáción keresztül kezeli ezt a portot is. A soros kommunikációhoz az adatokat string-
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ként, karaktersorozatként kell kezelni. Általában 8 bites adatokat akarunk kiküldeni a portra. 

Ha WINDOWS függvényeket használjuk, akkor ez azt igényli, hogy a számokat stringé kell 

alakítani, úgy hogy az adat bináris értéke ne változzon. Az Advanced»Data 

Manipulation»Type Cast VI függvényt használhatjuk erre a célra.  

Készítse el az itt látható VI-t. 

Előlap 

1. Hozzon létre egy új VI-t 

 

2. Helyezze az előlapra a I/O-ból a VISA Resource Name beállítót, egy numerikus 

beállító elemet, amelyet egész értékre, byte méretre kell állítani, valamint egy STOP 

logikai beállító elemet. 

3. Hozza létre az alábbi blokkdiagramot. 

 

 

Ha egyszerre több mint egy byte-ot küldeni ki, a driver egymás után küldi ki az adatokat és a 
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„Strobe line” (line 1) vonalat ki- bekapcsolja minden egyes adatra. Az időzítés változhat a 

különböző számítógépeken, de részben szabványosítva van.  

 

Hibajelzések 

 -1073807330 (BFFF003E) - VISA "Could not perform operation because of I/O 

error"  

vagy 

LabVIEW hangs with Serial Write compatibility VI. 

Ezek a hibajelzések általában azt jelentik, hogy a 11-e és 12-es bemeneti pont nincs jól 

leföldelve.. 

 

 

  

  Egyszerű párhuzamos port ki/Bemenet 

 

Módszer 

 

Egy másik lehetséges módszer, hogy közvetlenül írunk a párhuzamos port hardver 

regisztereibe. A LabVIEW-ban közvetlenül hozzáférhetünk a hardver regiszterekhez 

felhasználva az In Port.vi és Out Port.vi  függvényeket, amelyek az Advanced Port I/O 

palettán találhatók. Mivel nem használunk magasabb szintű meghajtó programot, nem kell 

foglalkozni a státuszvonalak állapotával. 

 

 

A párhuzamos port használatához az első lépés a port alapcímének, base address, megtalálása. 

A base address –t a Windows Device Manager adatai között párhuzamos port eszközei között 

lehet megtalálni.  

 

A Windows 9x: esetén (angol)  

1. A Desktop-on, a jobb egérgombbal kattintson a My Computer ikonra és válassza a 

Properties-t a felbukkanó menüből.  

2. Kattintson a Device Manager fülre és keresse meg LPT1-et a Plug and Play BIOS 

alatt.  
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3. Az LPT1 kiválasztása után kattintson a Properties gombra.  

4. Utána válassza a Resources fület és a címnek meg kell jelenni a Input/Output Range 

mögött. 

 

 A párhuzamos Port (LPT1) tulajdonságai (Properties) a „Windows Device Manager”-

ben 

 

A Windows XP esetén (magyar):  

1. Az asztalon kattintson a Sajátgépre a jobb egérrel és válassza a tulajdonságok 

menüpontot.  

2. Válassza Hardware fület és kattintson az Eszközkezelő gombra.  

3. LPT1 a Ports (COM & LPT) alatt található.  

4. Kattintson kettőt az LPT1-re.  
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5. Válassza az Erőforrások fület és a címek az I/O tartomány mellett jelennek meg 

címek. ECP beállítás esetén két tartomány is van. A normál címek 278, 378, vagy 

3BC. 

 

 

 

Több regiszter is tartozik a paralel porhoz, de az egyszerű adatkimenethez csak az 

adatregiszter szükséges. Ez az első regiszter az I/O sávban, azaz az alapcímen található. Az 

adatregiszterbe beírt 8 bit közvetlenül megjelenik az adatvonalakhoz (2-9). Az adat 

kiküldéséhez csak az Out Port.vi szükséges.  
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Az Out Port.vi használata 
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  Az adatvonalak használata bemenetként.   

 

Módszer 

 

A korábbiak említettek miatt a VISA VI-k nem nagyon alkalmasak arra, hogy a port-ot 

bementként használjuk. Általánosságban nem garantált, hogy az adatvonalakat kétirányú 

kommunikációra készítették fel. Részletesebben ez a következő részben foglalkozunk. Most 

tegyük fel, hogy a 8 adatvonalat nem lehet bemenetként használni. Szerencsére más vonalak 

is rendelkezésre állnak párhuzamos porton. Az adatregiszter után következő regiszter a 

(base+1), a status regiszter. A status regiszter öt bitje megjelenik a csatlakozón (Busy, nAck, 

PaperEnd, Select, nError). Ezek a 7,6,5,4,3 bitjei a status regiszternek, kapcsolatuk a 

csatlakozóval az alábbi ábrán látszik.  

 

 

 

A status vonalak már bemenetnek vannak konfigurálva. Amikor egy nyomtatóval 

kommunikálunk, ezek a vonalak az adat továbbítás vezérlésére (aszinkron kommunikáció) 

illetve visszajelzésre szolgálnak. A Busy vonalat invertál kell, mivel az inverz logikát használ. 

Ha öt vagy annál kevesebb vonal kell, akkor In Port.vi –t használhatjuk a status regiszter 

olvasására. Ha ötnél több bit szükséges, akkor a kontrol vonalakat is használnunk kell. 

A kontrol regiszter címe a base+2. Hasonlóan a status regiszterhez, a kontrol regiszter néhány 

bitje megjelenik a csatlakozón (nStrobe, nAutoLF, nInit, nSelectIn). Ezek a vonalak a kontrol 

regiszter 0,1,2,3 bitjeit jelenítik meg. Ezek a vonalak alapesetben kimenetek, de konfigurálni 

lehet őket, mint kétirányú vonalakat. Bementté alakításukhoz, csak egyszerűen magas logikai 

állapotba kell beállítani őket. Ha vonal magas szintre van állítva, és kívülről le van földelve, 

akkor a földelés lesz az erősebb és beolvasásra alacsony értéket fogunk kapni. Figyelembe 



118 

kell azonban venni, hogy a Strobe, nAutoLF, és nSelectIn vonalak inverz logikát használnak. 

Ha ezeket az inverz vonalakat alacsony szintre tesszük, a csatlakozón magas szint jelenik 

meg, így az alakul ki, amit akartunk. Ha egy teljes byte-ot akarunk beolvasni, a felső négy 

bitet a status regiszterből, az alsó négyet, pedig a kontrol regiszterből olvashatjuk be. Ez egy 

kis bináris manipulációt igényel a LabVIEW-ban, ahogy az a következő ábrán látható, és még 

vigyázni kell az inverz logikát használó bitekre.  

 

Megjegyzés: A számállandók a digitális logika számára binárisan vannak megadva.  

 

 

A kontrol és status vonalak használata bemenetként. 

 

Bizonyos párhuzamos portok, úgy vannak kialakítva, hogy lehetővé teszik az adatvonalak 

kétirányú használatát. Ez nagymértékben függ a gyártó által megvalósított kialakítástól. 

Vannak olyan megoldások, hogy ugyanúgy kell eljárni, mint kontrol vonalak esetében, azaz 

magas szinte kell állítani a vonalakat, majd beolvasva a külső jel állapotát kapjuk meg. 

Azonban a legtöbb párhuzamos port azt igényli, hogy beállítsuk az átvitel irányát. Erre a 

célra, a Kontrol regiszter 5. bitje szolgál (base+2). Ha a port képes rá, ezen irány bit beállítása 

háromállapotúvá változik, és vezérelni lehet kívülről. Néha a 6. bit átállítása is szükséges, 
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vagy magasra, vagy alacsonyra. Azonban, néhány gyártó rögzíti e bitek állapotát, így ezek 

szoftver úton nem változtathatók ezen esetben. A következő ábra mutatja a párhuzamos port 

használatát, háromállapotú esetben.  

 

Az adatvonalak használata bementként.  

 

Annak eldöntésére, hogy az adatvonalak, használhatók-e bementként, a közöket kell tenni:  

1. Állítsa be az 5. bitet kontrol regiszterben 1-re (base address+2).  

2. A szabadon hagyott porta írjon különböző számokat, és olvassa vissza a port 

adatait, minden írás után.  

 

Ha a kiirt adatok nem egyeznek meg visszaolvasott értékek, akkor a port valószínűleg 

kétirányú. A kontrol portra C5-öt írva, letiltja a kimenetet, és szabadon lehet olvasni a 

bemeneteket.  

 

Ha a visszaolvasott adatok megegyeznek a kiírtakkal, akkor a por nem kétirányú. Külső jelek 

olvasása nem lehetséges. 

 

Ha lehetséges az adatvonalak olvasása, akkor azt célszerű használni. Ekkor az bementkénti 

használathoz a kontrol regiszter 5. bitjét kell magasra állítani. 

 

 Feladatok: 

 

1. Készítse el VISA VI.vel történő adatkivitel VI-jét. 

2. Készítse el a 8 bites adatbevitel programját a status és kontrol vonalak segítségével.  

3. Ellenőrizze, hogy a számítógépének printer portja lehetővé teszi-e a kétirányú 

adatmozgatást. 

4. Készítsen egy VI-t, amellyel tetszőleges adat kiküldhető az adatvonalakra és a kontrol 

portra. Az adatokat visszaolvasva, jelenítse meg mind a három port LED-jeinek 

értékét az előlapon, hasonlóan, mint a LED-ek a kijelzőn. 

5. Készítsen egy programot, ami az adatporton egy beállított kezdeti bitkombinációt, 

másodpercenként, cirkulárisan jobbra és/vagy balra léptet. 

6. Bővítse az előző feladatott azzal a funkcióval, hogy az egyik status vonalra kötött 

kapcsolóval, befejezheti a VI futását.  

7. Bővítse a 6. feladat megoldását, úgy, hogy egy status vonal kapcsolójával, felére 

csökkenti az éppen érvényes várakozást az adatok eltolás között, míg egy harmadik 

status vonal kapcsolásával az időtartamot meg lehet kétszerezni.  
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10-1 Gyakorlat. A „Pop-Up Graph VI” használata. 

 
Tárgy: Egy subVI előlapjának megjelenítése egy VI futása közben.  
 

Készítsen egy a VI-t, ami 0.5 másodperces lépésközzel 10 másodpercig hőmérsékletet 

mér, majd jelenítsen meg egy subVI előlapot, ami megmutatja a gyűjtött adatokat egy 

grafikonon, és a grafikont addig tartja megnyitva, amíg rá nem kattint egy gombra.  

 

Előlap 
 

1. Nyisson meg egy új VI-t és hozza létre a következő előlapot.  

 

 
a. Kattintson a jobb egérgombbal a hőmérőre és válassza a Visible Items»Digital 

Display a megjelenő menüből, hogy megjelenítse a hőmérséklet értékét 

digitális formában. 

b. Változtassa # of data values megjelenítés formátumát I32 alakra. 

 

Blokkdiagram 
 

2. Hozza létre a következő blokkdiagramot. 

 

 
a. Helyezze a Functions»Structures palettán található „For Loop”. A „For 

Loop” 20 mérést fog végezni.  
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b. Helyezze a blokkdiagramra a 3-2 gyakorlat során korábban elkészített 

Thermometer VI-t. Ez a VI gyűjti a hőmérsékletadatokat. 

c. Helyezze a Functions»Time & Dialog palettán található, „Wait Until Next ms 

Multiple” a blokkdiagramra . Ez a függvény fogja meghatározni a For Loop 

végrehajtásának gyakoriságát.  

d. Helyezze el a Functions»Numeric palettán talaálható Multiply függvényt. Ez a 

függvény sorozza meg a kimenet mindegyik elemét 0.5-el és adja az x skála 

értéket, azaz az időintervallumot az egyes mérések között.  

e. Helyezze el a korábban készített Pop-Up Graph VI-t. Ez a  VI rajzolja fel a 

hőmérsékletadatokat egy XY grafikonra. 

3. Mentse el a VI-t, mint Use Pop-Up Graph.vi. 

4. Konfigurálja a subVI-t, hogy megjelenítse az előlapot, amikor hívják.  

a. Kettős kattintással nyissa meg a Pop-Up Graph subVI előlapját.  

b. Válassa a File»VI Properties. 

c. Válassza a Window Appearance a Category legördülő menüből. 

d. Kattintson a Customize gombra. Konfigurálja az ablak megjelenését, ahogy a 

következő dialóg ablakon látszik. 

 
 

e. Kattintson az OK gombra kétszer és zárja be a subVI-t. Ha az előlap az előlap 

nem záródott be, nem fog bezáródni a subVI futása után 

5. Futtassa a „Use Pop-Up Graph VI”-t. Miután a VI 10 másodpercig gyűjti a 

hőmérsékletadatokat, a Pop-Up Graph VI előlapja megjeleníti a hőmérsékletadatokat 

egy XY grafikonon. Kattintson a DONE gombra, hívó VI-hez való visszatéréshez. 

6. Változtassa meg az ablak megjelenését a „Pop-Up Graph subVI” számára a „Dialog 

window” stílusra. 

7. Mentse el és zárja be a subVI-t. 
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8. Futtassa a „Use Pop-Up Graph VI”-t ismét. A „Pop-Up Graph subVI” előlapja, mint 

egy dialóg ablak funkcionál. Például, az ablak a többi ablak felett marad és a 

rendszerszíneket használja.  

9. Zárja be az összes megnyitott VI-t. 
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10-2. Gyakorlat. Hőmérséklet rendszer VI „Temperature 
System VI” 

 

Tárgy: Billentyűzeti. gombok hozzárendelése az előlapon lévő beállító 
elemekhez és subVI előlapok megjeleníthetők, amikor a VI fut..  

A következő lépésekkel hozzon létre egy hőmérséklet ellenőrző rendszert, amelyekkel 

három különböző teszt hajtható végre. 

Előlap 

1. Nyissa meg a „Temperature System VI”-t. A következő előlap már elkészült.  

 

Az előlap négy logikai funkciójú (Boolean) gombot tartalmaz. A mechanikai akciója 

az első három gomb LatchWhen Pressed –re (a nyomásra váltja az adatot) van 

beállítva, míg a STOP gomb LatchWhen Released (a felengedéskor váltja az adatot).  

2. Kattintson a jobb egérgombbal a beállítóelemre és válassza a Advanced»Key 

Navigation a megjelenő menüből, hogy megjelenítse a Key Navigation dialóg 

ablakot. 

3. A Key Assignment szekcióban, válassza az billentyűzet gombokat az előlapon lehet 

látni.  

4. Ismételje 2. és 3. pontot minden beállító elemre. 

Blokkdiagram 

5. Hozza létre a következő blokkdiagramot, hagyja az összes FALSE esete üresen.  
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a. Helyezzen Functions»Structures palettáról egy „While Loop” és három 

„Case structure” a blokkdiagramra. 

b. Helyezze el a Functions»User Libraries»Basics I Course palettáról a 

„Display Temp VI”-t. Ez a VI szimulálja a hőmérsékletméréseket minden 500 

milliszekundumban és felrajzolja egy hullámgrafikonon. 

c. Helyezze el a Functions»User Libraries»Basics I Course palettáról a Display 

and Log Temp VI-t. Ez a VI szimulálja a hőmérsékletméréseket minden 500 

milliszekundumban és felrajzolja egy hullámgrafikonon, és tárolja egy fileban.  

d. Helyezze el a Functions»User Libraries»Basics I Course palettáról a Display 

Logged Temp VI-t. Ez a VI megnyitja a kiválasztott filet, beolvassa az 

elmentett adatokat és megjeleníti azokat egy grafikonon. 

e. Helyezze a Functions»Time & Dialog palettán található, „Wait Until Next ms 

Multiple” a blokkdiagramra. Ez a függvény fogja meghatározni a For Loop 

végrehajtásának gyakoriságát (100 ms). 

6. Kettős kattintással nyisson meg minden subVI előlapját és vizsgálja meg a hozzá 

tartozó blokkdiagramot, majd zárja be a subVI-ket.  

7. Konfiguráljon minden egyes subVI-t, hogy megjelenítse az előlapját, amikor 

meghívják. 

a. Kattintson a jobb egérgombbal a subVI-re és válassza a SubVI Node Setup a 

megjelenő menüből. 

b. Helyezze el bejelölést a Show Front Panel when called és a Close 

afterwards if originally closed jelölődobozokban. 

c. Ismételje meg az és b lépéseket a fennmaradó két subVI-re is. 

8. Mentse el a VI-t. 

9. Jelenítse meg az előlapot és futtassa a VI-t. 

10. Kattintson minden egyes gombra és a megfelelő billentyűzet gombra, a működés 

ellenőrzésére.  

Megjegyzés: A három subVI visszatér a Temperature System VI előlapjához, amikor 

megnyomja az <Enter> gombot. Próbálja ki, hogy az <Enter> gomb ténylegesen így 

müködik. 

11. Állítsa le a VI-t. 

12. Konfigurálja a Temperature System VI-t, hogy automatikusan elinduljon, amikor 

megnyitja. 

a. Válassza a File»VI Properties menüpontot. 

b. Válassza a Execution –t a  Category legördülő menüből. 

c. Helyezze a bejelölést a RunWhen Opened jelölődobozokban. 

13. Konfigurálja a VI-t, hogy sem a menüsáv, sem az eszközsáv ne legyen látható a futás 

alatt. 

a. Válassza a Window Appearance a Category legördülő menüből. 

b. Kattintson a Customize gombra. 
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c. Távolítsa el a jelölést a Show Menu Bar and Show Toolbar When Running 

jelölődobozból. 

d. Kattintson az OK gombra kétszer. 

14. Mentse el és zárja be az összes VI-t. 

15. Nyissa meg újra a Temperature System VI-t. A VI automatikusan elindul a 

megnyitásra.  

16. Kattintson az előlap gombokra, vagy használja a gyorsindító billentyűzet gombokat.  

17. A leállítás bezárja az összes VI-t. 
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10-3. gyakorlat: Szerkessz meg, „Edit Me VI”  
 

Tárgy: Olyan VI szerkesztése, amelynek a tulajdonságai olyanok, hogy 
akadályozzák a szerkesztést. 

A következő lépések segítségével olyan VI-t szerkesztünk, amelyet úgy konfiguráltak, 

hogy azonnal induljon el és a futás után lépjen ki a LabVIEW-ból.  

Előlap 

1. Zárja be az összes megnyitott VI-t és nyissa meg az Edit Me VI-t. A következő előlap 

jelenik meg.  

 

 

 

Ez a VI már fut, amikor megnyílik. A futás alatt nem lehet szerkeszteni, mert sem a 

menüsáv, sem a eszközsáv nem érhető el. A gyorsító billentyűk sem működnek.  

2. Kattintson a Start gombra. 10 másodperc után a VI megáll és leállítja a LabVIEW-t 

is. 

3. Indítsa újra a LabVIEW-t és nyisson egy új VI-t. 

4. Ha a VI amit szerkeszteni akar nem rendelkezik subVI-kel, vagy nem tudja melyek 

azok, akkor folytassa az 5-től 13 közötti lépésekkel.  

Azonban, ha léteznek és ismeri a subVI-ket, akkor nyissa meg az egyik ilyen subVI-t 

és módosítsa azt, hogy futtathatatlan legyen. Például helyezzen a blokkdiagramjára 

egy Add függvényt és ne kösse be a termináljait. Nyissa meg a subVI, amit 

szerkeszteni akar. Mivel a subVI nem végrehajtható, a amelyik VI hívja az is nem 

végrehajthatóvá válik. Ezért megnyitja automatikusan a szerkeszthető módot és a Run 

gomb töröttként megjelenik. A megszerkesztett VI (hívó) VI szerkesztésének 

befejezése után ne felejtse visszaállítani az elrontott subVI-t. 

5. Jelenítse meg egy új VI blokkdiagramját. 

6. Helyezze a Edit Me VI-t, amely már kész, a blokkdiagramra. Az Edit Me VI előlapja 

jelenik meg. Bár meg tudja jeleníteni az Edit Me VI blokkdiagramját, de nem tudja 

szerkeszteni.  

7. Válassza az Operate»Change to Edit Mode. Egy dialóg ablak jelenik meg, ami közli, 

hogy a VI zárolt (locked). 
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8. Kattintson az Unlock gombra. Most már szerkesztheti a VI-t. Mentesítheti a zárolás 

alól a VI-t a File»VI Properties kiválasztásával, majd a Category legördülő menüből 

a Security kiválasztásával. 

9. Válassza és törölje a Quit LabVIEW függvényt a blokkdiagramból. 

10. Mentse el és zárja be a Edit Me VI-t. Zárja be a VI-t és ne mentse el a változásokat. 

11. Nyissa meg ismét az Edit Me VI-t. 

12. A VI futása után, próbálja szerkeszteni. 

13. Zárja be az Edit Me VI-t. 

 

 

 

 

 

 

 


