What Are "Alphametic Puzzles"?
These are arithmetic operations with letters instead of digits where you have to substitute a letter to digit correspondence to obtain a true equation.
The rules that must be followed for solutions:
¨ The words stand for positive integer numbers.
¨ Same letters always represent the same digit throughout a puzzle, different letters represent different digits. So if N represents 5 in one place, it represents 5 everywhere, and no other letter may represent 5.
¨ Leading characters of the words must not be substituted by zeroes.

Of course, each puzzle uses a different representation. In some cases a digit has been replaced with a joker character, usually denoted by an asterisk. That may be any digit.
These popular puzzles are called Cryptarithms by the Flag of USA American Cryptogram Association, and Alphametics by the Journal of Recreational Mathematics.
They are called in Russian Russian flag as "Криптарифмы" in the journal "Компьютерра" . The German Flag of Germany denomination is " metamatische Aufgabe". They may be called in Hungarian Hungarain flag as "betűszámtan".
Whatever you call them, they all work the same way.


Classification of "Alphametic Puzzles"
See also: Examples Methods of their solution
Classification based on their words
The puzzles are usually made of
¨ sentences or phrases from a well-known place of the literature (e. g. from the Bible of Shakespeare).
¨ related words like politicians, characters from the Harry Potter books, states, countries, oceans, and planets.

Classification by meaning

Doubly True Alphametics

There is a class of alphametic puzzles involving spelled numbers which are doubly true that is both the operation read from the sentence in the applied natural language and the equation formed by the substituted digits are true.

Classification according to language
These puzzles may be in any natural language and any alphabet.

Classification according to complexity
Classification by arithmetic operations
0. The simplest alphametic puzzles are equations having two summands and a result. The summands and the result are intelligible words which form together a fancy sentence in the chosen language or belong to the same category of words.
There are several ways to complicate them.
1. System of two equations (or even more).
2. Allowing more than two summands on the left side of the equation.
3. Allowing a sum of more than one words on the right side of the equation.
4. Presence of multiplications in the equation.
a) The first step to retain the first order of the puzzle is to allow multiplications with constant factors.
b) The second step is allowing multiplied unknown words.
5. Presence of joker characters.
6. Fractions, divisions in the puzzle.
7. Powers.

Classification by number system
0. Puzzles for decimal number system.
1. Puzzles for other number systems. I need not explain that the same problem may be solvable in decimal one but unsolvable in octal one.

Classification by count of characters to be substituted
0. The number of characters to be substituted is less than the base of the number system.
1. The number of characters to be substituted is equal to than the base of the number system.
2. If number of characters to be substituted is greater than the base of the number system then the puzzle is unsolvable.

Classification by length of words to be substituted
0. The limit for short words is arbitrary.
1. You can say puzzles of very long words are made up of words that are all at least 12 letters long.
2. The subtype of the integer number used in the algorithm restricts the maximal length of words involved in the puzzle determines.


Restrictions
See also: Input of Puzzles
Accepted puzzles
The program accepts puzzles made of simple additions on one or both sides of the equation.
The program accepts puzzles having constant factors before or after the added words.
The program recognizes three operators: addition, multiplication and equal sign.
Rejected puzzles
The program rejects puzzles containing two or multiplied words.
The program rejects puzzles containing more than one equation.
The program rejects puzzles containing words having longer or equal length than the number of digits in the highest 64-bit unsigned number = 20.
The program uses the asterisk as operator of multiplication therefore it cannot handle puzzles containing jokers.


Classified Examples of Alphametic Puzzles

Classification by arithmetic operations | by count of characters | by length of words | according to language | by meaning | Examples
Two summands and a result | <10 | short | English | Sentence | SEND +MORE MONEY
Two summands and a result | <10 | short | Hungarian | Sentence | ÉLJEN +MÁJUS ELSEJE
More than two summands on the left side | =10 | short | German | Doubly true | EINS+ZWEI+SIEBEN+SECHZIG = SIEBZIG
Multiplications with constant factors. | <10 | short | English | Doubly true | 5 × TWO + 3 × TWENTY = SEVENTY
Multiplications with constant factors. | <10 | short | Russian | Related words | 4 × АИСТ=СТАЯ
Multiplications with constant factors. | <10 | short | Hungarian | Doubly true | 2 × TÍZ=HÚSZ
More than two summands on the left side | =10 | very long | English | ? | ARISTOCRATIC + PRESCRIPTION + PROSOPOPOEIA + PROTECTORATE = TRANSOCEANIC
Two summands and a result | =10 | short | Russian | Related words | МАГНИЙ+ТАНТАЛ=МЕТАЛЛЫ
Multiplied unknown words | <10 | short | Russian | Related words | ГОЛ × ГОЛ=ФУТБОЛ
Multiplied unknown words | =10 | short | English | ? | N I N E × F O R × E V E R = G O G O G O G O G O
Powers | <10 | short | English | Sentence | HEROLD = SHYDOG


Hungarian Examples
Doubly true
ÖT+EGY=HAT
2*TÍZ=HÚSZ
ÖTVEN+TÍZ=HATVAN
HATVAN+TÍZ=HETVEN
5*HÚSZ=SZÁZ

Related words and sentences
VÍZ+BOR=ITAL
KUTYA+CICUS=ÁLLAT
ÉLJEN+MÁJUS=ELSEJE
VÍZ+BOR=ITAL
EGER+BAJA=VÁROS
KLÓR+BRÓM+JÓD=MARÓ

BLUE : The author has met them somewhere.
RED : The author has find out himself.


Collection of Links

Cryptarithms or Alphametics are puzzles in cryptic arithmetic
W | I | N | Cryptarithms / Alphametics The Contest Center 59 DeGarmo Hills Road Wappingers Falls, NY 12590
I |  | O
N | O | W

Here are links to several other web pages on the net that deal with these puzzles.
Mike Keith's page with some very exotic puzzles.
Jorge Soares's Cryptarithm page
The Contest Center's Cryptarithm page
Copyright 1998, 1999, 2000 by Truman Collins
For comments, email: Truman Collins (truman@tkcs-collins.com)
Most recent update: January 5, 2005
 http://www.tkcs-collins.com/truman/alphamet/alphamet.shtml

Englisch Links

Collins Trueman
Link: http://www.tkcs-collins.com/truman/alphamet/alphamet.shtml

Mike Keith
Link: http://users.aol.com/s6sj7gt/mikealp.htm

Naoyuki Tamura
Link: http://bach.istc.kobe-u.ac.jp/llp/crypt.html

Torsten Sillke
Link: http://www.mathematik.uni-bielefeld.de/~sillke/PUZZLES/ALPHAMETIC/
... und einige Originale von uns!


The Great Collection
Alphametic Puzzles
Table of Contents
Sentences or phrases
Related words
Very long words
Doubly true puzzles involving numbers
French
Italian
Spanish
Links to other alphametic pages
Alphametic puzzle solver
Alphametic puzzle generator

An alphametic puzzle (also sometimes known as a cryptarithm) is a type of puzzle where words are put together into an arithmetic formula such that digits can be substituted for the letters to make the formula true. Here are two examples, the first being one of the simplest and the second being probably the best known alphametic puzzle:

I S E N D
+ B B + M O R E
----- ---------
I L L M O N E Y

In the first, I = 1, B = 9, and L = 0.
There are two rules that must be followed for solutions:
· The leftmost letter can't be zero in any word.
· There must be a one-to-one mapping between letters and digits. In other words, if you choose the digit 6 for the letter M, then all of the M's in the puzzle must be 6 and no other letter can be a 6.
Around the time I finished graduate school (in computer science) I wrote a program to solve addition alphametic puzzles. It's now about ten years later, and my wife and I have just had a baby. I gave Kristin the SEND + MORE = MONEY puzzle to do while she was nursing our daughter. She had fun solving it, and I found a few more for her. I thought it would be interesting to augment the program (written in C++) I wrote before to search for puzzles given a set of words. It turned out to be pretty effective at finding new ones, so I'm making some of them available on the net for anyone who's interested. Incidentally, my wife and I have only solved a few of these by hand.
I've found lots of valid puzzles, but I've only listed the ones here that were at least a little more interesting than random related words. For example, I found 77 puzzles made out of state names. I've just included ones where several states added together equal the word "STATES".
All of the puzzles listed here have exactly one correct solution in base 10 (meaning the digits 0-9 are usable). Incidentally, I've made available a web-based puzzle solver in case you need some help.
If you'd like to find some of your own puzzles, try my alphametic generator .

The number in parenthesis after the puzzle is the estimated difficulty on a scale from 1 to 5. Note that this is determined via automation, so it doesn't correspond in all cases with the difficulty a human has in solving it. It's really a guess at how hard the puzzle is.

Puzzles that are sentences or phrases
I made a modification to my program to allow it to search text for sentences or phrases that are puzzles. I found several in the King James version of the Bible and some in the works of Shakespeare. Here are those and a few others that I found in other text:

AND + HAD + NO = SONS (3) (Numbers, 27:2)
AS + I + WAS + WITH = MOSES (2) (Joshua, 1:5)
AND + UNTO + MOUNT = HERMON (2) (Chronicles 1, 5:23)
THOUGH + HE + HATH = GAINED (2) (Job, 27:8)
WHEN + THERE + WERE + NO = DEPTHS (3) (Proverbs, 8:24)
WHOSE + TEETH + ARE + AS = SWORDS (4) (Proverbs, 30:14)
THAT + THY + SHAME + MAY = APPEAR (3) (Jeremiah, 13:26)
AND + ALL + HANDS + SHALL + BE = FEEBLE (3) (Ezekiel, 21:7)
THEN + JESUS + WENT = THENCE (2) (Matthew, 15:21)
AND + SAID + UNTO = SIMON (3) (Luke, 7:44)
WHICH + WAS + WITH + THE = FATHER (2) (John, 1:1)
STOOD + BEFORE + THE = THRONE (4) (Revelation of Saint John the Devine, 7:9)

SINCE + JULIUS = CAESAR (4) (Antony and Cleopatra)
HERE + SHE = COMES (2) (Much Ado about Nothing)
NOT + THIS = YOUTH (2) (CYMBELINE)
I + WILL + PAY + THE = THEFT (3) (Hamlet)
I + THINK + IT + BE + THINE = INDEED (3) (Hamlet)
THIS + IS + HIS = CLAIM (2) (Henry V)
AND + NEVER + HEARD = BEFORE (3) (Henry VI)
IF + THOU + DIDST + THIS + DEED + OF = DEATH (3) (King John)
NO + MAN + BEARS + SORROW = BETTER (3) (Julius Caesar)
WHAT + WAS + THY = CAUSE (2) (King Lear)
ILL + MAKE + ALL = SPEED (3) (Measure for Measure)
FOR + LACK + OF = TREAD (3) (A Midsummer Night's Dream)
AND + THE + DEATH + OF + A + DEAR = FRIEND (2) (A Midsummer Night's Dream)
HIS + HORSE + IS = SLAIN (2) (King Richard III)
I + THINK + HE + CANNOT = CHOOSE (4) (The Taming Of The Shrew)
HAD + I + A + GLASS + I = WOULD (3) (The Taming Of The Shrew)
O + THOU + TOUCH + OF = HEARTS (2) (The Life Of Timon Of Athens)
TIS + SAD + TITUS = CALLS (3) (The Tragedy Of Titus Andronicus)

A + FAT = ASS (1)
AS + A = MOM (1)
I + DID = TOO (1)
NO + NO + TOO = LATE (1)
OOOH + FOOD = FIGHT (1)

AFTER + TWO = YEARS (2)
AND + I + WONT + DO + IT = AGAIN (2)
BEER + AND = SODAS (2)
CALL + THEIR = OFFICE (2)
CHECK + THE = TIRES (2)
CUDDLY + PUPPY = MILITIA (2)
DAYS + TOO = SHORT (2)
DO + YOU + FEEL = LUCKY (2)
EVER + SINCE = DARWIN (2)
FOR + LOST = GIRLS (2)
FULL + METAL = JACKET (2)
GONE + ON + THE = FRITZ (2)
HAVE + A + GREAT = SUMMER (2)
HE + SEES + THE = LIGHT (2)
HES + THE = BEST (2)
HOW + MUCH = POWER (2)
I + KNEW + IT + WASNT + A = KEEPER (2)
I + LOVE + YOU = CEILE (2)
I + LOVE + YOU = EMILE (2)
ILL + STILL = LAUGH (2)
IT + ISNT + GOING + TO = HAPPEN (2)
IT + SUITS + MY = NEEDS (2)
MENTAL + HEALTH = MATTERS (2)
NO + NOT + THAT = AGAIN (2)
NO + PHONE + CALLS = PLEASE (2)
NOW + WE + KNOW + THE = TRUTH (2)
PLEASE + MAKE = OFFERS (2)
SADDAM + IS + A + MASS = MURDER (2)
SO + WHOS + THE = LOSER (2)
SO + WHY + WASTE + THE = EFFORT (2)
SO + YOU + WERE = RAPED (2)
SORRY + TO + BE + A + PARTY = POOPER (2)
SORRY + TO + BUST + YOUR = BUBBLE (2)
STEEL + BELTED = RADIALS (2)
STILL + HAS = TRUTH (2)
THAT + HIT + A = NERVE (2)
THATS + A + SIDE = EFFECT (2)
THE + WITCH + OF + THE = NORTH (2)
THIS + IS + TOO = FUNNY (2)
THROW + AWAY = PEOPLE (2)
TO + GO = OUT (2)
TWO + SHOWS + IN + ONE = NIGHT (2)
WE + ARE + DEAD = WORDS (2)
WHERE + IS + THE = TRUTH (2)
WINTER + INTO = SPRING (2)
YOU + SILLY = GOOSE (2)
YOURE + FREE + TO = PURSUE (2)
ZERO + POINT = ENERGY (2)

ABRA + CADABRA + ABRA + CADABRA = HOUDINI (3)
AND + A + STRONG + OFFENSE + AS + A + GOOD = DEFENSE (3)
AND + HERES + A = STORY (3)
AND + PLANT + LITTLE = POSIES (3)
AND + THIS + ONE + DOESNT = EITHER (3)
BUS + ERROR + CORE = DUMPED (3)
BUT + HE + COULD = TEACH (3)
BUT + IT + STILL + IS = EARLY (3)
BUT + ITS + GOOD = MUSIC (3)
BUT + ITS + STILL = FUNNY (3)
COULD + ANYONE = REALLY (3)
DEATH + TO + ALL + THAT = APPOSE (3)
EASY + STREET + SIMI = VALLEY (3)
EVERY + THREE = MONTHS (3)
GET + NEAR + THE = GLASS (3)
HE + HAS + CLEAR = LUNGS (3)
HER + HOPE + BECAME + A = PRAYER (3)
HERES + THE + TRUTH = PEOPLE (3)
HOCUS + POCUS = PRESTO (3)
HOPE + THIS + HELPS + OTHER = PEOPLE (3)
I + AGREE + ITS = TOUGH (3)
I + DONT + THINK + ITS + THE = SEASON (3)
I + GUESS + THE + TRUTH = HURTS (3)
I + LIVE + VERY + VERY = WELL (3)
I + STILL + WANNA + STAY = ANALOG (3)
IF + SANTA + DID = EXIST (3)
INSIDE + THE + UNITED = STATES (3)
ISNT + THIS + FUN = STUFF (3)
IT + IS + NOT + A + DEAD = ISSUE (3)
IT + IS + STILL + BEING = TESTED (3)
IT + TAKES + A + LITTLE = EFFORT (3)
ITS + A + GREAT = STORE (3)
ITS + GOING + TO + BE + A = BLAST (3)
LETS + CUT + TO + THE = CHASE (3)
LETS + SEE + IF + IT = WORKS (3)
MALE + AND + FEMALE = SKULLS (3)
MEDIUM + SIZE = HOUSES (3)
NEVER + LEAVE + ME = ALONE (3)
NEW + IN + THESE = PARTS (3)
PROOF + READER = DELUXE (3)
RIPPED + APART = INSIDE (3)
SEEST + THOU + THESE = SCALES (3)
SLEEP + FOR = HOURS (3)
SOME + GOOD = IDEAS (3)
STILL + WITHIN = LIMITS (3)
TASTE + ALL + THESE = DISHES (3)
THAT + IS + WHY + IT + IS = FALSE (3)
THAT + ISNT + GOING + TO = CHANGE (3)
THAT + WAS + NOT + MONTY = PYTHON (3)
THE + CATCH + AS + CATCH + CAN = MINDED (3)
THE + CENTER + OF + THE = CIRCLE (3)
THE + CEO + COMES = FIRST (3)
THE + DEATH + OF + CANNON = FODDER (3)
THE + DEATH + VALLEY = DRIVER (3)
THE + DOG + GOT + HER + ON + THE + HAND = AGAIN (3)
THE + SECRET + IS = SIMPLE (3)
THE + UNDER = WORLD (3)
THERE + ARE = RISKS (3)
THERE + WAS + NO + OTHER = REASON (3)
THEY + DIDNT + RESIST = ARREST (3)
THIS + DOES + THE = TRICK (3)
UNDER + THE + UNITED = STATES (3)
USING + LOCAL = ACCESS (3)
WE + ARENT + BABIES = EITHER (3)
WE + GOT + THE + WRONG + ONE = AGAIN (3)
WHAT + A + WEEK + AT + NEWS + THIS + HAS = BEEN (3)
WHEN + I + REALLY + WANT + A = THRILL (3)
WHILE + LONDON = FLOODS (3)
WORLD + TRADE = CENTER (3)

BATMAN + GOTHAM = NIGHTS (4)
EASTERN + OREGON + STATE = COLLEGE (4)
ELVIS + PRESLEY = POSTERS (4)
GET + ALONG + LITTLE = DOGIES (4)
HIGHER + LEVEL = PEOPLE (4)
HOW + SWEET + COFFEE = TASTES (4)
I + GUESS + TASTES = CHANGE (4)
I + KNOW + I + DONT + WANT + TO + KNOW = THIS (4)
MAINTAIN + INTERNET = FIREWALL (4)
MIAMI + STILL + HAS + A = CHANCE (4)
THATS + ENOUGH = CHANGE (4)
THATS + NEVER + BEEN + A = SECRET (4)
THATS + THE + THEORY = ANYWAY (4)
THE + FOURTH + STATE + OF = MATTER (4)
THERE + ARE + OTHER + FORCES + OF = COURSE (4)
THESE + ARE + GREAT = DEALS (4)
THESE + TWENTY = NOBLES (4)
THIS + IT + SEEMS + TO + ME + IS + THE + HEART + OF + THE = MATTER (4)
UNITED + STATES + AND = CANADA (4)
WHICH + IS + IN + ONE + CORNER + OF + HIS = OFFICE (4)
YEAH + THATS + OUR = STORY (4)
YOUVE + NEVER + BEEN + TO = EUROPE (4)

Puzzles involving related words

BILL + WILLIAM + MONICA = CLINTON (4)

Some puzzles with words from the Harry Potter books.

DEAN + DRACO + WAND = WIZARD (2)
RUBEUS + SIRIUS = AZKABAN (3)
DEAN + FRED + GEORGE = POTTER (3)
DEAN + MERLIN + WAND = WIZARD (3)
GEORGE + GINNY + RON = POTTER (4)
HARRY + CHARM + GINNY + RON = MAGIC (4)

States, countries, oceans, and planets.

IDAHO + NEVADA = STATES (4)
ALASKA + KANSAS + NEVADA = STATES (4)
ALASKA + KANSAS + TEXAS = STATES (4)
HAWAII + MAINE + TEXAS = STATES (4)
IDAHO + MAINE + OHIO = STATES (4)
IDAHO + NEVADA + OHIO = STATES (5)
KANSAS + MAINE + NEVADA = STATES (5)
KANSAS + MAINE + OHIO = STATES (4)
HAWAII + IDAHO + IOWA + OHIO = STATES (4)
IDAHO + IOWA + OHIO + TEXAS = STATES (5)

COSTARICA + ERITREA + ESTONIA = COUNTRIES (5)
AUSTRIA + COSTARICA + CROATIA + IRAN = COUNTRIES (5)
AUSTRIA + COSTARICA + IRAN + RUSSIA = COUNTRIES (5)
COSTARICA + CROATIA + IRAN + RUSSIA = COUNTRIES (5)
COSTARICA + ERITREA + RUSSIA + TUNISIA = COUNTRIES (5)
AUSTRIA + COSTARICA + CROATIA + RUSSIA + TUNISIA = COUNTRIES (4)
COSTARICA + ERITREA + ESTONIA + IRAN + NAURU = COUNTRIES (5)
AUSTRIA + COSTARICA + ESTONIA + IRAN + NAURU + RUSSIA = COUNTRIES (5)

PACIFIC + PACIFIC + PACIFIC = ATLANTIC (3)

SATURN + URANUS = PLANETS (3)
SUN + URANUS + NEPTUNE = PLANETS (4)
MARS + SATURN + URANUS + NEPTUNE = PLANETS (5)
SATURN + URANUS + NEPTUNE + PLUTO = PLANETS (5)

Colors.

BEIGE + GREY = COLORS (2)
CORAL + ORANGE = COLORS (3)
GREEN + ORANGE = COLORS (3)
SIENNA + SILVER = COLORS (3)
AQUA + MAROON + SALMON = COLORS (4)
BEIGE + OLIVE + SILVER = COLORS (4)
BLACK + MAROON + SALMON = COLORS (5)
BLUE + CORAL + PURPLE = COLORS (4)
BLUE + OLIVE + SILVER = COLORS (3)
BLUE + PLUM + PURPLE = COLORS (3)
BROWN + CORAL + CYAN = COLORS (2)
BROWN + CORAL + SALMON = COLORS (4)
CORAL + CYAN + MAROON = COLORS (3)
CORAL + CYAN + ORANGE = COLORS (3)
CORAL + CYAN + SIENNA = COLORS (4)
CORAL + GREEN + SALMON = COLORS (5)
CORAL + MAROON + SALMON = COLORS (4)
CORAL + MAROON + TAN = COLORS (3)
CORAL + MAROON + TEAL = COLORS (4)
CORAL + OLIVE + SILVER = COLORS (3)
CORAL + OLIVE + VIOLET = COLORS (3)
CORAL + SIENNA + TAN = COLORS (4)
CYAN + GREEN + GREY = COLORS (2)
CYAN + GREEN + ORANGE = COLORS (3)
GOLD + OLIVE + SILVER = COLORS (4)
GREEN + ORANGE + SALMON = COLORS (4)
GREEN + ORANGE + TEAL = COLORS (4)
LIME + MAROON + SALMON = COLORS (4)
LIME + RED + SILVER = COLORS (2)
LIME + SALMON + SIENNA = COLORS (4)
LIME + SILVER + VIOLET = COLORS (4)
MAROON + NAVY + SALMON = COLORS (4)
MAROON + SALMON + SIENNA = COLORS (4)
MAROON + SALMON + TEAL = COLORS (4)
AQUA + CORAL + MAROON + SALMON = COLORS (4)
CORAL + CYAN + GREEN + GREY = COLORS (3)
CORAL + GOLD + GREEN + RED = COLORS (2)
CORAL + GREEN + MAROON + SALMON = COLORS (5)
CORAL + GREEN + ORANGE + SALMON = COLORS (5)
CORAL + GREEN + ORANGE + SIENNA = COLORS (5)
CORAL + GREEN + TAN + TEAL = COLORS (3)
CORAL + OLIVE + SILVER + TEAL = COLORS (4)
CYAN + GREEN + GREY + ORANGE = COLORS (4)
GOLD + GREEN + ORANGE + RED = COLORS (4)
OLIVE + SILVER + TEAL + VIOLET = COLORS (4)
CORAL + CYAN + MAROON + NAVY + SALMON = COLORS (5)
CORAL + GREEN + ORANGE + TAN + TEAL = COLORS (5)

CHESS + CHECK + KING = KNIGHT (3)
CHECK + MATE + KING = KNIGHT (3)
CHECK + KING + QUEEN = KNIGHT (4)

GEMINI + VIRGO = CANCER (4)
GEMINI + LIBRA = CANCER (4)
TAURUS + PISCES = SCORPIO (4)
LEO + LIBRA + ARIES = PISCES (4)

DALI + MONET = RENOIR (2)
MATISSE + RENOIR = CASSATT (4)
RENOIR + SEURAT = GAUGUIN (3)
CASSATT + RENOIR = PICASSO (3)
MANET + SEURAT = RENOIR (4)
CASSATT + CEZANNE + MANET = MATISSE (4)
CASSATT + MATISSE + MIRO = PICASSO (4)
CASSATT + MATISSE + MONET = PICASSO (4)
DEGAS + INGRES + SARGENT + SEURAT = GAUGUIN (5)
CASSATT + MANET + MATISSE + MONET = PICASSO (4)
MANET + MATISSE + MIRO + MONET + RENOIR = CASSATT (5)
CASSATT + GAUGUIN = ARTISTS (4)
GAUGUIN + RENOIR = ARTISTS (3)
BOSCH + CASSATT + ESCHER = ARTISTS (4)
BRAQUE + RUBENS + SEURAT = ARTISTS (4)
CASSATT + COROT + INGRES = ARTISTS (4)
CASSATT + DEGAS + SEURAT = ARTISTS (4)
CASSATT + MANET + MONET = ARTISTS (3)
CASSATT + PICASSO + RENOIR = ARTISTS (4)
CASSATT + RUBENS + SEURAT = ARTISTS (5)
COROT + PICASSO + RENOIR = ARTISTS (4)
CEZANNE + MANET + MATISSE = ARTISTS (4)
DAVID + MATISSE + SEURAT = ARTISTS (4)
DEGAS + SARGENT + SEURAT = ARTISTS (4)
DURER + GAUGUIN + SEURAT = ARTISTS (4)
GOYA + INGRES + SARGENT = ARTISTS (3)
INGRES + MONET + RENOIR = ARTISTS (4)
INGRES + RODIN + SARGENT = ARTISTS (3)
MANET + RENOIR + SEURAT = ARTISTS (4)
MANET + RUBENS + SEURAT = ARTISTS (4)
CASSATT + COROT + DALI + DAVID = ARTISTS (3)
CASSATT + COROT + ESCHER + SEURAT = ARTISTS (4)
CASSATT + COROT + INGRES + SARGENT = ARTISTS (4)
CASSATT + COROT + MANET + MIRO = ARTISTS (3)
CASSATT + COROT + PICASSO + RENOIR = ARTISTS (4)
CASSATT + COROT + RENOIR + RODIN = ARTISTS (5)
CASSATT + INGRES + RENOIR + SARGENT = ARTISTS (4)
CASSATT + MANET + MIRO + RENOIR = ARTISTS (5)
CASSATT + MANET + MONET + RENOIR = ARTISTS (5)
CASSATT + MATISSE + MIRO + SEURAT = ARTISTS (4)
DAVID + DEGAS + INGRES + SARGENT = ARTISTS (4)
DAVID + DURER + MATISSE + SEURAT = ARTISTS (4)
DEGAS + DURER + INGRES + SARGENT = ARTISTS (4)
DEGAS + INGRES + MANET + MATISSE = ARTISTS (4)
DURER + MANET + MATISSE + SEURAT = ARTISTS (4)
GAUGUIN + INGRES + RENOIR + SEURAT = ARTISTS (5)
GOYA + INGRES + RENOIR + SARGENT = ARTISTS (4)
INGRES + MANET + MIRO + MONET = ARTISTS (3)
INGRES + MATISSE + MIRO + SARGENT = ARTISTS (4)
INGRES + MIRO + MONET + SARGENT = ARTISTS (4)
INGRES + RENOIR + SARGENT + SEURAT = ARTISTS (5)
MIRO + MONET + RENOIR + SARGENT = ARTISTS (5)
CASSATT + COROT + MANET + MIRO + RENOIR = ARTISTS (5)
CASSATT + COROT + MIRO + MONET + RENOIR = ARTISTS (5)
CASSATT + MANET + MIRO + MONET + RENOIR = ARTISTS (5)
COROT + MANET + MATISSE + MONET + RENOIR = ARTISTS (5)
COROT + MATISSE + MIRO + MONET + RENOIR = ARTISTS (4)
DURER + GAUGUIN + INGRES + SARGENT + SEURAT = ARTISTS (5)
INGRES + MANET + MATISSE + MONET + SARGENT = ARTISTS (4)
INGRES + MANET + MATISSE + SARGENT + SEURAT = ARTISTS (5)
INGRES + MANET + MIRO + MONET + SARGENT = ARTISTS (4)
INGRES + MATISSE + MIRO + MONET + RENOIR = ARTISTS (4)
MANET + MATISSE + MIRO + MONET + RENOIR = ARTISTS (4)
MANET + MATISSE + MONET + RENOIR + SARGENT = ARTISTS (5)
CASSATT + MANET + MATISSE + MIRO + MONET + RENOIR = ARTISTS (5)

SUMAC + ALDER + ELDER = TREES (4)
ALDER + MAPLE + ELDER = TREES (4)
ELM + ALDER + MAPLE + ELDER = TREES (4)
ALDER + MAPLE + ELDER + PALM = TREES (4)
ELM + ALDER + ASPEN + MAPLE + PALM = TREES (5)
ELM + ALDER + ASPEN + ELDER + PALM = TREES (5)
ALDER + ASPEN + MAPLE + ELDER + PALM = TREES (4)
ELM + ALDER + ASPEN + MAPLE + ELDER + PALM = TREES (4)

GOD + SODOM = BIBLE (2)
GOD + EVE + EVIL = BIBLE (2)
JESUS + BIBLE = CHURCH (4)
CAIN + SIN + MICAH + SARAH + CANAAN + ISAIAH + MANNA + NEHEMIAH + SACRAMENT = CHRISTIAN (4)

COMPLEX + LAPLACE = CALCULUS (2)
CIRCLE + ELLIPSE + EULER + SERIES + SUM = CALCULUS (2)
ABSCISSA + AREA + CIRCLE + EQUAL + EULER + SCALAR = CALCULUS (2)
AREA + CONE + LAPLACE + PARALLEL + POLAR + SCALAR + SLOPE = CALCULUS (3)
ARC + AREA + ELLIPSE + EULER + LAPLACE + SCALAR + SERIES + SUM = CALCULUS (3)

DNA + ALLELE + DIPLOID = SPECIES (4)
CLONE + GENE + MEIOSIS + MITOSIS = GENETIC (4)
DNA + ALLELE + CLADE + GENE = SPECIES (2)

Long words
These puzzles are made up of words that are all at least 12 letters long.

4 Summands:

ARISTOCRATIC + PRESCRIPTION + PROSOPOPOEIA + PROTECTORATE = TRANSOCEANIC (3)

5 Summands:

NARRAGANSETT + NONOGENARIAN + OSTEOPOROSIS + PROPORTIONATE + TRANSPOSITION = RETROGRESSION (5)
INTERNESCINE + OSTEOPOROSIS + PERSPIRATION + POSTPROCESSOR + PROSCRIPTION = TRANSPIRATION (5)
ANTIPERSPIRANT + INTERSTITIAL + PRESENTATION + PROPORTIONATE + TRANSLITERATE = TRANSPORTATION (4)

7 Summands:

ARISTOCRATIC + POSTPOSITION + PROCRASTINATE + PROPRIOCEPTION + PROSCRIPTION
+ PROTECTORATE + TRANSOCEANIC = INTERPRETATION (4)
INAPPROPRIATE + OSTEOPOROSIS + PROCRASTINATE + PROSOPOPOEIA + RECONNAISSANCE
+ SPECTROSCOPE + TRANSCRIPTION = PROPRIOCEPTION (5)

8 Summands:

APPERCEPTION + ARISTOCRATIC + INTERPRETATION + PRESENTATION + PROPRIOCEPTION
+ PROSCRIPTION + TRANSPIRATION + TRANSPOSITION = CONCESSIONAIRE (5)
PERSPIRATION + POSTPROCESSOR + PRACTITIONER + PROSCRIPTION + PROSOPOPOEIA
+ RECONNAISSANCE + TRANSOCEANIC + TRANSPOSITION = CONCESSIONAIRE (5)
POSTPOSITION + PRESENTATION + PROTESTATION + RECONNAISSANCE + SPECTROSCOPE
+ SPECTROSCOPIC + TRANSCRIPTION + TRANSPOSITION = INTERPRETATION (5)
APPERCEPTION + ARISTOCRATIC + INCONSISTENT + OSTEOPOROSIS + PRESCRIPTION
+ PROTECTORATE + PROTESTATION + STATISTICIAN = SPECTROSCOPIC (5)
INCONSISTENT + OSTEOPOROSIS + PERSPIRATION + POSTPOSITION + PRESENTATION
+ PROPORTIONATE + SPECTROSCOPIC + TRANSPIRATION = TRANSPORTATION (5)
APPERCEPTION + INTERCEPTION + PRACTITIONER + PROSCRIPTION + PROTECTORATE
+ SPECTROSCOPE + SPECTROSCOPIC + TRANSOCEANIC = TRANSPOSITION (5)

18 Summands:

APPERCEPTION + ARISTOCRATIC + CONCESSIONAIRE + CONSCRIPTION + INAPPROPRIATE
+ INCAPACITATE + INCONSISTENT + INTERCEPTION + OSTEOPOROSIS + PERSPIRATION
+ PRESCRIPTION + PROSCRIPTION + PROSOPOPOEIA + PROTECTORATE + PROTESTATION
+ STATISTICIAN + TRANSOCEANIC + TRANSPIRATION = ANTIPERSPIRANT (5)

Doubly True Alphametics
There is a class of alphametic puzzles involving spelled numbers which are doubly true. There is a vast number of these puzzles if you allow duplication of numbers (45842 with sums less than or equal to 100), but few where all of the numbers are unique. Here are all twelve of these in english with sums up to 100 (with exactly one solution):

ONE + NINE + TWENTY + FIFTY = EIGHTY (4)
TWO + FOURTEEN + FIFTEEN + TWENTY = FIFTYONE (4)
THREE + SEVEN + TEN + TWENTY + THIRTY = SEVENTY (4)
THREE + NINE + TEN + FOURTEEN + FIFTEEN = FIFTYONE (4)
FIVE + SIX + SIXTEEN + NINETEEN + TWENTY = SIXTYSIX (3)
SIX + NINE + ELEVEN + SIXTEEN + NINETEEN = SIXTYONE (3)
EIGHT + TEN + SIXTEEN + SEVENTEEN + EIGHTEEN = SIXTYNINE (5)
ONE + FIVE + TEN + ELEVEN + NINETEEN + FORTYFIVE = NINETYONE (3)
ONE + SEVEN + NINE + FIFTEEN + SIXTEEN + SEVENTEEN = SIXTYFIVE (5)
FIVE + SEVEN + ELEVEN + TWELVE + FIFTEEN + TWENTY = SEVENTY (5)
SIX + SEVEN + NINE + TWELVE + SIXTEEN + TWENTY = SEVENTY (5)
ONE + TWO + FIVE + NINE + ELEVEN + TWELVE + FIFTY = NINETY (5)

I've included some with repeated numbers. I've used a shorthand so these don't get too long by writing, for example, 5(two) instead of two + two + two + two + two.

SIX + SEVEN + SEVEN = TWENTY (2)
TEN + TEN + FORTY = SIXTY (3)
ONE + NINE + TWENTY + FIFTY = EIGHTY (4)
TWO + FOURTEEN + FIFTEEN + TWENTY = FIFTYONE (4)
THREE + THREE + THREE + ELEVEN = TWENTY (4)
FIVE + FIVE + NINE + ELEVEN = THIRTY (4)
FIVE + FIVE + THIRTY + FORTY = EIGHTY (5)
FIVE + FIVE + THIRTY + FIFTY = NINETY (3)
SIX + EIGHT + EIGHT + EIGHT = THIRTY (3)
SEVEN + SEVEN + SEVEN + NINE = THIRTY (4)
SEVEN + TEN + TEN + FOURTEEN = FORTYONE (4)
5(TWO) + 3(TWENTY) = SEVENTY (3)
5(FOUR) + TEN + TWENTY + FORTY = NINETY (5)
6(SEVEN) + EIGHT + THIRTY = EIGHTY (5)
6(TWO) + EIGHT + TEN + FIFTY = EIGHTY (2)
8(THREE) + FOUR + FOURTEEN = FORTYTWO (5)
4(EIGHT) + 4(NINE) + 2(ELEVEN) = NINETY (3)
8(SEVEN) + 3(EIGHT) = EIGHTY (3)
12(FIVE) + 2(SIX) + EIGHT = EIGHTY (3)
FIVE + 13(SIX) + SEVEN = NINETY (3)
85(ONE) + TWO + THREE = NINETY (5)

Below are some in foreign languages. I've ignored accent marks.
There are no doubly true alphametics in French with sums less than or equal to 100 where no numbers are repeated. Here are some where there are repeated numbers. As with all of the puzzles on this page there is exactly one solution to each of these.

UN + UN + NEUF = ONZE (1)
CINQ + CINQ + VINGT = TRENTE (3)
UN + UN + QUATRE + DOUZE + DOUZE = TRENTE (5)
UN + DEUX + DEUX + DEUX + DEUX = NEUF (2)
UN + QUATRE + CINQ + CINQ + QUINZE = TRENTE (4)
3(TROIS) + CINQ + SEIZE = TRENTE (4)
3(QUATRE) + NEUF + NEUF = TRENTE (4)
5(QUATRE) + CINQ + CINQ = TRENTE (4)
15(DEUX) = TRENTE (2)
2(UN) + 6(DEUX) + 6(SIX) + 5(DIX) = CENT (3)
9(UN) + 5(DEUX) + 7(DIX) + ONZE = CENT (3)
88(UN) + 6(DEUX) = CENT (3)

In Italian there are eleven doubly true (single solution) alphametics with sums up to 100 where there are no repeated words.

VENTITRE + TRENTA + TRENTOTTO = NOVANTUNO (3)
UNO + QUATTRO + SETTE + VENTOTTO = QUARANTA (4)
DUE + SETTE + DIECI + UNDICI = TRENTA (5)
TRE + SEI + DIECI + UNDICI = TRENTA (4)
UNO + NOVE + VENTIDUE + VENTOTTO + TRENTUNO = NOVANTUNO (4)
OTTO + NOVE + TREDICI + VENTI + TRENTA = OTTANTA (4)
DUE + SETTE + OTTO + NOVE + TRENTADUE + TRENTATRE = NOVANTUNO (3)
SEI + SETTE + DODICI + DICIOTTO + VENTISEI + VENTINOVE = NOVANTOTTO (2)
UNO + OTTO + NOVE + DIECI + UNDICI + VENTI + VENTUNO = OTTANTA (4)
DUE + TRE + SETTE + OTTO + NOVE + VENTUNO + TRENTA = OTTANTA (4)
UNO + DUE + TRE + OTTO + UNDICI + DODICI + TREDICI + TRENTA = OTTANTA (4)

Here are some Italian ones with repeated words:

TRE + CINQUE + CINQUE = TREDICI (3)
CINQUE + CINQUE + SEI = SEDICI (3)
UNO + CINQUE + CINQUE + CINQUE = SEDICI (3)
DUE + DUE + CINQUE + SETTE = SEDICI (4)
DUE + DUE + CINQUE + DODICI = VENTUNO (4)
DUE + CINQUE + CINQUE + NOVE = VENTUNO (3)
TRE + TRE + DODICI + DODICI = TRENTA (3)
TRE + QUATTRO + SETTE + SETTE = VENTUNO (3)
CINQUE + DIECI + DIECI + QUINDICI = QUARANTA (5)
SEI + SEI + OTTO + DIECI = TRENTA (3)
2(CINQUE) + 3(OTTO) + 2(UNDICI) + 2(DODICI) = OTTANTA (5)
10(OTTO) + 2(DIECI) = CENTO (4)
9(DUE) + 2(SEI) + 2(QUINDICI) = SESSANTA (3)
4(CINQUE) + 10(SEI) = OTTANTA (3)
92(UNO) + 4(DUE) = CENTO (5)

In Spanish there are nine doubly true (single solution) alphametics with sums up to 100 where there are no repeated words.

SEIS + CATORCE + SETENTA = NOVENTA (5)
DOS + ONCE + TRECE + CATORCE + TREINTA = SETENTA (4)
TRES + SEIS + SIETE + CATORCE + SESENTA = NOVENTA (5)
CUATRO + CINCO + SIETE + CATORCE + TREINTA = SESENTA (5)
DOS + CINCO + SIETE + DOCE + CATORCE + TREINTA = SETENTA (4)
UNO + CUATRO + CINCO + SEIS + ONCE + TRECE + TREINTA = SETENTA (4)
TRES + CINCO + SEIS + OCHO + ONCE + TRECE + CATORCE = SESENTA (3)
TRES + SEIS + SIETE + ONCE + TRECE + VEINTE + TREINTA = NOVENTA (4)
UNO + DOS + TRES + CUATRO + ONCE + DOCE + TRECE + CATORCE = SESENTA (4)

Here are some Spanish ones with repeated words:

DOS + DOS + TRES = SIETE (2)
UNO + UNO + NUEVE + NUEVE = VEINTE (2)
UNO + CINCO + CINCO + NUEVE = VEINTE (4)
TRES + TRES + CATORCE + SETENTA = NOVENTA (5)
CUATRO + CUATRO + NUEVE + TRECE = TREINTA (4)
CINCO + CINCO + TREINTA + TREINTA = SETENTA (3)
OCHO + OCHO + CATORCE + TREINTA = SESENTA (4)
OCHO + DOCE + TREINTA + TREINTA = OCHENTA (4)
DIEZ + DIEZ + VEINTE + VEINTE = SESENTA (2)
UNO + UNO + UNO + SIETE + DIEZ = VEINTE (2)
UNO + UNO + UNO + SIETE + SETENTA = OCHENTA (2)
UNO + UNO + TRES + SEIS + NUEVE = VEINTE (3)
UNO + UNO + CUATRO + CUATRO + OCHENTA = NOVENTA (4)
UNO + DOS + DOS + CINCO + CINCO = QUINCE (2)
UNO + TRES + TRES + SEIS + SIETE = VEINTE (2)
UNO + CUATRO + CUATRO + ONCE + SETENTA = NOVENTA (5)
UNO + NUEVE + VEINTE + TREINTA + TREINTA = NOVENTA (4)
DOS + TRES + TRES + TRES + NUEVE = VEINTE (3)
DOS + TRES + TRES + CINCO + SIETE = VEINTE (4)
CUATRO + CUATRO + CUATRO + CUATRO + CUATRO = VEINTE (3)
CUATRO + CUATRO + CINCO + SEIS + ONCE = TREINTA (4)
OCHO + ONCE + ONCE + TREINTA + TREINTA = NOVENTA (3)
DIEZ + DIEZ + VEINTE + VEINTE + TREINTA = NOVENTA (4)
DIEZ + VEINTE + VEINTE + VEINTE + VEINTE = NOVENTA (3)
DOCE + DOCE + DOCE + CATORCE + TREINTA = OCHENTA (4)
TRECE + TRECE + CATORCE + VEINTE + VEINTE = OCHENTA (5)
8(DOS) + CATORCE + SESENTA = NOVENTA (4)
8(CUATRO) + 2(CATORCE) = SESENTA (4)
2(DOS) + 14(TRES) + CINCO + 2(SEIS) + 3(OCHO) + TRECE = CIENTO (5)

Here are links to several other web pages on the net that deal with these puzzles.
· Mike Keith's page with some very exotic puzzles.
· Jorge Soares's Cryptarithm page
· The Contest Center's Cryptarithm page
77,651 visits (1 today, 55 this week, 503 this month, 1,780 this year) since July 3, 1998.
Back to my alphametics index .
Back to my homepage .

Copyright 1998, 1999, 2000 by Truman Collins
For comments, email: Truman Collins (truman@tkcs-collins.com)
Most recent update: January 5, 2005
http://www.tkcs-collins.com/truman/alphamet/alphamet.shtml


German Examples
Rätsel und Denksport Metamatik Forum mailto: janko.at

Hier sind einige Aufgaben, die im doppelten Sinne wahr sind, im alphametischen und um wortwörtlichen!
Jeder Buchstabe steht für eine Ziffer von 0 bis 9, keine Zahl (auch kein Zwischenergebnis) beginnt mit einer 0, unterschiedliche Buchstaben bedeuten unterschiedliche Ziffern. Ein Punkt (bzw. ein leeres Feld) steht für eine beliebige Ziffer. Rekonstruieren Sie die Addition!

Deutsch
Im Deutschen gibt es nur einige wenige metamatische Aufgaben, zumindest viel weniger als in anderen Sprachen!

1   EINS+EINS+EINS+EINS=VIER
2   EINS+ZWEI+SIEBEN+SECHZIG=SIEBZIG
3   EINS+EINS+EINS+DREI+DREI=NEUN
4   ZWEI+ZWEI+ZWEI+SIEBEN+SIEBEN=ZWANZIG
5   ZWEI+VIER+VIER+VIERZIG+VIERZIG=NEUNZIG
6   SECHS+SECHS=ZWOELF

Links
Colins Trueman
Link: http://www.tkcs-collins.com/truman/alphamet/alphamet.shtml
Mike Keith
Link: http://users.aol.com/s6sj7gt/mikealp.htm
Naoyuki Tamura
Link: http://bach.istc.kobe-u.ac.jp/llp/crypt.html
Torsten Sillke
Link: http://www.mathematik.uni-bielefeld.de/~sillke/PUZZLES/ALPHAMETIC/
... und einige Originale von uns!


Russian Examples
Related words
НИТКА+НИТКА=ТКАНЬ
ВАГОН+ВАГОН=СОСТАВ
ВЕТКА+ВЕТКА=ДЕРЕВО
МАГНИЙ+ТАНТАЛ=МЕТАЛЛЫ
2*РАЙОН=ГОРОД
2*ЛАДЬЯ=ФЕРЗЬ
3*КНИГА=НАУКА
ДЕДКА+БАБКА+РЕПКА=СКАЗКА
АТАКА+2*УДАР=НОКАУТ
4*АИСТ=СТАЯ
ГОЛ*ГОЛ=ФУТБОЛ

Doubly true
СОРОК+СОРОК+СОРОК+СОРОК+СОРОК= ДВЕСТИ
ОДИН+ОДИН=МНОГО


Alphametic Puzzle Generator

This page will allow you to search for alphametic puzzles (for a description of what they are and for some examples, see my alphametics page ) among a group of words. These puzzles are rare, but given a number of words to use, it's not unusual to find one or two. I've also written a web-based solver for these puzzles.
The generator will search for puzzles among all the permutations of the words given and find all puzzles conforming to the specified parameters. For an example of how to use it, see the bottom of this page.
You need to enter at least three words (two if you allow duplication), or there won't be enough options for summands and a sum. If you want to try to find puzzles with the possibility of duplicated summands, you can set the button to allow repeated words. Note that allowing words to appear as summands more than once means that the maximum possible number of summands isn't limited by the number of words you enter, so set the maximum summands limit appropriately.
Try searching among all of the names in your family, or terms related to a hobby, or something you're interested in. If you find any good ones, I'd be interested if you'd email me about them.
Note: The C program I wrote to search for these puzzles is very fast, however, a large enough list of words (15 to 20 or so) can bog it down. The program will terminate after about five seconds of time so as not to use up too much of my ISP's resources. The amount of searching will depend partly on the how busy my ISP's machine is when you run it. See the bottom of this page for more technical information about how the solver works and what to do if it runs out of time.

What base do you want to search for puzzles in (10, normally)?
Minimum number of summands:
Maximum number of summands:
Do you only want puzzles with one solution?
Yes (only puzzles with exactly one solution will be generated)
No (puzzles with one or more solutions will be generated)
Do you want to only look for puzzles with the first listed word as the sum?
No (search for puzzles with any of the listed words as the sum word)
Yes (use only the first word listed as the sum word)
Do you want to allow repeated words among summands?
No (all summands will be unique)
Yes (repeated summands are allowed. This will increase processing time)
Enter the words to search for puzzles, one word per line:

Example: Look for puzzles among the names of the planets where the word 'planets' is the sum.

Use base 10, set minimum summands to 2 and maximum to 9. Ask for puzzles with only one solution, and select 'Yes' to only look for puzzles with the first listed (planets) word as the sum.
Don't allow repetition.

Enter the following words and make sure 'planets' is first:
After you press the submit button, it should find the following puzzles:

Technical Details
If the solver terminates because it ran out of time, there are several things you can do. Usually the best thing to try first is to reduce the range between the minimum and maximum summands. For example, if you want to look for puzzles with from 2 to 6 summands, you can get the same results asking for from 2 to 3 in one run and 4 to 6 in another run. Allowing repeated words for summands can increase processing time significantly, so disallowing them will help. Additionally, you may want to shorten the list of words, only ask for puzzles with one solution, or ask for puzzles with a specific word as the sum. For anyone using bases other than ten, larger bases take more time. There's not a specific number of words that's a limit because how long the analysis will take depends on the words in the list. Since the time limit is based on clock time instead of CPU time, using this generator when my ISP is less busy will get you farther. When exactly that is I don't know, but I'd guess that late night and early morning Pacific time would be a good bet.
The program searches for puzzles among all of the permutations of the words given, but it weeds out ones that can't have solutions due to word length or having more letters than the specified base. For example, "I + LOVE = ANN" can't have a solution because the sum is too short, and "HILLARY + RODHAM = CLINTON" has too many letters to have a solution in base 10. The permutations not easily weeded out in one of these ways are potential puzzles. For each of these the program tries to find one or more solutions. The program uses a smart depth-first search from the left to the right of the puzzle. With average length words and a machine that's not too heavily loaded, it will do about 300 of these searches a second.

53,080 visits (10 today, 65 this week, 65 this month, 5,843 this year) since January 3, 2000.
Back to my alphametics index .
Back to my homepage .

Copyright 2000 by Truman Collins
For comments, email: Truman Collins (truman@tkcs-collins.com)
Most recent update: January 5, 2005
http://www.tkcs-collins.com/truman/alphamet/alpha_gen.shtml


Methods of Their Solution
See also: Restrictions Normal Form
The first step is to decide whether the problem is solvable at all.

Unsolvable Puzzles
q The number of characters to be substituted are greater than the base of the number system. e. greater than 10 in the decimal one. Such problems are unsolvable because of the demand that different character must denote different digits.
q The number of characters to be substituted is equal to the base of the number system but all characters appear in word leading position. This case hurts the rule prohibiting the leading zeroes.
q One of the summands is longer than the result.
q The result is has too many digits compared to the length and count of summands.
q The above the rules may be generalized taking in account that an N-digit word may have values in the interval [10N -1,10N -1]. These ranges can be added on both sides of the equation and compared with each other.

For example, "I + LOVE = ANN" can't have a solution because the sum is too short, and "HILLARY + RODHAM = CLINTON" has too many letters to have a solution in base 10. "JOE+JILL=FAMILY" is unsolvable because addition of two 3-digit numbers may result three or four digit sums.
"AB+BC+CD+DE+EF+FG+GH+HI+IJ=9*JK" is unsolvable because at least one letter among A, B, C, D, E, G, H, I, J should be zero but all of them occur in leading position.

Brute-Force Total Backtracking
The least sophisticated way is to try to substitute all digits into the first letter of the puzzle then try to substitute all remaining letters into its second letters the N-2 rest ones into the third letter, so on. The check of equality of the left and right sides of the equation may be delayed after the substitution of the last present letter with one of the remaining digits. This is a simple but sl ooo w algorithm. If the base of the number system is M and the count of different codes is N then the total number of variations is M!/(M-N)!. In case of M=10 and N=10 the number of variations is 10!=3,628,800.

Ways in order to shorten the process

Restrictions for possible values of the characters in the leading position of the longest word
SEND
+MORE
M ONEY
ÉLJEN
+MÁJUS
E LSEJE
2×TÍZ=HÚSZ
U SSR
+ U SA
P EACE

¨ The common feature of the above puzzles is that the result of addition of two N-digit number has N+1 digits. It is trivial that the first digit from the N+1 ones may be only 1. So M=1, E=1, H=1, and P=1, respectively.
¨ We can get a sum having has N+1 digits adding an N-1 digit number to an N digit number only if the first digit of the N digit number is one less than the base of the number system. So the value of U is 9 in the last puzzle.

Restrictions for possible values of the characters in the trailing position
2×TÍ Z =HÚS Z

The trailing character of all words is Z.
The above puzzle contains even number of words or even summed factor 2 on the left side and odd number of words or odd summed factor on the right which implies than Z may be only zero, nothing else.

In general, the puzzles on type
m ×... A = n ×... A

have solution in the following cases:
If m-n is divisible by 10 | then A may be any decimal digit
else if m-n is divisible by 5 | then A must be even digit
else if m-n is divisible by 2 | then A may be 0 or 5.

Do the intervals of the possible values of the left and right side of the equation intersect?
Remember that an N-digit word may have values in the interval [10N -1,10N -1]. If the word has factor F then the interval of the product is [F × 10N -1, F × 10N -1]. We can obtain an interval by summing this values for the left and right sides of the equation and counting

The ordered normal form gives another intervals. In case of decimal number system. The highest value is obtained when the code having the highest factor has the value 9, the code having the second highest factor has the value 8, so on. The lowest value is obtained when the code having the highest factor has the value 0, the code having the second lowest factor has the value 1, so on. This guessed interval can be intersected by the above.

If the intersection is the empty set then the problem has no solution. If it is not empty we can gain restrictions for the possible values for some characters usually occupying leading positions. For example we get for the leading characters of the 2× T ÍZ= H ÚSZ puzzle T  [5; 6; 7; 8; 9] and H=1.

Continued in chapter Simplification of the Equations and Their Further Classification . 


Simplification of the Equations and Their Further Classification
Continued from chapter Methods of Their Solution.
It is trivial that the following puzzles in the first column are the same as the ones in the last column:
Repeated additions | Language | Multiplications [and additions]
TWO+TWO+TWO+TWO+TWO + TWENTY+TWENTY+TWENTY = SEVENTY | English language | 5× TWO + 3× TWENTY = SEVENTY
АИСТ+АИСТ+АИСТ+АИСТ = СТАЯ | Russian language | 4× АИСТ=СТАЯ
TÍZ+TÍZ = HÚSZ | Hungarian language | 2× TÍZ = HÚSZ
EINS+EINS+EINS + DREI+DREI = NEUN | German language | 3× EINS + 2× DREI = NEUN

We have to transform the equations from the form "Repeated additions" to the form "Multiplications [and additions]".

The rules for the leading characters and the lengths of words can be more easily checked if we order the words according to their decreasing lengths. We can check the rules based on Length of the longest word and Relative length of the words.
Original form | Decreasing word length | Length of the longest word | Relative length of the words
I + LOVE = ANN | LOVE+I=ANN | 4 | 0; -3|-1
EINS+ZWEI+SIEBEN+SECHZIG=SIEBZIG | SECHZIG+SIEBEN+EINS+ZWEI=SIEBZIG | 7 | 0; 0; -3; -3|0
USSR +USA PEACE | USSR+USA=PEACE | 5 | -1; -2| 0

Grouping repeated words to the same side of the equation we can accept or reject the puzzles.
Original form | Simplified form | Class | Validity
3*BEAN+RICE=DISH+BEAN | 2*BEAN+RICE=DISH | product+word=word | accepted
BEAN+RICE=DISH+BEAN | RICE=DISH | one word=other word | rejected
2*TÍZ+HÚSZ =TÍZ+TÍZ | HÚSZ =0 | empty right side | rejected
2*TÍZ =TÍZ+TÍZ | 0=0 | both sides are empty | rejected

Simplification with the greatest common divisor of all factors from both sides of the equation may reduce the problem and can allow restrictions on the trailing characters based on divisibility rules.
Original form | Simplified form | Class | Restrictions on the trailing characters
20× TWO + 12× TWENTY = 4×SEVENTY | 5× TWO + 3× TWENTY = SEVENTY | 2 products = 1 word |
100× АИСТ=25×СТАЯ | 4× АИСТ=СТАЯ | 1 product = 1 word | Я is even
4× TÍZ = HÚSZ+HÚSZ | 2× TÍZ = HÚSZ | 1 product = 1 word | Z is zero


Normal Form of First-Order Puzzles
See also: Restrictions Methods of Solution
The first order puzzles i. e. those where unknown words are not multiplied with each other have a normal form where each found letter forms a single letter word having summed multipliers. The summed normal form can be ordered by decreasing factors then the factors of the letters occurring on both sides of the equation can be subtracted resulting zero on one side and positive factor on the other side.
Puzzle
Normal form
Summed normal form
Summed and ordered normal form
Subtracted normal form
 SEND
+MORE
MONEY
1000*S+(100+1)*E+10*N+1*D+1000*M+100*O+10*R=10000*M+1000*O+100*N+10*E+1*Y
1000*S+101*E+10*N+1*D+1000*M+100*O+10*R=10000*M+1000*O+100*N+10*E+1*Y
1000*M+1000*S+101*E+100*O+10*N+10*R+1*D=10000*M+1000*O+100*N+10*E+1*Y
1000*M+1000*S+91*E+1*D+100*O+10*R=9900*M+1000*O+90*N+10*E+1*Y
  ÉLJEN
+MÁJUS
ELSEJE
10000*É+1000*L+200*J+10*E+1*N+10000*M+1000*Á+10*U+1*S=(100000+100+1)*E+10000*L+1000*S+10*J
10000*É+1000*L+200*J+10*E+1*N+10000*M+1000*Á+10*U+1*S=100101*E+10000*L+1000*S+10*J
10000*É+10000*M+1000*Á+1000*L+200*J+10*E+10*U+1*N+1*S=100101*E+10000*L+1000*S+10*J
10000*É+10000*M+1000*Á+190*J+10*E+10*U+1*N=100101*E+9000*L+999*S
2×TÍZ=HÚSZ
2*100*T+2*10*Í+2*Z=1000*H+100*Ú+10*S+1*Z
200*T+20*Í+2*Z=1000*H+100*Ú+10*S+1*Z
200*T+20*Í+2*Z=1000*H+100*Ú+10*S+1*Z
200*T+20*Í+1*Z=1000*H+100*Ú+10*S
EINS+ZWEI+SIEBEN+SECHZIG=SIEBZIG
Summed coefficients on the left side
'I',10111
'E',102020
'W',100
'Z',1100
'S',1100001
'N',11
'B',100
'G',1
'H',1000
'C',10000

Summed coefficients on the right side
'G',1
'I',100010
'Z',100
'B',1000
'E',10000
'S',1000000
Summed coefficients on the left side
'S',1100001
'E',102020
'I',10111
'C',10000
'W',100
'Z',1100
'H',1000
'B',100
'N',11
'G',1

Summed coefficients on the right side
'S',1000000
'I',100010
'E',10000
'B',1000
'Z',100
'G',1
Subtracted coefficients on the left side
'S',100001
'E',92020
'C',10000
'H',1000
'Z',1000
'W',100
'N',11

Subtracted coefficients on the right side
'I',89899
'B',900
'G',0

Definition of the normal form:

Rightmost position of codes:
We can determine which is the rightmost position of each unknown code in the the puzzles that is which is the rightmost local decimal value influenced by it.
Puzzle | Rightmost position
SEND +MORE MONEY |
ÉLJEN +MÁJUS ELSEJE |
2×TÍZ=HÚSZ |

where [image] and [image] are the coefficients and [image] and [image] the decimal values substituted into the codes.

This normal form does not contain the information which characters were in leading position of the the original words that is which one must be substituted by zero. It can be used to check the validity of substitution. It is suitable to shorten the search for solution .

The coefficients of the normal form can be expressed as combinations influencing the columns belonging to local value [image] and
or higher, respectively.
The rightmost position of codes for the problem " EINS + ZWEI + SIEBEN + SECHZIG = SIEBZIG "
Code | Bigger side | Smaller side | Coefficient | Last significant digit | Power P | Last with given power
'G' | right | left | 0 | 0 | 0 | no
'I' | right | left | 89899 | 9 | 0 | no
'N' | left | right | 11 | 1 | 0 | no
'S' | left | right | 100001 | 1 | 0 | yes
'E' | left | right | 9202 | 2 | 1 | yes
'B' | right | left | 9 | 9 | 2 | no
'W' | left | right | 1 | 1 | 2 | yes
'H' | left | right | 1 | 1 | 3 | no
'Z' | left | right | 1 | 1 | 3 | yes
'C' | left | right | 1 | 1 | 4 | yes


How to Shorten the Search?
See also: Methods Their Solution Normal Form
The pointed chapters contain rules for leading and the trailing characters.
This chapter contains tricks to avoid brute-force backtracking for other characters in special positions.

Counting the Last Missing Digit

Let's suppose that somehow we have a guess for all unknown codes but one.
We have an equation based on the subtracted normal form of the equation.

where the coefficients of the subtracted normal form cleft, j and cright, i are all known, the tried values Vleft, j and Vright, i are known from the previous stages of the search except j=k.
We have a linear Diophantian equation
which we have to solve in the set of still available decimal digits
where
is the set of posible digit in the position k determined by other rules, not necessarily {0; 1; 2; 3;...;9}. See Restrictions for leading and trailing characters .

There are a few posible cases.
A [image] and p is divisible by q and the result is in the set D k . ==> Vleft, k has one solution to be checked.
B [image] and p is divisible by q and the result is not in the set D k . ==> Vleft, k has no solution so this branch of backtracking fails.
C [image] and p is not divisible by q ==> Vleft, k has no solution so this branch of backtracking fails.
D [image] ==> Vleft, k has no solution so this branch of backtracking fails.
E [image] ==> Vleft, k has more than one solution, all of them shall be tried and checked.

Fitting the unknown character from left to right
The characters which are not fixed based on their leading nor in trailing positions are recommended to fit from right to left, that is

0 at first those characters which occur in the last position of at least one word,
1 then those characters which have 101 local value based on their position,
2 followed by those characters which have 102 local value,
3 ...so on.

The order of substitution for doubly true Hungarian puzzle, 2×TÍZ=HÚSZ meaning ten+ten=twenty is
Z =0
H =1
T is 5, 6, 7, 8 or 9.
Í having rightmost position 101 must be selected from the values not occupied by Z, H and T.
S is the last code having rightmost position 101. Its value can be determined by the already known values of the characters having equal of lower rightmost position.
(1)

A simpler explanation:
If a code is the last unsolved one having a given power the the digit at that position is the last digit of a product of a known and an unknown factor.
(2)
The rightmost position of codes for the problem " EINS + ZWEI + SIEBEN + SECHZIG = SIEBZIG "
Code | Bigger side | Smaller side | Subtracted coefficient | Last significant digit | Power P | Last with given power
'G' | right | left | 0 | 0 | 0 | no
'I' | right | left | 89899 | 9 | 0 | no
'N' | left | right | 11 | 1 | 0 | no
'S' | left | right | 100001 | 1 | 0 | yes
'E' | left | right | 9202 | 2 | 1 | yes
'B' | right | left | 9 | 9 | 2 | no
'W' | left | right | 1 | 1 | 2 | yes
'H' | left | right | 1 | 1 | 3 | no
'Z' | left | right | 1 | 1 | 3 | yes
'C' | left | right | 1 | 1 | 4 | yes

The above table is ordered according to the ascending power then the ascending code. A better secondary sort order is that which gives the least possible solutions of Equation (2) .
q If the last significant digit is fside,k = 5 and n =0 then Vk may be any of even digits {0, 2, 4, 6, 8}.
q If the last significant digit is fside,k = 5 and n =5 then Vk may be only 5.
q If the last significant digit is fside,k is other odd number than5 and n =0 then Vk may be only zero.
q Two solutions exist for Vk i n case of even fside,k >0 factors because
if
then
q If the last significant digit fside,k = 3 or fside,k =7 then there is always one solution for Vk because 3 • f and 7 • f give different n for each 0<= f <=9 integers.
q The last significant digits f =9 and f =1 imply always one simple solution:
Vk = n for f =1, Vk = 10-n for f =9, respectively.
q If the summed coefficients belonging to a code are equal on the both sides of the equation then the fit has no other restriction than the exclusion of the used up characters. Such characters having fside,k = 0 are fitted in the last steps.


Command Line Arguments
The command line arguments of the program is interpreted as an explicit input filename. If the trimmed argument is the name of an existing and readable file the this file is processed immediately .
Execute program with command line argument


Menu System
Menu system at a glance:
The hot keys are shown in a separate column in the tested and executable menu and they appear after '\t' separators in design phase, respectively.
Menu system and hot keys


Main Menu
See also: Menu System Hot Keys Invoking Submenus
The main menu of the program has four items.
Item Hot keys
1 The operations are grouped in the File submenu. Alt-F
2 The search and output options are grouped in the Options menu. Alt-O
3 The third submenu deals with the rendering of the windows . Alt-W
4 General and special help calls are available in the fourth one. Alt-H


File Submenu
The File Submenu has the usual items related files. The hot keys corresponding to its menu items are underlined in the dropped down submenu.

The items refer to
I input files
II output of solutions
III terminating the program

Item | GeneralHot Key | Local Hot Key | Toolbar Button | Task
New | F7 | N | Toolban button for utem | This item opens a new data entry dialog .
Open | F8 | O | Toolbar button for item | This item invokes the Selection of Input Problem Files dialog then it reads in an input file. Its lines are accessible in the next new data entry dialog .
Show Input Facts | F5 | H |  | Shows input facts in the "Messages" window .
Process Immediately | F9 | P |  | This item invokes the Selection of Input Puzzle Files dialog then it reads in an input file. The program processes its lines immediately.
Save | F2 | S |  | This item saves results as preset by the Output Options and Save as item below.
Save as | F12 | A | Toolbar button for item | This item calls output options with selection of output solution files selection and saves results checked in the options.
Close Output | F10 | C |  | Saving leaves output files open. Here can you close them.
Exit | Alt-F4 | X |  | Exit from program.


Options Submenu

Options Menu

The Options Menu contains the options limiting the search for solutions and options controlling the verbosity an the destination of output of solutions. The hot keys corresponding to its menu items are underlined in the dropped down submenu.
Item | General Hot Key | Local Hot Key | Toolbar Button | Task
Search | F3 | S | Toolbar button for item | This item opens the Search Options Dialog .
Output | F4 | O | Toolbar button for item | This item opens the Output Options Dialog.


Window Submenu
See Also: Division of the Screen of the Program
The Window Submenu has items arranging the Entry and Report forms and the window on the usual manner.
Dropped down submenu |
Dropped down submenu window |
Cascade | Tile
Cascaded windows | Outcome of Tile
Item | Local Hot Key
Tile | T
Cascade | C
Arrange Icons | A
1 Messages | 1
2 Report so on | 2 , 3 ...so on


Help Submenu

This submenu invokes the selected node of the programs compiled help file.
Item | GeneralHot Key | Local Hot Key | Toolbar Button | Task
Present Dialog | F1 | P | Present dialog | This item opens keyword search based on the main keyword of the last active dialog.
Contents | Ctrl-F1 | C |  | This item invokes the default topic "What Are "Alphametic Puzzles"?
Menu System | Shift-F1 | M |  | Shows input facts in the "Messages" window .
Hot Keys | Alt-F1 | H |  | This item invokes keyword search on "hot keys" .
Close Windows | Shift-F11 | E |  | This item closes the active help windows.
About | Ctrl-F11 | A |  | This item displays the About dialog of the program.


Toolbar Buttons Corresponding to Menu Items
See also: Hot Keys Corresponding Menu Items Division of the Screen .
The project toolbar
1 2 3 4 5 6
The project toolbar is a shortcut to the following menu items:
1 File --> New,
2 File --> Open,
3 File --> Save as,
4 Options --> Search ,
5 Options --> Output ,
6 Help --> Present dialog.


Dialogs
The program has two modeless forms :
1 Entry for entering problems and
2 Report for showing solutions.

It has three modal dialogs:
I About introducing the program,
II Search Options governing the limit of sought solutions and
III Output Options prescribing the output devices and the verbosity of the reports.

Selection of
a input problem files and
b output solution files are made by common dialogs .


Search Options
The user can set in this modal dialog the conditions limiting the search for solutions.
Dialog of search options

The dialog can be invoked explicitly
¨ from the Options submenu selecting Search or
¨ by a toolbar icon or
¨ using a hot key.

It is invoked programmatically in case immediately processing files.

The explanation of the fields and buttons appear in the status line when they get focus.
Toolbar icon | Dialog name | Hot key | Explanation displayed in the status line |
Toolbar icon for search options | Search Options | F3 | Set search options. See Menu Options -> Search |
Control type | Control names |  |  | Accepted values
Radiobutton | First match | Alt-F | Stop search for solutions after the first match |
Radiobutton | Limited | Alt-L | Stop search for solutions after limited number of matches |
Integer | Integer limit |  | Stop search for solutions after the given number of solutions | Integer between 2 and 100
Radiobutton | All | Alt-A | Search for all solutions |
Push button | OK | Alt-O | Store search options and close dialog |
Push button | Cancel | Esc | Cancel setting of search options |
Push button | Reset | Alt-E | Reset previous or default search options |
Push button | Help | Alt-H | Display help page belonging the dialog |

Error message in case of incorrect search limit


Output Options

Dialog output options
The dialog can be invoked explicitly from the Options submenu selecting Output.
The user can set in this modal dialog
i the information displayed by the program and saved in output files;
ii the targets of display and saving;
iii selection and open mode of output files.

It is invoked programmatically in case immediately processing files.

The explanation of the fields and buttons appear in the status line when they get focus.
Toolbar icon |  | Dialog name | Hot key | Explanation displayed in the status line |
OutputOptions icon |  | Output Options | F4 | Set output options. See Menu Options -> Output |
Group box | Control type | Control names |  |  | Accepted values
Saved intermediate results | Check box | Classification | Alt-F | Include facts of classification |
 | Check box | Track | Alt-T | Include track to solutions in saved results |
Last input Processed | Read only edit | Input folder |  | Folder containing the input file |
 | Read only edit | Input filename |  | Name of the recently read input file |
 | Read only radiobutton | from Entry dialog |  |  |
 | Read only radiobutton | immediately |  |  |
Write to | Check box | Report form | Alt-R | Display results in a Report form |
 | Check box | Message Window | Alt-M | Save results in Messages windows |
 | Integer | having ... lines | Alt-L | Maximum number of lines in Messages window | Between 500 and 9999. Default is 1500.
 | Check box | Disk file | Alt-D | Save results on disk |
 | Push button | Browse | Alt-B | Browsing for output file | Invokes "Save as" dialog of file submenu.
 | Read-only edit | Filename |  | Name of the chosen disk file |
 | Read-only edit | Path |  | Path to the chosen disk file |
 | Read-only edit | State |  | State of the chosen output file |
If file exists | Radiobutton | Overwrite | Alt-V | Overwrite existing disk file |
 | Radiobutton | Append | Alt-P | Append results to existing disk file |
 | Radiobutton | Refuse | Alt-U | Refuse existing disk file |
If does not exist | Radiobutton | Create | Alt-C | Allow creation of new disk file |
 | Radiobutton | Reject | Alt-J | Reject creation of new disk file |
Write to | Read only edit | Action |  | Action based on options and existence of the file |
 | Push button | OK | Alt-O | Store output options and close dialog |
 | Push button | Cancel | Esc | Cancel setting of output options |
 | Push button | Reset | Alt-E | Reset previous or default output options |
 | Push button | Help | Alt-H | Display help page belonging the dialog |

Error message in case of incorrect number of message lines


Entry
See also: Format of Input Files Restrictions Examples

The main purpose of the entry dialog is the manual entry of the puzzles.
The Text field serves for direct entry.
There are some default examples in the Examples list edit control.
Select one from the default examples
The selected example goes up to the text field.
The selected example goes up into the Text field
The contents of the last opened or immediately processed file overwrites the default examples.
The File ===> Open item can be invoked by the Browse button.
Toolbar icon | Dialog name | Hot key | Explanation displayed in the status line |
New | Entry | F7 | Entering of puzzle |
Control type | Control names |  |  | Accepted values and hints
Edit | Text | Alt-T | Edit raw text of the puzzle | Cyrillic and accented Latin characters allowed. See Format of Input Files . Some hot keys are available for cut and paste.
List edit | Example | Alt-X | Select an example or input line | The selected example goes up to the text field.
Read only edit | Read from | Alt-R | Source of the puzzle | Name of last opened or immediately processed file.
Push button | Browse | Alt-B | Browse for input file | Selection of an existing ANSI or Unicode file as shown here .
Push button | OK | Alt-O | Solve puzzle in Text input field | Start parsing and solving of puzzle in the text field and close dialog
Push button | All | Alt-A | Solve all read in puzzles | Start parsing and solving all items in the Examples list box and close dialog
Push button | Cancel | Esc | Cancel this dialog |
Push button | Reset | Alt-E | Reset previous or default output options |
Push button | Help | Alt-H | Invoke help |


Report
See also: Search Options Output Options Output of Solutions
This form appears when the user presses the [OK] or [All] buttons of the Entry form. Its purpose is the reporting of the simplified text and the classification of the problem , the applied rules and the solution. The saving of results can be invoked here, too. Local help is available, as in other dialogs. The form has not [Cancel] button because the [OK] button has not special effects beyond its destroying. The summary of the options is shown in read only controls. The kinds of information are distinguished by group boxes, and organized in synchronized list boxes .
The form may be present within the task window in more instances,
1 in case of reporting of evaluation of an input file given in the command line
2 in case of immediate processing of data or
3 when the user has pressed the [All] button of the Entry form.

The Report Form

The explanation of the fields and buttons appear in the status line when they get focus.
 | Toolbar icon | Dialog name | Hot keys | Explanation displayed in the status line | Accepted values and hints
 | None | Report | None | Report classifications |
Group box | Control type | Control names |  |  |
 | Read only edit | Text | Alt-T | Simplified text of the puzzle |
Classification | Group box | Classification |  | Classification of the problem |
 | List box | Point of view | Alt-P | Point of view of the classification of the problem | Their selection are synchronized with each other. Double click on explanations shows the full text of the selected item in the status line.
 | List box | Rank | Alt-R | Rank of the problem got from classification
 | List box | Judgement | Alt-J | Judgment of the problem got from classification
 | List box | Explanation | Alt-X | Explanation to the classification of problem
Solutions | Group box | Solutions |  | Solution of the problem |
 | Read only edit | Stopped after |  | Stopping conditions. See Menu Options -> Search |
 | Read only integer | Found |  | Found number of solutions |
 | Integer | Selected | Alt-E | Index of selected solution. | The modification of its value moves the selection within the list boxes.
 | List box | Digits corresponding | Alt-D | Corresponding alphabetic codes and decimal digits | Their selection are synchronized with each other.
 | List box | Digits substituted | Alt-U | Digits substituted into the puzzle
Preset output | Group box | Preset output |  | Output options in effect |
 | Read only edit | Filename |  | Output filename |
 | Read only edit | Path |  | Path to the output file |
 | Read only edit | Action |  | Opening action |
Track | Group box | Track |  | Applied rules during the search for the solution |
 | List box | Investigated rules | Alt-I | Investigated rules during backtracking | Double click on investigated rules shows the full text of the selected item in the status line . Their selection are synchronized with each other.
 | List box | Trials | Alt-A | Count of trials
 | List box | Matches | Alt-M | Count of matches
 | Button | OK | Alt-O | Finish reporting of solutions and ways to them. | Pressing [OK] destroys the form.
 | Button | Help | Alt-H | Display help page belonging the dialog |
 | Button | Save | Alt-S | Save solutions and ways to them. See Menu Options -> Output |


Selection of Input Puzzle Files
See also: Input of Puzzles Solution Files
Select input file
The selection is done by a common dialog .
The default extension of input puzzle files is ".apz".

Note:
If you select a solution file "*.aps" or the program finds lines typical to that kind of files then it filters out the lines of track and classification and it retains only the condensed text of the problems.


Selection of Output Solution Files
See also: Solution Files Output Options
The selection is done by a common dialog .
The default extension of output files is ".aps". The default coding is Unicode.
Select output file


About
See also: About the Author

This dialog can be invoked selecting the About item of the Help Submenu . It shows the description and version information of the program and the contact information to the author. You can invoke the default help topic: » What Are "Alphametic Puzzles"? «
Toolbar icon | Dialog name | Hot key | Explanation displayed in the status line
None | About | Ctrl-F11 | Display information about the program
Control type | Control names |  |
Push button | OK | Alt-O | Finish this dialog
Push button | Help | Alt-H | Display help from the local computer.


Input of Puzzles
See also: Format of Input Files Restrictions
The puzzles may be entered
I using the Entry dialog ,
II reading from a file selected in the File menu ,
III reading from a file explicitly given in the command line argument of the program.


Format of Input Files
See also: Restrictions Examples

The input files may be coded in ANSI or Unicode mode.

The lines of input files are interpreted as alphametic puzzles.
Comments are not accepted.
Ignored characters: | space, tabulator, newline, underline.
Prohibited characters: | '!' , apostrophe, '$' , '%' , '&' , double quote , '(' , ')' , ', ' , '-' , '.' , '/' , ':' , ';' , '<' , '>' , '?' , '@' , '[' , backslash, ']' , '^' , '`' , '{' , '|' , '}' , '~', '«', '»', '×'.
Rejected operators: | subtraction denoted by '-' , multiplication denoted by '×', exponentiation denoted by '^' .
Accepted operators: | '+' for addition, at least one must be present.
 | "*" for multiplication, at most one may be present between two '+' operators.
 | "=" between the side of the equation. Exactly one may be present.

Judgment | Description | Example
Rejected sequences | adjacent operators (after deletion of ignored characters) | A++B=C**D
 | decimal digits and words without separating operator | 2ONE=TWO
 | products of two or more numbers | 3*4*A=CD
 | product of two or more words |
Accepted sequences | product of a decimal number and a word, in any order | 4*ONE=TWO*2
 | words separated by '+' | SEND+MORE=MONEY
Rejected sequences | decimal numbers between two '+' operators | MONEY+20+GOLD=WEALTH
 | decimal numbers in front of the first '+' operator of any side of the equation | 1+A=B
 | decimal numbers after the last '+' operator of any side of the equation | A+1=B


Division of the Screen of the Program
See also: Window Submenu
The screen of the program is the so-called Task Window which contains
1 Title bar with the usual sizing and closing buttons.
2 Menu bar
3 Toolbar
4 Dialogs and forms
5 "Messages" window.
6 Status line .

The status line shows
either the explanation of the form field in focus,
status of the search for solutions.

Partts of the screen of the program


Output of Solutions
Destinations:
The solution of the puzzles may be directed to each - at least one - of the destinations below:
1. the "Messages" window ,
2. the "Report" form ,
3. a freely named solution file .

Search:
The user can set whether the program limits the search to seek one, some or all solutions. See dialog of search options .

Verbosity:
The above devices contain
1. The source of puzzle:
a) filename,
b) line;
2. the forms of the puzzle:
a) raw,
b) compressed,
c) ordered;
3. the classification of the puzzle:
a) intermediate facts,
b) judgments,
c) tried rules with counters of trials and matches;
4. track to the solution:
a) partial fits,
c) results of comparison of the sides,
5. the final solution:
a) as 'code'=value pairs,
b) as total substitution with digits.

Some of the above printouts are obligatory, others are not present in all destinations,
others may be asked or suppressed in the dialog of output options .


The "Messages" Window
The "Messages" window is the area of the Task Window where the messages of the program are collected. When its maximal number of lines are filled the first lines are lost. The maximal number of lines are set to 1500 as default but it can be set between 500 and 9999. The size of this window can be controlled by the usual way. Its relative position to the other form can be changed by the window submenu. Its font can be changed by the pop-up menu invoked by right-clicking of the mouse.

Messages with pop-up menu


Editing of Texts in "Messages" Window
Popup menu of
The text of the "Messages" window can be edited by the above pop-up menu activated by clicking of the right mouse button.
The usual cut and paste hot keys can be used within it.
The Search ... item invokes the dialog shown below.
Search within the
The Font dialog appears in the language of the operation system.
Note: Only certain fonts, like Tahoma and Times New Roman support the display of Cyrillic characters.
Font selection for the


Examples of Contents of "Messages" Files

classification no track no.msg

Input          folder         = D:\Feri\SOAP\Problems\
Input          filename       = sok angol szöveg összeadása.htm
Input          coding         = ANSI
Input          coding         = read_in
Input          pointer        = 1
Input          length         = 763
Input          processed      = by dialog

Condensed      puzzle         = SIX+SEVEN+SEVEN=TWENTY

Simplified     puzzle         = 2*SEVEN+SIX=TWENTY

Equation       judged         = The equation is accepted.

Equation       parsed         = Elements of parsed equation

clauses
characters("Prohibited","").
characters("Operator","+=").
characters("Codes","IXSVWENTY").
classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
classification("by kinds of characters","feasible",accepted("The equation contains the following codes: I and X and S and V and W and E and N and T and Y.")).
classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 3.")).
classification("by contents of words","legal",accepted("Part #1 on the left contains the word »SIX« composed of valid characters.")).
classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 5.")).
classification("by contents of words","legal",accepted("Part #2 on the left contains the word »SEVEN« composed of valid characters.")).
classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
classification("by lengths of components","accepted",accepted("The length of the word #3 on the  left is 5.")).
classification("by contents of words","legal",accepted("Part #3 on the left contains the word »SEVEN« composed of valid characters.")).
classification("by splitting at operators","simple",accepted("Part #3 on the  left contains a word.")).
classification("by splitting at operators","defined",accepted("The  left side of the equation contains 3 part(s).")).
classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 6.")).
classification("by contents of words","legal",accepted("Part #1 on the right contains the word »TWENTY« composed of valid characters.")).
classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 2 parts.")).
classification("by count of parts","additions and multiplications",accepted("The  left side of the simplified equation contains 1 unfactored and 1 factored words.")).
classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
classification("by count of parts","General",accepted("Mixed parts.")).
classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [100, 999].")).
classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [20000, 199998].")).
classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [100000, 999999].")).
classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [100000, 198221].")).
num_read_parts(left(),3).
num_read_parts(right(),1).
read_parts(t(left(),00BD0378)).
read_parts(t(left(),00BD0450)).
read_parts(t(right(),00BD0330)).
coefficients(summed(),right(),'Y',1).
coefficients(summed(),right(),'T',100010).
coefficients(summed(),right(),'N',100).
coefficients(summed(),right(),'E',1000).
coefficients(summed(),right(),'W',10000).
coefficients(summed(),left(),'N',2).
coefficients(summed(),left(),'E',2020).
coefficients(summed(),left(),'V',200).
coefficients(summed(),left(),'S',20100).
coefficients(summed(),left(),'X',1).
coefficients(summed(),left(),'I',10).
coefficients(substracted(),left(),'Y',0).
coefficients(substracted(),right(),'Y',1).
coefficients(substracted(),left(),'T',0).
coefficients(substracted(),right(),'T',100010).
coefficients(substracted(),left(),'N',0).
coefficients(substracted(),right(),'N',98).
coefficients(substracted(),left(),'W',0).
coefficients(substracted(),right(),'W',10000).
coefficients(substracted(),right(),'E',0).
coefficients(substracted(),left(),'E',1020).
coefficients(substracted(),right(),'V',0).
coefficients(substracted(),left(),'V',200).
coefficients(substracted(),right(),'S',0).
coefficients(substracted(),left(),'S',20100).
coefficients(substracted(),right(),'X',0).
coefficients(substracted(),left(),'X',1).
coefficients(substracted(),right(),'I',0).
coefficients(substracted(),left(),'I',10).
rightmost('Y',right(),left(),1,1,0).
rightmost('T',right(),left(),10001,1,1).
rightmost('N',right(),left(),98,8,0).
rightmost('W',right(),left(),1,1,4).
rightmost('E',left(),right(),102,2,1).
rightmost('V',left(),right(),2,2,2).
rightmost('S',left(),right(),201,1,2).
rightmost('X',left(),right(),1,1,0).
rightmost('I',left(),right(),1,1,1).

clauses
num_qualified_additions(left(),1).
num_qualified_additions(right(),1).
num_qualified_multiplications(left(),1).
num_qualified_multiplications(right(),0).
qualified_words(left(),00BE4CC0).
qualified_words(right(),00BE4CA0).
qualified_products(left(),00BEA4D8).
qualified_products(right(),00BEA4B0).
global_max(6).
relative_lengths_of_words(left(),[3],[1]).
relative_lengths_of_words(right(),[0],[1]).
relative_lengths_of_products(left(),[1],[2]).
relative_lengths_of_products(right(),[],[]).
code_ranges(left(),r(2776,198221)).
code_ranges(right(),r(12304,987695)).
intersection_of_ranges(r(100000,198221)).
greatest_common_divisors(left(),1).
greatest_common_divisors(right(),1).

Search         options        = stop after given number of matches = 2.
.

Tried          fits           = 1
Matching       fits found     = 1

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = N=2, X=0, Y=4, E=8, I=5, V=7, S=6, W=3, W=3, S=6, V=7, I=5, E=8, Y=4, X=0, N=2, T=1.
Solution       got            = 650+2*68782=138214

End of fit lists and results.

classification yes track yes.msg

Remaining      digits         = 0, 2, 6, 7, 8.
Possible       digits         = 8.
Intersection   of them        = 8.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=8, N=5, Y=3, E=4, D=9, M=1.
Remaining      digits         = 0 and 2 and 6 and 7.

Rightmost      place of 'O'   = 2
right          partial value  = 9453
left           partial value  = 453

Factor         of code mod 10 = 9

Digit on       right side     = 4

Digit on       other side     = 4

Product        mod 10         = 0
Possible       multipliers    = 0.

Remaining      digits         = 0, 2, 6, 7.
Possible       digits         = 0.
Intersection   of them        = 0.
Number of      elements       = 1

Current        code is        = 'S'
Intermediate   fit list       = O=0, R=8, N=5, Y=3, E=4, D=9, M=1.
Remaining      digits         = 2 and 6 and 7.

Calculated     ratio          = 9
Calculated     modulus        = 0

Partial        fit            = O=0, R=8, N=5, Y=3, E=4, D=9, M=1.
Partial        values         =                  453 is less than 9453.

Coefficient    of 'S'         =                 1000 is greater than 0.
Result of      predicate       = accepted("The final step could be shortened.")

Calculated     digit          = 9.

Remaining      digits         = 2, 6, 7.
Possible       digits         = 9.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=6, Y=3, E=4, D=9, M=1.
Remaining      digits         = 0 and 2 and 5 and 7 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 373
right          partial value  = 9543

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 4

Product        mod 10         = 7
Possible       multipliers    = 7.

Remaining      digits         = 0, 2, 5, 7, 8.
Possible       digits         = 7.
Intersection   of them        = 7.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=7, N=6, Y=3, E=4, D=9, M=1.
Remaining      digits         = 0 and 2 and 5 and 8.

Rightmost      place of 'O'   = 2
right          partial value  = 9543
left           partial value  = 443

Factor         of code mod 10 = 9

Digit on       right side     = 5

Digit on       other side     = 4

Product        mod 10         = 9
Possible       multipliers    = 1.

Remaining      digits         = 0, 2, 5, 8.
Possible       digits         = 1.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=7, Y=3, E=4, D=9, M=1.
Remaining      digits         = 0 and 2 and 5 and 6 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 373
right          partial value  = 9633

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 3

Product        mod 10         = 6
Possible       multipliers    = 6.

Remaining      digits         = 0, 2, 5, 6, 8.
Possible       digits         = 6.
Intersection   of them        = 6.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=6, N=7, Y=3, E=4, D=9, M=1.
Remaining      digits         = 0 and 2 and 5 and 8.

Rightmost      place of 'O'   = 2
right          partial value  = 9633
left           partial value  = 433

Factor         of code mod 10 = 9

Digit on       right side     = 6

Digit on       other side     = 4

Product        mod 10         = 8
Possible       multipliers    = 1.

Remaining      digits         = 0, 2, 5, 8.
Possible       digits         = 1.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=8, Y=3, E=4, D=9, M=1.
Remaining      digits         = 0 and 2 and 5 and 6 and 7.

Rightmost      place of 'R'   = 1
left           partial value  = 373
right          partial value  = 9723

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 2

Product        mod 10         = 5
Possible       multipliers    = 5.

Remaining      digits         = 0, 2, 5, 6, 7.
Possible       digits         = 5.
Intersection   of them        = 5.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=5, N=8, Y=3, E=4, D=9, M=1.
Remaining      digits         = 0 and 2 and 6 and 7.

Rightmost      place of 'O'   = 2
right          partial value  = 9723
left           partial value  = 423

Factor         of code mod 10 = 9

Digit on       right side     = 7

Digit on       other side     = 4

Product        mod 10         = 7
Possible       multipliers    = 2.

Remaining      digits         = 0, 2, 6, 7.
Possible       digits         = 2.
Intersection   of them        = 2.
Number of      elements       = 1

Current        code is        = 'S'
Intermediate   fit list       = O=2, R=5, N=8, Y=3, E=4, D=9, M=1.
Remaining      digits         = 6 and 7.

Calculated     ratio          = 11
Calculated     modulus        = 100

Partial        fit            = O=2, R=5, N=8, Y=3, E=4, D=9, M=1.
Partial        values         =                  423 is less than 11523.

Coefficient    of 'S'         =                 1000 is greater than 0.
Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'Y'
Intermediate   fit list       = E=5, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 6 and 7 and 8.

Rightmost      place of 'Y'   = 0
right          partial value  = 9000
left           partial value  = 464

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4
Possible       multipliers    = 4.

Remaining      digits         = 0, 2, 3, 4, 6, 7, 8.
Possible       digits         = 4.
Intersection   of them        = 4.
Number of      elements       = 1

Current        code is        = 'N'
Intermediate   fit list       = Y=4, E=5, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 6 and 7 and 8.

Current        code is        = 'R'
Intermediate   fit list       = N=0, Y=4, E=5, D=9, M=1.
Remaining      digits         = 2 and 3 and 6 and 7 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 464
right          partial value  = 9004

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 0

Product        mod 10         = 4
Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 6, 7, 8.
Possible       digits         = 4.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=2, Y=4, E=5, D=9, M=1.
Remaining      digits         = 0 and 3 and 6 and 7 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 464
right          partial value  = 9184

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 8

Product        mod 10         = 2
Possible       multipliers    = 2.

Remaining      digits         = 0, 3, 6, 7, 8.
Possible       digits         = 2.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=3, Y=4, E=5, D=9, M=1.
Remaining      digits         = 0 and 2 and 6 and 7 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 464
right          partial value  = 9274

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 7

Product        mod 10         = 1
Possible       multipliers    = 1.

Remaining      digits         = 0, 2, 6, 7, 8.
Possible       digits         = 1.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=6, Y=4, E=5, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 7 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 464
right          partial value  = 9544

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 4

Product        mod 10         = 8
Possible       multipliers    = 8.

Remaining      digits         = 0, 2, 3, 7, 8.
Possible       digits         = 8.
Intersection   of them        = 8.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=8, N=6, Y=4, E=5, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 7.

Rightmost      place of 'O'   = 2
right          partial value  = 9544
left           partial value  = 544

Factor         of code mod 10 = 9

Digit on       right side     = 5

Digit on       other side     = 5

Product        mod 10         = 0
Possible       multipliers    = 0.

Remaining      digits         = 0, 2, 3, 7.
Possible       digits         = 0.
Intersection   of them        = 0.
Number of      elements       = 1

Current        code is        = 'S'
Intermediate   fit list       = O=0, R=8, N=6, Y=4, E=5, D=9, M=1.
Remaining      digits         = 2 and 3 and 7.

Calculated     ratio          = 9
Calculated     modulus        = 0

Partial        fit            = O=0, R=8, N=6, Y=4, E=5, D=9, M=1.
Partial        values         =                  544 is less than 9544.

Coefficient    of 'S'         =                 1000 is greater than 0.
Result of      predicate       = accepted("The final step could be shortened.")

Calculated     digit          = 9.

Remaining      digits         = 2, 3, 7.
Possible       digits         = 9.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=7, Y=4, E=5, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 6 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 464
right          partial value  = 9634

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 3

Product        mod 10         = 7
Possible       multipliers    = 7.

Remaining      digits         = 0, 2, 3, 6, 8.
Possible       digits         = 7.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=8, Y=4, E=5, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 6 and 7.

Rightmost      place of 'R'   = 1
left           partial value  = 464
right          partial value  = 9724

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 2

Product        mod 10         = 6
Possible       multipliers    = 6.

Remaining      digits         = 0, 2, 3, 6, 7.
Possible       digits         = 6.
Intersection   of them        = 6.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=6, N=8, Y=4, E=5, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 7.

Rightmost      place of 'O'   = 2
right          partial value  = 9724
left           partial value  = 524

Factor         of code mod 10 = 9

Digit on       right side     = 7

Digit on       other side     = 5

Product        mod 10         = 8
Possible       multipliers    = 1.

Remaining      digits         = 0, 2, 3, 7.
Possible       digits         = 1.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'Y'
Intermediate   fit list       = E=6, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 7 and 8.

Rightmost      place of 'Y'   = 0
right          partial value  = 9000
left           partial value  = 555

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 5

Product        mod 10         = 5
Possible       multipliers    = 5.

Remaining      digits         = 0, 2, 3, 4, 5, 7, 8.
Possible       digits         = 5.
Intersection   of them        = 5.
Number of      elements       = 1

Current        code is        = 'N'
Intermediate   fit list       = Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 7 and 8.

Current        code is        = 'R'
Intermediate   fit list       = N=0, Y=5, E=6, D=9, M=1.
Remaining      digits         = 2 and 3 and 4 and 7 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 555
right          partial value  = 9005

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 0

Product        mod 10         = 5
Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 7, 8.
Possible       digits         = 5.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=2, Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 3 and 4 and 7 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 555
right          partial value  = 9185

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 8

Product        mod 10         = 3
Possible       multipliers    = 3.

Remaining      digits         = 0, 3, 4, 7, 8.
Possible       digits         = 3.
Intersection   of them        = 3.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=3, N=2, Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 4 and 7 and 8.

Rightmost      place of 'O'   = 2
right          partial value  = 9185
left           partial value  = 585

Factor         of code mod 10 = 9

Digit on       right side     = 1

Digit on       other side     = 5

Product        mod 10         = 4
Possible       multipliers    = 5.

Remaining      digits         = 0, 4, 7, 8.
Possible       digits         = 5.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=3, Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 2 and 4 and 7 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 555
right          partial value  = 9275

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 7

Product        mod 10         = 2
Possible       multipliers    = 2.

Remaining      digits         = 0, 2, 4, 7, 8.
Possible       digits         = 2.
Intersection   of them        = 2.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=2, N=3, Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 4 and 7 and 8.

Rightmost      place of 'O'   = 2
right          partial value  = 9275
left           partial value  = 575

Factor         of code mod 10 = 9

Digit on       right side     = 2

Digit on       other side     = 5

Product        mod 10         = 3
Possible       multipliers    = 6.

Remaining      digits         = 0, 4, 7, 8.
Possible       digits         = 6.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=4, Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 7 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 555
right          partial value  = 9365

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 6

Product        mod 10         = 1
Possible       multipliers    = 1.

Remaining      digits         = 0, 2, 3, 7, 8.
Possible       digits         = 1.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=7, Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 555
right          partial value  = 9635

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 3

Product        mod 10         = 8
Possible       multipliers    = 8.

Remaining      digits         = 0, 2, 3, 4, 8.
Possible       digits         = 8.
Intersection   of them        = 8.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=8, N=7, Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4.

Rightmost      place of 'O'   = 2
right          partial value  = 9635
left           partial value  = 635

Factor         of code mod 10 = 9

Digit on       right side     = 6

Digit on       other side     = 6

Product        mod 10         = 0
Possible       multipliers    = 0.

Remaining      digits         = 0, 2, 3, 4.
Possible       digits         = 0.
Intersection   of them        = 0.
Number of      elements       = 1

Current        code is        = 'S'
Intermediate   fit list       = O=0, R=8, N=7, Y=5, E=6, D=9, M=1.
Remaining      digits         = 2 and 3 and 4.

Calculated     ratio          = 9
Calculated     modulus        = 0

Partial        fit            = O=0, R=8, N=7, Y=5, E=6, D=9, M=1.
Partial        values         =                  635 is less than 9635.

Coefficient    of 'S'         =                 1000 is greater than 0.
Result of      predicate       = accepted("The final step could be shortened.")

Calculated     digit          = 9.

Remaining      digits         = 2, 3, 4.
Possible       digits         = 9.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=8, Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 7.

Rightmost      place of 'R'   = 1
left           partial value  = 555
right          partial value  = 9725

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 2

Product        mod 10         = 7
Possible       multipliers    = 7.

Remaining      digits         = 0, 2, 3, 4, 7.
Possible       digits         = 7.
Intersection   of them        = 7.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=7, N=8, Y=5, E=6, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4.

Rightmost      place of 'O'   = 2
right          partial value  = 9725
left           partial value  = 625

Factor         of code mod 10 = 9

Digit on       right side     = 7

Digit on       other side     = 6

Product        mod 10         = 9
Possible       multipliers    = 1.

Remaining      digits         = 0, 2, 3, 4.
Possible       digits         = 1.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'Y'
Intermediate   fit list       = E=7, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 6 and 8.

Rightmost      place of 'Y'   = 0
right          partial value  = 9000
left           partial value  = 646

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 6

Product        mod 10         = 6
Possible       multipliers    = 6.

Remaining      digits         = 0, 2, 3, 4, 5, 6, 8.
Possible       digits         = 6.
Intersection   of them        = 6.
Number of      elements       = 1

Current        code is        = 'N'
Intermediate   fit list       = Y=6, E=7, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 8.

Current        code is        = 'R'
Intermediate   fit list       = N=0, Y=6, E=7, D=9, M=1.
Remaining      digits         = 2 and 3 and 4 and 5 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 646
right          partial value  = 9006

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 0

Product        mod 10         = 6
Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 4, 5, 8.
Possible       digits         = 6.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=2, Y=6, E=7, D=9, M=1.
Remaining      digits         = 0 and 3 and 4 and 5 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 646
right          partial value  = 9186

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 8

Product        mod 10         = 4
Possible       multipliers    = 4.

Remaining      digits         = 0, 3, 4, 5, 8.
Possible       digits         = 4.
Intersection   of them        = 4.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=4, N=2, Y=6, E=7, D=9, M=1.
Remaining      digits         = 0 and 3 and 5 and 8.

Rightmost      place of 'O'   = 2
right          partial value  = 9186
left           partial value  = 686

Factor         of code mod 10 = 9

Digit on       right side     = 1

Digit on       other side     = 6

Product        mod 10         = 5
Possible       multipliers    = 5.

Remaining      digits         = 0, 3, 5, 8.
Possible       digits         = 5.
Intersection   of them        = 5.
Number of      elements       = 1

Current        code is        = 'S'
Intermediate   fit list       = O=5, R=4, N=2, Y=6, E=7, D=9, M=1.
Remaining      digits         = 3 and 8.

Calculated     ratio          = 13
Calculated     modulus        = 0

Partial        fit            = O=5, R=4, N=2, Y=6, E=7, D=9, M=1.
Partial        values         =                  686 is less than 13686.

Coefficient    of 'S'         =                 1000 is greater than 0.
Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'R'
Intermediate   fit list       = N=3, Y=6, E=7, D=9, M=1.
Remaining      digits         = 0 and 2 and 4 and 5 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 646
right          partial value  = 9276

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 7

Product        mod 10         = 3
Possible       multipliers    = 3.

Remaining      digits         = 0, 2, 4, 5, 8.
Possible       digits         = 3.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=4, Y=6, E=7, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 5 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 646
right          partial value  = 9366

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 6

Product        mod 10         = 2
Possible       multipliers    = 2.

Remaining      digits         = 0, 2, 3, 5, 8.
Possible       digits         = 2.
Intersection   of them        = 2.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=2, N=4, Y=6, E=7, D=9, M=1.
Remaining      digits         = 0 and 3 and 5 and 8.

Rightmost      place of 'O'   = 2
right          partial value  = 9366
left           partial value  = 666

Factor         of code mod 10 = 9

Digit on       right side     = 3

Digit on       other side     = 6

Product        mod 10         = 3
Possible       multipliers    = 6.

Remaining      digits         = 0, 3, 5, 8.
Possible       digits         = 6.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=5, Y=6, E=7, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 8.

Rightmost      place of 'R'   = 1
left           partial value  = 646
right          partial value  = 9456

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 5

Product        mod 10         = 1
Possible       multipliers    = 1.

Remaining      digits         = 0, 2, 3, 4, 8.
Possible       digits         = 1.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=8, Y=6, E=7, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 5.

Rightmost      place of 'R'   = 1
left           partial value  = 646
right          partial value  = 9726

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 2

Product        mod 10         = 8
Possible       multipliers    = 8.

Remaining      digits         = 0, 2, 3, 4, 5.
Possible       digits         = 8.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'Y'
Intermediate   fit list       = E=8, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 6 and 7.

Rightmost      place of 'Y'   = 0
right          partial value  = 9000
left           partial value  = 737

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 7

Product        mod 10         = 7
Possible       multipliers    = 7.

Remaining      digits         = 0, 2, 3, 4, 5, 6, 7.
Possible       digits         = 7.
Intersection   of them        = 7.
Number of      elements       = 1

Current        code is        = 'N'
Intermediate   fit list       = Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 6.

Current        code is        = 'R'
Intermediate   fit list       = N=0, Y=7, E=8, D=9, M=1.
Remaining      digits         = 2 and 3 and 4 and 5 and 6.

Rightmost      place of 'R'   = 1
left           partial value  = 737
right          partial value  = 9007

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 0

Product        mod 10         = 7
Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 4, 5, 6.
Possible       digits         = 7.
Intersection   of them        = none.
Number of      elements       = 0

Current        code is        = 'R'
Intermediate   fit list       = N=2, Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 3 and 4 and 5 and 6.

Rightmost      place of 'R'   = 1
left           partial value  = 737
right          partial value  = 9187

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 8

Product        mod 10         = 5
Possible       multipliers    = 5.

Remaining      digits         = 0, 3, 4, 5, 6.
Possible       digits         = 5.
Intersection   of them        = 5.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=5, N=2, Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 3 and 4 and 6.

Rightmost      place of 'O'   = 2
right          partial value  = 9187
left           partial value  = 787

Factor         of code mod 10 = 9

Digit on       right side     = 1

Digit on       other side     = 7

Product        mod 10         = 6
Possible       multipliers    = 3.

Remaining      digits         = 0, 3, 4, 6.
Possible       digits         = 3.
Intersection   of them        = 3.
Number of      elements       = 1

Current        code is        = 'S'
Intermediate   fit list       = O=3, R=5, N=2, Y=7, E=8, D=9, M=1.
Remaining      digits         = 4 and 6.

Calculated     ratio          = 11
Calculated     modulus        = 100

Partial        fit            = O=3, R=5, N=2, Y=7, E=8, D=9, M=1.
Partial        values         =                  787 is less than 11887.

Coefficient    of 'S'         =                 1000 is greater than 0.
Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'R'
Intermediate   fit list       = N=3, Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 2 and 4 and 5 and 6.

Rightmost      place of 'R'   = 1
left           partial value  = 737
right          partial value  = 9277

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 7

Product        mod 10         = 4
Possible       multipliers    = 4.

Remaining      digits         = 0, 2, 4, 5, 6.
Possible       digits         = 4.
Intersection   of them        = 4.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=4, N=3, Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 2 and 5 and 6.

Rightmost      place of 'O'   = 2
right          partial value  = 9277
left           partial value  = 777

Factor         of code mod 10 = 9

Digit on       right side     = 2

Digit on       other side     = 7

Product        mod 10         = 5
Possible       multipliers    = 5.

Remaining      digits         = 0, 2, 5, 6.
Possible       digits         = 5.
Intersection   of them        = 5.
Number of      elements       = 1

Current        code is        = 'S'
Intermediate   fit list       = O=5, R=4, N=3, Y=7, E=8, D=9, M=1.
Remaining      digits         = 2 and 6.

Calculated     ratio          = 13
Calculated     modulus        = 0

Partial        fit            = O=5, R=4, N=3, Y=7, E=8, D=9, M=1.
Partial        values         =                  777 is less than 13777.

Coefficient    of 'S'         =                 1000 is greater than 0.
Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'R'
Intermediate   fit list       = N=4, Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 5 and 6.

Rightmost      place of 'R'   = 1
left           partial value  = 737
right          partial value  = 9367

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 6

Product        mod 10         = 3
Possible       multipliers    = 3.

Remaining      digits         = 0, 2, 3, 5, 6.
Possible       digits         = 3.
Intersection   of them        = 3.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=3, N=4, Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 2 and 5 and 6.

Rightmost      place of 'O'   = 2
right          partial value  = 9367
left           partial value  = 767

Factor         of code mod 10 = 9

Digit on       right side     = 3

Digit on       other side     = 7

Product        mod 10         = 4
Possible       multipliers    = 5.

Remaining      digits         = 0, 2, 5, 6.
Possible       digits         = 5.
Intersection   of them        = 5.
Number of      elements       = 1

Current        code is        = 'S'
Intermediate   fit list       = O=5, R=3, N=4, Y=7, E=8, D=9, M=1.
Remaining      digits         = 2 and 6.

Calculated     ratio          = 13
Calculated     modulus        = 100

Partial        fit            = O=5, R=3, N=4, Y=7, E=8, D=9, M=1.
Partial        values         =                  767 is less than 13867.

Coefficient    of 'S'         =                 1000 is greater than 0.
Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'R'
Intermediate   fit list       = N=5, Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 6.

Rightmost      place of 'R'   = 1
left           partial value  = 737
right          partial value  = 9457

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 5

Product        mod 10         = 2
Possible       multipliers    = 2.

Remaining      digits         = 0, 2, 3, 4, 6.
Possible       digits         = 2.
Intersection   of them        = 2.
Number of      elements       = 1

Current        code is        = 'O'
Intermediate   fit list       = R=2, N=5, Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 3 and 4 and 6.

Rightmost      place of 'O'   = 2
right          partial value  = 9457
left           partial value  = 757

Factor         of code mod 10 = 9

Digit on       right side     = 4

Digit on       other side     = 7

Product        mod 10         = 3
Possible       multipliers    = 6.

Remaining      digits         = 0, 3, 4, 6.
Possible       digits         = 6.
Intersection   of them        = 6.
Number of      elements       = 1

Current        code is        = 'S'
Intermediate   fit list       = O=6, R=2, N=5, Y=7, E=8, D=9, M=1.
Remaining      digits         = 3 and 4.

Calculated     ratio          = 14
Calculated     modulus        = 100

Partial        fit            = O=6, R=2, N=5, Y=7, E=8, D=9, M=1.
Partial        values         =                  757 is less than 14857.

Coefficient    of 'S'         =                 1000 is greater than 0.
Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'R'
Intermediate   fit list       = N=6, Y=7, E=8, D=9, M=1.
Remaining      digits         = 0 and 2 and 3 and 4 and 5.

Rightmost      place of 'R'   = 1
left           partial value  = 737
right          partial value  = 9547

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 4

Product        mod 10         = 1
Possible       multipliers    = 1.

Remaining      digits         = 0, 2, 3, 4, 5.
Possible       digits         = 1.
Intersection   of them        = none.
Number of      elements       = 0

Search         options        = stop after given number of matches = 2.
.

Ranges         of words       = constraining the solutions

clauses
limited_ranges(left(),1,"MORE",r(1000,9999)).
limited_ranges(left(),1,"SEND",r(1000,9999)).
limited_ranges(right(),1,"MONEY",r(10000,18400)).
substracted_ranges(right(),1,"MONEY","Intersection",r(10000,18400)).
substracted_ranges(left(),1,"MORE","Intersection - SEND ",r(1,17400)).
substracted_ranges(left(),1,"SEND","Intersection - MORE ",r(1,17400)).
investigated_rules("Get intersection of the ranges of the two sides.",1,1).
investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",3,3).
investigated_rules("Restrict range subtracting the limited range of other words on the same side.",2,2).
investigated_rules("Compare limited and substracted ranges of words.",3,3).
investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",3,3).
investigated_rules("Leading characters may not represent zero digits.",8,2).
investigated_rules("Determine possible decimal digits at each words at given character positions.",13,13).
investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",4,0).
investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
investigated_rules("Is the substituted value of the left side is equal to that of the right side of the equation?",1,1).
investigated_rules("The last code missing from the partial fit is a deterministic result of a division.",54,54).
investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",500,500).
compared_ranges(right(),1,"MONEY",r(10000,18400)).
compared_ranges(left(),1,"MORE",r(1000,9999)).
compared_ranges(left(),1,"SEND",r(1000,9999)).
divided_ranges(right(),"MONEY",r(10000,18400)).
divided_ranges(left(),"MORE",r(1000,9999)).
divided_ranges(left(),"SEND",r(1000,9999)).

Possible       characters     = constraining the solutions

clauses
characters("unknown",['R','S','D','M','O','N','E','Y']).
characters("leading",['S','M']).
characters("trailing",['E','D','Y']).
characters("known",[]).
allowed_digits(a('R',['0','1','2','3','4','5','6','7','8','9'])).
allowed_digits(a('S',['1','2','3','4','5','6','7','8','9'])).
allowed_digits(a('D',['0','1','2','3','4','5','6','7','8','9'])).
allowed_digits(a('M',['1'])).
allowed_digits(a('O',['0','1','2','3','4','5','6','7','8'])).
allowed_digits(a('N',['0','1','2','3','4','5','6','7','8','9'])).
allowed_digits(a('E',['0','1','2','3','4','5','6','7','8','9'])).
allowed_digits(a('Y',['0','1','2','3','4','5','6','7','8','9'])).
grouped_substitutions([g(['O'],['0','2','3','4','5','6','7','8']),g(['S'],['2','3','4','5','6','7','8','9']),g(['Y','E','N','D','R'],['0','2','3','4','5','6','7','8','9'])]).
ordered_codes(["0   0 8   9 D 023456789","0   0 8   9 E 023456789","0 0 8   9 Y 023456789","0   1 7   9 N 023456789","0   1 8   9 R 023456789","0   2 7   8 O 02345678","0   3 8   8 S 23456789"]).
num_var(967680).
solved_fit(f('M','1')).

Condensed      puzzle         = SEND+MORE=MONEY

Simplified     puzzle         = MORE+SEND=MONEY

Condensed      puzzle         = SEND+MORE=MONEY

Simplified     puzzle         = MORE+SEND=MONEY

Tried          fits           = 1
Matching       fits found     = 1

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = D=7, E=5, Y=2, N=6, R=8, O=0, S=9, S=9, O=0, R=8, N=6, Y=2, E=5, D=7, M=1.
Solution       got            = 1085+9567=10652

End of fit lists and results.


The "Report" Dialog
See at Dialogs of the program --> Report .

report of send more money problem


Solution Files
See also: Output Options Search Options Selection of Output Solution Files
The solution files may be coded in ANSI or Unicode mode.
v Newly created or overwritten files are in Unicode mode,
v information can be appended to ANSI files.

Their contents is determined by the options. Their name are asked by a common dialog . Their open conditions are determined by the Output Options. Their default place is the ..\Results folder relative to the place of the program (which is SOAP\Exe ).

Next topic: Examples of Solution Files .


Examples of Solution Files

# | Contents | Classification | Track | Search limit
1 | Hungarian | no | no | all
2 | Hungarian | yes | no | all
3 | Hungarian | no | yes | first solution

Difference files
#-#
1-2
1-3


Simplest Output of Hungarian Puzzles
This an example of sol ution file of Hungarian puzzles.
It contains
¨ no classification
¨ no track
¨ all solutions.

2010. január 4. 8:57:57
Action         = overwrite      unicode file »magyarok00.aps« in folder »D:\Feri\SOAP\Results\«.

Condensed      puzzle         = 2*TÍZ=HÚSZ

Simplified     puzzle         = 2*TÍZ=HÚSZ

Tried          fits           = 11
Matching       fits found     = 11

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = Í=2, S=4, T=8, Ú=6, Ú=6, T=8, S=4, Í=2, Z=0, H=1.
Solution       got            = 2*820=1640

Solution       #              = 2
Solution       fitted         = Í=2, S=4, T=9, Ú=8, Ú=8, T=9, S=4, Í=2, Z=0, H=1.
Solution       got            = 2*920=1840

Solution       #              = 3
Solution       fitted         = Í=3, S=6, T=7, Ú=4, Ú=4, T=7, S=6, Í=3, Z=0, H=1.
Solution       got            = 2*730=1460

Solution       #              = 4
Solution       fitted         = Í=3, S=6, T=9, Ú=8, Ú=8, T=9, S=6, Í=3, Z=0, H=1.
Solution       got            = 2*930=1860

Solution       #              = 5
Solution       fitted         = Í=4, S=8, T=6, Ú=2, Ú=2, T=6, S=8, Í=4, Z=0, H=1.
Solution       got            = 2*640=1280

Solution       #              = 6
Solution       fitted         = Í=6, S=2, T=7, Ú=5, Ú=5, T=7, S=2, Í=6, Z=0, H=1.
Solution       got            = 2*760=1520

Solution       #              = 7
Solution       fitted         = Í=6, S=2, T=8, Ú=7, Ú=7, T=8, S=2, Í=6, Z=0, H=1.
Solution       got            = 2*860=1720

Solution       #              = 8
Solution       fitted         = Í=7, S=4, T=6, Ú=3, Ú=3, T=6, S=4, Í=7, Z=0, H=1.
Solution       got            = 2*670=1340

Solution       #              = 9
Solution       fitted         = Í=8, S=6, T=7, Ú=5, Ú=5, T=7, S=6, Í=8, Z=0, H=1.
Solution       got            = 2*780=1560

Solution       #              = 10
Solution       fitted         = Í=9, S=8, T=6, Ú=3, Ú=3, T=6, S=8, Í=9, Z=0, H=1.
Solution       got            = 2*690=1380

Solution       #              = 11
Solution       fitted         = Í=9, S=8, T=7, Ú=5, Ú=5, T=7, S=8, Í=9, Z=0, H=1.
Solution       got            = 2*790=1580

End of fit lists and results.

Condensed      puzzle         = ÖT+EGY=HAT

Simplified     puzzle         = EGY+ÖT=HAT

Tried          fits           = 432
Matching       fits found     = 432

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=5, T=5, H=4, E=3, G=9, A=1, Ö=2, Y=0.
Solution       got            = 390+25=415

Solution       #              = 2
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=6, T=6, H=4, E=3, G=9, A=1, Ö=2, Y=0.
Solution       got            = 390+26=416

Solution       #              = 3
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=7, T=7, H=4, E=3, G=9, A=1, Ö=2, Y=0.
Solution       got            = 390+27=417

Solution       #              = 4
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=8, T=8, H=4, E=3, G=9, A=1, Ö=2, Y=0.
Solution       got            = 390+28=418

Solution       #              = 5
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=4, H=5, T=3, T=3, H=5, E=4, G=9, A=1, Ö=2, Y=0.
Solution       got            = 490+23=513

Solution       #              = 6
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=4, H=5, T=6, T=6, H=5, E=4, G=9, A=1, Ö=2, Y=0.
Solution       got            = 490+26=516

Solution       #              = 7
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=4, H=5, T=7, T=7, H=5, E=4, G=9, A=1, Ö=2, Y=0.
Solution       got            = 490+27=517

Solution       #              = 8
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=4, H=5, T=8, T=8, H=5, E=4, G=9, A=1, Ö=2, Y=0.
Solution       got            = 490+28=518

Solution       #              = 9
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=5, H=6, T=3, T=3, H=6, E=5, G=9, A=1, Ö=2, Y=0.
Solution       got            = 590+23=613

Solution       #              = 10
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=5, H=6, T=4, T=4, H=6, E=5, G=9, A=1, Ö=2, Y=0.
Solution       got            = 590+24=614

Solution       #              = 11
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=5, H=6, T=7, T=7, H=6, E=5, G=9, A=1, Ö=2, Y=0.
Solution       got            = 590+27=617

Solution       #              = 12
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=5, H=6, T=8, T=8, H=6, E=5, G=9, A=1, Ö=2, Y=0.
Solution       got            = 590+28=618

Solution       #              = 13
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=6, H=7, T=3, T=3, H=7, E=6, G=9, A=1, Ö=2, Y=0.
Solution       got            = 690+23=713

Solution       #              = 14
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=6, H=7, T=4, T=4, H=7, E=6, G=9, A=1, Ö=2, Y=0.
Solution       got            = 690+24=714

Solution       #              = 15
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=6, H=7, T=5, T=5, H=7, E=6, G=9, A=1, Ö=2, Y=0.
Solution       got            = 690+25=715

Solution       #              = 16
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=6, H=7, T=8, T=8, H=7, E=6, G=9, A=1, Ö=2, Y=0.
Solution       got            = 690+28=718

Solution       #              = 17
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=7, H=8, T=3, T=3, H=8, E=7, G=9, A=1, Ö=2, Y=0.
Solution       got            = 790+23=813

Solution       #              = 18
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=7, H=8, T=4, T=4, H=8, E=7, G=9, A=1, Ö=2, Y=0.
Solution       got            = 790+24=814

Solution       #              = 19
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=7, H=8, T=5, T=5, H=8, E=7, G=9, A=1, Ö=2, Y=0.
Solution       got            = 790+25=815

Solution       #              = 20
Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=7, H=8, T=6, T=6, H=8, E=7, G=9, A=1, Ö=2, Y=0.
Solution       got            = 790+26=816

Solution       #              = 21
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=4, H=5, T=2, T=2, H=5, E=4, G=8, A=1, Ö=3, Y=0.
Solution       got            = 480+32=512

Solution       #              = 22
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=4, H=5, T=6, T=6, H=5, E=4, G=8, A=1, Ö=3, Y=0.
Solution       got            = 480+36=516

Solution       #              = 23
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=4, H=5, T=7, T=7, H=5, E=4, G=8, A=1, Ö=3, Y=0.
Solution       got            = 480+37=517

Solution       #              = 24
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=4, H=5, T=9, T=9, H=5, E=4, G=8, A=1, Ö=3, Y=0.
Solution       got            = 480+39=519

Solution       #              = 25
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=5, H=6, T=2, T=2, H=6, E=5, G=8, A=1, Ö=3, Y=0.
Solution       got            = 580+32=612

Solution       #              = 26
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=5, H=6, T=4, T=4, H=6, E=5, G=8, A=1, Ö=3, Y=0.
Solution       got            = 580+34=614

Solution       #              = 27
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=5, H=6, T=7, T=7, H=6, E=5, G=8, A=1, Ö=3, Y=0.
Solution       got            = 580+37=617

Solution       #              = 28
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=5, H=6, T=9, T=9, H=6, E=5, G=8, A=1, Ö=3, Y=0.
Solution       got            = 580+39=619

Solution       #              = 29
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=6, H=7, T=2, T=2, H=7, E=6, G=8, A=1, Ö=3, Y=0.
Solution       got            = 680+32=712

Solution       #              = 30
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=6, H=7, T=4, T=4, H=7, E=6, G=8, A=1, Ö=3, Y=0.
Solution       got            = 680+34=714

Solution       #              = 31
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=6, H=7, T=5, T=5, H=7, E=6, G=8, A=1, Ö=3, Y=0.
Solution       got            = 680+35=715

Solution       #              = 32
Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=6, H=7, T=9, T=9, H=7, E=6, G=8, A=1, Ö=3, Y=0.
Solution       got            = 680+39=719

Solution       #              = 33
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=4, H=5, T=1, T=1, H=5, E=4, G=9, A=2, Ö=3, Y=0.
Solution       got            = 490+31=521

Solution       #              = 34
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=4, H=5, T=6, T=6, H=5, E=4, G=9, A=2, Ö=3, Y=0.
Solution       got            = 490+36=526

Solution       #              = 35
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=4, H=5, T=7, T=7, H=5, E=4, G=9, A=2, Ö=3, Y=0.
Solution       got            = 490+37=527

Solution       #              = 36
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=4, H=5, T=8, T=8, H=5, E=4, G=9, A=2, Ö=3, Y=0.
Solution       got            = 490+38=528

Solution       #              = 37
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=5, H=6, T=1, T=1, H=6, E=5, G=9, A=2, Ö=3, Y=0.
Solution       got            = 590+31=621

Solution       #              = 38
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=5, H=6, T=4, T=4, H=6, E=5, G=9, A=2, Ö=3, Y=0.
Solution       got            = 590+34=624

Solution       #              = 39
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=5, H=6, T=7, T=7, H=6, E=5, G=9, A=2, Ö=3, Y=0.
Solution       got            = 590+37=627

Solution       #              = 40
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=5, H=6, T=8, T=8, H=6, E=5, G=9, A=2, Ö=3, Y=0.
Solution       got            = 590+38=628

Solution       #              = 41
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=6, H=7, T=1, T=1, H=7, E=6, G=9, A=2, Ö=3, Y=0.
Solution       got            = 690+31=721

Solution       #              = 42
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=6, H=7, T=4, T=4, H=7, E=6, G=9, A=2, Ö=3, Y=0.
Solution       got            = 690+34=724

Solution       #              = 43
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=6, H=7, T=5, T=5, H=7, E=6, G=9, A=2, Ö=3, Y=0.
Solution       got            = 690+35=725

Solution       #              = 44
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=6, H=7, T=8, T=8, H=7, E=6, G=9, A=2, Ö=3, Y=0.
Solution       got            = 690+38=728

Solution       #              = 45
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=7, H=8, T=1, T=1, H=8, E=7, G=9, A=2, Ö=3, Y=0.
Solution       got            = 790+31=821

Solution       #              = 46
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=7, H=8, T=4, T=4, H=8, E=7, G=9, A=2, Ö=3, Y=0.
Solution       got            = 790+34=824

Solution       #              = 47
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=7, H=8, T=5, T=5, H=8, E=7, G=9, A=2, Ö=3, Y=0.
Solution       got            = 790+35=825

Solution       #              = 48
Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=7, H=8, T=6, T=6, H=8, E=7, G=9, A=2, Ö=3, Y=0.
Solution       got            = 790+36=826

Solution       #              = 49
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=2, H=3, T=5, T=5, H=3, E=2, G=7, A=1, Ö=4, Y=0.
Solution       got            = 270+45=315

Solution       #              = 50
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=2, H=3, T=6, T=6, H=3, E=2, G=7, A=1, Ö=4, Y=0.
Solution       got            = 270+46=316

Solution       #              = 51
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=2, H=3, T=8, T=8, H=3, E=2, G=7, A=1, Ö=4, Y=0.
Solution       got            = 270+48=318

Solution       #              = 52
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=2, H=3, T=9, T=9, H=3, E=2, G=7, A=1, Ö=4, Y=0.
Solution       got            = 270+49=319

Solution       #              = 53
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=5, H=6, T=2, T=2, H=6, E=5, G=7, A=1, Ö=4, Y=0.
Solution       got            = 570+42=612

Solution       #              = 54
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=5, H=6, T=3, T=3, H=6, E=5, G=7, A=1, Ö=4, Y=0.
Solution       got            = 570+43=613

Solution       #              = 55
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=5, H=6, T=8, T=8, H=6, E=5, G=7, A=1, Ö=4, Y=0.
Solution       got            = 570+48=618

Solution       #              = 56
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=5, H=6, T=9, T=9, H=6, E=5, G=7, A=1, Ö=4, Y=0.
Solution       got            = 570+49=619

Solution       #              = 57
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=8, H=9, T=2, T=2, H=9, E=8, G=7, A=1, Ö=4, Y=0.
Solution       got            = 870+42=912

Solution       #              = 58
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=8, H=9, T=3, T=3, H=9, E=8, G=7, A=1, Ö=4, Y=0.
Solution       got            = 870+43=913

Solution       #              = 59
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=8, H=9, T=5, T=5, H=9, E=8, G=7, A=1, Ö=4, Y=0.
Solution       got            = 870+45=915

Solution       #              = 60
Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=8, H=9, T=6, T=6, H=9, E=8, G=7, A=1, Ö=4, Y=0.
Solution       got            = 870+46=916

Solution       #              = 61
Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=5, H=6, T=1, T=1, H=6, E=5, G=8, A=2, Ö=4, Y=0.
Solution       got            = 580+41=621

Solution       #              = 62
Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=5, H=6, T=3, T=3, H=6, E=5, G=8, A=2, Ö=4, Y=0.
Solution       got            = 580+43=623

Solution       #              = 63
Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=5, H=6, T=7, T=7, H=6, E=5, G=8, A=2, Ö=4, Y=0.
Solution       got            = 580+47=627

Solution       #              = 64
Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=5, H=6, T=9, T=9, H=6, E=5, G=8, A=2, Ö=4, Y=0.
Solution       got            = 580+49=629

Solution       #              = 65
Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=6, H=7, T=1, T=1, H=7, E=6, G=8, A=2, Ö=4, Y=0.
Solution       got            = 680+41=721

Solution       #              = 66
Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=6, H=7, T=3, T=3, H=7, E=6, G=8, A=2, Ö=4, Y=0.
Solution       got            = 680+43=723

Solution       #              = 67
Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=6, H=7, T=5, T=5, H=7, E=6, G=8, A=2, Ö=4, Y=0.
Solution       got            = 680+45=725

Solution       #              = 68
Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=6, H=7, T=9, T=9, H=7, E=6, G=8, A=2, Ö=4, Y=0.
Solution       got            = 680+49=729

Solution       #              = 69
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=1, H=2, T=5, T=5, H=2, E=1, G=9, A=3, Ö=4, Y=0.
Solution       got            = 190+45=235

Solution       #              = 70
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=1, H=2, T=6, T=6, H=2, E=1, G=9, A=3, Ö=4, Y=0.
Solution       got            = 190+46=236

Solution       #              = 71
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=1, H=2, T=7, T=7, H=2, E=1, G=9, A=3, Ö=4, Y=0.
Solution       got            = 190+47=237

Solution       #              = 72
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=1, H=2, T=8, T=8, H=2, E=1, G=9, A=3, Ö=4, Y=0.
Solution       got            = 190+48=238

Solution       #              = 73
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=5, H=6, T=1, T=1, H=6, E=5, G=9, A=3, Ö=4, Y=0.
Solution       got            = 590+41=631

Solution       #              = 74
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=5, H=6, T=2, T=2, H=6, E=5, G=9, A=3, Ö=4, Y=0.
Solution       got            = 590+42=632

Solution       #              = 75
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=5, H=6, T=7, T=7, H=6, E=5, G=9, A=3, Ö=4, Y=0.
Solution       got            = 590+47=637

Solution       #              = 76
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=5, H=6, T=8, T=8, H=6, E=5, G=9, A=3, Ö=4, Y=0.
Solution       got            = 590+48=638

Solution       #              = 77
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=6, H=7, T=1, T=1, H=7, E=6, G=9, A=3, Ö=4, Y=0.
Solution       got            = 690+41=731

Solution       #              = 78
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=6, H=7, T=2, T=2, H=7, E=6, G=9, A=3, Ö=4, Y=0.
Solution       got            = 690+42=732

Solution       #              = 79
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=6, H=7, T=5, T=5, H=7, E=6, G=9, A=3, Ö=4, Y=0.
Solution       got            = 690+45=735

Solution       #              = 80
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=6, H=7, T=8, T=8, H=7, E=6, G=9, A=3, Ö=4, Y=0.
Solution       got            = 690+48=738

Solution       #              = 81
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=7, H=8, T=1, T=1, H=8, E=7, G=9, A=3, Ö=4, Y=0.
Solution       got            = 790+41=831

Solution       #              = 82
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=7, H=8, T=2, T=2, H=8, E=7, G=9, A=3, Ö=4, Y=0.
Solution       got            = 790+42=832

Solution       #              = 83
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=7, H=8, T=5, T=5, H=8, E=7, G=9, A=3, Ö=4, Y=0.
Solution       got            = 790+45=835

Solution       #              = 84
Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=7, H=8, T=6, T=6, H=8, E=7, G=9, A=3, Ö=4, Y=0.
Solution       got            = 790+46=836

Solution       #              = 85
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=2, H=3, T=4, T=4, H=3, E=2, G=6, A=1, Ö=5, Y=0.
Solution       got            = 260+54=314

Solution       #              = 86
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=2, H=3, T=7, T=7, H=3, E=2, G=6, A=1, Ö=5, Y=0.
Solution       got            = 260+57=317

Solution       #              = 87
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=2, H=3, T=8, T=8, H=3, E=2, G=6, A=1, Ö=5, Y=0.
Solution       got            = 260+58=318

Solution       #              = 88
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=2, H=3, T=9, T=9, H=3, E=2, G=6, A=1, Ö=5, Y=0.
Solution       got            = 260+59=319

Solution       #              = 89
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=3, H=4, T=2, T=2, H=4, E=3, G=6, A=1, Ö=5, Y=0.
Solution       got            = 360+52=412

Solution       #              = 90
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=3, H=4, T=7, T=7, H=4, E=3, G=6, A=1, Ö=5, Y=0.
Solution       got            = 360+57=417

Solution       #              = 91
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=3, H=4, T=8, T=8, H=4, E=3, G=6, A=1, Ö=5, Y=0.
Solution       got            = 360+58=418

Solution       #              = 92
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=3, H=4, T=9, T=9, H=4, E=3, G=6, A=1, Ö=5, Y=0.
Solution       got            = 360+59=419

Solution       #              = 93
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=7, H=8, T=2, T=2, H=8, E=7, G=6, A=1, Ö=5, Y=0.
Solution       got            = 760+52=812

Solution       #              = 94
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=7, H=8, T=3, T=3, H=8, E=7, G=6, A=1, Ö=5, Y=0.
Solution       got            = 760+53=813

Solution       #              = 95
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=7, H=8, T=4, T=4, H=8, E=7, G=6, A=1, Ö=5, Y=0.
Solution       got            = 760+54=814

Solution       #              = 96
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=7, H=8, T=9, T=9, H=8, E=7, G=6, A=1, Ö=5, Y=0.
Solution       got            = 760+59=819

Solution       #              = 97
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=8, H=9, T=2, T=2, H=9, E=8, G=6, A=1, Ö=5, Y=0.
Solution       got            = 860+52=912

Solution       #              = 98
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=8, H=9, T=3, T=3, H=9, E=8, G=6, A=1, Ö=5, Y=0.
Solution       got            = 860+53=913

Solution       #              = 99
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=8, H=9, T=4, T=4, H=9, E=8, G=6, A=1, Ö=5, Y=0.
Solution       got            = 860+54=914

Solution       #              = 100
Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=8, H=9, T=7, T=7, H=9, E=8, G=6, A=1, Ö=5, Y=0.
Solution       got            = 860+57=917

Solution       #              = 101
Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=3, H=4, T=1, T=1, H=4, E=3, G=7, A=2, Ö=5, Y=0.
Solution       got            = 370+51=421

Solution       #              = 102
Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=3, H=4, T=6, T=6, H=4, E=3, G=7, A=2, Ö=5, Y=0.
Solution       got            = 370+56=426

Solution       #              = 103
Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=3, H=4, T=8, T=8, H=4, E=3, G=7, A=2, Ö=5, Y=0.
Solution       got            = 370+58=428

Solution       #              = 104
Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=3, H=4, T=9, T=9, H=4, E=3, G=7, A=2, Ö=5, Y=0.
Solution       got            = 370+59=429

Solution       #              = 105
Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=8, H=9, T=1, T=1, H=9, E=8, G=7, A=2, Ö=5, Y=0.
Solution       got            = 870+51=921

Solution       #              = 106
Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=8, H=9, T=3, T=3, H=9, E=8, G=7, A=2, Ö=5, Y=0.
Solution       got            = 870+53=923

Solution       #              = 107
Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=8, H=9, T=4, T=4, H=9, E=8, G=7, A=2, Ö=5, Y=0.
Solution       got            = 870+54=924

Solution       #              = 108
Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=8, H=9, T=6, T=6, H=9, E=8, G=7, A=2, Ö=5, Y=0.
Solution       got            = 870+56=926

Solution       #              = 109
Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=1, H=2, T=4, T=4, H=2, E=1, G=8, A=3, Ö=5, Y=0.
Solution       got            = 180+54=234

Solution       #              = 110
Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=1, H=2, T=6, T=6, H=2, E=1, G=8, A=3, Ö=5, Y=0.
Solution       got            = 180+56=236

Solution       #              = 111
Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=1, H=2, T=7, T=7, H=2, E=1, G=8, A=3, Ö=5, Y=0.
Solution       got            = 180+57=237

Solution       #              = 112
Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=1, H=2, T=9, T=9, H=2, E=1, G=8, A=3, Ö=5, Y=0.
Solution       got            = 180+59=239

Solution       #              = 113
Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=6, H=7, T=1, T=1, H=7, E=6, G=8, A=3, Ö=5, Y=0.
Solution       got            = 680+51=731

Solution       #              = 114
Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=6, H=7, T=2, T=2, H=7, E=6, G=8, A=3, Ö=5, Y=0.
Solution       got            = 680+52=732

Solution       #              = 115
Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=6, H=7, T=4, T=4, H=7, E=6, G=8, A=3, Ö=5, Y=0.
Solution       got            = 680+54=734

Solution       #              = 116
Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=6, H=7, T=9, T=9, H=7, E=6, G=8, A=3, Ö=5, Y=0.
Solution       got            = 680+59=739

Solution       #              = 117
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=1, H=2, T=3, T=3, H=2, E=1, G=9, A=4, Ö=5, Y=0.
Solution       got            = 190+53=243

Solution       #              = 118
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=1, H=2, T=6, T=6, H=2, E=1, G=9, A=4, Ö=5, Y=0.
Solution       got            = 190+56=246

Solution       #              = 119
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=1, H=2, T=7, T=7, H=2, E=1, G=9, A=4, Ö=5, Y=0.
Solution       got            = 190+57=247

Solution       #              = 120
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=1, H=2, T=8, T=8, H=2, E=1, G=9, A=4, Ö=5, Y=0.
Solution       got            = 190+58=248

Solution       #              = 121
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=2, H=3, T=1, T=1, H=3, E=2, G=9, A=4, Ö=5, Y=0.
Solution       got            = 290+51=341

Solution       #              = 122
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=2, H=3, T=6, T=6, H=3, E=2, G=9, A=4, Ö=5, Y=0.
Solution       got            = 290+56=346

Solution       #              = 123
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=2, H=3, T=7, T=7, H=3, E=2, G=9, A=4, Ö=5, Y=0.
Solution       got            = 290+57=347

Solution       #              = 124
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=2, H=3, T=8, T=8, H=3, E=2, G=9, A=4, Ö=5, Y=0.
Solution       got            = 290+58=348

Solution       #              = 125
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=6, H=7, T=1, T=1, H=7, E=6, G=9, A=4, Ö=5, Y=0.
Solution       got            = 690+51=741

Solution       #              = 126
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=6, H=7, T=2, T=2, H=7, E=6, G=9, A=4, Ö=5, Y=0.
Solution       got            = 690+52=742

Solution       #              = 127
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=6, H=7, T=3, T=3, H=7, E=6, G=9, A=4, Ö=5, Y=0.
Solution       got            = 690+53=743

Solution       #              = 128
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=6, H=7, T=8, T=8, H=7, E=6, G=9, A=4, Ö=5, Y=0.
Solution       got            = 690+58=748

Solution       #              = 129
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=7, H=8, T=1, T=1, H=8, E=7, G=9, A=4, Ö=5, Y=0.
Solution       got            = 790+51=841

Solution       #              = 130
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=7, H=8, T=2, T=2, H=8, E=7, G=9, A=4, Ö=5, Y=0.
Solution       got            = 790+52=842

Solution       #              = 131
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=7, H=8, T=3, T=3, H=8, E=7, G=9, A=4, Ö=5, Y=0.
Solution       got            = 790+53=843

Solution       #              = 132
Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=7, H=8, T=6, T=6, H=8, E=7, G=9, A=4, Ö=5, Y=0.
Solution       got            = 790+56=846

Solution       #              = 133
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=2, H=3, T=4, T=4, H=3, E=2, G=5, A=1, Ö=6, Y=0.
Solution       got            = 250+64=314

Solution       #              = 134
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=2, H=3, T=7, T=7, H=3, E=2, G=5, A=1, Ö=6, Y=0.
Solution       got            = 250+67=317

Solution       #              = 135
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=2, H=3, T=8, T=8, H=3, E=2, G=5, A=1, Ö=6, Y=0.
Solution       got            = 250+68=318

Solution       #              = 136
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=2, H=3, T=9, T=9, H=3, E=2, G=5, A=1, Ö=6, Y=0.
Solution       got            = 250+69=319

Solution       #              = 137
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=3, H=4, T=2, T=2, H=4, E=3, G=5, A=1, Ö=6, Y=0.
Solution       got            = 350+62=412

Solution       #              = 138
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=3, H=4, T=7, T=7, H=4, E=3, G=5, A=1, Ö=6, Y=0.
Solution       got            = 350+67=417

Solution       #              = 139
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=3, H=4, T=8, T=8, H=4, E=3, G=5, A=1, Ö=6, Y=0.
Solution       got            = 350+68=418

Solution       #              = 140
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=3, H=4, T=9, T=9, H=4, E=3, G=5, A=1, Ö=6, Y=0.
Solution       got            = 350+69=419

Solution       #              = 141
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=7, H=8, T=2, T=2, H=8, E=7, G=5, A=1, Ö=6, Y=0.
Solution       got            = 750+62=812

Solution       #              = 142
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=7, H=8, T=3, T=3, H=8, E=7, G=5, A=1, Ö=6, Y=0.
Solution       got            = 750+63=813

Solution       #              = 143
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=7, H=8, T=4, T=4, H=8, E=7, G=5, A=1, Ö=6, Y=0.
Solution       got            = 750+64=814

Solution       #              = 144
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=7, H=8, T=9, T=9, H=8, E=7, G=5, A=1, Ö=6, Y=0.
Solution       got            = 750+69=819

Solution       #              = 145
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=8, H=9, T=2, T=2, H=9, E=8, G=5, A=1, Ö=6, Y=0.
Solution       got            = 850+62=912

Solution       #              = 146
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=8, H=9, T=3, T=3, H=9, E=8, G=5, A=1, Ö=6, Y=0.
Solution       got            = 850+63=913

Solution       #              = 147
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=8, H=9, T=4, T=4, H=9, E=8, G=5, A=1, Ö=6, Y=0.
Solution       got            = 850+64=914

Solution       #              = 148
Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=8, H=9, T=7, T=7, H=9, E=8, G=5, A=1, Ö=6, Y=0.
Solution       got            = 850+67=917

Solution       #              = 149
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=1, H=2, T=4, T=4, H=2, E=1, G=7, A=3, Ö=6, Y=0.
Solution       got            = 170+64=234

Solution       #              = 150
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=1, H=2, T=5, T=5, H=2, E=1, G=7, A=3, Ö=6, Y=0.
Solution       got            = 170+65=235

Solution       #              = 151
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=1, H=2, T=8, T=8, H=2, E=1, G=7, A=3, Ö=6, Y=0.
Solution       got            = 170+68=238

Solution       #              = 152
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=1, H=2, T=9, T=9, H=2, E=1, G=7, A=3, Ö=6, Y=0.
Solution       got            = 170+69=239

Solution       #              = 153
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=4, H=5, T=1, T=1, H=5, E=4, G=7, A=3, Ö=6, Y=0.
Solution       got            = 470+61=531

Solution       #              = 154
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=4, H=5, T=2, T=2, H=5, E=4, G=7, A=3, Ö=6, Y=0.
Solution       got            = 470+62=532

Solution       #              = 155
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=4, H=5, T=8, T=8, H=5, E=4, G=7, A=3, Ö=6, Y=0.
Solution       got            = 470+68=538

Solution       #              = 156
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=4, H=5, T=9, T=9, H=5, E=4, G=7, A=3, Ö=6, Y=0.
Solution       got            = 470+69=539

Solution       #              = 157
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=8, H=9, T=1, T=1, H=9, E=8, G=7, A=3, Ö=6, Y=0.
Solution       got            = 870+61=931

Solution       #              = 158
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=8, H=9, T=2, T=2, H=9, E=8, G=7, A=3, Ö=6, Y=0.
Solution       got            = 870+62=932

Solution       #              = 159
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=8, H=9, T=4, T=4, H=9, E=8, G=7, A=3, Ö=6, Y=0.
Solution       got            = 870+64=934

Solution       #              = 160
Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=8, H=9, T=5, T=5, H=9, E=8, G=7, A=3, Ö=6, Y=0.
Solution       got            = 870+65=935

Solution       #              = 161
Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=1, H=2, T=3, T=3, H=2, E=1, G=8, A=4, Ö=6, Y=0.
Solution       got            = 180+63=243

Solution       #              = 162
Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=1, H=2, T=5, T=5, H=2, E=1, G=8, A=4, Ö=6, Y=0.
Solution       got            = 180+65=245

Solution       #              = 163
Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=1, H=2, T=7, T=7, H=2, E=1, G=8, A=4, Ö=6, Y=0.
Solution       got            = 180+67=247

Solution       #              = 164
Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=1, H=2, T=9, T=9, H=2, E=1, G=8, A=4, Ö=6, Y=0.
Solution       got            = 180+69=249

Solution       #              = 165
Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=2, H=3, T=1, T=1, H=3, E=2, G=8, A=4, Ö=6, Y=0.
Solution       got            = 280+61=341

Solution       #              = 166
Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=2, H=3, T=5, T=5, H=3, E=2, G=8, A=4, Ö=6, Y=0.
Solution       got            = 280+65=345

Solution       #              = 167
Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=2, H=3, T=7, T=7, H=3, E=2, G=8, A=4, Ö=6, Y=0.
Solution       got            = 280+67=347

Solution       #              = 168
Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=2, H=3, T=9, T=9, H=3, E=2, G=8, A=4, Ö=6, Y=0.
Solution       got            = 280+69=349

Solution       #              = 169
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=1, H=2, T=3, T=3, H=2, E=1, G=9, A=5, Ö=6, Y=0.
Solution       got            = 190+63=253

Solution       #              = 170
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=1, H=2, T=4, T=4, H=2, E=1, G=9, A=5, Ö=6, Y=0.
Solution       got            = 190+64=254

Solution       #              = 171
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=1, H=2, T=7, T=7, H=2, E=1, G=9, A=5, Ö=6, Y=0.
Solution       got            = 190+67=257

Solution       #              = 172
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=1, H=2, T=8, T=8, H=2, E=1, G=9, A=5, Ö=6, Y=0.
Solution       got            = 190+68=258

Solution       #              = 173
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=2, H=3, T=1, T=1, H=3, E=2, G=9, A=5, Ö=6, Y=0.
Solution       got            = 290+61=351

Solution       #              = 174
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=2, H=3, T=4, T=4, H=3, E=2, G=9, A=5, Ö=6, Y=0.
Solution       got            = 290+64=354

Solution       #              = 175
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=2, H=3, T=7, T=7, H=3, E=2, G=9, A=5, Ö=6, Y=0.
Solution       got            = 290+67=357

Solution       #              = 176
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=2, H=3, T=8, T=8, H=3, E=2, G=9, A=5, Ö=6, Y=0.
Solution       got            = 290+68=358

Solution       #              = 177
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=3, H=4, T=1, T=1, H=4, E=3, G=9, A=5, Ö=6, Y=0.
Solution       got            = 390+61=451

Solution       #              = 178
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=3, H=4, T=2, T=2, H=4, E=3, G=9, A=5, Ö=6, Y=0.
Solution       got            = 390+62=452

Solution       #              = 179
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=3, H=4, T=7, T=7, H=4, E=3, G=9, A=5, Ö=6, Y=0.
Solution       got            = 390+67=457

Solution       #              = 180
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=3, H=4, T=8, T=8, H=4, E=3, G=9, A=5, Ö=6, Y=0.
Solution       got            = 390+68=458

Solution       #              = 181
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=7, H=8, T=1, T=1, H=8, E=7, G=9, A=5, Ö=6, Y=0.
Solution       got            = 790+61=851

Solution       #              = 182
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=7, H=8, T=2, T=2, H=8, E=7, G=9, A=5, Ö=6, Y=0.
Solution       got            = 790+62=852

Solution       #              = 183
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=7, H=8, T=3, T=3, H=8, E=7, G=9, A=5, Ö=6, Y=0.
Solution       got            = 790+63=853

Solution       #              = 184
Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=7, H=8, T=4, T=4, H=8, E=7, G=9, A=5, Ö=6, Y=0.
Solution       got            = 790+64=854

Solution       #              = 185
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=2, H=3, T=5, T=5, H=3, E=2, G=4, A=1, Ö=7, Y=0.
Solution       got            = 240+75=315

Solution       #              = 186
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=2, H=3, T=6, T=6, H=3, E=2, G=4, A=1, Ö=7, Y=0.
Solution       got            = 240+76=316

Solution       #              = 187
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=2, H=3, T=8, T=8, H=3, E=2, G=4, A=1, Ö=7, Y=0.
Solution       got            = 240+78=318

Solution       #              = 188
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=2, H=3, T=9, T=9, H=3, E=2, G=4, A=1, Ö=7, Y=0.
Solution       got            = 240+79=319

Solution       #              = 189
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=5, H=6, T=2, T=2, H=6, E=5, G=4, A=1, Ö=7, Y=0.
Solution       got            = 540+72=612

Solution       #              = 190
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=5, H=6, T=3, T=3, H=6, E=5, G=4, A=1, Ö=7, Y=0.
Solution       got            = 540+73=613

Solution       #              = 191
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=5, H=6, T=8, T=8, H=6, E=5, G=4, A=1, Ö=7, Y=0.
Solution       got            = 540+78=618

Solution       #              = 192
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=5, H=6, T=9, T=9, H=6, E=5, G=4, A=1, Ö=7, Y=0.
Solution       got            = 540+79=619

Solution       #              = 193
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=8, H=9, T=2, T=2, H=9, E=8, G=4, A=1, Ö=7, Y=0.
Solution       got            = 840+72=912

Solution       #              = 194
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=8, H=9, T=3, T=3, H=9, E=8, G=4, A=1, Ö=7, Y=0.
Solution       got            = 840+73=913

Solution       #              = 195
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=8, H=9, T=5, T=5, H=9, E=8, G=4, A=1, Ö=7, Y=0.
Solution       got            = 840+75=915

Solution       #              = 196
Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=8, H=9, T=6, T=6, H=9, E=8, G=4, A=1, Ö=7, Y=0.
Solution       got            = 840+76=916

Solution       #              = 197
Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=3, H=4, T=1, T=1, H=4, E=3, G=5, A=2, Ö=7, Y=0.
Solution       got            = 350+71=421

Solution       #              = 198
Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=3, H=4, T=6, T=6, H=4, E=3, G=5, A=2, Ö=7, Y=0.
Solution       got            = 350+76=426

Solution       #              = 199
Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=3, H=4, T=8, T=8, H=4, E=3, G=5, A=2, Ö=7, Y=0.
Solution       got            = 350+78=428

Solution       #              = 200
Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=3, H=4, T=9, T=9, H=4, E=3, G=5, A=2, Ö=7, Y=0.
Solution       got            = 350+79=429

Solution       #              = 201
Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=8, H=9, T=1, T=1, H=9, E=8, G=5, A=2, Ö=7, Y=0.
Solution       got            = 850+71=921

Solution       #              = 202
Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=8, H=9, T=3, T=3, H=9, E=8, G=5, A=2, Ö=7, Y=0.
Solution       got            = 850+73=923

Solution       #              = 203
Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=8, H=9, T=4, T=4, H=9, E=8, G=5, A=2, Ö=7, Y=0.
Solution       got            = 850+74=924

Solution       #              = 204
Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=8, H=9, T=6, T=6, H=9, E=8, G=5, A=2, Ö=7, Y=0.
Solution       got            = 850+76=926

Solution       #              = 205
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=1, H=2, T=4, T=4, H=2, E=1, G=6, A=3, Ö=7, Y=0.
Solution       got            = 160+74=234

Solution       #              = 206
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=1, H=2, T=5, T=5, H=2, E=1, G=6, A=3, Ö=7, Y=0.
Solution       got            = 160+75=235

Solution       #              = 207
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=1, H=2, T=8, T=8, H=2, E=1, G=6, A=3, Ö=7, Y=0.
Solution       got            = 160+78=238

Solution       #              = 208
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=1, H=2, T=9, T=9, H=2, E=1, G=6, A=3, Ö=7, Y=0.
Solution       got            = 160+79=239

Solution       #              = 209
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=4, H=5, T=1, T=1, H=5, E=4, G=6, A=3, Ö=7, Y=0.
Solution       got            = 460+71=531

Solution       #              = 210
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=4, H=5, T=2, T=2, H=5, E=4, G=6, A=3, Ö=7, Y=0.
Solution       got            = 460+72=532

Solution       #              = 211
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=4, H=5, T=8, T=8, H=5, E=4, G=6, A=3, Ö=7, Y=0.
Solution       got            = 460+78=538

Solution       #              = 212
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=4, H=5, T=9, T=9, H=5, E=4, G=6, A=3, Ö=7, Y=0.
Solution       got            = 460+79=539

Solution       #              = 213
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=8, H=9, T=1, T=1, H=9, E=8, G=6, A=3, Ö=7, Y=0.
Solution       got            = 860+71=931

Solution       #              = 214
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=8, H=9, T=2, T=2, H=9, E=8, G=6, A=3, Ö=7, Y=0.
Solution       got            = 860+72=932

Solution       #              = 215
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=8, H=9, T=4, T=4, H=9, E=8, G=6, A=3, Ö=7, Y=0.
Solution       got            = 860+74=934

Solution       #              = 216
Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=8, H=9, T=5, T=5, H=9, E=8, G=6, A=3, Ö=7, Y=0.
Solution       got            = 860+75=935

Solution       #              = 217
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=1, H=2, T=3, T=3, H=2, E=1, G=8, A=5, Ö=7, Y=0.
Solution       got            = 180+73=253

Solution       #              = 218
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=1, H=2, T=4, T=4, H=2, E=1, G=8, A=5, Ö=7, Y=0.
Solution       got            = 180+74=254

Solution       #              = 219
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=1, H=2, T=6, T=6, H=2, E=1, G=8, A=5, Ö=7, Y=0.
Solution       got            = 180+76=256

Solution       #              = 220
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=1, H=2, T=9, T=9, H=2, E=1, G=8, A=5, Ö=7, Y=0.
Solution       got            = 180+79=259

Solution       #              = 221
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=2, H=3, T=1, T=1, H=3, E=2, G=8, A=5, Ö=7, Y=0.
Solution       got            = 280+71=351

Solution       #              = 222
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=2, H=3, T=4, T=4, H=3, E=2, G=8, A=5, Ö=7, Y=0.
Solution       got            = 280+74=354

Solution       #              = 223
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=2, H=3, T=6, T=6, H=3, E=2, G=8, A=5, Ö=7, Y=0.
Solution       got            = 280+76=356

Solution       #              = 224
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=2, H=3, T=9, T=9, H=3, E=2, G=8, A=5, Ö=7, Y=0.
Solution       got            = 280+79=359

Solution       #              = 225
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=3, H=4, T=1, T=1, H=4, E=3, G=8, A=5, Ö=7, Y=0.
Solution       got            = 380+71=451

Solution       #              = 226
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=3, H=4, T=2, T=2, H=4, E=3, G=8, A=5, Ö=7, Y=0.
Solution       got            = 380+72=452

Solution       #              = 227
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=3, H=4, T=6, T=6, H=4, E=3, G=8, A=5, Ö=7, Y=0.
Solution       got            = 380+76=456

Solution       #              = 228
Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=3, H=4, T=9, T=9, H=4, E=3, G=8, A=5, Ö=7, Y=0.
Solution       got            = 380+79=459

Solution       #              = 229
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=1, H=2, T=3, T=3, H=2, E=1, G=9, A=6, Ö=7, Y=0.
Solution       got            = 190+73=263

Solution       #              = 230
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=1, H=2, T=4, T=4, H=2, E=1, G=9, A=6, Ö=7, Y=0.
Solution       got            = 190+74=264

Solution       #              = 231
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=1, H=2, T=5, T=5, H=2, E=1, G=9, A=6, Ö=7, Y=0.
Solution       got            = 190+75=265

Solution       #              = 232
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=1, H=2, T=8, T=8, H=2, E=1, G=9, A=6, Ö=7, Y=0.
Solution       got            = 190+78=268

Solution       #              = 233
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=2, H=3, T=1, T=1, H=3, E=2, G=9, A=6, Ö=7, Y=0.
Solution       got            = 290+71=361

Solution       #              = 234
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=2, H=3, T=4, T=4, H=3, E=2, G=9, A=6, Ö=7, Y=0.
Solution       got            = 290+74=364

Solution       #              = 235
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=2, H=3, T=5, T=5, H=3, E=2, G=9, A=6, Ö=7, Y=0.
Solution       got            = 290+75=365

Solution       #              = 236
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=2, H=3, T=8, T=8, H=3, E=2, G=9, A=6, Ö=7, Y=0.
Solution       got            = 290+78=368

Solution       #              = 237
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=3, H=4, T=1, T=1, H=4, E=3, G=9, A=6, Ö=7, Y=0.
Solution       got            = 390+71=461

Solution       #              = 238
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=3, H=4, T=2, T=2, H=4, E=3, G=9, A=6, Ö=7, Y=0.
Solution       got            = 390+72=462

Solution       #              = 239
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=3, H=4, T=5, T=5, H=4, E=3, G=9, A=6, Ö=7, Y=0.
Solution       got            = 390+75=465

Solution       #              = 240
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=3, H=4, T=8, T=8, H=4, E=3, G=9, A=6, Ö=7, Y=0.
Solution       got            = 390+78=468

Solution       #              = 241
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=4, H=5, T=1, T=1, H=5, E=4, G=9, A=6, Ö=7, Y=0.
Solution       got            = 490+71=561

Solution       #              = 242
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=4, H=5, T=2, T=2, H=5, E=4, G=9, A=6, Ö=7, Y=0.
Solution       got            = 490+72=562

Solution       #              = 243
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=4, H=5, T=3, T=3, H=5, E=4, G=9, A=6, Ö=7, Y=0.
Solution       got            = 490+73=563

Solution       #              = 244
Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=4, H=5, T=8, T=8, H=5, E=4, G=9, A=6, Ö=7, Y=0.
Solution       got            = 490+78=568

Solution       #              = 245
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=4, H=5, T=2, T=2, H=5, E=4, G=3, A=1, Ö=8, Y=0.
Solution       got            = 430+82=512

Solution       #              = 246
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=4, H=5, T=6, T=6, H=5, E=4, G=3, A=1, Ö=8, Y=0.
Solution       got            = 430+86=516

Solution       #              = 247
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=4, H=5, T=7, T=7, H=5, E=4, G=3, A=1, Ö=8, Y=0.
Solution       got            = 430+87=517

Solution       #              = 248
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=4, H=5, T=9, T=9, H=5, E=4, G=3, A=1, Ö=8, Y=0.
Solution       got            = 430+89=519

Solution       #              = 249
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=5, H=6, T=2, T=2, H=6, E=5, G=3, A=1, Ö=8, Y=0.
Solution       got            = 530+82=612

Solution       #              = 250
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=5, H=6, T=4, T=4, H=6, E=5, G=3, A=1, Ö=8, Y=0.
Solution       got            = 530+84=614

Solution       #              = 251
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=5, H=6, T=7, T=7, H=6, E=5, G=3, A=1, Ö=8, Y=0.
Solution       got            = 530+87=617

Solution       #              = 252
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=5, H=6, T=9, T=9, H=6, E=5, G=3, A=1, Ö=8, Y=0.
Solution       got            = 530+89=619

Solution       #              = 253
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=6, H=7, T=2, T=2, H=7, E=6, G=3, A=1, Ö=8, Y=0.
Solution       got            = 630+82=712

Solution       #              = 254
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=6, H=7, T=4, T=4, H=7, E=6, G=3, A=1, Ö=8, Y=0.
Solution       got            = 630+84=714

Solution       #              = 255
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=6, H=7, T=5, T=5, H=7, E=6, G=3, A=1, Ö=8, Y=0.
Solution       got            = 630+85=715

Solution       #              = 256
Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=6, H=7, T=9, T=9, H=7, E=6, G=3, A=1, Ö=8, Y=0.
Solution       got            = 630+89=719

Solution       #              = 257
Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=5, H=6, T=1, T=1, H=6, E=5, G=4, A=2, Ö=8, Y=0.
Solution       got            = 540+81=621

Solution       #              = 258
Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=5, H=6, T=3, T=3, H=6, E=5, G=4, A=2, Ö=8, Y=0.
Solution       got            = 540+83=623

Solution       #              = 259
Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=5, H=6, T=7, T=7, H=6, E=5, G=4, A=2, Ö=8, Y=0.
Solution       got            = 540+87=627

Solution       #              = 260
Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=5, H=6, T=9, T=9, H=6, E=5, G=4, A=2, Ö=8, Y=0.
Solution       got            = 540+89=629

Solution       #              = 261
Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=6, H=7, T=1, T=1, H=7, E=6, G=4, A=2, Ö=8, Y=0.
Solution       got            = 640+81=721

Solution       #              = 262
Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=6, H=7, T=3, T=3, H=7, E=6, G=4, A=2, Ö=8, Y=0.
Solution       got            = 640+83=723

Solution       #              = 263
Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=6, H=7, T=5, T=5, H=7, E=6, G=4, A=2, Ö=8, Y=0.
Solution       got            = 640+85=725

Solution       #              = 264
Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=6, H=7, T=9, T=9, H=7, E=6, G=4, A=2, Ö=8, Y=0.
Solution       got            = 640+89=729

Solution       #              = 265
Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=1, H=2, T=4, T=4, H=2, E=1, G=5, A=3, Ö=8, Y=0.
Solution       got            = 150+84=234

Solution       #              = 266
Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=1, H=2, T=6, T=6, H=2, E=1, G=5, A=3, Ö=8, Y=0.
Solution       got            = 150+86=236

Solution       #              = 267
Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=1, H=2, T=7, T=7, H=2, E=1, G=5, A=3, Ö=8, Y=0.
Solution       got            = 150+87=237

Solution       #              = 268
Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=1, H=2, T=9, T=9, H=2, E=1, G=5, A=3, Ö=8, Y=0.
Solution       got            = 150+89=239

Solution       #              = 269
Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=6, H=7, T=1, T=1, H=7, E=6, G=5, A=3, Ö=8, Y=0.
Solution       got            = 650+81=731

Solution       #              = 270
Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=6, H=7, T=2, T=2, H=7, E=6, G=5, A=3, Ö=8, Y=0.
Solution       got            = 650+82=732

Solution       #              = 271
Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=6, H=7, T=4, T=4, H=7, E=6, G=5, A=3, Ö=8, Y=0.
Solution       got            = 650+84=734

Solution       #              = 272
Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=6, H=7, T=9, T=9, H=7, E=6, G=5, A=3, Ö=8, Y=0.
Solution       got            = 650+89=739

Solution       #              = 273
Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=1, H=2, T=3, T=3, H=2, E=1, G=6, A=4, Ö=8, Y=0.
Solution       got            = 160+83=243

Solution       #              = 274
Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=1, H=2, T=5, T=5, H=2, E=1, G=6, A=4, Ö=8, Y=0.
Solution       got            = 160+85=245

Solution       #              = 275
Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=1, H=2, T=7, T=7, H=2, E=1, G=6, A=4, Ö=8, Y=0.
Solution       got            = 160+87=247

Solution       #              = 276
Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=1, H=2, T=9, T=9, H=2, E=1, G=6, A=4, Ö=8, Y=0.
Solution       got            = 160+89=249

Solution       #              = 277
Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=2, H=3, T=1, T=1, H=3, E=2, G=6, A=4, Ö=8, Y=0.
Solution       got            = 260+81=341

Solution       #              = 278
Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=2, H=3, T=5, T=5, H=3, E=2, G=6, A=4, Ö=8, Y=0.
Solution       got            = 260+85=345

Solution       #              = 279
Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=2, H=3, T=7, T=7, H=3, E=2, G=6, A=4, Ö=8, Y=0.
Solution       got            = 260+87=347

Solution       #              = 280
Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=2, H=3, T=9, T=9, H=3, E=2, G=6, A=4, Ö=8, Y=0.
Solution       got            = 260+89=349

Solution       #              = 281
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=1, H=2, T=3, T=3, H=2, E=1, G=7, A=5, Ö=8, Y=0.
Solution       got            = 170+83=253

Solution       #              = 282
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=1, H=2, T=4, T=4, H=2, E=1, G=7, A=5, Ö=8, Y=0.
Solution       got            = 170+84=254

Solution       #              = 283
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=1, H=2, T=6, T=6, H=2, E=1, G=7, A=5, Ö=8, Y=0.
Solution       got            = 170+86=256

Solution       #              = 284
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=1, H=2, T=9, T=9, H=2, E=1, G=7, A=5, Ö=8, Y=0.
Solution       got            = 170+89=259

Solution       #              = 285
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=2, H=3, T=1, T=1, H=3, E=2, G=7, A=5, Ö=8, Y=0.
Solution       got            = 270+81=351

Solution       #              = 286
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=2, H=3, T=4, T=4, H=3, E=2, G=7, A=5, Ö=8, Y=0.
Solution       got            = 270+84=354

Solution       #              = 287
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=2, H=3, T=6, T=6, H=3, E=2, G=7, A=5, Ö=8, Y=0.
Solution       got            = 270+86=356

Solution       #              = 288
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=2, H=3, T=9, T=9, H=3, E=2, G=7, A=5, Ö=8, Y=0.
Solution       got            = 270+89=359

Solution       #              = 289
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=3, H=4, T=1, T=1, H=4, E=3, G=7, A=5, Ö=8, Y=0.
Solution       got            = 370+81=451

Solution       #              = 290
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=3, H=4, T=2, T=2, H=4, E=3, G=7, A=5, Ö=8, Y=0.
Solution       got            = 370+82=452

Solution       #              = 291
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=3, H=4, T=6, T=6, H=4, E=3, G=7, A=5, Ö=8, Y=0.
Solution       got            = 370+86=456

Solution       #              = 292
Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=3, H=4, T=9, T=9, H=4, E=3, G=7, A=5, Ö=8, Y=0.
Solution       got            = 370+89=459

Solution       #              = 293
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=1, H=2, T=3, T=3, H=2, E=1, G=9, A=7, Ö=8, Y=0.
Solution       got            = 190+83=273

Solution       #              = 294
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=1, H=2, T=4, T=4, H=2, E=1, G=9, A=7, Ö=8, Y=0.
Solution       got            = 190+84=274

Solution       #              = 295
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=1, H=2, T=5, T=5, H=2, E=1, G=9, A=7, Ö=8, Y=0.
Solution       got            = 190+85=275

Solution       #              = 296
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=1, H=2, T=6, T=6, H=2, E=1, G=9, A=7, Ö=8, Y=0.
Solution       got            = 190+86=276

Solution       #              = 297
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=2, H=3, T=1, T=1, H=3, E=2, G=9, A=7, Ö=8, Y=0.
Solution       got            = 290+81=371

Solution       #              = 298
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=2, H=3, T=4, T=4, H=3, E=2, G=9, A=7, Ö=8, Y=0.
Solution       got            = 290+84=374

Solution       #              = 299
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=2, H=3, T=5, T=5, H=3, E=2, G=9, A=7, Ö=8, Y=0.
Solution       got            = 290+85=375

Solution       #              = 300
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=2, H=3, T=6, T=6, H=3, E=2, G=9, A=7, Ö=8, Y=0.
Solution       got            = 290+86=376

Solution       #              = 301
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=3, H=4, T=1, T=1, H=4, E=3, G=9, A=7, Ö=8, Y=0.
Solution       got            = 390+81=471

Solution       #              = 302
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=3, H=4, T=2, T=2, H=4, E=3, G=9, A=7, Ö=8, Y=0.
Solution       got            = 390+82=472

Solution       #              = 303
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=3, H=4, T=5, T=5, H=4, E=3, G=9, A=7, Ö=8, Y=0.
Solution       got            = 390+85=475

Solution       #              = 304
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=3, H=4, T=6, T=6, H=4, E=3, G=9, A=7, Ö=8, Y=0.
Solution       got            = 390+86=476

Solution       #              = 305
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=4, H=5, T=1, T=1, H=5, E=4, G=9, A=7, Ö=8, Y=0.
Solution       got            = 490+81=571

Solution       #              = 306
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=4, H=5, T=2, T=2, H=5, E=4, G=9, A=7, Ö=8, Y=0.
Solution       got            = 490+82=572

Solution       #              = 307
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=4, H=5, T=3, T=3, H=5, E=4, G=9, A=7, Ö=8, Y=0.
Solution       got            = 490+83=573

Solution       #              = 308
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=4, H=5, T=6, T=6, H=5, E=4, G=9, A=7, Ö=8, Y=0.
Solution       got            = 490+86=576

Solution       #              = 309
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=5, H=6, T=1, T=1, H=6, E=5, G=9, A=7, Ö=8, Y=0.
Solution       got            = 590+81=671

Solution       #              = 310
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=5, H=6, T=2, T=2, H=6, E=5, G=9, A=7, Ö=8, Y=0.
Solution       got            = 590+82=672

Solution       #              = 311
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=5, H=6, T=3, T=3, H=6, E=5, G=9, A=7, Ö=8, Y=0.
Solution       got            = 590+83=673

Solution       #              = 312
Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=5, H=6, T=4, T=4, H=6, E=5, G=9, A=7, Ö=8, Y=0.
Solution       got            = 590+84=674

Solution       #              = 313
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=3, H=4, T=5, T=5, H=4, E=3, G=2, A=1, Ö=9, Y=0.
Solution       got            = 320+95=415

Solution       #              = 314
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=3, H=4, T=6, T=6, H=4, E=3, G=2, A=1, Ö=9, Y=0.
Solution       got            = 320+96=416

Solution       #              = 315
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=3, H=4, T=7, T=7, H=4, E=3, G=2, A=1, Ö=9, Y=0.
Solution       got            = 320+97=417

Solution       #              = 316
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=3, H=4, T=8, T=8, H=4, E=3, G=2, A=1, Ö=9, Y=0.
Solution       got            = 320+98=418

Solution       #              = 317
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=4, H=5, T=3, T=3, H=5, E=4, G=2, A=1, Ö=9, Y=0.
Solution       got            = 420+93=513

Solution       #              = 318
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=4, H=5, T=6, T=6, H=5, E=4, G=2, A=1, Ö=9, Y=0.
Solution       got            = 420+96=516

Solution       #              = 319
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=4, H=5, T=7, T=7, H=5, E=4, G=2, A=1, Ö=9, Y=0.
Solution       got            = 420+97=517

Solution       #              = 320
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=4, H=5, T=8, T=8, H=5, E=4, G=2, A=1, Ö=9, Y=0.
Solution       got            = 420+98=518

Solution       #              = 321
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=5, H=6, T=3, T=3, H=6, E=5, G=2, A=1, Ö=9, Y=0.
Solution       got            = 520+93=613

Solution       #              = 322
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=5, H=6, T=4, T=4, H=6, E=5, G=2, A=1, Ö=9, Y=0.
Solution       got            = 520+94=614

Solution       #              = 323
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=5, H=6, T=7, T=7, H=6, E=5, G=2, A=1, Ö=9, Y=0.
Solution       got            = 520+97=617

Solution       #              = 324
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=5, H=6, T=8, T=8, H=6, E=5, G=2, A=1, Ö=9, Y=0.
Solution       got            = 520+98=618

Solution       #              = 325
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=6, H=7, T=3, T=3, H=7, E=6, G=2, A=1, Ö=9, Y=0.
Solution       got            = 620+93=713

Solution       #              = 326
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=6, H=7, T=4, T=4, H=7, E=6, G=2, A=1, Ö=9, Y=0.
Solution       got            = 620+94=714

Solution       #              = 327
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=6, H=7, T=5, T=5, H=7, E=6, G=2, A=1, Ö=9, Y=0.
Solution       got            = 620+95=715

Solution       #              = 328
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=6, H=7, T=8, T=8, H=7, E=6, G=2, A=1, Ö=9, Y=0.
Solution       got            = 620+98=718

Solution       #              = 329
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=7, H=8, T=3, T=3, H=8, E=7, G=2, A=1, Ö=9, Y=0.
Solution       got            = 720+93=813

Solution       #              = 330
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=7, H=8, T=4, T=4, H=8, E=7, G=2, A=1, Ö=9, Y=0.
Solution       got            = 720+94=814

Solution       #              = 331
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=7, H=8, T=5, T=5, H=8, E=7, G=2, A=1, Ö=9, Y=0.
Solution       got            = 720+95=815

Solution       #              = 332
Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=7, H=8, T=6, T=6, H=8, E=7, G=2, A=1, Ö=9, Y=0.
Solution       got            = 720+96=816

Solution       #              = 333
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=4, H=5, T=1, T=1, H=5, E=4, G=3, A=2, Ö=9, Y=0.
Solution       got            = 430+91=521

Solution       #              = 334
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=4, H=5, T=6, T=6, H=5, E=4, G=3, A=2, Ö=9, Y=0.
Solution       got            = 430+96=526

Solution       #              = 335
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=4, H=5, T=7, T=7, H=5, E=4, G=3, A=2, Ö=9, Y=0.
Solution       got            = 430+97=527

Solution       #              = 336
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=4, H=5, T=8, T=8, H=5, E=4, G=3, A=2, Ö=9, Y=0.
Solution       got            = 430+98=528

Solution       #              = 337
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=5, H=6, T=1, T=1, H=6, E=5, G=3, A=2, Ö=9, Y=0.
Solution       got            = 530+91=621

Solution       #              = 338
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=5, H=6, T=4, T=4, H=6, E=5, G=3, A=2, Ö=9, Y=0.
Solution       got            = 530+94=624

Solution       #              = 339
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=5, H=6, T=7, T=7, H=6, E=5, G=3, A=2, Ö=9, Y=0.
Solution       got            = 530+97=627

Solution       #              = 340
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=5, H=6, T=8, T=8, H=6, E=5, G=3, A=2, Ö=9, Y=0.
Solution       got            = 530+98=628

Solution       #              = 341
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=6, H=7, T=1, T=1, H=7, E=6, G=3, A=2, Ö=9, Y=0.
Solution       got            = 630+91=721

Solution       #              = 342
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=6, H=7, T=4, T=4, H=7, E=6, G=3, A=2, Ö=9, Y=0.
Solution       got            = 630+94=724

Solution       #              = 343
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=6, H=7, T=5, T=5, H=7, E=6, G=3, A=2, Ö=9, Y=0.
Solution       got            = 630+95=725

Solution       #              = 344
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=6, H=7, T=8, T=8, H=7, E=6, G=3, A=2, Ö=9, Y=0.
Solution       got            = 630+98=728

Solution       #              = 345
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=7, H=8, T=1, T=1, H=8, E=7, G=3, A=2, Ö=9, Y=0.
Solution       got            = 730+91=821

Solution       #              = 346
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=7, H=8, T=4, T=4, H=8, E=7, G=3, A=2, Ö=9, Y=0.
Solution       got            = 730+94=824

Solution       #              = 347
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=7, H=8, T=5, T=5, H=8, E=7, G=3, A=2, Ö=9, Y=0.
Solution       got            = 730+95=825

Solution       #              = 348
Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=7, H=8, T=6, T=6, H=8, E=7, G=3, A=2, Ö=9, Y=0.
Solution       got            = 730+96=826

Solution       #              = 349
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=1, H=2, T=5, T=5, H=2, E=1, G=4, A=3, Ö=9, Y=0.
Solution       got            = 140+95=235

Solution       #              = 350
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=1, H=2, T=6, T=6, H=2, E=1, G=4, A=3, Ö=9, Y=0.
Solution       got            = 140+96=236

Solution       #              = 351
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=1, H=2, T=7, T=7, H=2, E=1, G=4, A=3, Ö=9, Y=0.
Solution       got            = 140+97=237

Solution       #              = 352
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=1, H=2, T=8, T=8, H=2, E=1, G=4, A=3, Ö=9, Y=0.
Solution       got            = 140+98=238

Solution       #              = 353
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=5, H=6, T=1, T=1, H=6, E=5, G=4, A=3, Ö=9, Y=0.
Solution       got            = 540+91=631

Solution       #              = 354
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=5, H=6, T=2, T=2, H=6, E=5, G=4, A=3, Ö=9, Y=0.
Solution       got            = 540+92=632

Solution       #              = 355
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=5, H=6, T=7, T=7, H=6, E=5, G=4, A=3, Ö=9, Y=0.
Solution       got            = 540+97=637

Solution       #              = 356
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=5, H=6, T=8, T=8, H=6, E=5, G=4, A=3, Ö=9, Y=0.
Solution       got            = 540+98=638

Solution       #              = 357
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=6, H=7, T=1, T=1, H=7, E=6, G=4, A=3, Ö=9, Y=0.
Solution       got            = 640+91=731

Solution       #              = 358
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=6, H=7, T=2, T=2, H=7, E=6, G=4, A=3, Ö=9, Y=0.
Solution       got            = 640+92=732

Solution       #              = 359
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=6, H=7, T=5, T=5, H=7, E=6, G=4, A=3, Ö=9, Y=0.
Solution       got            = 640+95=735

Solution       #              = 360
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=6, H=7, T=8, T=8, H=7, E=6, G=4, A=3, Ö=9, Y=0.
Solution       got            = 640+98=738

Solution       #              = 361
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=7, H=8, T=1, T=1, H=8, E=7, G=4, A=3, Ö=9, Y=0.
Solution       got            = 740+91=831

Solution       #              = 362
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=7, H=8, T=2, T=2, H=8, E=7, G=4, A=3, Ö=9, Y=0.
Solution       got            = 740+92=832

Solution       #              = 363
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=7, H=8, T=5, T=5, H=8, E=7, G=4, A=3, Ö=9, Y=0.
Solution       got            = 740+95=835

Solution       #              = 364
Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=7, H=8, T=6, T=6, H=8, E=7, G=4, A=3, Ö=9, Y=0.
Solution       got            = 740+96=836

Solution       #              = 365
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=1, H=2, T=3, T=3, H=2, E=1, G=5, A=4, Ö=9, Y=0.
Solution       got            = 150+93=243

Solution       #              = 366
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=1, H=2, T=6, T=6, H=2, E=1, G=5, A=4, Ö=9, Y=0.
Solution       got            = 150+96=246

Solution       #              = 367
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=1, H=2, T=7, T=7, H=2, E=1, G=5, A=4, Ö=9, Y=0.
Solution       got            = 150+97=247

Solution       #              = 368
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=1, H=2, T=8, T=8, H=2, E=1, G=5, A=4, Ö=9, Y=0.
Solution       got            = 150+98=248

Solution       #              = 369
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=2, H=3, T=1, T=1, H=3, E=2, G=5, A=4, Ö=9, Y=0.
Solution       got            = 250+91=341

Solution       #              = 370
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=2, H=3, T=6, T=6, H=3, E=2, G=5, A=4, Ö=9, Y=0.
Solution       got            = 250+96=346

Solution       #              = 371
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=2, H=3, T=7, T=7, H=3, E=2, G=5, A=4, Ö=9, Y=0.
Solution       got            = 250+97=347

Solution       #              = 372
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=2, H=3, T=8, T=8, H=3, E=2, G=5, A=4, Ö=9, Y=0.
Solution       got            = 250+98=348

Solution       #              = 373
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=6, H=7, T=1, T=1, H=7, E=6, G=5, A=4, Ö=9, Y=0.
Solution       got            = 650+91=741

Solution       #              = 374
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=6, H=7, T=2, T=2, H=7, E=6, G=5, A=4, Ö=9, Y=0.
Solution       got            = 650+92=742

Solution       #              = 375
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=6, H=7, T=3, T=3, H=7, E=6, G=5, A=4, Ö=9, Y=0.
Solution       got            = 650+93=743

Solution       #              = 376
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=6, H=7, T=8, T=8, H=7, E=6, G=5, A=4, Ö=9, Y=0.
Solution       got            = 650+98=748

Solution       #              = 377
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=7, H=8, T=1, T=1, H=8, E=7, G=5, A=4, Ö=9, Y=0.
Solution       got            = 750+91=841

Solution       #              = 378
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=7, H=8, T=2, T=2, H=8, E=7, G=5, A=4, Ö=9, Y=0.
Solution       got            = 750+92=842

Solution       #              = 379
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=7, H=8, T=3, T=3, H=8, E=7, G=5, A=4, Ö=9, Y=0.
Solution       got            = 750+93=843

Solution       #              = 380
Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=7, H=8, T=6, T=6, H=8, E=7, G=5, A=4, Ö=9, Y=0.
Solution       got            = 750+96=846

Solution       #              = 381
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=1, H=2, T=3, T=3, H=2, E=1, G=6, A=5, Ö=9, Y=0.
Solution       got            = 160+93=253

Solution       #              = 382
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=1, H=2, T=4, T=4, H=2, E=1, G=6, A=5, Ö=9, Y=0.
Solution       got            = 160+94=254

Solution       #              = 383
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=1, H=2, T=7, T=7, H=2, E=1, G=6, A=5, Ö=9, Y=0.
Solution       got            = 160+97=257

Solution       #              = 384
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=1, H=2, T=8, T=8, H=2, E=1, G=6, A=5, Ö=9, Y=0.
Solution       got            = 160+98=258

Solution       #              = 385
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=2, H=3, T=1, T=1, H=3, E=2, G=6, A=5, Ö=9, Y=0.
Solution       got            = 260+91=351

Solution       #              = 386
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=2, H=3, T=4, T=4, H=3, E=2, G=6, A=5, Ö=9, Y=0.
Solution       got            = 260+94=354

Solution       #              = 387
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=2, H=3, T=7, T=7, H=3, E=2, G=6, A=5, Ö=9, Y=0.
Solution       got            = 260+97=357

Solution       #              = 388
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=2, H=3, T=8, T=8, H=3, E=2, G=6, A=5, Ö=9, Y=0.
Solution       got            = 260+98=358

Solution       #              = 389
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=3, H=4, T=1, T=1, H=4, E=3, G=6, A=5, Ö=9, Y=0.
Solution       got            = 360+91=451

Solution       #              = 390
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=3, H=4, T=2, T=2, H=4, E=3, G=6, A=5, Ö=9, Y=0.
Solution       got            = 360+92=452

Solution       #              = 391
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=3, H=4, T=7, T=7, H=4, E=3, G=6, A=5, Ö=9, Y=0.
Solution       got            = 360+97=457

Solution       #              = 392
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=3, H=4, T=8, T=8, H=4, E=3, G=6, A=5, Ö=9, Y=0.
Solution       got            = 360+98=458

Solution       #              = 393
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=7, H=8, T=1, T=1, H=8, E=7, G=6, A=5, Ö=9, Y=0.
Solution       got            = 760+91=851

Solution       #              = 394
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=7, H=8, T=2, T=2, H=8, E=7, G=6, A=5, Ö=9, Y=0.
Solution       got            = 760+92=852

Solution       #              = 395
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=7, H=8, T=3, T=3, H=8, E=7, G=6, A=5, Ö=9, Y=0.
Solution       got            = 760+93=853

Solution       #              = 396
Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=7, H=8, T=4, T=4, H=8, E=7, G=6, A=5, Ö=9, Y=0.
Solution       got            = 760+94=854

Solution       #              = 397
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=1, H=2, T=3, T=3, H=2, E=1, G=7, A=6, Ö=9, Y=0.
Solution       got            = 170+93=263

Solution       #              = 398
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=1, H=2, T=4, T=4, H=2, E=1, G=7, A=6, Ö=9, Y=0.
Solution       got            = 170+94=264

Solution       #              = 399
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=1, H=2, T=5, T=5, H=2, E=1, G=7, A=6, Ö=9, Y=0.
Solution       got            = 170+95=265

Solution       #              = 400
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=1, H=2, T=8, T=8, H=2, E=1, G=7, A=6, Ö=9, Y=0.
Solution       got            = 170+98=268

Solution       #              = 401
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=2, H=3, T=1, T=1, H=3, E=2, G=7, A=6, Ö=9, Y=0.
Solution       got            = 270+91=361

Solution       #              = 402
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=2, H=3, T=4, T=4, H=3, E=2, G=7, A=6, Ö=9, Y=0.
Solution       got            = 270+94=364

Solution       #              = 403
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=2, H=3, T=5, T=5, H=3, E=2, G=7, A=6, Ö=9, Y=0.
Solution       got            = 270+95=365

Solution       #              = 404
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=2, H=3, T=8, T=8, H=3, E=2, G=7, A=6, Ö=9, Y=0.
Solution       got            = 270+98=368

Solution       #              = 405
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=3, H=4, T=1, T=1, H=4, E=3, G=7, A=6, Ö=9, Y=0.
Solution       got            = 370+91=461

Solution       #              = 406
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=3, H=4, T=2, T=2, H=4, E=3, G=7, A=6, Ö=9, Y=0.
Solution       got            = 370+92=462

Solution       #              = 407
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=3, H=4, T=5, T=5, H=4, E=3, G=7, A=6, Ö=9, Y=0.
Solution       got            = 370+95=465

Solution       #              = 408
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=3, H=4, T=8, T=8, H=4, E=3, G=7, A=6, Ö=9, Y=0.
Solution       got            = 370+98=468

Solution       #              = 409
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=4, H=5, T=1, T=1, H=5, E=4, G=7, A=6, Ö=9, Y=0.
Solution       got            = 470+91=561

Solution       #              = 410
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=4, H=5, T=2, T=2, H=5, E=4, G=7, A=6, Ö=9, Y=0.
Solution       got            = 470+92=562

Solution       #              = 411
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=4, H=5, T=3, T=3, H=5, E=4, G=7, A=6, Ö=9, Y=0.
Solution       got            = 470+93=563

Solution       #              = 412
Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=4, H=5, T=8, T=8, H=5, E=4, G=7, A=6, Ö=9, Y=0.
Solution       got            = 470+98=568

Solution       #              = 413
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=1, H=2, T=3, T=3, H=2, E=1, G=8, A=7, Ö=9, Y=0.
Solution       got            = 180+93=273

Solution       #              = 414
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=1, H=2, T=4, T=4, H=2, E=1, G=8, A=7, Ö=9, Y=0.
Solution       got            = 180+94=274

Solution       #              = 415
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=1, H=2, T=5, T=5, H=2, E=1, G=8, A=7, Ö=9, Y=0.
Solution       got            = 180+95=275

Solution       #              = 416
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=1, H=2, T=6, T=6, H=2, E=1, G=8, A=7, Ö=9, Y=0.
Solution       got            = 180+96=276

Solution       #              = 417
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=2, H=3, T=1, T=1, H=3, E=2, G=8, A=7, Ö=9, Y=0.
Solution       got            = 280+91=371

Solution       #              = 418
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=2, H=3, T=4, T=4, H=3, E=2, G=8, A=7, Ö=9, Y=0.
Solution       got            = 280+94=374

Solution       #              = 419
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=2, H=3, T=5, T=5, H=3, E=2, G=8, A=7, Ö=9, Y=0.
Solution       got            = 280+95=375

Solution       #              = 420
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=2, H=3, T=6, T=6, H=3, E=2, G=8, A=7, Ö=9, Y=0.
Solution       got            = 280+96=376

Solution       #              = 421
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=3, H=4, T=1, T=1, H=4, E=3, G=8, A=7, Ö=9, Y=0.
Solution       got            = 380+91=471

Solution       #              = 422
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=3, H=4, T=2, T=2, H=4, E=3, G=8, A=7, Ö=9, Y=0.
Solution       got            = 380+92=472

Solution       #              = 423
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=3, H=4, T=5, T=5, H=4, E=3, G=8, A=7, Ö=9, Y=0.
Solution       got            = 380+95=475

Solution       #              = 424
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=3, H=4, T=6, T=6, H=4, E=3, G=8, A=7, Ö=9, Y=0.
Solution       got            = 380+96=476

Solution       #              = 425
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=4, H=5, T=1, T=1, H=5, E=4, G=8, A=7, Ö=9, Y=0.
Solution       got            = 480+91=571

Solution       #              = 426
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=4, H=5, T=2, T=2, H=5, E=4, G=8, A=7, Ö=9, Y=0.
Solution       got            = 480+92=572

Solution       #              = 427
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=4, H=5, T=3, T=3, H=5, E=4, G=8, A=7, Ö=9, Y=0.
Solution       got            = 480+93=573

Solution       #              = 428
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=4, H=5, T=6, T=6, H=5, E=4, G=8, A=7, Ö=9, Y=0.
Solution       got            = 480+96=576

Solution       #              = 429
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=5, H=6, T=1, T=1, H=6, E=5, G=8, A=7, Ö=9, Y=0.
Solution       got            = 580+91=671

Solution       #              = 430
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=5, H=6, T=2, T=2, H=6, E=5, G=8, A=7, Ö=9, Y=0.
Solution       got            = 580+92=672

Solution       #              = 431
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=5, H=6, T=3, T=3, H=6, E=5, G=8, A=7, Ö=9, Y=0.
Solution       got            = 580+93=673

Solution       #              = 432
Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=5, H=6, T=4, T=4, H=6, E=5, G=8, A=7, Ö=9, Y=0.
Solution       got            = 580+94=674

End of fit lists and results.

Condensed      puzzle         = ÖTVEN+TÍZ=HATVAN

Simplified     puzzle         = ÖTVEN+TÍZ=HATVAN

Tried          fits           = 0
Matching       fits           = not found

Condensed      puzzle         = HATVAN+TÍZ=HETVEN

Simplified     puzzle         = HATVAN+TÍZ=HETVEN

Tried          fits           = 0
Matching       fits           = not found

Condensed      puzzle         = 5*HÚSZ=SZÁZ

Simplified     puzzle         = 5*HÚSZ=SZÁZ

Tried          fits           = 0
Matching       fits           = not found

Condensed      puzzle         = VÍZ+BOR=ITAL

Simplified     puzzle         = BOR+VÍZ=ITAL

Tried          fits           = 1872
Matching       fits found     = 96

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = L=2, R=3, Z=9, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.
Solution       got            = 743+859=1602

Solution       #              = 2
Solution       fitted         = L=2, R=3, Z=9, A=0, O=4, Í=5, B=8, T=6, V=7, V=7, T=6, B=8, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.
Solution       got            = 843+759=1602

Solution       #              = 3
Solution       fitted         = L=2, R=3, Z=9, A=0, O=5, Í=4, B=7, T=6, V=8, V=8, T=6, B=7, Í=4, O=5, A=0, Z=9, R=3, L=2, I=1.
Solution       got            = 753+849=1602

Solution       #              = 4
Solution       fitted         = L=2, R=3, Z=9, A=0, O=5, Í=4, B=8, T=6, V=7, V=7, T=6, B=8, Í=4, O=5, A=0, Z=9, R=3, L=2, I=1.
Solution       got            = 853+749=1602

Solution       #              = 5
Solution       fitted         = L=2, R=3, Z=9, A=6, O=7, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=7, A=6, Z=9, R=3, L=2, I=1.
Solution       got            = 473+589=1062

Solution       #              = 6
Solution       fitted         = L=2, R=3, Z=9, A=6, O=7, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=7, A=6, Z=9, R=3, L=2, I=1.
Solution       got            = 573+489=1062

Solution       #              = 7
Solution       fitted         = L=2, R=3, Z=9, A=6, O=8, Í=7, B=4, T=0, V=5, V=5, T=0, B=4, Í=7, O=8, A=6, Z=9, R=3, L=2, I=1.
Solution       got            = 483+579=1062

Solution       #              = 8
Solution       fitted         = L=2, R=3, Z=9, A=6, O=8, Í=7, B=5, T=0, V=4, V=4, T=0, B=5, Í=7, O=8, A=6, Z=9, R=3, L=2, I=1.
Solution       got            = 583+479=1062

Solution       #              = 9
Solution       fitted         = L=2, R=9, Z=3, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=3, R=9, L=2, I=1.
Solution       got            = 749+853=1602

Solution       #              = 10
Solution       fitted         = L=2, R=9, Z=3, A=0, O=4, Í=5, B=8, T=6, V=7, V=7, T=6, B=8, Í=5, O=4, A=0, Z=3, R=9, L=2, I=1.
Solution       got            = 849+753=1602

Solution       #              = 11
Solution       fitted         = L=2, R=9, Z=3, A=0, O=5, Í=4, B=7, T=6, V=8, V=8, T=6, B=7, Í=4, O=5, A=0, Z=3, R=9, L=2, I=1.
Solution       got            = 759+843=1602

Solution       #              = 12
Solution       fitted         = L=2, R=9, Z=3, A=0, O=5, Í=4, B=8, T=6, V=7, V=7, T=6, B=8, Í=4, O=5, A=0, Z=3, R=9, L=2, I=1.
Solution       got            = 859+743=1602

Solution       #              = 13
Solution       fitted         = L=2, R=9, Z=3, A=6, O=7, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=7, A=6, Z=3, R=9, L=2, I=1.
Solution       got            = 479+583=1062

Solution       #              = 14
Solution       fitted         = L=2, R=9, Z=3, A=6, O=7, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=7, A=6, Z=3, R=9, L=2, I=1.
Solution       got            = 579+483=1062

Solution       #              = 15
Solution       fitted         = L=2, R=9, Z=3, A=6, O=8, Í=7, B=4, T=0, V=5, V=5, T=0, B=4, Í=7, O=8, A=6, Z=3, R=9, L=2, I=1.
Solution       got            = 489+573=1062

Solution       #              = 16
Solution       fitted         = L=2, R=9, Z=3, A=6, O=8, Í=7, B=5, T=0, V=4, V=4, T=0, B=5, Í=7, O=8, A=6, Z=3, R=9, L=2, I=1.
Solution       got            = 589+473=1062

Solution       #              = 17
Solution       fitted         = L=3, R=4, Z=9, A=0, O=2, Í=7, B=6, T=5, V=8, V=8, T=5, B=6, Í=7, O=2, A=0, Z=9, R=4, L=3, I=1.
Solution       got            = 624+879=1503

Solution       #              = 18
Solution       fitted         = L=3, R=4, Z=9, A=0, O=2, Í=7, B=8, T=5, V=6, V=6, T=5, B=8, Í=7, O=2, A=0, Z=9, R=4, L=3, I=1.
Solution       got            = 824+679=1503

Solution       #              = 19
Solution       fitted         = L=3, R=4, Z=9, A=0, O=7, Í=2, B=6, T=5, V=8, V=8, T=5, B=6, Í=2, O=7, A=0, Z=9, R=4, L=3, I=1.
Solution       got            = 674+829=1503

Solution       #              = 20
Solution       fitted         = L=3, R=4, Z=9, A=0, O=7, Í=2, B=8, T=5, V=6, V=6, T=5, B=8, Í=2, O=7, A=0, Z=9, R=4, L=3, I=1.
Solution       got            = 874+629=1503

Solution       #              = 21
Solution       fitted         = L=3, R=4, Z=9, A=5, O=6, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=6, A=5, Z=9, R=4, L=3, I=1.
Solution       got            = 264+789=1053

Solution       #              = 22
Solution       fitted         = L=3, R=4, Z=9, A=5, O=6, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=6, A=5, Z=9, R=4, L=3, I=1.
Solution       got            = 764+289=1053

Solution       #              = 23
Solution       fitted         = L=3, R=4, Z=9, A=5, O=8, Í=6, B=2, T=0, V=7, V=7, T=0, B=2, Í=6, O=8, A=5, Z=9, R=4, L=3, I=1.
Solution       got            = 284+769=1053

Solution       #              = 24
Solution       fitted         = L=3, R=4, Z=9, A=5, O=8, Í=6, B=7, T=0, V=2, V=2, T=0, B=7, Í=6, O=8, A=5, Z=9, R=4, L=3, I=1.
Solution       got            = 784+269=1053

Solution       #              = 25
Solution       fitted         = L=3, R=9, Z=4, A=0, O=2, Í=7, B=6, T=5, V=8, V=8, T=5, B=6, Í=7, O=2, A=0, Z=4, R=9, L=3, I=1.
Solution       got            = 629+874=1503

Solution       #              = 26
Solution       fitted         = L=3, R=9, Z=4, A=0, O=2, Í=7, B=8, T=5, V=6, V=6, T=5, B=8, Í=7, O=2, A=0, Z=4, R=9, L=3, I=1.
Solution       got            = 829+674=1503

Solution       #              = 27
Solution       fitted         = L=3, R=9, Z=4, A=0, O=7, Í=2, B=6, T=5, V=8, V=8, T=5, B=6, Í=2, O=7, A=0, Z=4, R=9, L=3, I=1.
Solution       got            = 679+824=1503

Solution       #              = 28
Solution       fitted         = L=3, R=9, Z=4, A=0, O=7, Í=2, B=8, T=5, V=6, V=6, T=5, B=8, Í=2, O=7, A=0, Z=4, R=9, L=3, I=1.
Solution       got            = 879+624=1503

Solution       #              = 29
Solution       fitted         = L=3, R=9, Z=4, A=5, O=6, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=6, A=5, Z=4, R=9, L=3, I=1.
Solution       got            = 269+784=1053

Solution       #              = 30
Solution       fitted         = L=3, R=9, Z=4, A=5, O=6, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=6, A=5, Z=4, R=9, L=3, I=1.
Solution       got            = 769+284=1053

Solution       #              = 31
Solution       fitted         = L=3, R=9, Z=4, A=5, O=8, Í=6, B=2, T=0, V=7, V=7, T=0, B=2, Í=6, O=8, A=5, Z=4, R=9, L=3, I=1.
Solution       got            = 289+764=1053

Solution       #              = 32
Solution       fitted         = L=3, R=9, Z=4, A=5, O=8, Í=6, B=7, T=0, V=2, V=2, T=0, B=7, Í=6, O=8, A=5, Z=4, R=9, L=3, I=1.
Solution       got            = 789+264=1053

Solution       #              = 33
Solution       fitted         = L=5, R=6, Z=9, A=0, O=2, Í=7, B=4, T=3, V=8, V=8, T=3, B=4, Í=7, O=2, A=0, Z=9, R=6, L=5, I=1.
Solution       got            = 426+879=1305

Solution       #              = 34
Solution       fitted         = L=5, R=6, Z=9, A=0, O=2, Í=7, B=8, T=3, V=4, V=4, T=3, B=8, Í=7, O=2, A=0, Z=9, R=6, L=5, I=1.
Solution       got            = 826+479=1305

Solution       #              = 35
Solution       fitted         = L=5, R=6, Z=9, A=0, O=7, Í=2, B=4, T=3, V=8, V=8, T=3, B=4, Í=2, O=7, A=0, Z=9, R=6, L=5, I=1.
Solution       got            = 476+829=1305

Solution       #              = 36
Solution       fitted         = L=5, R=6, Z=9, A=0, O=7, Í=2, B=8, T=3, V=4, V=4, T=3, B=8, Í=2, O=7, A=0, Z=9, R=6, L=5, I=1.
Solution       got            = 876+429=1305

Solution       #              = 37
Solution       fitted         = L=5, R=6, Z=9, A=3, O=4, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=4, A=3, Z=9, R=6, L=5, I=1.
Solution       got            = 246+789=1035

Solution       #              = 38
Solution       fitted         = L=5, R=6, Z=9, A=3, O=4, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=4, A=3, Z=9, R=6, L=5, I=1.
Solution       got            = 746+289=1035

Solution       #              = 39
Solution       fitted         = L=5, R=6, Z=9, A=3, O=8, Í=4, B=2, T=0, V=7, V=7, T=0, B=2, Í=4, O=8, A=3, Z=9, R=6, L=5, I=1.
Solution       got            = 286+749=1035

Solution       #              = 40
Solution       fitted         = L=5, R=6, Z=9, A=3, O=8, Í=4, B=7, T=0, V=2, V=2, T=0, B=7, Í=4, O=8, A=3, Z=9, R=6, L=5, I=1.
Solution       got            = 786+249=1035

Solution       #              = 41
Solution       fitted         = L=5, R=9, Z=6, A=0, O=2, Í=7, B=4, T=3, V=8, V=8, T=3, B=4, Í=7, O=2, A=0, Z=6, R=9, L=5, I=1.
Solution       got            = 429+876=1305

Solution       #              = 42
Solution       fitted         = L=5, R=9, Z=6, A=0, O=2, Í=7, B=8, T=3, V=4, V=4, T=3, B=8, Í=7, O=2, A=0, Z=6, R=9, L=5, I=1.
Solution       got            = 829+476=1305

Solution       #              = 43
Solution       fitted         = L=5, R=9, Z=6, A=0, O=7, Í=2, B=4, T=3, V=8, V=8, T=3, B=4, Í=2, O=7, A=0, Z=6, R=9, L=5, I=1.
Solution       got            = 479+826=1305

Solution       #              = 44
Solution       fitted         = L=5, R=9, Z=6, A=0, O=7, Í=2, B=8, T=3, V=4, V=4, T=3, B=8, Í=2, O=7, A=0, Z=6, R=9, L=5, I=1.
Solution       got            = 879+426=1305

Solution       #              = 45
Solution       fitted         = L=5, R=9, Z=6, A=3, O=4, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=4, A=3, Z=6, R=9, L=5, I=1.
Solution       got            = 249+786=1035

Solution       #              = 46
Solution       fitted         = L=5, R=9, Z=6, A=3, O=4, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=4, A=3, Z=6, R=9, L=5, I=1.
Solution       got            = 749+286=1035

Solution       #              = 47
Solution       fitted         = L=5, R=9, Z=6, A=3, O=8, Í=4, B=2, T=0, V=7, V=7, T=0, B=2, Í=4, O=8, A=3, Z=6, R=9, L=5, I=1.
Solution       got            = 289+746=1035

Solution       #              = 48
Solution       fitted         = L=5, R=9, Z=6, A=3, O=8, Í=4, B=7, T=0, V=2, V=2, T=0, B=7, Í=4, O=8, A=3, Z=6, R=9, L=5, I=1.
Solution       got            = 789+246=1035

Solution       #              = 49
Solution       fitted         = L=6, R=7, Z=9, A=0, O=4, Í=5, B=3, T=2, V=8, V=8, T=2, B=3, Í=5, O=4, A=0, Z=9, R=7, L=6, I=1.
Solution       got            = 347+859=1206

Solution       #              = 50
Solution       fitted         = L=6, R=7, Z=9, A=0, O=4, Í=5, B=8, T=2, V=3, V=3, T=2, B=8, Í=5, O=4, A=0, Z=9, R=7, L=6, I=1.
Solution       got            = 847+359=1206

Solution       #              = 51
Solution       fitted         = L=6, R=7, Z=9, A=0, O=5, Í=4, B=3, T=2, V=8, V=8, T=2, B=3, Í=4, O=5, A=0, Z=9, R=7, L=6, I=1.
Solution       got            = 357+849=1206

Solution       #              = 52
Solution       fitted         = L=6, R=7, Z=9, A=0, O=5, Í=4, B=8, T=2, V=3, V=3, T=2, B=8, Í=4, O=5, A=0, Z=9, R=7, L=6, I=1.
Solution       got            = 857+349=1206

Solution       #              = 53
Solution       fitted         = L=6, R=7, Z=9, A=2, O=3, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=3, A=2, Z=9, R=7, L=6, I=1.
Solution       got            = 437+589=1026

Solution       #              = 54
Solution       fitted         = L=6, R=7, Z=9, A=2, O=3, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=3, A=2, Z=9, R=7, L=6, I=1.
Solution       got            = 537+489=1026

Solution       #              = 55
Solution       fitted         = L=6, R=7, Z=9, A=2, O=8, Í=3, B=4, T=0, V=5, V=5, T=0, B=4, Í=3, O=8, A=2, Z=9, R=7, L=6, I=1.
Solution       got            = 487+539=1026

Solution       #              = 56
Solution       fitted         = L=6, R=7, Z=9, A=2, O=8, Í=3, B=5, T=0, V=4, V=4, T=0, B=5, Í=3, O=8, A=2, Z=9, R=7, L=6, I=1.
Solution       got            = 587+439=1026

Solution       #              = 57
Solution       fitted         = L=6, R=9, Z=7, A=0, O=4, Í=5, B=3, T=2, V=8, V=8, T=2, B=3, Í=5, O=4, A=0, Z=7, R=9, L=6, I=1.
Solution       got            = 349+857=1206

Solution       #              = 58
Solution       fitted         = L=6, R=9, Z=7, A=0, O=4, Í=5, B=8, T=2, V=3, V=3, T=2, B=8, Í=5, O=4, A=0, Z=7, R=9, L=6, I=1.
Solution       got            = 849+357=1206

Solution       #              = 59
Solution       fitted         = L=6, R=9, Z=7, A=0, O=5, Í=4, B=3, T=2, V=8, V=8, T=2, B=3, Í=4, O=5, A=0, Z=7, R=9, L=6, I=1.
Solution       got            = 359+847=1206

Solution       #              = 60
Solution       fitted         = L=6, R=9, Z=7, A=0, O=5, Í=4, B=8, T=2, V=3, V=3, T=2, B=8, Í=4, O=5, A=0, Z=7, R=9, L=6, I=1.
Solution       got            = 859+347=1206

Solution       #              = 61
Solution       fitted         = L=6, R=9, Z=7, A=2, O=3, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=3, A=2, Z=7, R=9, L=6, I=1.
Solution       got            = 439+587=1026

Solution       #              = 62
Solution       fitted         = L=6, R=9, Z=7, A=2, O=3, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=3, A=2, Z=7, R=9, L=6, I=1.
Solution       got            = 539+487=1026

Solution       #              = 63
Solution       fitted         = L=6, R=9, Z=7, A=2, O=8, Í=3, B=4, T=0, V=5, V=5, T=0, B=4, Í=3, O=8, A=2, Z=7, R=9, L=6, I=1.
Solution       got            = 489+537=1026

Solution       #              = 64
Solution       fitted         = L=6, R=9, Z=7, A=2, O=8, Í=3, B=5, T=0, V=4, V=4, T=0, B=5, Í=3, O=8, A=2, Z=7, R=9, L=6, I=1.
Solution       got            = 589+437=1026

Solution       #              = 65
Solution       fitted         = L=8, R=2, Z=6, A=9, O=4, Í=5, B=3, T=0, V=7, V=7, T=0, B=3, Í=5, O=4, A=9, Z=6, R=2, L=8, I=1.
Solution       got            = 342+756=1098

Solution       #              = 66
Solution       fitted         = L=8, R=2, Z=6, A=9, O=4, Í=5, B=7, T=0, V=3, V=3, T=0, B=7, Í=5, O=4, A=9, Z=6, R=2, L=8, I=1.
Solution       got            = 742+356=1098

Solution       #              = 67
Solution       fitted         = L=8, R=2, Z=6, A=9, O=5, Í=4, B=3, T=0, V=7, V=7, T=0, B=3, Í=4, O=5, A=9, Z=6, R=2, L=8, I=1.
Solution       got            = 352+746=1098

Solution       #              = 68
Solution       fitted         = L=8, R=2, Z=6, A=9, O=5, Í=4, B=7, T=0, V=3, V=3, T=0, B=7, Í=4, O=5, A=9, Z=6, R=2, L=8, I=1.
Solution       got            = 752+346=1098

Solution       #              = 69
Solution       fitted         = L=8, R=3, Z=5, A=9, O=2, Í=7, B=4, T=0, V=6, V=6, T=0, B=4, Í=7, O=2, A=9, Z=5, R=3, L=8, I=1.
Solution       got            = 423+675=1098

Solution       #              = 70
Solution       fitted         = L=8, R=3, Z=5, A=9, O=2, Í=7, B=6, T=0, V=4, V=4, T=0, B=6, Í=7, O=2, A=9, Z=5, R=3, L=8, I=1.
Solution       got            = 623+475=1098

Solution       #              = 71
Solution       fitted         = L=8, R=3, Z=5, A=9, O=7, Í=2, B=4, T=0, V=6, V=6, T=0, B=4, Í=2, O=7, A=9, Z=5, R=3, L=8, I=1.
Solution       got            = 473+625=1098

Solution       #              = 72
Solution       fitted         = L=8, R=3, Z=5, A=9, O=7, Í=2, B=6, T=0, V=4, V=4, T=0, B=6, Í=2, O=7, A=9, Z=5, R=3, L=8, I=1.
Solution       got            = 673+425=1098

Solution       #              = 73
Solution       fitted         = L=8, R=5, Z=3, A=9, O=2, Í=7, B=4, T=0, V=6, V=6, T=0, B=4, Í=7, O=2, A=9, Z=3, R=5, L=8, I=1.
Solution       got            = 425+673=1098

Solution       #              = 74
Solution       fitted         = L=8, R=5, Z=3, A=9, O=2, Í=7, B=6, T=0, V=4, V=4, T=0, B=6, Í=7, O=2, A=9, Z=3, R=5, L=8, I=1.
Solution       got            = 625+473=1098

Solution       #              = 75
Solution       fitted         = L=8, R=5, Z=3, A=9, O=7, Í=2, B=4, T=0, V=6, V=6, T=0, B=4, Í=2, O=7, A=9, Z=3, R=5, L=8, I=1.
Solution       got            = 475+623=1098

Solution       #              = 76
Solution       fitted         = L=8, R=5, Z=3, A=9, O=7, Í=2, B=6, T=0, V=4, V=4, T=0, B=6, Í=2, O=7, A=9, Z=3, R=5, L=8, I=1.
Solution       got            = 675+423=1098

Solution       #              = 77
Solution       fitted         = L=8, R=6, Z=2, A=9, O=4, Í=5, B=3, T=0, V=7, V=7, T=0, B=3, Í=5, O=4, A=9, Z=2, R=6, L=8, I=1.
Solution       got            = 346+752=1098

Solution       #              = 78
Solution       fitted         = L=8, R=6, Z=2, A=9, O=4, Í=5, B=7, T=0, V=3, V=3, T=0, B=7, Í=5, O=4, A=9, Z=2, R=6, L=8, I=1.
Solution       got            = 746+352=1098

Solution       #              = 79
Solution       fitted         = L=8, R=6, Z=2, A=9, O=5, Í=4, B=3, T=0, V=7, V=7, T=0, B=3, Í=4, O=5, A=9, Z=2, R=6, L=8, I=1.
Solution       got            = 356+742=1098

Solution       #              = 80
Solution       fitted         = L=8, R=6, Z=2, A=9, O=5, Í=4, B=7, T=0, V=3, V=3, T=0, B=7, Í=4, O=5, A=9, Z=2, R=6, L=8, I=1.
Solution       got            = 756+342=1098

Solution       #              = 81
Solution       fitted         = L=9, R=2, Z=7, A=8, O=3, Í=5, B=4, T=0, V=6, V=6, T=0, B=4, Í=5, O=3, A=8, Z=7, R=2, L=9, I=1.
Solution       got            = 432+657=1089

Solution       #              = 82
Solution       fitted         = L=9, R=2, Z=7, A=8, O=3, Í=5, B=6, T=0, V=4, V=4, T=0, B=6, Í=5, O=3, A=8, Z=7, R=2, L=9, I=1.
Solution       got            = 632+457=1089

Solution       #              = 83
Solution       fitted         = L=9, R=2, Z=7, A=8, O=5, Í=3, B=4, T=0, V=6, V=6, T=0, B=4, Í=3, O=5, A=8, Z=7, R=2, L=9, I=1.
Solution       got            = 452+637=1089

Solution       #              = 84
Solution       fitted         = L=9, R=2, Z=7, A=8, O=5, Í=3, B=6, T=0, V=4, V=4, T=0, B=6, Í=3, O=5, A=8, Z=7, R=2, L=9, I=1.
Solution       got            = 652+437=1089

Solution       #              = 85
Solution       fitted         = L=9, R=4, Z=5, A=8, O=2, Í=6, B=3, T=0, V=7, V=7, T=0, B=3, Í=6, O=2, A=8, Z=5, R=4, L=9, I=1.
Solution       got            = 324+765=1089

Solution       #              = 86
Solution       fitted         = L=9, R=4, Z=5, A=8, O=2, Í=6, B=7, T=0, V=3, V=3, T=0, B=7, Í=6, O=2, A=8, Z=5, R=4, L=9, I=1.
Solution       got            = 724+365=1089

Solution       #              = 87
Solution       fitted         = L=9, R=4, Z=5, A=8, O=6, Í=2, B=3, T=0, V=7, V=7, T=0, B=3, Í=2, O=6, A=8, Z=5, R=4, L=9, I=1.
Solution       got            = 364+725=1089

Solution       #              = 88
Solution       fitted         = L=9, R=4, Z=5, A=8, O=6, Í=2, B=7, T=0, V=3, V=3, T=0, B=7, Í=2, O=6, A=8, Z=5, R=4, L=9, I=1.
Solution       got            = 764+325=1089

Solution       #              = 89
Solution       fitted         = L=9, R=5, Z=4, A=8, O=2, Í=6, B=3, T=0, V=7, V=7, T=0, B=3, Í=6, O=2, A=8, Z=4, R=5, L=9, I=1.
Solution       got            = 325+764=1089

Solution       #              = 90
Solution       fitted         = L=9, R=5, Z=4, A=8, O=2, Í=6, B=7, T=0, V=3, V=3, T=0, B=7, Í=6, O=2, A=8, Z=4, R=5, L=9, I=1.
Solution       got            = 725+364=1089

Solution       #              = 91
Solution       fitted         = L=9, R=5, Z=4, A=8, O=6, Í=2, B=3, T=0, V=7, V=7, T=0, B=3, Í=2, O=6, A=8, Z=4, R=5, L=9, I=1.
Solution       got            = 365+724=1089

Solution       #              = 92
Solution       fitted         = L=9, R=5, Z=4, A=8, O=6, Í=2, B=7, T=0, V=3, V=3, T=0, B=7, Í=2, O=6, A=8, Z=4, R=5, L=9, I=1.
Solution       got            = 765+324=1089

Solution       #              = 93
Solution       fitted         = L=9, R=7, Z=2, A=8, O=3, Í=5, B=4, T=0, V=6, V=6, T=0, B=4, Í=5, O=3, A=8, Z=2, R=7, L=9, I=1.
Solution       got            = 437+652=1089

Solution       #              = 94
Solution       fitted         = L=9, R=7, Z=2, A=8, O=3, Í=5, B=6, T=0, V=4, V=4, T=0, B=6, Í=5, O=3, A=8, Z=2, R=7, L=9, I=1.
Solution       got            = 637+452=1089

Solution       #              = 95
Solution       fitted         = L=9, R=7, Z=2, A=8, O=5, Í=3, B=4, T=0, V=6, V=6, T=0, B=4, Í=3, O=5, A=8, Z=2, R=7, L=9, I=1.
Solution       got            = 457+632=1089

Solution       #              = 96
Solution       fitted         = L=9, R=7, Z=2, A=8, O=5, Í=3, B=6, T=0, V=4, V=4, T=0, B=6, Í=3, O=5, A=8, Z=2, R=7, L=9, I=1.
Solution       got            = 657+432=1089

End of fit lists and results.

Condensed      puzzle         = KUTYA+CICUS=ÁLLAT

Simplified     puzzle         = CICUS+KUTYA=ÁLLAT

Tried          fits           = 140
Matching       fits found     = 8

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = A=1, T=0, S=9, U=6, Y=4, C=2, L=3, I=7, K=5, Á=8, Á=8, K=5, I=7, L=3, C=2, Y=4, U=6, S=9, T=0, A=1.
Solution       got            = 27269+56041=83310

Solution       #              = 2
Solution       fitted         = A=1, T=6, S=5, U=2, Y=9, C=3, L=0, I=7, K=4, Á=8, Á=8, K=4, I=7, L=0, C=3, Y=9, U=2, S=5, T=6, A=1.
Solution       got            = 37325+42691=80016

Solution       #              = 3
Solution       fitted         = A=1, T=6, S=5, U=3, Y=8, C=7, L=4, I=0, K=2, Á=9, Á=9, K=2, I=0, L=4, C=7, Y=8, U=3, S=5, T=6, A=1.
Solution       got            = 70735+23681=94416

Solution       #              = 4
Solution       fitted         = A=3, T=7, S=4, U=8, Y=5, C=2, L=0, I=1, K=6, Á=9, Á=9, K=6, I=1, L=0, C=2, Y=5, U=8, S=4, T=7, A=3.
Solution       got            = 21284+68753=90037

Solution       #              = 5
Solution       fitted         = A=5, T=2, S=7, U=4, Y=0, C=1, L=3, I=9, K=6, Á=8, Á=8, K=6, I=9, L=3, C=1, Y=0, U=4, S=7, T=2, A=5.
Solution       got            = 19147+64205=83352

Solution       #              = 6
Solution       fitted         = A=5, T=9, S=4, U=2, Y=3, C=1, L=0, I=7, K=6, Á=8, Á=8, K=6, I=7, L=0, C=1, Y=3, U=2, S=4, T=9, A=5.
Solution       got            = 17124+62935=80059

Solution       #              = 7
Solution       fitted         = A=7, T=8, S=1, U=4, Y=3, C=2, L=0, I=5, K=6, Á=9, Á=9, K=6, I=5, L=0, C=2, Y=3, U=4, S=1, T=8, A=7.
Solution       got            = 25241+64837=90078

Solution       #              = 8
Solution       fitted         = A=7, T=9, S=2, U=4, Y=3, C=1, L=0, I=5, K=6, Á=8, Á=8, K=6, I=5, L=0, C=1, Y=3, U=4, S=2, T=9, A=7.
Solution       got            = 15142+64937=80079

End of fit lists and results.

Condensed      puzzle         = ÉLJEN+MÁJUS=ELSEJE

Simplified     puzzle         = MÁJUS+ÉLJEN=ELSEJE

Tried          fits           = 512
Matching       fits found     = 8

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = S=5, N=6, J=0, U=8, L=3, Á=2, M=4, É=9, É=9, M=4, Á=2, L=3, U=8, J=0, N=6, S=5, E=1.
Solution       got            = 42085+93016=135101

Solution       #              = 2
Solution       fitted         = S=5, N=6, J=0, U=8, L=3, Á=2, M=9, É=4, É=4, M=9, Á=2, L=3, U=8, J=0, N=6, S=5, E=1.
Solution       got            = 92085+43016=135101

Solution       #              = 3
Solution       fitted         = S=6, N=5, J=0, U=8, L=2, Á=4, M=3, É=9, É=9, M=3, Á=4, L=2, U=8, J=0, N=5, S=6, E=1.
Solution       got            = 34086+92015=126101

Solution       #              = 4
Solution       fitted         = S=6, N=5, J=0, U=8, L=2, Á=4, M=9, É=3, É=3, M=9, Á=4, L=2, U=8, J=0, N=5, S=6, E=1.
Solution       got            = 94086+32015=126101

Solution       #              = 5
Solution       fitted         = S=7, N=4, J=0, U=8, L=2, Á=5, M=3, É=9, É=9, M=3, Á=5, L=2, U=8, J=0, N=4, S=7, E=1.
Solution       got            = 35087+92014=127101

Solution       #              = 6
Solution       fitted         = S=7, N=4, J=0, U=8, L=2, Á=5, M=9, É=3, É=3, M=9, Á=5, L=2, U=8, J=0, N=4, S=7, E=1.
Solution       got            = 95087+32014=127101

Solution       #              = 7
Solution       fitted         = S=7, N=4, J=0, U=8, L=5, Á=2, M=6, É=9, É=9, M=6, Á=2, L=5, U=8, J=0, N=4, S=7, E=1.
Solution       got            = 62087+95014=157101

Solution       #              = 8
Solution       fitted         = S=7, N=4, J=0, U=8, L=5, Á=2, M=9, É=6, É=6, M=9, Á=2, L=5, U=8, J=0, N=4, S=7, E=1.
Solution       got            = 92087+65014=157101

End of fit lists and results.

Condensed      puzzle         = VÍZ+BOR=ITAL

Simplified     puzzle         = BOR+VÍZ=ITAL

Tried          fits           = 1872
Matching       fits found     = 96

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = L=2, R=3, Z=9, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.
Solution       got            = 743+859=1602

Solution       #              = 2
Solution       fitted         = L=2, R=3, Z=9, A=0, O=4, Í=5, B=8, T=6, V=7, V=7, T=6, B=8, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.
Solution       got            = 843+759=1602

Solution       #              = 3
Solution       fitted         = L=2, R=3, Z=9, A=0, O=5, Í=4, B=7, T=6, V=8, V=8, T=6, B=7, Í=4, O=5, A=0, Z=9, R=3, L=2, I=1.
Solution       got            = 753+849=1602

Solution       #              = 4
Solution       fitted         = L=2, R=3, Z=9, A=0, O=5, Í=4, B=8, T=6, V=7, V=7, T=6, B=8, Í=4, O=5, A=0, Z=9, R=3, L=2, I=1.
Solution       got            = 853+749=1602

Solution       #              = 5
Solution       fitted         = L=2, R=3, Z=9, A=6, O=7, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=7, A=6, Z=9, R=3, L=2, I=1.
Solution       got            = 473+589=1062

Solution       #              = 6
Solution       fitted         = L=2, R=3, Z=9, A=6, O=7, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=7, A=6, Z=9, R=3, L=2, I=1.
Solution       got            = 573+489=1062

Solution       #              = 7
Solution       fitted         = L=2, R=3, Z=9, A=6, O=8, Í=7, B=4, T=0, V=5, V=5, T=0, B=4, Í=7, O=8, A=6, Z=9, R=3, L=2, I=1.
Solution       got            = 483+579=1062

Solution       #              = 8
Solution       fitted         = L=2, R=3, Z=9, A=6, O=8, Í=7, B=5, T=0, V=4, V=4, T=0, B=5, Í=7, O=8, A=6, Z=9, R=3, L=2, I=1.
Solution       got            = 583+479=1062

Solution       #              = 9
Solution       fitted         = L=2, R=9, Z=3, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=3, R=9, L=2, I=1.
Solution       got            = 749+853=1602

Solution       #              = 10
Solution       fitted         = L=2, R=9, Z=3, A=0, O=4, Í=5, B=8, T=6, V=7, V=7, T=6, B=8, Í=5, O=4, A=0, Z=3, R=9, L=2, I=1.
Solution       got            = 849+753=1602

Solution       #              = 11
Solution       fitted         = L=2, R=9, Z=3, A=0, O=5, Í=4, B=7, T=6, V=8, V=8, T=6, B=7, Í=4, O=5, A=0, Z=3, R=9, L=2, I=1.
Solution       got            = 759+843=1602

Solution       #              = 12
Solution       fitted         = L=2, R=9, Z=3, A=0, O=5, Í=4, B=8, T=6, V=7, V=7, T=6, B=8, Í=4, O=5, A=0, Z=3, R=9, L=2, I=1.
Solution       got            = 859+743=1602

Solution       #              = 13
Solution       fitted         = L=2, R=9, Z=3, A=6, O=7, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=7, A=6, Z=3, R=9, L=2, I=1.
Solution       got            = 479+583=1062

Solution       #              = 14
Solution       fitted         = L=2, R=9, Z=3, A=6, O=7, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=7, A=6, Z=3, R=9, L=2, I=1.
Solution       got            = 579+483=1062

Solution       #              = 15
Solution       fitted         = L=2, R=9, Z=3, A=6, O=8, Í=7, B=4, T=0, V=5, V=5, T=0, B=4, Í=7, O=8, A=6, Z=3, R=9, L=2, I=1.
Solution       got            = 489+573=1062

Solution       #              = 16
Solution       fitted         = L=2, R=9, Z=3, A=6, O=8, Í=7, B=5, T=0, V=4, V=4, T=0, B=5, Í=7, O=8, A=6, Z=3, R=9, L=2, I=1.
Solution       got            = 589+473=1062

Solution       #              = 17
Solution       fitted         = L=3, R=4, Z=9, A=0, O=2, Í=7, B=6, T=5, V=8, V=8, T=5, B=6, Í=7, O=2, A=0, Z=9, R=4, L=3, I=1.
Solution       got            = 624+879=1503

Solution       #              = 18
Solution       fitted         = L=3, R=4, Z=9, A=0, O=2, Í=7, B=8, T=5, V=6, V=6, T=5, B=8, Í=7, O=2, A=0, Z=9, R=4, L=3, I=1.
Solution       got            = 824+679=1503

Solution       #              = 19
Solution       fitted         = L=3, R=4, Z=9, A=0, O=7, Í=2, B=6, T=5, V=8, V=8, T=5, B=6, Í=2, O=7, A=0, Z=9, R=4, L=3, I=1.
Solution       got            = 674+829=1503

Solution       #              = 20
Solution       fitted         = L=3, R=4, Z=9, A=0, O=7, Í=2, B=8, T=5, V=6, V=6, T=5, B=8, Í=2, O=7, A=0, Z=9, R=4, L=3, I=1.
Solution       got            = 874+629=1503

Solution       #              = 21
Solution       fitted         = L=3, R=4, Z=9, A=5, O=6, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=6, A=5, Z=9, R=4, L=3, I=1.
Solution       got            = 264+789=1053

Solution       #              = 22
Solution       fitted         = L=3, R=4, Z=9, A=5, O=6, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=6, A=5, Z=9, R=4, L=3, I=1.
Solution       got            = 764+289=1053

Solution       #              = 23
Solution       fitted         = L=3, R=4, Z=9, A=5, O=8, Í=6, B=2, T=0, V=7, V=7, T=0, B=2, Í=6, O=8, A=5, Z=9, R=4, L=3, I=1.
Solution       got            = 284+769=1053

Solution       #              = 24
Solution       fitted         = L=3, R=4, Z=9, A=5, O=8, Í=6, B=7, T=0, V=2, V=2, T=0, B=7, Í=6, O=8, A=5, Z=9, R=4, L=3, I=1.
Solution       got            = 784+269=1053

Solution       #              = 25
Solution       fitted         = L=3, R=9, Z=4, A=0, O=2, Í=7, B=6, T=5, V=8, V=8, T=5, B=6, Í=7, O=2, A=0, Z=4, R=9, L=3, I=1.
Solution       got            = 629+874=1503

Solution       #              = 26
Solution       fitted         = L=3, R=9, Z=4, A=0, O=2, Í=7, B=8, T=5, V=6, V=6, T=5, B=8, Í=7, O=2, A=0, Z=4, R=9, L=3, I=1.
Solution       got            = 829+674=1503

Solution       #              = 27
Solution       fitted         = L=3, R=9, Z=4, A=0, O=7, Í=2, B=6, T=5, V=8, V=8, T=5, B=6, Í=2, O=7, A=0, Z=4, R=9, L=3, I=1.
Solution       got            = 679+824=1503

Solution       #              = 28
Solution       fitted         = L=3, R=9, Z=4, A=0, O=7, Í=2, B=8, T=5, V=6, V=6, T=5, B=8, Í=2, O=7, A=0, Z=4, R=9, L=3, I=1.
Solution       got            = 879+624=1503

Solution       #              = 29
Solution       fitted         = L=3, R=9, Z=4, A=5, O=6, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=6, A=5, Z=4, R=9, L=3, I=1.
Solution       got            = 269+784=1053

Solution       #              = 30
Solution       fitted         = L=3, R=9, Z=4, A=5, O=6, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=6, A=5, Z=4, R=9, L=3, I=1.
Solution       got            = 769+284=1053

Solution       #              = 31
Solution       fitted         = L=3, R=9, Z=4, A=5, O=8, Í=6, B=2, T=0, V=7, V=7, T=0, B=2, Í=6, O=8, A=5, Z=4, R=9, L=3, I=1.
Solution       got            = 289+764=1053

Solution       #              = 32
Solution       fitted         = L=3, R=9, Z=4, A=5, O=8, Í=6, B=7, T=0, V=2, V=2, T=0, B=7, Í=6, O=8, A=5, Z=4, R=9, L=3, I=1.
Solution       got            = 789+264=1053

Solution       #              = 33
Solution       fitted         = L=5, R=6, Z=9, A=0, O=2, Í=7, B=4, T=3, V=8, V=8, T=3, B=4, Í=7, O=2, A=0, Z=9, R=6, L=5, I=1.
Solution       got            = 426+879=1305

Solution       #              = 34
Solution       fitted         = L=5, R=6, Z=9, A=0, O=2, Í=7, B=8, T=3, V=4, V=4, T=3, B=8, Í=7, O=2, A=0, Z=9, R=6, L=5, I=1.
Solution       got            = 826+479=1305

Solution       #              = 35
Solution       fitted         = L=5, R=6, Z=9, A=0, O=7, Í=2, B=4, T=3, V=8, V=8, T=3, B=4, Í=2, O=7, A=0, Z=9, R=6, L=5, I=1.
Solution       got            = 476+829=1305

Solution       #              = 36
Solution       fitted         = L=5, R=6, Z=9, A=0, O=7, Í=2, B=8, T=3, V=4, V=4, T=3, B=8, Í=2, O=7, A=0, Z=9, R=6, L=5, I=1.
Solution       got            = 876+429=1305

Solution       #              = 37
Solution       fitted         = L=5, R=6, Z=9, A=3, O=4, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=4, A=3, Z=9, R=6, L=5, I=1.
Solution       got            = 246+789=1035

Solution       #              = 38
Solution       fitted         = L=5, R=6, Z=9, A=3, O=4, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=4, A=3, Z=9, R=6, L=5, I=1.
Solution       got            = 746+289=1035

Solution       #              = 39
Solution       fitted         = L=5, R=6, Z=9, A=3, O=8, Í=4, B=2, T=0, V=7, V=7, T=0, B=2, Í=4, O=8, A=3, Z=9, R=6, L=5, I=1.
Solution       got            = 286+749=1035

Solution       #              = 40
Solution       fitted         = L=5, R=6, Z=9, A=3, O=8, Í=4, B=7, T=0, V=2, V=2, T=0, B=7, Í=4, O=8, A=3, Z=9, R=6, L=5, I=1.
Solution       got            = 786+249=1035

Solution       #              = 41
Solution       fitted         = L=5, R=9, Z=6, A=0, O=2, Í=7, B=4, T=3, V=8, V=8, T=3, B=4, Í=7, O=2, A=0, Z=6, R=9, L=5, I=1.
Solution       got            = 429+876=1305

Solution       #              = 42
Solution       fitted         = L=5, R=9, Z=6, A=0, O=2, Í=7, B=8, T=3, V=4, V=4, T=3, B=8, Í=7, O=2, A=0, Z=6, R=9, L=5, I=1.
Solution       got            = 829+476=1305

Solution       #              = 43
Solution       fitted         = L=5, R=9, Z=6, A=0, O=7, Í=2, B=4, T=3, V=8, V=8, T=3, B=4, Í=2, O=7, A=0, Z=6, R=9, L=5, I=1.
Solution       got            = 479+826=1305

Solution       #              = 44
Solution       fitted         = L=5, R=9, Z=6, A=0, O=7, Í=2, B=8, T=3, V=4, V=4, T=3, B=8, Í=2, O=7, A=0, Z=6, R=9, L=5, I=1.
Solution       got            = 879+426=1305

Solution       #              = 45
Solution       fitted         = L=5, R=9, Z=6, A=3, O=4, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=4, A=3, Z=6, R=9, L=5, I=1.
Solution       got            = 249+786=1035

Solution       #              = 46
Solution       fitted         = L=5, R=9, Z=6, A=3, O=4, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=4, A=3, Z=6, R=9, L=5, I=1.
Solution       got            = 749+286=1035

Solution       #              = 47
Solution       fitted         = L=5, R=9, Z=6, A=3, O=8, Í=4, B=2, T=0, V=7, V=7, T=0, B=2, Í=4, O=8, A=3, Z=6, R=9, L=5, I=1.
Solution       got            = 289+746=1035

Solution       #              = 48
Solution       fitted         = L=5, R=9, Z=6, A=3, O=8, Í=4, B=7, T=0, V=2, V=2, T=0, B=7, Í=4, O=8, A=3, Z=6, R=9, L=5, I=1.
Solution       got            = 789+246=1035

Solution       #              = 49
Solution       fitted         = L=6, R=7, Z=9, A=0, O=4, Í=5, B=3, T=2, V=8, V=8, T=2, B=3, Í=5, O=4, A=0, Z=9, R=7, L=6, I=1.
Solution       got            = 347+859=1206

Solution       #              = 50
Solution       fitted         = L=6, R=7, Z=9, A=0, O=4, Í=5, B=8, T=2, V=3, V=3, T=2, B=8, Í=5, O=4, A=0, Z=9, R=7, L=6, I=1.
Solution       got            = 847+359=1206

Solution       #              = 51
Solution       fitted         = L=6, R=7, Z=9, A=0, O=5, Í=4, B=3, T=2, V=8, V=8, T=2, B=3, Í=4, O=5, A=0, Z=9, R=7, L=6, I=1.
Solution       got            = 357+849=1206

Solution       #              = 52
Solution       fitted         = L=6, R=7, Z=9, A=0, O=5, Í=4, B=8, T=2, V=3, V=3, T=2, B=8, Í=4, O=5, A=0, Z=9, R=7, L=6, I=1.
Solution       got            = 857+349=1206

Solution       #              = 53
Solution       fitted         = L=6, R=7, Z=9, A=2, O=3, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=3, A=2, Z=9, R=7, L=6, I=1.
Solution       got            = 437+589=1026

Solution       #              = 54
Solution       fitted         = L=6, R=7, Z=9, A=2, O=3, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=3, A=2, Z=9, R=7, L=6, I=1.
Solution       got            = 537+489=1026

Solution       #              = 55
Solution       fitted         = L=6, R=7, Z=9, A=2, O=8, Í=3, B=4, T=0, V=5, V=5, T=0, B=4, Í=3, O=8, A=2, Z=9, R=7, L=6, I=1.
Solution       got            = 487+539=1026

Solution       #              = 56
Solution       fitted         = L=6, R=7, Z=9, A=2, O=8, Í=3, B=5, T=0, V=4, V=4, T=0, B=5, Í=3, O=8, A=2, Z=9, R=7, L=6, I=1.
Solution       got            = 587+439=1026

Solution       #              = 57
Solution       fitted         = L=6, R=9, Z=7, A=0, O=4, Í=5, B=3, T=2, V=8, V=8, T=2, B=3, Í=5, O=4, A=0, Z=7, R=9, L=6, I=1.
Solution       got            = 349+857=1206

Solution       #              = 58
Solution       fitted         = L=6, R=9, Z=7, A=0, O=4, Í=5, B=8, T=2, V=3, V=3, T=2, B=8, Í=5, O=4, A=0, Z=7, R=9, L=6, I=1.
Solution       got            = 849+357=1206

Solution       #              = 59
Solution       fitted         = L=6, R=9, Z=7, A=0, O=5, Í=4, B=3, T=2, V=8, V=8, T=2, B=3, Í=4, O=5, A=0, Z=7, R=9, L=6, I=1.
Solution       got            = 359+847=1206

Solution       #              = 60
Solution       fitted         = L=6, R=9, Z=7, A=0, O=5, Í=4, B=8, T=2, V=3, V=3, T=2, B=8, Í=4, O=5, A=0, Z=7, R=9, L=6, I=1.
Solution       got            = 859+347=1206

Solution       #              = 61
Solution       fitted         = L=6, R=9, Z=7, A=2, O=3, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=3, A=2, Z=7, R=9, L=6, I=1.
Solution       got            = 439+587=1026

Solution       #              = 62
Solution       fitted         = L=6, R=9, Z=7, A=2, O=3, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=3, A=2, Z=7, R=9, L=6, I=1.
Solution       got            = 539+487=1026

Solution       #              = 63
Solution       fitted         = L=6, R=9, Z=7, A=2, O=8, Í=3, B=4, T=0, V=5, V=5, T=0, B=4, Í=3, O=8, A=2, Z=7, R=9, L=6, I=1.
Solution       got            = 489+537=1026

Solution       #              = 64
Solution       fitted         = L=6, R=9, Z=7, A=2, O=8, Í=3, B=5, T=0, V=4, V=4, T=0, B=5, Í=3, O=8, A=2, Z=7, R=9, L=6, I=1.
Solution       got            = 589+437=1026

Solution       #              = 65
Solution       fitted         = L=8, R=2, Z=6, A=9, O=4, Í=5, B=3, T=0, V=7, V=7, T=0, B=3, Í=5, O=4, A=9, Z=6, R=2, L=8, I=1.
Solution       got            = 342+756=1098

Solution       #              = 66
Solution       fitted         = L=8, R=2, Z=6, A=9, O=4, Í=5, B=7, T=0, V=3, V=3, T=0, B=7, Í=5, O=4, A=9, Z=6, R=2, L=8, I=1.
Solution       got            = 742+356=1098

Solution       #              = 67
Solution       fitted         = L=8, R=2, Z=6, A=9, O=5, Í=4, B=3, T=0, V=7, V=7, T=0, B=3, Í=4, O=5, A=9, Z=6, R=2, L=8, I=1.
Solution       got            = 352+746=1098

Solution       #              = 68
Solution       fitted         = L=8, R=2, Z=6, A=9, O=5, Í=4, B=7, T=0, V=3, V=3, T=0, B=7, Í=4, O=5, A=9, Z=6, R=2, L=8, I=1.
Solution       got            = 752+346=1098

Solution       #              = 69
Solution       fitted         = L=8, R=3, Z=5, A=9, O=2, Í=7, B=4, T=0, V=6, V=6, T=0, B=4, Í=7, O=2, A=9, Z=5, R=3, L=8, I=1.
Solution       got            = 423+675=1098

Solution       #              = 70
Solution       fitted         = L=8, R=3, Z=5, A=9, O=2, Í=7, B=6, T=0, V=4, V=4, T=0, B=6, Í=7, O=2, A=9, Z=5, R=3, L=8, I=1.
Solution       got            = 623+475=1098

Solution       #              = 71
Solution       fitted         = L=8, R=3, Z=5, A=9, O=7, Í=2, B=4, T=0, V=6, V=6, T=0, B=4, Í=2, O=7, A=9, Z=5, R=3, L=8, I=1.
Solution       got            = 473+625=1098

Solution       #              = 72
Solution       fitted         = L=8, R=3, Z=5, A=9, O=7, Í=2, B=6, T=0, V=4, V=4, T=0, B=6, Í=2, O=7, A=9, Z=5, R=3, L=8, I=1.
Solution       got            = 673+425=1098

Solution       #              = 73
Solution       fitted         = L=8, R=5, Z=3, A=9, O=2, Í=7, B=4, T=0, V=6, V=6, T=0, B=4, Í=7, O=2, A=9, Z=3, R=5, L=8, I=1.
Solution       got            = 425+673=1098

Solution       #              = 74
Solution       fitted         = L=8, R=5, Z=3, A=9, O=2, Í=7, B=6, T=0, V=4, V=4, T=0, B=6, Í=7, O=2, A=9, Z=3, R=5, L=8, I=1.
Solution       got            = 625+473=1098

Solution       #              = 75
Solution       fitted         = L=8, R=5, Z=3, A=9, O=7, Í=2, B=4, T=0, V=6, V=6, T=0, B=4, Í=2, O=7, A=9, Z=3, R=5, L=8, I=1.
Solution       got            = 475+623=1098

Solution       #              = 76
Solution       fitted         = L=8, R=5, Z=3, A=9, O=7, Í=2, B=6, T=0, V=4, V=4, T=0, B=6, Í=2, O=7, A=9, Z=3, R=5, L=8, I=1.
Solution       got            = 675+423=1098

Solution       #              = 77
Solution       fitted         = L=8, R=6, Z=2, A=9, O=4, Í=5, B=3, T=0, V=7, V=7, T=0, B=3, Í=5, O=4, A=9, Z=2, R=6, L=8, I=1.
Solution       got            = 346+752=1098

Solution       #              = 78
Solution       fitted         = L=8, R=6, Z=2, A=9, O=4, Í=5, B=7, T=0, V=3, V=3, T=0, B=7, Í=5, O=4, A=9, Z=2, R=6, L=8, I=1.
Solution       got            = 746+352=1098

Solution       #              = 79
Solution       fitted         = L=8, R=6, Z=2, A=9, O=5, Í=4, B=3, T=0, V=7, V=7, T=0, B=3, Í=4, O=5, A=9, Z=2, R=6, L=8, I=1.
Solution       got            = 356+742=1098

Solution       #              = 80
Solution       fitted         = L=8, R=6, Z=2, A=9, O=5, Í=4, B=7, T=0, V=3, V=3, T=0, B=7, Í=4, O=5, A=9, Z=2, R=6, L=8, I=1.
Solution       got            = 756+342=1098

Solution       #              = 81
Solution       fitted         = L=9, R=2, Z=7, A=8, O=3, Í=5, B=4, T=0, V=6, V=6, T=0, B=4, Í=5, O=3, A=8, Z=7, R=2, L=9, I=1.
Solution       got            = 432+657=1089

Solution       #              = 82
Solution       fitted         = L=9, R=2, Z=7, A=8, O=3, Í=5, B=6, T=0, V=4, V=4, T=0, B=6, Í=5, O=3, A=8, Z=7, R=2, L=9, I=1.
Solution       got            = 632+457=1089

Solution       #              = 83
Solution       fitted         = L=9, R=2, Z=7, A=8, O=5, Í=3, B=4, T=0, V=6, V=6, T=0, B=4, Í=3, O=5, A=8, Z=7, R=2, L=9, I=1.
Solution       got            = 452+637=1089

Solution       #              = 84
Solution       fitted         = L=9, R=2, Z=7, A=8, O=5, Í=3, B=6, T=0, V=4, V=4, T=0, B=6, Í=3, O=5, A=8, Z=7, R=2, L=9, I=1.
Solution       got            = 652+437=1089

Solution       #              = 85
Solution       fitted         = L=9, R=4, Z=5, A=8, O=2, Í=6, B=3, T=0, V=7, V=7, T=0, B=3, Í=6, O=2, A=8, Z=5, R=4, L=9, I=1.
Solution       got            = 324+765=1089

Solution       #              = 86
Solution       fitted         = L=9, R=4, Z=5, A=8, O=2, Í=6, B=7, T=0, V=3, V=3, T=0, B=7, Í=6, O=2, A=8, Z=5, R=4, L=9, I=1.
Solution       got            = 724+365=1089

Solution       #              = 87
Solution       fitted         = L=9, R=4, Z=5, A=8, O=6, Í=2, B=3, T=0, V=7, V=7, T=0, B=3, Í=2, O=6, A=8, Z=5, R=4, L=9, I=1.
Solution       got            = 364+725=1089

Solution       #              = 88
Solution       fitted         = L=9, R=4, Z=5, A=8, O=6, Í=2, B=7, T=0, V=3, V=3, T=0, B=7, Í=2, O=6, A=8, Z=5, R=4, L=9, I=1.
Solution       got            = 764+325=1089

Solution       #              = 89
Solution       fitted         = L=9, R=5, Z=4, A=8, O=2, Í=6, B=3, T=0, V=7, V=7, T=0, B=3, Í=6, O=2, A=8, Z=4, R=5, L=9, I=1.
Solution       got            = 325+764=1089

Solution       #              = 90
Solution       fitted         = L=9, R=5, Z=4, A=8, O=2, Í=6, B=7, T=0, V=3, V=3, T=0, B=7, Í=6, O=2, A=8, Z=4, R=5, L=9, I=1.
Solution       got            = 725+364=1089

Solution       #              = 91
Solution       fitted         = L=9, R=5, Z=4, A=8, O=6, Í=2, B=3, T=0, V=7, V=7, T=0, B=3, Í=2, O=6, A=8, Z=4, R=5, L=9, I=1.
Solution       got            = 365+724=1089

Solution       #              = 92
Solution       fitted         = L=9, R=5, Z=4, A=8, O=6, Í=2, B=7, T=0, V=3, V=3, T=0, B=7, Í=2, O=6, A=8, Z=4, R=5, L=9, I=1.
Solution       got            = 765+324=1089

Solution       #              = 93
Solution       fitted         = L=9, R=7, Z=2, A=8, O=3, Í=5, B=4, T=0, V=6, V=6, T=0, B=4, Í=5, O=3, A=8, Z=2, R=7, L=9, I=1.
Solution       got            = 437+652=1089

Solution       #              = 94
Solution       fitted         = L=9, R=7, Z=2, A=8, O=3, Í=5, B=6, T=0, V=4, V=4, T=0, B=6, Í=5, O=3, A=8, Z=2, R=7, L=9, I=1.
Solution       got            = 637+452=1089

Solution       #              = 95
Solution       fitted         = L=9, R=7, Z=2, A=8, O=5, Í=3, B=4, T=0, V=6, V=6, T=0, B=4, Í=3, O=5, A=8, Z=2, R=7, L=9, I=1.
Solution       got            = 457+632=1089

Solution       #              = 96
Solution       fitted         = L=9, R=7, Z=2, A=8, O=5, Í=3, B=6, T=0, V=4, V=4, T=0, B=6, Í=3, O=5, A=8, Z=2, R=7, L=9, I=1.
Solution       got            = 657+432=1089

End of fit lists and results.

Condensed      puzzle         = EGER+BAJA=VÁROS

Simplified     puzzle         = BAJA+EGER=VÁROS

Tried          fits           = 169
Matching       fits found     = 9

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = R=3, A=2, S=5, E=8, J=6, O=4, G=0, B=9, Á=7, Á=7, B=9, G=0, O=4, J=6, E=8, S=5, A=2, R=3, V=1.
Solution       got            = 9262+8083=17345

Solution       #              = 2
Solution       fitted         = R=3, A=2, S=5, E=8, J=9, O=7, G=0, B=6, Á=4, Á=4, B=6, G=0, O=7, J=9, E=8, S=5, A=2, R=3, V=1.
Solution       got            = 6292+8083=14375

Solution       #              = 3
Solution       fitted         = R=3, A=9, S=2, E=6, J=0, O=7, G=4, B=8, Á=5, Á=5, B=8, G=4, O=7, J=0, E=6, S=2, A=9, R=3, V=1.
Solution       got            = 8909+6463=15372

Solution       #              = 4
Solution       fitted         = R=4, A=5, S=9, E=7, J=6, O=3, G=8, B=2, Á=0, Á=0, B=2, G=8, O=3, J=6, E=7, S=9, A=5, R=4, V=1.
Solution       got            = 2565+7874=10439

Solution       #              = 5
Solution       fitted         = R=6, A=7, S=3, E=5, J=2, O=8, G=9, B=4, Á=0, Á=0, B=4, G=9, O=8, J=2, E=5, S=3, A=7, R=6, V=1.
Solution       got            = 4727+5956=10683

Solution       #              = 6
Solution       fitted         = R=6, A=9, S=5, E=3, J=0, O=4, G=7, B=8, Á=2, Á=2, B=8, G=7, O=4, J=0, E=3, S=5, A=9, R=6, V=1.
Solution       got            = 8909+3736=12645

Solution       #              = 7
Solution       fitted         = R=8, A=6, S=4, E=3, J=5, O=9, G=2, B=7, Á=0, Á=0, B=7, G=2, O=9, J=5, E=3, S=4, A=6, R=8, V=1.
Solution       got            = 7656+3238=10894

Solution       #              = 8
Solution       fitted         = R=9, A=5, S=4, E=8, J=7, O=6, G=3, B=2, Á=0, Á=0, B=2, G=3, O=6, J=7, E=8, S=4, A=5, R=9, V=1.
Solution       got            = 2575+8389=10964

Solution       #              = 9
Solution       fitted         = R=9, A=6, S=5, E=2, J=4, O=7, G=3, B=8, Á=0, Á=0, B=8, G=3, O=7, J=4, E=2, S=5, A=6, R=9, V=1.
Solution       got            = 8646+2329=10975

End of fit lists and results.

Condensed      puzzle         = KLÓR+BRÓM+JÓD=MARÓ

Simplified     puzzle         = BRÓM+KLÓR+JÓD=MARÓ

Tried          fits           = 37888
Matching       fits found     = 120

Start of fit lists and results:

Solution       #              = 1
Solution       fitted         = M=4, Ó=3, D=9, R=0, J=6, A=5, L=8, B=1, K=2, K=2, B=1, L=8, A=5, J=6, R=0, D=9, Ó=3, M=4.
Solution       got            = 1034+2830+639=4503

Solution       #              = 2
Solution       fitted         = M=4, Ó=3, D=9, R=0, J=6, A=5, L=8, B=2, K=1, K=1, B=2, L=8, A=5, J=6, R=0, D=9, Ó=3, M=4.
Solution       got            = 2034+1830+639=4503

Solution       #              = 3
Solution       fitted         = M=4, Ó=3, D=9, R=0, J=7, A=6, L=8, B=1, K=2, K=2, B=1, L=8, A=6, J=7, R=0, D=9, Ó=3, M=4.
Solution       got            = 1034+2830+739=4603

Solution       #              = 4
Solution       fitted         = M=4, Ó=3, D=9, R=0, J=7, A=6, L=8, B=2, K=1, K=1, B=2, L=8, A=6, J=7, R=0, D=9, Ó=3, M=4.
Solution       got            = 2034+1830+739=4603

Solution       #              = 5
Solution       fitted         = M=4, Ó=3, D=9, R=0, J=8, A=5, L=6, B=1, K=2, K=2, B=1, L=6, A=5, J=8, R=0, D=9, Ó=3, M=4.
Solution       got            = 1034+2630+839=4503

Solution       #              = 6
Solution       fitted         = M=4, Ó=3, D=9, R=0, J=8, A=5, L=6, B=2, K=1, K=1, B=2, L=6, A=5, J=8, R=0, D=9, Ó=3, M=4.
Solution       got            = 2034+1630+839=4503

Solution       #              = 7
Solution       fitted         = M=4, Ó=3, D=9, R=0, J=8, A=6, L=7, B=1, K=2, K=2, B=1, L=7, A=6, J=8, R=0, D=9, Ó=3, M=4.
Solution       got            = 1034+2730+839=4603

Solution       #              = 8
Solution       fitted         = M=4, Ó=3, D=9, R=0, J=8, A=6, L=7, B=2, K=1, K=1, B=2, L=7, A=6, J=8, R=0, D=9, Ó=3, M=4.
Solution       got            = 2034+1730+839=4603

Solution       #              = 9
Solution       fitted         = M=4, Ó=8, D=9, R=5, J=6, A=3, L=0, B=1, K=2, K=2, B=1, L=0, A=3, J=6, R=5, D=9, Ó=8, M=4.
Solution       got            = 1584+2085+689=4358

Solution       #              = 10
Solution       fitted         = M=4, Ó=8, D=9, R=5, J=6, A=3, L=0, B=2, K=1, K=1, B=2, L=0, A=3, J=6, R=5, D=9, Ó=8, M=4.
Solution       got            = 2584+1085+689=4358

Solution       #              = 11
Solution       fitted         = M=5, Ó=2, D=0, R=7, J=4, A=9, L=8, B=1, K=3, K=3, B=1, L=8, A=9, J=4, R=7, D=0, Ó=2, M=5.
Solution       got            = 1725+3827+420=5972

Solution       #              = 12
Solution       fitted         = M=5, Ó=2, D=0, R=7, J=4, A=9, L=8, B=3, K=1, K=1, B=3, L=8, A=9, J=4, R=7, D=0, Ó=2, M=5.
Solution       got            = 3725+1827+420=5972

Solution       #              = 13
Solution       fitted         = M=5, Ó=2, D=0, R=7, J=8, A=9, L=4, B=1, K=3, K=3, B=1, L=4, A=9, J=8, R=7, D=0, Ó=2, M=5.
Solution       got            = 1725+3427+820=5972

Solution       #              = 14
Solution       fitted         = M=5, Ó=2, D=0, R=7, J=8, A=9, L=4, B=3, K=1, K=1, B=3, L=4, A=9, J=8, R=7, D=0, Ó=2, M=5.
Solution       got            = 3725+1427+820=5972

Solution       #              = 15
Solution       fitted         = M=5, Ó=2, D=9, R=8, J=6, A=4, L=0, B=1, K=3, K=3, B=1, L=0, A=4, J=6, R=8, D=9, Ó=2, M=5.
Solution       got            = 1825+3028+629=5482

Solution       #              = 16
Solution       fitted         = M=5, Ó=2, D=9, R=8, J=6, A=4, L=0, B=3, K=1, K=1, B=3, L=0, A=4, J=6, R=8, D=9, Ó=2, M=5.
Solution       got            = 3825+1028+629=5482

Solution       #              = 17
Solution       fitted         = M=5, Ó=3, D=8, R=0, J=2, A=9, L=6, B=1, K=4, K=4, B=1, L=6, A=9, J=2, R=0, D=8, Ó=3, M=5.
Solution       got            = 1035+4630+238=5903

Solution       #              = 18
Solution       fitted         = M=5, Ó=3, D=8, R=0, J=2, A=9, L=6, B=4, K=1, K=1, B=4, L=6, A=9, J=2, R=0, D=8, Ó=3, M=5.
Solution       got            = 4035+1630+238=5903

Solution       #              = 19
Solution       fitted         = M=5, Ó=3, D=8, R=0, J=6, A=9, L=2, B=1, K=4, K=4, B=1, L=2, A=9, J=6, R=0, D=8, Ó=3, M=5.
Solution       got            = 1035+4230+638=5903

Solution       #              = 20
Solution       fitted         = M=5, Ó=3, D=8, R=0, J=6, A=9, L=2, B=4, K=1, K=1, B=4, L=2, A=9, J=6, R=0, D=8, Ó=3, M=5.
Solution       got            = 4035+1230+638=5903

Solution       #              = 21
Solution       fitted         = M=5, Ó=4, D=6, R=3, J=7, A=0, L=9, B=1, K=2, K=2, B=1, L=9, A=0, J=7, R=3, D=6, Ó=4, M=5.
Solution       got            = 1345+2943+746=5034

Solution       #              = 22
Solution       fitted         = M=5, Ó=4, D=6, R=3, J=7, A=0, L=9, B=2, K=1, K=1, B=2, L=9, A=0, J=7, R=3, D=6, Ó=4, M=5.
Solution       got            = 2345+1943+746=5034

Solution       #              = 23
Solution       fitted         = M=5, Ó=4, D=6, R=3, J=9, A=0, L=7, B=1, K=2, K=2, B=1, L=7, A=0, J=9, R=3, D=6, Ó=4, M=5.
Solution       got            = 1345+2743+946=5034

Solution       #              = 24
Solution       fitted         = M=5, Ó=4, D=6, R=3, J=9, A=0, L=7, B=2, K=1, K=1, B=2, L=7, A=0, J=9, R=3, D=6, Ó=4, M=5.
Solution       got            = 2345+1743+946=5034

Solution       #              = 25
Solution       fitted         = M=5, Ó=9, D=6, R=8, J=3, A=0, L=7, B=1, K=2, K=2, B=1, L=7, A=0, J=3, R=8, D=6, Ó=9, M=5.
Solution       got            = 1895+2798+396=5089

Solution       #              = 26
Solution       fitted         = M=5, Ó=9, D=6, R=8, J=3, A=0, L=7, B=2, K=1, K=1, B=2, L=7, A=0, J=3, R=8, D=6, Ó=9, M=5.
Solution       got            = 2895+1798+396=5089

Solution       #              = 27
Solution       fitted         = M=5, Ó=9, D=6, R=8, J=7, A=0, L=3, B=1, K=2, K=2, B=1, L=3, A=0, J=7, R=8, D=6, Ó=9, M=5.
Solution       got            = 1895+2398+796=5089

Solution       #              = 28
Solution       fitted         = M=5, Ó=9, D=6, R=8, J=7, A=0, L=3, B=2, K=1, K=1, B=2, L=3, A=0, J=7, R=8, D=6, Ó=9, M=5.
Solution       got            = 2895+1398+796=5089

Solution       #              = 29
Solution       fitted         = M=6, Ó=7, D=0, R=1, J=4, A=5, L=8, B=2, K=3, K=3, B=2, L=8, A=5, J=4, R=1, D=0, Ó=7, M=6.
Solution       got            = 2176+3871+470=6517

Solution       #              = 30
Solution       fitted         = M=6, Ó=7, D=0, R=1, J=4, A=5, L=8, B=3, K=2, K=2, B=3, L=8, A=5, J=4, R=1, D=0, Ó=7, M=6.
Solution       got            = 3176+2871+470=6517

Solution       #              = 31
Solution       fitted         = M=6, Ó=7, D=0, R=1, J=8, A=5, L=4, B=2, K=3, K=3, B=2, L=4, A=5, J=8, R=1, D=0, Ó=7, M=6.
Solution       got            = 2176+3471+870=6517

Solution       #              = 32
Solution       fitted         = M=6, Ó=7, D=0, R=1, J=8, A=5, L=4, B=3, K=2, K=2, B=3, L=4, A=5, J=8, R=1, D=0, Ó=7, M=6.
Solution       got            = 3176+2471+870=6517

Solution       #              = 33
Solution       fitted         = M=6, Ó=7, D=9, R=2, J=3, A=5, L=8, B=1, K=4, K=4, B=1, L=8, A=5, J=3, R=2, D=9, Ó=7, M=6.
Solution       got            = 1276+4872+379=6527

Solution       #              = 34
Solution       fitted         = M=6, Ó=7, D=9, R=2, J=3, A=5, L=8, B=4, K=1, K=1, B=4, L=8, A=5, J=3, R=2, D=9, Ó=7, M=6.
Solution       got            = 4276+1872+379=6527

Solution       #              = 35
Solution       fitted         = M=6, Ó=7, D=9, R=2, J=4, A=8, L=0, B=1, K=5, K=5, B=1, L=0, A=8, J=4, R=2, D=9, Ó=7, M=6.
Solution       got            = 1276+5072+479=6827

Solution       #              = 36
Solution       fitted         = M=6, Ó=7, D=9, R=2, J=4, A=8, L=0, B=5, K=1, K=1, B=5, L=0, A=8, J=4, R=2, D=9, Ó=7, M=6.
Solution       got            = 5276+1072+479=6827

Solution       #              = 37
Solution       fitted         = M=6, Ó=7, D=9, R=2, J=8, A=5, L=3, B=1, K=4, K=4, B=1, L=3, A=5, J=8, R=2, D=9, Ó=7, M=6.
Solution       got            = 1276+4372+879=6527

Solution       #              = 38
Solution       fitted         = M=6, Ó=7, D=9, R=2, J=8, A=5, L=3, B=4, K=1, K=1, B=4, L=3, A=5, J=8, R=2, D=9, Ó=7, M=6.
Solution       got            = 4276+1372+879=6527

Solution       #              = 39
Solution       fitted         = M=6, Ó=8, D=7, R=5, J=4, A=0, L=9, B=1, K=3, K=3, B=1, L=9, A=0, J=4, R=5, D=7, Ó=8, M=6.
Solution       got            = 1586+3985+487=6058

Solution       #              = 40
Solution       fitted         = M=6, Ó=8, D=7, R=5, J=4, A=0, L=9, B=3, K=1, K=1, B=3, L=9, A=0, J=4, R=5, D=7, Ó=8, M=6.
Solution       got            = 3586+1985+487=6058

Solution       #              = 41
Solution       fitted         = M=6, Ó=8, D=7, R=5, J=4, A=1, L=0, B=2, K=3, K=3, B=2, L=0, A=1, J=4, R=5, D=7, Ó=8, M=6.
Solution       got            = 2586+3085+487=6158

Solution       #              = 42
Solution       fitted         = M=6, Ó=8, D=7, R=5, J=4, A=1, L=0, B=3, K=2, K=2, B=3, L=0, A=1, J=4, R=5, D=7, Ó=8, M=6.
Solution       got            = 3586+2085+487=6158

Solution       #              = 43
Solution       fitted         = M=6, Ó=8, D=7, R=5, J=9, A=0, L=4, B=1, K=3, K=3, B=1, L=4, A=0, J=9, R=5, D=7, Ó=8, M=6.
Solution       got            = 1586+3485+987=6058

Solution       #              = 44
Solution       fitted         = M=6, Ó=8, D=7, R=5, J=9, A=0, L=4, B=3, K=1, K=1, B=3, L=4, A=0, J=9, R=5, D=7, Ó=8, M=6.
Solution       got            = 3586+1485+987=6058

Solution       #              = 45
Solution       fitted         = M=7, Ó=1, D=9, R=5, J=3, A=6, L=8, B=2, K=4, K=4, B=2, L=8, A=6, J=3, R=5, D=9, Ó=1, M=7.
Solution       got            = 2517+4815+319=7651

Solution       #              = 46
Solution       fitted         = M=7, Ó=1, D=9, R=5, J=3, A=6, L=8, B=4, K=2, K=2, B=4, L=8, A=6, J=3, R=5, D=9, Ó=1, M=7.
Solution       got            = 4517+2815+319=7651

Solution       #              = 47
Solution       fitted         = M=7, Ó=1, D=9, R=5, J=8, A=3, L=0, B=2, K=4, K=4, B=2, L=0, A=3, J=8, R=5, D=9, Ó=1, M=7.
Solution       got            = 2517+4015+819=7351

Solution       #              = 48
Solution       fitted         = M=7, Ó=1, D=9, R=5, J=8, A=3, L=0, B=4, K=2, K=2, B=4, L=0, A=3, J=8, R=5, D=9, Ó=1, M=7.
Solution       got            = 4517+2015+819=7351

Solution       #              = 49
Solution       fitted         = M=7, Ó=1, D=9, R=5, J=8, A=6, L=3, B=2, K=4, K=4, B=2, L=3, A=6, J=8, R=5, D=9, Ó=1, M=7.
Solution       got            = 2517+4315+819=7651

Solution       #              = 50
Solution       fitted         = M=7, Ó=1, D=9, R=5, J=8, A=6, L=3, B=4, K=2, K=2, B=4, L=3, A=6, J=8, R=5, D=9, Ó=1, M=7.
Solution       got            = 4517+2315+819=7651

Solution       #              = 51
Solution       fitted         = M=7, Ó=5, D=2, R=6, J=1, A=8, L=0, B=3, K=4, K=4, B=3, L=0, A=8, J=1, R=6, D=2, Ó=5, M=7.
Solution       got            = 3657+4056+152=7865

Solution       #              = 52
Solution       fitted         = M=7, Ó=5, D=2, R=6, J=1, A=8, L=0, B=4, K=3, K=3, B=4, L=0, A=8, J=1, R=6, D=2, Ó=5, M=7.
Solution       got            = 4657+3056+152=7865

Solution       #              = 53
Solution       fitted         = M=7, Ó=6, D=0, R=9, J=3, A=8, L=5, B=2, K=4, K=4, B=2, L=5, A=8, J=3, R=9, D=0, Ó=6, M=7.
Solution       got            = 2967+4569+360=7896

Solution       #              = 54
Solution       fitted         = M=7, Ó=6, D=0, R=9, J=3, A=8, L=5, B=4, K=2, K=2, B=4, L=5, A=8, J=3, R=9, D=0, Ó=6, M=7.
Solution       got            = 4967+2569+360=7896

Solution       #              = 55
Solution       fitted         = M=7, Ó=6, D=0, R=9, J=5, A=3, L=8, B=1, K=4, K=4, B=1, L=8, A=3, J=5, R=9, D=0, Ó=6, M=7.
Solution       got            = 1967+4869+560=7396

Solution       #              = 56
Solution       fitted         = M=7, Ó=6, D=0, R=9, J=5, A=3, L=8, B=4, K=1, K=1, B=4, L=8, A=3, J=5, R=9, D=0, Ó=6, M=7.
Solution       got            = 4967+1869+560=7396

Solution       #              = 57
Solution       fitted         = M=7, Ó=6, D=0, R=9, J=5, A=8, L=3, B=2, K=4, K=4, B=2, L=3, A=8, J=5, R=9, D=0, Ó=6, M=7.
Solution       got            = 2967+4369+560=7896

Solution       #              = 58
Solution       fitted         = M=7, Ó=6, D=0, R=9, J=5, A=8, L=3, B=4, K=2, K=2, B=4, L=3, A=8, J=5, R=9, D=0, Ó=6, M=7.
Solution       got            = 4967+2369+560=7896

Solution       #              = 59
Solution       fitted         = M=7, Ó=6, D=0, R=9, J=8, A=3, L=5, B=1, K=4, K=4, B=1, L=5, A=3, J=8, R=9, D=0, Ó=6, M=7.
Solution       got            = 1967+4569+860=7396

Solution       #              = 60
Solution       fitted         = M=7, Ó=6, D=0, R=9, J=8, A=3, L=5, B=4, K=1, K=1, B=4, L=5, A=3, J=8, R=9, D=0, Ó=6, M=7.
Solution       got            = 4967+1569+860=7396

Solution       #              = 61
Solution       fitted         = M=7, Ó=8, D=6, R=5, J=2, A=9, L=0, B=3, K=4, K=4, B=3, L=0, A=9, J=2, R=5, D=6, Ó=8, M=7.
Solution       got            = 3587+4085+286=7958

Solution       #              = 62
Solution       fitted         = M=7, Ó=8, D=6, R=5, J=2, A=9, L=0, B=4, K=3, K=3, B=4, L=0, A=9, J=2, R=5, D=6, Ó=8, M=7.
Solution       got            = 4587+3085+286=7958

Solution       #              = 63
Solution       fitted         = M=7, Ó=8, D=6, R=5, J=4, A=0, L=9, B=2, K=3, K=3, B=2, L=9, A=0, J=4, R=5, D=6, Ó=8, M=7.
Solution       got            = 2587+3985+486=7058

Solution       #              = 64
Solution       fitted         = M=7, Ó=8, D=6, R=5, J=4, A=0, L=9, B=3, K=2, K=2, B=3, L=9, A=0, J=4, R=5, D=6, Ó=8, M=7.
Solution       got            = 3587+2985+486=7058

Solution       #              = 65
Solution       fitted         = M=7, Ó=8, D=6, R=5, J=9, A=0, L=4, B=2, K=3, K=3, B=2, L=4, A=0, J=9, R=5, D=6, Ó=8, M=7.
Solution       got            = 2587+3485+986=7058

Solution       #              = 66
Solution       fitted         = M=7, Ó=8, D=6, R=5, J=9, A=0, L=4, B=3, K=2, K=2, B=3, L=4, A=0, J=9, R=5, D=6, Ó=8, M=7.
Solution       got            = 3587+2485+986=7058

Solution       #              = 67
Solution       fitted         = M=7, Ó=9, D=4, R=8, J=5, A=1, L=6, B=2, K=3, K=3, B=2, L=6, A=1, J=5, R=8, D=4, Ó=9, M=7.
Solution       got            = 2897+3698+594=7189

Solution       #              = 68
Solution       fitted         = M=7, Ó=9, D=4, R=8, J=5, A=1, L=6, B=3, K=2, K=2, B=3, L=6, A=1, J=5, R=8, D=4, Ó=9, M=7.
Solution       got            = 3897+2698+594=7189

Solution       #              = 69
Solution       fitted         = M=7, Ó=9, D=4, R=8, J=6, A=1, L=5, B=2, K=3, K=3, B=2, L=5, A=1, J=6, R=8, D=4, Ó=9, M=7.
Solution       got            = 2897+3598+694=7189

Solution       #              = 70
Solution       fitted         = M=7, Ó=9, D=4, R=8, J=6, A=1, L=5, B=3, K=2, K=2, B=3, L=5, A=1, J=6, R=8, D=4, Ó=9, M=7.
Solution       got            = 3897+2598+694=7189

Solution       #              = 71
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=1, A=9, L=7, B=2, K=6, K=6, B=2, L=7, A=9, J=1, R=0, D=5, Ó=3, M=8.
Solution       got            = 2038+6730+135=8903

Solution       #              = 72
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=1, A=9, L=7, B=6, K=2, K=2, B=6, L=7, A=9, J=1, R=0, D=5, Ó=3, M=8.
Solution       got            = 6038+2730+135=8903

Solution       #              = 73
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=2, A=9, L=6, B=1, K=7, K=7, B=1, L=6, A=9, J=2, R=0, D=5, Ó=3, M=8.
Solution       got            = 1038+7630+235=8903

Solution       #              = 74
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=2, A=9, L=6, B=7, K=1, K=1, B=7, L=6, A=9, J=2, R=0, D=5, Ó=3, M=8.
Solution       got            = 7038+1630+235=8903

Solution       #              = 75
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=4, A=2, L=7, B=1, K=6, K=6, B=1, L=7, A=2, J=4, R=0, D=5, Ó=3, M=8.
Solution       got            = 1038+6730+435=8203

Solution       #              = 76
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=4, A=2, L=7, B=6, K=1, K=1, B=6, L=7, A=2, J=4, R=0, D=5, Ó=3, M=8.
Solution       got            = 6038+1730+435=8203

Solution       #              = 77
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=6, A=9, L=2, B=1, K=7, K=7, B=1, L=2, A=9, J=6, R=0, D=5, Ó=3, M=8.
Solution       got            = 1038+7230+635=8903

Solution       #              = 78
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=6, A=9, L=2, B=7, K=1, K=1, B=7, L=2, A=9, J=6, R=0, D=5, Ó=3, M=8.
Solution       got            = 7038+1230+635=8903

Solution       #              = 79
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=7, A=2, L=4, B=1, K=6, K=6, B=1, L=4, A=2, J=7, R=0, D=5, Ó=3, M=8.
Solution       got            = 1038+6430+735=8203

Solution       #              = 80
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=7, A=2, L=4, B=6, K=1, K=1, B=6, L=4, A=2, J=7, R=0, D=5, Ó=3, M=8.
Solution       got            = 6038+1430+735=8203

Solution       #              = 81
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=7, A=9, L=1, B=2, K=6, K=6, B=2, L=1, A=9, J=7, R=0, D=5, Ó=3, M=8.
Solution       got            = 2038+6130+735=8903

Solution       #              = 82
Solution       fitted         = M=8, Ó=3, D=5, R=0, J=7, A=9, L=1, B=6, K=2, K=2, B=6, L=1, A=9, J=7, R=0, D=5, Ó=3, M=8.
Solution       got            = 6038+2130+735=8903

Solution       #              = 83
Solution       fitted         = M=8, Ó=5, D=1, R=6, J=7, A=3, L=9, B=2, K=4, K=4, B=2, L=9, A=3, J=7, R=6, D=1, Ó=5, M=8.
Solution       got            = 2658+4956+751=8365

Solution       #              = 84
Solution       fitted         = M=8, Ó=5, D=1, R=6, J=7, A=3, L=9, B=4, K=2, K=2, B=4, L=9, A=3, J=7, R=6, D=1, Ó=5, M=8.
Solution       got            = 4658+2956+751=8365

Solution       #              = 85
Solution       fitted         = M=8, Ó=5, D=1, R=6, J=9, A=3, L=7, B=2, K=4, K=4, B=2, L=7, A=3, J=9, R=6, D=1, Ó=5, M=8.
Solution       got            = 2658+4756+951=8365

Solution       #              = 86
Solution       fitted         = M=8, Ó=5, D=1, R=6, J=9, A=3, L=7, B=4, K=2, K=2, B=4, L=7, A=3, J=9, R=6, D=1, Ó=5, M=8.
Solution       got            = 4658+2756+951=8365

Solution       #              = 87
Solution       fitted         = M=9, Ó=1, D=7, R=5, J=8, A=3, L=0, B=2, K=6, K=6, B=2, L=0, A=3, J=8, R=5, D=7, Ó=1, M=9.
Solution       got            = 2519+6015+817=9351

Solution       #              = 88
Solution       fitted         = M=9, Ó=1, D=7, R=5, J=8, A=3, L=0, B=6, K=2, K=2, B=6, L=0, A=3, J=8, R=5, D=7, Ó=1, M=9.
Solution       got            = 6519+2015+817=9351

Solution       #              = 89
Solution       fitted         = M=9, Ó=2, D=5, R=8, J=6, A=1, L=7, B=3, K=4, K=4, B=3, L=7, A=1, J=6, R=8, D=5, Ó=2, M=9.
Solution       got            = 3829+4728+625=9182

Solution       #              = 90
Solution       fitted         = M=9, Ó=2, D=5, R=8, J=6, A=1, L=7, B=4, K=3, K=3, B=4, L=7, A=1, J=6, R=8, D=5, Ó=2, M=9.
Solution       got            = 4829+3728+625=9182

Solution       #              = 91
Solution       fitted         = M=9, Ó=2, D=5, R=8, J=6, A=4, L=0, B=1, K=7, K=7, B=1, L=0, A=4, J=6, R=8, D=5, Ó=2, M=9.
Solution       got            = 1829+7028+625=9482

Solution       #              = 92
Solution       fitted         = M=9, Ó=2, D=5, R=8, J=6, A=4, L=0, B=7, K=1, K=1, B=7, L=0, A=4, J=6, R=8, D=5, Ó=2, M=9.
Solution       got            = 7829+1028+625=9482

Solution       #              = 93
Solution       fitted         = M=9, Ó=2, D=5, R=8, J=7, A=1, L=6, B=3, K=4, K=4, B=3, L=6, A=1, J=7, R=8, D=5, Ó=2, M=9.
Solution       got            = 3829+4628+725=9182

Solution       #              = 94
Solution       fitted         = M=9, Ó=2, D=5, R=8, J=7, A=1, L=6, B=4, K=3, K=3, B=4, L=6, A=1, J=7, R=8, D=5, Ó=2, M=9.
Solution       got            = 4829+3628+725=9182

Solution       #              = 95
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=1, A=8, L=6, B=2, K=7, K=7, B=2, L=6, A=8, J=1, R=0, D=4, Ó=3, M=9.
Solution       got            = 2039+7630+134=9803

Solution       #              = 96
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=1, A=8, L=6, B=7, K=2, K=2, B=7, L=6, A=8, J=1, R=0, D=4, Ó=3, M=9.
Solution       got            = 7039+2630+134=9803

Solution       #              = 97
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=5, A=2, L=6, B=1, K=7, K=7, B=1, L=6, A=2, J=5, R=0, D=4, Ó=3, M=9.
Solution       got            = 1039+7630+534=9203

Solution       #              = 98
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=5, A=2, L=6, B=7, K=1, K=1, B=7, L=6, A=2, J=5, R=0, D=4, Ó=3, M=9.
Solution       got            = 7039+1630+534=9203

Solution       #              = 99
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=2, L=5, B=1, K=7, K=7, B=1, L=5, A=2, J=6, R=0, D=4, Ó=3, M=9.
Solution       got            = 1039+7530+634=9203

Solution       #              = 100
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=2, L=5, B=7, K=1, K=1, B=7, L=5, A=2, J=6, R=0, D=4, Ó=3, M=9.
Solution       got            = 7039+1530+634=9203

Solution       #              = 101
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=5, L=8, B=1, K=7, K=7, B=1, L=8, A=5, J=6, R=0, D=4, Ó=3, M=9.
Solution       got            = 1039+7830+634=9503

Solution       #              = 102
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=5, L=8, B=7, K=1, K=1, B=7, L=8, A=5, J=6, R=0, D=4, Ó=3, M=9.
Solution       got            = 7039+1830+634=9503

Solution       #              = 103
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=8, L=1, B=2, K=7, K=7, B=2, L=1, A=8, J=6, R=0, D=4, Ó=3, M=9.
Solution       got            = 2039+7130+634=9803

Solution       #              = 104
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=8, L=1, B=7, K=2, K=2, B=7, L=1, A=8, J=6, R=0, D=4, Ó=3, M=9.
Solution       got            = 7039+2130+634=9803

Solution       #              = 105
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=8, A=5, L=6, B=1, K=7, K=7, B=1, L=6, A=5, J=8, R=0, D=4, Ó=3, M=9.
Solution       got            = 1039+7630+834=9503

Solution       #              = 106
Solution       fitted         = M=9, Ó=3, D=4, R=0, J=8, A=5, L=6, B=7, K=1, K=1, B=7, L=6, A=5, J=8, R=0, D=4, Ó=3, M=9.
Solution       got            = 7039+1630+834=9503

Solution       #              = 107
Solution       fitted         = M=9, Ó=5, D=0, R=6, J=2, A=3, L=4, B=1, K=7, K=7, B=1, L=4, A=3, J=2, R=6, D=0, Ó=5, M=9.
Solution       got            = 1659+7456+250=9365

Solution       #              = 108
Solution       fitted         = M=9, Ó=5, D=0, R=6, J=2, A=3, L=4, B=7, K=1, K=1, B=7, L=4, A=3, J=2, R=6, D=0, Ó=5, M=9.
Solution       got            = 7659+1456+250=9365

Solution       #              = 109
Solution       fitted         = M=9, Ó=5, D=0, R=6, J=4, A=3, L=2, B=1, K=7, K=7, B=1, L=2, A=3, J=4, R=6, D=0, Ó=5, M=9.
Solution       got            = 1659+7256+450=9365

Solution       #              = 110
Solution       fitted         = M=9, Ó=5, D=0, R=6, J=4, A=3, L=2, B=7, K=1, K=1, B=7, L=2, A=3, J=4, R=6, D=0, Ó=5, M=9.
Solution       got            = 7659+1256+450=9365

Solution       #              = 111
Solution       fitted         = M=9, Ó=5, D=0, R=6, J=7, A=2, L=8, B=3, K=4, K=4, B=3, L=8, A=2, J=7, R=6, D=0, Ó=5, M=9.
Solution       got            = 3659+4856+750=9265

Solution       #              = 112
Solution       fitted         = M=9, Ó=5, D=0, R=6, J=7, A=2, L=8, B=4, K=3, K=3, B=4, L=8, A=2, J=7, R=6, D=0, Ó=5, M=9.
Solution       got            = 4659+3856+750=9265

Solution       #              = 113
Solution       fitted         = M=9, Ó=5, D=0, R=6, J=8, A=2, L=7, B=3, K=4, K=4, B=3, L=7, A=2, J=8, R=6, D=0, Ó=5, M=9.
Solution       got            = 3659+4756+850=9265

Solution       #              = 114
Solution       fitted         = M=9, Ó=5, D=0, R=6, J=8, A=2, L=7, B=4, K=3, K=3, B=4, L=7, A=2, J=8, R=6, D=0, Ó=5, M=9.
Solution       got            = 4659+3756+850=9265

Solution       #              = 115
Solution       fitted         = M=9, Ó=7, D=6, R=2, J=1, A=8, L=3, B=4, K=5, K=5, B=4, L=3, A=8, J=1, R=2, D=6, Ó=7, M=9.
Solution       got            = 4279+5372+176=9827

Solution       #              = 116
Solution       fitted         = M=9, Ó=7, D=6, R=2, J=1, A=8, L=3, B=5, K=4, K=4, B=5, L=3, A=8, J=1, R=2, D=6, Ó=7, M=9.
Solution       got            = 5279+4372+176=9827

Solution       #              = 117
Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=4, K=5, K=5, B=4, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.
Solution       got            = 4279+5172+376=9827

Solution       #              = 118
Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=5, K=4, K=4, B=5, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.
Solution       got            = 5279+4172+376=9827

Solution       #              = 119
Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=1, K=7, K=7, B=1, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.
Solution       got            = 1589+7085+684=9358

Solution       #              = 120
Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=7, K=1, K=1, B=7, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.
Solution       got            = 7589+1085+684=9358

End of fit lists and results.
2010. január 4. 8:58:45
Action         = closed         file »magyarok00.aps« in folder »D:\Feri\SOAP\Results\«.
=3, B=5, K=4, K=4, B=5, L=3, A=8, J=1, R=2, D=6, Ó=7, M=9.
Solution       got            = 5279+4372+176=9827

Solution       #              = 117
Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=4, K=5, K=5, B=4, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.
Solution       got            = 4279+5172+376=9827

Solution       #              = 118
Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=5, K=4, K=4, B=5, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.
Solution       got            = 5279+4172+376=9827

Solution       #              = 119
Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=1, K=7, K=7, B=1, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.
Solution       got            = 1589+7085+684=9358

Solution       #              = 120
Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=7, K=1, K=1, B=7, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.
Solution       got            = 7589+1085+684=9358

End of fit lists and results.
2010. január 4. 8:46:40
Action         = closed         file »magyarok00.aps« in folder »D:\Feri\SOAP\Results\«.


Solution of Hungarian Puzzles withTrack

This an example of sol ution file of Hungarian puzzles.

It contains

¨ no classification

¨ track

¨ first solution.

2010. január 4. 9:21:07

Action         = overwrite      unicode file »magyarok01.aps« in folder »D:\Feri\SOAP\Results\«.

Current        code is        = 'Í'

Intermediate   fit list       = Z=0, H=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'S'

Intermediate   fit list       = Í=2, Z=0, H=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'S'   = 1

right          partial value  = 1000

left           partial value  = 40

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = S=4, Í=2, Z=0, H=1.

Remaining      digits         = 5 and 6 and 7 and 8 and 9.

Current        code is        = 'Ú'

Intermediate   fit list       = T=5, S=4, Í=2, Z=0, H=1.

Remaining      digits         = 3 and 6 and 7 and 8 and 9.

Calculated     ratio          = 0

Calculated     modulus        = 0

Partial        fit            = T=5, S=4, Í=2, Z=0, H=1.

Partial        values         =                 1040 is equal to 1040.

Coefficient    of 'Ú'         =                    0 is less than 100.

Result of      predicate       = accepted("The final step could be shortened.")

Calculated     digit          = 0.

Remaining      digits         = 3, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Ú'

Intermediate   fit list       = T=6, S=4, Í=2, Z=0, H=1.

Remaining      digits         = 3 and 5 and 7 and 8 and 9.

Calculated     ratio          = 2

Calculated     modulus        = 0

Partial        fit            = T=6, S=4, Í=2, Z=0, H=1.

Partial        values         =                 1240 is greater than 1040.

Coefficient    of 'Ú'         =                    0 is less than 100.

Result of      predicate       = accepted("The final step could be shortened.")

Calculated     digit          = 2.

Remaining      digits         = 3, 5, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Ú'

Intermediate   fit list       = T=7, S=4, Í=2, Z=0, H=1.

Remaining      digits         = 3 and 5 and 6 and 8 and 9.

Calculated     ratio          = 4

Calculated     modulus        = 0

Partial        fit            = T=7, S=4, Í=2, Z=0, H=1.

Partial        values         =                 1440 is greater than 1040.

Coefficient    of 'Ú'         =                    0 is less than 100.

Result of      predicate       = accepted("The final step could be shortened.")

Calculated     digit          = 4.

Remaining      digits         = 3, 5, 6, 8, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Ú'

Intermediate   fit list       = T=8, S=4, Í=2, Z=0, H=1.

Remaining      digits         = 3 and 5 and 6 and 7 and 9.

Calculated     ratio          = 6

Calculated     modulus        = 0

Partial        fit            = T=8, S=4, Í=2, Z=0, H=1.

Partial        values         =                 1640 is greater than 1040.

Coefficient    of 'Ú'         =                    0 is less than 100.

Result of      predicate       = accepted("The final step could be shortened.")

Calculated     digit          = 6.

Remaining      digits         = 3, 5, 6, 7, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Tried          fit            = Í=2, S=4, T=8, Ú=6, Ú=6, T=8, S=4, Í=2, Z=0, H=1.

Results of     fit            = »2*820« related to     »1640«

Values of      fit            = 1640 is equal to       1640.

Condensed      puzzle         = 2*TÍZ=HÚSZ

Simplified     puzzle         = 2*TÍZ=HÚSZ

Condensed      puzzle         = 2*TÍZ=HÚSZ

Simplified     puzzle         = 2*TÍZ=HÚSZ

Tried          fits           = 1

Matching       fits found     = 1

Start of fit lists and results:

Solution       #              = 1

Solution       fitted         = Í=2, S=4, T=8, Ú=6, Ú=6, T=8, S=4, Í=2, Z=0, H=1.

Solution       got            = 2*820=1640

End of fit lists and results.

Current        code is        = 'Y'

Intermediate   fit list       = empty.

Remaining      digits         = 0 and 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Y'   = 0

left           partial value  = 0

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = 0.

Number of      elements       = 1

Current        code is        = 'Ö'

Intermediate   fit list       = Y=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'A'

Intermediate   fit list       = Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'G'

Intermediate   fit list       = A=2, Ö=1, Y=0.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'G'   = 1

left           partial value  = 10

right          partial value  = 20

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 2

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'G'

Intermediate   fit list       = A=3, Ö=1, Y=0.

Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'G'   = 1

left           partial value  = 10

right          partial value  = 30

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 3

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 4, 5, 6, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'E'

Intermediate   fit list       = G=2, A=3, Ö=1, Y=0.

Remaining      digits         = 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'H'

Intermediate   fit list       = E=4, G=2, A=3, Ö=1, Y=0.

Remaining      digits         = 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 30

left           partial value  = 430

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 5, 6, 7, 8, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=5, G=2, A=3, Ö=1, Y=0.

Remaining      digits         = 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 30

left           partial value  = 530

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 4, 6, 7, 8, 9.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=6, G=2, A=3, Ö=1, Y=0.

Remaining      digits         = 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 30

left           partial value  = 630

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 4, 5, 7, 8, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=7, G=2, A=3, Ö=1, Y=0.

Remaining      digits         = 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 30

left           partial value  = 730

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 4, 5, 6, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=8, G=2, A=3, Ö=1, Y=0.

Remaining      digits         = 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 30

left           partial value  = 830

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 4, 5, 6, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=9, G=2, A=3, Ö=1, Y=0.

Remaining      digits         = 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'H'   = 2

right          partial value  = 30

left           partial value  = 930

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 4, 5, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'G'

Intermediate   fit list       = A=4, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'G'   = 1

left           partial value  = 10

right          partial value  = 40

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 4

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 3, 5, 6, 7, 8, 9.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'E'

Intermediate   fit list       = G=3, A=4, Ö=1, Y=0.

Remaining      digits         = 2 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'H'

Intermediate   fit list       = E=2, G=3, A=4, Ö=1, Y=0.

Remaining      digits         = 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 40

left           partial value  = 240

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 5, 6, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=5, G=3, A=4, Ö=1, Y=0.

Remaining      digits         = 2 and 6 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 40

left           partial value  = 540

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 6, 7, 8, 9.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=6, G=3, A=4, Ö=1, Y=0.

Remaining      digits         = 2 and 5 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 40

left           partial value  = 640

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 5, 7, 8, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=7, G=3, A=4, Ö=1, Y=0.

Remaining      digits         = 2 and 5 and 6 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 40

left           partial value  = 740

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 5, 6, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=8, G=3, A=4, Ö=1, Y=0.

Remaining      digits         = 2 and 5 and 6 and 7 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 40

left           partial value  = 840

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 5, 6, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=9, G=3, A=4, Ö=1, Y=0.

Remaining      digits         = 2 and 5 and 6 and 7 and 8.

Rightmost      place of 'H'   = 2

right          partial value  = 40

left           partial value  = 940

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 5, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'G'

Intermediate   fit list       = A=5, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'G'   = 1

left           partial value  = 10

right          partial value  = 50

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 5

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'E'

Intermediate   fit list       = G=4, A=5, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 6 and 7 and 8 and 9.

Current        code is        = 'H'

Intermediate   fit list       = E=2, G=4, A=5, Ö=1, Y=0.

Remaining      digits         = 3 and 6 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 50

left           partial value  = 250

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 6, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=3, G=4, A=5, Ö=1, Y=0.

Remaining      digits         = 2 and 6 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 50

left           partial value  = 350

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 6, 7, 8, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=6, G=4, A=5, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 50

left           partial value  = 650

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 7, 8, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=7, G=4, A=5, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 6 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 50

left           partial value  = 750

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 6, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=8, G=4, A=5, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 6 and 7 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 50

left           partial value  = 850

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 6, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=9, G=4, A=5, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 6 and 7 and 8.

Rightmost      place of 'H'   = 2

right          partial value  = 50

left           partial value  = 950

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'G'

Intermediate   fit list       = A=6, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'G'   = 1

left           partial value  = 10

right          partial value  = 60

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 6

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'E'

Intermediate   fit list       = G=5, A=6, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

Current        code is        = 'H'

Intermediate   fit list       = E=2, G=5, A=6, Ö=1, Y=0.

Remaining      digits         = 3 and 4 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 60

left           partial value  = 260

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 4, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=3, G=5, A=6, Ö=1, Y=0.

Remaining      digits         = 2 and 4 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 60

left           partial value  = 360

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 4, 7, 8, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=4, G=5, A=6, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 7 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 60

left           partial value  = 460

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 7, 8, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=7, G=5, A=6, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 60

left           partial value  = 760

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 4, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=8, G=5, A=6, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 7 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 60

left           partial value  = 860

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 4, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=9, G=5, A=6, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 7 and 8.

Rightmost      place of 'H'   = 2

right          partial value  = 60

left           partial value  = 960

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 4, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'G'

Intermediate   fit list       = A=7, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'G'   = 1

left           partial value  = 10

right          partial value  = 70

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 7

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'E'

Intermediate   fit list       = G=6, A=7, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 8 and 9.

Current        code is        = 'H'

Intermediate   fit list       = E=2, G=6, A=7, Ö=1, Y=0.

Remaining      digits         = 3 and 4 and 5 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 70

left           partial value  = 270

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 4, 5, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=3, G=6, A=7, Ö=1, Y=0.

Remaining      digits         = 2 and 4 and 5 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 70

left           partial value  = 370

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 4, 5, 8, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=4, G=6, A=7, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 5 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 70

left           partial value  = 470

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 5, 8, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=5, G=6, A=7, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 8 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 70

left           partial value  = 570

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 8, 9.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=8, G=6, A=7, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 70

left           partial value  = 870

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 4, 5, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=9, G=6, A=7, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 8.

Rightmost      place of 'H'   = 2

right          partial value  = 70

left           partial value  = 970

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 4, 5, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'G'

Intermediate   fit list       = A=8, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'G'   = 1

left           partial value  = 10

right          partial value  = 80

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 8

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'E'

Intermediate   fit list       = G=7, A=8, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 9.

Current        code is        = 'H'

Intermediate   fit list       = E=2, G=7, A=8, Ö=1, Y=0.

Remaining      digits         = 3 and 4 and 5 and 6 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 80

left           partial value  = 280

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 4, 5, 6, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=3, G=7, A=8, Ö=1, Y=0.

Remaining      digits         = 2 and 4 and 5 and 6 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 80

left           partial value  = 380

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 4, 5, 6, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=4, G=7, A=8, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 5 and 6 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 80

left           partial value  = 480

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 5, 6, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=5, G=7, A=8, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 6 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 80

left           partial value  = 580

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 6, 9.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=6, G=7, A=8, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 9.

Rightmost      place of 'H'   = 2

right          partial value  = 80

left           partial value  = 680

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 4, 5, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=9, G=7, A=8, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6.

Rightmost      place of 'H'   = 2

right          partial value  = 80

left           partial value  = 980

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 4, 5, 6.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'G'

Intermediate   fit list       = A=9, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'G'   = 1

left           partial value  = 10

right          partial value  = 90

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 9

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'E'

Intermediate   fit list       = G=8, A=9, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7.

Current        code is        = 'H'

Intermediate   fit list       = E=2, G=8, A=9, Ö=1, Y=0.

Remaining      digits         = 3 and 4 and 5 and 6 and 7.

Rightmost      place of 'H'   = 2

right          partial value  = 90

left           partial value  = 290

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 4, 5, 6, 7.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=3, G=8, A=9, Ö=1, Y=0.

Remaining      digits         = 2 and 4 and 5 and 6 and 7.

Rightmost      place of 'H'   = 2

right          partial value  = 90

left           partial value  = 390

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 4, 5, 6, 7.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=4, G=8, A=9, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 5 and 6 and 7.

Rightmost      place of 'H'   = 2

right          partial value  = 90

left           partial value  = 490

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 5, 6, 7.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=5, G=8, A=9, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 6 and 7.

Rightmost      place of 'H'   = 2

right          partial value  = 90

left           partial value  = 590

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 6, 7.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=6, G=8, A=9, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 7.

Rightmost      place of 'H'   = 2

right          partial value  = 90

left           partial value  = 690

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 4, 5, 7.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'H'

Intermediate   fit list       = E=7, G=8, A=9, Ö=1, Y=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6.

Rightmost      place of 'H'   = 2

right          partial value  = 90

left           partial value  = 790

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 4, 5, 6.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'A'

Intermediate   fit list       = Ö=2, Y=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'G'

Intermediate   fit list       = A=1, Ö=2, Y=0.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'G'   = 1

left           partial value  = 20

right          partial value  = 10

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 1

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'E'

Intermediate   fit list       = G=9, A=1, Ö=2, Y=0.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

Current        code is        = 'H'

Intermediate   fit list       = E=3, G=9, A=1, Ö=2, Y=0.

Remaining      digits         = 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'H'   = 2

right          partial value  = 10

left           partial value  = 410

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 4, 5, 6, 7, 8.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = H=4, E=3, G=9, A=1, Ö=2, Y=0.

Remaining      digits         = 5 and 6 and 7 and 8.

Partial        fit            = H=4, E=3, G=9, A=1, Ö=2, Y=0.

Partial        values         =                  410 is equal to 410.

Coefficient    of 'T'         =                    0 is equal to 0.

Result of      predicate       = accepted("The final step could not be shortened.")

Calculated     digit          = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

Remaining      digits         = 5, 6, 7, 8.

Possible       digits         = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

Intersection   of them        = 5, 6, 7, 8.

Number of      elements       = 4

Tried          fit            = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=5, T=5, H=4, E=3, G=9, A=1, Ö=2, Y=0.

Results of     fit            = »390+25« related to     »415«

Values of      fit            = 415 is equal to       415.

Condensed      puzzle         = ÖT+EGY=HAT

Simplified     puzzle         = EGY+ÖT=HAT

Condensed      puzzle         = ÖT+EGY=HAT

Simplified     puzzle         = EGY+ÖT=HAT

Tried          fits           = 1

Matching       fits found     = 1

Start of fit lists and results:

Solution       #              = 1

Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=5, T=5, H=4, E=3, G=9, A=1, Ö=2, Y=0.

Solution       got            = 390+25=415

End of fit lists and results.

Current        code is        = 'Z'

Intermediate   fit list       = empty.

Remaining      digits         = none.

Condensed      puzzle         = ÖTVEN+TÍZ=HATVAN

Simplified     puzzle         = ÖTVEN+TÍZ=HATVAN

Condensed      puzzle         = ÖTVEN+TÍZ=HATVAN

Simplified     puzzle         = ÖTVEN+TÍZ=HATVAN

Tried          fits           = 0

Matching       fits           = not found

Current        code is        = 'Z'

Intermediate   fit list       = empty.

Remaining      digits         = 0 and 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 0

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = 0.

Number of      elements       = 1

Current        code is        = 'A'

Intermediate   fit list       = Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'E'

Intermediate   fit list       = A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = E=2, A=1, Z=0.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 10010

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 2

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=3, A=1, Z=0.

Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 10010

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 3

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 4, 5, 6, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=2, E=3, A=1, Z=0.

Remaining      digits         = 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 10030

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 4, 5, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=4, A=1, Z=0.

Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 10010

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 4

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 3, 5, 6, 7, 8, 9.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=3, E=4, A=1, Z=0.

Remaining      digits         = 2 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 10040

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 5, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=5, A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 10010

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 5

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=4, E=5, A=1, Z=0.

Remaining      digits         = 2 and 3 and 6 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 10050

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=6, A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 10010

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 6

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=5, E=6, A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 10060

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=7, A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 10010

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 7

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=6, E=7, A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 10070

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 5, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=8, A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 10010

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 8

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=7, E=8, A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 10080

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 5, 6, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=9, A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 10010

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 9

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=8, E=9, A=1, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7.

Rightmost      place of 'T'   = 2

left           partial value  = 10090

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 5, 6, 7.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'E'

Intermediate   fit list       = A=2, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = E=1, A=2, Z=0.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 20020

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 1

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=9, E=1, A=2, Z=0.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 20110

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 3, 4, 5, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=3, A=2, Z=0.

Remaining      digits         = 1 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 20020

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 3

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 1, 4, 5, 6, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = 1.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=1, E=3, A=2, Z=0.

Remaining      digits         = 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 20030

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 4, 5, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=4, A=2, Z=0.

Remaining      digits         = 1 and 3 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 20020

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 4

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 1, 3, 5, 6, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=5, A=2, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 20020

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 5

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 1, 3, 4, 6, 7, 8, 9.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=3, E=5, A=2, Z=0.

Remaining      digits         = 1 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 20050

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 4, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=6, A=2, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 20020

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 6

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 1, 3, 4, 5, 7, 8, 9.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=4, E=6, A=2, Z=0.

Remaining      digits         = 1 and 3 and 5 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 20060

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 3, 5, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=7, A=2, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 20020

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 7

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 1, 3, 4, 5, 6, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=5, E=7, A=2, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 20070

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 3, 4, 6, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=8, A=2, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 20020

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 8

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 1, 3, 4, 5, 6, 7, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=6, E=8, A=2, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 20080

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 3, 4, 5, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=9, A=2, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 20020

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 9

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 1, 3, 4, 5, 6, 7, 8.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=7, E=9, A=2, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 20090

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 3, 4, 5, 6, 8.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'E'

Intermediate   fit list       = A=3, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30030

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 1

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 4, 5, 6, 7, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 30110

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 4, 5, 6, 7, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 5 and 6 and 7.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 4 and 5 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 5 and 6 and 7.

Partial        fit            = N=4, H=2, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=2, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 4 and 6 and 7.

Partial        fit            = N=5, H=2, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=2, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 4 and 5 and 7.

Partial        fit            = N=6, H=2, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=2, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 4 and 5 and 6.

Partial        fit            = N=7, H=2, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 5 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 5 and 6 and 7.

Partial        fit            = N=2, H=4, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=4, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 6 and 7.

Partial        fit            = N=5, H=4, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=4, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 5 and 7.

Partial        fit            = N=6, H=4, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=4, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 5 and 6.

Partial        fit            = N=7, H=4, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=5, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 4 and 6 and 7.

Partial        fit            = N=2, H=5, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=5, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 6 and 7.

Partial        fit            = N=4, H=5, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=5, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=6, H=5, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=5, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=7, H=5, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=6, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 4 and 5 and 7.

Partial        fit            = N=2, H=6, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=6, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 5 and 7.

Partial        fit            = N=4, H=6, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=6, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=5, H=6, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=6, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 5.

Partial        fit            = N=7, H=6, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 5 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=7, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 4 and 5 and 6.

Partial        fit            = N=2, H=7, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=7, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 5 and 6.

Partial        fit            = N=4, H=7, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=7, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=5, H=7, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=7, T=9, Í=8, E=1, A=3, Z=0.

Remaining      digits         = 2 and 4 and 5.

Partial        fit            = N=6, H=7, T=9, Í=8, E=1, A=3, Z=0.

Partial        values         =                31010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=2, A=3, Z=0.

Remaining      digits         = 1 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30030

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 2

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 4, 5, 6, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=9, E=2, A=3, Z=0.

Remaining      digits         = 1 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 30120

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 4, 5, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=4, A=3, Z=0.

Remaining      digits         = 1 and 2 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30030

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 4

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 1, 2, 5, 6, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = 1.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=1, E=4, A=3, Z=0.

Remaining      digits         = 2 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 30040

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 5, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=5, A=3, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30030

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 5

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 1, 2, 4, 6, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=2, E=5, A=3, Z=0.

Remaining      digits         = 1 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 30050

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 4, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=6, A=3, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30030

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 6

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 1, 2, 4, 5, 7, 8, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=7, A=3, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30030

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 7

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 1, 2, 4, 5, 6, 8, 9.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=4, E=7, A=3, Z=0.

Remaining      digits         = 1 and 2 and 5 and 6 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 30070

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 2, 5, 6, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=8, A=3, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30030

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 8

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 1, 2, 4, 5, 6, 7, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=5, E=8, A=3, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 30080

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 2, 4, 6, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=9, A=3, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 30030

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 9

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 1, 2, 4, 5, 6, 7, 8.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=6, E=9, A=3, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 30090

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 2, 4, 5, 7, 8.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'E'

Intermediate   fit list       = A=4, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40040

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 1

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 5, 6, 7, 8, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 5 and 6 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 40110

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 5, 6, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 5 and 6 and 8.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 3 and 5 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=2, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 5 and 6 and 8.

Partial        fit            = N=3, H=2, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=2, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 3 and 6 and 8.

Partial        fit            = N=5, H=2, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=2, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 3 and 5 and 8.

Partial        fit            = N=6, H=2, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=2, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 3 and 5 and 6.

Partial        fit            = N=8, H=2, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 5 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=3, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 5 and 6 and 8.

Partial        fit            = N=2, H=3, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=3, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 6 and 8.

Partial        fit            = N=5, H=3, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=3, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 5 and 8.

Partial        fit            = N=6, H=3, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=3, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 5 and 6.

Partial        fit            = N=8, H=3, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=5, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 3 and 6 and 8.

Partial        fit            = N=2, H=5, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=5, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 6 and 8.

Partial        fit            = N=3, H=5, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=5, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 8.

Partial        fit            = N=6, H=5, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=5, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 6.

Partial        fit            = N=8, H=5, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=6, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 3 and 5 and 8.

Partial        fit            = N=2, H=6, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=6, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 5 and 8.

Partial        fit            = N=3, H=6, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=6, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 8.

Partial        fit            = N=5, H=6, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=6, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 5.

Partial        fit            = N=8, H=6, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=8, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 5 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=8, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 3 and 5 and 6.

Partial        fit            = N=2, H=8, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=8, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 5 and 6.

Partial        fit            = N=3, H=8, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=8, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 6.

Partial        fit            = N=5, H=8, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=8, T=9, Í=7, E=1, A=4, Z=0.

Remaining      digits         = 2 and 3 and 5.

Partial        fit            = N=6, H=8, T=9, Í=7, E=1, A=4, Z=0.

Partial        values         =                41010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40040

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 2

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 1, 3, 5, 6, 7, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 5 and 6 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 40120

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 3, 5, 6, 7, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 5 and 6 and 7.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 3 and 5 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=1, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 5 and 6 and 7.

Partial        fit            = N=3, H=1, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=1, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 3 and 6 and 7.

Partial        fit            = N=5, H=1, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=1, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 3 and 5 and 7.

Partial        fit            = N=6, H=1, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=1, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 3 and 5 and 6.

Partial        fit            = N=7, H=1, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 5 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=3, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 5 and 6 and 7.

Partial        fit            = N=1, H=3, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=3, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 6 and 7.

Partial        fit            = N=5, H=3, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=3, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 5 and 7.

Partial        fit            = N=6, H=3, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=3, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 5 and 6.

Partial        fit            = N=7, H=3, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=5, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 3 and 6 and 7.

Partial        fit            = N=1, H=5, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=5, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 6 and 7.

Partial        fit            = N=3, H=5, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=5, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 7.

Partial        fit            = N=6, H=5, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=5, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=7, H=5, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=6, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 3 and 5 and 7.

Partial        fit            = N=1, H=6, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=6, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 5 and 7.

Partial        fit            = N=3, H=6, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=6, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 7.

Partial        fit            = N=5, H=6, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=6, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 5.

Partial        fit            = N=7, H=6, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 5 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=7, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 3 and 5 and 6.

Partial        fit            = N=1, H=7, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=7, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 5 and 6.

Partial        fit            = N=3, H=7, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=7, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=5, H=7, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=7, T=9, Í=8, E=2, A=4, Z=0.

Remaining      digits         = 1 and 3 and 5.

Partial        fit            = N=6, H=7, T=9, Í=8, E=2, A=4, Z=0.

Partial        values         =                41020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=3, A=4, Z=0.

Remaining      digits         = 1 and 2 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40040

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 3

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 5, 6, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=9, E=3, A=4, Z=0.

Remaining      digits         = 1 and 2 and 5 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 40130

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 5, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=5, A=4, Z=0.

Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40040

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 5

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 1, 2, 3, 6, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = 1.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=1, E=5, A=4, Z=0.

Remaining      digits         = 2 and 3 and 6 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 40050

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 6, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=6, A=4, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40040

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 6

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 1, 2, 3, 5, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=2, E=6, A=4, Z=0.

Remaining      digits         = 1 and 3 and 5 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 40060

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 3, 5, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=7, A=4, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40040

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 7

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 1, 2, 3, 5, 6, 8, 9.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=3, E=7, A=4, Z=0.

Remaining      digits         = 1 and 2 and 5 and 6 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 40070

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 2, 5, 6, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=8, A=4, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40040

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 8

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 1, 2, 3, 5, 6, 7, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=9, A=4, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 40040

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 9

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 1, 2, 3, 5, 6, 7, 8.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=5, E=9, A=4, Z=0.

Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 40090

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 2, 3, 6, 7, 8.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'E'

Intermediate   fit list       = A=5, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50050

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 1

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 50110

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 4, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 4 and 7 and 8.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 3 and 4 and 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=2, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 4 and 7 and 8.

Partial        fit            = N=3, H=2, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 3 and 7 and 8.

Partial        fit            = N=4, H=2, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=2, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 3 and 4 and 8.

Partial        fit            = N=7, H=2, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=2, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 3 and 4 and 7.

Partial        fit            = N=8, H=2, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 4 and 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=3, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 4 and 7 and 8.

Partial        fit            = N=2, H=3, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=3, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 7 and 8.

Partial        fit            = N=4, H=3, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=3, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 4 and 8.

Partial        fit            = N=7, H=3, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=3, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=8, H=3, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 3 and 7 and 8.

Partial        fit            = N=2, H=4, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=4, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 7 and 8.

Partial        fit            = N=3, H=4, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=4, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 8.

Partial        fit            = N=7, H=4, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=4, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 7.

Partial        fit            = N=8, H=4, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=7, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 3 and 4 and 8.

Partial        fit            = N=2, H=7, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=7, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 4 and 8.

Partial        fit            = N=3, H=7, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=7, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 8.

Partial        fit            = N=4, H=7, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=7, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 4.

Partial        fit            = N=8, H=7, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=8, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 4 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=8, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 3 and 4 and 7.

Partial        fit            = N=2, H=8, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=8, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=3, H=8, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=8, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 7.

Partial        fit            = N=4, H=8, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=8, T=9, Í=6, E=1, A=5, Z=0.

Remaining      digits         = 2 and 3 and 4.

Partial        fit            = N=7, H=8, T=9, Í=6, E=1, A=5, Z=0.

Partial        values         =                51010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50050

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 2

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 1, 3, 4, 6, 7, 8, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 50120

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 3, 4, 6, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6 and 8.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 3 and 4 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=1, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 4 and 6 and 8.

Partial        fit            = N=3, H=1, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=1, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 3 and 6 and 8.

Partial        fit            = N=4, H=1, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=1, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 3 and 4 and 8.

Partial        fit            = N=6, H=1, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=1, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 3 and 4 and 6.

Partial        fit            = N=8, H=1, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 4 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=3, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 4 and 6 and 8.

Partial        fit            = N=1, H=3, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=3, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 6 and 8.

Partial        fit            = N=4, H=3, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=3, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 4 and 8.

Partial        fit            = N=6, H=3, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=3, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=8, H=3, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=4, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 3 and 6 and 8.

Partial        fit            = N=1, H=4, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=4, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 6 and 8.

Partial        fit            = N=3, H=4, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=4, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 8.

Partial        fit            = N=6, H=4, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=4, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=8, H=4, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=6, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 3 and 4 and 8.

Partial        fit            = N=1, H=6, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=6, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 4 and 8.

Partial        fit            = N=3, H=6, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=6, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 8.

Partial        fit            = N=4, H=6, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=6, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 4.

Partial        fit            = N=8, H=6, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=8, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=8, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 3 and 4 and 6.

Partial        fit            = N=1, H=8, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=8, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=3, H=8, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=8, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=4, H=8, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=8, T=9, Í=7, E=2, A=5, Z=0.

Remaining      digits         = 1 and 3 and 4.

Partial        fit            = N=6, H=8, T=9, Í=7, E=2, A=5, Z=0.

Partial        values         =                51020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50050

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 3

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 1, 2, 4, 6, 7, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 50130

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 4, 6, 7, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6 and 7.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 2 and 4 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=1, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 4 and 6 and 7.

Partial        fit            = N=2, H=1, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=1, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 2 and 6 and 7.

Partial        fit            = N=4, H=1, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=1, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=6, H=1, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=1, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=7, H=1, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 4 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=2, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 4 and 6 and 7.

Partial        fit            = N=1, H=2, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 6 and 7.

Partial        fit            = N=4, H=2, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=2, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 4 and 7.

Partial        fit            = N=6, H=2, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=2, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=7, H=2, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=4, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 2 and 6 and 7.

Partial        fit            = N=1, H=4, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 6 and 7.

Partial        fit            = N=2, H=4, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=4, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 7.

Partial        fit            = N=6, H=4, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=4, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 6.

Partial        fit            = N=7, H=4, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 4 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=6, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=1, H=6, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=6, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 4 and 7.

Partial        fit            = N=2, H=6, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=6, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 7.

Partial        fit            = N=4, H=6, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=6, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=7, H=6, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=7, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=1, H=7, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=7, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=2, H=7, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=7, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 6.

Partial        fit            = N=4, H=7, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=7, T=9, Í=8, E=3, A=5, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=6, H=7, T=9, Í=8, E=3, A=5, Z=0.

Partial        values         =                51030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=4, A=5, Z=0.

Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50050

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 4

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 6, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=9, E=4, A=5, Z=0.

Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 50140

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=6, A=5, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50050

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 6

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 1, 2, 3, 4, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = 1.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=1, E=6, A=5, Z=0.

Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 50060

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=7, A=5, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50050

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 7

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 1, 2, 3, 4, 6, 8, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=2, E=7, A=5, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 50070

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 3, 4, 6, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=8, A=5, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50050

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 8

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 1, 2, 3, 4, 6, 7, 9.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=3, E=8, A=5, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 50080

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 2, 4, 6, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=9, A=5, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 50050

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 9

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 1, 2, 3, 4, 6, 7, 8.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=4, E=9, A=5, Z=0.

Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 50090

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 2, 3, 6, 7, 8.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'E'

Intermediate   fit list       = A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60060

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 1

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 60110

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 4, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 4 and 7 and 8.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 3 and 4 and 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=2, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 4 and 7 and 8.

Partial        fit            = N=3, H=2, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 3 and 7 and 8.

Partial        fit            = N=4, H=2, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=2, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 3 and 4 and 8.

Partial        fit            = N=7, H=2, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=2, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 3 and 4 and 7.

Partial        fit            = N=8, H=2, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 4 and 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=3, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 4 and 7 and 8.

Partial        fit            = N=2, H=3, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=3, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 7 and 8.

Partial        fit            = N=4, H=3, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=3, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 4 and 8.

Partial        fit            = N=7, H=3, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=3, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=8, H=3, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 3 and 7 and 8.

Partial        fit            = N=2, H=4, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=4, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 7 and 8.

Partial        fit            = N=3, H=4, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=4, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 8.

Partial        fit            = N=7, H=4, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=4, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 7.

Partial        fit            = N=8, H=4, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=7, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 3 and 4 and 8.

Partial        fit            = N=2, H=7, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=7, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 4 and 8.

Partial        fit            = N=3, H=7, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=7, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 8.

Partial        fit            = N=4, H=7, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=7, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 4.

Partial        fit            = N=8, H=7, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=8, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 4 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=8, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 3 and 4 and 7.

Partial        fit            = N=2, H=8, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=8, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=3, H=8, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=8, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 7.

Partial        fit            = N=4, H=8, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=8, T=9, Í=5, E=1, A=6, Z=0.

Remaining      digits         = 2 and 3 and 4.

Partial        fit            = N=7, H=8, T=9, Í=5, E=1, A=6, Z=0.

Partial        values         =                61010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=2, A=6, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60060

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 2

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 1, 3, 4, 5, 7, 8, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60060

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 3

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 1, 2, 4, 5, 7, 8, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 60130

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 4, 5, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 8.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 2 and 4 and 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=1, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 4 and 5 and 8.

Partial        fit            = N=2, H=1, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=1, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 2 and 5 and 8.

Partial        fit            = N=4, H=1, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=1, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 2 and 4 and 8.

Partial        fit            = N=5, H=1, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=1, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 2 and 4 and 5.

Partial        fit            = N=8, H=1, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 4 and 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=2, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 4 and 5 and 8.

Partial        fit            = N=1, H=2, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 5 and 8.

Partial        fit            = N=4, H=2, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=2, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 4 and 8.

Partial        fit            = N=5, H=2, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=2, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 4 and 5.

Partial        fit            = N=8, H=2, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=4, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 2 and 5 and 8.

Partial        fit            = N=1, H=4, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 5 and 8.

Partial        fit            = N=2, H=4, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=4, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 8.

Partial        fit            = N=5, H=4, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=4, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 5.

Partial        fit            = N=8, H=4, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=5, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 2 and 4 and 8.

Partial        fit            = N=1, H=5, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=5, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 4 and 8.

Partial        fit            = N=2, H=5, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=5, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 8.

Partial        fit            = N=4, H=5, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=5, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=8, H=5, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=8, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=8, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 2 and 4 and 5.

Partial        fit            = N=1, H=8, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=8, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 4 and 5.

Partial        fit            = N=2, H=8, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=8, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 5.

Partial        fit            = N=4, H=8, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=8, T=9, Í=7, E=3, A=6, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=5, H=8, T=9, Í=7, E=3, A=6, Z=0.

Partial        values         =                61030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60060

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 4

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 1, 2, 3, 5, 7, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 60140

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 5, 7, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 7.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 2 and 3 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=1, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 3 and 5 and 7.

Partial        fit            = N=2, H=1, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=1, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 2 and 5 and 7.

Partial        fit            = N=3, H=1, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=1, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 2 and 3 and 7.

Partial        fit            = N=5, H=1, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=1, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 2 and 3 and 5.

Partial        fit            = N=7, H=1, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 3 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=2, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 3 and 5 and 7.

Partial        fit            = N=1, H=2, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=2, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 5 and 7.

Partial        fit            = N=3, H=2, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=2, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 3 and 7.

Partial        fit            = N=5, H=2, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=2, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 3 and 5.

Partial        fit            = N=7, H=2, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=3, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 2 and 5 and 7.

Partial        fit            = N=1, H=3, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=3, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 5 and 7.

Partial        fit            = N=2, H=3, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=3, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 7.

Partial        fit            = N=5, H=3, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=3, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 5.

Partial        fit            = N=7, H=3, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=5, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 2 and 3 and 7.

Partial        fit            = N=1, H=5, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=5, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 3 and 7.

Partial        fit            = N=2, H=5, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=5, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 7.

Partial        fit            = N=3, H=5, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=5, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3.

Partial        fit            = N=7, H=5, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=7, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 2 and 3 and 5.

Partial        fit            = N=1, H=7, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=7, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 3 and 5.

Partial        fit            = N=2, H=7, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=7, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 5.

Partial        fit            = N=3, H=7, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=7, T=9, Í=8, E=4, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3.

Partial        fit            = N=5, H=7, T=9, Í=8, E=4, A=6, Z=0.

Partial        values         =                61040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=5, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60060

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 5

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=9, E=5, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 60150

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=7, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60060

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 7

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 1, 2, 3, 4, 5, 8, 9.

Possible       digits         = 1.

Intersection   of them        = 1.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=1, E=7, A=6, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 60070

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 5, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=8, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60060

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 8

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 1, 2, 3, 4, 5, 7, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=2, E=8, A=6, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 60080

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 3, 4, 5, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=9, A=6, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 60060

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 9

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 1, 2, 3, 4, 5, 7, 8.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=3, E=9, A=6, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 60090

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 2, 4, 5, 7, 8.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'E'

Intermediate   fit list       = A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70070

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 1

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 5 and 6 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 70110

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 5, 6, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 5 and 6 and 8.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 3 and 5 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=2, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 5 and 6 and 8.

Partial        fit            = N=3, H=2, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=2, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 3 and 6 and 8.

Partial        fit            = N=5, H=2, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=2, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 3 and 5 and 8.

Partial        fit            = N=6, H=2, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=2, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 3 and 5 and 6.

Partial        fit            = N=8, H=2, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 5 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=3, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 5 and 6 and 8.

Partial        fit            = N=2, H=3, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=3, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 6 and 8.

Partial        fit            = N=5, H=3, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=3, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 5 and 8.

Partial        fit            = N=6, H=3, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=3, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 5 and 6.

Partial        fit            = N=8, H=3, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=5, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 3 and 6 and 8.

Partial        fit            = N=2, H=5, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=5, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 6 and 8.

Partial        fit            = N=3, H=5, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=5, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 8.

Partial        fit            = N=6, H=5, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=5, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 6.

Partial        fit            = N=8, H=5, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=6, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 3 and 5 and 8.

Partial        fit            = N=2, H=6, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=6, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 5 and 8.

Partial        fit            = N=3, H=6, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=6, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 8.

Partial        fit            = N=5, H=6, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=6, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 5.

Partial        fit            = N=8, H=6, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=8, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 5 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=8, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 3 and 5 and 6.

Partial        fit            = N=2, H=8, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=8, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 5 and 6.

Partial        fit            = N=3, H=8, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=8, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 6.

Partial        fit            = N=5, H=8, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=8, T=9, Í=4, E=1, A=7, Z=0.

Remaining      digits         = 2 and 3 and 5.

Partial        fit            = N=6, H=8, T=9, Í=4, E=1, A=7, Z=0.

Partial        values         =                71010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70070

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 2

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 1, 3, 4, 5, 6, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 70120

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 3, 4, 6, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6 and 8.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 3 and 4 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=1, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 4 and 6 and 8.

Partial        fit            = N=3, H=1, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=1, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 3 and 6 and 8.

Partial        fit            = N=4, H=1, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=1, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 3 and 4 and 8.

Partial        fit            = N=6, H=1, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=1, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 3 and 4 and 6.

Partial        fit            = N=8, H=1, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 4 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=3, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 4 and 6 and 8.

Partial        fit            = N=1, H=3, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=3, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 6 and 8.

Partial        fit            = N=4, H=3, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=3, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 4 and 8.

Partial        fit            = N=6, H=3, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=3, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=8, H=3, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=4, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 3 and 6 and 8.

Partial        fit            = N=1, H=4, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=4, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 6 and 8.

Partial        fit            = N=3, H=4, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=4, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 8.

Partial        fit            = N=6, H=4, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=4, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=8, H=4, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=6, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 3 and 4 and 8.

Partial        fit            = N=1, H=6, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=6, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 4 and 8.

Partial        fit            = N=3, H=6, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=6, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 8.

Partial        fit            = N=4, H=6, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=6, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4.

Partial        fit            = N=8, H=6, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=8, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=8, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 3 and 4 and 6.

Partial        fit            = N=1, H=8, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=8, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=3, H=8, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=8, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=4, H=8, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=8, T=9, Í=5, E=2, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4.

Partial        fit            = N=6, H=8, T=9, Í=5, E=2, A=7, Z=0.

Partial        values         =                71020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70070

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 3

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 1, 2, 4, 5, 6, 8, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 8 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 70130

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 4, 5, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 8.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 2 and 4 and 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=1, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 4 and 5 and 8.

Partial        fit            = N=2, H=1, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=1, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 2 and 5 and 8.

Partial        fit            = N=4, H=1, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=1, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 2 and 4 and 8.

Partial        fit            = N=5, H=1, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=1, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 2 and 4 and 5.

Partial        fit            = N=8, H=1, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 4 and 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=2, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 4 and 5 and 8.

Partial        fit            = N=1, H=2, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 5 and 8.

Partial        fit            = N=4, H=2, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=2, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 4 and 8.

Partial        fit            = N=5, H=2, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=2, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 4 and 5.

Partial        fit            = N=8, H=2, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=4, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 2 and 5 and 8.

Partial        fit            = N=1, H=4, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 5 and 8.

Partial        fit            = N=2, H=4, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=4, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 8.

Partial        fit            = N=5, H=4, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=4, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 5.

Partial        fit            = N=8, H=4, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=5, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 2 and 4 and 8.

Partial        fit            = N=1, H=5, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=5, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 4 and 8.

Partial        fit            = N=2, H=5, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=5, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 8.

Partial        fit            = N=4, H=5, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=8, H=5, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=8, H=5, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=8, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=8, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 2 and 4 and 5.

Partial        fit            = N=1, H=8, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=8, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 4 and 5.

Partial        fit            = N=2, H=8, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=8, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 5.

Partial        fit            = N=4, H=8, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=8, T=9, Í=6, E=3, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=5, H=8, T=9, Í=6, E=3, A=7, Z=0.

Partial        values         =                71030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=4, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70070

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 4

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 1, 2, 3, 5, 6, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70070

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 5

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 1, 2, 3, 4, 6, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 70150

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 6, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 2 and 3 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=1, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 3 and 4 and 6.

Partial        fit            = N=2, H=1, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=1, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=3, H=1, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=1, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 2 and 3 and 6.

Partial        fit            = N=4, H=1, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=1, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 2 and 3 and 4.

Partial        fit            = N=6, H=1, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=2, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 3 and 4 and 6.

Partial        fit            = N=1, H=2, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=2, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=3, H=2, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=4, H=2, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=2, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4.

Partial        fit            = N=6, H=2, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=3, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=1, H=3, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=3, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=2, H=3, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=3, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 6.

Partial        fit            = N=4, H=3, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=3, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=6, H=3, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=4, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 2 and 3 and 6.

Partial        fit            = N=1, H=4, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=2, H=4, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=4, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 6.

Partial        fit            = N=3, H=4, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=4, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3.

Partial        fit            = N=6, H=4, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=6, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 2 and 3 and 4.

Partial        fit            = N=1, H=6, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=6, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4.

Partial        fit            = N=2, H=6, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=6, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=3, H=6, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=6, T=9, Í=8, E=5, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3.

Partial        fit            = N=4, H=6, T=9, Í=8, E=5, A=7, Z=0.

Partial        values         =                71050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=6, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70070

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 6

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 5, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=9, E=6, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 70160

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 5, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=8, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70070

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 8

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 1, 2, 3, 4, 5, 6, 9.

Possible       digits         = 1.

Intersection   of them        = 1.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=1, E=8, A=7, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 70080

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 5, 6, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=9, A=7, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 70070

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 9

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 1, 2, 3, 4, 5, 6, 8.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=2, E=9, A=7, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 70090

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 1, 3, 4, 5, 6, 8.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'E'

Intermediate   fit list       = A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = E=1, A=8, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80080

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 1

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 80110

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 4, 5, 6, 7, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 5 and 6 and 7.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 4 and 5 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 5 and 6 and 7.

Partial        fit            = N=4, H=2, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=2, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 4 and 6 and 7.

Partial        fit            = N=5, H=2, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=2, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 4 and 5 and 7.

Partial        fit            = N=6, H=2, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=2, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 4 and 5 and 6.

Partial        fit            = N=7, H=2, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 5 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 5 and 6 and 7.

Partial        fit            = N=2, H=4, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=4, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 6 and 7.

Partial        fit            = N=5, H=4, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=4, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 5 and 7.

Partial        fit            = N=6, H=4, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=4, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 5 and 6.

Partial        fit            = N=7, H=4, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=5, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 4 and 6 and 7.

Partial        fit            = N=2, H=5, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=5, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 6 and 7.

Partial        fit            = N=4, H=5, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=5, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=6, H=5, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=5, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=7, H=5, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=6, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 4 and 5 and 7.

Partial        fit            = N=2, H=6, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=6, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 5 and 7.

Partial        fit            = N=4, H=6, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=6, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=5, H=6, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=6, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 5.

Partial        fit            = N=7, H=6, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 5 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=7, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 4 and 5 and 6.

Partial        fit            = N=2, H=7, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=7, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 5 and 6.

Partial        fit            = N=4, H=7, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=7, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=5, H=7, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=7, T=9, Í=3, E=1, A=8, Z=0.

Remaining      digits         = 2 and 4 and 5.

Partial        fit            = N=6, H=7, T=9, Í=3, E=1, A=8, Z=0.

Partial        values         =                81010 is greater than 10010.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80080

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 2

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 1, 3, 4, 5, 6, 7, 9.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 5 and 6 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 80120

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 3, 5, 6, 7, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 5 and 6 and 7.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 3 and 5 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=1, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 5 and 6 and 7.

Partial        fit            = N=3, H=1, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=1, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 3 and 6 and 7.

Partial        fit            = N=5, H=1, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=1, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 3 and 5 and 7.

Partial        fit            = N=6, H=1, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=1, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 3 and 5 and 6.

Partial        fit            = N=7, H=1, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 5 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=3, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 5 and 6 and 7.

Partial        fit            = N=1, H=3, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=3, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 6 and 7.

Partial        fit            = N=5, H=3, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=3, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 5 and 7.

Partial        fit            = N=6, H=3, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=3, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 5 and 6.

Partial        fit            = N=7, H=3, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=5, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 3 and 6 and 7.

Partial        fit            = N=1, H=5, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=5, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 6 and 7.

Partial        fit            = N=3, H=5, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=5, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 7.

Partial        fit            = N=6, H=5, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=5, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=7, H=5, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=6, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 3 and 5 and 7.

Partial        fit            = N=1, H=6, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=6, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 5 and 7.

Partial        fit            = N=3, H=6, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=6, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 7.

Partial        fit            = N=5, H=6, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=6, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 5.

Partial        fit            = N=7, H=6, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 5 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=7, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 3 and 5 and 6.

Partial        fit            = N=1, H=7, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=7, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 5 and 6.

Partial        fit            = N=3, H=7, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=7, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=5, H=7, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=7, T=9, Í=4, E=2, A=8, Z=0.

Remaining      digits         = 1 and 3 and 5.

Partial        fit            = N=6, H=7, T=9, Í=4, E=2, A=8, Z=0.

Partial        values         =                81020 is greater than 20020.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80080

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 3

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 1, 2, 4, 5, 6, 7, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 80130

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 4, 6, 7, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6 and 7.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 2 and 4 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=1, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 4 and 6 and 7.

Partial        fit            = N=2, H=1, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=1, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 2 and 6 and 7.

Partial        fit            = N=4, H=1, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=1, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=6, H=1, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=1, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=7, H=1, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 4 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=2, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 4 and 6 and 7.

Partial        fit            = N=1, H=2, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 6 and 7.

Partial        fit            = N=4, H=2, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=2, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 4 and 7.

Partial        fit            = N=6, H=2, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=2, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=7, H=2, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=4, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 2 and 6 and 7.

Partial        fit            = N=1, H=4, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 6 and 7.

Partial        fit            = N=2, H=4, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=4, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 7.

Partial        fit            = N=6, H=4, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=4, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 6.

Partial        fit            = N=7, H=4, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=6, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 2 and 4 and 7.

Partial        fit            = N=1, H=6, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=6, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 4 and 7.

Partial        fit            = N=2, H=6, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=6, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 7.

Partial        fit            = N=4, H=6, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=6, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=7, H=6, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=7, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=1, H=7, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=7, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=2, H=7, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=7, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 6.

Partial        fit            = N=4, H=7, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=7, T=9, Í=5, E=3, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=6, H=7, T=9, Í=5, E=3, A=8, Z=0.

Partial        values         =                81030 is greater than 30030.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80080

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 4

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 1, 2, 3, 5, 6, 7, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 7 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 80140

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 5, 7, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 7.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 2 and 3 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=1, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 3 and 5 and 7.

Partial        fit            = N=2, H=1, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=1, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 2 and 5 and 7.

Partial        fit            = N=3, H=1, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=1, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 2 and 3 and 7.

Partial        fit            = N=5, H=1, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=1, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 2 and 3 and 5.

Partial        fit            = N=7, H=1, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 3 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=2, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 3 and 5 and 7.

Partial        fit            = N=1, H=2, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=2, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 5 and 7.

Partial        fit            = N=3, H=2, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=2, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 3 and 7.

Partial        fit            = N=5, H=2, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=2, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 3 and 5.

Partial        fit            = N=7, H=2, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=3, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 2 and 5 and 7.

Partial        fit            = N=1, H=3, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=3, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 5 and 7.

Partial        fit            = N=2, H=3, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=3, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 7.

Partial        fit            = N=5, H=3, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=3, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 5.

Partial        fit            = N=7, H=3, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=5, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 7.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=5, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 2 and 3 and 7.

Partial        fit            = N=1, H=5, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=5, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 3 and 7.

Partial        fit            = N=2, H=5, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=5, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 7.

Partial        fit            = N=3, H=5, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=7, H=5, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3.

Partial        fit            = N=7, H=5, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=7, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=7, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 2 and 3 and 5.

Partial        fit            = N=1, H=7, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=7, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 3 and 5.

Partial        fit            = N=2, H=7, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=7, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 5.

Partial        fit            = N=3, H=7, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=5, H=7, T=9, Í=6, E=4, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3.

Partial        fit            = N=5, H=7, T=9, Í=6, E=4, A=8, Z=0.

Partial        values         =                81040 is greater than 40040.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80080

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 5

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 1, 2, 3, 4, 6, 7, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 9.

Rightmost      place of 'T'   = 2

left           partial value  = 80150

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 6, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'H'

Intermediate   fit list       = T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6.

Current        code is        = 'N'

Intermediate   fit list       = H=1, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 2 and 3 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=1, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 3 and 4 and 6.

Partial        fit            = N=2, H=1, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=1, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=3, H=1, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=1, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 2 and 3 and 6.

Partial        fit            = N=4, H=1, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=1, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 2 and 3 and 4.

Partial        fit            = N=6, H=1, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=2, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 3 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=2, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 3 and 4 and 6.

Partial        fit            = N=1, H=2, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=2, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=3, H=2, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=2, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=4, H=2, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=2, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 3 and 4.

Partial        fit            = N=6, H=2, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=3, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=3, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 2 and 4 and 6.

Partial        fit            = N=1, H=3, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=3, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 4 and 6.

Partial        fit            = N=2, H=3, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=3, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 6.

Partial        fit            = N=4, H=3, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=3, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=6, H=3, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=4, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 6.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=4, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 2 and 3 and 6.

Partial        fit            = N=1, H=4, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=4, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 3 and 6.

Partial        fit            = N=2, H=4, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=4, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 6.

Partial        fit            = N=3, H=4, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=6, H=4, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3.

Partial        fit            = N=6, H=4, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'N'

Intermediate   fit list       = H=6, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4.

Current        code is        = 'V'

Intermediate   fit list       = N=1, H=6, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 2 and 3 and 4.

Partial        fit            = N=1, H=6, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=2, H=6, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 3 and 4.

Partial        fit            = N=2, H=6, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=3, H=6, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 4.

Partial        fit            = N=3, H=6, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'V'

Intermediate   fit list       = N=4, H=6, T=9, Í=7, E=5, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3.

Partial        fit            = N=4, H=6, T=9, Í=7, E=5, A=8, Z=0.

Partial        values         =                81050 is greater than 50050.

Coefficient    of 'V'         =                    0 is equal to 0.

Result of      predicate       = rejected("The final step has no solution.")

Calculated     digit          = none.

Current        code is        = 'Í'

Intermediate   fit list       = E=6, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80080

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 6

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 1, 2, 3, 4, 5, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=7, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80080

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 7

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 5, 6, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=9, E=7, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6.

Rightmost      place of 'T'   = 2

left           partial value  = 80170

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 5, 6.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=9, A=8, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 80080

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 9

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 1, 2, 3, 4, 5, 6, 7.

Possible       digits         = 1.

Intersection   of them        = 1.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=1, E=9, A=8, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7.

Rightmost      place of 'T'   = 2

left           partial value  = 80090

right          partial value  = 90090

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 5, 6, 7.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'E'

Intermediate   fit list       = A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8.

Current        code is        = 'Í'

Intermediate   fit list       = E=1, A=9, Z=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 90090

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 1

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=2, E=1, A=9, Z=0.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 90110

right          partial value  = 10010

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 3, 4, 5, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=2, A=9, Z=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 90090

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 2

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 1, 3, 4, 5, 6, 7, 8.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=3, E=2, A=9, Z=0.

Remaining      digits         = 1 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 90120

right          partial value  = 20020

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 4, 5, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=3, A=9, Z=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 90090

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 3

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 1, 2, 4, 5, 6, 7, 8.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=4, E=3, A=9, Z=0.

Remaining      digits         = 1 and 2 and 5 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 90130

right          partial value  = 30030

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 5, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=4, A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 90090

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 4

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 1, 2, 3, 5, 6, 7, 8.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=5, E=4, A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 90140

right          partial value  = 40040

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=5, A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 90090

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 5

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 1, 2, 3, 4, 6, 7, 8.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=6, E=5, A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 7 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 90150

right          partial value  = 50050

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=6, A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 90090

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 6

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 1, 2, 3, 4, 5, 7, 8.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=7, E=6, A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 8.

Rightmost      place of 'T'   = 2

left           partial value  = 90160

right          partial value  = 60060

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 5, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=7, A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 90090

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 7

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 1, 2, 3, 4, 5, 6, 8.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'T'

Intermediate   fit list       = Í=8, E=7, A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6.

Rightmost      place of 'T'   = 2

left           partial value  = 90170

right          partial value  = 70070

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 5, 6.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = E=8, A=9, Z=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 90090

right          partial value  = 80080

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 8

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 5, 6, 7.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Condensed      puzzle         = HATVAN+TÍZ=HETVEN

Simplified     puzzle         = HATVAN+TÍZ=HETVEN

Condensed      puzzle         = HATVAN+TÍZ=HETVEN

Simplified     puzzle         = HATVAN+TÍZ=HETVEN

Tried          fits           = 0

Matching       fits           = not found

Current        code is        = 'Z'

Intermediate   fit list       = H=1.

Remaining      digits         = 0 and 5.

Rightmost      place of 'Z'   = 0

right          partial value  = 0

left           partial value  = 5000

Factor         of code mod 10 = 6

Digit on       right side     = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0 or 5.

Remaining      digits         = 0, 5.

Possible       digits         = 0, 5.

Intersection   of them        = 0, 5.

Number of      elements       = 2

Current        code is        = 'S'

Intermediate   fit list       = Z=0, H=1.

Remaining      digits         = 5 and 6 and 7 and 8 and 9.

Current        code is        = 'Á'

Intermediate   fit list       = S=5, Z=0, H=1.

Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'Á'   = 1

right          partial value  = 4750

left           partial value  = 5000

Factor         of code mod 10 = 1

Digit on       right side     = 5

Digit on       other side     = 0

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Á'

Intermediate   fit list       = S=6, Z=0, H=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'Á'   = 1

right          partial value  = 5700

left           partial value  = 5000

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Á'

Intermediate   fit list       = S=7, Z=0, H=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'Á'   = 1

right          partial value  = 6650

left           partial value  = 5000

Factor         of code mod 10 = 1

Digit on       right side     = 5

Digit on       other side     = 0

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'Ú'

Intermediate   fit list       = Á=5, S=7, Z=0, H=1.

Remaining      digits         = 2 and 3 and 4 and 6 and 8 and 9.

Calculated     ratio          = 3

Calculated     modulus        = 200

Partial        fit            = Á=5, S=7, Z=0, H=1.

Partial        values         =                 5000 is less than 6700.

Coefficient    of 'Ú'         =                  500 is greater than 0.

Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'Á'

Intermediate   fit list       = S=8, Z=0, H=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'Á'   = 1

right          partial value  = 7600

left           partial value  = 5000

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 0

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Á'

Intermediate   fit list       = S=9, Z=0, H=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Á'   = 1

right          partial value  = 8550

left           partial value  = 5000

Factor         of code mod 10 = 1

Digit on       right side     = 5

Digit on       other side     = 0

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'Ú'

Intermediate   fit list       = Á=5, S=9, Z=0, H=1.

Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8.

Calculated     ratio          = 7

Calculated     modulus        = 100

Partial        fit            = Á=5, S=9, Z=0, H=1.

Partial        values         =                 5000 is less than 8600.

Coefficient    of 'Ú'         =                  500 is greater than 0.

Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'S'

Intermediate   fit list       = Z=5, H=1.

Remaining      digits         = 6 and 7 and 8 and 9.

Current        code is        = 'Á'

Intermediate   fit list       = S=6, Z=5, H=1.

Remaining      digits         = 0 and 2 and 3 and 4 and 7 and 8 and 9.

Rightmost      place of 'Á'   = 1

right          partial value  = 6180

left           partial value  = 5000

Factor         of code mod 10 = 1

Digit on       right side     = 8

Digit on       other side     = 0

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 0, 2, 3, 4, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'Ú'

Intermediate   fit list       = Á=2, S=6, Z=5, H=1.

Remaining      digits         = 0 and 3 and 4 and 7 and 8 and 9.

Calculated     ratio          = 2

Calculated     modulus        = 200

Partial        fit            = Á=2, S=6, Z=5, H=1.

Partial        values         =                 5000 is less than 6200.

Coefficient    of 'Ú'         =                  500 is greater than 0.

Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'Á'

Intermediate   fit list       = S=7, Z=5, H=1.

Remaining      digits         = 0 and 2 and 3 and 4 and 6 and 8 and 9.

Rightmost      place of 'Á'   = 1

right          partial value  = 7130

left           partial value  = 5000

Factor         of code mod 10 = 1

Digit on       right side     = 3

Digit on       other side     = 0

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 0, 2, 3, 4, 6, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Á'

Intermediate   fit list       = S=8, Z=5, H=1.

Remaining      digits         = 0 and 2 and 3 and 4 and 6 and 7 and 9.

Rightmost      place of 'Á'   = 1

right          partial value  = 8080

left           partial value  = 5000

Factor         of code mod 10 = 1

Digit on       right side     = 8

Digit on       other side     = 0

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 0, 2, 3, 4, 6, 7, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'Ú'

Intermediate   fit list       = Á=2, S=8, Z=5, H=1.

Remaining      digits         = 0 and 3 and 4 and 6 and 7 and 9.

Calculated     ratio          = 6

Calculated     modulus        = 100

Partial        fit            = Á=2, S=8, Z=5, H=1.

Partial        values         =                 5000 is less than 8100.

Coefficient    of 'Ú'         =                  500 is greater than 0.

Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'Á'

Intermediate   fit list       = S=9, Z=5, H=1.

Remaining      digits         = 0 and 2 and 3 and 4 and 6 and 7 and 8.

Rightmost      place of 'Á'   = 1

right          partial value  = 9030

left           partial value  = 5000

Factor         of code mod 10 = 1

Digit on       right side     = 3

Digit on       other side     = 0

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 0, 2, 3, 4, 6, 7, 8.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'Ú'

Intermediate   fit list       = Á=7, S=9, Z=5, H=1.

Remaining      digits         = 0 and 2 and 3 and 4 and 6 and 8.

Calculated     ratio          = 8

Calculated     modulus        = 100

Partial        fit            = Á=7, S=9, Z=5, H=1.

Partial        values         =                 5000 is less than 9100.

Coefficient    of 'Ú'         =                  500 is greater than 0.

Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Condensed      puzzle         = 5*HÚSZ=SZÁZ

Simplified     puzzle         = 5*HÚSZ=SZÁZ

Condensed      puzzle         = 5*HÚSZ=SZÁZ

Simplified     puzzle         = 5*HÚSZ=SZÁZ

Tried          fits           = 0

Matching       fits           = not found

Current        code is        = 'L'

Intermediate   fit list       = I=1.

Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'R'

Intermediate   fit list       = L=0, I=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'Z'

Intermediate   fit list       = R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 2

right          partial value  = 1000

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 0

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'A'

Intermediate   fit list       = Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 9.

Current        code is        = 'O'

Intermediate   fit list       = A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 3

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 5, 6, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 3

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 4, 6, 7, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=2, Z=8, A=3, O=5, Í=7, B=4, T=6, V=9, V=9, T=6, B=4, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Results of     fit            = »452+978« related to     »1630«

Values of      fit            = 1430 is less than      1630.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=2, Z=8, A=3, O=5, Í=7, B=6, T=4, V=9, V=9, T=4, B=6, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Results of     fit            = »652+978« related to     »1430«

Values of      fit            = 1630 is greater than   1430.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=2, Z=8, A=3, O=5, Í=7, B=9, T=4, V=6, V=6, T=4, B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Results of     fit            = »952+678« related to     »1430«

Values of      fit            = 1630 is greater than   1430.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=2, Z=8, A=3, O=5, Í=7, B=9, T=6, V=4, V=4, T=6, B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

Results of     fit            = »952+478« related to     »1630«

Values of      fit            = 1430 is less than      1630.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 3

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 4, 5, 7, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 3

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 4, 5, 6, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=2, Z=8, A=3, O=7, Í=5, B=4, T=6, V=9, V=9, T=6, B=4, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Results of     fit            = »472+958« related to     »1630«

Values of      fit            = 1430 is less than      1630.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=2, Z=8, A=3, O=7, Í=5, B=6, T=4, V=9, V=9, T=4, B=6, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Results of     fit            = »672+958« related to     »1430«

Values of      fit            = 1630 is greater than   1430.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=2, Z=8, A=3, O=7, Í=5, B=9, T=4, V=6, V=6, T=4, B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Results of     fit            = »972+658« related to     »1430«

Values of      fit            = 1630 is greater than   1430.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=2, Z=8, A=3, O=7, Í=5, B=9, T=6, V=4, V=4, T=6, B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

Results of     fit            = »972+458« related to     »1630«

Values of      fit            = 1430 is less than      1630.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=3, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 4, 5, 6, 7.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 4

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 5, 6, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 4

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 6, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 4

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 3, 5, 7, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=3, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 5.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=3, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=2, Z=8, A=4, O=6, Í=7, B=3, T=5, V=9, V=9, T=5, B=3, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Results of     fit            = »362+978« related to     »1540«

Values of      fit            = 1340 is less than      1540.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=5, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=2, Z=8, A=4, O=6, Í=7, B=5, T=3, V=9, V=9, T=3, B=5, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Results of     fit            = »562+978« related to     »1340«

Values of      fit            = 1540 is greater than   1340.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=2, Z=8, A=4, O=6, Í=7, B=9, T=3, V=5, V=5, T=3, B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Results of     fit            = »962+578« related to     »1340«

Values of      fit            = 1540 is greater than   1340.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3.

Tried          fit            = L=0, R=2, Z=8, A=4, O=6, Í=7, B=9, T=5, V=3, V=3, T=5, B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

Results of     fit            = »962+378« related to     »1540«

Values of      fit            = 1340 is less than      1540.

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 4

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 5, 6, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=3, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 5.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=3, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=2, Z=8, A=4, O=7, Í=6, B=3, T=5, V=9, V=9, T=5, B=3, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Results of     fit            = »372+968« related to     »1540«

Values of      fit            = 1340 is less than      1540.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=5, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=2, Z=8, A=4, O=7, Í=6, B=5, T=3, V=9, V=9, T=3, B=5, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Results of     fit            = »572+968« related to     »1340«

Values of      fit            = 1540 is greater than   1340.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=2, Z=8, A=4, O=7, Í=6, B=9, T=3, V=5, V=5, T=3, B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Results of     fit            = »972+568« related to     »1340«

Values of      fit            = 1540 is greater than   1340.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3.

Tried          fit            = L=0, R=2, Z=8, A=4, O=7, Í=6, B=9, T=5, V=3, V=3, T=5, B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

Results of     fit            = »972+368« related to     »1540«

Values of      fit            = 1340 is less than      1540.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=4, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 5, 6, 7.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=5, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=5, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 5

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 4, 6, 7, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=5, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 5

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 3, 6, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=5, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 5

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 4, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=5, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 5

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 3, 4, 6, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=5, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 3, 4, 6, 7.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=6, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=6, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 6

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 4, 5, 7, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=6, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 6

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 3, 5, 7, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=6, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 6

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 3, 4, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=6, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 6

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 4, 5, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=6, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 4, 5, 7.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=7, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=7, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 7

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 4, 5, 6, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=7, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 7

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 5, 6, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=7, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 7

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 3, 4, 6, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=7, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 7

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 3, 4, 5, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=7, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 3, 4, 5, 6.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 9

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 4, 5, 6, 7.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6 and 7.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=4, T=6, V=7, V=7, T=6, B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »432+758« related to     »1690«

Values of      fit            = 1190 is less than      1690.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=4, T=7, V=6, V=6, T=7, B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »432+658« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=6, T=4, V=7, V=7, T=4, B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »632+758« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=6, T=7, V=4, V=4, T=7, B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »632+458« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=7, T=4, V=6, V=6, T=4, B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »732+658« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=7, T=6, V=4, V=4, T=6, B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »732+458« related to     »1690«

Values of      fit            = 1190 is less than      1690.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 9

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 5, 6, 7.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 9

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 3, 4, 6, 7.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6 and 7.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=4, T=6, V=7, V=7, T=6, B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »452+738« related to     »1690«

Values of      fit            = 1190 is less than      1690.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=4, T=7, V=6, V=6, T=7, B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »452+638« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=6, T=4, V=7, V=7, T=4, B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »652+738« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=6, T=7, V=4, V=4, T=7, B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »652+438« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=7, T=4, V=6, V=6, T=4, B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »752+638« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=7, T=6, V=4, V=4, T=6, B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

Results of     fit            = »752+438« related to     »1690«

Values of      fit            = 1190 is less than      1690.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 9

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 4, 5, 7.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=9, Z=8, R=2, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 9

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 3, 4, 5, 6.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Z'

Intermediate   fit list       = R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 3

right          partial value  = 1000

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 0

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 4, 5, 6, 7, 8, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'A'

Intermediate   fit list       = Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6 and 8 and 9.

Current        code is        = 'O'

Intermediate   fit list       = A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 2

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 5, 6, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 2

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 4, 6, 8, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 8 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 8.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=4, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=2, O=5, Í=6, B=4, T=8, V=9, V=9, T=8, B=4, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Results of     fit            = »453+967« related to     »1820«

Values of      fit            = 1420 is less than      1820.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=8, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=2, O=5, Í=6, B=8, T=4, V=9, V=9, T=4, B=8, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Results of     fit            = »853+967« related to     »1420«

Values of      fit            = 1820 is greater than   1420.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=3, Z=7, A=2, O=5, Í=6, B=9, T=4, V=8, V=8, T=4, B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Results of     fit            = »953+867« related to     »1420«

Values of      fit            = 1820 is greater than   1420.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=2, O=5, Í=6, B=9, T=8, V=4, V=4, T=8, B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

Results of     fit            = »953+467« related to     »1820«

Values of      fit            = 1420 is less than      1820.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 2

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 4, 5, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 8 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 8.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=4, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=2, O=6, Í=5, B=4, T=8, V=9, V=9, T=8, B=4, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Results of     fit            = »463+957« related to     »1820«

Values of      fit            = 1420 is less than      1820.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=8, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=2, O=6, Í=5, B=8, T=4, V=9, V=9, T=4, B=8, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Results of     fit            = »863+957« related to     »1420«

Values of      fit            = 1820 is greater than   1420.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=3, Z=7, A=2, O=6, Í=5, B=9, T=4, V=8, V=8, T=4, B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Results of     fit            = »963+857« related to     »1420«

Values of      fit            = 1820 is greater than   1420.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=2, O=6, Í=5, B=9, T=8, V=4, V=4, T=8, B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

Results of     fit            = »963+457« related to     »1820«

Values of      fit            = 1420 is less than      1820.

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 2

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 4, 5, 6, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=2, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 4, 5, 6, 8.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 4

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 5, 6, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 4

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 6, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=2, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=4, O=5, Í=8, B=2, T=6, V=9, V=9, T=6, B=2, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Results of     fit            = »253+987« related to     »1640«

Values of      fit            = 1240 is less than      1640.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=6, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=4, O=5, Í=8, B=6, T=2, V=9, V=9, T=2, B=6, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Results of     fit            = »653+987« related to     »1240«

Values of      fit            = 1640 is greater than   1240.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=3, Z=7, A=4, O=5, Í=8, B=9, T=2, V=6, V=6, T=2, B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Results of     fit            = »953+687« related to     »1240«

Values of      fit            = 1640 is greater than   1240.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=3, Z=7, A=4, O=5, Í=8, B=9, T=6, V=2, V=2, T=6, B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

Results of     fit            = »953+287« related to     »1640«

Values of      fit            = 1240 is less than      1640.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 4

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 5, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 4

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 5, 6, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=2, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=4, O=8, Í=5, B=2, T=6, V=9, V=9, T=6, B=2, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Results of     fit            = »283+957« related to     »1640«

Values of      fit            = 1240 is less than      1640.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=6, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=4, O=8, Í=5, B=6, T=2, V=9, V=9, T=2, B=6, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Results of     fit            = »683+957« related to     »1240«

Values of      fit            = 1640 is greater than   1240.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=3, Z=7, A=4, O=8, Í=5, B=9, T=2, V=6, V=6, T=2, B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Results of     fit            = »983+657« related to     »1240«

Values of      fit            = 1640 is greater than   1240.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=3, Z=7, A=4, O=8, Í=5, B=9, T=6, V=2, V=2, T=6, B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

Results of     fit            = »983+257« related to     »1640«

Values of      fit            = 1240 is less than      1640.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=4, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 5, 6, 8.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 5

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 4, 6, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 5

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 6, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 5

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 4, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=2, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=5, O=6, Í=8, B=2, T=4, V=9, V=9, T=4, B=2, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Results of     fit            = »263+987« related to     »1450«

Values of      fit            = 1250 is less than      1450.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=4, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=5, O=6, Í=8, B=4, T=2, V=9, V=9, T=2, B=4, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Results of     fit            = »463+987« related to     »1250«

Values of      fit            = 1450 is greater than   1250.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=5, O=6, Í=8, B=9, T=2, V=4, V=4, T=2, B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Results of     fit            = »963+487« related to     »1250«

Values of      fit            = 1450 is greater than   1250.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=3, Z=7, A=5, O=6, Í=8, B=9, T=4, V=2, V=2, T=4, B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

Results of     fit            = »963+287« related to     »1450«

Values of      fit            = 1250 is less than      1450.

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 5

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 4, 6, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=2, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=5, O=8, Í=6, B=2, T=4, V=9, V=9, T=4, B=2, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Results of     fit            = »283+967« related to     »1450«

Values of      fit            = 1250 is less than      1450.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=4, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=5, O=8, Í=6, B=4, T=2, V=9, V=9, T=2, B=4, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Results of     fit            = »483+967« related to     »1250«

Values of      fit            = 1450 is greater than   1250.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=5, O=8, Í=6, B=9, T=2, V=4, V=4, T=2, B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Results of     fit            = »983+467« related to     »1250«

Values of      fit            = 1450 is greater than   1250.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=3, Z=7, A=5, O=8, Í=6, B=9, T=4, V=2, V=2, T=4, B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

Results of     fit            = »983+267« related to     »1450«

Values of      fit            = 1250 is less than      1450.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=5, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 4, 6, 8.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=6, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=6, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 6

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 4, 5, 8, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=6, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 6

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 5, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=6, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 6

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 4, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=6, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 6

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 4, 5, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=6, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 4, 5, 8.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 8

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 4, 5, 6, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=8, O=2, Í=5, B=4, T=6, V=9, V=9, T=6, B=4, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Results of     fit            = »423+957« related to     »1680«

Values of      fit            = 1380 is less than      1680.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=8, O=2, Í=5, B=6, T=4, V=9, V=9, T=4, B=6, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Results of     fit            = »623+957« related to     »1480«

Values of      fit            = 1580 is greater than   1480.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=3, Z=7, A=8, O=2, Í=5, B=9, T=4, V=6, V=6, T=4, B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Results of     fit            = »923+657« related to     »1480«

Values of      fit            = 1580 is greater than   1480.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=8, O=2, Í=5, B=9, T=6, V=4, V=4, T=6, B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

Results of     fit            = »923+457« related to     »1680«

Values of      fit            = 1380 is less than      1680.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 8

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 5, 6, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 8

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 4, 6, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=8, O=5, Í=2, B=4, T=6, V=9, V=9, T=6, B=4, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Results of     fit            = »453+927« related to     »1680«

Values of      fit            = 1380 is less than      1680.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=3, Z=7, A=8, O=5, Í=2, B=6, T=4, V=9, V=9, T=4, B=6, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Results of     fit            = »653+927« related to     »1480«

Values of      fit            = 1580 is greater than   1480.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=3, Z=7, A=8, O=5, Í=2, B=9, T=4, V=6, V=6, T=4, B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Results of     fit            = »953+627« related to     »1480«

Values of      fit            = 1580 is greater than   1480.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=8, O=5, Í=2, B=9, T=6, V=4, V=4, T=6, B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

Results of     fit            = »953+427« related to     »1680«

Values of      fit            = 1380 is less than      1680.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 8

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 4, 5, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=8, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 4, 5, 6.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6 and 8.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 9

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 4, 5, 6, 8.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5 and 8.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=4, T=5, V=8, V=8, T=5, B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »423+867« related to     »1590«

Values of      fit            = 1290 is less than      1590.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=4, T=8, V=5, V=5, T=8, B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »423+567« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=5, T=4, V=8, V=8, T=4, B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »523+867« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=5, T=8, V=4, V=4, T=8, B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »523+467« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=8, T=4, V=5, V=5, T=4, B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »823+567« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=8, T=5, V=4, V=4, T=5, B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »823+467« related to     »1590«

Values of      fit            = 1290 is less than      1590.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 9

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 5, 6, 8.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 9

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 4, 6, 8.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 9

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 4, 5, 8.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5 and 8.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=4, T=5, V=8, V=8, T=5, B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »463+827« related to     »1590«

Values of      fit            = 1290 is less than      1590.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=4, T=8, V=5, V=5, T=8, B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »463+527« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=5, T=4, V=8, V=8, T=4, B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »563+827« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=5, T=8, V=4, V=4, T=8, B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »563+427« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4 and 5.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=8, T=4, V=5, V=5, T=4, B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »863+527« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=8, T=5, V=4, V=4, T=5, B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

Results of     fit            = »863+427« related to     »1590«

Values of      fit            = 1290 is less than      1590.

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=9, Z=7, R=3, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 9

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 4, 5, 6.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Z'

Intermediate   fit list       = R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 4

right          partial value  = 1000

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 0

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 5, 6, 7, 8, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'A'

Intermediate   fit list       = Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7 and 8 and 9.

Current        code is        = 'O'

Intermediate   fit list       = A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 2

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 5, 7, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5 and 7 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=5, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=2, O=3, Í=8, B=5, T=7, V=9, V=9, T=7, B=5, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Results of     fit            = »534+986« related to     »1720«

Values of      fit            = 1520 is less than      1720.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=7, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=2, O=3, Í=8, B=7, T=5, V=9, V=9, T=5, B=7, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Results of     fit            = »734+986« related to     »1520«

Values of      fit            = 1720 is greater than   1520.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=4, Z=6, A=2, O=3, Í=8, B=9, T=5, V=7, V=7, T=5, B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Results of     fit            = »934+786« related to     »1520«

Values of      fit            = 1720 is greater than   1520.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=4, Z=6, A=2, O=3, Í=8, B=9, T=7, V=5, V=5, T=7, B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

Results of     fit            = »934+586« related to     »1720«

Values of      fit            = 1520 is less than      1720.

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 2

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 7, 8, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 2

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 5, 8, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 2

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 3, 5, 7, 9.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5 and 7 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=5, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=2, O=8, Í=3, B=5, T=7, V=9, V=9, T=7, B=5, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Results of     fit            = »584+936« related to     »1720«

Values of      fit            = 1520 is less than      1720.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=7, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=2, O=8, Í=3, B=7, T=5, V=9, V=9, T=5, B=7, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Results of     fit            = »784+936« related to     »1520«

Values of      fit            = 1720 is greater than   1520.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=4, Z=6, A=2, O=8, Í=3, B=9, T=5, V=7, V=7, T=5, B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Results of     fit            = »984+736« related to     »1520«

Values of      fit            = 1720 is greater than   1520.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=4, Z=6, A=2, O=8, Í=3, B=9, T=7, V=5, V=5, T=7, B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

Results of     fit            = »984+536« related to     »1720«

Values of      fit            = 1520 is less than      1720.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=2, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 5, 7, 8.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 3

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 5, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 3

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 7, 8, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 8 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 8.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=2, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=3, O=5, Í=7, B=2, T=8, V=9, V=9, T=8, B=2, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Results of     fit            = »254+976« related to     »1830«

Values of      fit            = 1230 is less than      1830.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=8, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=3, O=5, Í=7, B=8, T=2, V=9, V=9, T=2, B=8, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Results of     fit            = »854+976« related to     »1230«

Values of      fit            = 1830 is greater than   1230.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=4, Z=6, A=3, O=5, Í=7, B=9, T=2, V=8, V=8, T=2, B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Results of     fit            = »954+876« related to     »1230«

Values of      fit            = 1830 is greater than   1230.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=4, Z=6, A=3, O=5, Í=7, B=9, T=8, V=2, V=2, T=8, B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

Results of     fit            = »954+276« related to     »1830«

Values of      fit            = 1230 is less than      1830.

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 3

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 5, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 8 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 8.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=2, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=3, O=7, Í=5, B=2, T=8, V=9, V=9, T=8, B=2, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Results of     fit            = »274+956« related to     »1830«

Values of      fit            = 1230 is less than      1830.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=8, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=3, O=7, Í=5, B=8, T=2, V=9, V=9, T=2, B=8, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Results of     fit            = »874+956« related to     »1230«

Values of      fit            = 1830 is greater than   1230.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=4, Z=6, A=3, O=7, Í=5, B=9, T=2, V=8, V=8, T=2, B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Results of     fit            = »974+856« related to     »1230«

Values of      fit            = 1830 is greater than   1230.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=4, Z=6, A=3, O=7, Í=5, B=9, T=8, V=2, V=2, T=8, B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

Results of     fit            = »974+256« related to     »1830«

Values of      fit            = 1230 is less than      1830.

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 3

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 5, 7, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=3, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 5, 7, 8.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=5, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=5, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 5

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=5, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 5

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=5, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 5

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=5, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 5

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 7, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=5, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 7, 8.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=7, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=7, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 7

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 5, 8, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=7, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 7

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 5, 8, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=7, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 7

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 3, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=7, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 7

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 5, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=7, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 5, 8.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 8

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 3, 5, 7, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 7 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=3, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=3, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=8, O=2, Í=5, B=3, T=7, V=9, V=9, T=7, B=3, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Results of     fit            = »324+956« related to     »1780«

Values of      fit            = 1280 is less than      1780.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=7, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=8, O=2, Í=5, B=7, T=3, V=9, V=9, T=3, B=7, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Results of     fit            = »724+956« related to     »1380«

Values of      fit            = 1680 is greater than   1380.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=4, Z=6, A=8, O=2, Í=5, B=9, T=3, V=7, V=7, T=3, B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Results of     fit            = »924+756« related to     »1380«

Values of      fit            = 1680 is greater than   1380.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3.

Tried          fit            = L=0, R=4, Z=6, A=8, O=2, Í=5, B=9, T=7, V=3, V=3, T=7, B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

Results of     fit            = »924+356« related to     »1780«

Values of      fit            = 1280 is less than      1780.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 8

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 5, 7, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 8

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 3, 7, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 7 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=3, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=3, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=8, O=5, Í=2, B=3, T=7, V=9, V=9, T=7, B=3, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Results of     fit            = »354+926« related to     »1780«

Values of      fit            = 1280 is less than      1780.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=7, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=4, Z=6, A=8, O=5, Í=2, B=7, T=3, V=9, V=9, T=3, B=7, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Results of     fit            = »754+926« related to     »1380«

Values of      fit            = 1680 is greater than   1380.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=4, Z=6, A=8, O=5, Í=2, B=9, T=3, V=7, V=7, T=3, B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Results of     fit            = »954+726« related to     »1380«

Values of      fit            = 1680 is greater than   1380.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3.

Tried          fit            = L=0, R=4, Z=6, A=8, O=5, Í=2, B=9, T=7, V=3, V=3, T=7, B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

Results of     fit            = »954+326« related to     »1780«

Values of      fit            = 1280 is less than      1780.

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 8

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 5, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=8, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 5, 7.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7 and 8.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 9

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 5, 7, 8.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 9

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 5, 7, 8.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 7 and 8.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=2, T=7, V=8, V=8, T=7, B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »234+856« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=2, T=8, V=7, V=7, T=8, B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »234+756« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=7, T=2, V=8, V=8, T=2, B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »734+856« related to     »1290«

Values of      fit            = 1590 is greater than   1290.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=7, T=8, V=2, V=2, T=8, B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »734+256« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=8, T=2, V=7, V=7, T=2, B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »834+756« related to     »1290«

Values of      fit            = 1590 is greater than   1290.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=8, T=7, V=2, V=2, T=7, B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »834+256« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 9

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 3, 7, 8.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 7 and 8.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=2, T=7, V=8, V=8, T=7, B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »254+836« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=2, T=8, V=7, V=7, T=8, B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »254+736« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=7, T=2, V=8, V=8, T=2, B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »754+836« related to     »1290«

Values of      fit            = 1590 is greater than   1290.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=7, T=8, V=2, V=2, T=8, B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »754+236« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=8, T=2, V=7, V=7, T=2, B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »854+736« related to     »1290«

Values of      fit            = 1590 is greater than   1290.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=8, T=7, V=2, V=2, T=7, B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

Results of     fit            = »854+236« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 9

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 3, 5, 8.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=9, Z=6, R=4, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 9

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 5, 7.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Z'

Intermediate   fit list       = R=5, L=0, I=1.

Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 5

right          partial value  = 1000

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 0

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Z'

Intermediate   fit list       = R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 6

right          partial value  = 1000

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 0

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'A'

Intermediate   fit list       = Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7 and 8 and 9.

Current        code is        = 'O'

Intermediate   fit list       = A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 2

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 5, 7, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5 and 7 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=5, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=2, O=3, Í=8, B=5, T=7, V=9, V=9, T=7, B=5, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Results of     fit            = »536+984« related to     »1720«

Values of      fit            = 1520 is less than      1720.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=7, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=2, O=3, Í=8, B=7, T=5, V=9, V=9, T=5, B=7, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Results of     fit            = »736+984« related to     »1520«

Values of      fit            = 1720 is greater than   1520.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=6, Z=4, A=2, O=3, Í=8, B=9, T=5, V=7, V=7, T=5, B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Results of     fit            = »936+784« related to     »1520«

Values of      fit            = 1720 is greater than   1520.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=6, Z=4, A=2, O=3, Í=8, B=9, T=7, V=5, V=5, T=7, B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

Results of     fit            = »936+584« related to     »1720«

Values of      fit            = 1520 is less than      1720.

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 2

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 7, 8, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 2

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 5, 8, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 2

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 3, 5, 7, 9.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5 and 7 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=5, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=2, O=8, Í=3, B=5, T=7, V=9, V=9, T=7, B=5, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Results of     fit            = »586+934« related to     »1720«

Values of      fit            = 1520 is less than      1720.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=7, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=2, O=8, Í=3, B=7, T=5, V=9, V=9, T=5, B=7, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Results of     fit            = »786+934« related to     »1520«

Values of      fit            = 1720 is greater than   1520.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=6, Z=4, A=2, O=8, Í=3, B=9, T=5, V=7, V=7, T=5, B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Results of     fit            = »986+734« related to     »1520«

Values of      fit            = 1720 is greater than   1520.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=6, Z=4, A=2, O=8, Í=3, B=9, T=7, V=5, V=5, T=7, B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

Results of     fit            = »986+534« related to     »1720«

Values of      fit            = 1520 is less than      1720.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=2, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 5, 7, 8.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 5 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 3

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 5, 7, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 3

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 7, 8, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 8 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 8.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=2, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=3, O=5, Í=7, B=2, T=8, V=9, V=9, T=8, B=2, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Results of     fit            = »256+974« related to     »1830«

Values of      fit            = 1230 is less than      1830.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=8, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=3, O=5, Í=7, B=8, T=2, V=9, V=9, T=2, B=8, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Results of     fit            = »856+974« related to     »1230«

Values of      fit            = 1830 is greater than   1230.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=6, Z=4, A=3, O=5, Í=7, B=9, T=2, V=8, V=8, T=2, B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Results of     fit            = »956+874« related to     »1230«

Values of      fit            = 1830 is greater than   1230.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=6, Z=4, A=3, O=5, Í=7, B=9, T=8, V=2, V=2, T=8, B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

Results of     fit            = »956+274« related to     »1830«

Values of      fit            = 1230 is less than      1830.

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 3

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 5, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 8 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 8.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=2, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=3, O=7, Í=5, B=2, T=8, V=9, V=9, T=8, B=2, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Results of     fit            = »276+954« related to     »1830«

Values of      fit            = 1230 is less than      1830.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=8, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=3, O=7, Í=5, B=8, T=2, V=9, V=9, T=2, B=8, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Results of     fit            = »876+954« related to     »1230«

Values of      fit            = 1830 is greater than   1230.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=6, Z=4, A=3, O=7, Í=5, B=9, T=2, V=8, V=8, T=2, B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Results of     fit            = »976+854« related to     »1230«

Values of      fit            = 1830 is greater than   1230.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=6, Z=4, A=3, O=7, Í=5, B=9, T=8, V=2, V=2, T=8, B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

Results of     fit            = »976+254« related to     »1830«

Values of      fit            = 1230 is less than      1830.

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 3

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 5, 7, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=3, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 5, 7, 8.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=5, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=5, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 5

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=5, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 7 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 5

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=5, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 5

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=5, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 5

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 7, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=5, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 7, 8.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=7, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=7, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 7

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 5, 8, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=7, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 7

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 5, 8, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=7, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 7

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 3, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=7, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 7

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 5, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=7, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 3, 5, 8.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 8

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 3, 5, 7, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 7 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=3, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=3, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=8, O=2, Í=5, B=3, T=7, V=9, V=9, T=7, B=3, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Results of     fit            = »326+954« related to     »1780«

Values of      fit            = 1280 is less than      1780.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=7, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=8, O=2, Í=5, B=7, T=3, V=9, V=9, T=3, B=7, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Results of     fit            = »726+954« related to     »1380«

Values of      fit            = 1680 is greater than   1380.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=6, Z=4, A=8, O=2, Í=5, B=9, T=3, V=7, V=7, T=3, B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Results of     fit            = »926+754« related to     »1380«

Values of      fit            = 1680 is greater than   1380.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3.

Tried          fit            = L=0, R=6, Z=4, A=8, O=2, Í=5, B=9, T=7, V=3, V=3, T=7, B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

Results of     fit            = »926+354« related to     »1780«

Values of      fit            = 1280 is less than      1780.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 8

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 5, 7, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 8

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 3, 7, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 7 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=3, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=3, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=8, O=5, Í=2, B=3, T=7, V=9, V=9, T=7, B=3, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Results of     fit            = »356+924« related to     »1780«

Values of      fit            = 1280 is less than      1780.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=7, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=6, Z=4, A=8, O=5, Í=2, B=7, T=3, V=9, V=9, T=3, B=7, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Results of     fit            = »756+924« related to     »1380«

Values of      fit            = 1680 is greater than   1380.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=6, Z=4, A=8, O=5, Í=2, B=9, T=3, V=7, V=7, T=3, B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Results of     fit            = »956+724« related to     »1380«

Values of      fit            = 1680 is greater than   1380.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3.

Tried          fit            = L=0, R=6, Z=4, A=8, O=5, Í=2, B=9, T=7, V=3, V=3, T=7, B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

Results of     fit            = »956+324« related to     »1780«

Values of      fit            = 1280 is less than      1780.

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 8

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 5, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=8, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 5, 7.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7 and 8.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 9

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 5, 7, 8.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 5 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 9

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 5, 7, 8.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 7 and 8.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=2, T=7, V=8, V=8, T=7, B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »236+854« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=2, T=8, V=7, V=7, T=8, B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »236+754« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=7, T=2, V=8, V=8, T=2, B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »736+854« related to     »1290«

Values of      fit            = 1590 is greater than   1290.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=7, T=8, V=2, V=2, T=8, B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »736+254« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=8, T=2, V=7, V=7, T=2, B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »836+754« related to     »1290«

Values of      fit            = 1590 is greater than   1290.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=8, T=7, V=2, V=2, T=7, B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »836+254« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 9

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 3, 7, 8.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 7 and 8.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=2, T=7, V=8, V=8, T=7, B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »256+834« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=2, T=8, V=7, V=7, T=8, B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »256+734« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=7, T=2, V=8, V=8, T=2, B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »756+834« related to     »1290«

Values of      fit            = 1590 is greater than   1290.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=7, T=8, V=2, V=2, T=8, B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »756+234« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=8, T=2, V=7, V=7, T=2, B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »856+734« related to     »1290«

Values of      fit            = 1590 is greater than   1290.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=8, T=7, V=2, V=2, T=7, B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

Results of     fit            = »856+234« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 9

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 3, 5, 8.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=9, Z=4, R=6, L=0, I=1.

Remaining      digits         = 2 and 3 and 5 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 9

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 3, 5, 7.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Z'

Intermediate   fit list       = R=7, L=0, I=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 7

right          partial value  = 1000

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 0

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'A'

Intermediate   fit list       = Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6 and 8 and 9.

Current        code is        = 'O'

Intermediate   fit list       = A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 2

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 5, 6, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 2

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 4, 6, 8, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 8 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 8.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=4, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=2, O=5, Í=6, B=4, T=8, V=9, V=9, T=8, B=4, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Results of     fit            = »457+963« related to     »1820«

Values of      fit            = 1420 is less than      1820.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=8, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=2, O=5, Í=6, B=8, T=4, V=9, V=9, T=4, B=8, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Results of     fit            = »857+963« related to     »1420«

Values of      fit            = 1820 is greater than   1420.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=7, Z=3, A=2, O=5, Í=6, B=9, T=4, V=8, V=8, T=4, B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Results of     fit            = »957+863« related to     »1420«

Values of      fit            = 1820 is greater than   1420.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=2, O=5, Í=6, B=9, T=8, V=4, V=4, T=8, B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

Results of     fit            = »957+463« related to     »1820«

Values of      fit            = 1420 is less than      1820.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 2

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 4, 5, 8, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 8 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 8.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=4, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=2, O=6, Í=5, B=4, T=8, V=9, V=9, T=8, B=4, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Results of     fit            = »467+953« related to     »1820«

Values of      fit            = 1420 is less than      1820.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=8, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=2, O=6, Í=5, B=8, T=4, V=9, V=9, T=4, B=8, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Results of     fit            = »867+953« related to     »1420«

Values of      fit            = 1820 is greater than   1420.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=7, Z=3, A=2, O=6, Í=5, B=9, T=4, V=8, V=8, T=4, B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Results of     fit            = »967+853« related to     »1420«

Values of      fit            = 1820 is greater than   1420.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=2, O=6, Í=5, B=9, T=8, V=4, V=4, T=8, B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

Results of     fit            = »967+453« related to     »1820«

Values of      fit            = 1420 is less than      1820.

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 2

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 4, 5, 6, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=2, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1020

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 4, 5, 6, 8.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 5 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 4

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 5, 6, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 4

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 6, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=2, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=4, O=5, Í=8, B=2, T=6, V=9, V=9, T=6, B=2, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Results of     fit            = »257+983« related to     »1640«

Values of      fit            = 1240 is less than      1640.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=6, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=4, O=5, Í=8, B=6, T=2, V=9, V=9, T=2, B=6, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Results of     fit            = »657+983« related to     »1240«

Values of      fit            = 1640 is greater than   1240.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=7, Z=3, A=4, O=5, Í=8, B=9, T=2, V=6, V=6, T=2, B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Results of     fit            = »957+683« related to     »1240«

Values of      fit            = 1640 is greater than   1240.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=7, Z=3, A=4, O=5, Í=8, B=9, T=6, V=2, V=2, T=6, B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

Results of     fit            = »957+283« related to     »1640«

Values of      fit            = 1240 is less than      1640.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 4

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 5, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 4

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 5, 6, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=2, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=4, O=8, Í=5, B=2, T=6, V=9, V=9, T=6, B=2, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Results of     fit            = »287+953« related to     »1640«

Values of      fit            = 1240 is less than      1640.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=6, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=4, O=8, Í=5, B=6, T=2, V=9, V=9, T=2, B=6, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Results of     fit            = »687+953« related to     »1240«

Values of      fit            = 1640 is greater than   1240.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=7, Z=3, A=4, O=8, Í=5, B=9, T=2, V=6, V=6, T=2, B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Results of     fit            = »987+653« related to     »1240«

Values of      fit            = 1640 is greater than   1240.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=7, Z=3, A=4, O=8, Í=5, B=9, T=6, V=2, V=2, T=6, B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

Results of     fit            = »987+253« related to     »1640«

Values of      fit            = 1240 is less than      1640.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=4, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 5, 6, 8.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 5

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 4, 6, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 6 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 5

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 6, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 5

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 4, 8, 9.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=2, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=5, O=6, Í=8, B=2, T=4, V=9, V=9, T=4, B=2, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Results of     fit            = »267+983« related to     »1450«

Values of      fit            = 1250 is less than      1450.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=4, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=5, O=6, Í=8, B=4, T=2, V=9, V=9, T=2, B=4, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Results of     fit            = »467+983« related to     »1250«

Values of      fit            = 1450 is greater than   1250.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=5, O=6, Í=8, B=9, T=2, V=4, V=4, T=2, B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Results of     fit            = »967+483« related to     »1250«

Values of      fit            = 1450 is greater than   1250.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=7, Z=3, A=5, O=6, Í=8, B=9, T=4, V=2, V=2, T=4, B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

Results of     fit            = »967+283« related to     »1450«

Values of      fit            = 1250 is less than      1450.

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 5

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 4, 6, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=2, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=2, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=5, O=8, Í=6, B=2, T=4, V=9, V=9, T=4, B=2, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Results of     fit            = »287+963« related to     »1450«

Values of      fit            = 1250 is less than      1450.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=4, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=5, O=8, Í=6, B=4, T=2, V=9, V=9, T=2, B=4, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Results of     fit            = »487+963« related to     »1250«

Values of      fit            = 1450 is greater than   1250.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4.

Current        code is        = 'V'

Intermediate   fit list       = T=2, B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=5, O=8, Í=6, B=9, T=2, V=4, V=4, T=2, B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Results of     fit            = »987+463« related to     »1250«

Values of      fit            = 1450 is greater than   1250.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2.

Tried          fit            = L=0, R=7, Z=3, A=5, O=8, Í=6, B=9, T=4, V=2, V=2, T=4, B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

Results of     fit            = »987+263« related to     »1450«

Values of      fit            = 1250 is less than      1450.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=5, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 4, 6, 8.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=6, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 8 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=6, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 6

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 4, 5, 8, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=6, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 5 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 6

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 5, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=6, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 8 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 6

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 4, 8, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=6, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 6

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 4, 5, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=6, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 4, 5, 8.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 8

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 4, 5, 6, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=8, O=2, Í=5, B=4, T=6, V=9, V=9, T=6, B=4, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Results of     fit            = »427+953« related to     »1680«

Values of      fit            = 1380 is less than      1680.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=8, O=2, Í=5, B=6, T=4, V=9, V=9, T=4, B=6, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Results of     fit            = »627+953« related to     »1480«

Values of      fit            = 1580 is greater than   1480.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=7, Z=3, A=8, O=2, Í=5, B=9, T=4, V=6, V=6, T=4, B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Results of     fit            = »927+653« related to     »1480«

Values of      fit            = 1580 is greater than   1480.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=8, O=2, Í=5, B=9, T=6, V=4, V=4, T=6, B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

Results of     fit            = »927+453« related to     »1680«

Values of      fit            = 1380 is less than      1680.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 8

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 5, 6, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 8

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 4, 6, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=8, O=5, Í=2, B=4, T=6, V=9, V=9, T=6, B=4, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Results of     fit            = »457+923« related to     »1680«

Values of      fit            = 1380 is less than      1680.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=7, Z=3, A=8, O=5, Í=2, B=6, T=4, V=9, V=9, T=4, B=6, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Results of     fit            = »657+923« related to     »1480«

Values of      fit            = 1580 is greater than   1480.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=7, Z=3, A=8, O=5, Í=2, B=9, T=4, V=6, V=6, T=4, B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Results of     fit            = »957+623« related to     »1480«

Values of      fit            = 1580 is greater than   1480.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=8, O=5, Í=2, B=9, T=6, V=4, V=4, T=6, B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

Results of     fit            = »957+423« related to     »1680«

Values of      fit            = 1380 is less than      1680.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 8

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 4, 5, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=8, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1080

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 4, 5, 6.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6 and 8.

Current        code is        = 'Í'

Intermediate   fit list       = O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 30

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 9

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 4, 5, 6, 8.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5 and 8.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=4, T=5, V=8, V=8, T=5, B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »427+863« related to     »1590«

Values of      fit            = 1290 is less than      1590.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=4, T=8, V=5, V=5, T=8, B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »427+563« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=5, T=4, V=8, V=8, T=4, B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »527+863« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=5, T=8, V=4, V=4, T=8, B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »527+463« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=8, T=4, V=5, V=5, T=4, B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »827+563« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=8, T=5, V=4, V=4, T=5, B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »827+463« related to     »1590«

Values of      fit            = 1290 is less than      1590.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 5 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 9

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 5, 6, 8.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 6 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 9

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 4, 6, 8.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 9

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 4, 5, 8.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5 and 8.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 5 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=4, T=5, V=8, V=8, T=5, B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »467+823« related to     »1590«

Values of      fit            = 1290 is less than      1590.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=4, T=8, V=5, V=5, T=8, B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »467+523« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 8.

Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=5, T=4, V=8, V=8, T=4, B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »567+823« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=5, T=8, V=4, V=4, T=8, B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »567+423« related to     »1890«

Values of      fit            = 990 is less than      1890.

Current        code is        = 'T'

Intermediate   fit list       = B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4 and 5.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=8, T=4, V=5, V=5, T=4, B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »867+523« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=8, T=5, V=4, V=4, T=5, B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

Results of     fit            = »867+423« related to     »1590«

Values of      fit            = 1290 is less than      1590.

Current        code is        = 'Í'

Intermediate   fit list       = O=8, A=9, Z=3, R=7, L=0, I=1.

Remaining      digits         = 2 and 4 and 5 and 6.

Rightmost      place of 'Í'   = 1

left           partial value  = 90

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 9

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 2, 4, 5, 6.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Z'

Intermediate   fit list       = R=8, L=0, I=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 8

right          partial value  = 1000

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 0

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'A'

Intermediate   fit list       = Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 9.

Current        code is        = 'O'

Intermediate   fit list       = A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 3

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 5, 6, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 3

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 4, 6, 7, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=8, Z=2, A=3, O=5, Í=7, B=4, T=6, V=9, V=9, T=6, B=4, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Results of     fit            = »458+972« related to     »1630«

Values of      fit            = 1430 is less than      1630.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=8, Z=2, A=3, O=5, Í=7, B=6, T=4, V=9, V=9, T=4, B=6, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Results of     fit            = »658+972« related to     »1430«

Values of      fit            = 1630 is greater than   1430.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=8, Z=2, A=3, O=5, Í=7, B=9, T=4, V=6, V=6, T=4, B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Results of     fit            = »958+672« related to     »1430«

Values of      fit            = 1630 is greater than   1430.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=8, Z=2, A=3, O=5, Í=7, B=9, T=6, V=4, V=4, T=6, B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

Results of     fit            = »958+472« related to     »1630«

Values of      fit            = 1430 is less than      1630.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 3

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 4, 5, 7, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 3

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 4, 5, 6, 9.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=8, Z=2, A=3, O=7, Í=5, B=4, T=6, V=9, V=9, T=6, B=4, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Results of     fit            = »478+952« related to     »1630«

Values of      fit            = 1430 is less than      1630.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=8, Z=2, A=3, O=7, Í=5, B=6, T=4, V=9, V=9, T=4, B=6, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Results of     fit            = »678+952« related to     »1430«

Values of      fit            = 1630 is greater than   1430.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=8, Z=2, A=3, O=7, Í=5, B=9, T=4, V=6, V=6, T=4, B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Results of     fit            = »978+652« related to     »1430«

Values of      fit            = 1630 is greater than   1430.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=8, Z=2, A=3, O=7, Í=5, B=9, T=6, V=4, V=4, T=6, B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

Results of     fit            = »978+452« related to     »1630«

Values of      fit            = 1430 is less than      1630.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=3, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1030

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 4, 5, 6, 7.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 5 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 4

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 5, 6, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 4

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 6, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 4

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 3, 5, 7, 9.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=3, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 5.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=3, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=8, Z=2, A=4, O=6, Í=7, B=3, T=5, V=9, V=9, T=5, B=3, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Results of     fit            = »368+972« related to     »1540«

Values of      fit            = 1340 is less than      1540.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=5, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=8, Z=2, A=4, O=6, Í=7, B=5, T=3, V=9, V=9, T=3, B=5, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Results of     fit            = »568+972« related to     »1340«

Values of      fit            = 1540 is greater than   1340.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=8, Z=2, A=4, O=6, Í=7, B=9, T=3, V=5, V=5, T=3, B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Results of     fit            = »968+572« related to     »1340«

Values of      fit            = 1540 is greater than   1340.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3.

Tried          fit            = L=0, R=8, Z=2, A=4, O=6, Í=7, B=9, T=5, V=3, V=3, T=5, B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

Results of     fit            = »968+372« related to     »1540«

Values of      fit            = 1340 is less than      1540.

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 4

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 5, 6, 9.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5 and 9.

Current        code is        = 'T'

Intermediate   fit list       = B=3, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 5.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=3, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=8, Z=2, A=4, O=7, Í=6, B=3, T=5, V=9, V=9, T=5, B=3, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Results of     fit            = »378+962« related to     »1540«

Values of      fit            = 1340 is less than      1540.

Current        code is        = 'T'

Intermediate   fit list       = B=5, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=5, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 9.

Tried          fit            = L=0, R=8, Z=2, A=4, O=7, Í=6, B=5, T=3, V=9, V=9, T=3, B=5, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Results of     fit            = »578+962« related to     »1340«

Values of      fit            = 1540 is greater than   1340.

Current        code is        = 'T'

Intermediate   fit list       = B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5.

Current        code is        = 'V'

Intermediate   fit list       = T=3, B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 5.

Tried          fit            = L=0, R=8, Z=2, A=4, O=7, Í=6, B=9, T=3, V=5, V=5, T=3, B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Results of     fit            = »978+562« related to     »1340«

Values of      fit            = 1540 is greater than   1340.

Current        code is        = 'V'

Intermediate   fit list       = T=5, B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3.

Tried          fit            = L=0, R=8, Z=2, A=4, O=7, Í=6, B=9, T=5, V=3, V=3, T=5, B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

Results of     fit            = »978+362« related to     »1540«

Values of      fit            = 1340 is less than      1540.

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=4, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1040

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 5, 6, 7.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=5, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=5, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 5

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 4, 6, 7, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=5, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 6 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 5

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 3, 6, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=5, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 5

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 4, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=5, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 5

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 3, 4, 6, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=5, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1050

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 3, 4, 6, 7.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=6, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 7 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=6, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 6

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 4, 5, 7, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=6, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 6

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 3, 5, 7, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=6, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 7 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 6

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 3, 4, 7, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=6, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 6

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 4, 5, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=6, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1060

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 4, 5, 7.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=7, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 9.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=7, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 7

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 4, 5, 6, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=7, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 7

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 5, 6, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=7, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 7

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 3, 4, 6, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=7, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 9.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 7

Product        mod 10         = 0

Possible       multipliers    = 0.

Remaining      digits         = 3, 4, 5, 9.

Possible       digits         = 0.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=9, A=7, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6.

Rightmost      place of 'Í'   = 1

left           partial value  = 100

right          partial value  = 1070

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 3, 4, 5, 6.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'O'

Intermediate   fit list       = A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7.

Current        code is        = 'Í'

Intermediate   fit list       = O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 40

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 9

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 4, 5, 6, 7.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6 and 7.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=4, T=6, V=7, V=7, T=6, B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »438+752« related to     »1690«

Values of      fit            = 1190 is less than      1690.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=4, T=7, V=6, V=6, T=7, B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »438+652« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=6, T=4, V=7, V=7, T=4, B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »638+752« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=6, T=7, V=4, V=4, T=7, B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »638+452« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=7, T=4, V=6, V=6, T=4, B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »738+652« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=7, T=6, V=4, V=4, T=6, B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »738+452« related to     »1690«

Values of      fit            = 1190 is less than      1690.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 5 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 50

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 9

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 5, 6, 7.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 6 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 60

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 9

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 3, 4, 6, 7.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6 and 7.

Current        code is        = 'T'

Intermediate   fit list       = B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=4, T=6, V=7, V=7, T=6, B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »458+732« related to     »1690«

Values of      fit            = 1190 is less than      1690.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=4, T=7, V=6, V=6, T=7, B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »458+632« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 7.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 7.

Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=6, T=4, V=7, V=7, T=4, B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »658+732« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=6, T=7, V=4, V=4, T=7, B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »658+432« related to     »1790«

Values of      fit            = 1090 is less than      1790.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4 and 6.

Current        code is        = 'V'

Intermediate   fit list       = T=4, B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 6.

Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=7, T=4, V=6, V=6, T=4, B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »758+632« related to     »1490«

Values of      fit            = 1390 is less than      1490.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 4.

Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=7, T=6, V=4, V=4, T=6, B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

Results of     fit            = »758+432« related to     »1690«

Values of      fit            = 1190 is less than      1690.

Current        code is        = 'Í'

Intermediate   fit list       = O=6, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 7.

Rightmost      place of 'Í'   = 1

left           partial value  = 70

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 9

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 4, 5, 7.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Í'

Intermediate   fit list       = O=7, A=9, Z=2, R=8, L=0, I=1.

Remaining      digits         = 3 and 4 and 5 and 6.

Rightmost      place of 'Í'   = 1

left           partial value  = 80

right          partial value  = 1090

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 9

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 3, 4, 5, 6.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Z'

Intermediate   fit list       = R=9, L=0, I=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Z'   = 0

left           partial value  = 9

right          partial value  = 1000

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 0

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'R'

Intermediate   fit list       = L=2, I=1.

Remaining      digits         = 0 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'Z'

Intermediate   fit list       = R=0, L=2, I=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 0

right          partial value  = 1002

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 2

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Z'

Intermediate   fit list       = R=3, L=2, I=1.

Remaining      digits         = 0 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'Z'   = 0

left           partial value  = 3

right          partial value  = 1002

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 2

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 0, 4, 5, 6, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'A'

Intermediate   fit list       = Z=9, R=3, L=2, I=1.

Remaining      digits         = 0 and 4 and 5 and 6 and 7 and 8.

Current        code is        = 'O'

Intermediate   fit list       = A=0, Z=9, R=3, L=2, I=1.

Remaining      digits         = 4 and 5 and 6 and 7 and 8.

Current        code is        = 'Í'

Intermediate   fit list       = O=4, A=0, Z=9, R=3, L=2, I=1.

Remaining      digits         = 5 and 6 and 7 and 8.

Rightmost      place of 'Í'   = 1

left           partial value  = 52

right          partial value  = 1002

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 0

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 5, 6, 7, 8.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'B'

Intermediate   fit list       = Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Remaining      digits         = 6 and 7 and 8.

Current        code is        = 'T'

Intermediate   fit list       = B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Remaining      digits         = 7 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=7, B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Remaining      digits         = 8.

Tried          fit            = L=2, R=3, Z=9, A=0, O=4, Í=5, B=6, T=7, V=8, V=8, T=7, B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Results of     fit            = »643+859« related to     »1702«

Values of      fit            = 1502 is less than      1702.

Current        code is        = 'V'

Intermediate   fit list       = T=8, B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Remaining      digits         = 7.

Tried          fit            = L=2, R=3, Z=9, A=0, O=4, Í=5, B=6, T=8, V=7, V=7, T=8, B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Results of     fit            = »643+759« related to     »1802«

Values of      fit            = 1402 is less than      1802.

Current        code is        = 'T'

Intermediate   fit list       = B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Remaining      digits         = 6 and 8.

Current        code is        = 'V'

Intermediate   fit list       = T=6, B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Remaining      digits         = 8.

Tried          fit            = L=2, R=3, Z=9, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Results of     fit            = »743+859« related to     »1602«

Values of      fit            = 1602 is equal to       1602.

Condensed      puzzle         = VÍZ+BOR=ITAL

Simplified     puzzle         = BOR+VÍZ=ITAL

Condensed      puzzle         = VÍZ+BOR=ITAL

Simplified     puzzle         = BOR+VÍZ=ITAL

Tried          fits           = 219

Matching       fits found     = 1

Start of fit lists and results:

Solution       #              = 1

Solution       fitted         = L=2, R=3, Z=9, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

Solution       got            = 743+859=1602

End of fit lists and results.

Current        code is        = 'A'

Intermediate   fit list       = empty.

Remaining      digits         = 0 and 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'T'

Intermediate   fit list       = A=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'S'

Intermediate   fit list       = T=1, A=0.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'S'   = 0

left           partial value  = 99

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 9

Digit on       other side     = 0

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'S'

Intermediate   fit list       = T=2, A=0.

Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'S'   = 0

left           partial value  = 198

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 8

Digit on       other side     = 0

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 1, 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'S'

Intermediate   fit list       = T=3, A=0.

Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'S'   = 0

left           partial value  = 297

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 7

Digit on       other side     = 0

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 1, 2, 4, 5, 6, 7, 8, 9.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'S'

Intermediate   fit list       = T=4, A=0.

Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'S'   = 0

left           partial value  = 396

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 0

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 1, 2, 3, 5, 6, 7, 8, 9.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'S'

Intermediate   fit list       = T=5, A=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 8 and 9.

Rightmost      place of 'S'   = 0

left           partial value  = 495

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 0

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 1, 2, 3, 4, 6, 7, 8, 9.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'S'

Intermediate   fit list       = T=6, A=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 8 and 9.

Rightmost      place of 'S'   = 0

left           partial value  = 594

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 0

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 1, 2, 3, 4, 5, 7, 8, 9.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'S'

Intermediate   fit list       = T=7, A=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 8 and 9.

Rightmost      place of 'S'   = 0

left           partial value  = 693

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 0

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 1, 2, 3, 4, 5, 6, 8, 9.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'S'

Intermediate   fit list       = T=8, A=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 9.

Rightmost      place of 'S'   = 0

left           partial value  = 792

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 0

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 1, 2, 3, 4, 5, 6, 7, 9.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'S'

Intermediate   fit list       = T=9, A=0.

Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'S'   = 0

left           partial value  = 891

right          partial value  = 0

Factor         of code mod 10 = 1

Digit on       left side      = 1

Digit on       other side     = 0

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 1, 2, 3, 4, 5, 6, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'T'

Intermediate   fit list       = A=1.

Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'S'

Intermediate   fit list       = T=0, A=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'S'   = 0

left           partial value  = 0

right          partial value  = 9

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'U'

Intermediate   fit list       = S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

Current        code is        = 'Y'

Intermediate   fit list       = U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Y'   = 1

left           partial value  = 2029

right          partial value  = 9

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 0

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 4, 5, 6, 7, 8.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'C'

Intermediate   fit list       = Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7.

Current        code is        = 'L'

Intermediate   fit list       = C=3, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 4 and 5 and 6 and 7.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 32409

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 4, 5, 6, 7.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'I'

Intermediate   fit list       = L=4, C=3, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 5 and 6 and 7.

Rightmost      place of 'I'   = 3

left           partial value  = 32409

right          partial value  = 4409

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 4

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 5, 6, 7.

Possible       digits         = 2.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'L'

Intermediate   fit list       = C=4, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 5 and 6 and 7.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 42509

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 3, 5, 6, 7.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'I'

Intermediate   fit list       = L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 6 and 7.

Rightmost      place of 'I'   = 3

left           partial value  = 42509

right          partial value  = 5509

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 5

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 3, 6, 7.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'K'

Intermediate   fit list       = I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 6 and 7.

Current        code is        = 'Á'

Intermediate   fit list       = K=6, I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 7.

Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=4, L=5, I=3, K=6, Á=7, Á=7, K=6, I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

Results of     fit            = »43429+62081« related to     »75510«

Values of      fit            = 105510 is greater than   75510.

Current        code is        = 'Á'

Intermediate   fit list       = K=7, I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 6.

Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=4, L=5, I=3, K=7, Á=6, Á=6, K=7, I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

Results of     fit            = »43429+72081« related to     »65510«

Values of      fit            = 115510 is greater than   65510.

Current        code is        = 'L'

Intermediate   fit list       = C=5, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 4 and 6 and 7.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 52609

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 4, 6, 7.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'I'

Intermediate   fit list       = L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 4 and 7.

Rightmost      place of 'I'   = 3

left           partial value  = 52609

right          partial value  = 6609

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 6

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 3, 4, 7.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'K'

Intermediate   fit list       = I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 7.

Current        code is        = 'Á'

Intermediate   fit list       = K=3, I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 7.

Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=5, L=6, I=4, K=3, Á=7, Á=7, K=3, I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

Results of     fit            = »54529+32081« related to     »76610«

Values of      fit            = 86610 is greater than   76610.

Current        code is        = 'Á'

Intermediate   fit list       = K=7, I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3.

Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=5, L=6, I=4, K=7, Á=3, Á=3, K=7, I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

Results of     fit            = »54529+72081« related to     »36610«

Values of      fit            = 126610 is greater than   36610.

Current        code is        = 'L'

Intermediate   fit list       = C=6, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 4 and 5 and 7.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 62709

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 3, 4, 5, 7.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'I'

Intermediate   fit list       = L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 4 and 5.

Rightmost      place of 'I'   = 3

left           partial value  = 62709

right          partial value  = 7709

Factor         of code mod 10 = 1

Digit on       left side      = 2

Digit on       other side     = 7

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 3, 4, 5.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'K'

Intermediate   fit list       = I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 4.

Current        code is        = 'Á'

Intermediate   fit list       = K=3, I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 4.

Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=6, L=7, I=5, K=3, Á=4, Á=4, K=3, I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

Results of     fit            = »65629+32081« related to     »47710«

Values of      fit            = 97710 is greater than   47710.

Current        code is        = 'Á'

Intermediate   fit list       = K=4, I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3.

Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=6, L=7, I=5, K=4, Á=3, Á=3, K=4, I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

Results of     fit            = »65629+42081« related to     »37710«

Values of      fit            = 107710 is greater than   37710.

Current        code is        = 'L'

Intermediate   fit list       = C=7, Y=8, U=2, S=9, T=0, A=1.

Remaining      digits         = 3 and 4 and 5 and 6.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 72809

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 4, 5, 6.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Y'

Intermediate   fit list       = U=3, S=9, T=0, A=1.

Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'Y'   = 1

left           partial value  = 3039

right          partial value  = 9

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 0

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 4, 5, 6, 7, 8.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'C'

Intermediate   fit list       = Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 2 and 4 and 5 and 6 and 8.

Current        code is        = 'L'

Intermediate   fit list       = C=2, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 4 and 5 and 6 and 8.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 23309

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 4, 5, 6, 8.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'L'

Intermediate   fit list       = C=4, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 2 and 5 and 6 and 8.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 43509

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 5, 6, 8.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'I'

Intermediate   fit list       = L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 2 and 6 and 8.

Rightmost      place of 'I'   = 3

left           partial value  = 43509

right          partial value  = 5509

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 5

Product        mod 10         = 2

Possible       multipliers    = 2.

Remaining      digits         = 2, 6, 8.

Possible       digits         = 2.

Intersection   of them        = 2.

Number of      elements       = 1

Current        code is        = 'K'

Intermediate   fit list       = I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 6 and 8.

Current        code is        = 'Á'

Intermediate   fit list       = K=6, I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 8.

Tried          fit            = A=1, T=0, S=9, U=3, Y=7, C=4, L=5, I=2, K=6, Á=8, Á=8, K=6, I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

Results of     fit            = »42439+63071« related to     »85510«

Values of      fit            = 105510 is greater than   85510.

Current        code is        = 'Á'

Intermediate   fit list       = K=8, I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 6.

Tried          fit            = A=1, T=0, S=9, U=3, Y=7, C=4, L=5, I=2, K=8, Á=6, Á=6, K=8, I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

Results of     fit            = »42439+83071« related to     »65510«

Values of      fit            = 125510 is greater than   65510.

Current        code is        = 'L'

Intermediate   fit list       = C=5, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 2 and 4 and 6 and 8.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 53609

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 4, 6, 8.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'I'

Intermediate   fit list       = L=6, C=5, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 2 and 4 and 8.

Rightmost      place of 'I'   = 3

left           partial value  = 53609

right          partial value  = 6609

Factor         of code mod 10 = 1

Digit on       left side      = 3

Digit on       other side     = 6

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 2, 4, 8.

Possible       digits         = 3.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'L'

Intermediate   fit list       = C=6, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 2 and 4 and 5 and 8.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 63709

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 2, 4, 5, 8.

Possible       digits         = 7.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'L'

Intermediate   fit list       = C=8, Y=7, U=3, S=9, T=0, A=1.

Remaining      digits         = 2 and 4 and 5 and 6.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 83909

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 4, 5, 6.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Y'

Intermediate   fit list       = U=4, S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8.

Rightmost      place of 'Y'   = 1

left           partial value  = 4049

right          partial value  = 9

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 0

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 5, 6, 7, 8.

Possible       digits         = 6.

Intersection   of them        = 6.

Number of      elements       = 1

Current        code is        = 'C'

Intermediate   fit list       = Y=6, U=4, S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 5 and 7 and 8.

Current        code is        = 'L'

Intermediate   fit list       = C=2, Y=6, U=4, S=9, T=0, A=1.

Remaining      digits         = 3 and 5 and 7 and 8.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 24309

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 3, 5, 7, 8.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'I'

Intermediate   fit list       = L=3, C=2, Y=6, U=4, S=9, T=0, A=1.

Remaining      digits         = 5 and 7 and 8.

Rightmost      place of 'I'   = 3

left           partial value  = 24309

right          partial value  = 3309

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 3

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 5, 7, 8.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'L'

Intermediate   fit list       = C=3, Y=6, U=4, S=9, T=0, A=1.

Remaining      digits         = 2 and 5 and 7 and 8.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 34409

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 4

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 5, 7, 8.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'L'

Intermediate   fit list       = C=5, Y=6, U=4, S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 7 and 8.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 54609

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 2, 3, 7, 8.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'L'

Intermediate   fit list       = C=7, Y=6, U=4, S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 5 and 8.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 74809

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 2, 3, 5, 8.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'I'

Intermediate   fit list       = L=8, C=7, Y=6, U=4, S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 5.

Rightmost      place of 'I'   = 3

left           partial value  = 74809

right          partial value  = 8809

Factor         of code mod 10 = 1

Digit on       left side      = 4

Digit on       other side     = 8

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 5.

Possible       digits         = 4.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'L'

Intermediate   fit list       = C=8, Y=6, U=4, S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 5 and 7.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 84909

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 2, 3, 5, 7.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Y'

Intermediate   fit list       = U=5, S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8.

Rightmost      place of 'Y'   = 1

left           partial value  = 5059

right          partial value  = 9

Factor         of code mod 10 = 1

Digit on       left side      = 5

Digit on       other side     = 0

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 2, 3, 4, 6, 7, 8.

Possible       digits         = 5.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Y'

Intermediate   fit list       = U=6, S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8.

Rightmost      place of 'Y'   = 1

left           partial value  = 6069

right          partial value  = 9

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 0

Product        mod 10         = 4

Possible       multipliers    = 4.

Remaining      digits         = 2, 3, 4, 5, 7, 8.

Possible       digits         = 4.

Intersection   of them        = 4.

Number of      elements       = 1

Current        code is        = 'C'

Intermediate   fit list       = Y=4, U=6, S=9, T=0, A=1.

Remaining      digits         = 2 and 3 and 5 and 7 and 8.

Current        code is        = 'L'

Intermediate   fit list       = C=2, Y=4, U=6, S=9, T=0, A=1.

Remaining      digits         = 3 and 5 and 7 and 8.

Rightmost      place of 'L'   = 2

right          partial value  = 9

left           partial value  = 26309

Factor         of code mod 10 = 1

Digit on       right side     = 0

Digit on       other side     = 3

Product        mod 10         = 3

Possible       multipliers    = 3.

Remaining      digits         = 3, 5, 7, 8.

Possible       digits         = 3.

Intersection   of them        = 3.

Number of      elements       = 1

Current        code is        = 'I'

Intermediate   fit list       = L=3, C=2, Y=4, U=6, S=9, T=0, A=1.

Remaining      digits         = 5 and 7 and 8.

Rightmost      place of 'I'   = 3

left           partial value  = 26309

right          partial value  = 3309

Factor         of code mod 10 = 1

Digit on       left side      = 6

Digit on       other side     = 3

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 5, 7, 8.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'K'

Intermediate   fit list       = I=7, L=3, C=2, Y=4, U=6, S=9, T=0, A=1.

Remaining      digits         = 5 and 8.

Current        code is        = 'Á'

Intermediate   fit list       = K=5, I=7, L=3, C=2, Y=4, U=6, S=9, T=0, A=1.

Remaining      digits         = 8.

Tried          fit            = A=1, T=0, S=9, U=6, Y=4, C=2, L=3, I=7, K=5, Á=8, Á=8, K=5, I=7, L=3, C=2, Y=4, U=6, S=9, T=0, A=1.

Results of     fit            = »27269+56041« related to     »83310«

Values of      fit            = 83310 is equal to       83310.

Condensed      puzzle         = KUTYA+CICUS=ÁLLAT

Simplified     puzzle         = CICUS+KUTYA=ÁLLAT

Condensed      puzzle         = KUTYA+CICUS=ÁLLAT

Simplified     puzzle         = CICUS+KUTYA=ÁLLAT

Tried          fits           = 9

Matching       fits found     = 1

Start of fit lists and results:

Solution       #              = 1

Solution       fitted         = A=1, T=0, S=9, U=6, Y=4, C=2, L=3, I=7, K=5, Á=8, Á=8, K=5, I=7, L=3, C=2, Y=4, U=6, S=9, T=0, A=1.

Solution       got            = 27269+56041=83310

End of fit lists and results.

Current        code is        = 'S'

Intermediate   fit list       = E=1.

Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Current        code is        = 'N'

Intermediate   fit list       = S=0, E=1.

Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'N'   = 0

left           partial value  = 0

right          partial value  = 100091

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 1

Product        mod 10         = 1

Possible       multipliers    = 1.

Remaining      digits         = 2, 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 1.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'N'

Intermediate   fit list       = S=2, E=1.

Remaining      digits         = 0 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

Rightmost      place of 'N'   = 0

left           partial value  = 0

right          partial value  = 102089

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 0, 3, 4, 5, 6, 7, 8, 9.

Possible       digits         = 9.

Intersection   of them        = 9.

Number of      elements       = 1

Current        code is        = 'J'

Intermediate   fit list       = N=9, S=2, E=1.

Remaining      digits         = 0 and 3 and 4 and 5 and 6 and 7 and 8.

Current        code is        = 'U'

Intermediate   fit list       = J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

Rightmost      place of 'U'   = 1

left           partial value  = 9

right          partial value  = 102089

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 4, 5, 6, 7, 8.

Possible       digits         = 8.

Intersection   of them        = 8.

Number of      elements       = 1

Current        code is        = 'L'

Intermediate   fit list       = U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 4 and 5 and 6 and 7.

Current        code is        = 'Á'

Intermediate   fit list       = L=3, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 4 and 5 and 6 and 7.

Rightmost      place of 'Á'   = 3

left           partial value  = 89

right          partial value  = 129089

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 9

Product        mod 10         = 9

Possible       multipliers    = 9.

Remaining      digits         = 4, 5, 6, 7.

Possible       digits         = 9.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Á'

Intermediate   fit list       = L=4, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 5 and 6 and 7.

Rightmost      place of 'Á'   = 3

left           partial value  = 89

right          partial value  = 138089

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 8

Product        mod 10         = 8

Possible       multipliers    = 8.

Remaining      digits         = 3, 5, 6, 7.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Á'

Intermediate   fit list       = L=5, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 4 and 6 and 7.

Rightmost      place of 'Á'   = 3

left           partial value  = 89

right          partial value  = 147089

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 7

Product        mod 10         = 7

Possible       multipliers    = 7.

Remaining      digits         = 3, 4, 6, 7.

Possible       digits         = 7.

Intersection   of them        = 7.

Number of      elements       = 1

Current        code is        = 'M'

Intermediate   fit list       = Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 4 and 6.

Current        code is        = 'É'

Intermediate   fit list       = M=3, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 4 and 6.

Calculated     ratio          = 11

Calculated     modulus        = 0

Partial        fit            = M=3, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

Partial        values         =                37089 is less than 147089.

Coefficient    of 'É'         =                10000 is greater than 0.

Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'É'

Intermediate   fit list       = M=4, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 6.

Calculated     ratio          = 10

Calculated     modulus        = 0

Partial        fit            = M=4, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

Partial        values         =                47089 is less than 147089.

Coefficient    of 'É'         =                10000 is greater than 0.

Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.

Current        code is        = 'É'

Intermediate   fit list       = M=6, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 4.

Calculated     ratio          = 8

Calculated     modulus        = 0

Partial        fit            = M=6, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

Partial        values         =                67089 is less than 147089.

Coefficient    of 'É'         =                10000 is greater than 0.

Result of      predicate       = accepted("The final step could be shortened.")

Calculated     digit          = 8.

Remaining      digits         = 3, 4.

Possible       digits         = 8.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Á'

Intermediate   fit list       = L=6, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 4 and 5 and 7.

Rightmost      place of 'Á'   = 3

left           partial value  = 89

right          partial value  = 156089

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 6

Product        mod 10         = 6

Possible       multipliers    = 6.

Remaining      digits         = 3, 4, 5, 7.

Possible       digits         = 6.

Intersection   of them        = none.

Number of      elements       = 0

Current        code is        = 'Á'

Intermediate   fit list       = L=7, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 4 and 5 and 6.

Rightmost      place of 'Á'   = 3

left           partial value  = 89

right          partial value  = 165089

Factor         of code mod 10 = 1

Digit on       left side      = 0

Digit on       other side     = 5

Product        mod 10         = 5

Possible       multipliers    = 5.

Remaining      digits         = 3, 4, 5, 6.

Possible       digits         = 5.

Intersection   of them        = 5.

Number of      elements       = 1

Current        code is        = 'M'

Intermediate   fit list       = Á=5, L=7, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 3 and 4 and 6.

Current        code is        = 'É'

Intermediate   fit list       = M=3, Á=5, L=7, U=8, J=0, N=9, S=2, E=1.

Remaining      digits         = 4 and 6.

Calculated     ratio          = 13

Calculated     modulus        = 0

Partial        fit            = M=3, Á=5, L=7, U=8, J=0, N=9, S=2, E=1.

Partial        values         =                35089 is less than 165089.

Coefficient    of 'É'         =                10000 is greater than 0.

Result of      predicate       = rejected("The final step has not acceptable solution.")

Calculated     digit          = none.


Comparison of Solution Files with and without Classification
Two examples of solution file of Hungarian puzzles are compared.
This an example of solution file of Hungarian puzzles.
First one contains
¨ no classification
¨ no track
¨ all solutions.

Second one contains
¨ classification
¨ no track
¨ all solutions.

Porównaj: (<)D:\Feri\SOAP\Results\magyarok00.aps (318202 bajtów)
   z: (>)D:\Feri\SOAP\Results\magyarok10.aps (514030 bajtów)

1,2c1,2
< 2010. január 4. 8:57:57
< Action         = overwrite      unicode file »magyarok00.aps« in folder »D:\Feri\SOAP\Results\«.
---
> 2010. január 4. 9:14:43
> Action         = create         unicode file »magyarok10.aps« in folder »D:\Feri\SOAP\Results\«.
9a9,154
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","*=").
> characters("Codes","TÍHÚSZ").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: * and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: T and Í and H and Ú and S and Z.")).
> classification("by lengths of components","accepted",accepted("The length of the factor #1 on the  left is 1.")).
> classification("by lengths of components","accepted",accepted("The length of the factor #1 on the  left is 1.")).
> classification("by contents of factors","legal",accepted("Part #1 on the  left contains a legal factor value =2.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 3.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »TÍZ« composed of valid characters.")).
> classification("by lengths of components","accepted",accepted("The length of the product #1 on the  left is 6.")).
> classification("by splitting at operators","combined",accepted("Part #1 on the  left contains a factor and a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 1 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 4.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »HÚSZ« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","simple",accepted("The  left side of the simplified equation contains only one part.")).
> classification("by count of parts","only multiplications",accepted("The  left side of the simplified equation contains only 1 factored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","1 product=1 word",accepted("The left factored word should be equal to the right unfactored one.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [200, 1998].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [1000, 9999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [1000, 1974].")).
> num_read_parts(left(),1).
> num_read_parts(right(),1).
> read_parts(t(left(),00BD0810)).
> read_parts(t(right(),00BD07C8)).
> coefficients(summed(),right(),'Z',1).
> coefficients(summed(),right(),'S',10).
> coefficients(summed(),right(),'Ú',100).
> coefficients(summed(),right(),'H',1000).
> coefficients(summed(),left(),'Z',2).
> coefficients(summed(),left(),'Í',20).
> coefficients(summed(),left(),'T',200).
> coefficients(substracted(),left(),'S',0).
> coefficients(substracted(),right(),'S',10).
> coefficients(substracted(),left(),'Ú',0).
> coefficients(substracted(),right(),'Ú',100).
> coefficients(substracted(),left(),'H',0).
> coefficients(substracted(),right(),'H',1000).
> coefficients(substracted(),right(),'Z',0).
> coefficients(substracted(),left(),'Z',1).
> coefficients(substracted(),right(),'Í',0).
> coefficients(substracted(),left(),'Í',20).
> coefficients(substracted(),right(),'T',0).
> coefficients(substracted(),left(),'T',200).
> rightmost('S',right(),left(),1,1,1).
> rightmost('Ú',right(),left(),1,1,2).
> rightmost('H',right(),left(),1,1,3).
> rightmost('Z',left(),right(),1,1,0).
> rightmost('Í',left(),right(),2,2,1).
> rightmost('T',left(),right(),2,2,2).
>
>
>
> clauses
> num_qualified_additions(left(),0).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),1).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4D60).
> qualified_words(right(),00BE4D40).
> qualified_products(left(),00BEA690).
> qualified_products(right(),00BEA668).
> global_max(4).
> relative_lengths_of_words(left(),[],[]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[1],[2]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(24,1974)).
> code_ranges(right(),r(123,9876)).
> intersection_of_ranges(r(1000,1974)).
> greatest_common_divisors(left(),2).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(right(),1,"HÚSZ",r(1000,1974)).
> limited_ranges(left(),2,"TÍZ",r(200,1974)).
> substracted_ranges(right(),1,"HÚSZ","Intersection",r(1000,1974)).
> substracted_ranges(left(),2,"TÍZ","Intersection",r(1000,1974)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",2,2).
> investigated_rules("Compare limited and substracted ranges of words.",2,2).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",2,2).
> investigated_rules("Leading characters may not represent zero digits.",6,2).
> investigated_rules("If all words end to the same character 'Z' and the difference of the sum of factors ends to 1 then the possible trailing characters are 0..",1,1).
> investigated_rules("The simple right side must end to 0 or 2 or 4 or 6 or 8. because the opposite side is divisible by 2.",1,1).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",7,7).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",4,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",8,8).
> investigated_rules("The last code missing from the partial fit is a deterministic result of a division.",27,27).
> investigated_rules("Is the substituted value of the left side is equal to that of the right side of the equation?",11,11).
> compared_ranges(right(),1,"HÚSZ",r(1000,1974)).
> compared_ranges(left(),2,"TÍZ",r(1000,1974)).
> divided_ranges(right(),"HÚSZ",r(1000,1974)).
> divided_ranges(left(),"TÍZ",r(500,987)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['T','Í','H','Ú','S','Z']).
> characters("leading",['T','H']).
> characters("trailing",['Z']).
> characters("known",[]).
> allowed_digits(a('H',['1'])).
> allowed_digits(a('Ú',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('S',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('T',['5','6','7','8','9'])).
> allowed_digits(a('Í',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Z',['0'])).
> grouped_substitutions([g(['T'],['5','6','7','8','9']),g(['Í','S','Ú'],['2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   1 1   8 Í 23456789","0   1 8   8 S 23456789","0 2 1   5 T 56789","0   2 8   8 Ú 23456789"]).
> num_var(1680).
> solved_fit(f('Z','0')).
> solved_fit(f('H','1')).
>
>
>
> Condensed      puzzle         = 2*TÍZ=HÚSZ
>
> Simplified     puzzle         = 2*TÍZ=HÚSZ
>
>
76a222,376
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","+=").
> characters("Codes","ÖEGYHAT").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: Ö and E and G and Y and H and A and T.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 2.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »ÖT« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 3.")).
> classification("by contents of words","legal",accepted("Part #2 on the left contains the word »EGY« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 2 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 3.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »HAT« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 2 parts.")).
> classification("by count of parts","only additions",accepted("The left side of the simplified equation contains only 2 unfactored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","2 words=1 word",accepted("Two unfactored words on the left side, one unfactored word on the right side.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [110, 1098].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [100, 999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [110, 987].")).
> num_read_parts(left(),2).
> num_read_parts(right(),1).
> read_parts(t(left(),00BD0E88)).
> read_parts(t(left(),00BD0E40)).
> read_parts(t(right(),00BD0DF8)).
> coefficients(summed(),right(),'T',1).
> coefficients(summed(),right(),'A',10).
> coefficients(summed(),right(),'H',100).
> coefficients(summed(),left(),'T',1).
> coefficients(summed(),left(),'Ö',10).
> coefficients(summed(),left(),'Y',1).
> coefficients(summed(),left(),'G',10).
> coefficients(summed(),left(),'E',100).
> coefficients(substracted(),left(),'T',0).
> coefficients(substracted(),right(),'T',0).
> coefficients(substracted(),left(),'A',0).
> coefficients(substracted(),right(),'A',10).
> coefficients(substracted(),left(),'H',0).
> coefficients(substracted(),right(),'H',100).
> coefficients(substracted(),right(),'T',0).
> coefficients(substracted(),left(),'T',0).
> coefficients(substracted(),right(),'Ö',0).
> coefficients(substracted(),left(),'Ö',10).
> coefficients(substracted(),right(),'Y',0).
> coefficients(substracted(),left(),'Y',1).
> coefficients(substracted(),right(),'G',0).
> coefficients(substracted(),left(),'G',10).
> coefficients(substracted(),right(),'E',0).
> coefficients(substracted(),left(),'E',100).
> rightmost('T',right(),left(),0,0,0).
> rightmost('A',right(),left(),1,1,1).
> rightmost('H',right(),left(),1,1,2).
> rightmost('T',left(),right(),0,0,0).
> rightmost('Ö',left(),right(),1,1,1).
> rightmost('Y',left(),right(),1,1,0).
> rightmost('G',left(),right(),1,1,1).
> rightmost('E',left(),right(),1,1,2).
>
>
>
> clauses
> num_qualified_additions(left(),2).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),0).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4F00).
> qualified_words(right(),00BE4EE0).
> qualified_products(left(),00D94FA0).
> qualified_products(right(),00D94F78).
> global_max(3).
> relative_lengths_of_words(left(),[0,1],[1,1]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[],[]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(37,1061)).
> code_ranges(right(),r(12,987)).
> intersection_of_ranges(r(110,987)).
> greatest_common_divisors(left(),1).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(left(),1,"EGY",r(100,987)).
> limited_ranges(left(),1,"ÖT",r(10,99)).
> limited_ranges(right(),1,"HAT",r(100,987)).
> substracted_ranges(right(),1,"HAT","Intersection",r(110,987)).
> substracted_ranges(left(),1,"EGY","Intersection - ÖT ",r(11,977)).
> substracted_ranges(left(),1,"ÖT","Intersection - EGY ",r(0,887)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",3,3).
> investigated_rules("Restrict range subtracting the limited range of other words on the same side.",2,2).
> investigated_rules("Compare limited and substracted ranges of words.",3,3).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",3,3).
> investigated_rules("Leading characters may not represent zero digits.",7,3).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",8,8).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",2,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("The last code missing from the partial fit is a deterministic result of a division.",108,108).
> investigated_rules("Is the substituted value of the left side is equal to that of the right side of the equation?",432,432).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",457,457).
> compared_ranges(right(),1,"HAT",r(110,987)).
> compared_ranges(left(),1,"EGY",r(100,977)).
> compared_ranges(left(),1,"ÖT",r(10,99)).
> divided_ranges(right(),"HAT",r(110,987)).
> divided_ranges(left(),"EGY",r(100,977)).
> divided_ranges(left(),"ÖT",r(10,99)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['E','G','Y','Ö','H','A','T']).
> characters("leading",['E','Ö','H']).
> characters("trailing",['Y','T']).
> characters("known",[]).
> allowed_digits(a('E',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('G',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Y',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Ö',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('H',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('A',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('T',['0','1','2','3','4','5','6','7','8','9'])).
> grouped_substitutions([g(['H','Ö','E'],['1','2','3','4','5','6','7','8','9']),g(['T','A','Y','G'],['0','1','2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   0 8  10 Y 0123456789","0   1 8   9 Ö 123456789","0 1 8  10 A 0123456789","0   1 8  10 G 0123456789","0   2 8   9 E 123456789","0   2 8   9 H 123456789","1   0 9  10 T 0123456789"]).
> num_var(2540160).
>
>
>
> Condensed      puzzle         = ÖT+EGY=HAT
>
> Simplified     puzzle         = EGY+ÖT=HAT
>
>
2248,2254c2549,2696
< Tried          fits           = 0
< Matching       fits           = not found
<
<
< Condensed      puzzle         = HATVAN+TÍZ=HETVEN
<
< Simplified     puzzle         = HATVAN+TÍZ=HETVEN
---
> Equation       judged         = The equation is disjointed by estimated range.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","+=").
> characters("Codes","ÖEÍZHTVAN").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: Ö and E and Í and Z and H and T and V and A and N.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 5.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »ÖTVEN« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 3.")).
> classification("by contents of words","legal",accepted("Part #2 on the left contains the word »TÍZ« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 2 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 6.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »HATVAN« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 2 parts.")).
> classification("by count of parts","only additions",accepted("The left side of the simplified equation contains only 2 unfactored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","2 words=1 word",accepted("Two unfactored words on the left side, one unfactored word on the right side.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [10100, 100998].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [100000, 999999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","disjointed",rejected("The ranges of left and right sides are disjointed.")).
> num_read_parts(left(),2).
> num_read_parts(right(),1).
> read_parts(t(left(),00BD0E70)).
> read_parts(t(left(),00BD0DB0)).
> read_parts(t(right(),00BD0D68)).
> coefficients(summed(),right(),'N',1).
> coefficients(summed(),right(),'A',10010).
> coefficients(summed(),right(),'V',100).
> coefficients(summed(),right(),'T',1000).
> coefficients(summed(),right(),'H',100000).
> coefficients(summed(),left(),'Z',1).
> coefficients(summed(),left(),'Í',10).
> coefficients(summed(),left(),'T',1100).
> coefficients(summed(),left(),'N',1).
> coefficients(summed(),left(),'E',10).
> coefficients(summed(),left(),'V',100).
> coefficients(summed(),left(),'Ö',10000).
> coefficients(substracted(),left(),'N',0).
> coefficients(substracted(),right(),'N',0).
> coefficients(substracted(),left(),'A',0).
> coefficients(substracted(),right(),'A',10010).
> coefficients(substracted(),left(),'V',0).
> coefficients(substracted(),right(),'V',0).
> coefficients(substracted(),left(),'H',0).
> coefficients(substracted(),right(),'H',100000).
> coefficients(substracted(),right(),'Z',0).
> coefficients(substracted(),left(),'Z',1).
> coefficients(substracted(),right(),'Í',0).
> coefficients(substracted(),left(),'Í',10).
> coefficients(substracted(),right(),'T',0).
> coefficients(substracted(),left(),'T',100).
> coefficients(substracted(),right(),'N',0).
> coefficients(substracted(),left(),'N',0).
> coefficients(substracted(),right(),'E',0).
> coefficients(substracted(),left(),'E',10).
> coefficients(substracted(),right(),'V',0).
> coefficients(substracted(),left(),'V',0).
> coefficients(substracted(),right(),'Ö',0).
> coefficients(substracted(),left(),'Ö',10000).
> rightmost('N',right(),left(),0,0,0).
> rightmost('A',right(),left(),1001,1,1).
> rightmost('V',right(),left(),0,0,0).
> rightmost('H',right(),left(),1,1,5).
> rightmost('Z',left(),right(),1,1,0).
> rightmost('Í',left(),right(),1,1,1).
> rightmost('T',left(),right(),1,1,2).
> rightmost('N',left(),right(),0,0,0).
> rightmost('E',left(),right(),1,1,1).
> rightmost('V',left(),right(),0,0,0).
> rightmost('Ö',left(),right(),1,1,4).
>
>
>
> clauses
> num_qualified_additions(left(),2).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),0).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4FA0).
> qualified_words(right(),00BE4F80).
> qualified_products(left(),00D94F50).
> qualified_products(right(),00D94F28).
> global_max(6).
> relative_lengths_of_words(left(),[1,3],[1,1]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[],[]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(1381,99617)).
> code_ranges(right(),r(12314,987685)).
> greatest_common_divisors(left(),1).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> investigated_rules("Get intersection of the ranges of the two sides.",1,0).
> investigated_rules("Leading characters may not represent zero digits.",9,3).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",14,0).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",1,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['Ö','E','Í','Z','H','T','V','A','N']).
> characters("leading",['Ö','T','H']).
> characters("trailing",['Z','N']).
> characters("known",[]).
> allowed_digits(a('Ö',[])).
> allowed_digits(a('T',[])).
> allowed_digits(a('V',[])).
> allowed_digits(a('E',[])).
> allowed_digits(a('N',[])).
> allowed_digits(a('Í',[])).
> allowed_digits(a('Z',[])).
> allowed_digits(a('H',[])).
> allowed_digits(a('A',[])).
> grouped_substitutions([g(['A','H','Z','Í','N','E','V','T','Ö'],[])]).
> ordered_codes(["0   0 8   0 Z ","0   1 8   0 A ","0   1 8   0 E ","0 1 8   0 Í ","0   2 8   0 T ","0   4 8   0 Ö ","0   5 8   0 H ","1   0 9 0 N ","1   0 9   0 V "]).
> num_var(0).
>
>
>
> Condensed      puzzle         = ÖTVEN+TÍZ=HATVAN
>
> Simplified     puzzle         = ÖTVEN+TÍZ=HATVAN
2261,2263c2703,2873
< Condensed      puzzle         = 5*HÚSZ=SZÁZ
<
< Simplified     puzzle         = 5*HÚSZ=SZÁZ
---
> Condensed      puzzle         = HATVAN+TÍZ=HETVEN
>
> Simplified     puzzle         = HATVAN+TÍZ=HETVEN
>
>
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","+=").
> characters("Codes","AÍZHTVEN").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: A and Í and Z and H and T and V and E and N.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 6.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »HATVAN« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 3.")).
> classification("by contents of words","legal",accepted("Part #2 on the left contains the word »TÍZ« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 2 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 6.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »HETVEN« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 2 parts.")).
> classification("by count of parts","only additions",accepted("The left side of the simplified equation contains only 2 unfactored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","2 words=1 word",accepted("Two unfactored words on the left side, one unfactored word on the right side.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [100100, 1000998].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [100000, 999999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [100100, 987685].")).
> num_read_parts(left(),2).
> num_read_parts(right(),1).
> read_parts(t(left(),00BD0E28)).
> read_parts(t(left(),00BD0D08)).
> read_parts(t(right(),00BD0CC0)).
> coefficients(summed(),right(),'N',1).
> coefficients(summed(),right(),'E',10010).
> coefficients(summed(),right(),'V',100).
> coefficients(summed(),right(),'T',1000).
> coefficients(summed(),right(),'H',100000).
> coefficients(summed(),left(),'Z',1).
> coefficients(summed(),left(),'Í',10).
> coefficients(summed(),left(),'T',1100).
> coefficients(summed(),left(),'N',1).
> coefficients(summed(),left(),'A',10010).
> coefficients(summed(),left(),'V',100).
> coefficients(summed(),left(),'H',100000).
> coefficients(substracted(),left(),'N',0).
> coefficients(substracted(),right(),'N',0).
> coefficients(substracted(),left(),'E',0).
> coefficients(substracted(),right(),'E',10010).
> coefficients(substracted(),left(),'V',0).
> coefficients(substracted(),right(),'V',0).
> coefficients(substracted(),left(),'H',0).
> coefficients(substracted(),right(),'H',0).
> coefficients(substracted(),right(),'Z',0).
> coefficients(substracted(),left(),'Z',1).
> coefficients(substracted(),right(),'Í',0).
> coefficients(substracted(),left(),'Í',10).
> coefficients(substracted(),right(),'T',0).
> coefficients(substracted(),left(),'T',100).
> coefficients(substracted(),right(),'N',0).
> coefficients(substracted(),left(),'N',0).
> coefficients(substracted(),right(),'A',0).
> coefficients(substracted(),left(),'A',10010).
> coefficients(substracted(),right(),'V',0).
> coefficients(substracted(),left(),'V',0).
> coefficients(substracted(),right(),'H',0).
> coefficients(substracted(),left(),'H',0).
> rightmost('N',right(),left(),0,0,0).
> rightmost('E',right(),left(),1001,1,1).
> rightmost('V',right(),left(),0,0,0).
> rightmost('H',right(),left(),0,0,0).
> rightmost('Z',left(),right(),1,1,0).
> rightmost('Í',left(),right(),1,1,1).
> rightmost('T',left(),right(),1,1,2).
> rightmost('N',left(),right(),0,0,0).
> rightmost('A',left(),right(),1001,1,1).
> rightmost('V',left(),right(),0,0,0).
> rightmost('H',left(),right(),0,0,0).
>
>
>
> clauses
> num_qualified_additions(left(),2).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),0).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4EA0).
> qualified_words(right(),00BE4E80).
> qualified_products(left(),00D94F00).
> qualified_products(right(),00D94ED8).
> global_max(6).
> relative_lengths_of_words(left(),[0,3],[1,1]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[],[]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(12561,988437)).
> code_ranges(right(),r(12314,987685)).
> intersection_of_ranges(r(100100,987685)).
> greatest_common_divisors(left(),1).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(left(),1,"HATVAN",r(100000,987685)).
> limited_ranges(left(),1,"TÍZ",r(100,999)).
> limited_ranges(right(),1,"HETVEN",r(100000,987685)).
> substracted_ranges(right(),1,"HETVEN","Intersection",r(100100,987685)).
> substracted_ranges(left(),1,"HATVAN","Intersection - TÍZ ",r(99101,987585)).
> substracted_ranges(left(),1,"TÍZ","Intersection - HATVAN ",r(0,887685)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",3,3).
> investigated_rules("Restrict range subtracting the limited range of other words on the same side.",2,2).
> investigated_rules("Compare limited and substracted ranges of words.",3,3).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",3,3).
> investigated_rules("Leading characters may not represent zero digits.",8,2).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",15,15).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",2,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("The last code missing from the partial fit is a deterministic result of a division.",360,360).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",137,137).
> compared_ranges(right(),1,"HETVEN",r(100100,987685)).
> compared_ranges(left(),1,"HATVAN",r(100000,987585)).
> compared_ranges(left(),1,"TÍZ",r(100,999)).
> divided_ranges(right(),"HETVEN",r(100100,987685)).
> divided_ranges(left(),"HATVAN",r(100000,987585)).
> divided_ranges(left(),"TÍZ",r(100,999)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['A','Í','Z','H','T','V','E','N']).
> characters("leading",['T','H']).
> characters("trailing",['Z','N']).
> characters("known",[]).
> allowed_digits(a('A',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Í',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Z',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('H',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('T',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('V',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('E',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('N',['0','1','2','3','4','5','6','7','8','9'])).
> grouped_substitutions([g(['T','H'],['1','2','3','4','5','6','7','8','9']),g(['N','E','V','Z','Í','A'],['0','1','2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   0 8  10 Z 0123456789","0   1 8  10 A 0123456789","0   1 8  10 E 0123456789","0   1 8  10 Í 0123456789","0   2 8   9 T 123456789","1   0 9   9 H 123456789","1   0 9  10 N 0123456789","1   0 9  10 V 0123456789"]).
> num_var(10886400).
>
>
>
> Condensed      puzzle         = HATVAN+TÍZ=HETVEN
>
> Simplified     puzzle         = HATVAN+TÍZ=HETVEN
2270a2880,3028
> Condensed      puzzle         = 5*HÚSZ=SZÁZ
>
> Simplified     puzzle         = 5*HÚSZ=SZÁZ
>
>
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","*=").
> characters("Codes","HÚSÁZ").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: * and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: H and Ú and S and Á and Z.")).
> classification("by lengths of components","accepted",accepted("The length of the factor #1 on the  left is 1.")).
> classification("by lengths of components","accepted",accepted("The length of the factor #1 on the  left is 1.")).
> classification("by contents of factors","legal",accepted("Part #1 on the  left contains a legal factor value =5.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 4.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »HÚSZ« composed of valid characters.")).
> classification("by lengths of components","accepted",accepted("The length of the product #1 on the  left is 7.")).
> classification("by splitting at operators","combined",accepted("Part #1 on the  left contains a factor and a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 1 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 4.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »SZÁZ« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","simple",accepted("The  left side of the simplified equation contains only one part.")).
> classification("by count of parts","only multiplications",accepted("The  left side of the simplified equation contains only 1 factored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","1 product=1 word",accepted("The left factored word should be equal to the right unfactored one.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [5000, 49995].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [1000, 9999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [5000, 9878].")).
> num_read_parts(left(),1).
> num_read_parts(right(),1).
> read_parts(t(left(),00BD0C60)).
> read_parts(t(right(),00BD0C18)).
> coefficients(summed(),right(),'Z',101).
> coefficients(summed(),right(),'Á',10).
> coefficients(summed(),right(),'S',1000).
> coefficients(summed(),left(),'Z',5).
> coefficients(summed(),left(),'S',50).
> coefficients(summed(),left(),'Ú',500).
> coefficients(summed(),left(),'H',5000).
> coefficients(substracted(),left(),'Z',0).
> coefficients(substracted(),right(),'Z',96).
> coefficients(substracted(),left(),'Á',0).
> coefficients(substracted(),right(),'Á',10).
> coefficients(substracted(),left(),'S',0).
> coefficients(substracted(),right(),'S',950).
> coefficients(substracted(),right(),'Ú',0).
> coefficients(substracted(),left(),'Ú',500).
> coefficients(substracted(),right(),'H',0).
> coefficients(substracted(),left(),'H',5000).
> rightmost('Z',right(),left(),96,6,0).
> rightmost('Á',right(),left(),1,1,1).
> rightmost('S',right(),left(),95,5,1).
> rightmost('Ú',left(),right(),5,5,2).
> rightmost('H',left(),right(),5,5,3).
>
>
>
> clauses
> num_qualified_additions(left(),0).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),1).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4E60).
> qualified_words(right(),00BE4E40).
> qualified_products(left(),00D94E60).
> qualified_products(right(),00D94E38).
> global_max(4).
> relative_lengths_of_words(left(),[],[]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[0],[5]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(615,49380)).
> code_ranges(right(),r(121,9878)).
> intersection_of_ranges(r(5000,9878)).
> greatest_common_divisors(left(),5).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(right(),1,"SZÁZ",r(1000,9878)).
> limited_ranges(left(),5,"HÚSZ",r(5000,9878)).
> substracted_ranges(right(),1,"SZÁZ","Intersection",r(5000,9878)).
> substracted_ranges(left(),5,"HÚSZ","Intersection",r(5000,9878)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",2,2).
> investigated_rules("Compare limited and substracted ranges of words.",2,2).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",2,2).
> investigated_rules("Leading characters may not represent zero digits.",5,2).
> investigated_rules("If all words end to the same character 'Z' and the difference of the sum of factors ends to 4 then the possible trailing characters are 0 or 5..",1,1).
> investigated_rules("The simple right side must end to 0 or 5. because the opposite side is divisible by 5.",1,1).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",8,8).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",4,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",10,10).
> investigated_rules("The last code missing from the partial fit is a deterministic result of a division.",5,5).
> compared_ranges(right(),1,"SZÁZ",r(5000,9878)).
> compared_ranges(left(),5,"HÚSZ",r(5000,9878)).
> divided_ranges(right(),"SZÁZ",r(5000,9878)).
> divided_ranges(left(),"HÚSZ",r(1000,1975)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['H','Ú','S','Á','Z']).
> characters("leading",['H','S']).
> characters("trailing",['Z']).
> characters("known",[]).
> allowed_digits(a('Á',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('H',['1'])).
> allowed_digits(a('Ú',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('S',['5','6','7','8','9'])).
> allowed_digits(a('Z',['0','5'])).
> grouped_substitutions([g(['Z'],['0','5']),g(['S'],['5','6','7','8','9']),g(['Ú','Á'],['0','2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   0 3   2 Z 05","0   1 0   5 S 56789","0   1 8   9 Á 023456789","0   2 0   9 Ú 023456789"]).
> num_var(720).
> solved_fit(f('H','1')).
>
>
>
> Condensed      puzzle         = 5*HÚSZ=SZÁZ
>
> Simplified     puzzle         = 5*HÚSZ=SZÁZ
>
>
> Tried          fits           = 0
> Matching       fits           = not found
>
>
2275a3034,3199
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","+=").
> characters("Codes","VÍZBORITAL").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: V and Í and Z and B and O and R and I and T and A and L.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 3.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »VÍZ« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 3.")).
> classification("by contents of words","legal",accepted("Part #2 on the left contains the word »BOR« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 2 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 4.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »ITAL« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 2 parts.")).
> classification("by count of parts","only additions",accepted("The left side of the simplified equation contains only 2 unfactored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","2 words=1 word",accepted("Two unfactored words on the left side, one unfactored word on the right side.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [200, 1998].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [1000, 9999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [1000, 1839].")).
> num_read_parts(left(),2).
> num_read_parts(right(),1).
> read_parts(t(left(),00DB4750)).
> read_parts(t(left(),00DB4708)).
> read_parts(t(right(),00DB46C0)).
> coefficients(summed(),right(),'L',1).
> coefficients(summed(),right(),'A',10).
> coefficients(summed(),right(),'T',100).
> coefficients(summed(),right(),'I',1000).
> coefficients(summed(),left(),'Z',1).
> coefficients(summed(),left(),'Í',10).
> coefficients(summed(),left(),'V',100).
> coefficients(summed(),left(),'R',1).
> coefficients(summed(),left(),'O',10).
> coefficients(summed(),left(),'B',100).
> coefficients(substracted(),left(),'L',0).
> coefficients(substracted(),right(),'L',1).
> coefficients(substracted(),left(),'A',0).
> coefficients(substracted(),right(),'A',10).
> coefficients(substracted(),left(),'T',0).
> coefficients(substracted(),right(),'T',100).
> coefficients(substracted(),left(),'I',0).
> coefficients(substracted(),right(),'I',1000).
> coefficients(substracted(),right(),'Z',0).
> coefficients(substracted(),left(),'Z',1).
> coefficients(substracted(),right(),'Í',0).
> coefficients(substracted(),left(),'Í',10).
> coefficients(substracted(),right(),'V',0).
> coefficients(substracted(),left(),'V',100).
> coefficients(substracted(),right(),'R',0).
> coefficients(substracted(),left(),'R',1).
> coefficients(substracted(),right(),'O',0).
> coefficients(substracted(),left(),'O',10).
> coefficients(substracted(),right(),'B',0).
> coefficients(substracted(),left(),'B',100).
> rightmost('L',right(),left(),1,1,0).
> rightmost('A',right(),left(),1,1,1).
> rightmost('T',right(),left(),1,1,2).
> rightmost('I',right(),left(),1,1,3).
> rightmost('Z',left(),right(),1,1,0).
> rightmost('Í',left(),right(),1,1,1).
> rightmost('V',left(),right(),1,1,2).
> rightmost('R',left(),right(),1,1,0).
> rightmost('O',left(),right(),1,1,1).
> rightmost('B',left(),right(),1,1,2).
>
>
>
> clauses
> num_qualified_additions(left(),2).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),0).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4CA0).
> qualified_words(right(),00BE4C80).
> qualified_products(left(),00EE34B0).
> qualified_products(right(),00EE3488).
> global_max(4).
> relative_lengths_of_words(left(),[1],[2]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[],[]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(159,1839)).
> code_ranges(right(),r(123,9876)).
> intersection_of_ranges(r(1000,1839)).
> greatest_common_divisors(left(),1).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(left(),1,"BOR",r(100,999)).
> limited_ranges(left(),1,"VÍZ",r(100,999)).
> limited_ranges(right(),1,"ITAL",r(1000,1839)).
> substracted_ranges(right(),1,"ITAL","Intersection",r(1000,1839)).
> substracted_ranges(left(),1,"BOR","Intersection - VÍZ ",r(1,1739)).
> substracted_ranges(left(),1,"VÍZ","Intersection - BOR ",r(1,1739)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",3,3).
> investigated_rules("Restrict range subtracting the limited range of other words on the same side.",2,2).
> investigated_rules("Compare limited and substracted ranges of words.",3,3).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",3,3).
> investigated_rules("Leading characters may not represent zero digits.",10,3).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",10,10).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",4,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("Is the substituted value of the left side is equal to that of the right side of the equation?",1872,96).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",1512,1512).
> compared_ranges(right(),1,"ITAL",r(1000,1839)).
> compared_ranges(left(),1,"BOR",r(100,999)).
> compared_ranges(left(),1,"VÍZ",r(100,999)).
> divided_ranges(right(),"ITAL",r(1000,1839)).
> divided_ranges(left(),"BOR",r(100,999)).
> divided_ranges(left(),"VÍZ",r(100,999)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['B','O','R','V','Í','Z','I','T','A','L']).
> characters("leading",['B','V','I']).
> characters("trailing",['R','Z','L']).
> characters("known",[]).
> allowed_digits(a('B',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('O',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('R',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('V',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Í',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Z',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('I',['1'])).
> allowed_digits(a('T',['0','1','2','3','4','5','6','7','8'])).
> allowed_digits(a('A',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('L',['0','1','2','3','4','5','6','7','8','9'])).
> grouped_substitutions([g(['T'],['0','2','3','4','5','6','7','8']),g(['V','B'],['2','3','4','5','6','7','8','9']),g(['L','A','Z','Í','R','O'],['0','2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   0 8   9 L 023456789","0   0 8   9 R 023456789","0 0 8   9 Z 023456789","0   1 8   9 A 023456789","0   1 8   9 O 023456789","0   1 8   9 Í 023456789","0   2 8   8 B 23456789","0   2 8 8 T 02345678","0   2 8   8 V 23456789"]).
> num_var(27095040).
> solved_fit(f('I','1')).
>
>
>
> Condensed      puzzle         = VÍZ+BOR=ITAL
>
> Simplified     puzzle         = BOR+VÍZ=ITAL
>
>
2767a3692,3858
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","+=").
> characters("Codes","KYICUSÁLAT").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: K and Y and I and C and U and S and Á and L and A and T.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 5.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »KUTYA« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 5.")).
> classification("by contents of words","legal",accepted("Part #2 on the left contains the word »CICUS« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 2 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 5.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »ÁLLAT« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 2 parts.")).
> classification("by count of parts","only additions",accepted("The left side of the simplified equation contains only 2 unfactored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","2 words=1 word",accepted("Two unfactored words on the left side, one unfactored word on the right side.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [20000, 199998].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [10000, 99999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [20000, 98876].")).
> num_read_parts(left(),2).
> num_read_parts(right(),1).
> read_parts(t(left(),00DB4FA8)).
> read_parts(t(left(),00DB4F60)).
> read_parts(t(right(),00DB4F18)).
> coefficients(summed(),right(),'T',1).
> coefficients(summed(),right(),'A',10).
> coefficients(summed(),right(),'L',1100).
> coefficients(summed(),right(),'Á',10000).
> coefficients(summed(),left(),'A',1).
> coefficients(summed(),left(),'Y',10).
> coefficients(summed(),left(),'T',100).
> coefficients(summed(),left(),'U',1010).
> coefficients(summed(),left(),'K',10000).
> coefficients(summed(),left(),'S',1).
> coefficients(summed(),left(),'C',10100).
> coefficients(summed(),left(),'I',1000).
> coefficients(substracted(),left(),'A',0).
> coefficients(substracted(),right(),'A',9).
> coefficients(substracted(),left(),'L',0).
> coefficients(substracted(),right(),'L',1100).
> coefficients(substracted(),left(),'Á',0).
> coefficients(substracted(),right(),'Á',10000).
> coefficients(substracted(),right(),'Y',0).
> coefficients(substracted(),left(),'Y',10).
> coefficients(substracted(),right(),'T',0).
> coefficients(substracted(),left(),'T',99).
> coefficients(substracted(),right(),'U',0).
> coefficients(substracted(),left(),'U',1010).
> coefficients(substracted(),right(),'K',0).
> coefficients(substracted(),left(),'K',10000).
> coefficients(substracted(),right(),'S',0).
> coefficients(substracted(),left(),'S',1).
> coefficients(substracted(),right(),'C',0).
> coefficients(substracted(),left(),'C',10100).
> coefficients(substracted(),right(),'I',0).
> coefficients(substracted(),left(),'I',1000).
> rightmost('A',right(),left(),9,9,0).
> rightmost('L',right(),left(),11,1,2).
> rightmost('Á',right(),left(),1,1,4).
> rightmost('Y',left(),right(),1,1,1).
> rightmost('T',left(),right(),99,9,0).
> rightmost('U',left(),right(),101,1,1).
> rightmost('K',left(),right(),1,1,4).
> rightmost('S',left(),right(),1,1,0).
> rightmost('C',left(),right(),101,1,2).
> rightmost('I',left(),right(),1,1,3).
>
>
>
> clauses
> num_qualified_additions(left(),2).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),0).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4F60).
> qualified_words(right(),00BE4F40).
> qualified_products(left(),01129FA0).
> qualified_products(right(),01129F78).
> global_max(5).
> relative_lengths_of_words(left(),[0],[2]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[],[]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(15483,184515)).
> code_ranges(right(),r(1123,98876)).
> intersection_of_ranges(r(20000,98876)).
> greatest_common_divisors(left(),1).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(left(),1,"CICUS",r(10000,98876)).
> limited_ranges(left(),1,"KUTYA",r(10000,98876)).
> limited_ranges(right(),1,"ÁLLAT",r(10000,98876)).
> substracted_ranges(right(),1,"ÁLLAT","Intersection",r(20000,98876)).
> substracted_ranges(left(),1,"CICUS","Intersection - KUTYA ",r(0,88876)).
> substracted_ranges(left(),1,"KUTYA","Intersection - CICUS ",r(0,88876)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",3,3).
> investigated_rules("Restrict range subtracting the limited range of other words on the same side.",2,2).
> investigated_rules("Compare limited and substracted ranges of words.",3,3).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",3,3).
> investigated_rules("Leading characters may not represent zero digits.",10,3).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",15,15).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",3,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("Is the substituted value of the left side is equal to that of the right side of the equation?",140,8).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",2160,2160).
> compared_ranges(right(),1,"ÁLLAT",r(20000,98876)).
> compared_ranges(left(),1,"CICUS",r(10000,88876)).
> compared_ranges(left(),1,"KUTYA",r(10000,88876)).
> divided_ranges(right(),"ÁLLAT",r(20000,98876)).
> divided_ranges(left(),"CICUS",r(10000,88876)).
> divided_ranges(left(),"KUTYA",r(10000,88876)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['I','C','S','K','U','Y','Á','L','A','T']).
> characters("leading",['C','K','Á']).
> characters("trailing",['S','A','T']).
> characters("known",[]).
> allowed_digits(a('I',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('C',['1','2','3','4','5','6','7','8'])).
> allowed_digits(a('S',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('K',['1','2','3','4','5','6','7','8'])).
> allowed_digits(a('U',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Y',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Á',['2','3','4','5','6','7','8','9'])).
> allowed_digits(a('L',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('A',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('T',['0','1','2','3','4','5','6','7','8','9'])).
> grouped_substitutions([g(['K','C'],['1','2','3','4','5','6','7','8']),g(['Á'],['2','3','4','5','6','7','8','9']),g(['T','A','L','Y','U','S','I'],['0','1','2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   0 7  10 A 0123456789","0   0 7  10 T 0123456789","0   0 8  10 S 0123456789","0   1 8  10 U 0123456789","0   1 8  10 Y 0123456789","0   2 8   8 C 12345678","0   2 8  10 L 0123456789","0   3 8  10 I 0123456789","0   4 8   8 K 12345678","0   4 8 8 Á 23456789"]).
> num_var(270950400).
>
>
>
> Condensed      puzzle         = KUTYA+CICUS=ÁLLAT
>
> Simplified     puzzle         = CICUS+KUTYA=ÁLLAT
>
>
2819a3911,4076
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","+=").
> characters("Codes","ÉNMÁULSJE").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: É and N and M and Á and U and L and S and J and E.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 5.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »ÉLJEN« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 5.")).
> classification("by contents of words","legal",accepted("Part #2 on the left contains the word »MÁJUS« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 2 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 6.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »ELSEJE« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 2 parts.")).
> classification("by count of parts","only additions",accepted("The left side of the simplified equation contains only 2 unfactored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","2 words=1 word",accepted("Two unfactored words on the left side, one unfactored word on the right side.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [20000, 199998].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [100000, 999999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [100000, 184073].")).
> num_read_parts(left(),2).
> num_read_parts(right(),1).
> read_parts(t(left(),00DB4F90)).
> read_parts(t(left(),00DB4ED0)).
> read_parts(t(right(),00DB4E88)).
> coefficients(summed(),right(),'E',100101).
> coefficients(summed(),right(),'J',10).
> coefficients(summed(),right(),'S',1000).
> coefficients(summed(),right(),'L',10000).
> coefficients(summed(),left(),'N',1).
> coefficients(summed(),left(),'E',10).
> coefficients(summed(),left(),'J',200).
> coefficients(summed(),left(),'L',1000).
> coefficients(summed(),left(),'É',10000).
> coefficients(summed(),left(),'S',1).
> coefficients(summed(),left(),'U',10).
> coefficients(summed(),left(),'Á',1000).
> coefficients(summed(),left(),'M',10000).
> coefficients(substracted(),left(),'E',0).
> coefficients(substracted(),right(),'E',100091).
> coefficients(substracted(),left(),'S',0).
> coefficients(substracted(),right(),'S',999).
> coefficients(substracted(),left(),'L',0).
> coefficients(substracted(),right(),'L',9000).
> coefficients(substracted(),right(),'N',0).
> coefficients(substracted(),left(),'N',1).
> coefficients(substracted(),right(),'J',0).
> coefficients(substracted(),left(),'J',190).
> coefficients(substracted(),right(),'É',0).
> coefficients(substracted(),left(),'É',10000).
> coefficients(substracted(),right(),'U',0).
> coefficients(substracted(),left(),'U',10).
> coefficients(substracted(),right(),'Á',0).
> coefficients(substracted(),left(),'Á',1000).
> coefficients(substracted(),right(),'M',0).
> coefficients(substracted(),left(),'M',10000).
> rightmost('E',right(),left(),100091,1,0).
> rightmost('S',right(),left(),999,9,0).
> rightmost('L',right(),left(),9,9,3).
> rightmost('N',left(),right(),1,1,0).
> rightmost('J',left(),right(),19,9,1).
> rightmost('É',left(),right(),1,1,4).
> rightmost('U',left(),right(),1,1,1).
> rightmost('Á',left(),right(),1,1,3).
> rightmost('M',left(),right(),1,1,4).
>
>
>
> clauses
> num_qualified_additions(left(),2).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),0).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4DC0).
> qualified_words(right(),00BE4DA0).
> qualified_products(left(),01129F50).
> qualified_products(right(),01129F28).
> global_max(6).
> relative_lengths_of_words(left(),[1],[2]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[],[]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(15925,184073)).
> code_ranges(right(),r(12030,987969)).
> intersection_of_ranges(r(100000,184073)).
> greatest_common_divisors(left(),1).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(left(),1,"MÁJUS",r(10000,99999)).
> limited_ranges(left(),1,"ÉLJEN",r(10000,99999)).
> limited_ranges(right(),1,"ELSEJE",r(100000,184073)).
> substracted_ranges(right(),1,"ELSEJE","Intersection",r(100000,184073)).
> substracted_ranges(left(),1,"MÁJUS","Intersection - ÉLJEN ",r(1,174073)).
> substracted_ranges(left(),1,"ÉLJEN","Intersection - MÁJUS ",r(1,174073)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",3,3).
> investigated_rules("Restrict range subtracting the limited range of other words on the same side.",2,2).
> investigated_rules("Compare limited and substracted ranges of words.",3,3).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",3,3).
> investigated_rules("Leading characters may not represent zero digits.",9,3).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",16,16).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",4,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",223,91).
> investigated_rules("The last code missing from the partial fit is a deterministic result of a division.",870,870).
> investigated_rules("Is the substituted value of the left side is equal to that of the right side of the equation?",512,8).
> compared_ranges(right(),1,"ELSEJE",r(100000,184073)).
> compared_ranges(left(),1,"MÁJUS",r(10000,99999)).
> compared_ranges(left(),1,"ÉLJEN",r(10000,99999)).
> divided_ranges(right(),"ELSEJE",r(100000,184073)).
> divided_ranges(left(),"MÁJUS",r(10000,99999)).
> divided_ranges(left(),"ÉLJEN",r(10000,99999)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['M','Á','U','É','N','L','S','J','E']).
> characters("leading",['M','É','E']).
> characters("trailing",['S','N','E']).
> characters("known",[]).
> allowed_digits(a('M',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Á',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('U',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('É',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('N',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('L',['0','1','2','3','4','5','6','7','8'])).
> allowed_digits(a('S',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('J',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('E',['1'])).
> grouped_substitutions([g(['L'],['0','2','3','4','5','6','7','8']),g(['É','M'],['2','3','4','5','6','7','8','9']),g(['J','S','N','U','Á'],['0','2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   0 7   9 S 023456789","0   0 8   9 N 023456789","0 1 7   9 J 023456789","0   1 8   9 U 023456789","0   3 7   8 L 02345678","0   3 8   9 Á 023456789","0   4 8   8 M 23456789","0   4 8 8 É 23456789"]).
> num_var(6773760).
> solved_fit(f('E','1')).
>
>
>
> Condensed      puzzle         = ÉLJEN+MÁJUS=ELSEJE
>
> Simplified     puzzle         = MÁJUS+ÉLJEN=ELSEJE
>
>
2871a4129,4294
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","+=").
> characters("Codes","VÍZBORITAL").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: V and Í and Z and B and O and R and I and T and A and L.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 3.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »VÍZ« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 3.")).
> classification("by contents of words","legal",accepted("Part #2 on the left contains the word »BOR« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 2 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 4.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »ITAL« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 2 parts.")).
> classification("by count of parts","only additions",accepted("The left side of the simplified equation contains only 2 unfactored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","2 words=1 word",accepted("Two unfactored words on the left side, one unfactored word on the right side.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [200, 1998].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [1000, 9999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [1000, 1839].")).
> num_read_parts(left(),2).
> num_read_parts(right(),1).
> read_parts(t(left(),00DB4F48)).
> read_parts(t(left(),00DB4E40)).
> read_parts(t(right(),00DB4DF8)).
> coefficients(summed(),right(),'L',1).
> coefficients(summed(),right(),'A',10).
> coefficients(summed(),right(),'T',100).
> coefficients(summed(),right(),'I',1000).
> coefficients(summed(),left(),'Z',1).
> coefficients(summed(),left(),'Í',10).
> coefficients(summed(),left(),'V',100).
> coefficients(summed(),left(),'R',1).
> coefficients(summed(),left(),'O',10).
> coefficients(summed(),left(),'B',100).
> coefficients(substracted(),left(),'L',0).
> coefficients(substracted(),right(),'L',1).
> coefficients(substracted(),left(),'A',0).
> coefficients(substracted(),right(),'A',10).
> coefficients(substracted(),left(),'T',0).
> coefficients(substracted(),right(),'T',100).
> coefficients(substracted(),left(),'I',0).
> coefficients(substracted(),right(),'I',1000).
> coefficients(substracted(),right(),'Z',0).
> coefficients(substracted(),left(),'Z',1).
> coefficients(substracted(),right(),'Í',0).
> coefficients(substracted(),left(),'Í',10).
> coefficients(substracted(),right(),'V',0).
> coefficients(substracted(),left(),'V',100).
> coefficients(substracted(),right(),'R',0).
> coefficients(substracted(),left(),'R',1).
> coefficients(substracted(),right(),'O',0).
> coefficients(substracted(),left(),'O',10).
> coefficients(substracted(),right(),'B',0).
> coefficients(substracted(),left(),'B',100).
> rightmost('L',right(),left(),1,1,0).
> rightmost('A',right(),left(),1,1,1).
> rightmost('T',right(),left(),1,1,2).
> rightmost('I',right(),left(),1,1,3).
> rightmost('Z',left(),right(),1,1,0).
> rightmost('Í',left(),right(),1,1,1).
> rightmost('V',left(),right(),1,1,2).
> rightmost('R',left(),right(),1,1,0).
> rightmost('O',left(),right(),1,1,1).
> rightmost('B',left(),right(),1,1,2).
>
>
>
> clauses
> num_qualified_additions(left(),2).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),0).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4E00).
> qualified_words(right(),00BE4DE0).
> qualified_products(left(),01129F00).
> qualified_products(right(),01129ED8).
> global_max(4).
> relative_lengths_of_words(left(),[1],[2]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[],[]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(159,1839)).
> code_ranges(right(),r(123,9876)).
> intersection_of_ranges(r(1000,1839)).
> greatest_common_divisors(left(),1).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(left(),1,"BOR",r(100,999)).
> limited_ranges(left(),1,"VÍZ",r(100,999)).
> limited_ranges(right(),1,"ITAL",r(1000,1839)).
> substracted_ranges(right(),1,"ITAL","Intersection",r(1000,1839)).
> substracted_ranges(left(),1,"BOR","Intersection - VÍZ ",r(1,1739)).
> substracted_ranges(left(),1,"VÍZ","Intersection - BOR ",r(1,1739)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",3,3).
> investigated_rules("Restrict range subtracting the limited range of other words on the same side.",2,2).
> investigated_rules("Compare limited and substracted ranges of words.",3,3).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",3,3).
> investigated_rules("Leading characters may not represent zero digits.",10,3).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",10,10).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",4,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("Is the substituted value of the left side is equal to that of the right side of the equation?",1872,96).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",1512,1512).
> compared_ranges(right(),1,"ITAL",r(1000,1839)).
> compared_ranges(left(),1,"BOR",r(100,999)).
> compared_ranges(left(),1,"VÍZ",r(100,999)).
> divided_ranges(right(),"ITAL",r(1000,1839)).
> divided_ranges(left(),"BOR",r(100,999)).
> divided_ranges(left(),"VÍZ",r(100,999)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['B','O','R','V','Í','Z','I','T','A','L']).
> characters("leading",['B','V','I']).
> characters("trailing",['R','Z','L']).
> characters("known",[]).
> allowed_digits(a('B',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('O',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('R',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('V',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Í',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Z',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('I',['1'])).
> allowed_digits(a('T',['0','1','2','3','4','5','6','7','8'])).
> allowed_digits(a('A',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('L',['0','1','2','3','4','5','6','7','8','9'])).
> grouped_substitutions([g(['T'],['0','2','3','4','5','6','7','8']),g(['V','B'],['2','3','4','5','6','7','8','9']),g(['L','A','Z','Í','R','O'],['0','2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   0 8   9 L 023456789","0   0 8   9 R 023456789","0 0 8   9 Z 023456789","0   1 8   9 A 023456789","0   1 8   9 O 023456789","0   1 8   9 Í 023456789","0   2 8   8 B 23456789","0   2 8 8 T 02345678","0   2 8   8 V 23456789"]).
> num_var(27095040).
> solved_fit(f('I','1')).
>
>
>
> Condensed      puzzle         = VÍZ+BOR=ITAL
>
> Simplified     puzzle         = BOR+VÍZ=ITAL
>
>
3363a4787,4953
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","+=").
> characters("Codes","GEBJAVÁROS").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: G and E and B and J and A and V and Á and R and O and S.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 4.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »EGER« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 4.")).
> classification("by contents of words","legal",accepted("Part #2 on the left contains the word »BAJA« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 2 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 5.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »VÁROS« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 2 parts.")).
> classification("by count of parts","only additions",accepted("The left side of the simplified equation contains only 2 unfactored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","2 words=1 word",accepted("Two unfactored words on the left side, one unfactored word on the right side.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [2000, 19998].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [10000, 99999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [10000, 18451].")).
> num_read_parts(left(),2).
> num_read_parts(right(),1).
> read_parts(t(left(),00DB4EB8)).
> read_parts(t(left(),00DB4DB0)).
> read_parts(t(right(),00DB4D68)).
> coefficients(summed(),right(),'S',1).
> coefficients(summed(),right(),'O',10).
> coefficients(summed(),right(),'R',100).
> coefficients(summed(),right(),'Á',1000).
> coefficients(summed(),right(),'V',10000).
> coefficients(summed(),left(),'R',1).
> coefficients(summed(),left(),'E',1010).
> coefficients(summed(),left(),'G',100).
> coefficients(summed(),left(),'A',101).
> coefficients(summed(),left(),'J',10).
> coefficients(summed(),left(),'B',1000).
> coefficients(substracted(),left(),'S',0).
> coefficients(substracted(),right(),'S',1).
> coefficients(substracted(),left(),'O',0).
> coefficients(substracted(),right(),'O',10).
> coefficients(substracted(),left(),'R',0).
> coefficients(substracted(),right(),'R',99).
> coefficients(substracted(),left(),'Á',0).
> coefficients(substracted(),right(),'Á',1000).
> coefficients(substracted(),left(),'V',0).
> coefficients(substracted(),right(),'V',10000).
> coefficients(substracted(),right(),'E',0).
> coefficients(substracted(),left(),'E',1010).
> coefficients(substracted(),right(),'G',0).
> coefficients(substracted(),left(),'G',100).
> coefficients(substracted(),right(),'A',0).
> coefficients(substracted(),left(),'A',101).
> coefficients(substracted(),right(),'J',0).
> coefficients(substracted(),left(),'J',10).
> coefficients(substracted(),right(),'B',0).
> coefficients(substracted(),left(),'B',1000).
> rightmost('S',right(),left(),1,1,0).
> rightmost('O',right(),left(),1,1,1).
> rightmost('R',right(),left(),99,9,0).
> rightmost('Á',right(),left(),1,1,3).
> rightmost('V',right(),left(),1,1,4).
> rightmost('E',left(),right(),101,1,1).
> rightmost('G',left(),right(),1,1,2).
> rightmost('A',left(),right(),101,1,0).
> rightmost('J',left(),right(),1,1,1).
> rightmost('B',left(),right(),1,1,3).
>
>
>
> clauses
> num_qualified_additions(left(),2).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),0).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4EC0).
> qualified_words(right(),00BE4E20).
> qualified_products(left(),01129EB0).
> qualified_products(right(),01129E88).
> global_max(5).
> relative_lengths_of_words(left(),[1],[2]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[],[]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(1547,18451)).
> code_ranges(right(),r(1234,98765)).
> intersection_of_ranges(r(10000,18451)).
> greatest_common_divisors(left(),1).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(left(),1,"BAJA",r(1000,9999)).
> limited_ranges(left(),1,"EGER",r(1000,9999)).
> limited_ranges(right(),1,"VÁROS",r(10000,18451)).
> substracted_ranges(right(),1,"VÁROS","Intersection",r(10000,18451)).
> substracted_ranges(left(),1,"BAJA","Intersection - EGER ",r(1,17451)).
> substracted_ranges(left(),1,"EGER","Intersection - BAJA ",r(1,17451)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",3,3).
> investigated_rules("Restrict range subtracting the limited range of other words on the same side.",2,2).
> investigated_rules("Compare limited and substracted ranges of words.",3,3).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",3,3).
> investigated_rules("Leading characters may not represent zero digits.",10,3).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",13,13).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",4,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",1766,1766).
> investigated_rules("Is the substituted value of the left side is equal to that of the right side of the equation?",169,9).
> compared_ranges(right(),1,"VÁROS",r(10000,18451)).
> compared_ranges(left(),1,"BAJA",r(1000,9999)).
> compared_ranges(left(),1,"EGER",r(1000,9999)).
> divided_ranges(right(),"VÁROS",r(10000,18451)).
> divided_ranges(left(),"BAJA",r(1000,9999)).
> divided_ranges(left(),"EGER",r(1000,9999)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['B','J','A','G','E','V','Á','R','O','S']).
> characters("leading",['B','E','V']).
> characters("trailing",['A','R','S']).
> characters("known",[]).
> allowed_digits(a('B',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('J',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('A',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('G',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('E',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('V',['1'])).
> allowed_digits(a('Á',['0','1','2','3','4','5','6','7','8'])).
> allowed_digits(a('R',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('O',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('S',['0','1','2','3','4','5','6','7','8','9'])).
> grouped_substitutions([g(['Á'],['0','2','3','4','5','6','7','8']),g(['E','B'],['2','3','4','5','6','7','8','9']),g(['S','O','R','G','A','J'],['0','2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   0 7   9 R 023456789","0   0 8   9 A 023456789","0 0 8   9 S 023456789","0   1 8   8 E 23456789","0   1 8   9 J 023456789","0   1 8   9 O 023456789","0   2 8   9 G 023456789","0   3 8 8 B 23456789","0   3 8   8 Á 02345678"]).
> num_var(27095040).
> solved_fit(f('V','1')).
>
>
>
> Condensed      puzzle         = EGER+BAJA=VÁROS
>
> Simplified     puzzle         = BAJA+EGER=VÁROS
>
>
3420a5011,5182
> Equation       judged         = The equation is accepted.
>
>
> Equation       parsed         = Elements of parsed equation
>
>
> clauses
> characters("Prohibited","").
> characters("Operator","+=").
> characters("Codes","KLBJDMARÓ").
> classification("by kinds of characters","legal",accepted("No prohibited characters found.")).
> classification("by kinds of characters","legal",accepted("The equation contains the following operators: + and =.")).
> classification("by kinds of characters","feasible",accepted("The equation contains the following codes: K and L and B and J and D and M and A and R and Ó.")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the  left is 4.")).
> classification("by contents of words","legal",accepted("Part #1 on the left contains the word »KLÓR« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #2 on the  left is 4.")).
> classification("by contents of words","legal",accepted("Part #2 on the left contains the word »BRÓM« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #2 on the  left contains a word.")).
> classification("by lengths of components","accepted",accepted("The length of the word #3 on the  left is 3.")).
> classification("by contents of words","legal",accepted("Part #3 on the left contains the word »JÓD« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #3 on the  left contains a word.")).
> classification("by splitting at operators","defined",accepted("The left side of the equation contains 3 part(s).")).
> classification("by lengths of components","accepted",accepted("The length of the word #1 on the right is 4.")).
> classification("by contents of words","legal",accepted("Part #1 on the right contains the word »MARÓ« composed of valid characters.")).
> classification("by splitting at operators","simple",accepted("Part #1 on the right contains a word.")).
> classification("by splitting at operators","defined",accepted("The right side of the equation contains 1 part(s).")).
> classification("by splitting at operators","normal",accepted("The equation contains exactly one equal sign.")).
> classification("by count of parts","filled",accepted("The  left side of the simplified equation contains 3 parts.")).
> classification("by count of parts","only additions",accepted("The left side of the simplified equation contains only 3 unfactored words.")).
> classification("by count of parts","simple",accepted("The right side of the simplified equation contains only one part.")).
> classification("by count of parts","only additions",accepted("The right side of the simplified equation contains only 1 unfactored words.")).
> classification("by count of parts","Many words=1 word",accepted("More than two unfactored words on the left side, one unfactored word on the right side.")).
> classification("by length of components","maybe",accepted("The problem may be solvable based on the relative lengths of the parts.")).
> classification("by estimated range","estimated",accepted("Range of values of  left side unfactored words = [2100, 20997].")).
> classification("by estimated range","estimated",accepted("Range of values of  left side factored products = [0, 0].")).
> classification("by estimated range","estimated",accepted("Range of values of right side unfactored words = [1000, 9999].")).
> classification("by estimated range","estimated",accepted("Range of values of right side factored products = [0, 0].")).
> classification("by estimated range","intersecting",accepted("Intersection of the ranges of the left and right sides= [2100, 9876].")).
> num_read_parts(left(),3).
> num_read_parts(right(),1).
> read_parts(t(left(),00DB4E28)).
> read_parts(t(left(),00DB4D20)).
> read_parts(t(left(),00DB4CD8)).
> read_parts(t(right(),00DB4C90)).
> coefficients(summed(),right(),'Ó',1).
> coefficients(summed(),right(),'R',10).
> coefficients(summed(),right(),'A',100).
> coefficients(summed(),right(),'M',1000).
> coefficients(summed(),left(),'D',1).
> coefficients(summed(),left(),'Ó',30).
> coefficients(summed(),left(),'J',100).
> coefficients(summed(),left(),'R',101).
> coefficients(summed(),left(),'L',100).
> coefficients(summed(),left(),'K',1000).
> coefficients(summed(),left(),'M',1).
> coefficients(summed(),left(),'B',1000).
> coefficients(substracted(),left(),'A',0).
> coefficients(substracted(),right(),'A',100).
> coefficients(substracted(),left(),'M',0).
> coefficients(substracted(),right(),'M',999).
> coefficients(substracted(),right(),'D',0).
> coefficients(substracted(),left(),'D',1).
> coefficients(substracted(),right(),'Ó',0).
> coefficients(substracted(),left(),'Ó',29).
> coefficients(substracted(),right(),'J',0).
> coefficients(substracted(),left(),'J',100).
> coefficients(substracted(),right(),'R',0).
> coefficients(substracted(),left(),'R',91).
> coefficients(substracted(),right(),'L',0).
> coefficients(substracted(),left(),'L',100).
> coefficients(substracted(),right(),'K',0).
> coefficients(substracted(),left(),'K',1000).
> coefficients(substracted(),right(),'B',0).
> coefficients(substracted(),left(),'B',1000).
> rightmost('A',right(),left(),1,1,2).
> rightmost('M',right(),left(),999,9,0).
> rightmost('D',left(),right(),1,1,0).
> rightmost('Ó',left(),right(),29,9,0).
> rightmost('J',left(),right(),1,1,2).
> rightmost('R',left(),right(),91,1,0).
> rightmost('L',left(),right(),1,1,2).
> rightmost('K',left(),right(),1,1,3).
> rightmost('B',left(),right(),1,1,3).
>
>
>
> clauses
> num_qualified_additions(left(),3).
> num_qualified_additions(right(),1).
> num_qualified_multiplications(left(),0).
> num_qualified_multiplications(right(),0).
> qualified_words(left(),00BE4CC0).
> qualified_words(right(),00BE4C60).
> qualified_products(left(),01129E60).
> qualified_products(right(),01129E38).
> global_max(4).
> relative_lengths_of_words(left(),[0,1],[2,1]).
> relative_lengths_of_words(right(),[0],[1]).
> relative_lengths_of_products(left(),[],[]).
> relative_lengths_of_products(right(),[],[]).
> code_ranges(left(),r(2065,18932)).
> code_ranges(right(),r(123,9876)).
> intersection_of_ranges(r(2100,9876)).
> greatest_common_divisors(left(),1).
> greatest_common_divisors(right(),1).
>
>
>
> Ranges         of words       = constraining the solutions
>
>
> clauses
> limited_ranges(left(),1,"BRÓM",r(1000,9876)).
> limited_ranges(left(),1,"KLÓR",r(1000,9876)).
> limited_ranges(left(),1,"JÓD",r(100,999)).
> limited_ranges(right(),1,"MARÓ",r(1000,9876)).
> substracted_ranges(right(),1,"MARÓ","Intersection",r(2100,9876)).
> substracted_ranges(left(),1,"BRÓM","Intersection - JÓD  - KLÓR ",r(0,8776)).
> substracted_ranges(left(),1,"KLÓR","Intersection - JÓD  - BRÓM ",r(0,8776)).
> substracted_ranges(left(),1,"JÓD","Intersection - KLÓR  - BRÓM ",r(0,7876)).
> investigated_rules("Get intersection of the ranges of the two sides.",1,1).
> investigated_rules("Limit range at the maximum of intersection of the ranges of the two sides.",4,4).
> investigated_rules("Restrict range subtracting the limited range of other words on the same side.",9,9).
> investigated_rules("Compare limited and substracted ranges of words.",4,4).
> investigated_rules("Ranges of words are counted from the ranges of products by division of the factor.",4,4).
> investigated_rules("Leading characters may not represent zero digits.",9,4).
> investigated_rules("Determine possible decimal digits at each words at given character positions.",15,15).
> investigated_rules("If more unknowns have less common possible values then the problem is unsolvable.",4,0).
> investigated_rules("If the count of different leading characters is greater than 9 then problem is unsolvable.",1,0).
> investigated_rules("If the next code has different rightmost distance from the end of the words then the values of current code can be restricted.",11706,1891).
> investigated_rules("The last code missing from the partial fit is a deterministic result of a division.",53235,53235).
> investigated_rules("Is the substituted value of the left side is equal to that of the right side of the equation?",37888,120).
> compared_ranges(right(),1,"MARÓ",r(2100,9876)).
> compared_ranges(left(),1,"BRÓM",r(1000,8776)).
> compared_ranges(left(),1,"KLÓR",r(1000,8776)).
> compared_ranges(left(),1,"JÓD",r(100,999)).
> divided_ranges(right(),"MARÓ",r(2100,9876)).
> divided_ranges(left(),"BRÓM",r(1000,8776)).
> divided_ranges(left(),"KLÓR",r(1000,8776)).
> divided_ranges(left(),"JÓD",r(100,999)).
>
>
>
> Possible       characters     = constraining the solutions
>
>
> clauses
> characters("unknown",['B','K','L','J','D','M','A','R','Ó']).
> characters("leading",['B','K','J','M']).
> characters("trailing",['M','R','D','Ó']).
> characters("known",[]).
> allowed_digits(a('B',['1','2','3','4','5','6','7','8'])).
> allowed_digits(a('K',['1','2','3','4','5','6','7','8'])).
> allowed_digits(a('L',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('J',['1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('D',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('M',['2','3','4','5','6','7','8','9'])).
> allowed_digits(a('A',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('R',['0','1','2','3','4','5','6','7','8','9'])).
> allowed_digits(a('Ó',['0','1','2','3','4','5','6','7','8','9'])).
> grouped_substitutions([g(['K','B'],['1','2','3','4','5','6','7','8']),g(['M'],['2','3','4','5','6','7','8','9']),g(['J'],['1','2','3','4','5','6','7','8','9']),g(['Ó','R','A','D','L'],['0','1','2','3','4','5','6','7','8','9'])]).
> ordered_codes(["0   0 7   8 M 23456789","0   0 7  10 Ó 0123456789","0 0 8  10 D 0123456789","0   0 8  10 R 0123456789","0   2 8   9 J 123456789","0   2 8  10 A 0123456789","0   2 8  10 L 0123456789","0   3 8   8 B 12345678","0   3 8   8 K 12345678"]).
> num_var(121927680).
>
>
>
> Condensed      puzzle         = KLÓR+BRÓM+JÓD=MARÓ
>
> Simplified     puzzle         = BRÓM+KLÓR+JÓD=MARÓ
>
>
4026,4054c5789,5790
< 2010. január 4. 8:58:45
< Action         = closed         file »magyarok00.aps« in folder »D:\Feri\SOAP\Results\«.
< =3, B=5, K=4, K=4, B=5, L=3, A=8, J=1, R=2, D=6, Ó=7, M=9.
< Solution       got            = 5279+4372+176=9827
<
<
< Solution       #              = 117
< Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=4, K=5, K=5, B=4, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.
< Solution       got            = 4279+5172+376=9827
<
<
< Solution       #              = 118
< Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=5, K=4, K=4, B=5, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.
< Solution       got            = 5279+4172+376=9827
<
<
< Solution       #              = 119
< Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=1, K=7, K=7, B=1, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.
< Solution       got            = 1589+7085+684=9358
<
<
< Solution       #              = 120
< Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=7, K=1, K=1, B=7, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.
< Solution       got            = 7589+1085+684=9358
<
<
< End of fit lists and results.
< 2010. január 4. 8:46:40
< Action         = closed         file »magyarok00.aps« in folder »D:\Feri\SOAP\Results\«.
---
> 2010. január 4. 9:15:26
> Action         = closed         file »magyarok10.aps« in folder »D:\Feri\SOAP\Results\«.


Comparison of Solution Files with and without Track

Two examples of solution file of Hungarian puzzles are compared.

This an example of solution file of Hungarian puzzles.

First one contains

¨ no classification

¨ no track

¨ all solutions.

Second one contains

¨ classification

¨ track

¨ first solution.

Porównaj: (<)D:\Feri\SOAP\Results\magyarok00.aps (318202 bajtów)

z: (>)D:\Feri\SOAP\Results\magyarok01.aps (1272922 bajtów)

1,2c1,136

< 2010. január 4. 8:57:57

< Action         = overwrite      unicode file »magyarok00.aps« in folder »D:\Feri\SOAP\Results\«.

---

> 2010. január 4. 9:21:07

> Action         = overwrite      unicode file »magyarok01.aps« in folder »D:\Feri\SOAP\Results\«.

>

> Current        code is        = 'Í'

> Intermediate   fit list       = Z=0, H=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = Í=2, Z=0, H=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'S'   = 1

> right          partial value  = 1000

> left           partial value  = 40

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = S=4, Í=2, Z=0, H=1.

> Remaining      digits         = 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Ú'

> Intermediate   fit list       = T=5, S=4, Í=2, Z=0, H=1.

> Remaining      digits         = 3 and 6 and 7 and 8 and 9.

>

>

> Calculated     ratio          = 0

> Calculated     modulus        = 0

>

> Partial        fit            = T=5, S=4, Í=2, Z=0, H=1.

> Partial        values         =                 1040 is equal to 1040.

>

> Coefficient    of 'Ú'         =                    0 is less than 100.

> Result of      predicate       = accepted("The final step could be shortened.")

>

> Calculated     digit          = 0.

>

>

> Remaining      digits         = 3, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Ú'

> Intermediate   fit list       = T=6, S=4, Í=2, Z=0, H=1.

> Remaining      digits         = 3 and 5 and 7 and 8 and 9.

>

>

> Calculated     ratio          = 2

> Calculated     modulus        = 0

>

> Partial        fit            = T=6, S=4, Í=2, Z=0, H=1.

> Partial        values         =                 1240 is greater than 1040.

>

> Coefficient    of 'Ú'         =                    0 is less than 100.

> Result of      predicate       = accepted("The final step could be shortened.")

>

> Calculated     digit          = 2.

>

>

> Remaining      digits         = 3, 5, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Ú'

> Intermediate   fit list       = T=7, S=4, Í=2, Z=0, H=1.

> Remaining      digits         = 3 and 5 and 6 and 8 and 9.

>

>

> Calculated     ratio          = 4

> Calculated     modulus        = 0

>

> Partial        fit            = T=7, S=4, Í=2, Z=0, H=1.

> Partial        values         =                 1440 is greater than 1040.

>

> Coefficient    of 'Ú'         =                    0 is less than 100.

> Result of      predicate       = accepted("The final step could be shortened.")

>

> Calculated     digit          = 4.

>

>

> Remaining      digits         = 3, 5, 6, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Ú'

> Intermediate   fit list       = T=8, S=4, Í=2, Z=0, H=1.

> Remaining      digits         = 3 and 5 and 6 and 7 and 9.

>

>

> Calculated     ratio          = 6

> Calculated     modulus        = 0

>

> Partial        fit            = T=8, S=4, Í=2, Z=0, H=1.

> Partial        values         =                 1640 is greater than 1040.

>

> Coefficient    of 'Ú'         =                    0 is less than 100.

> Result of      predicate       = accepted("The final step could be shortened.")

>

> Calculated     digit          = 6.

>

>

> Remaining      digits         = 3, 5, 6, 7, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Tried          fit            = Í=2, S=4, T=8, Ú=6, Ú=6, T=8, S=4, Í=2, Z=0, H=1.

> Results of     fit            = »2*820« related to     »1640«

> Values of      fit            = 1640 is equal to       1640.

>

>

9,10c143,149

< Tried          fits           = 11

< Matching       fits found     = 11

---

> Condensed      puzzle         = 2*TÍZ=HÚSZ

>

> Simplified     puzzle         = 2*TÍZ=HÚSZ

>

>

> Tried          fits           = 1

> Matching       fits found     = 1

19,80c158,1633

< Solution       #              = 2

< Solution       fitted         = Í=2, S=4, T=9, Ú=8, Ú=8, T=9, S=4, Í=2, Z=0, H=1.

< Solution       got            = 2*920=1840

<

<

< Solution       #              = 3

< Solution       fitted         = Í=3, S=6, T=7, Ú=4, Ú=4, T=7, S=6, Í=3, Z=0, H=1.

< Solution       got            = 2*730=1460

<

<

< Solution       #              = 4

< Solution       fitted         = Í=3, S=6, T=9, Ú=8, Ú=8, T=9, S=6, Í=3, Z=0, H=1.

< Solution       got            = 2*930=1860

<

<

< Solution       #              = 5

< Solution       fitted         = Í=4, S=8, T=6, Ú=2, Ú=2, T=6, S=8, Í=4, Z=0, H=1.

< Solution       got            = 2*640=1280

<

<

< Solution       #              = 6

< Solution       fitted         = Í=6, S=2, T=7, Ú=5, Ú=5, T=7, S=2, Í=6, Z=0, H=1.

< Solution       got            = 2*760=1520

<

<

< Solution       #              = 7

< Solution       fitted         = Í=6, S=2, T=8, Ú=7, Ú=7, T=8, S=2, Í=6, Z=0, H=1.

< Solution       got            = 2*860=1720

<

<

< Solution       #              = 8

< Solution       fitted         = Í=7, S=4, T=6, Ú=3, Ú=3, T=6, S=4, Í=7, Z=0, H=1.

< Solution       got            = 2*670=1340

<

<

< Solution       #              = 9

< Solution       fitted         = Í=8, S=6, T=7, Ú=5, Ú=5, T=7, S=6, Í=8, Z=0, H=1.

< Solution       got            = 2*780=1560

<

<

< Solution       #              = 10

< Solution       fitted         = Í=9, S=8, T=6, Ú=3, Ú=3, T=6, S=8, Í=9, Z=0, H=1.

< Solution       got            = 2*690=1380

<

<

< Solution       #              = 11

< Solution       fitted         = Í=9, S=8, T=7, Ú=5, Ú=5, T=7, S=8, Í=9, Z=0, H=1.

< Solution       got            = 2*790=1580

<

<

< End of fit lists and results.

<

< Condensed      puzzle         = ÖT+EGY=HAT

<

< Simplified     puzzle         = EGY+ÖT=HAT

<

<

< Tried          fits           = 432

< Matching       fits found     = 432

<

< Start of fit lists and results:

<

---

> End of fit lists and results.

>

> Current        code is        = 'Y'

> Intermediate   fit list       = empty.

> Remaining      digits         = 0 and 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Y'   = 0

> left           partial value  = 0

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = 0.

> Number of      elements       = 1

>

>

> Current        code is        = 'Ö'

> Intermediate   fit list       = Y=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'G'

> Intermediate   fit list       = A=2, Ö=1, Y=0.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'G'   = 1

> left           partial value  = 10

> right          partial value  = 20

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 2

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'G'

> Intermediate   fit list       = A=3, Ö=1, Y=0.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'G'   = 1

> left           partial value  = 10

> right          partial value  = 30

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 3

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = G=2, A=3, Ö=1, Y=0.

> Remaining      digits         = 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=4, G=2, A=3, Ö=1, Y=0.

> Remaining      digits         = 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 30

> left           partial value  = 430

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 5, 6, 7, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=5, G=2, A=3, Ö=1, Y=0.

> Remaining      digits         = 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 30

> left           partial value  = 530

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 4, 6, 7, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=6, G=2, A=3, Ö=1, Y=0.

> Remaining      digits         = 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 30

> left           partial value  = 630

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 4, 5, 7, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=7, G=2, A=3, Ö=1, Y=0.

> Remaining      digits         = 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 30

> left           partial value  = 730

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 4, 5, 6, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=8, G=2, A=3, Ö=1, Y=0.

> Remaining      digits         = 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 30

> left           partial value  = 830

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 4, 5, 6, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=9, G=2, A=3, Ö=1, Y=0.

> Remaining      digits         = 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 30

> left           partial value  = 930

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 4, 5, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'G'

> Intermediate   fit list       = A=4, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'G'   = 1

> left           partial value  = 10

> right          partial value  = 40

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 4

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 3, 5, 6, 7, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = G=3, A=4, Ö=1, Y=0.

> Remaining      digits         = 2 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=2, G=3, A=4, Ö=1, Y=0.

> Remaining      digits         = 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 40

> left           partial value  = 240

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 5, 6, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=5, G=3, A=4, Ö=1, Y=0.

> Remaining      digits         = 2 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 40

> left           partial value  = 540

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 6, 7, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=6, G=3, A=4, Ö=1, Y=0.

> Remaining      digits         = 2 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 40

> left           partial value  = 640

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 5, 7, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=7, G=3, A=4, Ö=1, Y=0.

> Remaining      digits         = 2 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 40

> left           partial value  = 740

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 5, 6, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=8, G=3, A=4, Ö=1, Y=0.

> Remaining      digits         = 2 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 40

> left           partial value  = 840

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 5, 6, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=9, G=3, A=4, Ö=1, Y=0.

> Remaining      digits         = 2 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 40

> left           partial value  = 940

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 5, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'G'

> Intermediate   fit list       = A=5, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'G'   = 1

> left           partial value  = 10

> right          partial value  = 50

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 5

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = G=4, A=5, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=2, G=4, A=5, Ö=1, Y=0.

> Remaining      digits         = 3 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 50

> left           partial value  = 250

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 6, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=3, G=4, A=5, Ö=1, Y=0.

> Remaining      digits         = 2 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 50

> left           partial value  = 350

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 6, 7, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=6, G=4, A=5, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 50

> left           partial value  = 650

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 7, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=7, G=4, A=5, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 6 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 50

> left           partial value  = 750

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 6, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=8, G=4, A=5, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 6 and 7 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 50

> left           partial value  = 850

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 6, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=9, G=4, A=5, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 6 and 7 and 8.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 50

> left           partial value  = 950

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'G'

> Intermediate   fit list       = A=6, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'G'   = 1

> left           partial value  = 10

> right          partial value  = 60

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 6

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = G=5, A=6, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=2, G=5, A=6, Ö=1, Y=0.

> Remaining      digits         = 3 and 4 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 60

> left           partial value  = 260

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 4, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=3, G=5, A=6, Ö=1, Y=0.

> Remaining      digits         = 2 and 4 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 60

> left           partial value  = 360

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 4, 7, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=4, G=5, A=6, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 7 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 60

> left           partial value  = 460

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 7, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=7, G=5, A=6, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 60

> left           partial value  = 760

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 4, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=8, G=5, A=6, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 7 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 60

> left           partial value  = 860

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 4, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=9, G=5, A=6, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 7 and 8.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 60

> left           partial value  = 960

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 4, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'G'

> Intermediate   fit list       = A=7, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'G'   = 1

> left           partial value  = 10

> right          partial value  = 70

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 7

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = G=6, A=7, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 8 and 9.

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=2, G=6, A=7, Ö=1, Y=0.

> Remaining      digits         = 3 and 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 70

> left           partial value  = 270

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 4, 5, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=3, G=6, A=7, Ö=1, Y=0.

> Remaining      digits         = 2 and 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 70

> left           partial value  = 370

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 4, 5, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=4, G=6, A=7, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 5 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 70

> left           partial value  = 470

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 5, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=5, G=6, A=7, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 8 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 70

> left           partial value  = 570

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=8, G=6, A=7, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 70

> left           partial value  = 870

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 4, 5, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=9, G=6, A=7, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 8.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 70

> left           partial value  = 970

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 4, 5, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'G'

> Intermediate   fit list       = A=8, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'G'   = 1

> left           partial value  = 10

> right          partial value  = 80

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 8

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = G=7, A=8, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 9.

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=2, G=7, A=8, Ö=1, Y=0.

> Remaining      digits         = 3 and 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 80

> left           partial value  = 280

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 4, 5, 6, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=3, G=7, A=8, Ö=1, Y=0.

> Remaining      digits         = 2 and 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 80

> left           partial value  = 380

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 4, 5, 6, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=4, G=7, A=8, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 5 and 6 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 80

> left           partial value  = 480

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 5, 6, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=5, G=7, A=8, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 6 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 80

> left           partial value  = 580

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 6, 9.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=6, G=7, A=8, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 9.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 80

> left           partial value  = 680

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 4, 5, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=9, G=7, A=8, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 80

> left           partial value  = 980

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'G'

> Intermediate   fit list       = A=9, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'G'   = 1

> left           partial value  = 10

> right          partial value  = 90

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 9

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = G=8, A=9, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7.

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=2, G=8, A=9, Ö=1, Y=0.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 90

> left           partial value  = 290

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=3, G=8, A=9, Ö=1, Y=0.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 90

> left           partial value  = 390

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 4, 5, 6, 7.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=4, G=8, A=9, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 5 and 6 and 7.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 90

> left           partial value  = 490

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 5, 6, 7.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=5, G=8, A=9, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 6 and 7.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 90

> left           partial value  = 590

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 6, 7.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=6, G=8, A=9, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 7.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 90

> left           partial value  = 690

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 4, 5, 7.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=7, G=8, A=9, Ö=1, Y=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 90

> left           partial value  = 790

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Ö=2, Y=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'G'

> Intermediate   fit list       = A=1, Ö=2, Y=0.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'G'   = 1

> left           partial value  = 20

> right          partial value  = 10

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 1

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = G=9, A=1, Ö=2, Y=0.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = E=3, G=9, A=1, Ö=2, Y=0.

> Remaining      digits         = 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'H'   = 2

> right          partial value  = 10

> left           partial value  = 410

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 4, 5, 6, 7, 8.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = H=4, E=3, G=9, A=1, Ö=2, Y=0.

> Remaining      digits         = 5 and 6 and 7 and 8.

>

>

> Partial        fit            = H=4, E=3, G=9, A=1, Ö=2, Y=0.

> Partial        values         =                  410 is equal to 410.

>

> Coefficient    of 'T'         =                    0 is equal to 0.

> Result of      predicate       = accepted("The final step could not be shortened.")

>

> Calculated     digit          = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

>

>

> Remaining      digits         = 5, 6, 7, 8.

> Possible       digits         = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

> Intersection   of them        = 5, 6, 7, 8.

> Number of      elements       = 4

>

>

> Tried          fit            = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=5, T=5, H=4, E=3, G=9, A=1, Ö=2, Y=0.

> Results of     fit            = »390+25« related to     »415«

> Values of      fit            = 415 is equal to       415.

>

>

>

> Condensed      puzzle         = ÖT+EGY=HAT

>

> Simplified     puzzle         = EGY+ÖT=HAT

>

>

> Condensed      puzzle         = ÖT+EGY=HAT

>

> Simplified     puzzle         = EGY+ÖT=HAT

>

>

> Tried          fits           = 1

> Matching       fits found     = 1

>

> Start of fit lists and results:

>

86,2241c1639,1644

< Solution       #              = 2

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=6, T=6, H=4, E=3, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 390+26=416

<

<

< Solution       #              = 3

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=7, T=7, H=4, E=3, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 390+27=417

<

<

< Solution       #              = 4

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=3, H=4, T=8, T=8, H=4, E=3, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 390+28=418

<

<

< Solution       #              = 5

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=4, H=5, T=3, T=3, H=5, E=4, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 490+23=513

<

<

< Solution       #              = 6

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=4, H=5, T=6, T=6, H=5, E=4, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 490+26=516

<

<

< Solution       #              = 7

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=4, H=5, T=7, T=7, H=5, E=4, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 490+27=517

<

<

< Solution       #              = 8

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=4, H=5, T=8, T=8, H=5, E=4, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 490+28=518

<

<

< Solution       #              = 9

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=5, H=6, T=3, T=3, H=6, E=5, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 590+23=613

<

<

< Solution       #              = 10

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=5, H=6, T=4, T=4, H=6, E=5, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 590+24=614

<

<

< Solution       #              = 11

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=5, H=6, T=7, T=7, H=6, E=5, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 590+27=617

<

<

< Solution       #              = 12

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=5, H=6, T=8, T=8, H=6, E=5, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 590+28=618

<

<

< Solution       #              = 13

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=6, H=7, T=3, T=3, H=7, E=6, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 690+23=713

<

<

< Solution       #              = 14

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=6, H=7, T=4, T=4, H=7, E=6, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 690+24=714

<

<

< Solution       #              = 15

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=6, H=7, T=5, T=5, H=7, E=6, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 690+25=715

<

<

< Solution       #              = 16

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=6, H=7, T=8, T=8, H=7, E=6, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 690+28=718

<

<

< Solution       #              = 17

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=7, H=8, T=3, T=3, H=8, E=7, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 790+23=813

<

<

< Solution       #              = 18

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=7, H=8, T=4, T=4, H=8, E=7, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 790+24=814

<

<

< Solution       #              = 19

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=7, H=8, T=5, T=5, H=8, E=7, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 790+25=815

<

<

< Solution       #              = 20

< Solution       fitted         = Y=0, Ö=2, A=1, G=9, E=7, H=8, T=6, T=6, H=8, E=7, G=9, A=1, Ö=2, Y=0.

< Solution       got            = 790+26=816

<

<

< Solution       #              = 21

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=4, H=5, T=2, T=2, H=5, E=4, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 480+32=512

<

<

< Solution       #              = 22

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=4, H=5, T=6, T=6, H=5, E=4, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 480+36=516

<

<

< Solution       #              = 23

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=4, H=5, T=7, T=7, H=5, E=4, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 480+37=517

<

<

< Solution       #              = 24

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=4, H=5, T=9, T=9, H=5, E=4, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 480+39=519

<

<

< Solution       #              = 25

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=5, H=6, T=2, T=2, H=6, E=5, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 580+32=612

<

<

< Solution       #              = 26

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=5, H=6, T=4, T=4, H=6, E=5, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 580+34=614

<

<

< Solution       #              = 27

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=5, H=6, T=7, T=7, H=6, E=5, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 580+37=617

<

<

< Solution       #              = 28

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=5, H=6, T=9, T=9, H=6, E=5, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 580+39=619

<

<

< Solution       #              = 29

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=6, H=7, T=2, T=2, H=7, E=6, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 680+32=712

<

<

< Solution       #              = 30

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=6, H=7, T=4, T=4, H=7, E=6, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 680+34=714

<

<

< Solution       #              = 31

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=6, H=7, T=5, T=5, H=7, E=6, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 680+35=715

<

<

< Solution       #              = 32

< Solution       fitted         = Y=0, Ö=3, A=1, G=8, E=6, H=7, T=9, T=9, H=7, E=6, G=8, A=1, Ö=3, Y=0.

< Solution       got            = 680+39=719

<

<

< Solution       #              = 33

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=4, H=5, T=1, T=1, H=5, E=4, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 490+31=521

<

<

< Solution       #              = 34

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=4, H=5, T=6, T=6, H=5, E=4, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 490+36=526

<

<

< Solution       #              = 35

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=4, H=5, T=7, T=7, H=5, E=4, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 490+37=527

<

<

< Solution       #              = 36

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=4, H=5, T=8, T=8, H=5, E=4, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 490+38=528

<

<

< Solution       #              = 37

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=5, H=6, T=1, T=1, H=6, E=5, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 590+31=621

<

<

< Solution       #              = 38

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=5, H=6, T=4, T=4, H=6, E=5, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 590+34=624

<

<

< Solution       #              = 39

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=5, H=6, T=7, T=7, H=6, E=5, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 590+37=627

<

<

< Solution       #              = 40

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=5, H=6, T=8, T=8, H=6, E=5, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 590+38=628

<

<

< Solution       #              = 41

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=6, H=7, T=1, T=1, H=7, E=6, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 690+31=721

<

<

< Solution       #              = 42

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=6, H=7, T=4, T=4, H=7, E=6, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 690+34=724

<

<

< Solution       #              = 43

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=6, H=7, T=5, T=5, H=7, E=6, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 690+35=725

<

<

< Solution       #              = 44

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=6, H=7, T=8, T=8, H=7, E=6, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 690+38=728

<

<

< Solution       #              = 45

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=7, H=8, T=1, T=1, H=8, E=7, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 790+31=821

<

<

< Solution       #              = 46

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=7, H=8, T=4, T=4, H=8, E=7, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 790+34=824

<

<

< Solution       #              = 47

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=7, H=8, T=5, T=5, H=8, E=7, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 790+35=825

<

<

< Solution       #              = 48

< Solution       fitted         = Y=0, Ö=3, A=2, G=9, E=7, H=8, T=6, T=6, H=8, E=7, G=9, A=2, Ö=3, Y=0.

< Solution       got            = 790+36=826

<

<

< Solution       #              = 49

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=2, H=3, T=5, T=5, H=3, E=2, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 270+45=315

<

<

< Solution       #              = 50

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=2, H=3, T=6, T=6, H=3, E=2, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 270+46=316

<

<

< Solution       #              = 51

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=2, H=3, T=8, T=8, H=3, E=2, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 270+48=318

<

<

< Solution       #              = 52

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=2, H=3, T=9, T=9, H=3, E=2, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 270+49=319

<

<

< Solution       #              = 53

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=5, H=6, T=2, T=2, H=6, E=5, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 570+42=612

<

<

< Solution       #              = 54

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=5, H=6, T=3, T=3, H=6, E=5, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 570+43=613

<

<

< Solution       #              = 55

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=5, H=6, T=8, T=8, H=6, E=5, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 570+48=618

<

<

< Solution       #              = 56

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=5, H=6, T=9, T=9, H=6, E=5, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 570+49=619

<

<

< Solution       #              = 57

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=8, H=9, T=2, T=2, H=9, E=8, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 870+42=912

<

<

< Solution       #              = 58

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=8, H=9, T=3, T=3, H=9, E=8, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 870+43=913

<

<

< Solution       #              = 59

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=8, H=9, T=5, T=5, H=9, E=8, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 870+45=915

<

<

< Solution       #              = 60

< Solution       fitted         = Y=0, Ö=4, A=1, G=7, E=8, H=9, T=6, T=6, H=9, E=8, G=7, A=1, Ö=4, Y=0.

< Solution       got            = 870+46=916

<

<

< Solution       #              = 61

< Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=5, H=6, T=1, T=1, H=6, E=5, G=8, A=2, Ö=4, Y=0.

< Solution       got            = 580+41=621

<

<

< Solution       #              = 62

< Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=5, H=6, T=3, T=3, H=6, E=5, G=8, A=2, Ö=4, Y=0.

< Solution       got            = 580+43=623

<

<

< Solution       #              = 63

< Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=5, H=6, T=7, T=7, H=6, E=5, G=8, A=2, Ö=4, Y=0.

< Solution       got            = 580+47=627

<

<

< Solution       #              = 64

< Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=5, H=6, T=9, T=9, H=6, E=5, G=8, A=2, Ö=4, Y=0.

< Solution       got            = 580+49=629

<

<

< Solution       #              = 65

< Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=6, H=7, T=1, T=1, H=7, E=6, G=8, A=2, Ö=4, Y=0.

< Solution       got            = 680+41=721

<

<

< Solution       #              = 66

< Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=6, H=7, T=3, T=3, H=7, E=6, G=8, A=2, Ö=4, Y=0.

< Solution       got            = 680+43=723

<

<

< Solution       #              = 67

< Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=6, H=7, T=5, T=5, H=7, E=6, G=8, A=2, Ö=4, Y=0.

< Solution       got            = 680+45=725

<

<

< Solution       #              = 68

< Solution       fitted         = Y=0, Ö=4, A=2, G=8, E=6, H=7, T=9, T=9, H=7, E=6, G=8, A=2, Ö=4, Y=0.

< Solution       got            = 680+49=729

<

<

< Solution       #              = 69

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=1, H=2, T=5, T=5, H=2, E=1, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 190+45=235

<

<

< Solution       #              = 70

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=1, H=2, T=6, T=6, H=2, E=1, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 190+46=236

<

<

< Solution       #              = 71

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=1, H=2, T=7, T=7, H=2, E=1, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 190+47=237

<

<

< Solution       #              = 72

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=1, H=2, T=8, T=8, H=2, E=1, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 190+48=238

<

<

< Solution       #              = 73

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=5, H=6, T=1, T=1, H=6, E=5, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 590+41=631

<

<

< Solution       #              = 74

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=5, H=6, T=2, T=2, H=6, E=5, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 590+42=632

<

<

< Solution       #              = 75

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=5, H=6, T=7, T=7, H=6, E=5, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 590+47=637

<

<

< Solution       #              = 76

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=5, H=6, T=8, T=8, H=6, E=5, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 590+48=638

<

<

< Solution       #              = 77

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=6, H=7, T=1, T=1, H=7, E=6, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 690+41=731

<

<

< Solution       #              = 78

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=6, H=7, T=2, T=2, H=7, E=6, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 690+42=732

<

<

< Solution       #              = 79

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=6, H=7, T=5, T=5, H=7, E=6, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 690+45=735

<

<

< Solution       #              = 80

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=6, H=7, T=8, T=8, H=7, E=6, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 690+48=738

<

<

< Solution       #              = 81

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=7, H=8, T=1, T=1, H=8, E=7, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 790+41=831

<

<

< Solution       #              = 82

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=7, H=8, T=2, T=2, H=8, E=7, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 790+42=832

<

<

< Solution       #              = 83

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=7, H=8, T=5, T=5, H=8, E=7, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 790+45=835

<

<

< Solution       #              = 84

< Solution       fitted         = Y=0, Ö=4, A=3, G=9, E=7, H=8, T=6, T=6, H=8, E=7, G=9, A=3, Ö=4, Y=0.

< Solution       got            = 790+46=836

<

<

< Solution       #              = 85

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=2, H=3, T=4, T=4, H=3, E=2, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 260+54=314

<

<

< Solution       #              = 86

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=2, H=3, T=7, T=7, H=3, E=2, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 260+57=317

<

<

< Solution       #              = 87

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=2, H=3, T=8, T=8, H=3, E=2, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 260+58=318

<

<

< Solution       #              = 88

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=2, H=3, T=9, T=9, H=3, E=2, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 260+59=319

<

<

< Solution       #              = 89

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=3, H=4, T=2, T=2, H=4, E=3, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 360+52=412

<

<

< Solution       #              = 90

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=3, H=4, T=7, T=7, H=4, E=3, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 360+57=417

<

<

< Solution       #              = 91

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=3, H=4, T=8, T=8, H=4, E=3, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 360+58=418

<

<

< Solution       #              = 92

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=3, H=4, T=9, T=9, H=4, E=3, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 360+59=419

<

<

< Solution       #              = 93

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=7, H=8, T=2, T=2, H=8, E=7, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 760+52=812

<

<

< Solution       #              = 94

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=7, H=8, T=3, T=3, H=8, E=7, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 760+53=813

<

<

< Solution       #              = 95

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=7, H=8, T=4, T=4, H=8, E=7, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 760+54=814

<

<

< Solution       #              = 96

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=7, H=8, T=9, T=9, H=8, E=7, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 760+59=819

<

<

< Solution       #              = 97

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=8, H=9, T=2, T=2, H=9, E=8, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 860+52=912

<

<

< Solution       #              = 98

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=8, H=9, T=3, T=3, H=9, E=8, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 860+53=913

<

<

< Solution       #              = 99

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=8, H=9, T=4, T=4, H=9, E=8, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 860+54=914

<

<

< Solution       #              = 100

< Solution       fitted         = Y=0, Ö=5, A=1, G=6, E=8, H=9, T=7, T=7, H=9, E=8, G=6, A=1, Ö=5, Y=0.

< Solution       got            = 860+57=917

<

<

< Solution       #              = 101

< Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=3, H=4, T=1, T=1, H=4, E=3, G=7, A=2, Ö=5, Y=0.

< Solution       got            = 370+51=421

<

<

< Solution       #              = 102

< Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=3, H=4, T=6, T=6, H=4, E=3, G=7, A=2, Ö=5, Y=0.

< Solution       got            = 370+56=426

<

<

< Solution       #              = 103

< Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=3, H=4, T=8, T=8, H=4, E=3, G=7, A=2, Ö=5, Y=0.

< Solution       got            = 370+58=428

<

<

< Solution       #              = 104

< Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=3, H=4, T=9, T=9, H=4, E=3, G=7, A=2, Ö=5, Y=0.

< Solution       got            = 370+59=429

<

<

< Solution       #              = 105

< Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=8, H=9, T=1, T=1, H=9, E=8, G=7, A=2, Ö=5, Y=0.

< Solution       got            = 870+51=921

<

<

< Solution       #              = 106

< Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=8, H=9, T=3, T=3, H=9, E=8, G=7, A=2, Ö=5, Y=0.

< Solution       got            = 870+53=923

<

<

< Solution       #              = 107

< Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=8, H=9, T=4, T=4, H=9, E=8, G=7, A=2, Ö=5, Y=0.

< Solution       got            = 870+54=924

<

<

< Solution       #              = 108

< Solution       fitted         = Y=0, Ö=5, A=2, G=7, E=8, H=9, T=6, T=6, H=9, E=8, G=7, A=2, Ö=5, Y=0.

< Solution       got            = 870+56=926

<

<

< Solution       #              = 109

< Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=1, H=2, T=4, T=4, H=2, E=1, G=8, A=3, Ö=5, Y=0.

< Solution       got            = 180+54=234

<

<

< Solution       #              = 110

< Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=1, H=2, T=6, T=6, H=2, E=1, G=8, A=3, Ö=5, Y=0.

< Solution       got            = 180+56=236

<

<

< Solution       #              = 111

< Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=1, H=2, T=7, T=7, H=2, E=1, G=8, A=3, Ö=5, Y=0.

< Solution       got            = 180+57=237

<

<

< Solution       #              = 112

< Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=1, H=2, T=9, T=9, H=2, E=1, G=8, A=3, Ö=5, Y=0.

< Solution       got            = 180+59=239

<

<

< Solution       #              = 113

< Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=6, H=7, T=1, T=1, H=7, E=6, G=8, A=3, Ö=5, Y=0.

< Solution       got            = 680+51=731

<

<

< Solution       #              = 114

< Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=6, H=7, T=2, T=2, H=7, E=6, G=8, A=3, Ö=5, Y=0.

< Solution       got            = 680+52=732

<

<

< Solution       #              = 115

< Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=6, H=7, T=4, T=4, H=7, E=6, G=8, A=3, Ö=5, Y=0.

< Solution       got            = 680+54=734

<

<

< Solution       #              = 116

< Solution       fitted         = Y=0, Ö=5, A=3, G=8, E=6, H=7, T=9, T=9, H=7, E=6, G=8, A=3, Ö=5, Y=0.

< Solution       got            = 680+59=739

<

<

< Solution       #              = 117

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=1, H=2, T=3, T=3, H=2, E=1, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 190+53=243

<

<

< Solution       #              = 118

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=1, H=2, T=6, T=6, H=2, E=1, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 190+56=246

<

<

< Solution       #              = 119

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=1, H=2, T=7, T=7, H=2, E=1, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 190+57=247

<

<

< Solution       #              = 120

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=1, H=2, T=8, T=8, H=2, E=1, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 190+58=248

<

<

< Solution       #              = 121

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=2, H=3, T=1, T=1, H=3, E=2, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 290+51=341

<

<

< Solution       #              = 122

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=2, H=3, T=6, T=6, H=3, E=2, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 290+56=346

<

<

< Solution       #              = 123

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=2, H=3, T=7, T=7, H=3, E=2, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 290+57=347

<

<

< Solution       #              = 124

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=2, H=3, T=8, T=8, H=3, E=2, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 290+58=348

<

<

< Solution       #              = 125

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=6, H=7, T=1, T=1, H=7, E=6, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 690+51=741

<

<

< Solution       #              = 126

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=6, H=7, T=2, T=2, H=7, E=6, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 690+52=742

<

<

< Solution       #              = 127

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=6, H=7, T=3, T=3, H=7, E=6, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 690+53=743

<

<

< Solution       #              = 128

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=6, H=7, T=8, T=8, H=7, E=6, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 690+58=748

<

<

< Solution       #              = 129

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=7, H=8, T=1, T=1, H=8, E=7, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 790+51=841

<

<

< Solution       #              = 130

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=7, H=8, T=2, T=2, H=8, E=7, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 790+52=842

<

<

< Solution       #              = 131

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=7, H=8, T=3, T=3, H=8, E=7, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 790+53=843

<

<

< Solution       #              = 132

< Solution       fitted         = Y=0, Ö=5, A=4, G=9, E=7, H=8, T=6, T=6, H=8, E=7, G=9, A=4, Ö=5, Y=0.

< Solution       got            = 790+56=846

<

<

< Solution       #              = 133

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=2, H=3, T=4, T=4, H=3, E=2, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 250+64=314

<

<

< Solution       #              = 134

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=2, H=3, T=7, T=7, H=3, E=2, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 250+67=317

<

<

< Solution       #              = 135

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=2, H=3, T=8, T=8, H=3, E=2, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 250+68=318

<

<

< Solution       #              = 136

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=2, H=3, T=9, T=9, H=3, E=2, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 250+69=319

<

<

< Solution       #              = 137

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=3, H=4, T=2, T=2, H=4, E=3, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 350+62=412

<

<

< Solution       #              = 138

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=3, H=4, T=7, T=7, H=4, E=3, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 350+67=417

<

<

< Solution       #              = 139

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=3, H=4, T=8, T=8, H=4, E=3, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 350+68=418

<

<

< Solution       #              = 140

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=3, H=4, T=9, T=9, H=4, E=3, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 350+69=419

<

<

< Solution       #              = 141

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=7, H=8, T=2, T=2, H=8, E=7, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 750+62=812

<

<

< Solution       #              = 142

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=7, H=8, T=3, T=3, H=8, E=7, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 750+63=813

<

<

< Solution       #              = 143

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=7, H=8, T=4, T=4, H=8, E=7, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 750+64=814

<

<

< Solution       #              = 144

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=7, H=8, T=9, T=9, H=8, E=7, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 750+69=819

<

<

< Solution       #              = 145

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=8, H=9, T=2, T=2, H=9, E=8, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 850+62=912

<

<

< Solution       #              = 146

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=8, H=9, T=3, T=3, H=9, E=8, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 850+63=913

<

<

< Solution       #              = 147

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=8, H=9, T=4, T=4, H=9, E=8, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 850+64=914

<

<

< Solution       #              = 148

< Solution       fitted         = Y=0, Ö=6, A=1, G=5, E=8, H=9, T=7, T=7, H=9, E=8, G=5, A=1, Ö=6, Y=0.

< Solution       got            = 850+67=917

<

<

< Solution       #              = 149

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=1, H=2, T=4, T=4, H=2, E=1, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 170+64=234

<

<

< Solution       #              = 150

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=1, H=2, T=5, T=5, H=2, E=1, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 170+65=235

<

<

< Solution       #              = 151

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=1, H=2, T=8, T=8, H=2, E=1, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 170+68=238

<

<

< Solution       #              = 152

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=1, H=2, T=9, T=9, H=2, E=1, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 170+69=239

<

<

< Solution       #              = 153

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=4, H=5, T=1, T=1, H=5, E=4, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 470+61=531

<

<

< Solution       #              = 154

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=4, H=5, T=2, T=2, H=5, E=4, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 470+62=532

<

<

< Solution       #              = 155

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=4, H=5, T=8, T=8, H=5, E=4, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 470+68=538

<

<

< Solution       #              = 156

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=4, H=5, T=9, T=9, H=5, E=4, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 470+69=539

<

<

< Solution       #              = 157

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=8, H=9, T=1, T=1, H=9, E=8, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 870+61=931

<

<

< Solution       #              = 158

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=8, H=9, T=2, T=2, H=9, E=8, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 870+62=932

<

<

< Solution       #              = 159

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=8, H=9, T=4, T=4, H=9, E=8, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 870+64=934

<

<

< Solution       #              = 160

< Solution       fitted         = Y=0, Ö=6, A=3, G=7, E=8, H=9, T=5, T=5, H=9, E=8, G=7, A=3, Ö=6, Y=0.

< Solution       got            = 870+65=935

<

<

< Solution       #              = 161

< Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=1, H=2, T=3, T=3, H=2, E=1, G=8, A=4, Ö=6, Y=0.

< Solution       got            = 180+63=243

<

<

< Solution       #              = 162

< Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=1, H=2, T=5, T=5, H=2, E=1, G=8, A=4, Ö=6, Y=0.

< Solution       got            = 180+65=245

<

<

< Solution       #              = 163

< Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=1, H=2, T=7, T=7, H=2, E=1, G=8, A=4, Ö=6, Y=0.

< Solution       got            = 180+67=247

<

<

< Solution       #              = 164

< Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=1, H=2, T=9, T=9, H=2, E=1, G=8, A=4, Ö=6, Y=0.

< Solution       got            = 180+69=249

<

<

< Solution       #              = 165

< Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=2, H=3, T=1, T=1, H=3, E=2, G=8, A=4, Ö=6, Y=0.

< Solution       got            = 280+61=341

<

<

< Solution       #              = 166

< Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=2, H=3, T=5, T=5, H=3, E=2, G=8, A=4, Ö=6, Y=0.

< Solution       got            = 280+65=345

<

<

< Solution       #              = 167

< Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=2, H=3, T=7, T=7, H=3, E=2, G=8, A=4, Ö=6, Y=0.

< Solution       got            = 280+67=347

<

<

< Solution       #              = 168

< Solution       fitted         = Y=0, Ö=6, A=4, G=8, E=2, H=3, T=9, T=9, H=3, E=2, G=8, A=4, Ö=6, Y=0.

< Solution       got            = 280+69=349

<

<

< Solution       #              = 169

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=1, H=2, T=3, T=3, H=2, E=1, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 190+63=253

<

<

< Solution       #              = 170

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=1, H=2, T=4, T=4, H=2, E=1, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 190+64=254

<

<

< Solution       #              = 171

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=1, H=2, T=7, T=7, H=2, E=1, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 190+67=257

<

<

< Solution       #              = 172

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=1, H=2, T=8, T=8, H=2, E=1, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 190+68=258

<

<

< Solution       #              = 173

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=2, H=3, T=1, T=1, H=3, E=2, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 290+61=351

<

<

< Solution       #              = 174

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=2, H=3, T=4, T=4, H=3, E=2, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 290+64=354

<

<

< Solution       #              = 175

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=2, H=3, T=7, T=7, H=3, E=2, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 290+67=357

<

<

< Solution       #              = 176

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=2, H=3, T=8, T=8, H=3, E=2, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 290+68=358

<

<

< Solution       #              = 177

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=3, H=4, T=1, T=1, H=4, E=3, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 390+61=451

<

<

< Solution       #              = 178

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=3, H=4, T=2, T=2, H=4, E=3, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 390+62=452

<

<

< Solution       #              = 179

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=3, H=4, T=7, T=7, H=4, E=3, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 390+67=457

<

<

< Solution       #              = 180

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=3, H=4, T=8, T=8, H=4, E=3, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 390+68=458

<

<

< Solution       #              = 181

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=7, H=8, T=1, T=1, H=8, E=7, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 790+61=851

<

<

< Solution       #              = 182

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=7, H=8, T=2, T=2, H=8, E=7, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 790+62=852

<

<

< Solution       #              = 183

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=7, H=8, T=3, T=3, H=8, E=7, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 790+63=853

<

<

< Solution       #              = 184

< Solution       fitted         = Y=0, Ö=6, A=5, G=9, E=7, H=8, T=4, T=4, H=8, E=7, G=9, A=5, Ö=6, Y=0.

< Solution       got            = 790+64=854

<

<

< Solution       #              = 185

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=2, H=3, T=5, T=5, H=3, E=2, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 240+75=315

<

<

< Solution       #              = 186

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=2, H=3, T=6, T=6, H=3, E=2, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 240+76=316

<

<

< Solution       #              = 187

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=2, H=3, T=8, T=8, H=3, E=2, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 240+78=318

<

<

< Solution       #              = 188

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=2, H=3, T=9, T=9, H=3, E=2, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 240+79=319

<

<

< Solution       #              = 189

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=5, H=6, T=2, T=2, H=6, E=5, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 540+72=612

<

<

< Solution       #              = 190

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=5, H=6, T=3, T=3, H=6, E=5, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 540+73=613

<

<

< Solution       #              = 191

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=5, H=6, T=8, T=8, H=6, E=5, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 540+78=618

<

<

< Solution       #              = 192

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=5, H=6, T=9, T=9, H=6, E=5, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 540+79=619

<

<

< Solution       #              = 193

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=8, H=9, T=2, T=2, H=9, E=8, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 840+72=912

<

<

< Solution       #              = 194

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=8, H=9, T=3, T=3, H=9, E=8, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 840+73=913

<

<

< Solution       #              = 195

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=8, H=9, T=5, T=5, H=9, E=8, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 840+75=915

<

<

< Solution       #              = 196

< Solution       fitted         = Y=0, Ö=7, A=1, G=4, E=8, H=9, T=6, T=6, H=9, E=8, G=4, A=1, Ö=7, Y=0.

< Solution       got            = 840+76=916

<

<

< Solution       #              = 197

< Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=3, H=4, T=1, T=1, H=4, E=3, G=5, A=2, Ö=7, Y=0.

< Solution       got            = 350+71=421

<

<

< Solution       #              = 198

< Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=3, H=4, T=6, T=6, H=4, E=3, G=5, A=2, Ö=7, Y=0.

< Solution       got            = 350+76=426

<

<

< Solution       #              = 199

< Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=3, H=4, T=8, T=8, H=4, E=3, G=5, A=2, Ö=7, Y=0.

< Solution       got            = 350+78=428

<

<

< Solution       #              = 200

< Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=3, H=4, T=9, T=9, H=4, E=3, G=5, A=2, Ö=7, Y=0.

< Solution       got            = 350+79=429

<

<

< Solution       #              = 201

< Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=8, H=9, T=1, T=1, H=9, E=8, G=5, A=2, Ö=7, Y=0.

< Solution       got            = 850+71=921

<

<

< Solution       #              = 202

< Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=8, H=9, T=3, T=3, H=9, E=8, G=5, A=2, Ö=7, Y=0.

< Solution       got            = 850+73=923

<

<

< Solution       #              = 203

< Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=8, H=9, T=4, T=4, H=9, E=8, G=5, A=2, Ö=7, Y=0.

< Solution       got            = 850+74=924

<

<

< Solution       #              = 204

< Solution       fitted         = Y=0, Ö=7, A=2, G=5, E=8, H=9, T=6, T=6, H=9, E=8, G=5, A=2, Ö=7, Y=0.

< Solution       got            = 850+76=926

<

<

< Solution       #              = 205

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=1, H=2, T=4, T=4, H=2, E=1, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 160+74=234

<

<

< Solution       #              = 206

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=1, H=2, T=5, T=5, H=2, E=1, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 160+75=235

<

<

< Solution       #              = 207

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=1, H=2, T=8, T=8, H=2, E=1, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 160+78=238

<

<

< Solution       #              = 208

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=1, H=2, T=9, T=9, H=2, E=1, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 160+79=239

<

<

< Solution       #              = 209

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=4, H=5, T=1, T=1, H=5, E=4, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 460+71=531

<

<

< Solution       #              = 210

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=4, H=5, T=2, T=2, H=5, E=4, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 460+72=532

<

<

< Solution       #              = 211

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=4, H=5, T=8, T=8, H=5, E=4, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 460+78=538

<

<

< Solution       #              = 212

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=4, H=5, T=9, T=9, H=5, E=4, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 460+79=539

<

<

< Solution       #              = 213

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=8, H=9, T=1, T=1, H=9, E=8, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 860+71=931

<

<

< Solution       #              = 214

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=8, H=9, T=2, T=2, H=9, E=8, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 860+72=932

<

<

< Solution       #              = 215

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=8, H=9, T=4, T=4, H=9, E=8, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 860+74=934

<

<

< Solution       #              = 216

< Solution       fitted         = Y=0, Ö=7, A=3, G=6, E=8, H=9, T=5, T=5, H=9, E=8, G=6, A=3, Ö=7, Y=0.

< Solution       got            = 860+75=935

<

<

< Solution       #              = 217

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=1, H=2, T=3, T=3, H=2, E=1, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 180+73=253

<

<

< Solution       #              = 218

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=1, H=2, T=4, T=4, H=2, E=1, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 180+74=254

<

<

< Solution       #              = 219

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=1, H=2, T=6, T=6, H=2, E=1, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 180+76=256

<

<

< Solution       #              = 220

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=1, H=2, T=9, T=9, H=2, E=1, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 180+79=259

<

<

< Solution       #              = 221

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=2, H=3, T=1, T=1, H=3, E=2, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 280+71=351

<

<

< Solution       #              = 222

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=2, H=3, T=4, T=4, H=3, E=2, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 280+74=354

<

<

< Solution       #              = 223

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=2, H=3, T=6, T=6, H=3, E=2, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 280+76=356

<

<

< Solution       #              = 224

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=2, H=3, T=9, T=9, H=3, E=2, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 280+79=359

<

<

< Solution       #              = 225

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=3, H=4, T=1, T=1, H=4, E=3, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 380+71=451

<

<

< Solution       #              = 226

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=3, H=4, T=2, T=2, H=4, E=3, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 380+72=452

<

<

< Solution       #              = 227

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=3, H=4, T=6, T=6, H=4, E=3, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 380+76=456

<

<

< Solution       #              = 228

< Solution       fitted         = Y=0, Ö=7, A=5, G=8, E=3, H=4, T=9, T=9, H=4, E=3, G=8, A=5, Ö=7, Y=0.

< Solution       got            = 380+79=459

<

<

< Solution       #              = 229

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=1, H=2, T=3, T=3, H=2, E=1, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 190+73=263

<

<

< Solution       #              = 230

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=1, H=2, T=4, T=4, H=2, E=1, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 190+74=264

<

<

< Solution       #              = 231

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=1, H=2, T=5, T=5, H=2, E=1, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 190+75=265

<

<

< Solution       #              = 232

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=1, H=2, T=8, T=8, H=2, E=1, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 190+78=268

<

<

< Solution       #              = 233

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=2, H=3, T=1, T=1, H=3, E=2, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 290+71=361

<

<

< Solution       #              = 234

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=2, H=3, T=4, T=4, H=3, E=2, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 290+74=364

<

<

< Solution       #              = 235

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=2, H=3, T=5, T=5, H=3, E=2, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 290+75=365

<

<

< Solution       #              = 236

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=2, H=3, T=8, T=8, H=3, E=2, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 290+78=368

<

<

< Solution       #              = 237

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=3, H=4, T=1, T=1, H=4, E=3, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 390+71=461

<

<

< Solution       #              = 238

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=3, H=4, T=2, T=2, H=4, E=3, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 390+72=462

<

<

< Solution       #              = 239

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=3, H=4, T=5, T=5, H=4, E=3, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 390+75=465

<

<

< Solution       #              = 240

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=3, H=4, T=8, T=8, H=4, E=3, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 390+78=468

<

<

< Solution       #              = 241

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=4, H=5, T=1, T=1, H=5, E=4, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 490+71=561

<

<

< Solution       #              = 242

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=4, H=5, T=2, T=2, H=5, E=4, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 490+72=562

<

<

< Solution       #              = 243

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=4, H=5, T=3, T=3, H=5, E=4, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 490+73=563

<

<

< Solution       #              = 244

< Solution       fitted         = Y=0, Ö=7, A=6, G=9, E=4, H=5, T=8, T=8, H=5, E=4, G=9, A=6, Ö=7, Y=0.

< Solution       got            = 490+78=568

<

<

< Solution       #              = 245

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=4, H=5, T=2, T=2, H=5, E=4, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 430+82=512

<

<

< Solution       #              = 246

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=4, H=5, T=6, T=6, H=5, E=4, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 430+86=516

<

<

< Solution       #              = 247

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=4, H=5, T=7, T=7, H=5, E=4, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 430+87=517

<

<

< Solution       #              = 248

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=4, H=5, T=9, T=9, H=5, E=4, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 430+89=519

<

<

< Solution       #              = 249

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=5, H=6, T=2, T=2, H=6, E=5, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 530+82=612

<

<

< Solution       #              = 250

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=5, H=6, T=4, T=4, H=6, E=5, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 530+84=614

<

<

< Solution       #              = 251

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=5, H=6, T=7, T=7, H=6, E=5, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 530+87=617

<

<

< Solution       #              = 252

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=5, H=6, T=9, T=9, H=6, E=5, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 530+89=619

<

<

< Solution       #              = 253

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=6, H=7, T=2, T=2, H=7, E=6, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 630+82=712

<

<

< Solution       #              = 254

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=6, H=7, T=4, T=4, H=7, E=6, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 630+84=714

<

<

< Solution       #              = 255

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=6, H=7, T=5, T=5, H=7, E=6, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 630+85=715

<

<

< Solution       #              = 256

< Solution       fitted         = Y=0, Ö=8, A=1, G=3, E=6, H=7, T=9, T=9, H=7, E=6, G=3, A=1, Ö=8, Y=0.

< Solution       got            = 630+89=719

<

<

< Solution       #              = 257

< Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=5, H=6, T=1, T=1, H=6, E=5, G=4, A=2, Ö=8, Y=0.

< Solution       got            = 540+81=621

<

<

< Solution       #              = 258

< Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=5, H=6, T=3, T=3, H=6, E=5, G=4, A=2, Ö=8, Y=0.

< Solution       got            = 540+83=623

<

<

< Solution       #              = 259

< Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=5, H=6, T=7, T=7, H=6, E=5, G=4, A=2, Ö=8, Y=0.

< Solution       got            = 540+87=627

<

<

< Solution       #              = 260

< Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=5, H=6, T=9, T=9, H=6, E=5, G=4, A=2, Ö=8, Y=0.

< Solution       got            = 540+89=629

<

<

< Solution       #              = 261

< Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=6, H=7, T=1, T=1, H=7, E=6, G=4, A=2, Ö=8, Y=0.

< Solution       got            = 640+81=721

<

<

< Solution       #              = 262

< Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=6, H=7, T=3, T=3, H=7, E=6, G=4, A=2, Ö=8, Y=0.

< Solution       got            = 640+83=723

<

<

< Solution       #              = 263

< Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=6, H=7, T=5, T=5, H=7, E=6, G=4, A=2, Ö=8, Y=0.

< Solution       got            = 640+85=725

<

<

< Solution       #              = 264

< Solution       fitted         = Y=0, Ö=8, A=2, G=4, E=6, H=7, T=9, T=9, H=7, E=6, G=4, A=2, Ö=8, Y=0.

< Solution       got            = 640+89=729

<

<

< Solution       #              = 265

< Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=1, H=2, T=4, T=4, H=2, E=1, G=5, A=3, Ö=8, Y=0.

< Solution       got            = 150+84=234

<

<

< Solution       #              = 266

< Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=1, H=2, T=6, T=6, H=2, E=1, G=5, A=3, Ö=8, Y=0.

< Solution       got            = 150+86=236

<

<

< Solution       #              = 267

< Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=1, H=2, T=7, T=7, H=2, E=1, G=5, A=3, Ö=8, Y=0.

< Solution       got            = 150+87=237

<

<

< Solution       #              = 268

< Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=1, H=2, T=9, T=9, H=2, E=1, G=5, A=3, Ö=8, Y=0.

< Solution       got            = 150+89=239

<

<

< Solution       #              = 269

< Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=6, H=7, T=1, T=1, H=7, E=6, G=5, A=3, Ö=8, Y=0.

< Solution       got            = 650+81=731

<

<

< Solution       #              = 270

< Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=6, H=7, T=2, T=2, H=7, E=6, G=5, A=3, Ö=8, Y=0.

< Solution       got            = 650+82=732

<

<

< Solution       #              = 271

< Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=6, H=7, T=4, T=4, H=7, E=6, G=5, A=3, Ö=8, Y=0.

< Solution       got            = 650+84=734

<

<

< Solution       #              = 272

< Solution       fitted         = Y=0, Ö=8, A=3, G=5, E=6, H=7, T=9, T=9, H=7, E=6, G=5, A=3, Ö=8, Y=0.

< Solution       got            = 650+89=739

<

<

< Solution       #              = 273

< Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=1, H=2, T=3, T=3, H=2, E=1, G=6, A=4, Ö=8, Y=0.

< Solution       got            = 160+83=243

<

<

< Solution       #              = 274

< Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=1, H=2, T=5, T=5, H=2, E=1, G=6, A=4, Ö=8, Y=0.

< Solution       got            = 160+85=245

<

<

< Solution       #              = 275

< Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=1, H=2, T=7, T=7, H=2, E=1, G=6, A=4, Ö=8, Y=0.

< Solution       got            = 160+87=247

<

<

< Solution       #              = 276

< Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=1, H=2, T=9, T=9, H=2, E=1, G=6, A=4, Ö=8, Y=0.

< Solution       got            = 160+89=249

<

<

< Solution       #              = 277

< Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=2, H=3, T=1, T=1, H=3, E=2, G=6, A=4, Ö=8, Y=0.

< Solution       got            = 260+81=341

<

<

< Solution       #              = 278

< Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=2, H=3, T=5, T=5, H=3, E=2, G=6, A=4, Ö=8, Y=0.

< Solution       got            = 260+85=345

<

<

< Solution       #              = 279

< Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=2, H=3, T=7, T=7, H=3, E=2, G=6, A=4, Ö=8, Y=0.

< Solution       got            = 260+87=347

<

<

< Solution       #              = 280

< Solution       fitted         = Y=0, Ö=8, A=4, G=6, E=2, H=3, T=9, T=9, H=3, E=2, G=6, A=4, Ö=8, Y=0.

< Solution       got            = 260+89=349

<

<

< Solution       #              = 281

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=1, H=2, T=3, T=3, H=2, E=1, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 170+83=253

<

<

< Solution       #              = 282

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=1, H=2, T=4, T=4, H=2, E=1, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 170+84=254

<

<

< Solution       #              = 283

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=1, H=2, T=6, T=6, H=2, E=1, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 170+86=256

<

<

< Solution       #              = 284

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=1, H=2, T=9, T=9, H=2, E=1, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 170+89=259

<

<

< Solution       #              = 285

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=2, H=3, T=1, T=1, H=3, E=2, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 270+81=351

<

<

< Solution       #              = 286

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=2, H=3, T=4, T=4, H=3, E=2, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 270+84=354

<

<

< Solution       #              = 287

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=2, H=3, T=6, T=6, H=3, E=2, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 270+86=356

<

<

< Solution       #              = 288

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=2, H=3, T=9, T=9, H=3, E=2, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 270+89=359

<

<

< Solution       #              = 289

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=3, H=4, T=1, T=1, H=4, E=3, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 370+81=451

<

<

< Solution       #              = 290

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=3, H=4, T=2, T=2, H=4, E=3, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 370+82=452

<

<

< Solution       #              = 291

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=3, H=4, T=6, T=6, H=4, E=3, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 370+86=456

<

<

< Solution       #              = 292

< Solution       fitted         = Y=0, Ö=8, A=5, G=7, E=3, H=4, T=9, T=9, H=4, E=3, G=7, A=5, Ö=8, Y=0.

< Solution       got            = 370+89=459

<

<

< Solution       #              = 293

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=1, H=2, T=3, T=3, H=2, E=1, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 190+83=273

<

<

< Solution       #              = 294

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=1, H=2, T=4, T=4, H=2, E=1, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 190+84=274

<

<

< Solution       #              = 295

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=1, H=2, T=5, T=5, H=2, E=1, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 190+85=275

<

<

< Solution       #              = 296

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=1, H=2, T=6, T=6, H=2, E=1, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 190+86=276

<

<

< Solution       #              = 297

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=2, H=3, T=1, T=1, H=3, E=2, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 290+81=371

<

<

< Solution       #              = 298

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=2, H=3, T=4, T=4, H=3, E=2, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 290+84=374

<

<

< Solution       #              = 299

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=2, H=3, T=5, T=5, H=3, E=2, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 290+85=375

<

<

< Solution       #              = 300

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=2, H=3, T=6, T=6, H=3, E=2, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 290+86=376

<

<

< Solution       #              = 301

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=3, H=4, T=1, T=1, H=4, E=3, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 390+81=471

<

<

< Solution       #              = 302

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=3, H=4, T=2, T=2, H=4, E=3, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 390+82=472

<

<

< Solution       #              = 303

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=3, H=4, T=5, T=5, H=4, E=3, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 390+85=475

<

<

< Solution       #              = 304

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=3, H=4, T=6, T=6, H=4, E=3, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 390+86=476

<

<

< Solution       #              = 305

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=4, H=5, T=1, T=1, H=5, E=4, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 490+81=571

<

<

< Solution       #              = 306

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=4, H=5, T=2, T=2, H=5, E=4, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 490+82=572

<

<

< Solution       #              = 307

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=4, H=5, T=3, T=3, H=5, E=4, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 490+83=573

<

<

< Solution       #              = 308

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=4, H=5, T=6, T=6, H=5, E=4, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 490+86=576

<

<

< Solution       #              = 309

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=5, H=6, T=1, T=1, H=6, E=5, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 590+81=671

<

<

< Solution       #              = 310

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=5, H=6, T=2, T=2, H=6, E=5, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 590+82=672

<

<

< Solution       #              = 311

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=5, H=6, T=3, T=3, H=6, E=5, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 590+83=673

<

<

< Solution       #              = 312

< Solution       fitted         = Y=0, Ö=8, A=7, G=9, E=5, H=6, T=4, T=4, H=6, E=5, G=9, A=7, Ö=8, Y=0.

< Solution       got            = 590+84=674

<

<

< Solution       #              = 313

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=3, H=4, T=5, T=5, H=4, E=3, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 320+95=415

<

<

< Solution       #              = 314

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=3, H=4, T=6, T=6, H=4, E=3, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 320+96=416

<

<

< Solution       #              = 315

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=3, H=4, T=7, T=7, H=4, E=3, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 320+97=417

<

<

< Solution       #              = 316

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=3, H=4, T=8, T=8, H=4, E=3, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 320+98=418

<

<

< Solution       #              = 317

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=4, H=5, T=3, T=3, H=5, E=4, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 420+93=513

<

<

< Solution       #              = 318

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=4, H=5, T=6, T=6, H=5, E=4, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 420+96=516

<

<

< Solution       #              = 319

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=4, H=5, T=7, T=7, H=5, E=4, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 420+97=517

<

<

< Solution       #              = 320

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=4, H=5, T=8, T=8, H=5, E=4, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 420+98=518

<

<

< Solution       #              = 321

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=5, H=6, T=3, T=3, H=6, E=5, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 520+93=613

<

<

< Solution       #              = 322

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=5, H=6, T=4, T=4, H=6, E=5, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 520+94=614

<

<

< Solution       #              = 323

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=5, H=6, T=7, T=7, H=6, E=5, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 520+97=617

<

<

< Solution       #              = 324

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=5, H=6, T=8, T=8, H=6, E=5, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 520+98=618

<

<

< Solution       #              = 325

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=6, H=7, T=3, T=3, H=7, E=6, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 620+93=713

<

<

< Solution       #              = 326

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=6, H=7, T=4, T=4, H=7, E=6, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 620+94=714

<

<

< Solution       #              = 327

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=6, H=7, T=5, T=5, H=7, E=6, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 620+95=715

<

<

< Solution       #              = 328

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=6, H=7, T=8, T=8, H=7, E=6, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 620+98=718

<

<

< Solution       #              = 329

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=7, H=8, T=3, T=3, H=8, E=7, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 720+93=813

<

<

< Solution       #              = 330

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=7, H=8, T=4, T=4, H=8, E=7, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 720+94=814

<

<

< Solution       #              = 331

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=7, H=8, T=5, T=5, H=8, E=7, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 720+95=815

<

<

< Solution       #              = 332

< Solution       fitted         = Y=0, Ö=9, A=1, G=2, E=7, H=8, T=6, T=6, H=8, E=7, G=2, A=1, Ö=9, Y=0.

< Solution       got            = 720+96=816

<

<

< Solution       #              = 333

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=4, H=5, T=1, T=1, H=5, E=4, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 430+91=521

<

<

< Solution       #              = 334

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=4, H=5, T=6, T=6, H=5, E=4, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 430+96=526

<

<

< Solution       #              = 335

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=4, H=5, T=7, T=7, H=5, E=4, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 430+97=527

<

<

< Solution       #              = 336

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=4, H=5, T=8, T=8, H=5, E=4, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 430+98=528

<

<

< Solution       #              = 337

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=5, H=6, T=1, T=1, H=6, E=5, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 530+91=621

<

<

< Solution       #              = 338

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=5, H=6, T=4, T=4, H=6, E=5, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 530+94=624

<

<

< Solution       #              = 339

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=5, H=6, T=7, T=7, H=6, E=5, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 530+97=627

<

<

< Solution       #              = 340

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=5, H=6, T=8, T=8, H=6, E=5, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 530+98=628

<

<

< Solution       #              = 341

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=6, H=7, T=1, T=1, H=7, E=6, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 630+91=721

<

<

< Solution       #              = 342

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=6, H=7, T=4, T=4, H=7, E=6, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 630+94=724

<

<

< Solution       #              = 343

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=6, H=7, T=5, T=5, H=7, E=6, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 630+95=725

<

<

< Solution       #              = 344

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=6, H=7, T=8, T=8, H=7, E=6, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 630+98=728

<

<

< Solution       #              = 345

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=7, H=8, T=1, T=1, H=8, E=7, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 730+91=821

<

<

< Solution       #              = 346

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=7, H=8, T=4, T=4, H=8, E=7, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 730+94=824

<

<

< Solution       #              = 347

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=7, H=8, T=5, T=5, H=8, E=7, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 730+95=825

<

<

< Solution       #              = 348

< Solution       fitted         = Y=0, Ö=9, A=2, G=3, E=7, H=8, T=6, T=6, H=8, E=7, G=3, A=2, Ö=9, Y=0.

< Solution       got            = 730+96=826

<

<

< Solution       #              = 349

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=1, H=2, T=5, T=5, H=2, E=1, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 140+95=235

<

<

< Solution       #              = 350

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=1, H=2, T=6, T=6, H=2, E=1, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 140+96=236

<

<

< Solution       #              = 351

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=1, H=2, T=7, T=7, H=2, E=1, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 140+97=237

<

<

< Solution       #              = 352

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=1, H=2, T=8, T=8, H=2, E=1, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 140+98=238

<

<

< Solution       #              = 353

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=5, H=6, T=1, T=1, H=6, E=5, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 540+91=631

<

<

< Solution       #              = 354

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=5, H=6, T=2, T=2, H=6, E=5, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 540+92=632

<

<

< Solution       #              = 355

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=5, H=6, T=7, T=7, H=6, E=5, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 540+97=637

<

<

< Solution       #              = 356

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=5, H=6, T=8, T=8, H=6, E=5, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 540+98=638

<

<

< Solution       #              = 357

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=6, H=7, T=1, T=1, H=7, E=6, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 640+91=731

<

<

< Solution       #              = 358

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=6, H=7, T=2, T=2, H=7, E=6, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 640+92=732

<

<

< Solution       #              = 359

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=6, H=7, T=5, T=5, H=7, E=6, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 640+95=735

<

<

< Solution       #              = 360

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=6, H=7, T=8, T=8, H=7, E=6, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 640+98=738

<

<

< Solution       #              = 361

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=7, H=8, T=1, T=1, H=8, E=7, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 740+91=831

<

<

< Solution       #              = 362

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=7, H=8, T=2, T=2, H=8, E=7, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 740+92=832

<

<

< Solution       #              = 363

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=7, H=8, T=5, T=5, H=8, E=7, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 740+95=835

<

<

< Solution       #              = 364

< Solution       fitted         = Y=0, Ö=9, A=3, G=4, E=7, H=8, T=6, T=6, H=8, E=7, G=4, A=3, Ö=9, Y=0.

< Solution       got            = 740+96=836

<

<

< Solution       #              = 365

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=1, H=2, T=3, T=3, H=2, E=1, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 150+93=243

<

<

< Solution       #              = 366

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=1, H=2, T=6, T=6, H=2, E=1, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 150+96=246

<

<

< Solution       #              = 367

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=1, H=2, T=7, T=7, H=2, E=1, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 150+97=247

<

<

< Solution       #              = 368

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=1, H=2, T=8, T=8, H=2, E=1, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 150+98=248

<

<

< Solution       #              = 369

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=2, H=3, T=1, T=1, H=3, E=2, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 250+91=341

<

<

< Solution       #              = 370

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=2, H=3, T=6, T=6, H=3, E=2, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 250+96=346

<

<

< Solution       #              = 371

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=2, H=3, T=7, T=7, H=3, E=2, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 250+97=347

<

<

< Solution       #              = 372

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=2, H=3, T=8, T=8, H=3, E=2, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 250+98=348

<

<

< Solution       #              = 373

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=6, H=7, T=1, T=1, H=7, E=6, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 650+91=741

<

<

< Solution       #              = 374

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=6, H=7, T=2, T=2, H=7, E=6, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 650+92=742

<

<

< Solution       #              = 375

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=6, H=7, T=3, T=3, H=7, E=6, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 650+93=743

<

<

< Solution       #              = 376

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=6, H=7, T=8, T=8, H=7, E=6, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 650+98=748

<

<

< Solution       #              = 377

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=7, H=8, T=1, T=1, H=8, E=7, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 750+91=841

<

<

< Solution       #              = 378

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=7, H=8, T=2, T=2, H=8, E=7, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 750+92=842

<

<

< Solution       #              = 379

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=7, H=8, T=3, T=3, H=8, E=7, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 750+93=843

<

<

< Solution       #              = 380

< Solution       fitted         = Y=0, Ö=9, A=4, G=5, E=7, H=8, T=6, T=6, H=8, E=7, G=5, A=4, Ö=9, Y=0.

< Solution       got            = 750+96=846

<

<

< Solution       #              = 381

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=1, H=2, T=3, T=3, H=2, E=1, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 160+93=253

<

<

< Solution       #              = 382

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=1, H=2, T=4, T=4, H=2, E=1, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 160+94=254

<

<

< Solution       #              = 383

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=1, H=2, T=7, T=7, H=2, E=1, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 160+97=257

<

<

< Solution       #              = 384

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=1, H=2, T=8, T=8, H=2, E=1, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 160+98=258

<

<

< Solution       #              = 385

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=2, H=3, T=1, T=1, H=3, E=2, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 260+91=351

<

<

< Solution       #              = 386

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=2, H=3, T=4, T=4, H=3, E=2, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 260+94=354

<

<

< Solution       #              = 387

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=2, H=3, T=7, T=7, H=3, E=2, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 260+97=357

<

<

< Solution       #              = 388

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=2, H=3, T=8, T=8, H=3, E=2, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 260+98=358

<

<

< Solution       #              = 389

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=3, H=4, T=1, T=1, H=4, E=3, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 360+91=451

<

<

< Solution       #              = 390

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=3, H=4, T=2, T=2, H=4, E=3, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 360+92=452

<

<

< Solution       #              = 391

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=3, H=4, T=7, T=7, H=4, E=3, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 360+97=457

<

<

< Solution       #              = 392

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=3, H=4, T=8, T=8, H=4, E=3, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 360+98=458

<

<

< Solution       #              = 393

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=7, H=8, T=1, T=1, H=8, E=7, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 760+91=851

<

<

< Solution       #              = 394

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=7, H=8, T=2, T=2, H=8, E=7, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 760+92=852

<

<

< Solution       #              = 395

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=7, H=8, T=3, T=3, H=8, E=7, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 760+93=853

<

<

< Solution       #              = 396

< Solution       fitted         = Y=0, Ö=9, A=5, G=6, E=7, H=8, T=4, T=4, H=8, E=7, G=6, A=5, Ö=9, Y=0.

< Solution       got            = 760+94=854

<

<

< Solution       #              = 397

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=1, H=2, T=3, T=3, H=2, E=1, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 170+93=263

<

<

< Solution       #              = 398

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=1, H=2, T=4, T=4, H=2, E=1, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 170+94=264

<

<

< Solution       #              = 399

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=1, H=2, T=5, T=5, H=2, E=1, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 170+95=265

<

<

< Solution       #              = 400

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=1, H=2, T=8, T=8, H=2, E=1, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 170+98=268

<

<

< Solution       #              = 401

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=2, H=3, T=1, T=1, H=3, E=2, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 270+91=361

<

<

< Solution       #              = 402

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=2, H=3, T=4, T=4, H=3, E=2, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 270+94=364

<

<

< Solution       #              = 403

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=2, H=3, T=5, T=5, H=3, E=2, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 270+95=365

<

<

< Solution       #              = 404

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=2, H=3, T=8, T=8, H=3, E=2, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 270+98=368

<

<

< Solution       #              = 405

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=3, H=4, T=1, T=1, H=4, E=3, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 370+91=461

<

<

< Solution       #              = 406

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=3, H=4, T=2, T=2, H=4, E=3, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 370+92=462

<

<

< Solution       #              = 407

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=3, H=4, T=5, T=5, H=4, E=3, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 370+95=465

<

<

< Solution       #              = 408

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=3, H=4, T=8, T=8, H=4, E=3, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 370+98=468

<

<

< Solution       #              = 409

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=4, H=5, T=1, T=1, H=5, E=4, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 470+91=561

<

<

< Solution       #              = 410

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=4, H=5, T=2, T=2, H=5, E=4, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 470+92=562

<

<

< Solution       #              = 411

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=4, H=5, T=3, T=3, H=5, E=4, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 470+93=563

<

<

< Solution       #              = 412

< Solution       fitted         = Y=0, Ö=9, A=6, G=7, E=4, H=5, T=8, T=8, H=5, E=4, G=7, A=6, Ö=9, Y=0.

< Solution       got            = 470+98=568

<

<

< Solution       #              = 413

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=1, H=2, T=3, T=3, H=2, E=1, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 180+93=273

<

<

< Solution       #              = 414

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=1, H=2, T=4, T=4, H=2, E=1, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 180+94=274

<

<

< Solution       #              = 415

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=1, H=2, T=5, T=5, H=2, E=1, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 180+95=275

<

<

< Solution       #              = 416

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=1, H=2, T=6, T=6, H=2, E=1, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 180+96=276

<

<

< Solution       #              = 417

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=2, H=3, T=1, T=1, H=3, E=2, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 280+91=371

<

<

< Solution       #              = 418

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=2, H=3, T=4, T=4, H=3, E=2, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 280+94=374

<

<

< Solution       #              = 419

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=2, H=3, T=5, T=5, H=3, E=2, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 280+95=375

<

<

< Solution       #              = 420

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=2, H=3, T=6, T=6, H=3, E=2, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 280+96=376

<

<

< Solution       #              = 421

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=3, H=4, T=1, T=1, H=4, E=3, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 380+91=471

<

<

< Solution       #              = 422

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=3, H=4, T=2, T=2, H=4, E=3, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 380+92=472

<

<

< Solution       #              = 423

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=3, H=4, T=5, T=5, H=4, E=3, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 380+95=475

<

<

< Solution       #              = 424

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=3, H=4, T=6, T=6, H=4, E=3, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 380+96=476

<

<

< Solution       #              = 425

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=4, H=5, T=1, T=1, H=5, E=4, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 480+91=571

<

<

< Solution       #              = 426

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=4, H=5, T=2, T=2, H=5, E=4, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 480+92=572

<

<

< Solution       #              = 427

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=4, H=5, T=3, T=3, H=5, E=4, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 480+93=573

<

<

< Solution       #              = 428

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=4, H=5, T=6, T=6, H=5, E=4, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 480+96=576

<

<

< Solution       #              = 429

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=5, H=6, T=1, T=1, H=6, E=5, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 580+91=671

<

<

< Solution       #              = 430

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=5, H=6, T=2, T=2, H=6, E=5, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 580+92=672

<

<

< Solution       #              = 431

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=5, H=6, T=3, T=3, H=6, E=5, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 580+93=673

<

<

< Solution       #              = 432

< Solution       fitted         = Y=0, Ö=9, A=7, G=8, E=5, H=6, T=4, T=4, H=6, E=5, G=8, A=7, Ö=9, Y=0.

< Solution       got            = 580+94=674

<

<

< End of fit lists and results.

---

> End of fit lists and results.

>

> Current        code is        = 'Z'

> Intermediate   fit list       = empty.

> Remaining      digits         = none.

>

2248a1651,1655

> Condensed      puzzle         = ÖTVEN+TÍZ=HATVAN

>

> Simplified     puzzle         = ÖTVEN+TÍZ=HATVAN

>

>

2252a1660,10851

> Current        code is        = 'Z'

> Intermediate   fit list       = empty.

> Remaining      digits         = 0 and 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 0

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = 0.

> Number of      elements       = 1

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=2, A=1, Z=0.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 10010

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 2

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=3, A=1, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 10010

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 3

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=2, E=3, A=1, Z=0.

> Remaining      digits         = 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 10030

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 4, 5, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=4, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 10010

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 4

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 3, 5, 6, 7, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=3, E=4, A=1, Z=0.

> Remaining      digits         = 2 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 10040

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 5, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=5, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 10010

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 5

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=4, E=5, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 10050

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=6, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 10010

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 6

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=5, E=6, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 10060

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=7, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 10010

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 7

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=6, E=7, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 10070

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 5, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=8, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 10010

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 8

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=7, E=8, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 10080

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=9, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 10010

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 9

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=8, E=9, A=1, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 10090

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = A=2, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=1, A=2, Z=0.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 20020

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 1

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=9, E=1, A=2, Z=0.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 20110

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=3, A=2, Z=0.

> Remaining      digits         = 1 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 20020

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 3

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 1, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = 1.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=1, E=3, A=2, Z=0.

> Remaining      digits         = 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 20030

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 4, 5, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=4, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 20020

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 4

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 1, 3, 5, 6, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=5, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 20020

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 5

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 1, 3, 4, 6, 7, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=3, E=5, A=2, Z=0.

> Remaining      digits         = 1 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 20050

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 4, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=6, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 20020

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 6

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 1, 3, 4, 5, 7, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=4, E=6, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 20060

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 3, 5, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=7, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 20020

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 7

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 1, 3, 4, 5, 6, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=5, E=7, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 20070

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 3, 4, 6, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=8, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 20020

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 8

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 1, 3, 4, 5, 6, 7, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=6, E=8, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 20080

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 3, 4, 5, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=9, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 20020

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 9

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 1, 3, 4, 5, 6, 7, 8.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=7, E=9, A=2, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 20090

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 3, 4, 5, 6, 8.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = A=3, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30030

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 1

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 30110

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 4, 5, 6, 7, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 4 and 5 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 5 and 6 and 7.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=2, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Partial        fit            = N=5, H=2, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=2, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 4 and 5 and 7.

>

>

> Partial        fit            = N=6, H=2, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=2, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 4 and 5 and 6.

>

>

> Partial        fit            = N=7, H=2, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 5 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 5 and 6 and 7.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=4, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 6 and 7.

>

>

> Partial        fit            = N=5, H=4, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=4, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 5 and 7.

>

>

> Partial        fit            = N=6, H=4, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=4, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 5 and 6.

>

>

> Partial        fit            = N=7, H=4, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=5, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Partial        fit            = N=2, H=5, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=5, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 6 and 7.

>

>

> Partial        fit            = N=4, H=5, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=5, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=6, H=5, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=5, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=7, H=5, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=6, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 4 and 5 and 7.

>

>

> Partial        fit            = N=2, H=6, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=6, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 5 and 7.

>

>

> Partial        fit            = N=4, H=6, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=6, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=5, H=6, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=6, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 5.

>

>

> Partial        fit            = N=7, H=6, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=7, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 4 and 5 and 6.

>

>

> Partial        fit            = N=2, H=7, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=7, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 5 and 6.

>

>

> Partial        fit            = N=4, H=7, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=7, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=5, H=7, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=7, T=9, Í=8, E=1, A=3, Z=0.

> Remaining      digits         = 2 and 4 and 5.

>

>

> Partial        fit            = N=6, H=7, T=9, Í=8, E=1, A=3, Z=0.

> Partial        values         =                31010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=2, A=3, Z=0.

> Remaining      digits         = 1 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30030

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 2

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=9, E=2, A=3, Z=0.

> Remaining      digits         = 1 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 30120

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 4, 5, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=4, A=3, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30030

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 4

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 1, 2, 5, 6, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = 1.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=1, E=4, A=3, Z=0.

> Remaining      digits         = 2 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 30040

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 5, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=5, A=3, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30030

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 5

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 1, 2, 4, 6, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=2, E=5, A=3, Z=0.

> Remaining      digits         = 1 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 30050

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 4, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=6, A=3, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30030

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 6

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 1, 2, 4, 5, 7, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=7, A=3, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30030

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 7

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 1, 2, 4, 5, 6, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=4, E=7, A=3, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 30070

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 2, 5, 6, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=8, A=3, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30030

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 8

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 1, 2, 4, 5, 6, 7, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=5, E=8, A=3, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 30080

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 2, 4, 6, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=9, A=3, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30030

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 9

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 1, 2, 4, 5, 6, 7, 8.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=6, E=9, A=3, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 30090

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 2, 4, 5, 7, 8.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = A=4, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40040

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 1

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 5, 6, 7, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 40110

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 5, 6, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 6 and 8.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=2, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 5 and 6 and 8.

>

>

> Partial        fit            = N=3, H=2, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=2, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 3 and 6 and 8.

>

>

> Partial        fit            = N=5, H=2, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=2, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 8.

>

>

> Partial        fit            = N=6, H=2, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=2, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 6.

>

>

> Partial        fit            = N=8, H=2, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 5 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=3, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 5 and 6 and 8.

>

>

> Partial        fit            = N=2, H=3, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=3, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 6 and 8.

>

>

> Partial        fit            = N=5, H=3, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=3, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 5 and 8.

>

>

> Partial        fit            = N=6, H=3, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=3, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 5 and 6.

>

>

> Partial        fit            = N=8, H=3, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=5, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 3 and 6 and 8.

>

>

> Partial        fit            = N=2, H=5, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=5, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 6 and 8.

>

>

> Partial        fit            = N=3, H=5, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=5, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 8.

>

>

> Partial        fit            = N=6, H=5, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=5, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 6.

>

>

> Partial        fit            = N=8, H=5, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=6, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 8.

>

>

> Partial        fit            = N=2, H=6, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=6, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 5 and 8.

>

>

> Partial        fit            = N=3, H=6, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=6, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 8.

>

>

> Partial        fit            = N=5, H=6, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=6, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 5.

>

>

> Partial        fit            = N=8, H=6, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=8, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=8, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 6.

>

>

> Partial        fit            = N=2, H=8, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=8, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 5 and 6.

>

>

> Partial        fit            = N=3, H=8, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=8, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 6.

>

>

> Partial        fit            = N=5, H=8, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=8, T=9, Í=7, E=1, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 5.

>

>

> Partial        fit            = N=6, H=8, T=9, Í=7, E=1, A=4, Z=0.

> Partial        values         =                41010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40040

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 2

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 1, 3, 5, 6, 7, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 40120

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 3, 5, 6, 7, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 6 and 7.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=1, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 5 and 6 and 7.

>

>

> Partial        fit            = N=3, H=1, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=1, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 3 and 6 and 7.

>

>

> Partial        fit            = N=5, H=1, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=1, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 7.

>

>

> Partial        fit            = N=6, H=1, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=1, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 6.

>

>

> Partial        fit            = N=7, H=1, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 5 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=3, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 5 and 6 and 7.

>

>

> Partial        fit            = N=1, H=3, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=3, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 6 and 7.

>

>

> Partial        fit            = N=5, H=3, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=3, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 5 and 7.

>

>

> Partial        fit            = N=6, H=3, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=3, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 5 and 6.

>

>

> Partial        fit            = N=7, H=3, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=5, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 3 and 6 and 7.

>

>

> Partial        fit            = N=1, H=5, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=5, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 6 and 7.

>

>

> Partial        fit            = N=3, H=5, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=5, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 7.

>

>

> Partial        fit            = N=6, H=5, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=5, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=7, H=5, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=6, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 7.

>

>

> Partial        fit            = N=1, H=6, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=6, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 5 and 7.

>

>

> Partial        fit            = N=3, H=6, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=6, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 7.

>

>

> Partial        fit            = N=5, H=6, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=6, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 5.

>

>

> Partial        fit            = N=7, H=6, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=7, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 3 and 5 and 6.

>

>

> Partial        fit            = N=1, H=7, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=7, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 5 and 6.

>

>

> Partial        fit            = N=3, H=7, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=7, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=5, H=7, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=7, T=9, Í=8, E=2, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 5.

>

>

> Partial        fit            = N=6, H=7, T=9, Í=8, E=2, A=4, Z=0.

> Partial        values         =                41020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=3, A=4, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40040

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 3

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 5, 6, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=9, E=3, A=4, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 40130

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 5, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=5, A=4, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40040

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 5

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 1, 2, 3, 6, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = 1.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=1, E=5, A=4, Z=0.

> Remaining      digits         = 2 and 3 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 40050

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 6, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=6, A=4, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40040

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 6

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 1, 2, 3, 5, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=2, E=6, A=4, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 40060

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 3, 5, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=7, A=4, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40040

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 7

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 1, 2, 3, 5, 6, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=3, E=7, A=4, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 40070

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 2, 5, 6, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=8, A=4, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40040

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 8

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 1, 2, 3, 5, 6, 7, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=9, A=4, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40040

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 9

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 1, 2, 3, 5, 6, 7, 8.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=5, E=9, A=4, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 40090

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 2, 3, 6, 7, 8.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = A=5, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50050

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 1

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 50110

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 4, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 7 and 8.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=2, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 4 and 7 and 8.

>

>

> Partial        fit            = N=3, H=2, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 3 and 7 and 8.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=2, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 8.

>

>

> Partial        fit            = N=7, H=2, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=2, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 7.

>

>

> Partial        fit            = N=8, H=2, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=3, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 4 and 7 and 8.

>

>

> Partial        fit            = N=2, H=3, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=3, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 7 and 8.

>

>

> Partial        fit            = N=4, H=3, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=3, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 8.

>

>

> Partial        fit            = N=7, H=3, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=3, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=8, H=3, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 3 and 7 and 8.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=4, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 7 and 8.

>

>

> Partial        fit            = N=3, H=4, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=4, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 8.

>

>

> Partial        fit            = N=7, H=4, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=4, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 7.

>

>

> Partial        fit            = N=8, H=4, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=7, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 8.

>

>

> Partial        fit            = N=2, H=7, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=7, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 8.

>

>

> Partial        fit            = N=3, H=7, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=7, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 8.

>

>

> Partial        fit            = N=4, H=7, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=7, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 4.

>

>

> Partial        fit            = N=8, H=7, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=8, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=8, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 7.

>

>

> Partial        fit            = N=2, H=8, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=8, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=3, H=8, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=8, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 7.

>

>

> Partial        fit            = N=4, H=8, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=8, T=9, Í=6, E=1, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 4.

>

>

> Partial        fit            = N=7, H=8, T=9, Í=6, E=1, A=5, Z=0.

> Partial        values         =                51010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50050

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 2

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 1, 3, 4, 6, 7, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 50120

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 3, 4, 6, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6 and 8.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=1, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 4 and 6 and 8.

>

>

> Partial        fit            = N=3, H=1, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=1, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 3 and 6 and 8.

>

>

> Partial        fit            = N=4, H=1, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=1, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 8.

>

>

> Partial        fit            = N=6, H=1, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=1, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Partial        fit            = N=8, H=1, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=3, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 4 and 6 and 8.

>

>

> Partial        fit            = N=1, H=3, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=3, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 6 and 8.

>

>

> Partial        fit            = N=4, H=3, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=3, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 8.

>

>

> Partial        fit            = N=6, H=3, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=3, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=8, H=3, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=4, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 3 and 6 and 8.

>

>

> Partial        fit            = N=1, H=4, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=4, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 6 and 8.

>

>

> Partial        fit            = N=3, H=4, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=4, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 8.

>

>

> Partial        fit            = N=6, H=4, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=4, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=8, H=4, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=6, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 8.

>

>

> Partial        fit            = N=1, H=6, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=6, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 8.

>

>

> Partial        fit            = N=3, H=6, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=6, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 8.

>

>

> Partial        fit            = N=4, H=6, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=6, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 4.

>

>

> Partial        fit            = N=8, H=6, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=8, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=8, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Partial        fit            = N=1, H=8, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=8, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=3, H=8, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=8, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=4, H=8, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=8, T=9, Í=7, E=2, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 4.

>

>

> Partial        fit            = N=6, H=8, T=9, Í=7, E=2, A=5, Z=0.

> Partial        values         =                51020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50050

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 3

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 1, 2, 4, 6, 7, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 50130

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 4, 6, 7, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6 and 7.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=1, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Partial        fit            = N=2, H=1, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=1, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 2 and 6 and 7.

>

>

> Partial        fit            = N=4, H=1, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=1, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=6, H=1, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=1, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=7, H=1, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=2, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Partial        fit            = N=1, H=2, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 6 and 7.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=2, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 7.

>

>

> Partial        fit            = N=6, H=2, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=2, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=7, H=2, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=4, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 2 and 6 and 7.

>

>

> Partial        fit            = N=1, H=4, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 6 and 7.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=4, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 7.

>

>

> Partial        fit            = N=6, H=4, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=4, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 6.

>

>

> Partial        fit            = N=7, H=4, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=6, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=1, H=6, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=6, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 7.

>

>

> Partial        fit            = N=2, H=6, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=6, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 7.

>

>

> Partial        fit            = N=4, H=6, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=6, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=7, H=6, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=7, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=1, H=7, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=7, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=2, H=7, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=7, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 6.

>

>

> Partial        fit            = N=4, H=7, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=7, T=9, Í=8, E=3, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=6, H=7, T=9, Í=8, E=3, A=5, Z=0.

> Partial        values         =                51030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=4, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50050

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 4

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 6, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=9, E=4, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 50140

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=6, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50050

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 6

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 1, 2, 3, 4, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = 1.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=1, E=6, A=5, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 50060

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=7, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50050

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 7

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 1, 2, 3, 4, 6, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=2, E=7, A=5, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 50070

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 3, 4, 6, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=8, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50050

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 8

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 1, 2, 3, 4, 6, 7, 9.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=3, E=8, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 50080

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 2, 4, 6, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=9, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50050

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 9

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 1, 2, 3, 4, 6, 7, 8.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=4, E=9, A=5, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 50090

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 2, 3, 6, 7, 8.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60060

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 1

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 7 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 60110

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 4, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 7 and 8.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 3 and 4 and 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=2, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 4 and 7 and 8.

>

>

> Partial        fit            = N=3, H=2, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 3 and 7 and 8.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=2, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 3 and 4 and 8.

>

>

> Partial        fit            = N=7, H=2, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=2, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 3 and 4 and 7.

>

>

> Partial        fit            = N=8, H=2, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=3, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 4 and 7 and 8.

>

>

> Partial        fit            = N=2, H=3, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=3, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 7 and 8.

>

>

> Partial        fit            = N=4, H=3, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=3, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 8.

>

>

> Partial        fit            = N=7, H=3, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=3, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=8, H=3, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 3 and 7 and 8.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=4, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 7 and 8.

>

>

> Partial        fit            = N=3, H=4, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=4, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 8.

>

>

> Partial        fit            = N=7, H=4, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=4, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 7.

>

>

> Partial        fit            = N=8, H=4, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=7, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 3 and 4 and 8.

>

>

> Partial        fit            = N=2, H=7, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=7, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 8.

>

>

> Partial        fit            = N=3, H=7, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=7, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 8.

>

>

> Partial        fit            = N=4, H=7, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=7, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 4.

>

>

> Partial        fit            = N=8, H=7, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=8, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=8, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 3 and 4 and 7.

>

>

> Partial        fit            = N=2, H=8, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=8, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=3, H=8, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=8, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 7.

>

>

> Partial        fit            = N=4, H=8, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=8, T=9, Í=5, E=1, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 4.

>

>

> Partial        fit            = N=7, H=8, T=9, Í=5, E=1, A=6, Z=0.

> Partial        values         =                61010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=2, A=6, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60060

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 2

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 1, 3, 4, 5, 7, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60060

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 3

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 1, 2, 4, 5, 7, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 60130

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 4, 5, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 8.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=1, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 4 and 5 and 8.

>

>

> Partial        fit            = N=2, H=1, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=1, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 2 and 5 and 8.

>

>

> Partial        fit            = N=4, H=1, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=1, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 8.

>

>

> Partial        fit            = N=5, H=1, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=1, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 5.

>

>

> Partial        fit            = N=8, H=1, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 4 and 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=2, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 4 and 5 and 8.

>

>

> Partial        fit            = N=1, H=2, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 5 and 8.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=2, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 4 and 8.

>

>

> Partial        fit            = N=5, H=2, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=2, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 4 and 5.

>

>

> Partial        fit            = N=8, H=2, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=4, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 2 and 5 and 8.

>

>

> Partial        fit            = N=1, H=4, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 5 and 8.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=4, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 8.

>

>

> Partial        fit            = N=5, H=4, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=4, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 5.

>

>

> Partial        fit            = N=8, H=4, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=5, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 8.

>

>

> Partial        fit            = N=1, H=5, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=5, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 4 and 8.

>

>

> Partial        fit            = N=2, H=5, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=5, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 8.

>

>

> Partial        fit            = N=4, H=5, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=5, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=8, H=5, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=8, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=8, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 2 and 4 and 5.

>

>

> Partial        fit            = N=1, H=8, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=8, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 4 and 5.

>

>

> Partial        fit            = N=2, H=8, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=8, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 5.

>

>

> Partial        fit            = N=4, H=8, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=8, T=9, Í=7, E=3, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=5, H=8, T=9, Í=7, E=3, A=6, Z=0.

> Partial        values         =                61030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60060

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 4

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 1, 2, 3, 5, 7, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 60140

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 5, 7, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 7.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=1, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 3 and 5 and 7.

>

>

> Partial        fit            = N=2, H=1, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=1, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 2 and 5 and 7.

>

>

> Partial        fit            = N=3, H=1, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=1, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 7.

>

>

> Partial        fit            = N=5, H=1, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=1, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 5.

>

>

> Partial        fit            = N=7, H=1, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=2, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 3 and 5 and 7.

>

>

> Partial        fit            = N=1, H=2, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=2, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 5 and 7.

>

>

> Partial        fit            = N=3, H=2, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=2, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 3 and 7.

>

>

> Partial        fit            = N=5, H=2, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=2, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 3 and 5.

>

>

> Partial        fit            = N=7, H=2, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=3, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 2 and 5 and 7.

>

>

> Partial        fit            = N=1, H=3, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=3, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 5 and 7.

>

>

> Partial        fit            = N=2, H=3, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=3, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 7.

>

>

> Partial        fit            = N=5, H=3, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=3, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 5.

>

>

> Partial        fit            = N=7, H=3, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=5, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 7.

>

>

> Partial        fit            = N=1, H=5, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=5, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 3 and 7.

>

>

> Partial        fit            = N=2, H=5, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=5, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 7.

>

>

> Partial        fit            = N=3, H=5, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=5, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3.

>

>

> Partial        fit            = N=7, H=5, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=7, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 5.

>

>

> Partial        fit            = N=1, H=7, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=7, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 3 and 5.

>

>

> Partial        fit            = N=2, H=7, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=7, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 5.

>

>

> Partial        fit            = N=3, H=7, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=7, T=9, Í=8, E=4, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3.

>

>

> Partial        fit            = N=5, H=7, T=9, Í=8, E=4, A=6, Z=0.

> Partial        values         =                61040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=5, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60060

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 5

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=9, E=5, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 60150

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=7, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60060

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 7

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = 1.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=1, E=7, A=6, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 60070

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 5, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=8, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60060

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 8

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 7, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=2, E=8, A=6, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 60080

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 3, 4, 5, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=9, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60060

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 9

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 7, 8.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=3, E=9, A=6, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 60090

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 2, 4, 5, 7, 8.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70070

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 1

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 70110

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 5, 6, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 6 and 8.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 3 and 5 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=2, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 5 and 6 and 8.

>

>

> Partial        fit            = N=3, H=2, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=2, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 3 and 6 and 8.

>

>

> Partial        fit            = N=5, H=2, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=2, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 3 and 5 and 8.

>

>

> Partial        fit            = N=6, H=2, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=2, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 3 and 5 and 6.

>

>

> Partial        fit            = N=8, H=2, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 5 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=3, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 5 and 6 and 8.

>

>

> Partial        fit            = N=2, H=3, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=3, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 6 and 8.

>

>

> Partial        fit            = N=5, H=3, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=3, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 5 and 8.

>

>

> Partial        fit            = N=6, H=3, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=3, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 5 and 6.

>

>

> Partial        fit            = N=8, H=3, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=5, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 3 and 6 and 8.

>

>

> Partial        fit            = N=2, H=5, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=5, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 6 and 8.

>

>

> Partial        fit            = N=3, H=5, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=5, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 8.

>

>

> Partial        fit            = N=6, H=5, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=5, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 6.

>

>

> Partial        fit            = N=8, H=5, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=6, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 3 and 5 and 8.

>

>

> Partial        fit            = N=2, H=6, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=6, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 5 and 8.

>

>

> Partial        fit            = N=3, H=6, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=6, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 8.

>

>

> Partial        fit            = N=5, H=6, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=6, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 5.

>

>

> Partial        fit            = N=8, H=6, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=8, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=8, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 3 and 5 and 6.

>

>

> Partial        fit            = N=2, H=8, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=8, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 5 and 6.

>

>

> Partial        fit            = N=3, H=8, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=8, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 6.

>

>

> Partial        fit            = N=5, H=8, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=8, T=9, Í=4, E=1, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 5.

>

>

> Partial        fit            = N=6, H=8, T=9, Í=4, E=1, A=7, Z=0.

> Partial        values         =                71010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70070

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 2

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 1, 3, 4, 5, 6, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 70120

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 3, 4, 6, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6 and 8.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 3 and 4 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=1, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 4 and 6 and 8.

>

>

> Partial        fit            = N=3, H=1, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=1, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 3 and 6 and 8.

>

>

> Partial        fit            = N=4, H=1, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=1, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 3 and 4 and 8.

>

>

> Partial        fit            = N=6, H=1, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=1, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Partial        fit            = N=8, H=1, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=3, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 4 and 6 and 8.

>

>

> Partial        fit            = N=1, H=3, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=3, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 6 and 8.

>

>

> Partial        fit            = N=4, H=3, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=3, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 8.

>

>

> Partial        fit            = N=6, H=3, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=3, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=8, H=3, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=4, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 3 and 6 and 8.

>

>

> Partial        fit            = N=1, H=4, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=4, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 6 and 8.

>

>

> Partial        fit            = N=3, H=4, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=4, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 8.

>

>

> Partial        fit            = N=6, H=4, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=4, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=8, H=4, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=6, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 3 and 4 and 8.

>

>

> Partial        fit            = N=1, H=6, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=6, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 8.

>

>

> Partial        fit            = N=3, H=6, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=6, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 8.

>

>

> Partial        fit            = N=4, H=6, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=6, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4.

>

>

> Partial        fit            = N=8, H=6, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=8, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=8, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Partial        fit            = N=1, H=8, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=8, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=3, H=8, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=8, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=4, H=8, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=8, T=9, Í=5, E=2, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4.

>

>

> Partial        fit            = N=6, H=8, T=9, Í=5, E=2, A=7, Z=0.

> Partial        values         =                71020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70070

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 3

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 1, 2, 4, 5, 6, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 70130

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 4, 5, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 8.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=1, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 4 and 5 and 8.

>

>

> Partial        fit            = N=2, H=1, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=1, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 2 and 5 and 8.

>

>

> Partial        fit            = N=4, H=1, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=1, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 2 and 4 and 8.

>

>

> Partial        fit            = N=5, H=1, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=1, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 2 and 4 and 5.

>

>

> Partial        fit            = N=8, H=1, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=2, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 4 and 5 and 8.

>

>

> Partial        fit            = N=1, H=2, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 5 and 8.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=2, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 8.

>

>

> Partial        fit            = N=5, H=2, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=2, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 5.

>

>

> Partial        fit            = N=8, H=2, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=4, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 2 and 5 and 8.

>

>

> Partial        fit            = N=1, H=4, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 5 and 8.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=4, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 8.

>

>

> Partial        fit            = N=5, H=4, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=4, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 5.

>

>

> Partial        fit            = N=8, H=4, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=5, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 2 and 4 and 8.

>

>

> Partial        fit            = N=1, H=5, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=5, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 8.

>

>

> Partial        fit            = N=2, H=5, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=5, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 8.

>

>

> Partial        fit            = N=4, H=5, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=8, H=5, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=8, H=5, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=8, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=8, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 2 and 4 and 5.

>

>

> Partial        fit            = N=1, H=8, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=8, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 5.

>

>

> Partial        fit            = N=2, H=8, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=8, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 5.

>

>

> Partial        fit            = N=4, H=8, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=8, T=9, Í=6, E=3, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=5, H=8, T=9, Í=6, E=3, A=7, Z=0.

> Partial        values         =                71030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=4, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70070

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 4

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 1, 2, 3, 5, 6, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70070

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 5

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 1, 2, 3, 4, 6, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 70150

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 6, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=1, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Partial        fit            = N=2, H=1, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=1, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=3, H=1, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=1, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 6.

>

>

> Partial        fit            = N=4, H=1, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=1, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 4.

>

>

> Partial        fit            = N=6, H=1, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=2, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Partial        fit            = N=1, H=2, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=2, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=3, H=2, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=2, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4.

>

>

> Partial        fit            = N=6, H=2, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=3, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=1, H=3, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=3, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=2, H=3, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=3, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 6.

>

>

> Partial        fit            = N=4, H=3, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=3, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=6, H=3, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=4, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 6.

>

>

> Partial        fit            = N=1, H=4, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=4, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 6.

>

>

> Partial        fit            = N=3, H=4, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=4, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3.

>

>

> Partial        fit            = N=6, H=4, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=6, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 4.

>

>

> Partial        fit            = N=1, H=6, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=6, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4.

>

>

> Partial        fit            = N=2, H=6, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=6, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=3, H=6, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=6, T=9, Í=8, E=5, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3.

>

>

> Partial        fit            = N=4, H=6, T=9, Í=8, E=5, A=7, Z=0.

> Partial        values         =                71050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=6, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70070

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 6

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=9, E=6, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 70160

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=8, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70070

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 8

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6, 9.

> Possible       digits         = 1.

> Intersection   of them        = 1.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=1, E=8, A=7, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 70080

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=9, A=7, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70070

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 9

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6, 8.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=2, E=9, A=7, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 70090

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 1, 3, 4, 5, 6, 8.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=1, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80080

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 1

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 80110

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 4, 5, 6, 7, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 4 and 5 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 5 and 6 and 7.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=2, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Partial        fit            = N=5, H=2, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=2, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 4 and 5 and 7.

>

>

> Partial        fit            = N=6, H=2, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=2, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 4 and 5 and 6.

>

>

> Partial        fit            = N=7, H=2, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 5 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 5 and 6 and 7.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=4, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 6 and 7.

>

>

> Partial        fit            = N=5, H=4, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=4, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 5 and 7.

>

>

> Partial        fit            = N=6, H=4, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=4, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 5 and 6.

>

>

> Partial        fit            = N=7, H=4, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=5, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Partial        fit            = N=2, H=5, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=5, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 6 and 7.

>

>

> Partial        fit            = N=4, H=5, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=5, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=6, H=5, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=5, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=7, H=5, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=6, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 4 and 5 and 7.

>

>

> Partial        fit            = N=2, H=6, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=6, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 5 and 7.

>

>

> Partial        fit            = N=4, H=6, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=6, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=5, H=6, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=6, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 5.

>

>

> Partial        fit            = N=7, H=6, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 5 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=7, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 4 and 5 and 6.

>

>

> Partial        fit            = N=2, H=7, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=7, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 5 and 6.

>

>

> Partial        fit            = N=4, H=7, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=7, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=5, H=7, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=7, T=9, Í=3, E=1, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 5.

>

>

> Partial        fit            = N=6, H=7, T=9, Í=3, E=1, A=8, Z=0.

> Partial        values         =                81010 is greater than 10010.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80080

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 2

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 1, 3, 4, 5, 6, 7, 9.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 80120

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 3, 5, 6, 7, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 6 and 7.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 3 and 5 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=1, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 5 and 6 and 7.

>

>

> Partial        fit            = N=3, H=1, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=1, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 3 and 6 and 7.

>

>

> Partial        fit            = N=5, H=1, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=1, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 3 and 5 and 7.

>

>

> Partial        fit            = N=6, H=1, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=1, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 3 and 5 and 6.

>

>

> Partial        fit            = N=7, H=1, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 5 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=3, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 5 and 6 and 7.

>

>

> Partial        fit            = N=1, H=3, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=3, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 6 and 7.

>

>

> Partial        fit            = N=5, H=3, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=3, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 5 and 7.

>

>

> Partial        fit            = N=6, H=3, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=3, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 5 and 6.

>

>

> Partial        fit            = N=7, H=3, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=5, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 3 and 6 and 7.

>

>

> Partial        fit            = N=1, H=5, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=5, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 6 and 7.

>

>

> Partial        fit            = N=3, H=5, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=5, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 7.

>

>

> Partial        fit            = N=6, H=5, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=5, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=7, H=5, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=6, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 3 and 5 and 7.

>

>

> Partial        fit            = N=1, H=6, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=6, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 5 and 7.

>

>

> Partial        fit            = N=3, H=6, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=6, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 7.

>

>

> Partial        fit            = N=5, H=6, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=6, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 5.

>

>

> Partial        fit            = N=7, H=6, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=7, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 3 and 5 and 6.

>

>

> Partial        fit            = N=1, H=7, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=7, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 5 and 6.

>

>

> Partial        fit            = N=3, H=7, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=7, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=5, H=7, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=7, T=9, Í=4, E=2, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 5.

>

>

> Partial        fit            = N=6, H=7, T=9, Í=4, E=2, A=8, Z=0.

> Partial        values         =                81020 is greater than 20020.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80080

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 3

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 1, 2, 4, 5, 6, 7, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 80130

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 4, 6, 7, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6 and 7.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=1, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Partial        fit            = N=2, H=1, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=1, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 2 and 6 and 7.

>

>

> Partial        fit            = N=4, H=1, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=1, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=6, H=1, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=1, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=7, H=1, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 4 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=2, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Partial        fit            = N=1, H=2, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 6 and 7.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=2, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 4 and 7.

>

>

> Partial        fit            = N=6, H=2, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=2, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=7, H=2, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=4, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 2 and 6 and 7.

>

>

> Partial        fit            = N=1, H=4, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 6 and 7.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=4, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 7.

>

>

> Partial        fit            = N=6, H=4, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=4, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 6.

>

>

> Partial        fit            = N=7, H=4, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=6, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 7.

>

>

> Partial        fit            = N=1, H=6, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=6, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 4 and 7.

>

>

> Partial        fit            = N=2, H=6, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=6, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 7.

>

>

> Partial        fit            = N=4, H=6, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=6, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=7, H=6, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=7, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=1, H=7, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=7, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=2, H=7, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=7, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 6.

>

>

> Partial        fit            = N=4, H=7, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=7, T=9, Í=5, E=3, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=6, H=7, T=9, Í=5, E=3, A=8, Z=0.

> Partial        values         =                81030 is greater than 30030.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80080

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 4

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 1, 2, 3, 5, 6, 7, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 80140

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 5, 7, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 7.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=1, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 3 and 5 and 7.

>

>

> Partial        fit            = N=2, H=1, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=1, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 2 and 5 and 7.

>

>

> Partial        fit            = N=3, H=1, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=1, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 7.

>

>

> Partial        fit            = N=5, H=1, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=1, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 5.

>

>

> Partial        fit            = N=7, H=1, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=2, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 3 and 5 and 7.

>

>

> Partial        fit            = N=1, H=2, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=2, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 5 and 7.

>

>

> Partial        fit            = N=3, H=2, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=2, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 7.

>

>

> Partial        fit            = N=5, H=2, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=2, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 5.

>

>

> Partial        fit            = N=7, H=2, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=3, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 2 and 5 and 7.

>

>

> Partial        fit            = N=1, H=3, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=3, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 5 and 7.

>

>

> Partial        fit            = N=2, H=3, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=3, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 7.

>

>

> Partial        fit            = N=5, H=3, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=3, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 5.

>

>

> Partial        fit            = N=7, H=3, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=5, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=5, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 7.

>

>

> Partial        fit            = N=1, H=5, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=5, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 7.

>

>

> Partial        fit            = N=2, H=5, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=5, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 7.

>

>

> Partial        fit            = N=3, H=5, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=7, H=5, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3.

>

>

> Partial        fit            = N=7, H=5, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=7, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=7, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 5.

>

>

> Partial        fit            = N=1, H=7, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=7, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 5.

>

>

> Partial        fit            = N=2, H=7, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=7, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 5.

>

>

> Partial        fit            = N=3, H=7, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=5, H=7, T=9, Í=6, E=4, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3.

>

>

> Partial        fit            = N=5, H=7, T=9, Í=6, E=4, A=8, Z=0.

> Partial        values         =                81040 is greater than 40040.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80080

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 5

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 1, 2, 3, 4, 6, 7, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 9.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 80150

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 6, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'H'

> Intermediate   fit list       = T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=1, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=1, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Partial        fit            = N=2, H=1, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=1, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=3, H=1, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=1, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 6.

>

>

> Partial        fit            = N=4, H=1, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=1, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 4.

>

>

> Partial        fit            = N=6, H=1, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=2, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=2, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Partial        fit            = N=1, H=2, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=2, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=3, H=2, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=2, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=4, H=2, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=2, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 4.

>

>

> Partial        fit            = N=6, H=2, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=3, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=3, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 2 and 4 and 6.

>

>

> Partial        fit            = N=1, H=3, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=3, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 4 and 6.

>

>

> Partial        fit            = N=2, H=3, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=3, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 6.

>

>

> Partial        fit            = N=4, H=3, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=3, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=6, H=3, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=4, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=4, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 6.

>

>

> Partial        fit            = N=1, H=4, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=4, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 6.

>

>

> Partial        fit            = N=2, H=4, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=4, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 6.

>

>

> Partial        fit            = N=3, H=4, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=6, H=4, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3.

>

>

> Partial        fit            = N=6, H=4, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = H=6, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=1, H=6, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 4.

>

>

> Partial        fit            = N=1, H=6, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=2, H=6, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 3 and 4.

>

>

> Partial        fit            = N=2, H=6, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=3, H=6, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 4.

>

>

> Partial        fit            = N=3, H=6, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = N=4, H=6, T=9, Í=7, E=5, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3.

>

>

> Partial        fit            = N=4, H=6, T=9, Í=7, E=5, A=8, Z=0.

> Partial        values         =                81050 is greater than 50050.

>

> Coefficient    of 'V'         =                    0 is equal to 0.

> Result of      predicate       = rejected("The final step has no solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=6, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80080

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 6

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=7, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80080

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 7

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=9, E=7, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 80170

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=9, A=8, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80080

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 9

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6, 7.

> Possible       digits         = 1.

> Intersection   of them        = 1.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=1, E=9, A=8, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 80090

> right          partial value  = 90090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'E'

> Intermediate   fit list       = A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=1, A=9, Z=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90090

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 1

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=2, E=1, A=9, Z=0.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 90110

> right          partial value  = 10010

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=2, A=9, Z=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90090

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 2

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 1, 3, 4, 5, 6, 7, 8.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=3, E=2, A=9, Z=0.

> Remaining      digits         = 1 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 90120

> right          partial value  = 20020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 4, 5, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=3, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90090

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 3

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 1, 2, 4, 5, 6, 7, 8.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=4, E=3, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 90130

> right          partial value  = 30030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 5, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=4, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90090

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 4

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 1, 2, 3, 5, 6, 7, 8.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=5, E=4, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 6 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 90140

> right          partial value  = 40040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=5, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90090

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 5

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 1, 2, 3, 4, 6, 7, 8.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=6, E=5, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 7 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 90150

> right          partial value  = 50050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=6, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90090

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 6

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 7, 8.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=7, E=6, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 8.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 90160

> right          partial value  = 60060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=7, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90090

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 7

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6, 8.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = Í=8, E=7, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'T'   = 2

> left           partial value  = 90170

> right          partial value  = 70070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = E=8, A=9, Z=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90090

> right          partial value  = 80080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 8

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6, 7.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

2257,2263c10857,10859

< Tried          fits           = 0

< Matching       fits           = not found

<

<

< Condensed      puzzle         = 5*HÚSZ=SZÁZ

<

< Simplified     puzzle         = 5*HÚSZ=SZÁZ

---

> Condensed      puzzle         = HATVAN+TÍZ=HETVEN

>

> Simplified     puzzle         = HATVAN+TÍZ=HETVEN

2270a10866,19819

> Current        code is        = 'Z'

> Intermediate   fit list       = H=1.

> Remaining      digits         = 0 and 5.

>

>

> Rightmost      place of 'Z'   = 0

> right          partial value  = 0

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 6

>

> Digit on       right side     = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0 or 5.

>

>

> Remaining      digits         = 0, 5.

> Possible       digits         = 0, 5.

> Intersection   of them        = 0, 5.

> Number of      elements       = 2

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = Z=0, H=1.

> Remaining      digits         = 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = S=5, Z=0, H=1.

> Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Á'   = 1

> right          partial value  = 4750

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 5

>

> Digit on       other side     = 0

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = S=6, Z=0, H=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Á'   = 1

> right          partial value  = 5700

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = S=7, Z=0, H=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Á'   = 1

> right          partial value  = 6650

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 5

>

> Digit on       other side     = 0

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'Ú'

> Intermediate   fit list       = Á=5, S=7, Z=0, H=1.

> Remaining      digits         = 2 and 3 and 4 and 6 and 8 and 9.

>

>

> Calculated     ratio          = 3

> Calculated     modulus        = 200

>

> Partial        fit            = Á=5, S=7, Z=0, H=1.

> Partial        values         =                 5000 is less than 6700.

>

> Coefficient    of 'Ú'         =                  500 is greater than 0.

> Result of      predicate       = rejected("The final step has not acceptable solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = S=8, Z=0, H=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Á'   = 1

> right          partial value  = 7600

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 0

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = S=9, Z=0, H=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Á'   = 1

> right          partial value  = 8550

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 5

>

> Digit on       other side     = 0

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'Ú'

> Intermediate   fit list       = Á=5, S=9, Z=0, H=1.

> Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8.

>

>

> Calculated     ratio          = 7

> Calculated     modulus        = 100

>

> Partial        fit            = Á=5, S=9, Z=0, H=1.

> Partial        values         =                 5000 is less than 8600.

>

> Coefficient    of 'Ú'         =                  500 is greater than 0.

> Result of      predicate       = rejected("The final step has not acceptable solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = Z=5, H=1.

> Remaining      digits         = 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = S=6, Z=5, H=1.

> Remaining      digits         = 0 and 2 and 3 and 4 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Á'   = 1

> right          partial value  = 6180

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 8

>

> Digit on       other side     = 0

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 0, 2, 3, 4, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'Ú'

> Intermediate   fit list       = Á=2, S=6, Z=5, H=1.

> Remaining      digits         = 0 and 3 and 4 and 7 and 8 and 9.

>

>

> Calculated     ratio          = 2

> Calculated     modulus        = 200

>

> Partial        fit            = Á=2, S=6, Z=5, H=1.

> Partial        values         =                 5000 is less than 6200.

>

> Coefficient    of 'Ú'         =                  500 is greater than 0.

> Result of      predicate       = rejected("The final step has not acceptable solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = S=7, Z=5, H=1.

> Remaining      digits         = 0 and 2 and 3 and 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Á'   = 1

> right          partial value  = 7130

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 3

>

> Digit on       other side     = 0

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 0, 2, 3, 4, 6, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = S=8, Z=5, H=1.

> Remaining      digits         = 0 and 2 and 3 and 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Á'   = 1

> right          partial value  = 8080

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 8

>

> Digit on       other side     = 0

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 0, 2, 3, 4, 6, 7, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'Ú'

> Intermediate   fit list       = Á=2, S=8, Z=5, H=1.

> Remaining      digits         = 0 and 3 and 4 and 6 and 7 and 9.

>

>

> Calculated     ratio          = 6

> Calculated     modulus        = 100

>

> Partial        fit            = Á=2, S=8, Z=5, H=1.

> Partial        values         =                 5000 is less than 8100.

>

> Coefficient    of 'Ú'         =                  500 is greater than 0.

> Result of      predicate       = rejected("The final step has not acceptable solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = S=9, Z=5, H=1.

> Remaining      digits         = 0 and 2 and 3 and 4 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Á'   = 1

> right          partial value  = 9030

> left           partial value  = 5000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 3

>

> Digit on       other side     = 0

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 0, 2, 3, 4, 6, 7, 8.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'Ú'

> Intermediate   fit list       = Á=7, S=9, Z=5, H=1.

> Remaining      digits         = 0 and 2 and 3 and 4 and 6 and 8.

>

>

> Calculated     ratio          = 8

> Calculated     modulus        = 100

>

> Partial        fit            = Á=7, S=9, Z=5, H=1.

> Partial        values         =                 5000 is less than 9100.

>

> Coefficient    of 'Ú'         =                  500 is greater than 0.

> Result of      predicate       = rejected("The final step has not acceptable solution.")

>

> Calculated     digit          = none.

>

>

> Condensed      puzzle         = 5*HÚSZ=SZÁZ

>

> Simplified     puzzle         = 5*HÚSZ=SZÁZ

>

>

> Condensed      puzzle         = 5*HÚSZ=SZÁZ

>

> Simplified     puzzle         = 5*HÚSZ=SZÁZ

>

>

> Tried          fits           = 0

> Matching       fits           = not found

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = I=1.

> Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'R'

> Intermediate   fit list       = L=0, I=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 2

> right          partial value  = 1000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 0

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 3

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 5, 6, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 3

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 4, 6, 7, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=3, O=5, Í=7, B=4, T=6, V=9, V=9, T=6, B=4, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Results of     fit            = »452+978« related to     »1630«

> Values of      fit            = 1430 is less than      1630.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=3, O=5, Í=7, B=6, T=4, V=9, V=9, T=4, B=6, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Results of     fit            = »652+978« related to     »1430«

> Values of      fit            = 1630 is greater than   1430.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=3, O=5, Í=7, B=9, T=4, V=6, V=6, T=4, B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Results of     fit            = »952+678« related to     »1430«

> Values of      fit            = 1630 is greater than   1430.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=3, O=5, Í=7, B=9, T=6, V=4, V=4, T=6, B=9, Í=7, O=5, A=3, Z=8, R=2, L=0, I=1.

> Results of     fit            = »952+478« related to     »1630«

> Values of      fit            = 1430 is less than      1630.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 3

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 4, 5, 7, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 3

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 4, 5, 6, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=3, O=7, Í=5, B=4, T=6, V=9, V=9, T=6, B=4, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Results of     fit            = »472+958« related to     »1630«

> Values of      fit            = 1430 is less than      1630.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=3, O=7, Í=5, B=6, T=4, V=9, V=9, T=4, B=6, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Results of     fit            = »672+958« related to     »1430«

> Values of      fit            = 1630 is greater than   1430.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=3, O=7, Í=5, B=9, T=4, V=6, V=6, T=4, B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Results of     fit            = »972+658« related to     »1430«

> Values of      fit            = 1630 is greater than   1430.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=3, O=7, Í=5, B=9, T=6, V=4, V=4, T=6, B=9, Í=5, O=7, A=3, Z=8, R=2, L=0, I=1.

> Results of     fit            = »972+458« related to     »1630«

> Values of      fit            = 1430 is less than      1630.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=3, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 4, 5, 6, 7.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 4

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 5, 6, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 4

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 6, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 4

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 3, 5, 7, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=3, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=3, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=4, O=6, Í=7, B=3, T=5, V=9, V=9, T=5, B=3, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Results of     fit            = »362+978« related to     »1540«

> Values of      fit            = 1340 is less than      1540.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=5, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=4, O=6, Í=7, B=5, T=3, V=9, V=9, T=3, B=5, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Results of     fit            = »562+978« related to     »1340«

> Values of      fit            = 1540 is greater than   1340.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=4, O=6, Í=7, B=9, T=3, V=5, V=5, T=3, B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Results of     fit            = »962+578« related to     »1340«

> Values of      fit            = 1540 is greater than   1340.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=4, O=6, Í=7, B=9, T=5, V=3, V=3, T=5, B=9, Í=7, O=6, A=4, Z=8, R=2, L=0, I=1.

> Results of     fit            = »962+378« related to     »1540«

> Values of      fit            = 1340 is less than      1540.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 4

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 5, 6, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=3, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=3, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=4, O=7, Í=6, B=3, T=5, V=9, V=9, T=5, B=3, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Results of     fit            = »372+968« related to     »1540«

> Values of      fit            = 1340 is less than      1540.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=5, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=4, O=7, Í=6, B=5, T=3, V=9, V=9, T=3, B=5, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Results of     fit            = »572+968« related to     »1340«

> Values of      fit            = 1540 is greater than   1340.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=4, O=7, Í=6, B=9, T=3, V=5, V=5, T=3, B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Results of     fit            = »972+568« related to     »1340«

> Values of      fit            = 1540 is greater than   1340.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=4, O=7, Í=6, B=9, T=5, V=3, V=3, T=5, B=9, Í=6, O=7, A=4, Z=8, R=2, L=0, I=1.

> Results of     fit            = »972+368« related to     »1540«

> Values of      fit            = 1340 is less than      1540.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=4, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 5, 6, 7.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=5, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=5, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 5

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 4, 6, 7, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=5, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 5

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 3, 6, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=5, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 5

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 4, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=5, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 5

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 3, 4, 6, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=5, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 3, 4, 6, 7.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=6, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=6, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 6

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 4, 5, 7, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=6, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 6

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 3, 5, 7, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=6, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 6

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 3, 4, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=6, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 6

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 4, 5, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=6, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 4, 5, 7.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=7, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=7, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 7

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 4, 5, 6, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=7, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 7

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 5, 6, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=7, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 7

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 3, 4, 6, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=7, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 7

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 3, 4, 5, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=7, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 3, 4, 5, 6.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 9

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 4, 5, 6, 7.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=4, T=6, V=7, V=7, T=6, B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »432+758« related to     »1690«

> Values of      fit            = 1190 is less than      1690.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=4, T=7, V=6, V=6, T=7, B=4, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »432+658« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=6, T=4, V=7, V=7, T=4, B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »632+758« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=6, T=7, V=4, V=4, T=7, B=6, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »632+458« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=7, T=4, V=6, V=6, T=4, B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »732+658« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=3, Í=5, B=7, T=6, V=4, V=4, T=6, B=7, Í=5, O=3, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »732+458« related to     »1690«

> Values of      fit            = 1190 is less than      1690.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 9

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 5, 6, 7.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 9

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 3, 4, 6, 7.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=4, T=6, V=7, V=7, T=6, B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »452+738« related to     »1690«

> Values of      fit            = 1190 is less than      1690.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=4, T=7, V=6, V=6, T=7, B=4, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »452+638« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=6, T=4, V=7, V=7, T=4, B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »652+738« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=6, T=7, V=4, V=4, T=7, B=6, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »652+438« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=7, T=4, V=6, V=6, T=4, B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »752+638« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=2, Z=8, A=9, O=5, Í=3, B=7, T=6, V=4, V=4, T=6, B=7, Í=3, O=5, A=9, Z=8, R=2, L=0, I=1.

> Results of     fit            = »752+438« related to     »1690«

> Values of      fit            = 1190 is less than      1690.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 9

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 4, 5, 7.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=9, Z=8, R=2, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 9

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 3, 4, 5, 6.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 3

> right          partial value  = 1000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 0

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6 and 8 and 9.

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 2

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 5, 6, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 2

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 4, 6, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 8 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=4, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=2, O=5, Í=6, B=4, T=8, V=9, V=9, T=8, B=4, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Results of     fit            = »453+967« related to     »1820«

> Values of      fit            = 1420 is less than      1820.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=8, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=2, O=5, Í=6, B=8, T=4, V=9, V=9, T=4, B=8, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Results of     fit            = »853+967« related to     »1420«

> Values of      fit            = 1820 is greater than   1420.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=2, O=5, Í=6, B=9, T=4, V=8, V=8, T=4, B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Results of     fit            = »953+867« related to     »1420«

> Values of      fit            = 1820 is greater than   1420.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=2, O=5, Í=6, B=9, T=8, V=4, V=4, T=8, B=9, Í=6, O=5, A=2, Z=7, R=3, L=0, I=1.

> Results of     fit            = »953+467« related to     »1820«

> Values of      fit            = 1420 is less than      1820.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 2

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 4, 5, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 8 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=4, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=2, O=6, Í=5, B=4, T=8, V=9, V=9, T=8, B=4, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Results of     fit            = »463+957« related to     »1820«

> Values of      fit            = 1420 is less than      1820.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=8, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=2, O=6, Í=5, B=8, T=4, V=9, V=9, T=4, B=8, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Results of     fit            = »863+957« related to     »1420«

> Values of      fit            = 1820 is greater than   1420.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=2, O=6, Í=5, B=9, T=4, V=8, V=8, T=4, B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Results of     fit            = »963+857« related to     »1420«

> Values of      fit            = 1820 is greater than   1420.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=2, O=6, Í=5, B=9, T=8, V=4, V=4, T=8, B=9, Í=5, O=6, A=2, Z=7, R=3, L=0, I=1.

> Results of     fit            = »963+457« related to     »1820«

> Values of      fit            = 1420 is less than      1820.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 2

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 4, 5, 6, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=2, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 4, 5, 6, 8.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 4

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 5, 6, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 4

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 6, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=2, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=4, O=5, Í=8, B=2, T=6, V=9, V=9, T=6, B=2, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Results of     fit            = »253+987« related to     »1640«

> Values of      fit            = 1240 is less than      1640.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=6, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=4, O=5, Í=8, B=6, T=2, V=9, V=9, T=2, B=6, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Results of     fit            = »653+987« related to     »1240«

> Values of      fit            = 1640 is greater than   1240.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=4, O=5, Í=8, B=9, T=2, V=6, V=6, T=2, B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Results of     fit            = »953+687« related to     »1240«

> Values of      fit            = 1640 is greater than   1240.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=4, O=5, Í=8, B=9, T=6, V=2, V=2, T=6, B=9, Í=8, O=5, A=4, Z=7, R=3, L=0, I=1.

> Results of     fit            = »953+287« related to     »1640«

> Values of      fit            = 1240 is less than      1640.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 4

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 5, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 4

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 5, 6, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=2, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=4, O=8, Í=5, B=2, T=6, V=9, V=9, T=6, B=2, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Results of     fit            = »283+957« related to     »1640«

> Values of      fit            = 1240 is less than      1640.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=6, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=4, O=8, Í=5, B=6, T=2, V=9, V=9, T=2, B=6, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Results of     fit            = »683+957« related to     »1240«

> Values of      fit            = 1640 is greater than   1240.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=4, O=8, Í=5, B=9, T=2, V=6, V=6, T=2, B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Results of     fit            = »983+657« related to     »1240«

> Values of      fit            = 1640 is greater than   1240.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=4, O=8, Í=5, B=9, T=6, V=2, V=2, T=6, B=9, Í=5, O=8, A=4, Z=7, R=3, L=0, I=1.

> Results of     fit            = »983+257« related to     »1640«

> Values of      fit            = 1240 is less than      1640.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=4, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 5, 6, 8.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 5

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 4, 6, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 5

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 6, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 5

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 4, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=2, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=5, O=6, Í=8, B=2, T=4, V=9, V=9, T=4, B=2, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Results of     fit            = »263+987« related to     »1450«

> Values of      fit            = 1250 is less than      1450.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=4, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=5, O=6, Í=8, B=4, T=2, V=9, V=9, T=2, B=4, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Results of     fit            = »463+987« related to     »1250«

> Values of      fit            = 1450 is greater than   1250.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=5, O=6, Í=8, B=9, T=2, V=4, V=4, T=2, B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Results of     fit            = »963+487« related to     »1250«

> Values of      fit            = 1450 is greater than   1250.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=5, O=6, Í=8, B=9, T=4, V=2, V=2, T=4, B=9, Í=8, O=6, A=5, Z=7, R=3, L=0, I=1.

> Results of     fit            = »963+287« related to     »1450«

> Values of      fit            = 1250 is less than      1450.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 5

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 4, 6, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=2, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=5, O=8, Í=6, B=2, T=4, V=9, V=9, T=4, B=2, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Results of     fit            = »283+967« related to     »1450«

> Values of      fit            = 1250 is less than      1450.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=4, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=5, O=8, Í=6, B=4, T=2, V=9, V=9, T=2, B=4, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Results of     fit            = »483+967« related to     »1250«

> Values of      fit            = 1450 is greater than   1250.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=5, O=8, Í=6, B=9, T=2, V=4, V=4, T=2, B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Results of     fit            = »983+467« related to     »1250«

> Values of      fit            = 1450 is greater than   1250.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=5, O=8, Í=6, B=9, T=4, V=2, V=2, T=4, B=9, Í=6, O=8, A=5, Z=7, R=3, L=0, I=1.

> Results of     fit            = »983+267« related to     »1450«

> Values of      fit            = 1250 is less than      1450.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=5, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 4, 6, 8.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=6, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=6, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 6

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 4, 5, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=6, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 6

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 5, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=6, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 6

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 4, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=6, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 6

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 4, 5, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=6, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 4, 5, 8.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 8

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 4, 5, 6, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=8, O=2, Í=5, B=4, T=6, V=9, V=9, T=6, B=4, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Results of     fit            = »423+957« related to     »1680«

> Values of      fit            = 1380 is less than      1680.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=8, O=2, Í=5, B=6, T=4, V=9, V=9, T=4, B=6, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Results of     fit            = »623+957« related to     »1480«

> Values of      fit            = 1580 is greater than   1480.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=8, O=2, Í=5, B=9, T=4, V=6, V=6, T=4, B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Results of     fit            = »923+657« related to     »1480«

> Values of      fit            = 1580 is greater than   1480.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=8, O=2, Í=5, B=9, T=6, V=4, V=4, T=6, B=9, Í=5, O=2, A=8, Z=7, R=3, L=0, I=1.

> Results of     fit            = »923+457« related to     »1680«

> Values of      fit            = 1380 is less than      1680.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 8

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 5, 6, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 8

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 4, 6, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=8, O=5, Í=2, B=4, T=6, V=9, V=9, T=6, B=4, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Results of     fit            = »453+927« related to     »1680«

> Values of      fit            = 1380 is less than      1680.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=8, O=5, Í=2, B=6, T=4, V=9, V=9, T=4, B=6, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Results of     fit            = »653+927« related to     »1480«

> Values of      fit            = 1580 is greater than   1480.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=8, O=5, Í=2, B=9, T=4, V=6, V=6, T=4, B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Results of     fit            = »953+627« related to     »1480«

> Values of      fit            = 1580 is greater than   1480.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=8, O=5, Í=2, B=9, T=6, V=4, V=4, T=6, B=9, Í=2, O=5, A=8, Z=7, R=3, L=0, I=1.

> Results of     fit            = »953+427« related to     »1680«

> Values of      fit            = 1380 is less than      1680.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 8

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 4, 5, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=8, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 4, 5, 6.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6 and 8.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 9

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 4, 5, 6, 8.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5 and 8.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=4, T=5, V=8, V=8, T=5, B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »423+867« related to     »1590«

> Values of      fit            = 1290 is less than      1590.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=4, T=8, V=5, V=5, T=8, B=4, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »423+567« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=5, T=4, V=8, V=8, T=4, B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »523+867« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=5, T=8, V=4, V=4, T=8, B=5, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »523+467« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=8, T=4, V=5, V=5, T=4, B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »823+567« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=2, Í=6, B=8, T=5, V=4, V=4, T=5, B=8, Í=6, O=2, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »823+467« related to     »1590«

> Values of      fit            = 1290 is less than      1590.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 9

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 5, 6, 8.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 9

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 4, 6, 8.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 9

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 4, 5, 8.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5 and 8.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=4, T=5, V=8, V=8, T=5, B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »463+827« related to     »1590«

> Values of      fit            = 1290 is less than      1590.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=4, T=8, V=5, V=5, T=8, B=4, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »463+527« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=5, T=4, V=8, V=8, T=4, B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »563+827« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=5, T=8, V=4, V=4, T=8, B=5, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »563+427« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=8, T=4, V=5, V=5, T=4, B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »863+527« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=3, Z=7, A=9, O=6, Í=2, B=8, T=5, V=4, V=4, T=5, B=8, Í=2, O=6, A=9, Z=7, R=3, L=0, I=1.

> Results of     fit            = »863+427« related to     »1590«

> Values of      fit            = 1290 is less than      1590.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=9, Z=7, R=3, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 9

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 4, 5, 6.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 4

> right          partial value  = 1000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 0

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 5, 6, 7, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7 and 8 and 9.

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 2

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 5, 7, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5 and 7 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=5, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=2, O=3, Í=8, B=5, T=7, V=9, V=9, T=7, B=5, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Results of     fit            = »534+986« related to     »1720«

> Values of      fit            = 1520 is less than      1720.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=7, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=2, O=3, Í=8, B=7, T=5, V=9, V=9, T=5, B=7, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Results of     fit            = »734+986« related to     »1520«

> Values of      fit            = 1720 is greater than   1520.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=2, O=3, Í=8, B=9, T=5, V=7, V=7, T=5, B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Results of     fit            = »934+786« related to     »1520«

> Values of      fit            = 1720 is greater than   1520.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=2, O=3, Í=8, B=9, T=7, V=5, V=5, T=7, B=9, Í=8, O=3, A=2, Z=6, R=4, L=0, I=1.

> Results of     fit            = »934+586« related to     »1720«

> Values of      fit            = 1520 is less than      1720.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 2

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 7, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 2

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 5, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 2

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 3, 5, 7, 9.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5 and 7 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=5, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=2, O=8, Í=3, B=5, T=7, V=9, V=9, T=7, B=5, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Results of     fit            = »584+936« related to     »1720«

> Values of      fit            = 1520 is less than      1720.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=7, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=2, O=8, Í=3, B=7, T=5, V=9, V=9, T=5, B=7, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Results of     fit            = »784+936« related to     »1520«

> Values of      fit            = 1720 is greater than   1520.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=2, O=8, Í=3, B=9, T=5, V=7, V=7, T=5, B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Results of     fit            = »984+736« related to     »1520«

> Values of      fit            = 1720 is greater than   1520.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=2, O=8, Í=3, B=9, T=7, V=5, V=5, T=7, B=9, Í=3, O=8, A=2, Z=6, R=4, L=0, I=1.

> Results of     fit            = »984+536« related to     »1720«

> Values of      fit            = 1520 is less than      1720.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=2, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 5, 7, 8.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 3

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 5, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 3

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 7, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 8 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=2, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=3, O=5, Í=7, B=2, T=8, V=9, V=9, T=8, B=2, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Results of     fit            = »254+976« related to     »1830«

> Values of      fit            = 1230 is less than      1830.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=8, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=3, O=5, Í=7, B=8, T=2, V=9, V=9, T=2, B=8, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Results of     fit            = »854+976« related to     »1230«

> Values of      fit            = 1830 is greater than   1230.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=3, O=5, Í=7, B=9, T=2, V=8, V=8, T=2, B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Results of     fit            = »954+876« related to     »1230«

> Values of      fit            = 1830 is greater than   1230.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=3, O=5, Í=7, B=9, T=8, V=2, V=2, T=8, B=9, Í=7, O=5, A=3, Z=6, R=4, L=0, I=1.

> Results of     fit            = »954+276« related to     »1830«

> Values of      fit            = 1230 is less than      1830.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 3

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 5, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 8 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=2, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=3, O=7, Í=5, B=2, T=8, V=9, V=9, T=8, B=2, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Results of     fit            = »274+956« related to     »1830«

> Values of      fit            = 1230 is less than      1830.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=8, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=3, O=7, Í=5, B=8, T=2, V=9, V=9, T=2, B=8, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Results of     fit            = »874+956« related to     »1230«

> Values of      fit            = 1830 is greater than   1230.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=3, O=7, Í=5, B=9, T=2, V=8, V=8, T=2, B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Results of     fit            = »974+856« related to     »1230«

> Values of      fit            = 1830 is greater than   1230.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=3, O=7, Í=5, B=9, T=8, V=2, V=2, T=8, B=9, Í=5, O=7, A=3, Z=6, R=4, L=0, I=1.

> Results of     fit            = »974+256« related to     »1830«

> Values of      fit            = 1230 is less than      1830.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 3

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 5, 7, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=3, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 5, 7, 8.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=5, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=5, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 5

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=5, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 5

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=5, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 5

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=5, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 5

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 7, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=5, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 7, 8.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=7, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=7, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 7

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 5, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=7, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 7

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 5, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=7, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 7

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 3, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=7, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 7

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 5, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=7, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 5, 8.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 8

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 3, 5, 7, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 7 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=3, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=3, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=8, O=2, Í=5, B=3, T=7, V=9, V=9, T=7, B=3, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Results of     fit            = »324+956« related to     »1780«

> Values of      fit            = 1280 is less than      1780.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=7, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=8, O=2, Í=5, B=7, T=3, V=9, V=9, T=3, B=7, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Results of     fit            = »724+956« related to     »1380«

> Values of      fit            = 1680 is greater than   1380.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=8, O=2, Í=5, B=9, T=3, V=7, V=7, T=3, B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Results of     fit            = »924+756« related to     »1380«

> Values of      fit            = 1680 is greater than   1380.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=8, O=2, Í=5, B=9, T=7, V=3, V=3, T=7, B=9, Í=5, O=2, A=8, Z=6, R=4, L=0, I=1.

> Results of     fit            = »924+356« related to     »1780«

> Values of      fit            = 1280 is less than      1780.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 8

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 5, 7, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 8

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 3, 7, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 7 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=3, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=3, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=8, O=5, Í=2, B=3, T=7, V=9, V=9, T=7, B=3, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Results of     fit            = »354+926« related to     »1780«

> Values of      fit            = 1280 is less than      1780.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=7, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=8, O=5, Í=2, B=7, T=3, V=9, V=9, T=3, B=7, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Results of     fit            = »754+926« related to     »1380«

> Values of      fit            = 1680 is greater than   1380.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=8, O=5, Í=2, B=9, T=3, V=7, V=7, T=3, B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Results of     fit            = »954+726« related to     »1380«

> Values of      fit            = 1680 is greater than   1380.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=8, O=5, Í=2, B=9, T=7, V=3, V=3, T=7, B=9, Í=2, O=5, A=8, Z=6, R=4, L=0, I=1.

> Results of     fit            = »954+326« related to     »1780«

> Values of      fit            = 1280 is less than      1780.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 8

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 5, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=8, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 5, 7.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7 and 8.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 9

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 5, 7, 8.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 9

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 5, 7, 8.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 7 and 8.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=2, T=7, V=8, V=8, T=7, B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »234+856« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=2, T=8, V=7, V=7, T=8, B=2, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »234+756« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=7, T=2, V=8, V=8, T=2, B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »734+856« related to     »1290«

> Values of      fit            = 1590 is greater than   1290.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=7, T=8, V=2, V=2, T=8, B=7, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »734+256« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=8, T=2, V=7, V=7, T=2, B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »834+756« related to     »1290«

> Values of      fit            = 1590 is greater than   1290.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=3, Í=5, B=8, T=7, V=2, V=2, T=7, B=8, Í=5, O=3, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »834+256« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 9

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 3, 7, 8.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 7 and 8.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=2, T=7, V=8, V=8, T=7, B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »254+836« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=2, T=8, V=7, V=7, T=8, B=2, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »254+736« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=7, T=2, V=8, V=8, T=2, B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »754+836« related to     »1290«

> Values of      fit            = 1590 is greater than   1290.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=7, T=8, V=2, V=2, T=8, B=7, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »754+236« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=8, T=2, V=7, V=7, T=2, B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »854+736« related to     »1290«

> Values of      fit            = 1590 is greater than   1290.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=4, Z=6, A=9, O=5, Í=3, B=8, T=7, V=2, V=2, T=7, B=8, Í=3, O=5, A=9, Z=6, R=4, L=0, I=1.

> Results of     fit            = »854+236« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 9

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 3, 5, 8.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=9, Z=6, R=4, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 9

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 5, 7.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=5, L=0, I=1.

> Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 5

> right          partial value  = 1000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 0

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 6, 7, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 6

> right          partial value  = 1000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 0

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 4, 5, 7, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7 and 8 and 9.

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 2

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 5, 7, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5 and 7 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=5, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=2, O=3, Í=8, B=5, T=7, V=9, V=9, T=7, B=5, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Results of     fit            = »536+984« related to     »1720«

> Values of      fit            = 1520 is less than      1720.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=7, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=2, O=3, Í=8, B=7, T=5, V=9, V=9, T=5, B=7, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Results of     fit            = »736+984« related to     »1520«

> Values of      fit            = 1720 is greater than   1520.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=2, O=3, Í=8, B=9, T=5, V=7, V=7, T=5, B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Results of     fit            = »936+784« related to     »1520«

> Values of      fit            = 1720 is greater than   1520.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=2, O=3, Í=8, B=9, T=7, V=5, V=5, T=7, B=9, Í=8, O=3, A=2, Z=4, R=6, L=0, I=1.

> Results of     fit            = »936+584« related to     »1720«

> Values of      fit            = 1520 is less than      1720.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 2

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 7, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 2

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 5, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 2

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 3, 5, 7, 9.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5 and 7 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=5, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=2, O=8, Í=3, B=5, T=7, V=9, V=9, T=7, B=5, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Results of     fit            = »586+934« related to     »1720«

> Values of      fit            = 1520 is less than      1720.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=7, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=2, O=8, Í=3, B=7, T=5, V=9, V=9, T=5, B=7, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Results of     fit            = »786+934« related to     »1520«

> Values of      fit            = 1720 is greater than   1520.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=2, O=8, Í=3, B=9, T=5, V=7, V=7, T=5, B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Results of     fit            = »986+734« related to     »1520«

> Values of      fit            = 1720 is greater than   1520.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=2, O=8, Í=3, B=9, T=7, V=5, V=5, T=7, B=9, Í=3, O=8, A=2, Z=4, R=6, L=0, I=1.

> Results of     fit            = »986+534« related to     »1720«

> Values of      fit            = 1520 is less than      1720.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=2, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 5, 7, 8.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 3

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 5, 7, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 3

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 7, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 8 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=2, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=3, O=5, Í=7, B=2, T=8, V=9, V=9, T=8, B=2, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Results of     fit            = »256+974« related to     »1830«

> Values of      fit            = 1230 is less than      1830.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=8, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=3, O=5, Í=7, B=8, T=2, V=9, V=9, T=2, B=8, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Results of     fit            = »856+974« related to     »1230«

> Values of      fit            = 1830 is greater than   1230.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=3, O=5, Í=7, B=9, T=2, V=8, V=8, T=2, B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Results of     fit            = »956+874« related to     »1230«

> Values of      fit            = 1830 is greater than   1230.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=3, O=5, Í=7, B=9, T=8, V=2, V=2, T=8, B=9, Í=7, O=5, A=3, Z=4, R=6, L=0, I=1.

> Results of     fit            = »956+274« related to     »1830«

> Values of      fit            = 1230 is less than      1830.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 3

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 5, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 8 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=2, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=3, O=7, Í=5, B=2, T=8, V=9, V=9, T=8, B=2, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Results of     fit            = »276+954« related to     »1830«

> Values of      fit            = 1230 is less than      1830.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=8, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=3, O=7, Í=5, B=8, T=2, V=9, V=9, T=2, B=8, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Results of     fit            = »876+954« related to     »1230«

> Values of      fit            = 1830 is greater than   1230.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=3, O=7, Í=5, B=9, T=2, V=8, V=8, T=2, B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Results of     fit            = »976+854« related to     »1230«

> Values of      fit            = 1830 is greater than   1230.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=3, O=7, Í=5, B=9, T=8, V=2, V=2, T=8, B=9, Í=5, O=7, A=3, Z=4, R=6, L=0, I=1.

> Results of     fit            = »976+254« related to     »1830«

> Values of      fit            = 1230 is less than      1830.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 3

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 5, 7, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=3, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 5, 7, 8.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=5, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=5, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 5

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=5, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 5

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=5, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 5

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=5, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 5

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 7, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=5, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 7, 8.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=7, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=7, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 7

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 5, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=7, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 7

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 5, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=7, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 7

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 3, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=7, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 7

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 5, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=7, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 3, 5, 8.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 8

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 3, 5, 7, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 7 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=3, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=3, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=8, O=2, Í=5, B=3, T=7, V=9, V=9, T=7, B=3, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Results of     fit            = »326+954« related to     »1780«

> Values of      fit            = 1280 is less than      1780.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=7, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=8, O=2, Í=5, B=7, T=3, V=9, V=9, T=3, B=7, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Results of     fit            = »726+954« related to     »1380«

> Values of      fit            = 1680 is greater than   1380.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=8, O=2, Í=5, B=9, T=3, V=7, V=7, T=3, B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Results of     fit            = »926+754« related to     »1380«

> Values of      fit            = 1680 is greater than   1380.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=8, O=2, Í=5, B=9, T=7, V=3, V=3, T=7, B=9, Í=5, O=2, A=8, Z=4, R=6, L=0, I=1.

> Results of     fit            = »926+354« related to     »1780«

> Values of      fit            = 1280 is less than      1780.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 8

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 5, 7, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 8

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 3, 7, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 7 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=3, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=3, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=8, O=5, Í=2, B=3, T=7, V=9, V=9, T=7, B=3, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Results of     fit            = »356+924« related to     »1780«

> Values of      fit            = 1280 is less than      1780.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=7, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=8, O=5, Í=2, B=7, T=3, V=9, V=9, T=3, B=7, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Results of     fit            = »756+924« related to     »1380«

> Values of      fit            = 1680 is greater than   1380.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=8, O=5, Í=2, B=9, T=3, V=7, V=7, T=3, B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Results of     fit            = »956+724« related to     »1380«

> Values of      fit            = 1680 is greater than   1380.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=8, O=5, Í=2, B=9, T=7, V=3, V=3, T=7, B=9, Í=2, O=5, A=8, Z=4, R=6, L=0, I=1.

> Results of     fit            = »956+324« related to     »1780«

> Values of      fit            = 1280 is less than      1780.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 8

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 5, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=8, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 5, 7.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7 and 8.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 9

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 5, 7, 8.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 9

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 5, 7, 8.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 7 and 8.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=2, T=7, V=8, V=8, T=7, B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »236+854« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=2, T=8, V=7, V=7, T=8, B=2, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »236+754« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=7, T=2, V=8, V=8, T=2, B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »736+854« related to     »1290«

> Values of      fit            = 1590 is greater than   1290.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=7, T=8, V=2, V=2, T=8, B=7, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »736+254« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=8, T=2, V=7, V=7, T=2, B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »836+754« related to     »1290«

> Values of      fit            = 1590 is greater than   1290.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=3, Í=5, B=8, T=7, V=2, V=2, T=7, B=8, Í=5, O=3, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »836+254« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 9

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 3, 7, 8.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 7 and 8.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=2, T=7, V=8, V=8, T=7, B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »256+834« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=2, T=8, V=7, V=7, T=8, B=2, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »256+734« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=7, T=2, V=8, V=8, T=2, B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »756+834« related to     »1290«

> Values of      fit            = 1590 is greater than   1290.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=7, T=8, V=2, V=2, T=8, B=7, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »756+234« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=8, T=2, V=7, V=7, T=2, B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »856+734« related to     »1290«

> Values of      fit            = 1590 is greater than   1290.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=6, Z=4, A=9, O=5, Í=3, B=8, T=7, V=2, V=2, T=7, B=8, Í=3, O=5, A=9, Z=4, R=6, L=0, I=1.

> Results of     fit            = »856+234« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 9

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 3, 5, 8.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=9, Z=4, R=6, L=0, I=1.

> Remaining      digits         = 2 and 3 and 5 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 9

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 3, 5, 7.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=7, L=0, I=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 7

> right          partial value  = 1000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 0

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6 and 8 and 9.

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 2

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 5, 6, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 2

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 4, 6, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 8 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=4, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=2, O=5, Í=6, B=4, T=8, V=9, V=9, T=8, B=4, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Results of     fit            = »457+963« related to     »1820«

> Values of      fit            = 1420 is less than      1820.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=8, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=2, O=5, Í=6, B=8, T=4, V=9, V=9, T=4, B=8, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Results of     fit            = »857+963« related to     »1420«

> Values of      fit            = 1820 is greater than   1420.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=2, O=5, Í=6, B=9, T=4, V=8, V=8, T=4, B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Results of     fit            = »957+863« related to     »1420«

> Values of      fit            = 1820 is greater than   1420.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=2, O=5, Í=6, B=9, T=8, V=4, V=4, T=8, B=9, Í=6, O=5, A=2, Z=3, R=7, L=0, I=1.

> Results of     fit            = »957+463« related to     »1820«

> Values of      fit            = 1420 is less than      1820.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 2

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 4, 5, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 8 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=4, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=2, O=6, Í=5, B=4, T=8, V=9, V=9, T=8, B=4, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Results of     fit            = »467+953« related to     »1820«

> Values of      fit            = 1420 is less than      1820.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=8, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=2, O=6, Í=5, B=8, T=4, V=9, V=9, T=4, B=8, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Results of     fit            = »867+953« related to     »1420«

> Values of      fit            = 1820 is greater than   1420.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=2, O=6, Í=5, B=9, T=4, V=8, V=8, T=4, B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Results of     fit            = »967+853« related to     »1420«

> Values of      fit            = 1820 is greater than   1420.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=2, O=6, Í=5, B=9, T=8, V=4, V=4, T=8, B=9, Í=5, O=6, A=2, Z=3, R=7, L=0, I=1.

> Results of     fit            = »967+453« related to     »1820«

> Values of      fit            = 1420 is less than      1820.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 2

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 4, 5, 6, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=2, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1020

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 4, 5, 6, 8.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 4

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 5, 6, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 4

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 6, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=2, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=4, O=5, Í=8, B=2, T=6, V=9, V=9, T=6, B=2, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Results of     fit            = »257+983« related to     »1640«

> Values of      fit            = 1240 is less than      1640.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=6, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=4, O=5, Í=8, B=6, T=2, V=9, V=9, T=2, B=6, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Results of     fit            = »657+983« related to     »1240«

> Values of      fit            = 1640 is greater than   1240.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=4, O=5, Í=8, B=9, T=2, V=6, V=6, T=2, B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Results of     fit            = »957+683« related to     »1240«

> Values of      fit            = 1640 is greater than   1240.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=4, O=5, Í=8, B=9, T=6, V=2, V=2, T=6, B=9, Í=8, O=5, A=4, Z=3, R=7, L=0, I=1.

> Results of     fit            = »957+283« related to     »1640«

> Values of      fit            = 1240 is less than      1640.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 4

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 5, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 4

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 5, 6, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=2, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=4, O=8, Í=5, B=2, T=6, V=9, V=9, T=6, B=2, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Results of     fit            = »287+953« related to     »1640«

> Values of      fit            = 1240 is less than      1640.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=6, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=4, O=8, Í=5, B=6, T=2, V=9, V=9, T=2, B=6, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Results of     fit            = »687+953« related to     »1240«

> Values of      fit            = 1640 is greater than   1240.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=4, O=8, Í=5, B=9, T=2, V=6, V=6, T=2, B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Results of     fit            = »987+653« related to     »1240«

> Values of      fit            = 1640 is greater than   1240.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=4, O=8, Í=5, B=9, T=6, V=2, V=2, T=6, B=9, Í=5, O=8, A=4, Z=3, R=7, L=0, I=1.

> Results of     fit            = »987+253« related to     »1640«

> Values of      fit            = 1240 is less than      1640.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=4, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 5, 6, 8.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 5

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 4, 6, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 6 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 5

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 6, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 5

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 4, 8, 9.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=2, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=5, O=6, Í=8, B=2, T=4, V=9, V=9, T=4, B=2, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Results of     fit            = »267+983« related to     »1450«

> Values of      fit            = 1250 is less than      1450.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=4, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=5, O=6, Í=8, B=4, T=2, V=9, V=9, T=2, B=4, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Results of     fit            = »467+983« related to     »1250«

> Values of      fit            = 1450 is greater than   1250.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=5, O=6, Í=8, B=9, T=2, V=4, V=4, T=2, B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Results of     fit            = »967+483« related to     »1250«

> Values of      fit            = 1450 is greater than   1250.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=5, O=6, Í=8, B=9, T=4, V=2, V=2, T=4, B=9, Í=8, O=6, A=5, Z=3, R=7, L=0, I=1.

> Results of     fit            = »967+283« related to     »1450«

> Values of      fit            = 1250 is less than      1450.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 5

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 4, 6, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=2, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=2, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=5, O=8, Í=6, B=2, T=4, V=9, V=9, T=4, B=2, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Results of     fit            = »287+963« related to     »1450«

> Values of      fit            = 1250 is less than      1450.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=4, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=5, O=8, Í=6, B=4, T=2, V=9, V=9, T=2, B=4, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Results of     fit            = »487+963« related to     »1250«

> Values of      fit            = 1450 is greater than   1250.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=2, B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=5, O=8, Í=6, B=9, T=2, V=4, V=4, T=2, B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Results of     fit            = »987+463« related to     »1250«

> Values of      fit            = 1450 is greater than   1250.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=5, O=8, Í=6, B=9, T=4, V=2, V=2, T=4, B=9, Í=6, O=8, A=5, Z=3, R=7, L=0, I=1.

> Results of     fit            = »987+263« related to     »1450«

> Values of      fit            = 1250 is less than      1450.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=5, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 4, 6, 8.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=6, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 8 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=6, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 6

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 4, 5, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=6, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 5 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 6

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 5, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=6, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 8 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 6

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 4, 8, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=6, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 6

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 4, 5, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=6, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 4, 5, 8.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 8

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 4, 5, 6, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=8, O=2, Í=5, B=4, T=6, V=9, V=9, T=6, B=4, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Results of     fit            = »427+953« related to     »1680«

> Values of      fit            = 1380 is less than      1680.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=8, O=2, Í=5, B=6, T=4, V=9, V=9, T=4, B=6, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Results of     fit            = »627+953« related to     »1480«

> Values of      fit            = 1580 is greater than   1480.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=8, O=2, Í=5, B=9, T=4, V=6, V=6, T=4, B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Results of     fit            = »927+653« related to     »1480«

> Values of      fit            = 1580 is greater than   1480.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=8, O=2, Í=5, B=9, T=6, V=4, V=4, T=6, B=9, Í=5, O=2, A=8, Z=3, R=7, L=0, I=1.

> Results of     fit            = »927+453« related to     »1680«

> Values of      fit            = 1380 is less than      1680.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 8

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 5, 6, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 8

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 4, 6, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=8, O=5, Í=2, B=4, T=6, V=9, V=9, T=6, B=4, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Results of     fit            = »457+923« related to     »1680«

> Values of      fit            = 1380 is less than      1680.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=8, O=5, Í=2, B=6, T=4, V=9, V=9, T=4, B=6, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Results of     fit            = »657+923« related to     »1480«

> Values of      fit            = 1580 is greater than   1480.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=8, O=5, Í=2, B=9, T=4, V=6, V=6, T=4, B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Results of     fit            = »957+623« related to     »1480«

> Values of      fit            = 1580 is greater than   1480.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=8, O=5, Í=2, B=9, T=6, V=4, V=4, T=6, B=9, Í=2, O=5, A=8, Z=3, R=7, L=0, I=1.

> Results of     fit            = »957+423« related to     »1680«

> Values of      fit            = 1380 is less than      1680.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 8

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 4, 5, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=8, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1080

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 4, 5, 6.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6 and 8.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 30

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 9

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 4, 5, 6, 8.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5 and 8.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=4, T=5, V=8, V=8, T=5, B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »427+863« related to     »1590«

> Values of      fit            = 1290 is less than      1590.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=4, T=8, V=5, V=5, T=8, B=4, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »427+563« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=5, T=4, V=8, V=8, T=4, B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »527+863« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=5, T=8, V=4, V=4, T=8, B=5, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »527+463« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=8, T=4, V=5, V=5, T=4, B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »827+563« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=2, Í=6, B=8, T=5, V=4, V=4, T=5, B=8, Í=6, O=2, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »827+463« related to     »1590«

> Values of      fit            = 1290 is less than      1590.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 5 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 9

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 5, 6, 8.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 6 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 9

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 4, 6, 8.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 9

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 4, 5, 8.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5 and 8.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 5 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=4, T=5, V=8, V=8, T=5, B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »467+823« related to     »1590«

> Values of      fit            = 1290 is less than      1590.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=4, T=8, V=5, V=5, T=8, B=4, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »467+523« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=5, T=4, V=8, V=8, T=4, B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »567+823« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=5, T=8, V=4, V=4, T=8, B=5, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »567+423« related to     »1890«

> Values of      fit            = 990 is less than      1890.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=8, T=4, V=5, V=5, T=4, B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »867+523« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=7, Z=3, A=9, O=6, Í=2, B=8, T=5, V=4, V=4, T=5, B=8, Í=2, O=6, A=9, Z=3, R=7, L=0, I=1.

> Results of     fit            = »867+423« related to     »1590«

> Values of      fit            = 1290 is less than      1590.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=8, A=9, Z=3, R=7, L=0, I=1.

> Remaining      digits         = 2 and 4 and 5 and 6.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 90

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 9

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 2, 4, 5, 6.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=8, L=0, I=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 8

> right          partial value  = 1000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 0

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 9.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 3

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 5, 6, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 3

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 4, 6, 7, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=3, O=5, Í=7, B=4, T=6, V=9, V=9, T=6, B=4, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Results of     fit            = »458+972« related to     »1630«

> Values of      fit            = 1430 is less than      1630.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=3, O=5, Í=7, B=6, T=4, V=9, V=9, T=4, B=6, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Results of     fit            = »658+972« related to     »1430«

> Values of      fit            = 1630 is greater than   1430.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=3, O=5, Í=7, B=9, T=4, V=6, V=6, T=4, B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Results of     fit            = »958+672« related to     »1430«

> Values of      fit            = 1630 is greater than   1430.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=3, O=5, Í=7, B=9, T=6, V=4, V=4, T=6, B=9, Í=7, O=5, A=3, Z=2, R=8, L=0, I=1.

> Results of     fit            = »958+472« related to     »1630«

> Values of      fit            = 1430 is less than      1630.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 3

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 4, 5, 7, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 3

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 4, 5, 6, 9.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=3, O=7, Í=5, B=4, T=6, V=9, V=9, T=6, B=4, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Results of     fit            = »478+952« related to     »1630«

> Values of      fit            = 1430 is less than      1630.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=3, O=7, Í=5, B=6, T=4, V=9, V=9, T=4, B=6, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Results of     fit            = »678+952« related to     »1430«

> Values of      fit            = 1630 is greater than   1430.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=3, O=7, Í=5, B=9, T=4, V=6, V=6, T=4, B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Results of     fit            = »978+652« related to     »1430«

> Values of      fit            = 1630 is greater than   1430.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=3, O=7, Í=5, B=9, T=6, V=4, V=4, T=6, B=9, Í=5, O=7, A=3, Z=2, R=8, L=0, I=1.

> Results of     fit            = »978+452« related to     »1630«

> Values of      fit            = 1430 is less than      1630.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=3, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1030

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 4, 5, 6, 7.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 4

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 5, 6, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 4

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 6, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 4

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 3, 5, 7, 9.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=3, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=3, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=4, O=6, Í=7, B=3, T=5, V=9, V=9, T=5, B=3, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Results of     fit            = »368+972« related to     »1540«

> Values of      fit            = 1340 is less than      1540.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=5, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=4, O=6, Í=7, B=5, T=3, V=9, V=9, T=3, B=5, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Results of     fit            = »568+972« related to     »1340«

> Values of      fit            = 1540 is greater than   1340.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=4, O=6, Í=7, B=9, T=3, V=5, V=5, T=3, B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Results of     fit            = »968+572« related to     »1340«

> Values of      fit            = 1540 is greater than   1340.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=4, O=6, Í=7, B=9, T=5, V=3, V=3, T=5, B=9, Í=7, O=6, A=4, Z=2, R=8, L=0, I=1.

> Results of     fit            = »968+372« related to     »1540«

> Values of      fit            = 1340 is less than      1540.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 4

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 5, 6, 9.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=3, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=3, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=4, O=7, Í=6, B=3, T=5, V=9, V=9, T=5, B=3, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Results of     fit            = »378+962« related to     »1540«

> Values of      fit            = 1340 is less than      1540.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=5, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=5, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 9.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=4, O=7, Í=6, B=5, T=3, V=9, V=9, T=3, B=5, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Results of     fit            = »578+962« related to     »1340«

> Values of      fit            = 1540 is greater than   1340.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=3, B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 5.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=4, O=7, Í=6, B=9, T=3, V=5, V=5, T=3, B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Results of     fit            = »978+562« related to     »1340«

> Values of      fit            = 1540 is greater than   1340.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=5, B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=4, O=7, Í=6, B=9, T=5, V=3, V=3, T=5, B=9, Í=6, O=7, A=4, Z=2, R=8, L=0, I=1.

> Results of     fit            = »978+362« related to     »1540«

> Values of      fit            = 1340 is less than      1540.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=4, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1040

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 5, 6, 7.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=5, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=5, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 5

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 4, 6, 7, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=5, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 6 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 5

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 3, 6, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=5, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 5

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 4, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=5, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 5

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 3, 4, 6, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=5, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1050

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 3, 4, 6, 7.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=6, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 7 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=6, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 6

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 4, 5, 7, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=6, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 6

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 3, 5, 7, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=6, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 7 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 6

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 3, 4, 7, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=6, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 6

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 4, 5, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=6, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1060

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 4, 5, 7.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=7, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 9.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=7, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 7

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 4, 5, 6, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=7, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 7

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 5, 6, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=7, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 7

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 3, 4, 6, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=7, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 9.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 7

>

> Product        mod 10         = 0

> Possible       multipliers    = 0.

>

>

> Remaining      digits         = 3, 4, 5, 9.

> Possible       digits         = 0.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=9, A=7, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 100

> right          partial value  = 1070

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 3, 4, 5, 6.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 40

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 9

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 4, 5, 6, 7.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=4, T=6, V=7, V=7, T=6, B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »438+752« related to     »1690«

> Values of      fit            = 1190 is less than      1690.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=4, T=7, V=6, V=6, T=7, B=4, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »438+652« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=6, T=4, V=7, V=7, T=4, B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »638+752« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=6, T=7, V=4, V=4, T=7, B=6, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »638+452« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=7, T=4, V=6, V=6, T=4, B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »738+652« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=3, Í=5, B=7, T=6, V=4, V=4, T=6, B=7, Í=5, O=3, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »738+452« related to     »1690«

> Values of      fit            = 1190 is less than      1690.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 50

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 9

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 5, 6, 7.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 6 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 60

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 9

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 3, 4, 6, 7.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6 and 7.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=4, T=6, V=7, V=7, T=6, B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »458+732« related to     »1690«

> Values of      fit            = 1190 is less than      1690.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=4, T=7, V=6, V=6, T=7, B=4, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »458+632« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 7.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=6, T=4, V=7, V=7, T=4, B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »658+732« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=6, T=7, V=4, V=4, T=7, B=6, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »658+432« related to     »1790«

> Values of      fit            = 1090 is less than      1790.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4 and 6.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=4, B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=7, T=4, V=6, V=6, T=4, B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »758+632« related to     »1490«

> Values of      fit            = 1390 is less than      1490.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = L=0, R=8, Z=2, A=9, O=5, Í=3, B=7, T=6, V=4, V=4, T=6, B=7, Í=3, O=5, A=9, Z=2, R=8, L=0, I=1.

> Results of     fit            = »758+432« related to     »1690«

> Values of      fit            = 1190 is less than      1690.

>

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=6, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 7.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 70

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 9

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 4, 5, 7.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=7, A=9, Z=2, R=8, L=0, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 80

> right          partial value  = 1090

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 9

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 3, 4, 5, 6.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=9, L=0, I=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 9

> right          partial value  = 1000

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 0

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 8.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'R'

> Intermediate   fit list       = L=2, I=1.

> Remaining      digits         = 0 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=0, L=2, I=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 0

> right          partial value  = 1002

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 2

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Z'

> Intermediate   fit list       = R=3, L=2, I=1.

> Remaining      digits         = 0 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'Z'   = 0

> left           partial value  = 3

> right          partial value  = 1002

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 2

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 0, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'A'

> Intermediate   fit list       = Z=9, R=3, L=2, I=1.

> Remaining      digits         = 0 and 4 and 5 and 6 and 7 and 8.

>

>

> Current        code is        = 'O'

> Intermediate   fit list       = A=0, Z=9, R=3, L=2, I=1.

> Remaining      digits         = 4 and 5 and 6 and 7 and 8.

>

>

> Current        code is        = 'Í'

> Intermediate   fit list       = O=4, A=0, Z=9, R=3, L=2, I=1.

> Remaining      digits         = 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Í'   = 1

> left           partial value  = 52

> right          partial value  = 1002

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 0

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 5, 6, 7, 8.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'B'

> Intermediate   fit list       = Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

> Remaining      digits         = 6 and 7 and 8.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

> Remaining      digits         = 7 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=7, B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=2, R=3, Z=9, A=0, O=4, Í=5, B=6, T=7, V=8, V=8, T=7, B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

> Results of     fit            = »643+859« related to     »1702«

> Values of      fit            = 1502 is less than      1702.

>

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=8, B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = L=2, R=3, Z=9, A=0, O=4, Í=5, B=6, T=8, V=7, V=7, T=8, B=6, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

> Results of     fit            = »643+759« related to     »1802«

> Values of      fit            = 1402 is less than      1802.

>

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

> Remaining      digits         = 6 and 8.

>

>

> Current        code is        = 'V'

> Intermediate   fit list       = T=6, B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = L=2, R=3, Z=9, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

> Results of     fit            = »743+859« related to     »1602«

> Values of      fit            = 1602 is equal to       1602.

>

>

>

2275,2276c19825,19831

< Tried          fits           = 1872

< Matching       fits found     = 96

---

> Condensed      puzzle         = VÍZ+BOR=ITAL

>

> Simplified     puzzle         = BOR+VÍZ=ITAL

>

>

> Tried          fits           = 219

> Matching       fits found     = 1

2285,2771c19840,21060

< Solution       #              = 2

< Solution       fitted         = L=2, R=3, Z=9, A=0, O=4, Í=5, B=8, T=6, V=7, V=7, T=6, B=8, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

< Solution       got            = 843+759=1602

<

<

< Solution       #              = 3

< Solution       fitted         = L=2, R=3, Z=9, A=0, O=5, Í=4, B=7, T=6, V=8, V=8, T=6, B=7, Í=4, O=5, A=0, Z=9, R=3, L=2, I=1.

< Solution       got            = 753+849=1602

<

<

< Solution       #              = 4

< Solution       fitted         = L=2, R=3, Z=9, A=0, O=5, Í=4, B=8, T=6, V=7, V=7, T=6, B=8, Í=4, O=5, A=0, Z=9, R=3, L=2, I=1.

< Solution       got            = 853+749=1602

<

<

< Solution       #              = 5

< Solution       fitted         = L=2, R=3, Z=9, A=6, O=7, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=7, A=6, Z=9, R=3, L=2, I=1.

< Solution       got            = 473+589=1062

<

<

< Solution       #              = 6

< Solution       fitted         = L=2, R=3, Z=9, A=6, O=7, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=7, A=6, Z=9, R=3, L=2, I=1.

< Solution       got            = 573+489=1062

<

<

< Solution       #              = 7

< Solution       fitted         = L=2, R=3, Z=9, A=6, O=8, Í=7, B=4, T=0, V=5, V=5, T=0, B=4, Í=7, O=8, A=6, Z=9, R=3, L=2, I=1.

< Solution       got            = 483+579=1062

<

<

< Solution       #              = 8

< Solution       fitted         = L=2, R=3, Z=9, A=6, O=8, Í=7, B=5, T=0, V=4, V=4, T=0, B=5, Í=7, O=8, A=6, Z=9, R=3, L=2, I=1.

< Solution       got            = 583+479=1062

<

<

< Solution       #              = 9

< Solution       fitted         = L=2, R=9, Z=3, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=3, R=9, L=2, I=1.

< Solution       got            = 749+853=1602

<

<

< Solution       #              = 10

< Solution       fitted         = L=2, R=9, Z=3, A=0, O=4, Í=5, B=8, T=6, V=7, V=7, T=6, B=8, Í=5, O=4, A=0, Z=3, R=9, L=2, I=1.

< Solution       got            = 849+753=1602

<

<

< Solution       #              = 11

< Solution       fitted         = L=2, R=9, Z=3, A=0, O=5, Í=4, B=7, T=6, V=8, V=8, T=6, B=7, Í=4, O=5, A=0, Z=3, R=9, L=2, I=1.

< Solution       got            = 759+843=1602

<

<

< Solution       #              = 12

< Solution       fitted         = L=2, R=9, Z=3, A=0, O=5, Í=4, B=8, T=6, V=7, V=7, T=6, B=8, Í=4, O=5, A=0, Z=3, R=9, L=2, I=1.

< Solution       got            = 859+743=1602

<

<

< Solution       #              = 13

< Solution       fitted         = L=2, R=9, Z=3, A=6, O=7, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=7, A=6, Z=3, R=9, L=2, I=1.

< Solution       got            = 479+583=1062

<

<

< Solution       #              = 14

< Solution       fitted         = L=2, R=9, Z=3, A=6, O=7, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=7, A=6, Z=3, R=9, L=2, I=1.

< Solution       got            = 579+483=1062

<

<

< Solution       #              = 15

< Solution       fitted         = L=2, R=9, Z=3, A=6, O=8, Í=7, B=4, T=0, V=5, V=5, T=0, B=4, Í=7, O=8, A=6, Z=3, R=9, L=2, I=1.

< Solution       got            = 489+573=1062

<

<

< Solution       #              = 16

< Solution       fitted         = L=2, R=9, Z=3, A=6, O=8, Í=7, B=5, T=0, V=4, V=4, T=0, B=5, Í=7, O=8, A=6, Z=3, R=9, L=2, I=1.

< Solution       got            = 589+473=1062

<

<

< Solution       #              = 17

< Solution       fitted         = L=3, R=4, Z=9, A=0, O=2, Í=7, B=6, T=5, V=8, V=8, T=5, B=6, Í=7, O=2, A=0, Z=9, R=4, L=3, I=1.

< Solution       got            = 624+879=1503

<

<

< Solution       #              = 18

< Solution       fitted         = L=3, R=4, Z=9, A=0, O=2, Í=7, B=8, T=5, V=6, V=6, T=5, B=8, Í=7, O=2, A=0, Z=9, R=4, L=3, I=1.

< Solution       got            = 824+679=1503

<

<

< Solution       #              = 19

< Solution       fitted         = L=3, R=4, Z=9, A=0, O=7, Í=2, B=6, T=5, V=8, V=8, T=5, B=6, Í=2, O=7, A=0, Z=9, R=4, L=3, I=1.

< Solution       got            = 674+829=1503

<

<

< Solution       #              = 20

< Solution       fitted         = L=3, R=4, Z=9, A=0, O=7, Í=2, B=8, T=5, V=6, V=6, T=5, B=8, Í=2, O=7, A=0, Z=9, R=4, L=3, I=1.

< Solution       got            = 874+629=1503

<

<

< Solution       #              = 21

< Solution       fitted         = L=3, R=4, Z=9, A=5, O=6, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=6, A=5, Z=9, R=4, L=3, I=1.

< Solution       got            = 264+789=1053

<

<

< Solution       #              = 22

< Solution       fitted         = L=3, R=4, Z=9, A=5, O=6, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=6, A=5, Z=9, R=4, L=3, I=1.

< Solution       got            = 764+289=1053

<

<

< Solution       #              = 23

< Solution       fitted         = L=3, R=4, Z=9, A=5, O=8, Í=6, B=2, T=0, V=7, V=7, T=0, B=2, Í=6, O=8, A=5, Z=9, R=4, L=3, I=1.

< Solution       got            = 284+769=1053

<

<

< Solution       #              = 24

< Solution       fitted         = L=3, R=4, Z=9, A=5, O=8, Í=6, B=7, T=0, V=2, V=2, T=0, B=7, Í=6, O=8, A=5, Z=9, R=4, L=3, I=1.

< Solution       got            = 784+269=1053

<

<

< Solution       #              = 25

< Solution       fitted         = L=3, R=9, Z=4, A=0, O=2, Í=7, B=6, T=5, V=8, V=8, T=5, B=6, Í=7, O=2, A=0, Z=4, R=9, L=3, I=1.

< Solution       got            = 629+874=1503

<

<

< Solution       #              = 26

< Solution       fitted         = L=3, R=9, Z=4, A=0, O=2, Í=7, B=8, T=5, V=6, V=6, T=5, B=8, Í=7, O=2, A=0, Z=4, R=9, L=3, I=1.

< Solution       got            = 829+674=1503

<

<

< Solution       #              = 27

< Solution       fitted         = L=3, R=9, Z=4, A=0, O=7, Í=2, B=6, T=5, V=8, V=8, T=5, B=6, Í=2, O=7, A=0, Z=4, R=9, L=3, I=1.

< Solution       got            = 679+824=1503

<

<

< Solution       #              = 28

< Solution       fitted         = L=3, R=9, Z=4, A=0, O=7, Í=2, B=8, T=5, V=6, V=6, T=5, B=8, Í=2, O=7, A=0, Z=4, R=9, L=3, I=1.

< Solution       got            = 879+624=1503

<

<

< Solution       #              = 29

< Solution       fitted         = L=3, R=9, Z=4, A=5, O=6, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=6, A=5, Z=4, R=9, L=3, I=1.

< Solution       got            = 269+784=1053

<

<

< Solution       #              = 30

< Solution       fitted         = L=3, R=9, Z=4, A=5, O=6, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=6, A=5, Z=4, R=9, L=3, I=1.

< Solution       got            = 769+284=1053

<

<

< Solution       #              = 31

< Solution       fitted         = L=3, R=9, Z=4, A=5, O=8, Í=6, B=2, T=0, V=7, V=7, T=0, B=2, Í=6, O=8, A=5, Z=4, R=9, L=3, I=1.

< Solution       got            = 289+764=1053

<

<

< Solution       #              = 32

< Solution       fitted         = L=3, R=9, Z=4, A=5, O=8, Í=6, B=7, T=0, V=2, V=2, T=0, B=7, Í=6, O=8, A=5, Z=4, R=9, L=3, I=1.

< Solution       got            = 789+264=1053

<

<

< Solution       #              = 33

< Solution       fitted         = L=5, R=6, Z=9, A=0, O=2, Í=7, B=4, T=3, V=8, V=8, T=3, B=4, Í=7, O=2, A=0, Z=9, R=6, L=5, I=1.

< Solution       got            = 426+879=1305

<

<

< Solution       #              = 34

< Solution       fitted         = L=5, R=6, Z=9, A=0, O=2, Í=7, B=8, T=3, V=4, V=4, T=3, B=8, Í=7, O=2, A=0, Z=9, R=6, L=5, I=1.

< Solution       got            = 826+479=1305

<

<

< Solution       #              = 35

< Solution       fitted         = L=5, R=6, Z=9, A=0, O=7, Í=2, B=4, T=3, V=8, V=8, T=3, B=4, Í=2, O=7, A=0, Z=9, R=6, L=5, I=1.

< Solution       got            = 476+829=1305

<

<

< Solution       #              = 36

< Solution       fitted         = L=5, R=6, Z=9, A=0, O=7, Í=2, B=8, T=3, V=4, V=4, T=3, B=8, Í=2, O=7, A=0, Z=9, R=6, L=5, I=1.

< Solution       got            = 876+429=1305

<

<

< Solution       #              = 37

< Solution       fitted         = L=5, R=6, Z=9, A=3, O=4, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=4, A=3, Z=9, R=6, L=5, I=1.

< Solution       got            = 246+789=1035

<

<

< Solution       #              = 38

< Solution       fitted         = L=5, R=6, Z=9, A=3, O=4, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=4, A=3, Z=9, R=6, L=5, I=1.

< Solution       got            = 746+289=1035

<

<

< Solution       #              = 39

< Solution       fitted         = L=5, R=6, Z=9, A=3, O=8, Í=4, B=2, T=0, V=7, V=7, T=0, B=2, Í=4, O=8, A=3, Z=9, R=6, L=5, I=1.

< Solution       got            = 286+749=1035

<

<

< Solution       #              = 40

< Solution       fitted         = L=5, R=6, Z=9, A=3, O=8, Í=4, B=7, T=0, V=2, V=2, T=0, B=7, Í=4, O=8, A=3, Z=9, R=6, L=5, I=1.

< Solution       got            = 786+249=1035

<

<

< Solution       #              = 41

< Solution       fitted         = L=5, R=9, Z=6, A=0, O=2, Í=7, B=4, T=3, V=8, V=8, T=3, B=4, Í=7, O=2, A=0, Z=6, R=9, L=5, I=1.

< Solution       got            = 429+876=1305

<

<

< Solution       #              = 42

< Solution       fitted         = L=5, R=9, Z=6, A=0, O=2, Í=7, B=8, T=3, V=4, V=4, T=3, B=8, Í=7, O=2, A=0, Z=6, R=9, L=5, I=1.

< Solution       got            = 829+476=1305

<

<

< Solution       #              = 43

< Solution       fitted         = L=5, R=9, Z=6, A=0, O=7, Í=2, B=4, T=3, V=8, V=8, T=3, B=4, Í=2, O=7, A=0, Z=6, R=9, L=5, I=1.

< Solution       got            = 479+826=1305

<

<

< Solution       #              = 44

< Solution       fitted         = L=5, R=9, Z=6, A=0, O=7, Í=2, B=8, T=3, V=4, V=4, T=3, B=8, Í=2, O=7, A=0, Z=6, R=9, L=5, I=1.

< Solution       got            = 879+426=1305

<

<

< Solution       #              = 45

< Solution       fitted         = L=5, R=9, Z=6, A=3, O=4, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=4, A=3, Z=6, R=9, L=5, I=1.

< Solution       got            = 249+786=1035

<

<

< Solution       #              = 46

< Solution       fitted         = L=5, R=9, Z=6, A=3, O=4, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=4, A=3, Z=6, R=9, L=5, I=1.

< Solution       got            = 749+286=1035

<

<

< Solution       #              = 47

< Solution       fitted         = L=5, R=9, Z=6, A=3, O=8, Í=4, B=2, T=0, V=7, V=7, T=0, B=2, Í=4, O=8, A=3, Z=6, R=9, L=5, I=1.

< Solution       got            = 289+746=1035

<

<

< Solution       #              = 48

< Solution       fitted         = L=5, R=9, Z=6, A=3, O=8, Í=4, B=7, T=0, V=2, V=2, T=0, B=7, Í=4, O=8, A=3, Z=6, R=9, L=5, I=1.

< Solution       got            = 789+246=1035

<

<

< Solution       #              = 49

< Solution       fitted         = L=6, R=7, Z=9, A=0, O=4, Í=5, B=3, T=2, V=8, V=8, T=2, B=3, Í=5, O=4, A=0, Z=9, R=7, L=6, I=1.

< Solution       got            = 347+859=1206

<

<

< Solution       #              = 50

< Solution       fitted         = L=6, R=7, Z=9, A=0, O=4, Í=5, B=8, T=2, V=3, V=3, T=2, B=8, Í=5, O=4, A=0, Z=9, R=7, L=6, I=1.

< Solution       got            = 847+359=1206

<

<

< Solution       #              = 51

< Solution       fitted         = L=6, R=7, Z=9, A=0, O=5, Í=4, B=3, T=2, V=8, V=8, T=2, B=3, Í=4, O=5, A=0, Z=9, R=7, L=6, I=1.

< Solution       got            = 357+849=1206

<

<

< Solution       #              = 52

< Solution       fitted         = L=6, R=7, Z=9, A=0, O=5, Í=4, B=8, T=2, V=3, V=3, T=2, B=8, Í=4, O=5, A=0, Z=9, R=7, L=6, I=1.

< Solution       got            = 857+349=1206

<

<

< Solution       #              = 53

< Solution       fitted         = L=6, R=7, Z=9, A=2, O=3, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=3, A=2, Z=9, R=7, L=6, I=1.

< Solution       got            = 437+589=1026

<

<

< Solution       #              = 54

< Solution       fitted         = L=6, R=7, Z=9, A=2, O=3, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=3, A=2, Z=9, R=7, L=6, I=1.

< Solution       got            = 537+489=1026

<

<

< Solution       #              = 55

< Solution       fitted         = L=6, R=7, Z=9, A=2, O=8, Í=3, B=4, T=0, V=5, V=5, T=0, B=4, Í=3, O=8, A=2, Z=9, R=7, L=6, I=1.

< Solution       got            = 487+539=1026

<

<

< Solution       #              = 56

< Solution       fitted         = L=6, R=7, Z=9, A=2, O=8, Í=3, B=5, T=0, V=4, V=4, T=0, B=5, Í=3, O=8, A=2, Z=9, R=7, L=6, I=1.

< Solution       got            = 587+439=1026

<

<

< Solution       #              = 57

< Solution       fitted         = L=6, R=9, Z=7, A=0, O=4, Í=5, B=3, T=2, V=8, V=8, T=2, B=3, Í=5, O=4, A=0, Z=7, R=9, L=6, I=1.

< Solution       got            = 349+857=1206

<

<

< Solution       #              = 58

< Solution       fitted         = L=6, R=9, Z=7, A=0, O=4, Í=5, B=8, T=2, V=3, V=3, T=2, B=8, Í=5, O=4, A=0, Z=7, R=9, L=6, I=1.

< Solution       got            = 849+357=1206

<

<

< Solution       #              = 59

< Solution       fitted         = L=6, R=9, Z=7, A=0, O=5, Í=4, B=3, T=2, V=8, V=8, T=2, B=3, Í=4, O=5, A=0, Z=7, R=9, L=6, I=1.

< Solution       got            = 359+847=1206

<

<

< Solution       #              = 60

< Solution       fitted         = L=6, R=9, Z=7, A=0, O=5, Í=4, B=8, T=2, V=3, V=3, T=2, B=8, Í=4, O=5, A=0, Z=7, R=9, L=6, I=1.

< Solution       got            = 859+347=1206

<

<

< Solution       #              = 61

< Solution       fitted         = L=6, R=9, Z=7, A=2, O=3, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=3, A=2, Z=7, R=9, L=6, I=1.

< Solution       got            = 439+587=1026

<

<

< Solution       #              = 62

< Solution       fitted         = L=6, R=9, Z=7, A=2, O=3, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=3, A=2, Z=7, R=9, L=6, I=1.

< Solution       got            = 539+487=1026

<

<

< Solution       #              = 63

< Solution       fitted         = L=6, R=9, Z=7, A=2, O=8, Í=3, B=4, T=0, V=5, V=5, T=0, B=4, Í=3, O=8, A=2, Z=7, R=9, L=6, I=1.

< Solution       got            = 489+537=1026

<

<

< Solution       #              = 64

< Solution       fitted         = L=6, R=9, Z=7, A=2, O=8, Í=3, B=5, T=0, V=4, V=4, T=0, B=5, Í=3, O=8, A=2, Z=7, R=9, L=6, I=1.

< Solution       got            = 589+437=1026

<

<

< Solution       #              = 65

< Solution       fitted         = L=8, R=2, Z=6, A=9, O=4, Í=5, B=3, T=0, V=7, V=7, T=0, B=3, Í=5, O=4, A=9, Z=6, R=2, L=8, I=1.

< Solution       got            = 342+756=1098

<

<

< Solution       #              = 66

< Solution       fitted         = L=8, R=2, Z=6, A=9, O=4, Í=5, B=7, T=0, V=3, V=3, T=0, B=7, Í=5, O=4, A=9, Z=6, R=2, L=8, I=1.

< Solution       got            = 742+356=1098

<

<

< Solution       #              = 67

< Solution       fitted         = L=8, R=2, Z=6, A=9, O=5, Í=4, B=3, T=0, V=7, V=7, T=0, B=3, Í=4, O=5, A=9, Z=6, R=2, L=8, I=1.

< Solution       got            = 352+746=1098

<

<

< Solution       #              = 68

< Solution       fitted         = L=8, R=2, Z=6, A=9, O=5, Í=4, B=7, T=0, V=3, V=3, T=0, B=7, Í=4, O=5, A=9, Z=6, R=2, L=8, I=1.

< Solution       got            = 752+346=1098

<

<

< Solution       #              = 69

< Solution       fitted         = L=8, R=3, Z=5, A=9, O=2, Í=7, B=4, T=0, V=6, V=6, T=0, B=4, Í=7, O=2, A=9, Z=5, R=3, L=8, I=1.

< Solution       got            = 423+675=1098

<

<

< Solution       #              = 70

< Solution       fitted         = L=8, R=3, Z=5, A=9, O=2, Í=7, B=6, T=0, V=4, V=4, T=0, B=6, Í=7, O=2, A=9, Z=5, R=3, L=8, I=1.

< Solution       got            = 623+475=1098

<

<

< Solution       #              = 71

< Solution       fitted         = L=8, R=3, Z=5, A=9, O=7, Í=2, B=4, T=0, V=6, V=6, T=0, B=4, Í=2, O=7, A=9, Z=5, R=3, L=8, I=1.

< Solution       got            = 473+625=1098

<

<

< Solution       #              = 72

< Solution       fitted         = L=8, R=3, Z=5, A=9, O=7, Í=2, B=6, T=0, V=4, V=4, T=0, B=6, Í=2, O=7, A=9, Z=5, R=3, L=8, I=1.

< Solution       got            = 673+425=1098

<

<

< Solution       #              = 73

< Solution       fitted         = L=8, R=5, Z=3, A=9, O=2, Í=7, B=4, T=0, V=6, V=6, T=0, B=4, Í=7, O=2, A=9, Z=3, R=5, L=8, I=1.

< Solution       got            = 425+673=1098

<

<

< Solution       #              = 74

< Solution       fitted         = L=8, R=5, Z=3, A=9, O=2, Í=7, B=6, T=0, V=4, V=4, T=0, B=6, Í=7, O=2, A=9, Z=3, R=5, L=8, I=1.

< Solution       got            = 625+473=1098

<

<

< Solution       #              = 75

< Solution       fitted         = L=8, R=5, Z=3, A=9, O=7, Í=2, B=4, T=0, V=6, V=6, T=0, B=4, Í=2, O=7, A=9, Z=3, R=5, L=8, I=1.

< Solution       got            = 475+623=1098

<

<

< Solution       #              = 76

< Solution       fitted         = L=8, R=5, Z=3, A=9, O=7, Í=2, B=6, T=0, V=4, V=4, T=0, B=6, Í=2, O=7, A=9, Z=3, R=5, L=8, I=1.

< Solution       got            = 675+423=1098

<

<

< Solution       #              = 77

< Solution       fitted         = L=8, R=6, Z=2, A=9, O=4, Í=5, B=3, T=0, V=7, V=7, T=0, B=3, Í=5, O=4, A=9, Z=2, R=6, L=8, I=1.

< Solution       got            = 346+752=1098

<

<

< Solution       #              = 78

< Solution       fitted         = L=8, R=6, Z=2, A=9, O=4, Í=5, B=7, T=0, V=3, V=3, T=0, B=7, Í=5, O=4, A=9, Z=2, R=6, L=8, I=1.

< Solution       got            = 746+352=1098

<

<

< Solution       #              = 79

< Solution       fitted         = L=8, R=6, Z=2, A=9, O=5, Í=4, B=3, T=0, V=7, V=7, T=0, B=3, Í=4, O=5, A=9, Z=2, R=6, L=8, I=1.

< Solution       got            = 356+742=1098

<

<

< Solution       #              = 80

< Solution       fitted         = L=8, R=6, Z=2, A=9, O=5, Í=4, B=7, T=0, V=3, V=3, T=0, B=7, Í=4, O=5, A=9, Z=2, R=6, L=8, I=1.

< Solution       got            = 756+342=1098

<

<

< Solution       #              = 81

< Solution       fitted         = L=9, R=2, Z=7, A=8, O=3, Í=5, B=4, T=0, V=6, V=6, T=0, B=4, Í=5, O=3, A=8, Z=7, R=2, L=9, I=1.

< Solution       got            = 432+657=1089

<

<

< Solution       #              = 82

< Solution       fitted         = L=9, R=2, Z=7, A=8, O=3, Í=5, B=6, T=0, V=4, V=4, T=0, B=6, Í=5, O=3, A=8, Z=7, R=2, L=9, I=1.

< Solution       got            = 632+457=1089

<

<

< Solution       #              = 83

< Solution       fitted         = L=9, R=2, Z=7, A=8, O=5, Í=3, B=4, T=0, V=6, V=6, T=0, B=4, Í=3, O=5, A=8, Z=7, R=2, L=9, I=1.

< Solution       got            = 452+637=1089

<

<

< Solution       #              = 84

< Solution       fitted         = L=9, R=2, Z=7, A=8, O=5, Í=3, B=6, T=0, V=4, V=4, T=0, B=6, Í=3, O=5, A=8, Z=7, R=2, L=9, I=1.

< Solution       got            = 652+437=1089

<

<

< Solution       #              = 85

< Solution       fitted         = L=9, R=4, Z=5, A=8, O=2, Í=6, B=3, T=0, V=7, V=7, T=0, B=3, Í=6, O=2, A=8, Z=5, R=4, L=9, I=1.

< Solution       got            = 324+765=1089

<

<

< Solution       #              = 86

< Solution       fitted         = L=9, R=4, Z=5, A=8, O=2, Í=6, B=7, T=0, V=3, V=3, T=0, B=7, Í=6, O=2, A=8, Z=5, R=4, L=9, I=1.

< Solution       got            = 724+365=1089

<

<

< Solution       #              = 87

< Solution       fitted         = L=9, R=4, Z=5, A=8, O=6, Í=2, B=3, T=0, V=7, V=7, T=0, B=3, Í=2, O=6, A=8, Z=5, R=4, L=9, I=1.

< Solution       got            = 364+725=1089

<

<

< Solution       #              = 88

< Solution       fitted         = L=9, R=4, Z=5, A=8, O=6, Í=2, B=7, T=0, V=3, V=3, T=0, B=7, Í=2, O=6, A=8, Z=5, R=4, L=9, I=1.

< Solution       got            = 764+325=1089

<

<

< Solution       #              = 89

< Solution       fitted         = L=9, R=5, Z=4, A=8, O=2, Í=6, B=3, T=0, V=7, V=7, T=0, B=3, Í=6, O=2, A=8, Z=4, R=5, L=9, I=1.

< Solution       got            = 325+764=1089

<

<

< Solution       #              = 90

< Solution       fitted         = L=9, R=5, Z=4, A=8, O=2, Í=6, B=7, T=0, V=3, V=3, T=0, B=7, Í=6, O=2, A=8, Z=4, R=5, L=9, I=1.

< Solution       got            = 725+364=1089

<

<

< Solution       #              = 91

< Solution       fitted         = L=9, R=5, Z=4, A=8, O=6, Í=2, B=3, T=0, V=7, V=7, T=0, B=3, Í=2, O=6, A=8, Z=4, R=5, L=9, I=1.

< Solution       got            = 365+724=1089

<

<

< Solution       #              = 92

< Solution       fitted         = L=9, R=5, Z=4, A=8, O=6, Í=2, B=7, T=0, V=3, V=3, T=0, B=7, Í=2, O=6, A=8, Z=4, R=5, L=9, I=1.

< Solution       got            = 765+324=1089

<

<

< Solution       #              = 93

< Solution       fitted         = L=9, R=7, Z=2, A=8, O=3, Í=5, B=4, T=0, V=6, V=6, T=0, B=4, Í=5, O=3, A=8, Z=2, R=7, L=9, I=1.

< Solution       got            = 437+652=1089

<

<

< Solution       #              = 94

< Solution       fitted         = L=9, R=7, Z=2, A=8, O=3, Í=5, B=6, T=0, V=4, V=4, T=0, B=6, Í=5, O=3, A=8, Z=2, R=7, L=9, I=1.

< Solution       got            = 637+452=1089

<

<

< Solution       #              = 95

< Solution       fitted         = L=9, R=7, Z=2, A=8, O=5, Í=3, B=4, T=0, V=6, V=6, T=0, B=4, Í=3, O=5, A=8, Z=2, R=7, L=9, I=1.

< Solution       got            = 457+632=1089

<

<

< Solution       #              = 96

< Solution       fitted         = L=9, R=7, Z=2, A=8, O=5, Í=3, B=6, T=0, V=4, V=4, T=0, B=6, Í=3, O=5, A=8, Z=2, R=7, L=9, I=1.

< Solution       got            = 657+432=1089

<

<

< End of fit lists and results.

<

< Condensed      puzzle         = KUTYA+CICUS=ÁLLAT

<

< Simplified     puzzle         = CICUS+KUTYA=ÁLLAT

<

<

< Tried          fits           = 140

< Matching       fits found     = 8

<

< Start of fit lists and results:

<

---

> End of fit lists and results.

>

> Current        code is        = 'A'

> Intermediate   fit list       = empty.

> Remaining      digits         = 0 and 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = A=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=1, A=0.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 99

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 9

>

> Digit on       other side     = 0

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=2, A=0.

> Remaining      digits         = 1 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 198

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 8

>

> Digit on       other side     = 0

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 1, 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=3, A=0.

> Remaining      digits         = 1 and 2 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 297

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 7

>

> Digit on       other side     = 0

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 1, 2, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=4, A=0.

> Remaining      digits         = 1 and 2 and 3 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 396

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 0

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 1, 2, 3, 5, 6, 7, 8, 9.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=5, A=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 495

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 0

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 1, 2, 3, 4, 6, 7, 8, 9.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=6, A=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 7 and 8 and 9.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 594

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 0

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 7, 8, 9.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=7, A=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 8 and 9.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 693

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 0

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6, 8, 9.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=8, A=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 9.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 792

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 0

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6, 7, 9.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=9, A=0.

> Remaining      digits         = 1 and 2 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 891

> right          partial value  = 0

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 1

>

> Digit on       other side     = 0

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 1, 2, 3, 4, 5, 6, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'T'

> Intermediate   fit list       = A=1.

> Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'S'

> Intermediate   fit list       = T=0, A=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'S'   = 0

> left           partial value  = 0

> right          partial value  = 9

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'U'

> Intermediate   fit list       = S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Current        code is        = 'Y'

> Intermediate   fit list       = U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Y'   = 1

> left           partial value  = 2029

> right          partial value  = 9

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 0

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'C'

> Intermediate   fit list       = Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7.

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=3, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 32409

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 4, 5, 6, 7.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'I'

> Intermediate   fit list       = L=4, C=3, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 5 and 6 and 7.

>

>

> Rightmost      place of 'I'   = 3

> left           partial value  = 32409

> right          partial value  = 4409

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 4

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 5, 6, 7.

> Possible       digits         = 2.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=4, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 5 and 6 and 7.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 42509

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 3, 5, 6, 7.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'I'

> Intermediate   fit list       = L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 6 and 7.

>

>

> Rightmost      place of 'I'   = 3

> left           partial value  = 42509

> right          partial value  = 5509

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 5

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 3, 6, 7.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'K'

> Intermediate   fit list       = I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 6 and 7.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = K=6, I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=4, L=5, I=3, K=6, Á=7, Á=7, K=6, I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

> Results of     fit            = »43429+62081« related to     »75510«

> Values of      fit            = 105510 is greater than   75510.

>

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = K=7, I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=4, L=5, I=3, K=7, Á=6, Á=6, K=7, I=3, L=5, C=4, Y=8, U=2, S=9, T=0, A=1.

> Results of     fit            = »43429+72081« related to     »65510«

> Values of      fit            = 115510 is greater than   65510.

>

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=5, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 4 and 6 and 7.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 52609

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 4, 6, 7.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'I'

> Intermediate   fit list       = L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 4 and 7.

>

>

> Rightmost      place of 'I'   = 3

> left           partial value  = 52609

> right          partial value  = 6609

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 6

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 3, 4, 7.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'K'

> Intermediate   fit list       = I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 7.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = K=3, I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 7.

>

>

> Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=5, L=6, I=4, K=3, Á=7, Á=7, K=3, I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

> Results of     fit            = »54529+32081« related to     »76610«

> Values of      fit            = 86610 is greater than   76610.

>

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = K=7, I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=5, L=6, I=4, K=7, Á=3, Á=3, K=7, I=4, L=6, C=5, Y=8, U=2, S=9, T=0, A=1.

> Results of     fit            = »54529+72081« related to     »36610«

> Values of      fit            = 126610 is greater than   36610.

>

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=6, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 4 and 5 and 7.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 62709

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 3, 4, 5, 7.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'I'

> Intermediate   fit list       = L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 4 and 5.

>

>

> Rightmost      place of 'I'   = 3

> left           partial value  = 62709

> right          partial value  = 7709

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 2

>

> Digit on       other side     = 7

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 3, 4, 5.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'K'

> Intermediate   fit list       = I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 4.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = K=3, I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 4.

>

>

> Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=6, L=7, I=5, K=3, Á=4, Á=4, K=3, I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

> Results of     fit            = »65629+32081« related to     »47710«

> Values of      fit            = 97710 is greater than   47710.

>

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = K=4, I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3.

>

>

> Tried          fit            = A=1, T=0, S=9, U=2, Y=8, C=6, L=7, I=5, K=4, Á=3, Á=3, K=4, I=5, L=7, C=6, Y=8, U=2, S=9, T=0, A=1.

> Results of     fit            = »65629+42081« related to     »37710«

> Values of      fit            = 107710 is greater than   37710.

>

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=7, Y=8, U=2, S=9, T=0, A=1.

> Remaining      digits         = 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 72809

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 4, 5, 6.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Y'

> Intermediate   fit list       = U=3, S=9, T=0, A=1.

> Remaining      digits         = 2 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Y'   = 1

> left           partial value  = 3039

> right          partial value  = 9

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 0

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 4, 5, 6, 7, 8.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'C'

> Intermediate   fit list       = Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 2 and 4 and 5 and 6 and 8.

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=2, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 4 and 5 and 6 and 8.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 23309

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 4, 5, 6, 8.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=4, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 2 and 5 and 6 and 8.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 43509

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 5, 6, 8.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'I'

> Intermediate   fit list       = L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 2 and 6 and 8.

>

>

> Rightmost      place of 'I'   = 3

> left           partial value  = 43509

> right          partial value  = 5509

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 5

>

> Product        mod 10         = 2

> Possible       multipliers    = 2.

>

>

> Remaining      digits         = 2, 6, 8.

> Possible       digits         = 2.

> Intersection   of them        = 2.

> Number of      elements       = 1

>

>

> Current        code is        = 'K'

> Intermediate   fit list       = I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 6 and 8.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = K=6, I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = A=1, T=0, S=9, U=3, Y=7, C=4, L=5, I=2, K=6, Á=8, Á=8, K=6, I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

> Results of     fit            = »42439+63071« related to     »85510«

> Values of      fit            = 105510 is greater than   85510.

>

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = K=8, I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 6.

>

>

> Tried          fit            = A=1, T=0, S=9, U=3, Y=7, C=4, L=5, I=2, K=8, Á=6, Á=6, K=8, I=2, L=5, C=4, Y=7, U=3, S=9, T=0, A=1.

> Results of     fit            = »42439+83071« related to     »65510«

> Values of      fit            = 125510 is greater than   65510.

>

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=5, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 2 and 4 and 6 and 8.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 53609

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 4, 6, 8.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'I'

> Intermediate   fit list       = L=6, C=5, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 2 and 4 and 8.

>

>

> Rightmost      place of 'I'   = 3

> left           partial value  = 53609

> right          partial value  = 6609

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 3

>

> Digit on       other side     = 6

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 2, 4, 8.

> Possible       digits         = 3.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=6, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 2 and 4 and 5 and 8.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 63709

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 2, 4, 5, 8.

> Possible       digits         = 7.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=8, Y=7, U=3, S=9, T=0, A=1.

> Remaining      digits         = 2 and 4 and 5 and 6.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 83909

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 4, 5, 6.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Y'

> Intermediate   fit list       = U=4, S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Y'   = 1

> left           partial value  = 4049

> right          partial value  = 9

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 0

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 5, 6, 7, 8.

> Possible       digits         = 6.

> Intersection   of them        = 6.

> Number of      elements       = 1

>

>

> Current        code is        = 'C'

> Intermediate   fit list       = Y=6, U=4, S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 5 and 7 and 8.

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=2, Y=6, U=4, S=9, T=0, A=1.

> Remaining      digits         = 3 and 5 and 7 and 8.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 24309

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 3, 5, 7, 8.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'I'

> Intermediate   fit list       = L=3, C=2, Y=6, U=4, S=9, T=0, A=1.

> Remaining      digits         = 5 and 7 and 8.

>

>

> Rightmost      place of 'I'   = 3

> left           partial value  = 24309

> right          partial value  = 3309

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 3

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 5, 7, 8.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=3, Y=6, U=4, S=9, T=0, A=1.

> Remaining      digits         = 2 and 5 and 7 and 8.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 34409

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 4

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 5, 7, 8.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=5, Y=6, U=4, S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 7 and 8.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 54609

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 2, 3, 7, 8.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=7, Y=6, U=4, S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 5 and 8.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 74809

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 2, 3, 5, 8.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'I'

> Intermediate   fit list       = L=8, C=7, Y=6, U=4, S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 5.

>

>

> Rightmost      place of 'I'   = 3

> left           partial value  = 74809

> right          partial value  = 8809

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 4

>

> Digit on       other side     = 8

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 5.

> Possible       digits         = 4.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=8, Y=6, U=4, S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 5 and 7.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 84909

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 2, 3, 5, 7.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Y'

> Intermediate   fit list       = U=5, S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 4 and 6 and 7 and 8.

>

>

> Rightmost      place of 'Y'   = 1

> left           partial value  = 5059

> right          partial value  = 9

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 5

>

> Digit on       other side     = 0

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 2, 3, 4, 6, 7, 8.

> Possible       digits         = 5.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Y'

> Intermediate   fit list       = U=6, S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 7 and 8.

>

>

> Rightmost      place of 'Y'   = 1

> left           partial value  = 6069

> right          partial value  = 9

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 0

>

> Product        mod 10         = 4

> Possible       multipliers    = 4.

>

>

> Remaining      digits         = 2, 3, 4, 5, 7, 8.

> Possible       digits         = 4.

> Intersection   of them        = 4.

> Number of      elements       = 1

>

>

> Current        code is        = 'C'

> Intermediate   fit list       = Y=4, U=6, S=9, T=0, A=1.

> Remaining      digits         = 2 and 3 and 5 and 7 and 8.

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = C=2, Y=4, U=6, S=9, T=0, A=1.

> Remaining      digits         = 3 and 5 and 7 and 8.

>

>

> Rightmost      place of 'L'   = 2

> right          partial value  = 9

> left           partial value  = 26309

>

>

> Factor         of code mod 10 = 1

>

> Digit on       right side     = 0

>

> Digit on       other side     = 3

>

> Product        mod 10         = 3

> Possible       multipliers    = 3.

>

>

> Remaining      digits         = 3, 5, 7, 8.

> Possible       digits         = 3.

> Intersection   of them        = 3.

> Number of      elements       = 1

>

>

> Current        code is        = 'I'

> Intermediate   fit list       = L=3, C=2, Y=4, U=6, S=9, T=0, A=1.

> Remaining      digits         = 5 and 7 and 8.

>

>

> Rightmost      place of 'I'   = 3

> left           partial value  = 26309

> right          partial value  = 3309

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 6

>

> Digit on       other side     = 3

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 5, 7, 8.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'K'

> Intermediate   fit list       = I=7, L=3, C=2, Y=4, U=6, S=9, T=0, A=1.

> Remaining      digits         = 5 and 8.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = K=5, I=7, L=3, C=2, Y=4, U=6, S=9, T=0, A=1.

> Remaining      digits         = 8.

>

>

> Tried          fit            = A=1, T=0, S=9, U=6, Y=4, C=2, L=3, I=7, K=5, Á=8, Á=8, K=5, I=7, L=3, C=2, Y=4, U=6, S=9, T=0, A=1.

> Results of     fit            = »27269+56041« related to     »83310«

> Values of      fit            = 83310 is equal to       83310.

>

>

>

> Condensed      puzzle         = KUTYA+CICUS=ÁLLAT

>

> Simplified     puzzle         = CICUS+KUTYA=ÁLLAT

>

>

> Condensed      puzzle         = KUTYA+CICUS=ÁLLAT

>

> Simplified     puzzle         = CICUS+KUTYA=ÁLLAT

>

>

> Tried          fits           = 9

> Matching       fits found     = 1

>

> Start of fit lists and results:

>

2777,2779c21066,21372

< Solution       #              = 2

< Solution       fitted         = A=1, T=6, S=5, U=2, Y=9, C=3, L=0, I=7, K=4, Á=8, Á=8, K=4, I=7, L=0, C=3, Y=9, U=2, S=5, T=6, A=1.

< Solution       got            = 37325+42691=80016

---

> End of fit lists and results.

>

> Current        code is        = 'S'

> Intermediate   fit list       = E=1.

> Remaining      digits         = 0 and 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = S=0, E=1.

> Remaining      digits         = 2 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'N'   = 0

> left           partial value  = 0

> right          partial value  = 100091

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 1

>

> Product        mod 10         = 1

> Possible       multipliers    = 1.

>

>

> Remaining      digits         = 2, 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 1.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'N'

> Intermediate   fit list       = S=2, E=1.

> Remaining      digits         = 0 and 3 and 4 and 5 and 6 and 7 and 8 and 9.

>

>

> Rightmost      place of 'N'   = 0

> left           partial value  = 0

> right          partial value  = 102089

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 0, 3, 4, 5, 6, 7, 8, 9.

> Possible       digits         = 9.

> Intersection   of them        = 9.

> Number of      elements       = 1

>

>

> Current        code is        = 'J'

> Intermediate   fit list       = N=9, S=2, E=1.

> Remaining      digits         = 0 and 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Current        code is        = 'U'

> Intermediate   fit list       = J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7 and 8.

>

>

> Rightmost      place of 'U'   = 1

> left           partial value  = 9

> right          partial value  = 102089

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 4, 5, 6, 7, 8.

> Possible       digits         = 8.

> Intersection   of them        = 8.

> Number of      elements       = 1

>

>

> Current        code is        = 'L'

> Intermediate   fit list       = U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 4 and 5 and 6 and 7.

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = L=3, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 4 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Á'   = 3

> left           partial value  = 89

> right          partial value  = 129089

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 9

>

> Product        mod 10         = 9

> Possible       multipliers    = 9.

>

>

> Remaining      digits         = 4, 5, 6, 7.

> Possible       digits         = 9.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = L=4, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 5 and 6 and 7.

>

>

> Rightmost      place of 'Á'   = 3

> left           partial value  = 89

> right          partial value  = 138089

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 8

>

> Product        mod 10         = 8

> Possible       multipliers    = 8.

>

>

> Remaining      digits         = 3, 5, 6, 7.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = L=5, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 4 and 6 and 7.

>

>

> Rightmost      place of 'Á'   = 3

> left           partial value  = 89

> right          partial value  = 147089

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 7

>

> Product        mod 10         = 7

> Possible       multipliers    = 7.

>

>

> Remaining      digits         = 3, 4, 6, 7.

> Possible       digits         = 7.

> Intersection   of them        = 7.

> Number of      elements       = 1

>

>

> Current        code is        = 'M'

> Intermediate   fit list       = Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Current        code is        = 'É'

> Intermediate   fit list       = M=3, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 4 and 6.

>

>

> Calculated     ratio          = 11

> Calculated     modulus        = 0

>

> Partial        fit            = M=3, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

> Partial        values         =                37089 is less than 147089.

>

> Coefficient    of 'É'         =                10000 is greater than 0.

> Result of      predicate       = rejected("The final step has not acceptable solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'É'

> Intermediate   fit list       = M=4, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 6.

>

>

> Calculated     ratio          = 10

> Calculated     modulus        = 0

>

> Partial        fit            = M=4, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

> Partial        values         =                47089 is less than 147089.

>

> Coefficient    of 'É'         =                10000 is greater than 0.

> Result of      predicate       = rejected("The final step has not acceptable solution.")

>

> Calculated     digit          = none.

>

>

> Current        code is        = 'É'

> Intermediate   fit list       = M=6, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 4.

>

>

> Calculated     ratio          = 8

> Calculated     modulus        = 0

>

> Partial        fit            = M=6, Á=7, L=5, U=8, J=0, N=9, S=2, E=1.

> Partial        values         =                67089 is less than 147089.

>

> Coefficient    of 'É'         =                10000 is greater than 0.

> Result of      predicate       = accepted("The final step could be shortened.")

>

> Calculated     digit          = 8.

>

>

> Remaining      digits         = 3, 4.

> Possible       digits         = 8.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = L=6, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 4 and 5 and 7.

>

>

> Rightmost      place of 'Á'   = 3

> left           partial value  = 89

> right          partial value  = 156089

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 6

>

> Product        mod 10         = 6

> Possible       multipliers    = 6.

>

>

> Remaining      digits         = 3, 4, 5, 7.

> Possible       digits         = 6.

> Intersection   of them        = none.

> Number of      elements       = 0

>

>

> Current        code is        = 'Á'

> Intermediate   fit list       = L=7, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 4 and 5 and 6.

>

>

> Rightmost      place of 'Á'   = 3

> left           partial value  = 89

> right          partial value  = 165089

>

>

> Factor         of code mod 10 = 1

>

> Digit on       left side      = 0

>

> Digit on       other side     = 5

>

> Product        mod 10         = 5

> Possible       multipliers    = 5.

>

>

> Remaining      digits         = 3, 4, 5, 6.

> Possible       digits         = 5.

> Intersection   of them        = 5.

> Number of      elements       = 1

>

>

> Current        code is        = 'M'

> Intermediate   fit list       = Á=5, L=7, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 3 and 4 and 6.

>

>

> Current        code is        = 'É'

> Intermediate   fit list       = M=3, Á=5, L=7, U=8, J=0, N=9, S=2, E=1.

> Remaining      digits         = 4 and 6.

>

>

> Calculated     ratio          = 13

> Calculated     modulus        = 0

>

> Partial        fit            = M=3, Á=5, L=7, U=8, J=0, N=9, S=2, E=1.

> Partial        values         =                35089 is less than 165089.

>

> Coefficient    of 'É'         =                10000 is greater than 0.

> Result of      predicate       = rejected("The final step has not acceptable solution.")

>

> Calculated     digit          = none.

2781,4054d21374

<

< Solution       #              = 3

< Solution       fitted         = A=1, T=6, S=5, U=3, Y=8, C=7, L=4, I=0, K=2, Á=9, Á=9, K=2, I=0, L=4, C=7, Y=8, U=3, S=5, T=6, A=1.

< Solution       got            = 70735+23681=94416

<

<

< Solution       #              = 4

< Solution       fitted         = A=3, T=7, S=4, U=8, Y=5, C=2, L=0, I=1, K=6, Á=9, Á=9, K=6, I=1, L=0, C=2, Y=5, U=8, S=4, T=7, A=3.

< Solution       got            = 21284+68753=90037

<

<

< Solution       #              = 5

< Solution       fitted         = A=5, T=2, S=7, U=4, Y=0, C=1, L=3, I=9, K=6, Á=8, Á=8, K=6, I=9, L=3, C=1, Y=0, U=4, S=7, T=2, A=5.

< Solution       got            = 19147+64205=83352

<

<

< Solution       #              = 6

< Solution       fitted         = A=5, T=9, S=4, U=2, Y=3, C=1, L=0, I=7, K=6, Á=8, Á=8, K=6, I=7, L=0, C=1, Y=3, U=2, S=4, T=9, A=5.

< Solution       got            = 17124+62935=80059

<

<

< Solution       #              = 7

< Solution       fitted         = A=7, T=8, S=1, U=4, Y=3, C=2, L=0, I=5, K=6, Á=9, Á=9, K=6, I=5, L=0, C=2, Y=3, U=4, S=1, T=8, A=7.

< Solution       got            = 25241+64837=90078

<

<

< Solution       #              = 8

< Solution       fitted         = A=7, T=9, S=2, U=4, Y=3, C=1, L=0, I=5, K=6, Á=8, Á=8, K=6, I=5, L=0, C=1, Y=3, U=4, S=2, T=9, A=7.

< Solution       got            = 15142+64937=80079

<

<

< End of fit lists and results.

<

< Condensed      puzzle         = ÉLJEN+MÁJUS=ELSEJE

<

< Simplified     puzzle         = MÁJUS+ÉLJEN=ELSEJE

<

<

< Tried          fits           = 512

< Matching       fits found     = 8

<

< Start of fit lists and results:

<

< Solution       #              = 1

< Solution       fitted         = S=5, N=6, J=0, U=8, L=3, Á=2, M=4, É=9, É=9, M=4, Á=2, L=3, U=8, J=0, N=6, S=5, E=1.

< Solution       got            = 42085+93016=135101

<

<

< Solution       #              = 2

< Solution       fitted         = S=5, N=6, J=0, U=8, L=3, Á=2, M=9, É=4, É=4, M=9, Á=2, L=3, U=8, J=0, N=6, S=5, E=1.

< Solution       got            = 92085+43016=135101

<

<

< Solution       #              = 3

< Solution       fitted         = S=6, N=5, J=0, U=8, L=2, Á=4, M=3, É=9, É=9, M=3, Á=4, L=2, U=8, J=0, N=5, S=6, E=1.

< Solution       got            = 34086+92015=126101

<

<

< Solution       #              = 4

< Solution       fitted         = S=6, N=5, J=0, U=8, L=2, Á=4, M=9, É=3, É=3, M=9, Á=4, L=2, U=8, J=0, N=5, S=6, E=1.

< Solution       got            = 94086+32015=126101

<

<

< Solution       #              = 5

< Solution       fitted         = S=7, N=4, J=0, U=8, L=2, Á=5, M=3, É=9, É=9, M=3, Á=5, L=2, U=8, J=0, N=4, S=7, E=1.

< Solution       got            = 35087+92014=127101

<

<

< Solution       #              = 6

< Solution       fitted         = S=7, N=4, J=0, U=8, L=2, Á=5, M=9, É=3, É=3, M=9, Á=5, L=2, U=8, J=0, N=4, S=7, E=1.

< Solution       got            = 95087+32014=127101

<

<

< Solution       #              = 7

< Solution       fitted         = S=7, N=4, J=0, U=8, L=5, Á=2, M=6, É=9, É=9, M=6, Á=2, L=5, U=8, J=0, N=4, S=7, E=1.

< Solution       got            = 62087+95014=157101

<

<

< Solution       #              = 8

< Solution       fitted         = S=7, N=4, J=0, U=8, L=5, Á=2, M=9, É=6, É=6, M=9, Á=2, L=5, U=8, J=0, N=4, S=7, E=1.

< Solution       got            = 92087+65014=157101

<

<

< End of fit lists and results.

<

< Condensed      puzzle         = VÍZ+BOR=ITAL

<

< Simplified     puzzle         = BOR+VÍZ=ITAL

<

<

< Tried          fits           = 1872

< Matching       fits found     = 96

<

< Start of fit lists and results:

<

< Solution       #              = 1

< Solution       fitted         = L=2, R=3, Z=9, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

< Solution       got            = 743+859=1602

<

<

< Solution       #              = 2

< Solution       fitted         = L=2, R=3, Z=9, A=0, O=4, Í=5, B=8, T=6, V=7, V=7, T=6, B=8, Í=5, O=4, A=0, Z=9, R=3, L=2, I=1.

< Solution       got            = 843+759=1602

<

<

< Solution       #              = 3

< Solution       fitted         = L=2, R=3, Z=9, A=0, O=5, Í=4, B=7, T=6, V=8, V=8, T=6, B=7, Í=4, O=5, A=0, Z=9, R=3, L=2, I=1.

< Solution       got            = 753+849=1602

<

<

< Solution       #              = 4

< Solution       fitted         = L=2, R=3, Z=9, A=0, O=5, Í=4, B=8, T=6, V=7, V=7, T=6, B=8, Í=4, O=5, A=0, Z=9, R=3, L=2, I=1.

< Solution       got            = 853+749=1602

<

<

< Solution       #              = 5

< Solution       fitted         = L=2, R=3, Z=9, A=6, O=7, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=7, A=6, Z=9, R=3, L=2, I=1.

< Solution       got            = 473+589=1062

<

<

< Solution       #              = 6

< Solution       fitted         = L=2, R=3, Z=9, A=6, O=7, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=7, A=6, Z=9, R=3, L=2, I=1.

< Solution       got            = 573+489=1062

<

<

< Solution       #              = 7

< Solution       fitted         = L=2, R=3, Z=9, A=6, O=8, Í=7, B=4, T=0, V=5, V=5, T=0, B=4, Í=7, O=8, A=6, Z=9, R=3, L=2, I=1.

< Solution       got            = 483+579=1062

<

<

< Solution       #              = 8

< Solution       fitted         = L=2, R=3, Z=9, A=6, O=8, Í=7, B=5, T=0, V=4, V=4, T=0, B=5, Í=7, O=8, A=6, Z=9, R=3, L=2, I=1.

< Solution       got            = 583+479=1062

<

<

< Solution       #              = 9

< Solution       fitted         = L=2, R=9, Z=3, A=0, O=4, Í=5, B=7, T=6, V=8, V=8, T=6, B=7, Í=5, O=4, A=0, Z=3, R=9, L=2, I=1.

< Solution       got            = 749+853=1602

<

<

< Solution       #              = 10

< Solution       fitted         = L=2, R=9, Z=3, A=0, O=4, Í=5, B=8, T=6, V=7, V=7, T=6, B=8, Í=5, O=4, A=0, Z=3, R=9, L=2, I=1.

< Solution       got            = 849+753=1602

<

<

< Solution       #              = 11

< Solution       fitted         = L=2, R=9, Z=3, A=0, O=5, Í=4, B=7, T=6, V=8, V=8, T=6, B=7, Í=4, O=5, A=0, Z=3, R=9, L=2, I=1.

< Solution       got            = 759+843=1602

<

<

< Solution       #              = 12

< Solution       fitted         = L=2, R=9, Z=3, A=0, O=5, Í=4, B=8, T=6, V=7, V=7, T=6, B=8, Í=4, O=5, A=0, Z=3, R=9, L=2, I=1.

< Solution       got            = 859+743=1602

<

<

< Solution       #              = 13

< Solution       fitted         = L=2, R=9, Z=3, A=6, O=7, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=7, A=6, Z=3, R=9, L=2, I=1.

< Solution       got            = 479+583=1062

<

<

< Solution       #              = 14

< Solution       fitted         = L=2, R=9, Z=3, A=6, O=7, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=7, A=6, Z=3, R=9, L=2, I=1.

< Solution       got            = 579+483=1062

<

<

< Solution       #              = 15

< Solution       fitted         = L=2, R=9, Z=3, A=6, O=8, Í=7, B=4, T=0, V=5, V=5, T=0, B=4, Í=7, O=8, A=6, Z=3, R=9, L=2, I=1.

< Solution       got            = 489+573=1062

<

<

< Solution       #              = 16

< Solution       fitted         = L=2, R=9, Z=3, A=6, O=8, Í=7, B=5, T=0, V=4, V=4, T=0, B=5, Í=7, O=8, A=6, Z=3, R=9, L=2, I=1.

< Solution       got            = 589+473=1062

<

<

< Solution       #              = 17

< Solution       fitted         = L=3, R=4, Z=9, A=0, O=2, Í=7, B=6, T=5, V=8, V=8, T=5, B=6, Í=7, O=2, A=0, Z=9, R=4, L=3, I=1.

< Solution       got            = 624+879=1503

<

<

< Solution       #              = 18

< Solution       fitted         = L=3, R=4, Z=9, A=0, O=2, Í=7, B=8, T=5, V=6, V=6, T=5, B=8, Í=7, O=2, A=0, Z=9, R=4, L=3, I=1.

< Solution       got            = 824+679=1503

<

<

< Solution       #              = 19

< Solution       fitted         = L=3, R=4, Z=9, A=0, O=7, Í=2, B=6, T=5, V=8, V=8, T=5, B=6, Í=2, O=7, A=0, Z=9, R=4, L=3, I=1.

< Solution       got            = 674+829=1503

<

<

< Solution       #              = 20

< Solution       fitted         = L=3, R=4, Z=9, A=0, O=7, Í=2, B=8, T=5, V=6, V=6, T=5, B=8, Í=2, O=7, A=0, Z=9, R=4, L=3, I=1.

< Solution       got            = 874+629=1503

<

<

< Solution       #              = 21

< Solution       fitted         = L=3, R=4, Z=9, A=5, O=6, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=6, A=5, Z=9, R=4, L=3, I=1.

< Solution       got            = 264+789=1053

<

<

< Solution       #              = 22

< Solution       fitted         = L=3, R=4, Z=9, A=5, O=6, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=6, A=5, Z=9, R=4, L=3, I=1.

< Solution       got            = 764+289=1053

<

<

< Solution       #              = 23

< Solution       fitted         = L=3, R=4, Z=9, A=5, O=8, Í=6, B=2, T=0, V=7, V=7, T=0, B=2, Í=6, O=8, A=5, Z=9, R=4, L=3, I=1.

< Solution       got            = 284+769=1053

<

<

< Solution       #              = 24

< Solution       fitted         = L=3, R=4, Z=9, A=5, O=8, Í=6, B=7, T=0, V=2, V=2, T=0, B=7, Í=6, O=8, A=5, Z=9, R=4, L=3, I=1.

< Solution       got            = 784+269=1053

<

<

< Solution       #              = 25

< Solution       fitted         = L=3, R=9, Z=4, A=0, O=2, Í=7, B=6, T=5, V=8, V=8, T=5, B=6, Í=7, O=2, A=0, Z=4, R=9, L=3, I=1.

< Solution       got            = 629+874=1503

<

<

< Solution       #              = 26

< Solution       fitted         = L=3, R=9, Z=4, A=0, O=2, Í=7, B=8, T=5, V=6, V=6, T=5, B=8, Í=7, O=2, A=0, Z=4, R=9, L=3, I=1.

< Solution       got            = 829+674=1503

<

<

< Solution       #              = 27

< Solution       fitted         = L=3, R=9, Z=4, A=0, O=7, Í=2, B=6, T=5, V=8, V=8, T=5, B=6, Í=2, O=7, A=0, Z=4, R=9, L=3, I=1.

< Solution       got            = 679+824=1503

<

<

< Solution       #              = 28

< Solution       fitted         = L=3, R=9, Z=4, A=0, O=7, Í=2, B=8, T=5, V=6, V=6, T=5, B=8, Í=2, O=7, A=0, Z=4, R=9, L=3, I=1.

< Solution       got            = 879+624=1503

<

<

< Solution       #              = 29

< Solution       fitted         = L=3, R=9, Z=4, A=5, O=6, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=6, A=5, Z=4, R=9, L=3, I=1.

< Solution       got            = 269+784=1053

<

<

< Solution       #              = 30

< Solution       fitted         = L=3, R=9, Z=4, A=5, O=6, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=6, A=5, Z=4, R=9, L=3, I=1.

< Solution       got            = 769+284=1053

<

<

< Solution       #              = 31

< Solution       fitted         = L=3, R=9, Z=4, A=5, O=8, Í=6, B=2, T=0, V=7, V=7, T=0, B=2, Í=6, O=8, A=5, Z=4, R=9, L=3, I=1.

< Solution       got            = 289+764=1053

<

<

< Solution       #              = 32

< Solution       fitted         = L=3, R=9, Z=4, A=5, O=8, Í=6, B=7, T=0, V=2, V=2, T=0, B=7, Í=6, O=8, A=5, Z=4, R=9, L=3, I=1.

< Solution       got            = 789+264=1053

<

<

< Solution       #              = 33

< Solution       fitted         = L=5, R=6, Z=9, A=0, O=2, Í=7, B=4, T=3, V=8, V=8, T=3, B=4, Í=7, O=2, A=0, Z=9, R=6, L=5, I=1.

< Solution       got            = 426+879=1305

<

<

< Solution       #              = 34

< Solution       fitted         = L=5, R=6, Z=9, A=0, O=2, Í=7, B=8, T=3, V=4, V=4, T=3, B=8, Í=7, O=2, A=0, Z=9, R=6, L=5, I=1.

< Solution       got            = 826+479=1305

<

<

< Solution       #              = 35

< Solution       fitted         = L=5, R=6, Z=9, A=0, O=7, Í=2, B=4, T=3, V=8, V=8, T=3, B=4, Í=2, O=7, A=0, Z=9, R=6, L=5, I=1.

< Solution       got            = 476+829=1305

<

<

< Solution       #              = 36

< Solution       fitted         = L=5, R=6, Z=9, A=0, O=7, Í=2, B=8, T=3, V=4, V=4, T=3, B=8, Í=2, O=7, A=0, Z=9, R=6, L=5, I=1.

< Solution       got            = 876+429=1305

<

<

< Solution       #              = 37

< Solution       fitted         = L=5, R=6, Z=9, A=3, O=4, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=4, A=3, Z=9, R=6, L=5, I=1.

< Solution       got            = 246+789=1035

<

<

< Solution       #              = 38

< Solution       fitted         = L=5, R=6, Z=9, A=3, O=4, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=4, A=3, Z=9, R=6, L=5, I=1.

< Solution       got            = 746+289=1035

<

<

< Solution       #              = 39

< Solution       fitted         = L=5, R=6, Z=9, A=3, O=8, Í=4, B=2, T=0, V=7, V=7, T=0, B=2, Í=4, O=8, A=3, Z=9, R=6, L=5, I=1.

< Solution       got            = 286+749=1035

<

<

< Solution       #              = 40

< Solution       fitted         = L=5, R=6, Z=9, A=3, O=8, Í=4, B=7, T=0, V=2, V=2, T=0, B=7, Í=4, O=8, A=3, Z=9, R=6, L=5, I=1.

< Solution       got            = 786+249=1035

<

<

< Solution       #              = 41

< Solution       fitted         = L=5, R=9, Z=6, A=0, O=2, Í=7, B=4, T=3, V=8, V=8, T=3, B=4, Í=7, O=2, A=0, Z=6, R=9, L=5, I=1.

< Solution       got            = 429+876=1305

<

<

< Solution       #              = 42

< Solution       fitted         = L=5, R=9, Z=6, A=0, O=2, Í=7, B=8, T=3, V=4, V=4, T=3, B=8, Í=7, O=2, A=0, Z=6, R=9, L=5, I=1.

< Solution       got            = 829+476=1305

<

<

< Solution       #              = 43

< Solution       fitted         = L=5, R=9, Z=6, A=0, O=7, Í=2, B=4, T=3, V=8, V=8, T=3, B=4, Í=2, O=7, A=0, Z=6, R=9, L=5, I=1.

< Solution       got            = 479+826=1305

<

<

< Solution       #              = 44

< Solution       fitted         = L=5, R=9, Z=6, A=0, O=7, Í=2, B=8, T=3, V=4, V=4, T=3, B=8, Í=2, O=7, A=0, Z=6, R=9, L=5, I=1.

< Solution       got            = 879+426=1305

<

<

< Solution       #              = 45

< Solution       fitted         = L=5, R=9, Z=6, A=3, O=4, Í=8, B=2, T=0, V=7, V=7, T=0, B=2, Í=8, O=4, A=3, Z=6, R=9, L=5, I=1.

< Solution       got            = 249+786=1035

<

<

< Solution       #              = 46

< Solution       fitted         = L=5, R=9, Z=6, A=3, O=4, Í=8, B=7, T=0, V=2, V=2, T=0, B=7, Í=8, O=4, A=3, Z=6, R=9, L=5, I=1.

< Solution       got            = 749+286=1035

<

<

< Solution       #              = 47

< Solution       fitted         = L=5, R=9, Z=6, A=3, O=8, Í=4, B=2, T=0, V=7, V=7, T=0, B=2, Í=4, O=8, A=3, Z=6, R=9, L=5, I=1.

< Solution       got            = 289+746=1035

<

<

< Solution       #              = 48

< Solution       fitted         = L=5, R=9, Z=6, A=3, O=8, Í=4, B=7, T=0, V=2, V=2, T=0, B=7, Í=4, O=8, A=3, Z=6, R=9, L=5, I=1.

< Solution       got            = 789+246=1035

<

<

< Solution       #              = 49

< Solution       fitted         = L=6, R=7, Z=9, A=0, O=4, Í=5, B=3, T=2, V=8, V=8, T=2, B=3, Í=5, O=4, A=0, Z=9, R=7, L=6, I=1.

< Solution       got            = 347+859=1206

<

<

< Solution       #              = 50

< Solution       fitted         = L=6, R=7, Z=9, A=0, O=4, Í=5, B=8, T=2, V=3, V=3, T=2, B=8, Í=5, O=4, A=0, Z=9, R=7, L=6, I=1.

< Solution       got            = 847+359=1206

<

<

< Solution       #              = 51

< Solution       fitted         = L=6, R=7, Z=9, A=0, O=5, Í=4, B=3, T=2, V=8, V=8, T=2, B=3, Í=4, O=5, A=0, Z=9, R=7, L=6, I=1.

< Solution       got            = 357+849=1206

<

<

< Solution       #              = 52

< Solution       fitted         = L=6, R=7, Z=9, A=0, O=5, Í=4, B=8, T=2, V=3, V=3, T=2, B=8, Í=4, O=5, A=0, Z=9, R=7, L=6, I=1.

< Solution       got            = 857+349=1206

<

<

< Solution       #              = 53

< Solution       fitted         = L=6, R=7, Z=9, A=2, O=3, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=3, A=2, Z=9, R=7, L=6, I=1.

< Solution       got            = 437+589=1026

<

<

< Solution       #              = 54

< Solution       fitted         = L=6, R=7, Z=9, A=2, O=3, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=3, A=2, Z=9, R=7, L=6, I=1.

< Solution       got            = 537+489=1026

<

<

< Solution       #              = 55

< Solution       fitted         = L=6, R=7, Z=9, A=2, O=8, Í=3, B=4, T=0, V=5, V=5, T=0, B=4, Í=3, O=8, A=2, Z=9, R=7, L=6, I=1.

< Solution       got            = 487+539=1026

<

<

< Solution       #              = 56

< Solution       fitted         = L=6, R=7, Z=9, A=2, O=8, Í=3, B=5, T=0, V=4, V=4, T=0, B=5, Í=3, O=8, A=2, Z=9, R=7, L=6, I=1.

< Solution       got            = 587+439=1026

<

<

< Solution       #              = 57

< Solution       fitted         = L=6, R=9, Z=7, A=0, O=4, Í=5, B=3, T=2, V=8, V=8, T=2, B=3, Í=5, O=4, A=0, Z=7, R=9, L=6, I=1.

< Solution       got            = 349+857=1206

<

<

< Solution       #              = 58

< Solution       fitted         = L=6, R=9, Z=7, A=0, O=4, Í=5, B=8, T=2, V=3, V=3, T=2, B=8, Í=5, O=4, A=0, Z=7, R=9, L=6, I=1.

< Solution       got            = 849+357=1206

<

<

< Solution       #              = 59

< Solution       fitted         = L=6, R=9, Z=7, A=0, O=5, Í=4, B=3, T=2, V=8, V=8, T=2, B=3, Í=4, O=5, A=0, Z=7, R=9, L=6, I=1.

< Solution       got            = 359+847=1206

<

<

< Solution       #              = 60

< Solution       fitted         = L=6, R=9, Z=7, A=0, O=5, Í=4, B=8, T=2, V=3, V=3, T=2, B=8, Í=4, O=5, A=0, Z=7, R=9, L=6, I=1.

< Solution       got            = 859+347=1206

<

<

< Solution       #              = 61

< Solution       fitted         = L=6, R=9, Z=7, A=2, O=3, Í=8, B=4, T=0, V=5, V=5, T=0, B=4, Í=8, O=3, A=2, Z=7, R=9, L=6, I=1.

< Solution       got            = 439+587=1026

<

<

< Solution       #              = 62

< Solution       fitted         = L=6, R=9, Z=7, A=2, O=3, Í=8, B=5, T=0, V=4, V=4, T=0, B=5, Í=8, O=3, A=2, Z=7, R=9, L=6, I=1.

< Solution       got            = 539+487=1026

<

<

< Solution       #              = 63

< Solution       fitted         = L=6, R=9, Z=7, A=2, O=8, Í=3, B=4, T=0, V=5, V=5, T=0, B=4, Í=3, O=8, A=2, Z=7, R=9, L=6, I=1.

< Solution       got            = 489+537=1026

<

<

< Solution       #              = 64

< Solution       fitted         = L=6, R=9, Z=7, A=2, O=8, Í=3, B=5, T=0, V=4, V=4, T=0, B=5, Í=3, O=8, A=2, Z=7, R=9, L=6, I=1.

< Solution       got            = 589+437=1026

<

<

< Solution       #              = 65

< Solution       fitted         = L=8, R=2, Z=6, A=9, O=4, Í=5, B=3, T=0, V=7, V=7, T=0, B=3, Í=5, O=4, A=9, Z=6, R=2, L=8, I=1.

< Solution       got            = 342+756=1098

<

<

< Solution       #              = 66

< Solution       fitted         = L=8, R=2, Z=6, A=9, O=4, Í=5, B=7, T=0, V=3, V=3, T=0, B=7, Í=5, O=4, A=9, Z=6, R=2, L=8, I=1.

< Solution       got            = 742+356=1098

<

<

< Solution       #              = 67

< Solution       fitted         = L=8, R=2, Z=6, A=9, O=5, Í=4, B=3, T=0, V=7, V=7, T=0, B=3, Í=4, O=5, A=9, Z=6, R=2, L=8, I=1.

< Solution       got            = 352+746=1098

<

<

< Solution       #              = 68

< Solution       fitted         = L=8, R=2, Z=6, A=9, O=5, Í=4, B=7, T=0, V=3, V=3, T=0, B=7, Í=4, O=5, A=9, Z=6, R=2, L=8, I=1.

< Solution       got            = 752+346=1098

<

<

< Solution       #              = 69

< Solution       fitted         = L=8, R=3, Z=5, A=9, O=2, Í=7, B=4, T=0, V=6, V=6, T=0, B=4, Í=7, O=2, A=9, Z=5, R=3, L=8, I=1.

< Solution       got            = 423+675=1098

<

<

< Solution       #              = 70

< Solution       fitted         = L=8, R=3, Z=5, A=9, O=2, Í=7, B=6, T=0, V=4, V=4, T=0, B=6, Í=7, O=2, A=9, Z=5, R=3, L=8, I=1.

< Solution       got            = 623+475=1098

<

<

< Solution       #              = 71

< Solution       fitted         = L=8, R=3, Z=5, A=9, O=7, Í=2, B=4, T=0, V=6, V=6, T=0, B=4, Í=2, O=7, A=9, Z=5, R=3, L=8, I=1.

< Solution       got            = 473+625=1098

<

<

< Solution       #              = 72

< Solution       fitted         = L=8, R=3, Z=5, A=9, O=7, Í=2, B=6, T=0, V=4, V=4, T=0, B=6, Í=2, O=7, A=9, Z=5, R=3, L=8, I=1.

< Solution       got            = 673+425=1098

<

<

< Solution       #              = 73

< Solution       fitted         = L=8, R=5, Z=3, A=9, O=2, Í=7, B=4, T=0, V=6, V=6, T=0, B=4, Í=7, O=2, A=9, Z=3, R=5, L=8, I=1.

< Solution       got            = 425+673=1098

<

<

< Solution       #              = 74

< Solution       fitted         = L=8, R=5, Z=3, A=9, O=2, Í=7, B=6, T=0, V=4, V=4, T=0, B=6, Í=7, O=2, A=9, Z=3, R=5, L=8, I=1.

< Solution       got            = 625+473=1098

<

<

< Solution       #              = 75

< Solution       fitted         = L=8, R=5, Z=3, A=9, O=7, Í=2, B=4, T=0, V=6, V=6, T=0, B=4, Í=2, O=7, A=9, Z=3, R=5, L=8, I=1.

< Solution       got            = 475+623=1098

<

<

< Solution       #              = 76

< Solution       fitted         = L=8, R=5, Z=3, A=9, O=7, Í=2, B=6, T=0, V=4, V=4, T=0, B=6, Í=2, O=7, A=9, Z=3, R=5, L=8, I=1.

< Solution       got            = 675+423=1098

<

<

< Solution       #              = 77

< Solution       fitted         = L=8, R=6, Z=2, A=9, O=4, Í=5, B=3, T=0, V=7, V=7, T=0, B=3, Í=5, O=4, A=9, Z=2, R=6, L=8, I=1.

< Solution       got            = 346+752=1098

<

<

< Solution       #              = 78

< Solution       fitted         = L=8, R=6, Z=2, A=9, O=4, Í=5, B=7, T=0, V=3, V=3, T=0, B=7, Í=5, O=4, A=9, Z=2, R=6, L=8, I=1.

< Solution       got            = 746+352=1098

<

<

< Solution       #              = 79

< Solution       fitted         = L=8, R=6, Z=2, A=9, O=5, Í=4, B=3, T=0, V=7, V=7, T=0, B=3, Í=4, O=5, A=9, Z=2, R=6, L=8, I=1.

< Solution       got            = 356+742=1098

<

<

< Solution       #              = 80

< Solution       fitted         = L=8, R=6, Z=2, A=9, O=5, Í=4, B=7, T=0, V=3, V=3, T=0, B=7, Í=4, O=5, A=9, Z=2, R=6, L=8, I=1.

< Solution       got            = 756+342=1098

<

<

< Solution       #              = 81

< Solution       fitted         = L=9, R=2, Z=7, A=8, O=3, Í=5, B=4, T=0, V=6, V=6, T=0, B=4, Í=5, O=3, A=8, Z=7, R=2, L=9, I=1.

< Solution       got            = 432+657=1089

<

<

< Solution       #              = 82

< Solution       fitted         = L=9, R=2, Z=7, A=8, O=3, Í=5, B=6, T=0, V=4, V=4, T=0, B=6, Í=5, O=3, A=8, Z=7, R=2, L=9, I=1.

< Solution       got            = 632+457=1089

<

<

< Solution       #              = 83

< Solution       fitted         = L=9, R=2, Z=7, A=8, O=5, Í=3, B=4, T=0, V=6, V=6, T=0, B=4, Í=3, O=5, A=8, Z=7, R=2, L=9, I=1.

< Solution       got            = 452+637=1089

<

<

< Solution       #              = 84

< Solution       fitted         = L=9, R=2, Z=7, A=8, O=5, Í=3, B=6, T=0, V=4, V=4, T=0, B=6, Í=3, O=5, A=8, Z=7, R=2, L=9, I=1.

< Solution       got            = 652+437=1089

<

<

< Solution       #              = 85

< Solution       fitted         = L=9, R=4, Z=5, A=8, O=2, Í=6, B=3, T=0, V=7, V=7, T=0, B=3, Í=6, O=2, A=8, Z=5, R=4, L=9, I=1.

< Solution       got            = 324+765=1089

<

<

< Solution       #              = 86

< Solution       fitted         = L=9, R=4, Z=5, A=8, O=2, Í=6, B=7, T=0, V=3, V=3, T=0, B=7, Í=6, O=2, A=8, Z=5, R=4, L=9, I=1.

< Solution       got            = 724+365=1089

<

<

< Solution       #              = 87

< Solution       fitted         = L=9, R=4, Z=5, A=8, O=6, Í=2, B=3, T=0, V=7, V=7, T=0, B=3, Í=2, O=6, A=8, Z=5, R=4, L=9, I=1.

< Solution       got            = 364+725=1089

<

<

< Solution       #              = 88

< Solution       fitted         = L=9, R=4, Z=5, A=8, O=6, Í=2, B=7, T=0, V=3, V=3, T=0, B=7, Í=2, O=6, A=8, Z=5, R=4, L=9, I=1.

< Solution       got            = 764+325=1089

<

<

< Solution       #              = 89

< Solution       fitted         = L=9, R=5, Z=4, A=8, O=2, Í=6, B=3, T=0, V=7, V=7, T=0, B=3, Í=6, O=2, A=8, Z=4, R=5, L=9, I=1.

< Solution       got            = 325+764=1089

<

<

< Solution       #              = 90

< Solution       fitted         = L=9, R=5, Z=4, A=8, O=2, Í=6, B=7, T=0, V=3, V=3, T=0, B=7, Í=6, O=2, A=8, Z=4, R=5, L=9, I=1.

< Solution       got            = 725+364=1089

<

<

< Solution       #              = 91

< Solution       fitted         = L=9, R=5, Z=4, A=8, O=6, Í=2, B=3, T=0, V=7, V=7, T=0, B=3, Í=2, O=6, A=8, Z=4, R=5, L=9, I=1.

< Solution       got            = 365+724=1089

<

<

< Solution       #              = 92

< Solution       fitted         = L=9, R=5, Z=4, A=8, O=6, Í=2, B=7, T=0, V=3, V=3, T=0, B=7, Í=2, O=6, A=8, Z=4, R=5, L=9, I=1.

< Solution       got            = 765+324=1089

<

<

< Solution       #              = 93

< Solution       fitted         = L=9, R=7, Z=2, A=8, O=3, Í=5, B=4, T=0, V=6, V=6, T=0, B=4, Í=5, O=3, A=8, Z=2, R=7, L=9, I=1.

< Solution       got            = 437+652=1089

<

<

< Solution       #              = 94

< Solution       fitted         = L=9, R=7, Z=2, A=8, O=3, Í=5, B=6, T=0, V=4, V=4, T=0, B=6, Í=5, O=3, A=8, Z=2, R=7, L=9, I=1.

< Solution       got            = 637+452=1089

<

<

< Solution       #              = 95

< Solution       fitted         = L=9, R=7, Z=2, A=8, O=5, Í=3, B=4, T=0, V=6, V=6, T=0, B=4, Í=3, O=5, A=8, Z=2, R=7, L=9, I=1.

< Solution       got            = 457+632=1089

<

<

< Solution       #              = 96

< Solution       fitted         = L=9, R=7, Z=2, A=8, O=5, Í=3, B=6, T=0, V=4, V=4, T=0, B=6, Í=3, O=5, A=8, Z=2, R=7, L=9, I=1.

< Solution       got            = 657+432=1089

<

<

< End of fit lists and results.

<

< Condensed      puzzle         = EGER+BAJA=VÁROS

<

< Simplified     puzzle         = BAJA+EGER=VÁROS

<

<

< Tried          fits           = 169

< Matching       fits found     = 9

<

< Start of fit lists and results:

<

< Solution       #              = 1

< Solution       fitted         = R=3, A=2, S=5, E=8, J=6, O=4, G=0, B=9, Á=7, Á=7, B=9, G=0, O=4, J=6, E=8, S=5, A=2, R=3, V=1.

< Solution       got            = 9262+8083=17345

<

<

< Solution       #              = 2

< Solution       fitted         = R=3, A=2, S=5, E=8, J=9, O=7, G=0, B=6, Á=4, Á=4, B=6, G=0, O=7, J=9, E=8, S=5, A=2, R=3, V=1.

< Solution       got            = 6292+8083=14375

<

<

< Solution       #              = 3

< Solution       fitted         = R=3, A=9, S=2, E=6, J=0, O=7, G=4, B=8, Á=5, Á=5, B=8, G=4, O=7, J=0, E=6, S=2, A=9, R=3, V=1.

< Solution       got            = 8909+6463=15372

<

<

< Solution       #              = 4

< Solution       fitted         = R=4, A=5, S=9, E=7, J=6, O=3, G=8, B=2, Á=0, Á=0, B=2, G=8, O=3, J=6, E=7, S=9, A=5, R=4, V=1.

< Solution       got            = 2565+7874=10439

<

<

< Solution       #              = 5

< Solution       fitted         = R=6, A=7, S=3, E=5, J=2, O=8, G=9, B=4, Á=0, Á=0, B=4, G=9, O=8, J=2, E=5, S=3, A=7, R=6, V=1.

< Solution       got            = 4727+5956=10683

<

<

< Solution       #              = 6

< Solution       fitted         = R=6, A=9, S=5, E=3, J=0, O=4, G=7, B=8, Á=2, Á=2, B=8, G=7, O=4, J=0, E=3, S=5, A=9, R=6, V=1.

< Solution       got            = 8909+3736=12645

<

<

< Solution       #              = 7

< Solution       fitted         = R=8, A=6, S=4, E=3, J=5, O=9, G=2, B=7, Á=0, Á=0, B=7, G=2, O=9, J=5, E=3, S=4, A=6, R=8, V=1.

< Solution       got            = 7656+3238=10894

<

<

< Solution       #              = 8

< Solution       fitted         = R=9, A=5, S=4, E=8, J=7, O=6, G=3, B=2, Á=0, Á=0, B=2, G=3, O=6, J=7, E=8, S=4, A=5, R=9, V=1.

< Solution       got            = 2575+8389=10964

<

<

< Solution       #              = 9

< Solution       fitted         = R=9, A=6, S=5, E=2, J=4, O=7, G=3, B=8, Á=0, Á=0, B=8, G=3, O=7, J=4, E=2, S=5, A=6, R=9, V=1.

< Solution       got            = 8646+2329=10975

<

<

< End of fit lists and results.

<

< Condensed      puzzle         = KLÓR+BRÓM+JÓD=MARÓ

<

< Simplified     puzzle         = BRÓM+KLÓR+JÓD=MARÓ

<

<

< Tried          fits           = 37888

< Matching       fits found     = 120

<

< Start of fit lists and results:

<

< Solution       #              = 1

< Solution       fitted         = M=4, Ó=3, D=9, R=0, J=6, A=5, L=8, B=1, K=2, K=2, B=1, L=8, A=5, J=6, R=0, D=9, Ó=3, M=4.

< Solution       got            = 1034+2830+639=4503

<

<

< Solution       #              = 2

< Solution       fitted         = M=4, Ó=3, D=9, R=0, J=6, A=5, L=8, B=2, K=1, K=1, B=2, L=8, A=5, J=6, R=0, D=9, Ó=3, M=4.

< Solution       got            = 2034+1830+639=4503

<

<

< Solution       #              = 3

< Solution       fitted         = M=4, Ó=3, D=9, R=0, J=7, A=6, L=8, B=1, K=2, K=2, B=1, L=8, A=6, J=7, R=0, D=9, Ó=3, M=4.

< Solution       got            = 1034+2830+739=4603

<

<

< Solution       #              = 4

< Solution       fitted         = M=4, Ó=3, D=9, R=0, J=7, A=6, L=8, B=2, K=1, K=1, B=2, L=8, A=6, J=7, R=0, D=9, Ó=3, M=4.

< Solution       got            = 2034+1830+739=4603

<

<

< Solution       #              = 5

< Solution       fitted         = M=4, Ó=3, D=9, R=0, J=8, A=5, L=6, B=1, K=2, K=2, B=1, L=6, A=5, J=8, R=0, D=9, Ó=3, M=4.

< Solution       got            = 1034+2630+839=4503

<

<

< Solution       #              = 6

< Solution       fitted         = M=4, Ó=3, D=9, R=0, J=8, A=5, L=6, B=2, K=1, K=1, B=2, L=6, A=5, J=8, R=0, D=9, Ó=3, M=4.

< Solution       got            = 2034+1630+839=4503

<

<

< Solution       #              = 7

< Solution       fitted         = M=4, Ó=3, D=9, R=0, J=8, A=6, L=7, B=1, K=2, K=2, B=1, L=7, A=6, J=8, R=0, D=9, Ó=3, M=4.

< Solution       got            = 1034+2730+839=4603

<

<

< Solution       #              = 8

< Solution       fitted         = M=4, Ó=3, D=9, R=0, J=8, A=6, L=7, B=2, K=1, K=1, B=2, L=7, A=6, J=8, R=0, D=9, Ó=3, M=4.

< Solution       got            = 2034+1730+839=4603

<

<

< Solution       #              = 9

< Solution       fitted         = M=4, Ó=8, D=9, R=5, J=6, A=3, L=0, B=1, K=2, K=2, B=1, L=0, A=3, J=6, R=5, D=9, Ó=8, M=4.

< Solution       got            = 1584+2085+689=4358

<

<

< Solution       #              = 10

< Solution       fitted         = M=4, Ó=8, D=9, R=5, J=6, A=3, L=0, B=2, K=1, K=1, B=2, L=0, A=3, J=6, R=5, D=9, Ó=8, M=4.

< Solution       got            = 2584+1085+689=4358

<

<

< Solution       #              = 11

< Solution       fitted         = M=5, Ó=2, D=0, R=7, J=4, A=9, L=8, B=1, K=3, K=3, B=1, L=8, A=9, J=4, R=7, D=0, Ó=2, M=5.

< Solution       got            = 1725+3827+420=5972

<

<

< Solution       #              = 12

< Solution       fitted         = M=5, Ó=2, D=0, R=7, J=4, A=9, L=8, B=3, K=1, K=1, B=3, L=8, A=9, J=4, R=7, D=0, Ó=2, M=5.

< Solution       got            = 3725+1827+420=5972

<

<

< Solution       #              = 13

< Solution       fitted         = M=5, Ó=2, D=0, R=7, J=8, A=9, L=4, B=1, K=3, K=3, B=1, L=4, A=9, J=8, R=7, D=0, Ó=2, M=5.

< Solution       got            = 1725+3427+820=5972

<

<

< Solution       #              = 14

< Solution       fitted         = M=5, Ó=2, D=0, R=7, J=8, A=9, L=4, B=3, K=1, K=1, B=3, L=4, A=9, J=8, R=7, D=0, Ó=2, M=5.

< Solution       got            = 3725+1427+820=5972

<

<

< Solution       #              = 15

< Solution       fitted         = M=5, Ó=2, D=9, R=8, J=6, A=4, L=0, B=1, K=3, K=3, B=1, L=0, A=4, J=6, R=8, D=9, Ó=2, M=5.

< Solution       got            = 1825+3028+629=5482

<

<

< Solution       #              = 16

< Solution       fitted         = M=5, Ó=2, D=9, R=8, J=6, A=4, L=0, B=3, K=1, K=1, B=3, L=0, A=4, J=6, R=8, D=9, Ó=2, M=5.

< Solution       got            = 3825+1028+629=5482

<

<

< Solution       #              = 17

< Solution       fitted         = M=5, Ó=3, D=8, R=0, J=2, A=9, L=6, B=1, K=4, K=4, B=1, L=6, A=9, J=2, R=0, D=8, Ó=3, M=5.

< Solution       got            = 1035+4630+238=5903

<

<

< Solution       #              = 18

< Solution       fitted         = M=5, Ó=3, D=8, R=0, J=2, A=9, L=6, B=4, K=1, K=1, B=4, L=6, A=9, J=2, R=0, D=8, Ó=3, M=5.

< Solution       got            = 4035+1630+238=5903

<

<

< Solution       #              = 19

< Solution       fitted         = M=5, Ó=3, D=8, R=0, J=6, A=9, L=2, B=1, K=4, K=4, B=1, L=2, A=9, J=6, R=0, D=8, Ó=3, M=5.

< Solution       got            = 1035+4230+638=5903

<

<

< Solution       #              = 20

< Solution       fitted         = M=5, Ó=3, D=8, R=0, J=6, A=9, L=2, B=4, K=1, K=1, B=4, L=2, A=9, J=6, R=0, D=8, Ó=3, M=5.

< Solution       got            = 4035+1230+638=5903

<

<

< Solution       #              = 21

< Solution       fitted         = M=5, Ó=4, D=6, R=3, J=7, A=0, L=9, B=1, K=2, K=2, B=1, L=9, A=0, J=7, R=3, D=6, Ó=4, M=5.

< Solution       got            = 1345+2943+746=5034

<

<

< Solution       #              = 22

< Solution       fitted         = M=5, Ó=4, D=6, R=3, J=7, A=0, L=9, B=2, K=1, K=1, B=2, L=9, A=0, J=7, R=3, D=6, Ó=4, M=5.

< Solution       got            = 2345+1943+746=5034

<

<

< Solution       #              = 23

< Solution       fitted         = M=5, Ó=4, D=6, R=3, J=9, A=0, L=7, B=1, K=2, K=2, B=1, L=7, A=0, J=9, R=3, D=6, Ó=4, M=5.

< Solution       got            = 1345+2743+946=5034

<

<

< Solution       #              = 24

< Solution       fitted         = M=5, Ó=4, D=6, R=3, J=9, A=0, L=7, B=2, K=1, K=1, B=2, L=7, A=0, J=9, R=3, D=6, Ó=4, M=5.

< Solution       got            = 2345+1743+946=5034

<

<

< Solution       #              = 25

< Solution       fitted         = M=5, Ó=9, D=6, R=8, J=3, A=0, L=7, B=1, K=2, K=2, B=1, L=7, A=0, J=3, R=8, D=6, Ó=9, M=5.

< Solution       got            = 1895+2798+396=5089

<

<

< Solution       #              = 26

< Solution       fitted         = M=5, Ó=9, D=6, R=8, J=3, A=0, L=7, B=2, K=1, K=1, B=2, L=7, A=0, J=3, R=8, D=6, Ó=9, M=5.

< Solution       got            = 2895+1798+396=5089

<

<

< Solution       #              = 27

< Solution       fitted         = M=5, Ó=9, D=6, R=8, J=7, A=0, L=3, B=1, K=2, K=2, B=1, L=3, A=0, J=7, R=8, D=6, Ó=9, M=5.

< Solution       got            = 1895+2398+796=5089

<

<

< Solution       #              = 28

< Solution       fitted         = M=5, Ó=9, D=6, R=8, J=7, A=0, L=3, B=2, K=1, K=1, B=2, L=3, A=0, J=7, R=8, D=6, Ó=9, M=5.

< Solution       got            = 2895+1398+796=5089

<

<

< Solution       #              = 29

< Solution       fitted         = M=6, Ó=7, D=0, R=1, J=4, A=5, L=8, B=2, K=3, K=3, B=2, L=8, A=5, J=4, R=1, D=0, Ó=7, M=6.

< Solution       got            = 2176+3871+470=6517

<

<

< Solution       #              = 30

< Solution       fitted         = M=6, Ó=7, D=0, R=1, J=4, A=5, L=8, B=3, K=2, K=2, B=3, L=8, A=5, J=4, R=1, D=0, Ó=7, M=6.

< Solution       got            = 3176+2871+470=6517

<

<

< Solution       #              = 31

< Solution       fitted         = M=6, Ó=7, D=0, R=1, J=8, A=5, L=4, B=2, K=3, K=3, B=2, L=4, A=5, J=8, R=1, D=0, Ó=7, M=6.

< Solution       got            = 2176+3471+870=6517

<

<

< Solution       #              = 32

< Solution       fitted         = M=6, Ó=7, D=0, R=1, J=8, A=5, L=4, B=3, K=2, K=2, B=3, L=4, A=5, J=8, R=1, D=0, Ó=7, M=6.

< Solution       got            = 3176+2471+870=6517

<

<

< Solution       #              = 33

< Solution       fitted         = M=6, Ó=7, D=9, R=2, J=3, A=5, L=8, B=1, K=4, K=4, B=1, L=8, A=5, J=3, R=2, D=9, Ó=7, M=6.

< Solution       got            = 1276+4872+379=6527

<

<

< Solution       #              = 34

< Solution       fitted         = M=6, Ó=7, D=9, R=2, J=3, A=5, L=8, B=4, K=1, K=1, B=4, L=8, A=5, J=3, R=2, D=9, Ó=7, M=6.

< Solution       got            = 4276+1872+379=6527

<

<

< Solution       #              = 35

< Solution       fitted         = M=6, Ó=7, D=9, R=2, J=4, A=8, L=0, B=1, K=5, K=5, B=1, L=0, A=8, J=4, R=2, D=9, Ó=7, M=6.

< Solution       got            = 1276+5072+479=6827

<

<

< Solution       #              = 36

< Solution       fitted         = M=6, Ó=7, D=9, R=2, J=4, A=8, L=0, B=5, K=1, K=1, B=5, L=0, A=8, J=4, R=2, D=9, Ó=7, M=6.

< Solution       got            = 5276+1072+479=6827

<

<

< Solution       #              = 37

< Solution       fitted         = M=6, Ó=7, D=9, R=2, J=8, A=5, L=3, B=1, K=4, K=4, B=1, L=3, A=5, J=8, R=2, D=9, Ó=7, M=6.

< Solution       got            = 1276+4372+879=6527

<

<

< Solution       #              = 38

< Solution       fitted         = M=6, Ó=7, D=9, R=2, J=8, A=5, L=3, B=4, K=1, K=1, B=4, L=3, A=5, J=8, R=2, D=9, Ó=7, M=6.

< Solution       got            = 4276+1372+879=6527

<

<

< Solution       #              = 39

< Solution       fitted         = M=6, Ó=8, D=7, R=5, J=4, A=0, L=9, B=1, K=3, K=3, B=1, L=9, A=0, J=4, R=5, D=7, Ó=8, M=6.

< Solution       got            = 1586+3985+487=6058

<

<

< Solution       #              = 40

< Solution       fitted         = M=6, Ó=8, D=7, R=5, J=4, A=0, L=9, B=3, K=1, K=1, B=3, L=9, A=0, J=4, R=5, D=7, Ó=8, M=6.

< Solution       got            = 3586+1985+487=6058

<

<

< Solution       #              = 41

< Solution       fitted         = M=6, Ó=8, D=7, R=5, J=4, A=1, L=0, B=2, K=3, K=3, B=2, L=0, A=1, J=4, R=5, D=7, Ó=8, M=6.

< Solution       got            = 2586+3085+487=6158

<

<

< Solution       #              = 42

< Solution       fitted         = M=6, Ó=8, D=7, R=5, J=4, A=1, L=0, B=3, K=2, K=2, B=3, L=0, A=1, J=4, R=5, D=7, Ó=8, M=6.

< Solution       got            = 3586+2085+487=6158

<

<

< Solution       #              = 43

< Solution       fitted         = M=6, Ó=8, D=7, R=5, J=9, A=0, L=4, B=1, K=3, K=3, B=1, L=4, A=0, J=9, R=5, D=7, Ó=8, M=6.

< Solution       got            = 1586+3485+987=6058

<

<

< Solution       #              = 44

< Solution       fitted         = M=6, Ó=8, D=7, R=5, J=9, A=0, L=4, B=3, K=1, K=1, B=3, L=4, A=0, J=9, R=5, D=7, Ó=8, M=6.

< Solution       got            = 3586+1485+987=6058

<

<

< Solution       #              = 45

< Solution       fitted         = M=7, Ó=1, D=9, R=5, J=3, A=6, L=8, B=2, K=4, K=4, B=2, L=8, A=6, J=3, R=5, D=9, Ó=1, M=7.

< Solution       got            = 2517+4815+319=7651

<

<

< Solution       #              = 46

< Solution       fitted         = M=7, Ó=1, D=9, R=5, J=3, A=6, L=8, B=4, K=2, K=2, B=4, L=8, A=6, J=3, R=5, D=9, Ó=1, M=7.

< Solution       got            = 4517+2815+319=7651

<

<

< Solution       #              = 47

< Solution       fitted         = M=7, Ó=1, D=9, R=5, J=8, A=3, L=0, B=2, K=4, K=4, B=2, L=0, A=3, J=8, R=5, D=9, Ó=1, M=7.

< Solution       got            = 2517+4015+819=7351

<

<

< Solution       #              = 48

< Solution       fitted         = M=7, Ó=1, D=9, R=5, J=8, A=3, L=0, B=4, K=2, K=2, B=4, L=0, A=3, J=8, R=5, D=9, Ó=1, M=7.

< Solution       got            = 4517+2015+819=7351

<

<

< Solution       #              = 49

< Solution       fitted         = M=7, Ó=1, D=9, R=5, J=8, A=6, L=3, B=2, K=4, K=4, B=2, L=3, A=6, J=8, R=5, D=9, Ó=1, M=7.

< Solution       got            = 2517+4315+819=7651

<

<

< Solution       #              = 50

< Solution       fitted         = M=7, Ó=1, D=9, R=5, J=8, A=6, L=3, B=4, K=2, K=2, B=4, L=3, A=6, J=8, R=5, D=9, Ó=1, M=7.

< Solution       got            = 4517+2315+819=7651

<

<

< Solution       #              = 51

< Solution       fitted         = M=7, Ó=5, D=2, R=6, J=1, A=8, L=0, B=3, K=4, K=4, B=3, L=0, A=8, J=1, R=6, D=2, Ó=5, M=7.

< Solution       got            = 3657+4056+152=7865

<

<

< Solution       #              = 52

< Solution       fitted         = M=7, Ó=5, D=2, R=6, J=1, A=8, L=0, B=4, K=3, K=3, B=4, L=0, A=8, J=1, R=6, D=2, Ó=5, M=7.

< Solution       got            = 4657+3056+152=7865

<

<

< Solution       #              = 53

< Solution       fitted         = M=7, Ó=6, D=0, R=9, J=3, A=8, L=5, B=2, K=4, K=4, B=2, L=5, A=8, J=3, R=9, D=0, Ó=6, M=7.

< Solution       got            = 2967+4569+360=7896

<

<

< Solution       #              = 54

< Solution       fitted         = M=7, Ó=6, D=0, R=9, J=3, A=8, L=5, B=4, K=2, K=2, B=4, L=5, A=8, J=3, R=9, D=0, Ó=6, M=7.

< Solution       got            = 4967+2569+360=7896

<

<

< Solution       #              = 55

< Solution       fitted         = M=7, Ó=6, D=0, R=9, J=5, A=3, L=8, B=1, K=4, K=4, B=1, L=8, A=3, J=5, R=9, D=0, Ó=6, M=7.

< Solution       got            = 1967+4869+560=7396

<

<

< Solution       #              = 56

< Solution       fitted         = M=7, Ó=6, D=0, R=9, J=5, A=3, L=8, B=4, K=1, K=1, B=4, L=8, A=3, J=5, R=9, D=0, Ó=6, M=7.

< Solution       got            = 4967+1869+560=7396

<

<

< Solution       #              = 57

< Solution       fitted         = M=7, Ó=6, D=0, R=9, J=5, A=8, L=3, B=2, K=4, K=4, B=2, L=3, A=8, J=5, R=9, D=0, Ó=6, M=7.

< Solution       got            = 2967+4369+560=7896

<

<

< Solution       #              = 58

< Solution       fitted         = M=7, Ó=6, D=0, R=9, J=5, A=8, L=3, B=4, K=2, K=2, B=4, L=3, A=8, J=5, R=9, D=0, Ó=6, M=7.

< Solution       got            = 4967+2369+560=7896

<

<

< Solution       #              = 59

< Solution       fitted         = M=7, Ó=6, D=0, R=9, J=8, A=3, L=5, B=1, K=4, K=4, B=1, L=5, A=3, J=8, R=9, D=0, Ó=6, M=7.

< Solution       got            = 1967+4569+860=7396

<

<

< Solution       #              = 60

< Solution       fitted         = M=7, Ó=6, D=0, R=9, J=8, A=3, L=5, B=4, K=1, K=1, B=4, L=5, A=3, J=8, R=9, D=0, Ó=6, M=7.

< Solution       got            = 4967+1569+860=7396

<

<

< Solution       #              = 61

< Solution       fitted         = M=7, Ó=8, D=6, R=5, J=2, A=9, L=0, B=3, K=4, K=4, B=3, L=0, A=9, J=2, R=5, D=6, Ó=8, M=7.

< Solution       got            = 3587+4085+286=7958

<

<

< Solution       #              = 62

< Solution       fitted         = M=7, Ó=8, D=6, R=5, J=2, A=9, L=0, B=4, K=3, K=3, B=4, L=0, A=9, J=2, R=5, D=6, Ó=8, M=7.

< Solution       got            = 4587+3085+286=7958

<

<

< Solution       #              = 63

< Solution       fitted         = M=7, Ó=8, D=6, R=5, J=4, A=0, L=9, B=2, K=3, K=3, B=2, L=9, A=0, J=4, R=5, D=6, Ó=8, M=7.

< Solution       got            = 2587+3985+486=7058

<

<

< Solution       #              = 64

< Solution       fitted         = M=7, Ó=8, D=6, R=5, J=4, A=0, L=9, B=3, K=2, K=2, B=3, L=9, A=0, J=4, R=5, D=6, Ó=8, M=7.

< Solution       got            = 3587+2985+486=7058

<

<

< Solution       #              = 65

< Solution       fitted         = M=7, Ó=8, D=6, R=5, J=9, A=0, L=4, B=2, K=3, K=3, B=2, L=4, A=0, J=9, R=5, D=6, Ó=8, M=7.

< Solution       got            = 2587+3485+986=7058

<

<

< Solution       #              = 66

< Solution       fitted         = M=7, Ó=8, D=6, R=5, J=9, A=0, L=4, B=3, K=2, K=2, B=3, L=4, A=0, J=9, R=5, D=6, Ó=8, M=7.

< Solution       got            = 3587+2485+986=7058

<

<

< Solution       #              = 67

< Solution       fitted         = M=7, Ó=9, D=4, R=8, J=5, A=1, L=6, B=2, K=3, K=3, B=2, L=6, A=1, J=5, R=8, D=4, Ó=9, M=7.

< Solution       got            = 2897+3698+594=7189

<

<

< Solution       #              = 68

< Solution       fitted         = M=7, Ó=9, D=4, R=8, J=5, A=1, L=6, B=3, K=2, K=2, B=3, L=6, A=1, J=5, R=8, D=4, Ó=9, M=7.

< Solution       got            = 3897+2698+594=7189

<

<

< Solution       #              = 69

< Solution       fitted         = M=7, Ó=9, D=4, R=8, J=6, A=1, L=5, B=2, K=3, K=3, B=2, L=5, A=1, J=6, R=8, D=4, Ó=9, M=7.

< Solution       got            = 2897+3598+694=7189

<

<

< Solution       #              = 70

< Solution       fitted         = M=7, Ó=9, D=4, R=8, J=6, A=1, L=5, B=3, K=2, K=2, B=3, L=5, A=1, J=6, R=8, D=4, Ó=9, M=7.

< Solution       got            = 3897+2598+694=7189

<

<

< Solution       #              = 71

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=1, A=9, L=7, B=2, K=6, K=6, B=2, L=7, A=9, J=1, R=0, D=5, Ó=3, M=8.

< Solution       got            = 2038+6730+135=8903

<

<

< Solution       #              = 72

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=1, A=9, L=7, B=6, K=2, K=2, B=6, L=7, A=9, J=1, R=0, D=5, Ó=3, M=8.

< Solution       got            = 6038+2730+135=8903

<

<

< Solution       #              = 73

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=2, A=9, L=6, B=1, K=7, K=7, B=1, L=6, A=9, J=2, R=0, D=5, Ó=3, M=8.

< Solution       got            = 1038+7630+235=8903

<

<

< Solution       #              = 74

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=2, A=9, L=6, B=7, K=1, K=1, B=7, L=6, A=9, J=2, R=0, D=5, Ó=3, M=8.

< Solution       got            = 7038+1630+235=8903

<

<

< Solution       #              = 75

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=4, A=2, L=7, B=1, K=6, K=6, B=1, L=7, A=2, J=4, R=0, D=5, Ó=3, M=8.

< Solution       got            = 1038+6730+435=8203

<

<

< Solution       #              = 76

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=4, A=2, L=7, B=6, K=1, K=1, B=6, L=7, A=2, J=4, R=0, D=5, Ó=3, M=8.

< Solution       got            = 6038+1730+435=8203

<

<

< Solution       #              = 77

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=6, A=9, L=2, B=1, K=7, K=7, B=1, L=2, A=9, J=6, R=0, D=5, Ó=3, M=8.

< Solution       got            = 1038+7230+635=8903

<

<

< Solution       #              = 78

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=6, A=9, L=2, B=7, K=1, K=1, B=7, L=2, A=9, J=6, R=0, D=5, Ó=3, M=8.

< Solution       got            = 7038+1230+635=8903

<

<

< Solution       #              = 79

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=7, A=2, L=4, B=1, K=6, K=6, B=1, L=4, A=2, J=7, R=0, D=5, Ó=3, M=8.

< Solution       got            = 1038+6430+735=8203

<

<

< Solution       #              = 80

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=7, A=2, L=4, B=6, K=1, K=1, B=6, L=4, A=2, J=7, R=0, D=5, Ó=3, M=8.

< Solution       got            = 6038+1430+735=8203

<

<

< Solution       #              = 81

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=7, A=9, L=1, B=2, K=6, K=6, B=2, L=1, A=9, J=7, R=0, D=5, Ó=3, M=8.

< Solution       got            = 2038+6130+735=8903

<

<

< Solution       #              = 82

< Solution       fitted         = M=8, Ó=3, D=5, R=0, J=7, A=9, L=1, B=6, K=2, K=2, B=6, L=1, A=9, J=7, R=0, D=5, Ó=3, M=8.

< Solution       got            = 6038+2130+735=8903

<

<

< Solution       #              = 83

< Solution       fitted         = M=8, Ó=5, D=1, R=6, J=7, A=3, L=9, B=2, K=4, K=4, B=2, L=9, A=3, J=7, R=6, D=1, Ó=5, M=8.

< Solution       got            = 2658+4956+751=8365

<

<

< Solution       #              = 84

< Solution       fitted         = M=8, Ó=5, D=1, R=6, J=7, A=3, L=9, B=4, K=2, K=2, B=4, L=9, A=3, J=7, R=6, D=1, Ó=5, M=8.

< Solution       got            = 4658+2956+751=8365

<

<

< Solution       #              = 85

< Solution       fitted         = M=8, Ó=5, D=1, R=6, J=9, A=3, L=7, B=2, K=4, K=4, B=2, L=7, A=3, J=9, R=6, D=1, Ó=5, M=8.

< Solution       got            = 2658+4756+951=8365

<

<

< Solution       #              = 86

< Solution       fitted         = M=8, Ó=5, D=1, R=6, J=9, A=3, L=7, B=4, K=2, K=2, B=4, L=7, A=3, J=9, R=6, D=1, Ó=5, M=8.

< Solution       got            = 4658+2756+951=8365

<

<

< Solution       #              = 87

< Solution       fitted         = M=9, Ó=1, D=7, R=5, J=8, A=3, L=0, B=2, K=6, K=6, B=2, L=0, A=3, J=8, R=5, D=7, Ó=1, M=9.

< Solution       got            = 2519+6015+817=9351

<

<

< Solution       #              = 88

< Solution       fitted         = M=9, Ó=1, D=7, R=5, J=8, A=3, L=0, B=6, K=2, K=2, B=6, L=0, A=3, J=8, R=5, D=7, Ó=1, M=9.

< Solution       got            = 6519+2015+817=9351

<

<

< Solution       #              = 89

< Solution       fitted         = M=9, Ó=2, D=5, R=8, J=6, A=1, L=7, B=3, K=4, K=4, B=3, L=7, A=1, J=6, R=8, D=5, Ó=2, M=9.

< Solution       got            = 3829+4728+625=9182

<

<

< Solution       #              = 90

< Solution       fitted         = M=9, Ó=2, D=5, R=8, J=6, A=1, L=7, B=4, K=3, K=3, B=4, L=7, A=1, J=6, R=8, D=5, Ó=2, M=9.

< Solution       got            = 4829+3728+625=9182

<

<

< Solution       #              = 91

< Solution       fitted         = M=9, Ó=2, D=5, R=8, J=6, A=4, L=0, B=1, K=7, K=7, B=1, L=0, A=4, J=6, R=8, D=5, Ó=2, M=9.

< Solution       got            = 1829+7028+625=9482

<

<

< Solution       #              = 92

< Solution       fitted         = M=9, Ó=2, D=5, R=8, J=6, A=4, L=0, B=7, K=1, K=1, B=7, L=0, A=4, J=6, R=8, D=5, Ó=2, M=9.

< Solution       got            = 7829+1028+625=9482

<

<

< Solution       #              = 93

< Solution       fitted         = M=9, Ó=2, D=5, R=8, J=7, A=1, L=6, B=3, K=4, K=4, B=3, L=6, A=1, J=7, R=8, D=5, Ó=2, M=9.

< Solution       got            = 3829+4628+725=9182

<

<

< Solution       #              = 94

< Solution       fitted         = M=9, Ó=2, D=5, R=8, J=7, A=1, L=6, B=4, K=3, K=3, B=4, L=6, A=1, J=7, R=8, D=5, Ó=2, M=9.

< Solution       got            = 4829+3628+725=9182

<

<

< Solution       #              = 95

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=1, A=8, L=6, B=2, K=7, K=7, B=2, L=6, A=8, J=1, R=0, D=4, Ó=3, M=9.

< Solution       got            = 2039+7630+134=9803

<

<

< Solution       #              = 96

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=1, A=8, L=6, B=7, K=2, K=2, B=7, L=6, A=8, J=1, R=0, D=4, Ó=3, M=9.

< Solution       got            = 7039+2630+134=9803

<

<

< Solution       #              = 97

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=5, A=2, L=6, B=1, K=7, K=7, B=1, L=6, A=2, J=5, R=0, D=4, Ó=3, M=9.

< Solution       got            = 1039+7630+534=9203

<

<

< Solution       #              = 98

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=5, A=2, L=6, B=7, K=1, K=1, B=7, L=6, A=2, J=5, R=0, D=4, Ó=3, M=9.

< Solution       got            = 7039+1630+534=9203

<

<

< Solution       #              = 99

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=2, L=5, B=1, K=7, K=7, B=1, L=5, A=2, J=6, R=0, D=4, Ó=3, M=9.

< Solution       got            = 1039+7530+634=9203

<

<

< Solution       #              = 100

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=2, L=5, B=7, K=1, K=1, B=7, L=5, A=2, J=6, R=0, D=4, Ó=3, M=9.

< Solution       got            = 7039+1530+634=9203

<

<

< Solution       #              = 101

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=5, L=8, B=1, K=7, K=7, B=1, L=8, A=5, J=6, R=0, D=4, Ó=3, M=9.

< Solution       got            = 1039+7830+634=9503

<

<

< Solution       #              = 102

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=5, L=8, B=7, K=1, K=1, B=7, L=8, A=5, J=6, R=0, D=4, Ó=3, M=9.

< Solution       got            = 7039+1830+634=9503

<

<

< Solution       #              = 103

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=8, L=1, B=2, K=7, K=7, B=2, L=1, A=8, J=6, R=0, D=4, Ó=3, M=9.

< Solution       got            = 2039+7130+634=9803

<

<

< Solution       #              = 104

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=6, A=8, L=1, B=7, K=2, K=2, B=7, L=1, A=8, J=6, R=0, D=4, Ó=3, M=9.

< Solution       got            = 7039+2130+634=9803

<

<

< Solution       #              = 105

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=8, A=5, L=6, B=1, K=7, K=7, B=1, L=6, A=5, J=8, R=0, D=4, Ó=3, M=9.

< Solution       got            = 1039+7630+834=9503

<

<

< Solution       #              = 106

< Solution       fitted         = M=9, Ó=3, D=4, R=0, J=8, A=5, L=6, B=7, K=1, K=1, B=7, L=6, A=5, J=8, R=0, D=4, Ó=3, M=9.

< Solution       got            = 7039+1630+834=9503

<

<

< Solution       #              = 107

< Solution       fitted         = M=9, Ó=5, D=0, R=6, J=2, A=3, L=4, B=1, K=7, K=7, B=1, L=4, A=3, J=2, R=6, D=0, Ó=5, M=9.

< Solution       got            = 1659+7456+250=9365

<

<

< Solution       #              = 108

< Solution       fitted         = M=9, Ó=5, D=0, R=6, J=2, A=3, L=4, B=7, K=1, K=1, B=7, L=4, A=3, J=2, R=6, D=0, Ó=5, M=9.

< Solution       got            = 7659+1456+250=9365

<

<

< Solution       #              = 109

< Solution       fitted         = M=9, Ó=5, D=0, R=6, J=4, A=3, L=2, B=1, K=7, K=7, B=1, L=2, A=3, J=4, R=6, D=0, Ó=5, M=9.

< Solution       got            = 1659+7256+450=9365

<

<

< Solution       #              = 110

< Solution       fitted         = M=9, Ó=5, D=0, R=6, J=4, A=3, L=2, B=7, K=1, K=1, B=7, L=2, A=3, J=4, R=6, D=0, Ó=5, M=9.

< Solution       got            = 7659+1256+450=9365

<

<

< Solution       #              = 111

< Solution       fitted         = M=9, Ó=5, D=0, R=6, J=7, A=2, L=8, B=3, K=4, K=4, B=3, L=8, A=2, J=7, R=6, D=0, Ó=5, M=9.

< Solution       got            = 3659+4856+750=9265

<

<

< Solution       #              = 112

< Solution       fitted         = M=9, Ó=5, D=0, R=6, J=7, A=2, L=8, B=4, K=3, K=3, B=4, L=8, A=2, J=7, R=6, D=0, Ó=5, M=9.

< Solution       got            = 4659+3856+750=9265

<

<

< Solution       #              = 113

< Solution       fitted         = M=9, Ó=5, D=0, R=6, J=8, A=2, L=7, B=3, K=4, K=4, B=3, L=7, A=2, J=8, R=6, D=0, Ó=5, M=9.

< Solution       got            = 3659+4756+850=9265

<

<

< Solution       #              = 114

< Solution       fitted         = M=9, Ó=5, D=0, R=6, J=8, A=2, L=7, B=4, K=3, K=3, B=4, L=7, A=2, J=8, R=6, D=0, Ó=5, M=9.

< Solution       got            = 4659+3756+850=9265

<

<

< Solution       #              = 115

< Solution       fitted         = M=9, Ó=7, D=6, R=2, J=1, A=8, L=3, B=4, K=5, K=5, B=4, L=3, A=8, J=1, R=2, D=6, Ó=7, M=9.

< Solution       got            = 4279+5372+176=9827

<

<

< Solution       #              = 116

< Solution       fitted         = M=9, Ó=7, D=6, R=2, J=1, A=8, L=3, B=5, K=4, K=4, B=5, L=3, A=8, J=1, R=2, D=6, Ó=7, M=9.

< Solution       got            = 5279+4372+176=9827

<

<

< Solution       #              = 117

< Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=4, K=5, K=5, B=4, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.

< Solution       got            = 4279+5172+376=9827

<

<

< Solution       #              = 118

< Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=5, K=4, K=4, B=5, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.

< Solution       got            = 5279+4172+376=9827

<

<

< Solution       #              = 119

< Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=1, K=7, K=7, B=1, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.

< Solution       got            = 1589+7085+684=9358

<

<

< Solution       #              = 120

< Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=7, K=1, K=1, B=7, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.

< Solution       got            = 7589+1085+684=9358

<

<

< End of fit lists and results.

< 2010. január 4. 8:58:45

< Action         = closed         file »magyarok00.aps« in folder »D:\Feri\SOAP\Results\«.

< =3, B=5, K=4, K=4, B=5, L=3, A=8, J=1, R=2, D=6, Ó=7, M=9.

< Solution       got            = 5279+4372+176=9827

<

<

< Solution       #              = 117

< Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=4, K=5, K=5, B=4, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.

< Solution       got            = 4279+5172+376=9827

<

<

< Solution       #              = 118

< Solution       fitted         = M=9, Ó=7, D=6, R=2, J=3, A=8, L=1, B=5, K=4, K=4, B=5, L=1, A=8, J=3, R=2, D=6, Ó=7, M=9.

< Solution       got            = 5279+4172+376=9827

<

<

< Solution       #              = 119

< Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=1, K=7, K=7, B=1, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.

< Solution       got            = 1589+7085+684=9358

<

<

< Solution       #              = 120

< Solution       fitted         = M=9, Ó=8, D=4, R=5, J=6, A=3, L=0, B=7, K=1, K=1, B=7, L=0, A=3, J=6, R=5, D=4, Ó=8, M=9.

< Solution       got            = 7589+1085+684=9358

<

<

< End of fit lists and results.

< 2010. január 4. 8:46:40

< Action         = closed         file »magyarok00.aps« in folder »D:\Feri\SOAP\Results\«.


Hot Keys
The program can be commanded by hot keys to execute the most important tasks.
q Invoking submenus
q Invoking submenu items
q Editing and formatting messages
q Editing and exiting dialogs


Hot Keys Invoking Submenus
The submenus of the program can be invoked by keyboard shortcuts.
Key | Modifier | Submenu
F | Alt | File
O | Alt | Options
W | Alt | Window
H | Alt | Help


Hot Keys Corresponding Menu Items
See also: Hot Keys
The following hot keys invoke the submenu items from everywhere.
Key | Modifier | Submenu==>Item
F1 | Nothing | Help ==>Local
F1 | Alt | Help==>Hot Keys
F1 | Control | Help==>Contents
F1 | Shift | Help==>Menu System
F2 | Nothing | File ==>Save
F3 | Nothing | Options==> Search
F4 | Alt | File==>Exit
F4 | Nothing | Options==> Output
F5 | Nothing | File ==>Show
F7 | Nothing | File==>New
F8 | Nothing | File==>Open
F9 | Nothing | File==>Process
F10 | Nothing | File==>Close
F11 | Control | Help ==>About
F12 | Nothing | File ==>Save As

The submenu items may be called by pressing the underlined characters in the dropped down state of submenu. These hot keys are listed in the chapters describing the submenus.


Hot Keys within the "Messages" Window

Key | Modifier | Action
C | Control | Copy selection
Del | Nothing | Delete selection
X | Control | Cut selection
V | Control | Paste from clipboard


Hot Keys for Other Purposes
If some text is selected within the input fields of the dialogs then the usual editing hot keys are available.
Key | Modifier | Action
C | Control | Copy selection
Del | Nothing | Delete selection
X | Control | Cut selection
V | Control | Paste from clipboard
Enter ¿ | None | Confirm dialog
Esc | None | Escape from dialog


About the Author
E-mail:
nagy.frank@citromail.hu

Home address:
H-1102 BUDAPEST Hölgy u. 48. I. 8
Phone:
+36-1-262-1198 with answering machine
+36-20-5251065
Family:
I am married. I have two adult daughters and four grandsons.
Home page:
http://franknagy.atw.hu


Programming Considerations
This chapter summarizes the programming considerations used during the development of the SOAP program.
The negotiated subjects are
A operation system
B programming language
C utilities used for development
D object model of the program.


Operation System
The operation system is Windows XP ®.


Programming Language
The programming language is Visual Prolog 7.2. The Personal Edition was used.
About screen of the used version
Copyright (c) 1984 - 2008 Prolog Development Center A/S
H.J.Holst Vej 3-5C
- 2605 Broendby, Denmark
Tel + 45 3636 0000
FAX + 45 3636 0001

E-mail: sales@visual-prolog.com
URL: http://www.visual-prolog.com
http://www.pdc.dk

Why Visual Prolog?

The author has been dealt with different versions of prolog, like Turbo Prolog 0.0 to 2.0, PDC Prolog 3.0, Visual Prolog 4.0 to 5.2 since 1988. He has chosen the task Solver of Alphametic Puzzles as a tool to get acquainted with the latest version of Visual Prolog, and remain in programming practice as well.


Utilities Used for Development
The global searches, file comparisons and the handling of Unicode input and output files were made by the TextPad program http://www.textpad.com/support/ .
The used version communicated in Polish language.

The pictures were collected and handled by IrfanView .
About IfranView T

The on-line help was written using
HelpMaker VII
This is Licensed Material and the Property of Vizacc.
Copyright © 2008-2010 by Vizacc. All rights reserved.
Copyright © 1998-2007 by Vizacc. All rights reserved.
The product version is: 7.4.4 Beta Release

The vendor is:
Vizacc
Po Box 147
Woodlands Central Post Office,
900 Woodland Civic Centre #02-05
Singapore 730900

Support Options:
Website: www.vizacc.com
Forum: www.vizacc.com/nntp2/
Email: vizacc.com/nntp2/sendmessage.php
NNTP: news.vizacc.com


Object Model
See also: Folders
The program is object oriented as required in Visual Prolog.
The building of the classes by support keywords is shown below.
Class | Supports | Purpose
main |  | This module starts the program. It creates the Task Window .
word | word | Word to be substituted. Word whose characters have to be substituted by decimal digits.
words |  | Words without factors on the same side of the equation.
product | word | Product of a factor and a word.
products | words, product | Products with factors on the same side of the equation.
equation |  | Parsing, validation and solution of alphametic equations. See Classification of "Alphametic Puzzles"
solver |  | Solution of parsed and classified equations. See Simplification of the Equations and Their Further Classification
mystring |  | Typical string handling for the project used in parsing of raw texts and reporting of solutions
mylist |  | Additional list handling predicates. (Frequencies of repeated elements, so on.)
mymath |  | Mathematical predicates for the project.
combinatorics |  | Combinatoric unctions like factorial(N) so on.
myhelp |  | Providing context sensitive help for the program.
taskWindow | applicationWindow | Task window for validation and solution of alphametic equations. Handles the Menu System .
statusLine |  | Displaying messages about the chosen control of the current dialog. Displaying progress of evaluation.
projectToolbar |  | Toolbar buttons for the most important menu items.
report | formWindow | Report solutions.
entry | formWindow | Entry puzzles.
aboutDialog |  | Introducing the program. See About dialog .
searchDlg | dialog | Editing search options .
output | dialog | Editing output options .
myDialogTricks |  | Typical dialog handling tricks for the project, like: - synchronization of list boxes , - display explanation of selected control in the status line.


Folders for Installation and Development
See also: Object model Installation

Folder | Collects
D:\Feri\Soap | Project folder
├───combinatorics | Source files of class combinatorics
├───Doc | Source documents of help
│ ├───images | Images of help
│ │ ├───Toolbars | Toolbar buttons
│ │ └───Zaszlok | Flags
│ ├───soap_tmphhp | Temporary folder for help compilation
│ │ └───SOAP | Temporary folder for help compilation
│ ├───soap_tmphpj | Temporary folder for help compilation
│ ├───soap_tmphtm | Temporary folder for help compilation
│ └───SOAP_tmprtf | Temporary folder for help compilation
├───equation | Source files of class equation
│ ├───products | Source files of class products
│ └───solver | Source files of class solver
├─── Exe | Executable programs, DLL-s and help files to be i nstalled elsewhere
├───Help | Source files of class myhelp
├───myDialogTricks | Source files of class myDialogTricks
├───Obj | Folder used during complation of the Visual Prolog source files
├─── Output | Source files of class output
├───Problems | Collection of alphametic puzzles
├───References | References on the Internet
│ ├───alphametic puzzle generator_elemei | Parts belonging to a referenced webpage
│ ├───alphametics more_elemei | Parts belonging to a referenced webpage
│ └───Криптарифмы - Журнал 'Компьютерра'_elemei | Parts belonging to a referenced webpage
│ ├───ads_data | Parts belonging to a referenced webpage
│ ├───erle_data | Parts belonging to a referenced webpage
│ ├───erle_data_002 | Parts belonging to a referenced webpage
│ └───erle_data_003 | Parts belonging to a referenced webpage
├───Results | Result files
├───SearchDlg | Source files of class searchdlg
├───TaskWindow | Source files of class taskwindow
│ └───Toolbars | Source files of class toolbars
└───Utility | Collection of source code of utilities
├───mylist | Source files of class mylist
├───mymath | Source files of class mymath
└───mystring | Source files of class mystring

Color code:
Recommended for installation but may be initially empty.
Required for installation with all files in.

D:\Feri\SOAP\Exe>
File | Role
hm.css | Style page for on-line help
soap.chm | On-line help
SOAP.exe | Executable program
vip7edit.dll | Dll-s required for exacutable Visual Prolog 7.2 programs
vip7kernel.dll
vip7regexp2.dll
vip7run.dll
vip7vpi.dll


Acknowledgements
The author thanks for the assistance of the Visual Prolog support team especially to Anatoly Asparuhov and Thomas Linder Puls who answered his questions on the Visual Prolog discussion forum .


Solver of Alphametic Puzzles

The Acronym SOAP stands for S olver O f A lphametic P uzzles.


Solver of Alphametic Puzzles

The Common Dialogs are the standard dialogs provided by the operation system by which the user can


Solver of Alphametic Puzzles

The condensed text of the puzzles consists of the essential characters of their raw text remained after deletion ignored characters like spaces, tabs, underscores and newlines from the raw text of the equation, and changing text to uppercase.
See also: Format of Input Files and Restrictions .


.topic 646
The Common Dialogs are the standard dialogs provided by the operation system by which the user can

.topic 436
Modal dialogs are those dialogs which must be closed by [OK] or [Cancel] buttons in order to let the program go on. Opposite of modeless dialog.

.topic 446
Modeless dialogs are those dialogs which may be left opened without closing by [OK] or [Cancel] buttons in order to let the program go on. Opposite of modal dialog. Its special cases are the forms.

.topic 456
Forms are modeless dialogs that is they be left opened without closing by [OK] or [Cancel] buttons in order to let the program go on. They can be arranged within the Task Window of the program together with the "Messages" window using the Windows submenu.

.topic 466
The task window is the parent window of all other windows displayed by the program.

.topic 546
Tabular information in the Report form are handled by Synchronized List Boxes whose selected items change together. The information of some columns may be truncated due to the fixed column with. Double click on the selected item in order to see in in the Status line which is wider than the list box.

.topic 556
The Track of Solutions
consists of the denomination of the rules applied during the fit,
count of their trials,
count of their matches.
These data are shown in the solution files and in the "Messages" window
as formatted data lines  and as synchronized list boxes of the report form,
respectively.
The report does not contains the intermediate partial fits shown in Examples of Contents "Messages" Files and
Examples of Solution Files.

.topic 586
The condensed text of the puzzles consists of the essential characters of their raw text remained after deletion ignored characters like spaces, tabs, underscores and newlines from the raw text of the equation, and changing text to uppercase.
See also: Format of Input Files and Restrictions.

.topic 5050
The Acronym SOAP stands for Solver Of Alphametic Puzzles.


Solver of Alphametic Puzzles

Forms are modeless dialogs that is they be left opened without closing by [OK] or [Cancel] buttons in order to let the program go on. They can be arranged within the Task Window of the program together with the "Messages" window using the Windows submenu .


Solver of Alphametic Puzzles

Modal dialogs are those dialogs which must be closed by [OK] or [Cancel] buttons in order to let the program go on. Opposite of modeless dialog .


Solver of Alphametic Puzzles

Modeless dialogs are those dialogs which may be left opened without closing by [OK] or [Cancel] buttons in order to let the program go on. Opposite of modal dialog . Its special cases are the forms .


Solver of Alphametic Puzzles

Tabular information in the Report form are handled by Synchronized List Boxes whose selected items change together. The information of some columns may be truncated due to the fixed column with. Double click on the selected item in order to see in in the Status line which is wider than the list box.


Solver of Alphametic Puzzles

The task window is the parent window of all other windows displayed by the program.


Solver of Alphametic Puzzles

The Track of Solutions
¨ consists of the denomination of the rules applied during the fit,
¨ count of their trials,
¨ count of their matches.
These data are shown in the solution files and in the "Messages" window
as formatted data lines and as synchronized list boxes of the report form ,
respectively.
Ø The report does not contains the intermediate partial fits shown in Examples of Contents "Messages" Files and
Ø Examples of Solution Files .