Building QCA (Qt cryptographic architecture) library on Ubuntu 13.10 with Qt5 

I have tried to build the QCA library from the KDE git repository (git clone git://anongit.kde.org/qca.git) with Qt5. (The Ubuntu 13.10 distribution ships only QCA built with Qt4 in the repositories).

The cmake failed with:

CMake Error in CMakeLists.txt:
Imported target "Qt5::Core" includes non-existent path

"/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64"

in its INTERFACE_INCLUDE_DIRECTORIES. Possible reasons include:

* The path was deleted, renamed, or moved to another location.

* An install or uninstall procedure did not complete successfully.

* The installation package was faulty and references files it does not
provide.


The solution was creating a symlink from the mkspecs:

sudo ln -s /usr/share/qt5/mkspecs/ /usr/lib/x86_64-linux-gnu/qt5/

[ hozzászólás ] ( 23 megtekintés ) [ 0 trackbackek ] permalink ( 3 / 178 )

<< <Előző | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | Következő> >>

 
számláló